HC

HC
Versions-Informationen

HC

HC

  • Versions-Informationen
  • Überblick
  • Kommunikation
  • Arithmetik
  • Daten-Struktur Grundwörter
  • Bedingte Ausführung
  • Schleifen
  • Variablen-Definition
  • Prozedur-Definition
  • Kontroll-Strukturen
  • Vorlagen-basierte Iteration
  • Arbeitsbereiche
  • Makros
  • Grafiken
  • GUI Programmierung
  • Geräusche

Versions-Informationen


HC / Versions-Informationen

Versions-Informationen

HC [image] Versions-Informationen
HC Versions-Informationen für Version 4.7

Versions-Informationen

Wenn Sie neu bei aUCBLogo sind und Probleme auftreten, versuchen Sie bitte, die Versions-Informationen und die Fehler-Liste zu lesen, der Abschnitt "Tokenisierung" kann auch hilfreich sein. Falls Sie einen Fehler in der Hilfe entdecken, teilen Sie mir das bitte mit, am besten einschließlich einer Korrektur. Sagen Sie mir bitte auch Fehler, die nicht im Fehlerverzeichnis aufgelistet sind. Das wäre sehr hilfreich für die Entwicklung, weil Stabilität und Korrektheit sehr wichtig sind.

Versions-Informationen

  • Versions-Informationen für Version 4.7
  • Release Notes für Version 4.69
  • Release Notes für Version 4.689
  • Release Notes für Version 4.688
  • Release Notes für Version 4.687
  • Release Notes für Version 4.686
  • Release Notes für Version 4.685
  • Release Notes für Version 4.683
  • Release Notes für Version 4.682
  • Release Notes für Version 4.68
  • Release Notes für Version 4.672
  • Release Notes für Version 4.67
  • Release Notes für Version 4.66
  • Release Notes für Version 4.65
  • buglist für Version 4.65
  • Release Notes für Version 4.64
  • Berkeley Logo-Anwenderdokumentation


HC / Versions-Informationen / Versions-Informationen für Version 4.7

Versions-Informationen für Version 4.7

HC [image] Versions-Informationen [image] Versions-Informationen für Version 4.7
Versions-Informationen Release Notes für Version 4.69

Versions-Informationen für Version 4.7

Dies ist eine große Version, für Windows und Linux. Viel wurde getan seit der letzten Ausgabe. Ich weiß, diese Versionsinfos sind ein bißchen lang dieses Mal, Entschuldigung.

Die meiste Arbeit wurde in die parallele Ausführung gesteckt. Davon abhängige Bereiche waren die Notwendigkeit einer neuen Variablen-Stapel-Strategie, verwendet wird jetzt Tiefe Bindung statt der Flachen Bindung.

Zusätzlich wurde Obejekt-Orientierung eingebaut; dazu war es nötig, ein neues System für den Gültigkeitsbereich von Variablen einzuführen: den lexikalischen Gültigkeitsbereich. Dabei wurden in einem ersten Schritt geschachtelte Prozeduren möglich, dann wurde der neue Knotentyp LogoObject erfunden, der der Basistyp aller Objekte in aUCBLogo-4.7 ist, und damit Methodenaufrufe möglich machte, die ein "Dies"-Objekt verwenden.

Die parallele Ausführung WAR ziemlich problematisch bezüglich des Müllsammlers und der Existenz der vielen globalen und statischen Variablen im Quellcode, und IST immer noch problematisch in bezug auf das C Stapel-Prüfens in der Linux-Version.

Die neuen Fehlersuche-Möglichkeiten beinhalten jetzt Rückwärts-Einzelschritt, was sehr nützlich sein kann bei der Fehlersuche in schwierigen Algorithmen. aUCBLogo ist eine der wenigen Programmiersprachen, die Rückwärts-Einzelschritt unterstützen. Um es zu aktivieren, setzen Sie einen von Null verschiedenen Wert in Editor / Ausführen / Setze Ringpuffer-Größe.

Eine andere neue Möglichkeit ist der Autoload-Modus. Nach seiner Aktivierung durch einen Klick im Editor-Menü / Ausführen / Lade Datei automatisch in den Arbeitspeicher und wenn Sie eine Datei im Editor geöffnet haben und Ausführen oder F9 gedrückt haben, dann können Sie das laufende Programm editieren. Das kann viel Spaß machen und kann wie ein interaktives Tabellenkalkulationsprogramm wirken.

Auch wurden Versuche unternommen, einen Formel-Editor zu schreiben, die Sie in den verschiedenen Versionen von formulatest.lg anschauen können.

Einige Arbeit wurde auch in die Internationalisierung der Benutzer-Oberfläche gesteckt, einschließlich der meisten hart-codierten Texte sowie der Logo-Sprache, die jetzt in andere Sprachem übersetzt werden kann. Die einzige Sprache, in die bisjetzt übersetzt wurde, ist zur Zeit Deutsch, aber die Übersetzung der Benutzeroberfläche und Logo-Sprache sind Benutzerdefinierbar, jeder kann sie leicht anpassen.

Ein neuer Sandkasten-artiger Sicherer Ausführungs-Modus wurde eingeführt mit dem neuen Grundwort führeSicherAus, das besonders gebraucht wird, wenn man aUCBLogo als Webserver laufenläßt. CGI Skripting, sowie aUCBLogo als Service laufenzulassen, ist nun möglich. So können Sie jetzt komplette Web-Anwendungen in Logo schreiben. Nur Datenbank-Zugriffe werden noch nicht unterstützt. Diese werden aber wahrscheinlich in einer der nächsten Versionen eingebaut.

Beim Versuch, eine sichere Sprache sogar in Umgebungen mit begrenzten Speicher anzubieten, war es möglich, die meisten "Speicher aus"-Abstürze in Fehlermeldungen umzuwandeln.

Dieselben Sicherheits-Gründe führten zu Untersuchungen über ringförmige Datenstrukturen, die jetzt nicht mehr zu unendlichen Schleifen innerhalb des Interpreters führen sollten.

Ein -nogui Kommandozeilen-Schalter wurde eingeführt, um es zu erlauben, quasi-eigenständige Anwendungen in Logo zu schreiben. Beispiele können Sie in der Windows-Version von aUCBLogo-4.7 sehen; dort gibt es im aucblogo-Verzeichnis ein paar symbolische Verknüpfungen: am2, landscape4, etc.

Andere Igel-Formen werden nun unterstützt. Es gibt allerdings noch Probleme mit dreidimensionalen Igel-Formen, aber die zweidimensionalen sollten schon gut funktionieren.

Das Vars Debug-Fenster wurde erweitert um den Anforderungen der Objekt-Orientierung gerecht zu werden, indem nun die Variablen in einer Baum-Struktur dargestellt werden. Man kann jetzt sogar Prozedur-Definitionen in diesem Fenster anschauen.

Der neue lexikale Geltungsbreich von Variablen kann nun verwendet werden, wenn Sie die spezielle Form "be" anstatt "to" zur Prozedur-Definition hernehmen. be's können geschachtelt werden, so daß komplizierte Programme in baumartige kleinere Abschnitte zerlegt werden können, was die Entwicklung "Von-Oben-Nach-Unten" erleichtert.

Um ein Objekt zu erstellen, verwenden Sie eine mit "be" definierte Prozedur, die nichts explizit ausgeben sollte, aber lokale Variablen besitzt, und weisen den Aufruf dieser Prozedur einer Variablen zu. Das ist ziemlich ähnlich wie in Elica. Der einzige Nachteil der momentanen Implementation in aUCBLogo-4.7 ist, daß man runde Klammern um jeden Methoden-Aufruf mit einem oder mehr Argument schreiben muß. Ein Methoden-Aufruf wird genau wie Nachschlagen in einer Tabelle durchgeführt, unter Benutzung des Punkt . oder des einfachen Anführungszeichens '. Ein Aufruf mit Punkt ist praktisch für dynamische Aufrufe, wo der Methodenname in einer Variablen oder das Ergebnis einer Funktion ist. Verwendet man das einfache Anführungszeichen ', so ist das wie der Punkt in C++ oder Java; es wird intern tatsächlich umgewandelt in Punkt-Anführungszeichen.

Es ist jetzt möglich, sämtliche Grundwörter der neuen Klasse "Fenster" mit jeglichem Control oder Rahmen zu verwenden, was ermöglicht, so ziemlich jede Eigenschaft des angesprochenen wxWidgets einzustellen. Dies wurde erreicht durch Erfinden einer Art virtueller Mehrfach-Vererbung, unter Zuhilfenahme einer virtuellen Funktion innerhalb wxWindow, wxWindow::d, die auf einen Zeiger auf eine Reihe von Knoten zugreift, den es in jeder abgeleiteten Klasse gibt.

Das Grundwort "parallelAusführen" wurde schon recht lange ausprobiert. Bei Diskussionen mit Pavel Boytchev wurde klar, daß es eine schnellere Lösung geben muß, die keinen so großen Synchronisations-Overhead hat, wie ein normaler Thread braucht, wenn er vom Betriebssystem verwaltet wird. Die vorläufige Lösung ist das neue Grundwort "Fiber", das momentan nur unter Windows implementiert ist: hier werden die Thread-Wechsel von Logo selbst durchgeführt, so daß es nahezu keinen Synchroniations-Overhead gibt.

Mit der Tastenkombination Strg+rauf wird eine Liste der bereits einmal in die Konsole eingetippten Befehle angeboten. Diese Liste wird beim Verlassen von Logo gespeichert. Wenn Sie die Liste löschen wollen, löschen Sie einfach die Datei Benutzername-aUCBLogo.history (ersetzen Sie Benutzername durch den Namen unter dem Sie sich im Betriebssystem eingeloggt haben). Diese Funktionalität kann oft wegen der Tippersparnis nützlich sein, besonders wenn die aufgerufenen Logo-Routinen viel Text in die Konsole schreiben, Sie aber eigentlich zurück nach oben gehen möchten und etwas nocheinmal ausführen möchten.

Es gibt jetzt eine Version von aUCBLogo als DLL, aucblogo.dll, die Sie verwenden können, um aUCBLogo bequem zu erweitern, ohne das ganze aUCBLogo selbst kompilieren zu müssen, sondern nur Ihre eigenen Erweiterungen, danach verknüpfen Sie Ihr Programm einfach mit der aucblogo.dll. So können Sie neue Grundwörter in C++ schreiben für zeitkritische routinene, die im interpretierten Logo zu langsam wären.

Ferner wurden viele neue Grundwörter geschrieben und manche erweitert, siehe die Liste unten.

Folgendes war meine TODO-Liste bis jetzt:

10)	Vars Fenster als TreeCtrl v
20)	dies in Vars window v
30)	setze dies->bit.table_expand temporär auf wahr v
40)	ändere << in Push(&) v
50)	Calls Fenster ausbessern (schwer) v
60)	Vars & Calls & Graph rollback v
70)	reverse stepping (Shift-F7/8); Flags im Menü v
80)	setDebugRingbufferSize + Menü Eintrag v
90)	History (Ctrl-up) in Konsole v
100)	correct memory counting in führeSicherAus v
110)	aucblogo.dll v
120)	molecules.lg v
130)	ermögliche Haltepunkte wieder (schwer!) v
140)	und, oder mit Listen v
150)	Schatten nochmal v
160)	Speicher aus v
170)	untreeify v
180)	"to editing" soll alle Prozeduren im Editor enthalten v
        editiere laufende Programme v
190)	spezielle Variablen entfernen v
200)	Beispiel-Katalog v
210)	.exe Ort aktuatlisieren v
220)	setzeLogoSchriftenVerzeichnis v
230)	Internationalisierung v
240)	Fehler-Texte v
250)	Speichere Unter-Fehler v
260)	Suche: markiere Wort v
270)	ändere Fehlermarkierungs-Farbe v
280)	VieleckStart/End->Vieleck, Tesselation, Oberfläche, Grafik v
290)	unterstütze ringförmige Daten-Strukturen besser
        mit weniger Abstürzen v
300)	-nogui v
310)	Editor Drucken v
320)	entferne tabelle1 tabelle2
330)	Igel-Formen:
        XOr v
        3D
340)	Menü für Speicher-Fenster v
350)	Upgrade auf wxWidgets-2.8.3 v
360)	Fenster-Docking (wxAui) v
370)	Threads Fenster
380)	Window => Vererbung v

390)	viele bugs ausgebessert

400)	erzeuge rpm & Debian Paket
410)	Beispiele sollen laufen

420)	Hilfe aktualisieren zu:

AFONTS und aucblogo.dll
sei fülleBitmap klebeBitmapSchnell klebeBitmapAuf klebeBitmapAufSkaliert
CGI KammSort KammSortAufDerStelle Befehlszeile zähleThreads Zylinder
definiereSei rufeDLAuf  TextureFontAus
TextureFontAn erweitereBackslashes
Faser fülle formatiere
holeArchitekturName holeEndiannessName holeUmgebung getUmgebungsTabelle
holeBetriebsSystemFamilienName holeBetriebsSystemIdName
holeBesitzer holePortIdName holeProzessID holeThreadID holeBenutzer
beginneGraph Grafik verlasseGraph
versteckeLogoKonsolew versteckeLogoHauptfenster Historie
vererbe iSeqIA Elemente
beendeThread
ZeilenSpalte ZeilenTabSpalte ZeilenZeile ladeAnsicht ladeLokal
LogoKonstanten LogoSchriftenVerzeichnis LogoSprache
makeTree makeTreeFromBody mdFloatArray MausKnöpfe ParalleleAusführung
Namensraum Knoten Norm
Objekte oder orthographisch
Vieleck
liesListeFlach liesListeFlachZeile liesListeFlachRoh liesListeFlachMarken
liesRoheZeile erneuereGUI redefinierbar?
DateiUmbenennen renderLogoAsHTML renderLogoFileAsHTML
RückwärtsEinzelschritt führeSicherAus
speichereAnsicht Geltungsbereiche setzeUmgebung
setzeLöscheAllesBeiAusführen setzeErweitereBackslashes
setzeFüllToleranz setzeFocusBeiAusführen setzeFPUStatusFlags setzeGenSym
setzeLogoSchriftenVerzeichnis setzeLogoSprache setzeNamensraum
setzeStiftgröße setzePlayOnSwap setzePunktgroße setzeProcessIdleInterleaving
setzeRedefinierbar setzeSchirmBereich setzeStartup
setzeIgelFormen setzeBenutzer Shell zeigeLogoKonsoleW zeigeLogoHauptfenster
spezielleVariablen startup Oberfläche
Tabelle Tesselation dies Thread ThreadJoinable
Threads zuGanzzahl IgelFormen
yield
wxWindowFunctionen WWW-Server


HC / Versions-Informationen / Release Notes für Version 4.69

Release Notes für Version 4.69

HC [image] Versions-Informationen [image] Release Notes für Version 4.69
Versions-Informationen für Version 4.7 Release Notes für Version 4.689

Release Notes für Version 4.69

das ich eine Farbe zu tsh Funktion, ListeTSH und ListeTSHA, schrieb um beim Sortieren der Farbdatenbank von Farbstich zu ermöglichen. Die Farbdatenbank kann jetzt mit getcolordatabase geholt werden. Ich stelle die meisten Arbeit in Schattenwürfel-zeit: Oberflächen, Polygone, tesselated Polygone und EllipsoidenTeil jetzt können Schatten produzieren, wenn Sie aufrufen schattenan vor ihrem Verwendungs-und das primitive wirfschatten einfach vor updategraph. Die Schatteninformation bleibt beharrliches bis, das Sie löscheschatten nennen, so Sie können leicht zeichnenochmal die Lochszene von einem unterschiedlichen Aussichtsturm mit d. h. rotatescene, weil zeichnenochmal automatisch aufruft wirfSchatten, werden wenn Schatten ermöglicht. Die Farbe der Schatten kann mit mit shadowcolor in Frage gestelltem setzeSchattenfarbe und gesetzt werden.

Versions-Informationen für Version 4.7 Release Notes für Version 4.689


HC / Versions-Informationen / Release Notes für Version 4.689

Release Notes für Version 4.689

HC [image] Versions-Informationen [image] Release Notes für Version 4.689
Release Notes für Version 4.69 Release Notes für Version 4.688

Release Notes für Version 4.689

Für mein neues IFS3D.lg, das ich setzepunktxyz und brauchte, einige Nebel-grundwörter:

nebelan nebelaus="" setzenebeldichte="" setzenebelbereich="" setzenebelfarbe="" setzenebelmodus=

Ich wollte die basierte Vorlage Iterationswerkzeuge mit Reihen benutzen können, so habe ich einige reihe Möglichkeiten hinzugefügt zu:

erstes ohneerstes="" letztes="" ohneletztes="" alleerste="" ohneerste="" vornhin="" hängean="" verbinde=

logoversion gibt jetzt auch Details über die Betriebssystemversion aus.

Um die Schirmgröße zu bekommen, schrieb ich das primitive osscreensize.

Ich habe einige layouting grundwörter= für den knoten tippe fenster= hinzugefügt:

fenstergroß fensterklein="" fenstervollbild=

Um die Stapel in Gleitpunktbetriebsart zu setzen (damit man Fehler behebt), können Sie jetzt das neue primitive setstacknoisy rufen. Standardmäßig sind die Stapel nicht rauschbehaftet jetzt. Rauschbehaftetes Mittel sie schreib ihre Größe wenn sie oder anpflanzen Klapsdoktor.

Release Notes für Version 4.69 Release Notes für Version 4.688


HC / Versions-Informationen / Release Notes für Version 4.688

Release Notes für Version 4.688

HC [image] Versions-Informationen [image] Release Notes für Version 4.688
Release Notes für Version 4.689 Release Notes für Version 4.687

Release Notes für Version 4.688

von ken kahns= extrapolate11.lg Inspiriert, das ich einem ifs morphing= Programm ifsmorph.lg. schrieb Dafür brauchte ich ein schnelles mische Primitiv-und verbinde= für Gebrauch mit reihe Typen, so schrieb ich sie.

Release Notes für Version 4.689 Release Notes für Version 4.687


HC / Versions-Informationen / Release Notes für Version 4.687

Release Notes für Version 4.687

HC [image] Versions-Informationen [image] Release Notes für Version 4.687
Release Notes für Version 4.688 Release Notes für Version 4.686

Release Notes für Version 4.687

in dem Die knoten Ausdauer jetzt nochmals funktioniert, Würfelversion. Nur simstring3.lg ist ein bisschen in addtion dazu verändert worden, so diese Release Notes sehr kurz bleiben.

Release Notes für Version 4.688 Release Notes für Version 4.686


HC / Versions-Informationen / Release Notes für Version 4.686

Release Notes für Version 4.686

HC [image] Versions-Informationen [image] Release Notes für Version 4.686
Release Notes für Version 4.687 Release Notes für Version 4.685

Release Notes für Version 4.686

das Dies hauptsächlich ist, eine bugfix Veröffentlichung. Die knoten Ausdauer wird in Würfelversion gebrochen, weil ich dynamische Stapel einführte, den und anpflanzen können auf Verlangen schrumpfen, und, das jenes nicht ist aber in dem völlig Fehler behoben. Ich habe geschrieben, dass ein mandelbrot Zoom Programm, mandel5.lg. setzte Das neue ifs2.lg ist jetzt viel schneller, wie die mandel Programme wegen neuer reihe Operationen sind. Eine einfache Simulation einer flatternden Flag, die ich schrieb, ist flappingflag.lg. Ich schrieb eine epiano Simulation mit berechnetem Wellen-dateien, bei der Benutzung von echos und="" lowpassfilters=. Auch eine schöne neue Demo ist eine Schnursimulation simstring3.lg, die eine .wav Dateiausgabe schaffen kann. Und ich spielte ein bisschen mit neuem stiftfarbe Sprecher-und midi= Sound-grundwörter herum, da sie leichter zu benutzen sind, als jeden Sound für spieleWave in Logo zu berechnen (der komplexe Simulationen für d. h. Trommeln betrifft). Ich schrieb einem Auto Rennsimulationsspiel, carrace.lg (aber ohne Autos). Ich habe auch ein paar Spiele zu aUCBLogo portiert: Schlange. lg, Schlangen. lg und="" pacman.lg= von david costanzo=, und juniper9.lg (Wacholder-Grün) von david peacock=.

Ich habe auch ein paar neue reihe Operationen eingeschlossen. Am wichtigsten von ihnen ist "Element" mit einem Liste Register, das als ein Anfragen-tabelle benutzt werden kann (sehen Sie ifs2.lg!).

Etwas neuer syntaktischer Zucker sind die neuen setzeelement Operatoren: a.x=b und="" a.x.y="b]", ein muss sein etwas Elemente, und x und, das y Ausdrücke sein können (ohne whitespace, noch zu tun), zum Beispiel a.(i-2).(j+k)=b habend.

Ein paar neues verändertes oder grundwörter auch werden eingeschlossen:

zählemidigeräte midigeräteinfo="" öffnemidi="" schließemidi="" midimeldung="" wechslemidiprogramm="" midinotean="" midinoteaus="" midiallegeräuscheaus="" midiausgabestrom="" startemidiausgabestrom="" stoppemidiausgabestrom="" beendeteMidiAusgabeströme=

Ton Töne stoppeTöne beendeteTöne

Sound Sounds soundsstop soundsfinished=

textschriftart textschriftgröße="" textschriftdicke="" textausrichtung=

setzepunkt setzepunktxy=

addierefarbenrest

mandeliterate

kodiereschrägstrich

aktivierekonsole

tiefpaßfilter sättigeoberhalb="" sättigeunterhalb=

tiefekopie

Element setzemdelement

verkleinerestapel

Sie können mich immer um wenn bitten, bei dem Sie Probleme erleben, aUCBLogo!

andreas micheler=

Release Notes für Version 4.687 Release Notes für Version 4.685


HC / Versions-Informationen / Release Notes für Version 4.685

Release Notes für Version 4.685

HC [image] Versions-Informationen [image] Release Notes für Version 4.685
Release Notes für Version 4.686 Release

Release Notes für Version 4.685

Bei der Versuchung zu gebaut mehr persistenz in aUCBLogo, das Konsol-Fenster Text= können jetzt automatisch in der datei gespeichert werden BENUTZER-aUCBLogo tröste, BENUTZER wird namens der gegenwärtig eingeloggte Computerbenutzer ersetzt. Es gibt ein Überprüfungselement in der menü, mit der Sie Selbstladungs-und -speichere des Konsoltextes sperren können. Der gleiche Selbstballabwehrmechanismus wird jetzt für die Bilddaten zur Verfügung gestellt, und ladegraph="" und="" speicheregraph= jetzt arbeiten (Ich hoffe) richtig. Zusätzlich hielt ich von Bild Daten-und Besserentstören das neue grundwörter ladegraphtext="" und="" speicheregraphtext=, um leichtes exportierendes importierendes und zu ermöglichen.

Schließlich erreichte ich persistenz allen Logo-knoten, so Sie können führeaus ein aUCBLogo Programm, schließe aucblogo=, etwas sonst ausführen, starten nochmals aUCBLogo und Ihren letztes Staat wiedergewinnen. Der letztes Staat kann oder in Mitte eines Testablaufs laufen lassen. Dieser beharrliche Modus kann natürlich durch das Unüberprüfen von "autosave knoten=" in der datei Speisekarte gesperrt werden, den sehr gewollt werden können wenn, das es viele mit dem gleichen Benutzernamen eingeloggte Benutzer gibt.

Druck funktioniert jetzt.

Unterstützung für willkürliche die mapm Bibliothek benutzende Präzisionsmathematik ist hinzugefügt worden:

großezahl großezahlsetzgenauigkeit

Das grundwörter zeit="" und="" dateizeit= jetzt das gleiche Ausgabeformat-und haben, das die milliseconds sind, ein zusätzliches Mitglied.

Das Prädikat dateip / datei? ist jetzt pro primitve.

Das neue Primitiv dateien gibt das dateien des gegenwärtigen Arbeitsdateiverzeichnisses aus.

Das Folgenden-grundwörter sind dafür, mit Verzeichnissen zu funktionieren:

verzeichnisp liesarbeitsverzeichnis="" neuesverzeichnis=

Die Konstrukteure reihe, ganzzahlen, 16bitzahlen und="" reellezahlen= expandiert worden sein um einen Kopienkonstrukteur einzuschließen, so können sich solche Daten leicht verdoppeln.

Das grundwörter savescreenbmp="" und="" savebmp= gestrichen worden sein, weil es jetzt speichereschirm gibt, das den Bildschirm in allen von wxwidgets gestützten Formaten speichern kann.

Zusätzlich gibt es jetzt speichereschirmvektoriell, das die GL2PS-Bibliothek verbraucht, um verschiedene Vektorgraphikformate zu erzeugen.

bitmapgrößex und="" bitmapgrößey= sind neue primitves, das maximale zu bekommen, erlaubten Koordinaten einer von bitmapkopieren oder= erhaltenen Bitmap eine datei.

Das shininess eines 3 d kann gefüllte formatiereZahl gesetzt werden jetzt mit setmaterialshininess.

Zu dem kugel Primitiv ist expandiert worden optional zuzunehmen Scheiben-und schichtet parameter, was mehr Kontrolle über die Zeichnungsfinesse gibt.

Das grundwörter und="" lieszeichenerweitert= mich zu nicht, ein wort ausgegeben mit Länge 1 (ein zeichen) aber um einen ganzzahl auszugeben, weil die wxwidgets keycode= Konstanten im Abschnitt über tastenwert hinzugefügt worden sind, geändert worden sein, das alles hat, Zahlen >= 300, und, das zu ist, groß einzufügen ein verkohlen.

Es ist jetzt möglich zu unterbrich oder="" weiter= Schleifen durch die Benutzung der unterbrich oder="" weitermitschleife= Erklärungen.

Das schöne Primitiv spieleWave2 ist für Verwendung in Spiele-und Musikprogrammen hinzugefügt worden. Es kann vielfaches Wellen-dateien simultanously= spielen.

Sie können jetzt ein Video für Windows schaffen (.avi) bei der Benutzung des neuen grundwörter videostart..videoframe..videoend= beantragen

Die Farb-Datenbank ist von anzahlen von zusätzlichem Farb-variablennamen erweitert worden, aber alles stillt einfach in Englisch.

Unter anderem neuen gui Programmier-grundwörter werden in Logo schriftliche Gewohnheits Tastatur-und Mausereignisführer jetzt unterstützt. Für die Konsole sind die folgenden Tastatur-und Mausführer:

beizeichen beigedrücktertaste="" beilosgelassenertaste="" tastenwert="" beiLinksGeklickterTextmaus="" beiRechtsGeklickterTextmaus="" beiMitteGeklickterTextmaus="" beitextmauslinkslosgelassen="" beitextmausrechtslosgelassen="" beitextmausmittelosgelassen="" beiLinksDoppeltGeklickterTextmaus="" beiRechtsDoppeltgeklickterTextmaus="" beiMitteDoppeltgeklickterTextmaus="" beitextmausbewegung=

Für das Hauptdiagramm sind Fenster jene Mausführer:

beiLinksGeklickterMaus beiRechtsGeklickterMaus="" beiMitteGeklickterMaus="" beiLinksLosgelasserMaus="" beiRechtsLosgelasserMaus="" beiMitteLosgelasserMaus="" beiLinksDoppeltgeklickerMaus="" beiRechtsDoppeltgeklickerMaus="" beiMitteDoppeltgeklickerMaus="" beiMausBewegung=

Sie können jetzt das Maus-einfügemarke zu "beschäftigt" oder Normal-und setzen wenn Maus fragen ist mit den folgenden befehlen beschäftigt:

beginneBeschäftigt beendebeschäftigt beschäftigt?

Die folgenden standardmäßigen Dialoge dafür, dem Benutzer Information abzugewinnen, sind jetzt verfügbar:

verzeichnisauswahl dateiauswahl="" holefarbevombenutzer="" holeschriftvombenutzer="" holeauswahlmöglichkeiten="" holezahlvombenutzer="" holepasswortvombenutzer="" holetextvombenutzer="" holeauswahl="" holeauswahlzahl="" meldungsbox=

Für Reinigung von textur Speicher, das es jetzt löschetexturen gibt, das ein textur Gedächtnisüberlauf so verhindert werden kann, wenn, das Sie viele Texturen schaffen, die Sie vielleicht nur einmal benutzen.

Wenn Sie dann Diagramm-Fenster mit einer definierten formatiereZahl benutzen könnte setzeschirmbereich nützlich sein um der vorgabe zu entkommen [800,600] logische Bildelemente.

setzepunkt kann jetzt auch 3 d coordiantes als Argumente nehmen.

Für leichteres den neuen befehl ausheckendes schnelleres und ist setzepunktxy geschrieben worden: Es nimmt an, dass strukturiertes x Daten-und ebenso y Daten als gesonderte Argumente strukturierte.

Das dlcall Primitiv stützt jetzt Argument-nah-Zeiger wann "intptr, "Int16Ptr, "Int8Ptr, "UInt8Ptr oder "floatptr werden als Argumenttyp spezifiziert.

Damit man die Logo-Umgebung für spezielle Bedürfnisse anpasst, beantragen Sie und dir Pfade, den wichtigsten kann verändertes und jetzt gelesen werden:

logocomspec setzelogocomspec="" logoeditor="" setzelogoeditor="" logohilfeverzeichnis="" setzelogohilfeverzeichnis="" logobibliotheksverzeichnis="" setzelogobibliotheksverzeichnis="" logotemporäresverzeichnis="" setzelogotemporäresverzeichnis=

Windows (den Konstrukteur fenster benutzend), vielfache Diagramm-Fenster (das Konstrukteur-Diagramm benutzend) und viele Controls vom wxwidgets Rahmen sind jetzt eingeschlossen.

Neues grundwörter für Gebrauch mit fenster:

zerstörefenster beifensterzeichen beigedrücktertasteinfenster=beilosgelassenertasteinfenster aktiviereFenster FensterAn setzeInnereFenstergröße setzeFensterFarbe setzeFensterHintergundfarbe setzeFensterSchriftgröße setzeFensterSchriftname setzeFensterSchriftstil setzeFensterSchriftdicke settFensterform setzeFenstersizer]>

Neues grundwörter für Gebrauch mit Diagramm:

zerstöregraph graphcurrent="" aktivieregraph="" beigraphzeichen="" beigedrücktertasteingraph="" beilosgelassenertasteingraph="" graphonmouseleftdown="" beiRechtsGeklickterGraphMaus="" beiMitteGeklickterGraphMaus="" beigraphmauslinkslosgelassen="" beiLinksGeklickterGraphMaus="" beigraphmausmittelosgelassen="" beigraphmauslinksdoppelklick="" beigraphmausrechtsdoppelklick="" beigraphmausmittedoppelklick="" beigraphmausbewegung=

Der Haupt-Fenster Gestaltungsmechanismus von wxwidgets wird mit dem Konstrukteur Gestell und= das anwendbare grundwörter gestützt:

zumGestelldazu zerstöreGestell=

Seien Sie des befehls bewusst setzefenstersizer: es ermöglicht ein sizer auf einem Rahmen.

Die neuen Controls sind (hier den Konstrukteuren alphabetisch folgen, die detaillierte Auflistung von grundwörter folgt):

knopf ankreuzbox="" auswahlbox= kombibox zahlbox="" balken="" ganzzahlbox="" listenbox="" listcontrol="" radioknopf="" schieberegler="" statischertext="" textcontrol="" schaltknopf=

Neues grundwörter für Gebrauch mit knopf:

zerstöreknopfbeiknopfdruckknopfan

Neues grundwörter für Gebrauch mit ankreuzbox:

zerstöreankreuzbox beiGeklickterAnkreuzbox="" ankreuzboxwert="" setzeankreuzbox="" ankreuzboxan=

Neues grundwörter für Gebrauch mit auswahlbox:

zerstöreauswahlbox auswahlboxauswahl="" setzeauswahlboxauswahl="" setzeauswahlboxmöglichkeiten="" zurauswahlboxdazu="" setzeauswahlboxelement="" entferneauswahlboxelement="" zähleauswahlbox="" setzeauswahlboxhintergrundfarbe="" setzeauswahlboxfarbe="" setzeauswahlboxschriftgröße="" setzeauswahlboxschriftname="" setzeauswahlboxschriftstil="" setzeauswahlboxschriftdicke="" beizeicheninauswahlbox="" beigedrücktertasteinauswahlbox="" beilosgelassenertasteinauswahlbox="" beiauswahlboxauswahl="" auswahlboxan=

Neues grundwörter für Gebrauch mit kombibox:

zerstörekombibox kombiboxauswahl="" setzekombiboxauswahl="" setzekombiboxmöglichkeiten="" zurkombiboxdazu="" setzekombiboxelement="" entfernekombiboxelement="" zählekombibox="" kombiboxwert="" setzekombiboxwert="" setzekombiboxhintergrundfarbe="" setzekombiboxfarbe="" setzekombiboxschriftgröße="" setzekombiboxschriftname="" setzekombiboxschriftstil="" setzekombiboxschriftdicke="" beikombiboxzeichen="" beigedrücktertasteinkombibox="" beilosgelassenertasteinkombibox="" beikombiboxauswahl="" beikombiboxÄnderung="" beikombiboxeingabe="" kombiboxan=

Neues grundwörter für Gebrauch mit zahlbox:

floatcontroldestroy zahlboxwert="" setzereellezahlboxwert="" setzereellezahlboxbereich="" beiÄnderunginreellerzahlbox="" zahlboxan=

Neues grundwörter für Gebrauch mit balken:

zerstörebalken balkenwert="" setzebalkenwert="" setzebalkenbereich="" setzebalkenfarbe="" setzebalkenhintergrundfarbe=

Neues grundwörter für Gebrauch mit ganzzahlbox:

zerstöreganzzahlbox ganzzahlboxwert="" setzeganzzahlboxwert="" setzeganzzahlboxbereich="" beiganzzahlboxÄnderung="" ganzzahlboxan=

Neues grundwörter für Gebrauch mit listenbox:

zerstörelistenbox listenboxauswahl="" setzelistenboxauswahl="" setzelistenboxmöglichkeiten="" hängeanlistenbox="" setzelistenboxelement="" entfernelistenboxelement="" zählelistenbox="" setzelistenboxhintergrundfarbe="" setzelistenboxfarbe="" setzelistenboxschriftgröße="" setzelistenboxschriftname="" setzelistenboxschriftstil="" setzelistenboxschriftdicke="" beilistenboxzeichen="" beigedrücktertasteinlistenbox="" beilosgelassenertasteinlistenbox="" beilistenboxauswahl="" beiDoppeltgeklickterListenbox="" listenboxan=

Neues grundwörter für Gebrauch mit listcontrol:

zerstörelistencontrol fügespalteinlistencontrolein="" fügeelementinlistencontrolein="" setzelistencontrolelement="" holelistencontrolelement="" entfernelistencontrolelement="" setzelistencontrolzeile="" setzelistencontrolspalte="" setzelistencontrol="" holelistencontrolzeile="" holelistencontrolspalte="" holelistencontrolwert="" zählelistencontrolelemente="" listencontrolspaltenanzahl="" listencontrolspalte="" listencontrolzeile="" listencontroltext="" sortierelistencontrol="" setzelistencontrolhintergrundfarbe="" setzelistencontrolfarbe="" setzelistencontrolschriftgröße="" setzelistencontrolschriftname="" setzelistencontrolschriftstil="" setzelistencontrolschriftdicke="" beizeicheninlistencontrol="" beigedrücktertasteinlistencontrol="" beilosgelassenertasteinlistencontrol="" beiausgewähltemlistencontrolelement="" beiaktiviertemlistencontrolelement="" beiGeklickterListencontrolSpalte="" listencontrolan=

Neues grundwörter für Gebrauch mit radioknopf:

zerstöreradioknopf beiGeklicktemRadioKnopf="" radioknopfwert="" setzeradioknopf="" radioknopfan=

Neues grundwörter für Gebrauch mit schieberegler:

zerstöreschieberegler schiebereglerwertsetzeschiebereglerwertsetzeschiebereglerbereichbeischiebereglerverschiebung SchiebereglerAn]>

Neues grundwörter für Gebrauch mit statischertext:

zerstörestatischentext statischertextinhalt="" setzestatischentext="" setzestatischertexthintergrundfarbe="" setzestatischertextfarbe="" setzestatischertextschriftgröße="" setzestatischertextschriftname="" setzestatischertextschriftstil="" setzestatischertextschriftdicke=

Neues grundwörter für Gebrauch mit textcontrol:

zerstöretextbox textboxinhalt="" setzetextboxinhalt="" schreibeInTextbox="" zutextboxdazu="" setzetextboxeinfügepunktansende="" textboxcursor="" setzetextboxcursor="" textboxeinfügemodus="" textboxÜberschreibmodus="" setzetextboxhintergrundfarbe="" setzetextboxfarbe="" setzetextboxschriftgröße="" setzetextboxschriftname="" setzetextboxschriftstil="" setzetextboxschriftdicke= beitextboxzeichen beigedrücktertasteintextbox=beilosgelassenertasteintextbox beiTextboxÄnderung beiTextboxEingabe TextboxAn]>

Neues grundwörter für Gebrauch mit schaltknopf:

zerstöreschaltknopf beiGeklicktemSchaltknopf="" setzeschaltknopfzustand="" schaltknopfzustand="" schaltknopfan=

Und für das Entstören des Müll-Kollektors (und für meine Vergnügung) schrieb ich einem Speicher-Fenster, accessable durch die Ansichtenmenü, eins jeden knoten untersuchen kann, mit der Maus darauf hinzuweisen: ein tooltip Fenster= mit einer wörtlichen darstellung jenes knotens wirst zeige rauf= dann. Es ist ziemlich interessant, die müllsammeln Arbeit zu sehen!

Sie können mich immer um wenn bitten, bei dem Sie Probleme erleben, aUCBLogo!

Andreas Micheler

Release Notes für Version 4.685

  • Release


HC / Versions-Informationen / Release Notes für Version 4.685 / Release

Release

HC [image] Versions-Informationen [image] Release Notes für Version 4.685 [image] Release
Release Notes für Version 4.685 Release Notes für Version 4.683

Release Notes für Version 4.684 ------------------------------- das Diese Release hauptsächlich ist weil ich die aUCBLogo Linux-Version aktualisiert habe. Ich veränderte auch das "Pausen"-und "Halte"-Hot-Key von [trl-q] und [ctrl-p] zu [Pause] und [ctrl-pause]. Zusätzliches Hot-Key ist jetzt [F2]="wiederhole letztes befehlen" und [Ctrl-F2]="reset" (aufrufe "stellte zurück. lg", so ist es benutzerbestimmbar). Für die Anfänger gibt es jetzt ein Popup-Menu auf einem richtigen Mausklick, mit dem eins grundwörter einfügen kann, choosen von Kategorie wie in der Hilfe. Ich fügte das neue tippe reellezahlen= hinzu, um schnellere reihe Datenverarbeitung zu ermöglichen, die manchmal sehr gewollt wird, weil es fünfmal so fast ist wie mit konventionellen Reihen. Um das neue tippe zu stützen, schrieb ich auch reellezahlenfolge, abgekürztes reellezahlenfolge, welche Hirschkuh beinah das gleiche als zahlenfolge, aber mit einem reellezahlen ausgibt. Von Michael Malien inspiriert ich schrieb ein bisschen profiler (Profil. lg, mit Demos testprofile.lg, testprofile2.lg und testprofile3.lg). Um um wenn zu bitten, das ein bestimmter Charakter in einigen Teilmengen von Charakteren ist, fügte ich das neue Prädikate-alphanumerisch hinzu?, alphabetisch?, ASCII?, kontrollzeichen?, C_Zeichen?, ziffer?, Diagramm?, kleinbuchstabig?, druckbar?, interpunktion?, leerraum?, großbuchstabig?, und xdigit=?. Sie vermessen direkt zu dem c Funktionen mit ähnlichem variablennamen (isalpha etc.). Ich verbesserte bounce3.lg ein bisschen. Jetzt wird der Ball strukturiert und rotiert, je nach in welcher Richtung es fliegt. Für dies das neue grundwörter drehex=, drehey und="" drehez= geschrieben worden sein, und, um das Überschreiben von gezogener Grafik zu ermöglichen, die ich setzetiefentestfunktion, bei der Stützung des Wählens des opengl depthfunc= hinzufügte. Ich spielte auch mit hinzugefügtem explosion.lg und= die Demo 3drohre.lg herum, den modeled nach dem Bildschirmschoner "3" ist d Rohre". Um die Geschwindigkeit des neuen reellezahlen tippe= zu beweisen, entwickelte ich makewav5.lg und makewav6.lg. In makewav6.lg ist ein Echtzeitoszilloskop, während des Spielens der berechneten Welle gezeigt. Mikrofon Sandig mich inspiriert um nameintabelle einzuschließen? . Und ich habe ein paar sehr schlechte reihe Fehler in den einstoffigen und Binärmathematikfunktionen ausgebessert.

References:

    Release Notes für Version 4.68, Release Notes für Version 4.687, beiGraphMausLinksLosgelassen, beiGraphMausMitteLosgelassen, beiLinksGeklickterGraphMaus, beiLinksLosgelasserMaus, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInFenster, beiLosgelassenerTasteInKombiBox, beiLosgelassenerTasteInListenControl, beiLosgelassenerTasteInListenbox, beiLosgelassenerTasteInTextbox, beiMitteLosgelasserMaus, beiRechtsLosgelasserMaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen

Release Notes für Version 4.685 Release Notes für Version 4.683


HC / Versions-Informationen / Release Notes für Version 4.683

Release Notes für Version 4.683

HC [image] Versions-Informationen [image] Release Notes für Version 4.683
Release Release Notes für Version 4.682

Release Notes für Version 4.683

bitload & bitsave dass entfernt worden sind, weil es jetzt ladebild und="" speicherebild= gibt, was alle Dateiformate kennen, die wxwidgets kennt.

Die Strukturierung ist verbessert worden (sehen Sie throwcoin.lg, house2.lg und landscape4.lg!).

Neues und veränderte grundwörter sind:

dateizeit

bitmapsetzpunkt bitmappunkt=

textur

ladebild speicherebild

setzetexturxysetzetexturort

setzetesselationregeln

Release Release Notes für Version 4.682


HC / Versions-Informationen / Release Notes für Version 4.682

Release Notes für Version 4.682

HC [image] Versions-Informationen [image] Release Notes für Version 4.682
Release Notes für Version 4.683 Release Notes für Version 4.68

Release Notes für Version 4.682

Das ide viel verbessert worden.

F9 lässt immer das Programm von Quellcode-linie laufen, das Programm an jener zeit ist.

F7 setzt immer das Programm in den Einzelschrittmodus und führt einen Schritt aus. Vergrabenes prozeduren sind schrittweise über.

Kontroll-F8 setzt einen Unterbrecherkontakt im Quellcode-linie an der position des einfügemarke.

Die vars und aufrufe Fenster sind jetzt viel schnelleres und flackern nicht nicht mehr.

intern funktionieren meine ptrdebug KlugzeigerüberprüfungsVorlagen jetzt nochmals, ist und Gedächtnislecküberprüfung verfügbar im gebauten Debug von aucblogo.exe. Dies ist wichtig um die Stabilität zu verbessern, ich fand mehrere bezogene fehler.

Und ich fand auch die meisten fehler in bounce3.lg und am2.lg.

Verändertes grundwörter bearbeite bearbeitedatei sind:

Ein neues Primitiv ist erneuerevariablenlistebeischritt

Release Notes für Version 4.683 Release Notes für Version 4.68


HC / Versions-Informationen / Release Notes für Version 4.68

Release Notes für Version 4.68

HC [image] Versions-Informationen [image] Release Notes für Version 4.68
Release Notes für Version 4.682 Release Notes für Version 4.672

Release Notes für Version 4.68

das es jetzt pro integrierte eingeschlossene Entstörumgebung gibt (ide), Sie können singlestep im Quellcode. Das edit.exe ist jetzt ist veraltetes und nicht miteingeschlossen mehr weil es den internen editor gibt. Auch Fehler springen direkt zu dem Quellcode-linie, etwas unrecht hatte. Ein einfaches Beispiel von den Entstörmöglichkeiten zeigt testedit.lg. Das lib dateien= jetzt hat alles ein Dateibezeichnungsende ".lg".

Kein neues grundwörter und= deswegen keine neue Hilfe. Für Online-html hilfe= Verwendung den 4.672 hilfe Version.

Ich können setze eine Linux-Version vom neuen 4.68 Release wenn irgendjemandes interessiert, gerade mir eine E-Mail schicken (das adress ist am Schluß von meiner Webseite).

Das Mastermind-Spiel von brian harvey= läuft jetzt auch gut mit den neuen delayed-Listen-Auswertungs-streams.

Release Notes für Version 4.682 Release Notes für Version 4.672


HC / Versions-Informationen / Release Notes für Version 4.672

Release Notes für Version 4.672

HC [image] Versions-Informationen [image] Release Notes für Version 4.672
Release Notes für Version 4.68 Release Notes für Version 4.67

Release Notes für Version 4.672

das Dies hauptsächlich ist, eine bugfix Veröffentlichung.

Es gab einen fehler herein "für", eins in der Spalter-Fenster Klasse, einem in setzeelement, in kugel und mehrere andere kleinere fehler.

Neu in diesRelease sind das grundwörter:

dynamischebibliothekrufedynamischebibliothekaufdlcall

bitelement elemente setzeelemente

textpuffer textpufferinwort

setzematerialumgebungsetzematerialdiffus setzematerialspecularsetzematerialemission

setzevariablenfensterteilersetzefensterteileraufrufe

textmausorttextmausx textmausy

wortuntercursor setzetextauswahl=

textmausereignisseantextmausereignisseaus

Und das primitive geteilterbildschirm und= Abkürzung geteilterbildschirm neugeschrieben worden sein um optional ein Spaltungsverhältnis zu akzeptieren. Die Fenster Spalterklasse ist mehrstimmig geschrieben worden, jetzt sollten die Spalter richtig funktionieren.

Die Fenster Positions-und Größe einschließlich der Spalterverhältnisse jetzt werden in die Registrierung darauf gespeichert, aUCBLogo zu schließen.

vieleckstart und="" tesselationstart= jetzt mich zu nicht geändert worden sein das gegenwärtige ort ins Polygon einschließen. vieleckstart ist jetzt wie in mswlogo.

edit.exe wird auch aktualisiert.

Und ich habe durch alle Logodemos geackert, sie sollten jetzt völlig problemlos funktionieren.

Release Notes für Version 4.68 Release Notes für Version 4.67


HC / Versions-Informationen / Release Notes für Version 4.67

Release Notes für Version 4.67

HC [image] Versions-Informationen [image] Release Notes für Version 4.67
Release Notes für Version 4.672 Release Notes für Version 4.66

Release Notes für Version 4.67

Das "bearbeite" ausführbar ist neu. Es können ersetze Crimson-Editor in den meisten Fällen, ist und für Logo-Programme sogar ein bisschen schöner. Es hat auf wxstyledtextcontrol basiert, besser auf dem stctest Beispiel von wxwidgets-2.6.1, aber erweiterte sich etwas. Ich habe die Syntax fast vollkommen einem lexer Modul besonders für aUCBLogo geschrieben, das hervorhebt, richtig. Das Syntaxhervorheben kann leicht durch das Wählen view language]> deaktiviert werden. Das "Ausführen"-Kommando bei F9 kann verändert werden, auch der Pfad von der hilfe Datei, an F1 gebunden, so dass aUCBLogo in jedem WegPfad sein kann. F4 springt zum prozedur, wie das wort unter dem einfügemarke genannt, das für Symbol, sich umumsehend, schön ist. Es gibt auch einige Zugaben in der Zusätzlichen menü: Fall von Symbolen umwandeln, um aUCBLogo Herbst zu korrigieren, und Bekehrten "setze" zu "=".

Ich habe einige neue Logo-Typen für Gebrauch mit binären Daten geschaffen:

16bitzahl 8bitzahl positive8BitZahl ganzzahlen 16bitzahlenstruktur

Neues und veränderte grundwörter sind:

8bitzahl16bitzahl positive8bitzahl="" ganzzahlen="" 16bitzahlen= Struktur]>

größevon typvon

inliste

setzeschreibersetreader

liesGanzzahlBinär lies16BitZahlBinär lies8BitZahlBinär liesPositive8BitZahlBinär liesZahlBinär liesKomplexeZahlBinär liesGanzzahlenBinär lies16BitZahlenBinär liesStrukturBinär

dateigröße

logoversion

fettertextmodus normaltextmodus="" setzetextgröße="" zeichenuntercursor=

iterieremandelbrot

grafikanfanggrafikendezeichnegraphik

vollbildmoduskeinvollbildmodus

beleuchtunganbeleuchtungaus ditheringanditheringaus punktglättunganpunktglättungaus

spieleWave

portausgangporteingangsetzeportbit löscheportbit= liesportbitnichtportbitschiebeportlinks schiebeportrechts=

waitus

setzestiftfarbesetzehintergrundfarbe setzeFüllfarbe]>

Neues und veränderte Bibliotheks-prozeduren sind:

arc2

transposematrix

vowelp

Release Notes für Version 4.672 Release Notes für Version 4.66


HC / Versions-Informationen / Release Notes für Version 4.66

Release Notes für Version 4.66

HC [image] Versions-Informationen [image] Release Notes für Version 4.66
Release Notes für Version 4.67 Release Notes für Version 4.65

Release Notes für Version 4.66

Es gibt nicht viel neues zu sagen. Ich habe nur aUCBLogo zu eine Linux-Version gemacht und wxwidgets und= portiert. Weil dies doch ein bit Arbeit war, deswegen gebe ich die Neue Version heraus.

Release Notes für Version 4.67 Release Notes für Version 4.65


HC / Versions-Informationen / Release Notes für Version 4.65

Release Notes für Version 4.65

HC [image] Versions-Informationen [image] Release Notes für Version 4.65
Release Notes für Version 4.66 buglist für Version 4.65

Release Notes für Version 4.65

aucblogo-4.65 ist ein port meiner ucblogo Version zur opengl Grafikbibliothek. Der Kern ist nur ein bisschen seit der letztes Version verändert worden (4.64): Zwei neue Warnungen sind hinzugefügt worden, so Sie können leichtere Backbordprogramme von ucblogo und="" mswlogo=. Sie werden gezeigt wenn eine Variable die Namensgleichheit als ein proc oder= hat ein Primitiv.

Gestützte plattform ist noch nur Windows 9x und= neuer, wo opengl existiert. aUCBLogo zu wxwindows und= Linux zu portieren ist auf meiner Projektliste.

Neu sind antialised zeichnet, Polygonwiedergabe-und textur= vermessend (mit fehlern, aber schön doch).

Ich habe ein Löschen hinzugefügt. lg, um den Interpreter zu einem bekannten zustand zurückzustellen.

Auch neu ist der (jetzt funktionierend) dir (weil systemaufruf besser funktioniert) und dirlg.lg= dirlg ist besonders nützlich für die Anschauung der Beispiele in Kombination mit Löschen.

Ich habe zu setze jede alte Demosarbeit mit dem neuen Grafikmotor versucht, aber die Projektionsmatrixfunktionen sind ruhige nicht Arbeit (spelltest.lg).

Auf einigen Graphikenkarten (d. h. Intel-Extrem-Grafik) there´s seltsames OpenGL SwapBuffers()-Verhalten, deswegen habe ich den befehl einfachpuffer hinzugefügt (zurückzustellendes und: doppelpufferung).

Um auch den freien Karmesinroten editor zu benutzen, veränderte ich das Hochlaufverhalten. Jetzt wenn, das Sie logo.exe mit einem xxx.lg Dateinamensparameter nennen (logo.exe xxx.lg=), das dann die datei geladen werden wird, und wird das Verfahrens-xxx ausgeführt werden.

Dies ist kühl weil Sie so schreiben können dass Ihre Logo-Programme in einem editor wie Karmesinrotes und dann Ihr Programm mit gerade einem Hot-Key ausführen (wenn Sie einen zuweisend, den ich intensly empfehlen). Die Karmesinrote Syntaxdatei im Karmesinroten Index wird auch natürlich aktualisiert. Sie sollten der kopieren /Crimson/ Verzeichnis zu Ihren Karmesinroten Programmen Verzeichnis, um Syntaxhervorheben zu ermöglichen.

EINE Microsoft htmlhelp Datei (aucblogo.chm) ist neu in diesm . So können Sie in Logo dem hilfe mit F1 rufen, und sogar besser, schließen das .chm herein Crimson ein, so haben Sie das F1 Hilfe dort, auch (Benützung crimson´s tools/conf=. Zu konfigurierende Benutzer-werkzeuge Speisekarte).

Die Vergleichs-Operatoren sollten jetzt auch mit Strings arbeiten. Wenn eins der Argumente eine Zahl ist, wird das andere Argument dann in ein Zahlen-String wenn möglich umgewandelt werden. Wenn nicht möglich, dann wird ein Stringvergleich gemacht.

Beim umwandeln von mswlogo oder="" ucblogo= nach aUCBLogo sollten Sie alle Punkte. durch _ ersetzen, weil der Punkt . der Element-Operator in aUCBLogo ist. Auch sollte = zu == verändert werden, weil = der Zuweisungsoperator ist, == ist der comparsion Operator. Aber die größte Hürde sind Variable, die die Namensgleichheit als ein Verfahrens-oder haben, ein Primitiv. In solch einem Fall benenne ich zumeist d. h. eine Variable "Liste" zu "list_" um.

Auch habe ich einige der kühlen csls Demos portiert, um mit aUCBLogo zu funktionieren (basisch, Pascal, diff).

Verändertes und Neu-grundwörter sind:

&links; &links;= == > >=

bogensinus bogenkosinusradbogensinusradbogenkosinus

ignoriere ersetze

wechsleverzeichnis wechsleverzeichnis=

doppelpufferung einfachpufferzeichnenochmalsavesizesetzespeicherungsgröße

bitmapkopierenzeichnebitmapbitload machebitmapdurchsichtig="" bittrans=bitsave

linienglättungan linienglättungan="" linienglättungaus="" vieleckglättungan="" vieleckglättungaus="" rundelinienendenan="" rundelinienendenaus=

perspektivischzweidimensional setzeauge setzestiftdicke

Ellipse fülleellipsefüllekuchenfüllerechteck

listergba rgbatshaaddierefarben

setzexyz setzezortxyzsetzeortxyz

abstandxyz inrichtungxyz

setzeortinkugelkoordinaten setzezylinderort

Brötchenrollelinks rollrechts

orientierungsetzeorientierung

vieleckendevieleckstart

kugelEllipsoid

setzelichtort setzeumgebungslichtsetzediffuseslicht setzespecularlicht

texturtexturenantexturenantexturenaustexturenaus

neues Bibliotheks-prozeduren sind:

dir dirlgLöschenÜberprüfung

Beile rotatescene

displaymatrix

bitpastet ist gestrichen worden weil es jetzt machebitmapdurchsichtig gibt, und opengl= sorgt für Alpha KanalUnterstützung (transparence).

printsize, setprintsize werden gestrichen, weil Druck die Größen automatisch wählt. Und Speichern wird über setzespeicherungsgröße, savesize, kontrolliert.

movepixel und="" moveline= werden gestrichen, weil es doppelte Pufferung gibt.

Für Fragen betreffend dies besondere Version von gutem alten ucblogo, um das Sie andreas micheler= bitten können.

Release Notes für Version 4.66 buglist für Version 4.65


HC / Versions-Informationen / buglist für Version 4.65

buglist für Version 4.65

HC [image] Versions-Informationen [image] buglist für Version 4.65
Release Notes für Version 4.65 Release Notes für Version 4.64

buglist für Version 4.65

das ich nicht liebe Sie jene fehler zu sagen, aber von dem ich glaube dass es es besser ist als zu gehen dass Sie hängen.

1) ;~+-Bemerkungs-Fehler:
    ;~comment
    ; I don't know how  to ~comment
but even worse:
    ;~+
    No way! This is bogus!; I don't know how  to ~
    weiter ; Pausing...
2) Procedure redefinition bug (wrong error message):
    circle2
    ;  	[]
    doesn't like Unbound as input
circle2.lg is:
    to kreis r
        bogen 360 r
    end
3) Arcbug (arcbug.lg): on resizeing the screen some rabbish is drawn.
    to arcbug
        löscheSchirm
        vorwärts 400
        links 180
        bogen 15 100
    end
4) "=" bug (wrong error message):
    zeige a=1
    ;  = didn't output to 	[]
5) another "=" bug:
    i1=0
    zeige i1
    Unbound
Workaround is adding a space after a symbol with numeric end:
    j1 =0
    zeige j1
    0
6) "+=" bug: the number input is nicht copied but changed.
    a=0
    b=a
    a+=1
    b
    1  ;-)
Workaround: use a=ganzzahl für initialising when using "+="!

7) empty linie "end" bug:
    to t
        schreibe 1234

    end


HC / Versions-Informationen / Release Notes für Version 4.64

Release Notes für Version 4.64

HC [image] Versions-Informationen [image] Release Notes für Version 4.64
buglist für Version 4.65 Berkeley Logo-Anwenderdokumentation

Release Notes für Version 4.64

Dies ist eine größere Neubearbeitung des Kernes von UCBLogo einschließlich des Müllkollektors, jetzt mit typensicherem C++, vielen neuen enums, Templates zum Debuggen des Müllsammelns und mit einem Geschwindigkeitsgewinn von ungefähr 20-40 Mal:-))) Höchstgeschwindigkeit ist besser als 310 CPU-Uhrzyklen pro Logoanweisung, was nicht schlecht ist für einen Interpreter. Dies war möglich durch die Einführung von Stapeln und dadurch die Umgehung von neuen Konstruktoren während der Laufzeit, die den Müllsammeler zu viel belastete.

Das Befehls-linie ist jetzt eine richedit Kontrolle mit all Vorteilen. ctrl -ENTER fügt eine neue Zeile, ENTER ausführt die zeile. Es gibt kein Stichwort mehr (außer einigen Fehlern wenn pausierend), weil jedes linie ausführbar sein sollte. Der Fehler "Sie don`t sagen was zu tun mit" jetzt wird zugunsten des Ergebnisses mit der Bemerkung entfernt;-) so Sie können setze Schnellrechnungen von Hand wenn, das Sie sie brauchen. linie Fortsetzungen ~ sind mehr benötigtes nicht.

e aufrufe= der editor (schreiben Sie die folgenden einstellungen zu Ihrem autoexec.bat oder= in Ihre Systemumgebung auf windows xp=:
set AEDITOR=C:\Windows\Notepad
set ALOGOLIB=C:\aUCBLogo\Lib
set ALOGOHELP=C:\aUCBLogo\Help).

h [command] opens a web browser with the Hilfe page für that command. You will have to change the directories in h.lg für correct operation.

A bit of new syntax has been introduced to setze unquoted variable assignments und colonless variables possible, like

a_variable=some_other_var
b=[1 2 3]
c=3.14
d+=pi

Equality can be checked with ==, as in

zeige wahr==falsch
falsch

A variable now has higher priority than a procedure of the same name.

Also some new grundwörter are included:

Wiederholung, SystemaufrufAbspalten, verfolgt, setzeGroßKleinEgal, GroßKleinEgalP,

Matrix, setMatrix, IgelMatrix, IgelMatrix, setzeIgelMatrix, setzeIgelMatrix, IdentitätsMatrix, IDM, setzeIdentitätsmatrix, setIDM, Punkt, setzePunkt, Linie, movePixel, moveLine, fülleRechteck, fülle, fülleEllipse, setzeFüllfarbe,setzeFüllfarbe, Füllfarbe, RGB, listeRGB, TSH, addiereFarben, speichereGraph, speichereGraph, ladeGraph, ladeGraph, speicherePostScript, savePS,

ZeichenP, intP, floatP, complexP, liesZeichenErweitert,liesZeichenErweitert, rotiere, ArrayToList, ListToArray, verschmelze, verschmelzePaare, inListenListe, mergeSort, _setzeNächstes, PropertyList, getProperty, putProperty, removeProperty,

Faculty, primeP, faktorisiere, =, kleinerGleichP,größerGleichP, <=,>=, kleinstes, größtes, Norm, MaximumsNorm, vergrößere, zufällig, kreuzprodukt, invertMatrix, rundeAb, Tangens, mod, ^, radTangens, abs, xKopieren, xPlus, xMinus, xMal, xDividieren, xRest, +=, -=, *=, /=,

Parameteranzahl, Grundwörter, PropertyLists, listeProzedur, listeTitel, vergißAlle, vergißProzeduren, vergißVariablen, erasePropertyLists,

timeFine, timeMilli, TimeU, TimeURes, ZeitgeberFrequenz, zeit, MillionenBefehleProSekunde, Ton, spieleWave, warteMilliSekunden,

setzeTextschrift, EinfügeModus, Überschreibmodus, setzeSchreibpräzision

TextSchriftgröße, setzeSchriftgröße, setzeSchriftname, setzeSchriftdicke, setLabelAlign.

PrintSize, SetPrintSize, saveScreenBMP, saveBMP, setzeGraphAktualisieren, erneuereGraph, erneuereVariablenliste, Aufrufe, erneuereAufrufliste, refreshP, verteileMeldungen, BitmapKopieren, zeichneBitmap, BitPasteT, scrolle, kalibriereScrolling, scrollCal

Multiple turtles: Igel, neuerIgel, setzeIgel

3D: perspektivisch, zweidimensional, setzeAuge, rolleLinks,lR, rollRechts,rollRechts, rauf,rauf, runter,runter, setzeZ, setzeXYZ, setzeOrtXYZ, _setzeOrtXYZ, setzeOrtInKugelkoordinaten, setzeZylinderOrt, xKoor, yKoor, zKoor, OrtXYZ, setzeRollWinkel, setzeNeigung, setzeOrientierung, Roll, Pitch, Orientierung, inRichtung, inRichtungXYZ, Abstand, DistanceXYZ.

And some functions have been extended, especially the math functions, which can now take nested lists und arrays und complex numbers like

{[1 2] 3.14 {4 5 [6 7]}}+{[1 2] 3.14 {4 5 [6 7]}}
{[2 4] 6.28 	{8 10 [12 14]}
}  ;-)

(1+2i)*(2+4i)
-6+8i  ;-)

1+2e3i
1+2000i  ;-)

exp pi*2i
-1+1.22460635382238e-016i  ;-)

unary functions: BitNicht, random, Ganzzahl, round, truncate, Sinus, Kosinus, Tangens, radSinus, radKosinus, radTangens, quadriere, Quadratwurzel, exp, natürlicherLogarithmus, ZehnerLogarithmus, real, imag, conjugate

binary functions: +, -, *, /, RestDerDivision, schiebeArithmetisch, schiebeLogisch, BitOder, BitUnd, BitXOder, Potenz, BogenTangens, radBogenTangens

Systemaufruf acts now more like in unix, it gives zurück the output in formatierezahl of a liste, but it has still some bugs.

A syntax highlighting scheme für the free Proton Editor is included (aUCBLogo.sch), another editor scheme is für the Crimson editor (crimson.zip).

For questions concerning dies special version of good old UCBLogo you may ask Andreas Micheler.


HC / Versions-Informationen / Berkeley Logo-Anwenderdokumentation

Berkeley Logo-Anwenderdokumentation

HC [image] Versions-Informationen [image] Berkeley Logo-Anwenderdokumentation
Release Notes für Version 4.64 Überblick

Berkeley Logo-Anwenderdokumentation

Copyright (C) 1993 by the Regents of the University of California

This program is free software; you can redistribute it und/oder modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, oder
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY oder FITNESS für A PARTICULAR PURPOSE.
See the GNU General Public License für more details.

You should have received a copy of the GNU General Public License
along with dies program; wenn nicht, write to the Free Software
Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.

This is a program that is still being written. Many things are missing, including adequate documentation. This manual assumes that you already know how to program in Logo, und merely presents the details of dies new implementation. Read
    Computer Science Logo Style, Volume 1:
    Symbolic Computing  by
    Brian Harvey (MIT Press, 1997)
für a tutorial on Logo programming with emphasis on symbolic computation. Or you can look at the Logo Forum
    comp.lang.logo
für interesting information und intensive discussions.

Here are the special features of dies dialect of Logo:

Source file compatible among Unix, DOS, und Mac platforms.

Random-access ARRAYs.

Variable number of inputs to user-defined procedures.

MUTATORS für LISTE structure (dangerous).

PAUSE on ERROR, und other improvements to ERROR PROCESSING.

Comments und continuation lines; formatting is preserved when
PROCEDURE DEFINITION(s) are saved oder edited.

Terrapin-style TOKENIZATION (e.g., [2+3] is a LISTE with one elementeab)
but LCSI-style syntax (no special forms except TO).  The best of
both worlds.

First-class instruction und expression templates (see WENDEAN).

MACROS.

Features *nicht* found in Berkeley Logo include robotics, music, GUIs, animation, parallelism, und multimedia. For those, buy a commercial version.


HC / Überblick

Überblick

HC [image] Überblick
Berkeley Logo-Anwenderdokumentation Einführung in die Logo-Programmierung

Überblick

Dieses Kapitel gruppiert verschiedene Übersichtsartikel.

Es sollte auch eine kurze Einführung in die Logo-Programmiersprache in diesem Handbuch geben, aber niemand hat sie bisher geschrieben. Beiträge sind willkommen!

Überblick

  • Einführung in die Logo-Programmierung
  • Starten und Verlassen von Logo
  • Kommandozeilen-Schalter -nogui
  • Kommandozeilen-Schalter -run
  • Tokenisierung
  • Fehlersuche
  • Geltungsbereich der Variablen
  • Parallele Ausführung
  • Objekte
  • Fehler-Verarbeitung
  • CGI Skripting und WWW
  • Über Komplexität

Reference:

    Einführung in die Logo-Programmierung

Berkeley Logo-Anwenderdokumentation Einführung in die Logo-Programmierung


HC / Überblick / Einführung in die Logo-Programmierung

Einführung in die Logo-Programmierung

HC [image] Überblick [image] Einführung in die Logo-Programmierung
Überblick Starten und Verlassen von Logo

Einführung in die Logo-Programmierung

TODO: vervollständigen der Liste, eine kurze Einführung schreiben...

Eine Möglichkeit, mit Logo anzufangen, wäre, sich zu überlegen, was man gerne selbst Neues mit einem Computer machen möchte. Naheliegend sind zum Beispiel das Schreiben von Programmen, die Bilder, Animationen oder auch Musik produzieren. Auch ein schöner Einstieg können Spiele sein, dabei wird manch einer feststellen, dass er/sie dabei viel mehr über Algorithmen, Logik und Mathematik lernt, als er/sie vorher gedacht hätte.

Manchmal braucht man auch ein kleines oder großes Programm zum Steuern irgendwelcher Maschinen, und sei es nur eine Lichtorgel, die man am Parallelport mit seinen 12 ansteuerbaren Pins betreibt.

Oder man will einen Internet-Chat-Server schreiben, den es in der Form, wie man ihn haben will, noch nicht gibt.

Vieles davon läßt sich in Logo realisieren.

Anderes erfordert auch Kenntnisse von Systemprogrammierung, die oft in C oder C++ dargestellt wird. Man kann aber auch leicht neue Logo-Befehle hinzufügen, wenn man C, besser etwas C++ beherrscht, was auch manchmal nötig ist, wenn man aufwändige Berechnungen durchführen möchte.

Aber zum Kennenlernen der Möglichkeiten, die Programmierung bietet, reicht Logo allein auch schon recht gut.

Logo ist ein mächtiges Werkzeug.

Es gibt einige Bücher über Logo, zu den bekanntesten zählen

Computer Science Logo Style
Volume 1: Symbolic Computing
Brian Harvey
University of California, Berkeley

Computer Science Logo Style
Volume 2: Advanced Techniques
Brian Harvey
University of California, Berkeley

Computer Science Logo Style
Volume 3: Beyond Programming
Brian Harvey
University of California, Berkeley

Die drei Bücher von Brian Harvey, Computer Science Logo Style I, II und III, (kurz CSLS) können Sie sogar online lesen auf seiner Homepage:
    http://www.cs.berkeley.edu/~bh/logo
aUCBLogo ist leider nicht 100%ig kompatibel zu UCBLogo, was viele neue Features erst möglich werden ließ, aber wenn Sie CSLS lesen wollen, empfiehlt es sich, auch UCBLogo zu installieren, da einige Beispiele von CSLS in aUCBLogo ohne Veränderung nicht laufen. Sie können versuchen, einige Beispiele in aUCBLogo laufenzulassen, indem Sie den Schalter
    setzeLogoSprache "ucblogo
verwenden, jedoch ist dieser Schalter noch nicht ganz fertig.

Im aUCBLogo-Paket sind sehr viele große und kleine Beispiel-Programme enthalten. Wenn Sie etwas an einem Beispiel lernen wollen, können Sie am einfachsten mit der Suche-in-Dateien-Funktion Ihres Betriebssystems im Verzeichnis .../aucblogo suchen, oder natürlich auch mit einem speziellen Suchprogramm.

Ferner ist es naheliegend, die üblichen Suchmaschinen im Internet abzufragen.

Die Homepage von Andreas Micheler
    http://www.physik.uni-augsburg.de/~micheler/
bietet Tabellen mit den Beispielen zu aUCBLogo, die Ihnen einen gewissen Überblick verschaffen können.

Fragen stellen können Sie auch Online, z.B. bei
    news:comp.lang.logo,
oder im LogoForum:
    http://groups.yahoo.com/group/LogoForum/
Eine Verbindung zu den vielen anderen Logo-Interpretern und den wenigen Compilern stellt
    The Great Logo Atlas
    http://ccgi.frindsbury.force9.co.uk/greatlogoatlas/
dar.

Wenn Sie glauben, einen Fehler in aUCBLogo gefunden zu haben, oder eine spezielle Frage oder Anregung zu einer Funktion haben, können Sie auch gerne eine email schreiben an:
    mailto:Andreas.Micheler@physik.uni-augsburg.de


HC / Überblick / Starten und Verlassen von Logo

Starten und Verlassen von Logo

HC [image] Überblick [image] Starten und Verlassen von Logo
Einführung in die Logo-Programmierung Kommandozeilen-Schalter -nogui

Starten und Verlassen von Logo

TODO: diesen Abschnitt sollte mal jemand neu schreiben, denn die Gliederung sowie der Inhalt sind nicht mehr aktuell.

Der Vorgang, Logo zu starten, hängt von Ihrem Betriebssystem ab:

Unix:	 Type the wort aucblogo to the shell.
(The directory in which you've installed Logo must be in your path.)

Windows: Double-click on aucblogo.exe in the aucblogo folder.

To leave Logo, enter the command "Tschüß".

Under Unix oder DOS, wenn you include one oder more filenames on the command linie when starting Logo, those dateien will be loaded before the interpreter starts reading commands from your terminal. If you lade a file that executes some program that includes a "Tschüß" command, Logo will führeAus that program und exit. You can therefore write standalone programs in Logo und führeAus them with systemaufruf/batch scripts. To support dies technique, Logo does nicht schreibe its usual welcoming und parting messages wenn you give file arguments to the logo command.

If you tippe your interrupt character (see tabelle below) Logo will stop what it's doing und return to toplevel, as wenn you did wirf "TOPLEVEL. If you tippe your quit character Logo will pause as wenn you did Pause.

toplevel    [Ctrl-Pause]

pause       [Pause]

If you have an environment variable called ALOGOLIB whose value is the name of a directory, then Logo will use that directory instead of the default library. If you invoke a procedure that has nicht been defined, Logo erstes looks für a file in the current directory named proc.lg where "proc" is the procedure name in lower Fall letters. If such a file exists, Logo loads that file. If the missing procedure is still undefined, oder wenn there is no such file, Logo then looks in the library directory für a file named proc.lg und, wenn it exists, loads it. If neither file contains a definition für the procedure, then Logo signals an error. Several prozeduren that are primitive in most versions of Logo are included in the default library, so wenn you use a different library you may want to include some oder all of the default library in it.


HC / Überblick / Kommandozeilen-Schalter -nogui

Kommandozeilen-Schalter -nogui

HC [image] Überblick [image] Kommandozeilen-Schalter -nogui
Starten und Verlassen von Logo Kommandozeilen-Schalter -run

Kommandozeilen-Schalter -nogui

Sie können komplett ohne die graphische Benutzeroberfläche (GUI) von aUCBLogo arbeiten, wenn Sie den Kommandozeilen-Schalter -nogui verwenden, wie in dem Beispiel:
    aucblogo -nogui
(von einer Betriebssystem-Konsole heraus). Um danach dennoch ein Grafik-Fenster zu erzeugen, können Sie die Bibliotheksprozedur noguigraph irgendwo in Ihrem Programm aufrufen, oder auch in der Kommandozeile:
    aucblogo -nogui noguigraph
Als Beispiel können Sie auch ein Logo-Programm mitaufrufen:
    aucblogo -nogui noguigraph 3dbutterfly
Um eigenständige Programme zu schreiben, verwenden Sie Tschüß:
    aucblogo -nogui noguigraph 3dbutterfly Tschüß


HC / Überblick / Kommandozeilen-Schalter -run

Kommandozeilen-Schalter -run

HC [image] Überblick [image] Kommandozeilen-Schalter -run
Kommandozeilen-Schalter -nogui Tokenisierung

Kommandozeilen-Schalter -run

Sie können eine beliebige Liste von Logo-Befehlen von der Befehlszeile aus aufrufen, z.B.
    aucblogo -run [schreibe [Hallo, Welt!]]
Wenn Sie den Schalter -run mit dem Schalter -nogui verbinden, können Sie shell-Skripten in Logo schreiben.

Beispiel:
    aucblogo -nogui -run [schreibe Dateien Tschüß] > test.txt


HC / Überblick / Tokenisierung

Tokenisierung

HC [image] Überblick [image] Tokenisierung
Kommandozeilen-Schalter -run Fehlersuche

Tokenisierung

TODO: diesen Abschnitt sollte man neu schreiben, da sich hier vieles seit UCBLogo geändert hat.

VariablenNamen von prozeduren, Variablen, Und Eigentumslisten sind So Fall unempfindlich. ist das besondere Wörter-ENDE, WAHR, und nicht WAHR. Kiste von Buchstaben wird in allem Sie tippe bewahrt, allerdings.

Innerhalb Winkelträgern werden Wörter nur von Plätze-Und Winkelträgern abgegrenzt.
    [2+3]
is a liste containing one word. Note, however, that the Logo grundwörter that interpret such a liste as a Logo instruction oder expression (führeAus, wenn, etc.) reparse the liste as wenn it had nicht been typed inside brackets.

After a quotation mark outside square brackets, a wort is delimited by a space, a square bracket, oder a parenthesis.

A wort nicht after a quotation mark oder inside square brackets is delimited by a
    space, a bracket, a parenthesis,
    oder an infix operator + - * / ^ = < > += -= *= /= == != <= >=.
Note that words following colons are in dies category. Note that quote und colon are nicht delimiters.

A wort consisting of a question mark followed by a number
    ?37
when runparsed (i.e., where a procedure name is expected), is treated as wenn it were the sequence
    ( ? 37 )
making the number an input to the ? procedure. (See the discussion of templates, below.) This special treatment does nicht wendeAn to words read as data, to words with a non-number following the question mark, oder wenn the question mark is backslashed.

A linie (an instruction linie oder one read by liesListe oder liesWort) can be continued onto the following linie wenn its letztes character is a
    tilde ~ .
LIESWORT preserves the tilde und the newline; LIESLISTE does not.

Linie Continuation: An instruction linie oder a linie read by LIESLISTE (but nicht by LIESWORT) is automatically continued to the next linie, as wenn ended with a tilde, wenn there are unmatched
    brackets, parentheses, braces, oder vertical bars
pending. However, it's an error wenn the continuation linie contains only the wort END; dies is to prevent runaway procedure definitions. Lines eplicitly continued with a tilde avoid dies restriction.

If a linie being typed interactively on the keyboard is continued, either with a tilde oder automatically, Logo will display a tilde as a prompt character für the continuation line.

A semicolon begins a comment in an instruction line. Logo ignores characters from the semicolon to the end of the line. A tilde as the letztes character still indicates a continuation linie, but nicht a continuation of the comment.

For example, typing the instruction
    schreibe "abc;comment ~
    def
will schreibe the wort abcdef. Semicolon has no special meaning in data lines read by LIESWORT oder LIESLISTE, but such a linie can later be reparsed using klammereFürAusführung und then comments will be recognized.

To include an otherwise delimiting character (including semicolon oder tilde) in a wort, precede it with
    backslash  .
If the letztes character of a linie is a backslash, then the newline character following the backslash will be part of the letztes wort on the linie, und the linie continues onto the following line.
    To include a backslash in a wort, use .
If the combination backslash-newline is entered at the terminal, Logo will issue a backslash as a prompt character für the continuation line. All of dies applies to data lines read with LIESWORT oder LIESLISTE as well as to instruction lines. A character entered with backslash is gleichP to the same character without the backslash, but can be distinguished by the SchrägstrichP predicate. (However, SCHRÄGSTRICHP recognizes backslashedness only on characters für which it is necessary:
    whitespace, parentheses, brackets, infix operators,
    backslash, vertical bar, tilde, quote,
    question mark, colon, und semicolon.)
An alternative notation to include otherwise delimiting characters in words is to enclose a group of characters in vertical bars. All characters between vertical bars are treated as wenn they were letters. In data read with LIESWORT the vertical bars are preserved in the resulting word. In data read with LIESLISTE (oder resulting from a klammere oder KLAMMEREFÜRAUSFÜHRUNG of a wort) the vertical bars do nicht appear explicitly; all potentially delimiting characters (including spaces, brackets, parentheses, und infix operators) appear as though entered with a backslash. Within vertical bars, backslash may still be used; the only characters that must be backslashed in dies context are backslash und vertical bar themselves.

Characters entered between vertical bars are dauernd special, even wenn the wort oder liste containing them is later reparsed with KLAMMERE oder RUNPARSE. Characters typed after a backslash are treated somewhat differently: When a quoted wort containing a backslashed character is runparsed, the backslashed character loses its special quality und acts thereafter as wenn typed normally. This distinction is important only wenn you are building a Logo expression out of parts, to be FÜHREAUS later, und want to use parentheses.

For example,
    schreibe FÜHREAUS (Satz "( 2 "+ 3 "))
will schreibe 5, but
    FÜHREAUS (Satz "setze ""( 2)
will create a variable whose name is open-parenthesis. (Each example would fail wenn vertical bars und backslashes were interchanged.)

Reference:

    Versions-Informationen

Kommandozeilen-Schalter -run Fehlersuche


HC / Überblick / Fehlersuche

Fehlersuche

HC [image] Überblick [image] Fehlersuche
Tokenisierung Geltungsbereich der Variablen

Fehlersuche

TODO: Tabelle von Tastaturkürzeln & Befehlen, beschreibe Reverse Stepping, die Debug-Fenster Vars, StackVars, Aufrufe & Speicher, und verschiedene Strategien, Fehler zu suchen in einem Logo-Programm.

References:

    Versions-Informationen für Version 4.7(2), Editieren, neuerZufall, setzeFPUStatusFlags, setzeFehlerAktion, setzeGenSym

Tokenisierung Geltungsbereich der Variablen


HC / Überblick / Geltungsbereich der Variablen

Geltungsbereich der Variablen

HC [image] Überblick [image] Geltungsbereich der Variablen
Fehlersuche Parallele Ausführung

Geltungsbereich der Variablen

TODO: Dieser Abschnitt soll den dynamischen Geltungsbereich beschreiben, der in Logos üblich ist, und den Benutzer mit Fragen zu Objektorientierung und Multithreading konfrontieren, ebenso soll der in vielen anderen Programmiersprachen übliche lexikalische Geltungsbereich erklärt werden.

Der Geltungsbereich kann global sein, wenn die "setze"-Anweisung global oder in einer mit dynamischem Geltungsbereich definerten Prozedur (mit "zu" definert) ausgeführt wird. Er kann auch lokal zur aktuellen Prozedur sein, wenn vorher die Variable mit "lokal" lokal gemacht wurde. Er kann auch auf die aktuelle Prozedur und ihrer Kind-Prozeduren beschränkt sein, wenn die aktuelle Prozedur unter Verwendung von "sei" mit lexikalischem Geltungsbereich definiert wurde.

References:

    sei, setze

Fehlersuche Parallele Ausführung


HC / Überblick / Parallele Ausführung

Parallele Ausführung

HC [image] Überblick [image] Parallele Ausführung
Geltungsbereich der Variablen Objekte

Parallele Ausführung

Die parallele Ausführung in aUCBLogo basiert auf folgenden Grundwörtern:

Die Konstrukteure

parallelAusführen
Faser

, einige Abfragen

Threads
zähleThreads
liesThreadNummer

und ein paar Hilfsfunktionen:

beginneGraph
beendeGraph
beendeThread
yield

Synchronisierung fehlt leider noch.

Nun, was Sie tun können ist eigentlich ziemlich einfach: verwenden Sie parallelAusführen (oder Thread), um einen neuen parallelen Ausfürhungsstrang zu beginnen, der die als Argumente übergebenen Befehle ausführen soll, wie in folgendem Beispiel:

TODO

Reference:

    Versions-Informationen für Version 4.7(2)

Geltungsbereich der Variablen Objekte


HC / Überblick / Objekte

Objekte

HC [image] Überblick [image] Objekte
Parallele Ausführung Fehler-Verarbeitung

Objekte

TODO: hier soll einmal die Objekt-Orientierung beschrieben werden, wie sie in aUCBLogo implementiert ist.

Example:

  • Versions-Informationen für Version 4.7

References:

    Versions-Informationen für Version 4.7(2), löscheSchatten

Parallele Ausführung Fehler-Verarbeitung


HC / Überblick / Fehler-Verarbeitung

Fehler-Verarbeitung

HC [image] Überblick [image] Fehler-Verarbeitung
Objekte CGI Skripting und WWW

Fehler-Verarbeitung

Wenn ein Fehler auftritt, nimmt Logo die folgenden Schritte. Zuerst, wenn, das es ein verfügbares variables genanntes ERRACT gibt, nimmt Logo Wert ein instructionlist und die Anweisungen laufen lässt. Der Operations-liesFehler kann innerhalb der Anweisungen (einmal) benutzt werden, den Fehlerzustand zu prüfen. Wenn das Befehlsliste Pause aufruft, wird die Fehlermeldung gedruckt, bevor die Pause geschieht. Gewisse Fehler sind "wiederherstellbar"; für einen jener Fehler, wenn gibt das Befehlsliste einen Wert aus, dass Wert benutzt wird an Ort und Stelle von dem Ausdruck, der den Fehler verursachte. (Wenn ERRACT PAUSEN-Und aufruft ruft der Benutzer dann weiter mit einer Eingabe auf, das Eingabe die Ausgabe von PAUSE Und deswegen wird die Ausgabe vom ERRACT instructionlist.)

Es ist möglich dass ein ERRACT instructionlist einen unangemessenen Wert oder erzeugt kein Wert, eins benötigt wird. Dadurch könnte sich der gleiche Fehlerzustand dauernd wegen Würfelmechanismus wiederholen. Jene Gefahr zu vermeiden, wenn der gleiche Fehlerzustand tritt zweimal hintereinander von einem ERRACT instructionlist ohne Benutzerwechselwirkung auf, die Meldung "Erract Schleife" wird Und Kontrollrückkehr zu toplevel gedruckt. "Ohne Benutzerwechselwirkung" bedeutet dass wenn ERRACT PAUSEN-Und aufruft sorgt der Benutzer für einen falschen Wert, Würfelschleifenverhinderungsmechanismus tritt nicht und in Kraft, das der Benutzer nochmals versuchen bekommt.

Während des Laufens des ERRACT instructionlist wird ERRACT örtlich ungebunden, so ein Fehler in den ERRACT Anweisungen selbst wird nicht eine Schleife verursachen. Im Besonderen, ein Fehler während einer Pause wird nicht verursachen ein Pausen-innen-ein-Pause außer wenn der Benutzer während der Pause den Wert [PAUSE] zu ERRACT wieder zuweist. Aber solch ein Fehler wird nicht zu toplevel zurückgegeben; es wird innerhalb der ursprünglichen Pausenschleife übrig bleiben.

Wenn es keinen verfügbaren ERRACT Wert gibt, beherrscht Logo den Fehler durch die Erzeugung eines internen wirf "FEHLER. (Ein Anwenderprogramm kann absichtlich auch einen Fehlerzustand durch das Aufrufen des WURFES erzeugen.) Wenn dieses Wirf nicht von einem fange "FEHLER im Anwenderprogramm gefangen wird, wird es schließlich entweder von der Toplevel Anweisungsschleife oder von einer Pausenschleife gefangen, die die Fehlermeldung druckt. Eine Anrufung von FANGE "FEHLER in einem Anwenderprogramm örtlich losbindet ERRACT, so ist das die Wirkung gleich welches von ERRACT und FANGE "FEHLER ist mehr lokal wird Vorrang nehmen.

Wenn ein Gleitpunktüberlauf während einer Rechnungsart auftritt, oder eine zwei-eingegebene mathematische Funktion (wie Potenz) wird mit einer illegalen Mischung aus Eingaben aufgerufen, der "mag nicht" Meldung verweist zur zweiten Rechengröße, aber sollte genommen werden, als die Kombination zu bedeuten.

Objekte CGI Skripting und WWW


HC / Überblick / CGI Skripting und WWW

CGI Skripting und WWW

HC [image] Überblick [image] CGI Skripting und WWW
Fehler-Verarbeitung Über Komplexität

CGI Skripting und WWW

TODO: hier soll einmal die Möglichkeit, CGI-Skripte mit Logo anzufertigen, sowie der Einsatz von aUCBLogo als Internet-Anwendung beschrieben werden.

Beispiele:

cgitest3
cgicounter
cgicounter_ifs


HC / Überblick / Über Komplexität

Über Komplexität

HC [image] Überblick [image] Über Komplexität
CGI Skripting und WWW Kommunikation

Über Komplexität

Die Komplexität eines Logo-Grundworts im numerischen Sinn, d.h. bezüglich seines Laufzeit-Bedarfs, hängt im Allgemeinen von den Daten ab, auf denen sie arbeitet.

Meist muß man zusätzlich einen relativ konstanten Betrag hinzuzählen, wenn die Funktion von interpretiertem Code aus aufgerufen wird. Sofern die Benutzer-Funktion vorher kompilert wurde, fällt dieser konstante zusätzliche Betrag fast weg.

Wenn die Laufzeit einer Funktion nicht von der Elementeanzahl der Eingabedaten abhängt, kann man sagen, die Komplexität sei konstant oder von der Ordnung 1:

O(1)

Wenn die Laufzeit einer Funktion linear von der Elementeanzahl der Eingabedaten abhängt, kann man sagen, die Komplexität sei linear oder von der Ordnung N:

O(N)

Wenn die Laufzeit einer Funktion quadratisch von der Elementeanzahl der Eingabedaten abhängt, kann man sagen, die Komplexität sei quadratisch oder von der Ordnung N^2:

O(N^2)

... Und so weiter.

Für große Datenmengen kann man für den Zeitbedarf folgende Reihenfolge angeben:

O(1)
O(log(N))
O(N)
O(N*(log(N))
O(N^2)
O(N^3)
O(N^x)
O(exp(N))

Für die viele Logo-Grundwörter kann man den Zeitbedarf ungefähr angeben, was in diesem Handbuch auch versucht wird.


HC / Kommunikation

Kommunikation

HC [image] Kommunikation
Über Komplexität Sender

Kommunikation

Hier werden Ein- und Ausgabe-Funktionen von Logo beschrieben.

Kommunikation

  • Sender
  • Empfänger
  • Konsole-Funktionen
  • Dateien öffnen
  • Datei-Zugriff
  • Datei-Verzeichnisse
  • Umgebung
  • Port-Eingabe Und Ausgabe
  • Zeitmessung
  • Dynamische Bibliotheken
  • Betriebssystem


HC / Kommunikation / Sender

Sender

HC [image] Kommunikation [image] Sender
Kommunikation schreibe

Sender

...sind Befehle, die zum gegenwärtigen Schreiber schreiben (mit der Konsole als Standard-Ausgabe).

Sender

  • schreibe
  • tippe
  • zeige
  • displaymatrix


HC / Kommunikation / Sender / schreibe

schreibe

HC [image] Kommunikation [image] Sender [image] schreibe
Sender tippe

schreibe wert
(schreibe wert1 wert2...)
(schreibe wert1 wert2...)

Kommando. Schreibt die Eingabe oder die Eingaben auf den momentanen Schreiber-Strom (anfänglich die Konsole). Alle Eingaben werden in eine einzelne Zeile geschrieben, von Leerzeichen getrennt, mit einem newline am Ende. Wenn eine Eingabe eine Liste ist, werden darum herum keine eckigen Klammern ausgegeben, aber eckige Klammern werden um Unterlisten gedruckt.

schreibe 1234		;1234
schreibe pi		;3.14159
schreibe "Hallo		;hallo
schreibe [Hallo World!]		;Hallo World!
schreibe {an reihe}		;{an reihe}
schreibe [[sublist][structure]]		;[sublist][structure]
(schreibe)		;prints an empty linie
(schreibe "one "two "three)		;one two three
(schreibe 1 "one [One] {one})		;1 one One {one}

See also:

  • Tokenisierung
  • tippe

Examples:

  • beiLosgelassenerTasteInListenControl
  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • beiGedrückterTasteInListenControl
  • beiLosgelassenerTasteInAuswahlbox
  • beiGeklickterListencontrolSpalte
  • beiLosgelassenerTasteInListenbox
  • beiLosgelassenerTasteInKombiBox
  • beiGedrückterTasteInAuswahlbox
  • beiLosgelassenerTasteInFenster
  • beiLosgelassenerTasteInTextbox
  • beiDoppeltgeklickterListenbox
  • beiGedrückterTasteInListenbox
  • beiGraphMausRechtsDoppelKlick
  • beiRechtsDoppeltgeklickerMaus
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • beiGraphMausLinksDoppelKlick
  • beiGraphMausLinksLosgelassen
  • beiGraphMausMitteDoppelKlick
  • beiGraphMausMitteLosgelassen
  • beiLinksDoppeltgeklickerMaus
  • beiLosgelassenerTasteInGraph
  • beiMitteDoppeltgeklickerMaus
  • beiSchiebereglerVerschiebung
  • beiGedrückterTasteInFenster
  • beiGedrückterTasteInTextbox
  • beiLinksGeklickterGraphMaus
  • beiMitteGeklickterGraphMaus
  • beiÄnderungInReellerZahlbox
  • Vorlagen-basierte Iteration
  • setzeKombiBoxMöglichkeiten
  • beiGedrückterTasteInGraph
  • beiZeichenInListenControl
  • setzeBackslashErweiterung
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • setzeReelleZahlboxBereich
  • setzeSchiebereglerBereich
  • beiGeklicktemSchaltknopf
  • beiRechtsLosgelasserMaus
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • beiGeklickterAnkreuzbox
  • beiLinksLosgelasserMaus
  • beiMitteLosgelasserMaus
  • entferneKombiBoxElement
  • setzeGanzzahlBoxBereich
  • beiGanzzahlBoxÄnderung
  • beiMitteGeklickterMaus
  • beiZeichenInAuswahlbox
  • holeSchriftVomBenutzer
  • setzeReelleZahlboxWert
  • setzeSchiebereglerWert
  • beiLosgelassenerTaste
  • SystemaufrufAbspalten
  • zerstöreSchieberegler
  • öffneZumAktualisieren
  • beiAuswahlboxAuswahl
  • holeFarbeVomBenutzer
  • liesZeichenErweitert
  • setzeGanzzahlBoxWert
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • beiKombiBoxÄnderung
  • beiListenboxAuswahl
  • beiListenboxZeichen
  • FloatControlDestroy
  • ListenControlSpalte
  • zerstöreGanzzahlBox
  • _vielleichtAusgabe
  • beiGedrückterTaste
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • beiTextboxÄnderung
  • führeAusMitAusgabe
  • ListenControlZeile
  • setzeKombiBoxFarbe
  • VerzeichnisAuswahl
  • beiFensterZeichen
  • beiTextboxEingabe
  • beiTextboxZeichen
  • ListenControlText
  • SchiebereglerWert
  • setzeKombiBoxWert
  • setzeSchreiberOrt
  • spieleWaveSchnell
  • weiterMitSchleife
  • öffneZumSchreiben
  • setzeTextschrift
  • zerstöreKombiBox
  • öffneZumAnhängen
  • beiGraphZeichen
  • GanzzahlBoxWert
  • KombiBoxAuswahl
  • SchiebereglerAn
  • setzeNamensraum
  • setzeRadioknopf
  • zurKombiBoxDazu
  • MidiGeräteInfo
  • RadioknopfWert
  • setzeSchreiber
  • Einzelschritt
  • GanzzahlBoxAn
  • listeProzedur
  • setzeLeserOrt
  • WiederholZahl
  • zähleKombiBox
  • öffneZumLesen
  • beendeteTöne
  • DateiAuswahl
  • KombiBoxWert
  • RadioknopfAn
  • setzeStartup
  • Systemaufruf
  • zähleThreads
  • liesZeichen
  • ZahlboxWert
  • beiZeichen
  • KombiBoxAn
  • liesFehler
  • listeTitel
  • Namensraum
  • setzelokal
  • tue_solang
  • unterbrich
  • wennFalsch
  • wiederhole
  • reduziere
  • versteckt
  • wennSonst
  • ZahlboxAn
  • führeAus
  • fürImmer
  • Struktur
  • wennWahr
  • Ausgabe
  • Element
  • solange
  • Textbox
  • tue_bis
  • Zahlbox
  • _Makro
  • geheZu
  • weiter
  • fange
  • Faser
  • lokal
  • poall
  • setze
  • tippe
  • Fall
  • Halt
  • pops
  • wenn
  • wirf
  • bis
  • für
  • sei
  • zu

References:

    unterbrich(16), weiterMitSchleife(16), _Makro(8), sei(7), führeAus(5), Tokenisierung(4), tippe(4), wennSonst(4), Ausgabe(3), Fall(3), ListenControlSpalte(3), ListenControlText(3), ListenControlZeile(3), beiGedrückterTasteInKombiBox(3), beiKombiBoxAuswahl(3), beiKombiBoxEingabe(3), beiKombiBoxZeichen(3), beiKombiBoxÄnderung(3), beiLosgelassenerTasteInKombiBox(3), fange(3), geheZu(3), setzeLeserOrt(3), setzeSchreiber(3), setzeSchreiberOrt(3), wenn(3), wirf(3), DateiAuswahl(2), Einzelschritt(2), Halt(2), KombiBoxAn(2), KombiBoxAuswahl(2), KombiBoxWert(2), Kommandozeilen-Schalter -run(2), Namensraum(2), Textbox(2), VerzeichnisAuswahl(2), Vorlagen-basierte Iteration(2), _vielleichtAusgabe(2), beendeteTöne(2), beiGeklicktemSchaltknopf(2), beiGeklickterAnkreuzbox(2), bis(2), entferneKombiBoxElement(2), für(2), holeFarbeVomBenutzer(2), liesZeichen(2), liesZeichenErweitert(2), listeProzedur(2), poall(2), pops(2), setzeBackslashErweiterung(2), setzeKombiBoxAuswahl(2), setzeKombiBoxElement(2), setzeKombiBoxFarbe(2), setzeKombiBoxHintergrundfarbe(2), setzeKombiBoxMöglichkeiten(2), setzeKombiBoxSchriftdicke(2), setzeKombiBoxSchriftgröße(2), setzeKombiBoxSchriftname(2), setzeKombiBoxSchriftstil(2), setzeKombiBoxWert(2), setzeNamensraum(2), solange(2), tue_bis(2), tue_solang(2), weiter(2), zerstöreKombiBox(2), zurKombiBoxDazu(2), zähleKombiBox(2), öffneZumAktualisieren(2), 16BitZahlen, Element, Faser, FloatControlDestroy, GanzzahlBoxAn, GanzzahlBoxWert, Ganzzahlen, MidiGeräteInfo, RadioknopfAn, RadioknopfWert, Reihe, SchiebereglerAn, SchiebereglerWert, SchreibBreitenGrenze, SchreibtiefenGrenze, Starten und Verlassen von Logo, Struktur, Systemaufruf, SystemaufrufAbspalten, WiederholZahl, Zahlbox, ZahlboxAn, ZahlboxWert, beiAktiviertemListenControlElement, beiAusgewähltemListenControlElement, beiAuswahlboxAuswahl, beiDoppeltgeklickterListenbox, beiFensterZeichen, beiGanzzahlBoxÄnderung, beiGedrückterTaste, beiGedrückterTasteInAuswahlbox, beiGedrückterTasteInFenster, beiGedrückterTasteInGraph, beiGedrückterTasteInListenControl, beiGedrückterTasteInListenbox, beiGedrückterTasteInTextbox, beiGeklickterListencontrolSpalte, beiGraphMausLinksDoppelKlick, beiGraphMausLinksLosgelassen, beiGraphMausMitteDoppelKlick, beiGraphMausMitteLosgelassen, beiGraphMausRechtsDoppelKlick, beiGraphZeichen, beiLinksDoppeltgeklickerMaus, beiLinksGeklickterGraphMaus, beiLinksLosgelasserMaus, beiListenboxAuswahl, beiListenboxZeichen, beiLosgelassenerTaste, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInFenster, beiLosgelassenerTasteInGraph, beiLosgelassenerTasteInListenControl, beiLosgelassenerTasteInListenbox, beiLosgelassenerTasteInTextbox, beiMitteDoppeltgeklickerMaus, beiMitteGeklickterGraphMaus, beiMitteGeklickterMaus, beiMitteLosgelasserMaus, beiRechtsDoppeltgeklickerMaus, beiRechtsLosgelasserMaus, beiSchiebereglerVerschiebung, beiTextboxEingabe, beiTextboxZeichen, beiTextboxÄnderung, beiZeichen, beiZeichenInAuswahlbox, beiZeichenInListenControl, beiÄnderungInReellerZahlbox, buglist für Version 4.65, führeAusMitAusgabe, fürImmer, holeSchriftVomBenutzer, liesFehler, listeTitel, lokal, pots, reduziere, reelleZahlen, setze, setzeGanzzahlBoxBereich, setzeGanzzahlBoxWert, setzeRadioknopf, setzeReelleZahlboxBereich, setzeReelleZahlboxWert, setzeSchiebereglerBereich, setzeSchiebereglerWert, setzeSchreibBreitenGrenze, setzeSchreibTiefenGrenze, setzeStartup, setzeTextschrift, setzelokal, spieleWaveSchnell, versteckt, wennFalsch, wennWahr, wiederhole, zerstöreGanzzahlBox, zerstöreSchieberegler, zu, zähleThreads, öffneZumAnhängen, öffneZumLesen, öffneZumSchreiben

Sender tippe


HC / Kommunikation / Sender / tippe

tippe

HC [image] Kommunikation [image] Sender [image] tippe
schreibe zeige

tippe wert
(tippe wert1 wert2...)

Kommando. Schreibt die Eingabe oder Eingaben wie schreibe, ausser dass kein Zeilenvorschub am Ende ist, und dass mehrere Eingaben nicht von Leerzeichen getrennt sind. Anmerkung: zur Konsole zu schreiben ist normalerweise "zeilengepuffert"; das heißt, die Zeichen, die Sie unter Verwendung von TIPPE schreiben, werden nicht eher auf dem Bildschirm erscheinen, bis Sie entweder einen Zeilenvorschub wird schreiben (zum Beispiel, mit SCHREIBE oder zeige) oder Logo versucht, von der Tastatur zu lesen (entweder von Ihrem Programm aus oder nach einem Befehlsprompt). Dieses Puffern macht das Programm viel schneller, als es wäre, wenn jedes Zeichen sofort erscheinen würde, und in den meisten Fällen ist das auch vorteilhaft. Um an Programme angepasst zu sein, die viel positionierten Text anzeigen unter Benützung von TIPPE, erzwingt Logo die Text-Anzeige auch, wann auch immer setzeCursor aufgerufen wird. Dies löst die meisten Pufferungsprobleme. Doch können Sie es gelegentlich notwendig finden, die gepufferten Zeichen explizit anzuzeigen; dies kann mittels des warte Befehls bewerkstelligt werden. WARTE 0 wird die Text-Anzeige erzwingen, ohne eigentlich zu warten.

Beispiele:

(tippe "Hallo "Welt)
(schreibe)		;hallowelt
(tippe [Hallo] [Welt])
(schreibe)		;HalloWelt
(tippe [Hallo][Welt!])
warte 0		;HalloWelt!

Examples:

  • beiLosgelassenerTasteInGraph
  • beiGedrückterTasteInGraph
  • TextboxÜberschreibmodus
  • öffneZumSchreibenBinär
  • TextboxEinfügemodus
  • beiGraphZeichen
  • beendeteTöne
  • _Makro
  • sei

References:

    sei(5), Release(3), Starten und Verlassen von Logo(2), TextboxEinfügemodus(2), TextboxÜberschreibmodus(2), Release Notes für Version 4.689, Tokenisierung, _Makro, beendeteTöne, beiGedrückterTasteInGraph, beiGraphZeichen, beiLosgelassenerTasteInGraph, öffneZumSchreibenBinär

schreibe zeige


HC / Kommunikation / Sender / zeige

zeige

HC [image] Kommunikation [image] Sender [image] zeige
tippe displaymatrix

zeige wert
(zeige wert1 wert2...)

Kommando. Schreibt die Eingabe oder die Eingaben wie SCHREIB, außer, dass wenn eine Eingabe eine Liste ist, sie in eckigen Klammern geschrieben wird.

Beispiel:

zeige [dies ist eine Liste]		;[dies ist ein Liste]

See also:

  • tippe

Examples:

  • beiLosgelassenerTasteInAuswahlbox
  • beiLosgelassenerTasteInKombiBox
  • setzeAuswahlboxHintergrundfarbe
  • beiGedrückterTasteInAuswahlbox
  • Release Notes für Version 4.64
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • setzeAuswahlboxMöglichkeiten
  • setzeAuswahlboxSchriftdicke
  • setzeAuswahlboxSchriftgröße
  • Vorlagen-basierte Iteration
  • ListenControlSpaltenanzahl
  • LogoBibliotheksVerzeichnis
  • setzeAuswahlboxSchriftname
  • setzeAuswahlboxSchriftstil
  • setzeKombiBoxMöglichkeiten
  • zähleListenControlElemente
  • entferneAuswahlboxElement
  • LogoTemporäresVerzeichnis
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • GroßeZahlSetzGenauigkeit
  • holeAuswahlmöglichkeiten
  • holeListenControlElement
  • LogoSchriftenVerzeichnis
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • entferneKombiBoxElement
  • holeListenControlSpalte
  • holePasswortVomBenutzer
  • beiZeichenInAuswahlbox
  • holeListenControlZeile
  • setzeAuswahlboxAuswahl
  • setzeAuswahlboxElement
  • holeListenControlWert
  • beiAuswahlboxAuswahl
  • DynamischeBibliothek
  • KammSortAufDerStelle
  • LogoHilfeVerzeichnis
  • setzeAuswahlboxFarbe
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • StatischerTextInhalt
  • beiKombiBoxÄnderung
  • holeTextVomBenutzer
  • holeZahlVomBenutzer
  • liesListeFlachZeile
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • liesListeFlachTags
  • setzeKombiBoxFarbe
  • zerstöreAuswahlbox
  • AuswahlboxAuswahl
  • entferneDuplikate
  • liesListeFlachRoh
  • setzeKombiBoxWert
  • setzeOrientierung
  • zurAuswahlboxDazu
  • ListenboxAuswahl
  • positive8BitZahl
  • TextSchriftgröße
  • zerstöreKombiBox
  • Bildschirmgröße
  • holeAuswahlZahl
  • kleinbuchstabig
  • KombiBoxAuswahl
  • setzeRollWinkel
  • zurKombiBoxDazu
  • zähleAuswahlbox
  • _setzeNächstes
  • großbuchstabig
  • liesListeFlach
  • LogoKonstanten
  • setzeMdElement
  • zähleListenbox
  • erzeugeSymbol
  • inRichtungXYZ
  • liesRoheZeile
  • offeneDateien
  • setzeElemente
  • TextboxCursor
  • WiederholZahl
  • wähleZufällig
  • zähleKombiBox
  • _setzeErstes
  • AuswahlboxAn
  • Faktorisiere
  • KombiBoxWert
  • Orientierung
  • reelleZahlen
  • setzeElement
  • setzeNeigung
  • 16BitZahlen
  • ausSchlange
  • Grundwörter
  • holeAuswahl
  • konjugieren
  • LogoComspec
  • LogoVersion
  • macroexpand
  • ohneLetztes
  • PortEingang
  • setzeGenSym
  • AbstandXYZ
  • Auswahlbox
  • BalkenWert
  • BitElement
  • Ganzzahlen
  • IgelFormen
  • inRichtung
  • inSchlange
  • kaskadiere
  • KombiBoxAn
  • liesFehler
  • LogoEditor
  • Namensraum
  • ohneErstes
  • RollWinkel
  • TextPuffer
  • 16BitZahl
  • alleErste
  • aufStapel
  • GroßeZahl
  • ladeLokal
  • listeTSHA
  • mergeSort
  • ohneErste
  • setzeKurs
  • vomStapel
  • 8BitZahl
  • ASCIIroh
  • crossmap
  • Elemente
  • entferne
  • imaginär
  • KammSort
  • listeTSH
  • Realteil
  • setzeOrt
  • verbinde
  • Abstand
  • Ausgabe
  • Dateien
  • dreheum
  • Element
  • ersetze
  • fürAlle
  • hängeAn
  • inListe
  • letztes
  • Neigung
  • Rotiere
  • rufeAuf
  • Tabelle
  • vornhin
  • wendeAn
  • erstes
  • mische
  • OrtXYZ
  • Hilfe
  • Liste
  • oder2
  • Reihe
  • xKoor
  • yKoor
  • zKoor
  • Kurs
  • oder
  • Satz
  • Wort
  • Ort
  • sei
  • und
  • `

References:

    inListe(9), 16BitZahlen(7), Ganzzahlen(7), reelleZahlen(7), verbinde(7), 16BitZahl(6), 8BitZahl(6), BitElement(6), Element(6), Reihe(6), fürAlle(6), positive8BitZahl(6), vornhin(6), KammSort(5), Vorlagen-basierte Iteration(5), hängeAn(5), sei(5), wendeAn(5), Hilfe(4), KammSortAufDerStelle(4), Liste(4), Satz(4), Wort(4), ausSchlange(4), dreheum(4), ersetze(4), holePasswortVomBenutzer(4), mische(4), vomStapel(4), Rotiere(3), TextControl(3), buglist für Version 4.65(3), entferne(3), erstes(3), holeAuswahlmöglichkeiten(3), holeTextVomBenutzer(3), kaskadiere(3), letztes(3), oder(3), ohneErstes(3), ohneLetztes(3), setzeElement(3), setzeOrt(3), und(3), ASCIIroh(2), Abstand(2), AbstandXYZ(2), Dateien(2), Elemente(2), Realteil(2), Tabelle(2), TextSchriftgröße(2), WiederholZahl(2), alleErste(2), aufStapel(2), entferneDuplikate(2), großbuchstabig(2), holeAuswahl(2), holeAuswahlZahl(2), holeListenControlZeile(2), holeZahlVomBenutzer(2), imaginär(2), inSchlange(2), kleinbuchstabig(2), konjugieren(2), mergeSort(2), oder2(2), ohneErste(2), setzeMdElement(2), wähleZufällig(2), zähleAuswahlbox(2), zähleKombiBox(2), Ausgabe, Auswahlbox, AuswahlboxAn, AuswahlboxAuswahl, BalkenWert, Bildschirmgröße, DateiAuswahl, DynamischeBibliothek, Faktorisiere, FensterVollbild, GroßeZahl, GroßeZahlSetzGenauigkeit, Grundwörter, IgelFormen, KombiBoxAn, KombiBoxAuswahl, KombiBoxWert, Kurs, ListenControlSpaltenanzahl, ListenboxAuswahl, LogoBibliotheksVerzeichnis, LogoComspec, LogoEditor, LogoHilfeVerzeichnis, LogoKonstanten, LogoSchriftenVerzeichnis, LogoTemporäresVerzeichnis, LogoVersion, Meldungsbox, Namensraum, Neigung, Orientierung, Ort, OrtXYZ, PortEingang, Release Notes für Version 4.64, Release Notes für Version 4.685, RollWinkel, StatischerTextInhalt, TextPuffer, TextboxCursor, VerzeichnisAuswahl, _Makro, _setzeErstes, _setzeNächstes, `, beendeBeschäftigt, beginneBeschäftigt, beiAuswahlboxAuswahl, beiGedrückterTasteInAuswahlbox, beiGedrückterTasteInKombiBox, beiKombiBoxAuswahl, beiKombiBoxEingabe, beiKombiBoxZeichen, beiKombiBoxÄnderung, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInKombiBox, beiZeichenInAuswahlbox, crossmap, entferneAuswahlboxElement, entferneKombiBoxElement, erzeugeSymbol, holeFarbeVomBenutzer, holeListenControlElement, holeListenControlSpalte, holeListenControlWert, holeSchriftVomBenutzer, inRichtung, inRichtungXYZ, ladeLokal, liesFehler, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesRoheZeile, listeTSH, listeTSHA, macroexpand, offeneDateien, rufeAuf, setzeAuswahlboxAuswahl, setzeAuswahlboxElement, setzeAuswahlboxFarbe, setzeAuswahlboxHintergrundfarbe, setzeAuswahlboxMöglichkeiten, setzeAuswahlboxSchriftdicke, setzeAuswahlboxSchriftgröße, setzeAuswahlboxSchriftname, setzeAuswahlboxSchriftstil, setzeElemente, setzeGenSym, setzeKombiBoxAuswahl, setzeKombiBoxElement, setzeKombiBoxFarbe, setzeKombiBoxHintergrundfarbe, setzeKombiBoxMöglichkeiten, setzeKombiBoxSchriftdicke, setzeKombiBoxSchriftgröße, setzeKombiBoxSchriftname, setzeKombiBoxSchriftstil, setzeKombiBoxWert, setzeKurs, setzeNeigung, setzeOrientierung, setzeRollWinkel, tippe, xKoor, yKoor, zKoor, zerstöreAuswahlbox, zerstöreKombiBox, zurAuswahlboxDazu, zurKombiBoxDazu, zähleListenControlElemente, zähleListenbox

tippe displaymatrix


HC / Kommunikation / Sender / displaymatrix

displaymatrix

HC [image] Kommunikation [image] Sender [image] displaymatrix
zeige Empfänger

displaymatrix (Bibliotheksprozedur)

zeigt eine Matrix in der Konsole an.

Beispiele:

displaymatrix [[1 2][3 4]]
   1.000   3.000
    2.000   4.000

displaymatrix {{1 2}{3 4}}
   1.000   3.000
   2.000   4.000

Reference:

    Release Notes für Version 4.65

zeige Empfänger


HC / Kommunikation / Empfänger

Empfänger

HC [image] Kommunikation [image] Empfänger
displaymatrix liesListe

Empfänger

...empfangen ein Datum oder mehrere Daten von der Tastatur, einer Datei oder vom Betriebssystem.

Empfänger

  • liesListe
  • liesListeFlach
  • liesListeFlachZeile
  • liesListeFlachRoh
  • liesListeFlachTags
  • liesRoheZeile
  • liesWort
  • liesZeichen
  • liesZeichenErweitert
  • liesMehrereZeichen
  • liesGanzzahlBinär
  • lies16BitZahlBinär
  • lies8BitZahlBinär
  • liesPositive8BitZahlBinär
  • liesZahlBinär
  • liesKomplexeZahlBinär
  • liesGanzzahlenBinär
  • lies16BitZahlenBinär
  • liesZahlenBinär
  • liesStrukturBinär
  • Systemaufruf
  • SystemaufrufAbspalten


HC / Kommunikation / Empfänger / liesListe

liesListe

HC [image] Kommunikation [image] Empfänger [image] liesListe
Empfänger liesListeFlach

liesListe

liest eine Zeile vom Leser-Strom (anfänglich die Konsole) und gibt diese Zeile als eine Liste aus. Die Zeile wird in Wörtern getrennt, als ob sie in eckigen Klammern in einer Anweisung getippt wurde. Wenn der Leser-Strom eine Datei ist, und das Dateiende erreicht wird, gibt LIESLISTE das leere Wort aus (nicht die leere Liste). LIESLISTE verarbeitet Backslash, vertikale Striche, und Tilden im Leser-Strom; die Ausgabe-Liste wird nicht diese Zeichen enthalten aber sie werden ihre übliche Wirkung gehabt haben. LIESLISTE behandelt allerdings Strichpunkte nicht als Kommentarzeichen.

Beispiel:

liesListe
a b c (1+2)*3		;[a b c (1+2)*3] ;-)

See also:

  • liesMehrereZeichen
  • setzeSchreiberOrt
  • setzeLeserOrt
  • Tokenisierung
  • Systemaufruf
  • liesZeichen
  • setReader
  • TasteP

Examples:

  • öffneZumAktualisieren
  • setzeSchreiberOrt
  • setzeLeserOrt

References:

    Tokenisierung(6), setzeLeserOrt(3), setzeSchreiberOrt(3), klammere(2), öffneZumAktualisieren(2), Systemaufruf, TasteP, liesMehrereZeichen, liesZeichen, setReader

Empfänger liesListeFlach


HC / Kommunikation / Empfänger / liesListeFlach

liesListeFlach

HC [image] Kommunikation [image] Empfänger [image] liesListeFlach
liesListe liesListeFlachZeile

liesListeFlach

liest eine ganze Datei vom Leser und gibt seinen Inhalt als eine große Liste aus, wobei Leerraum ignoriert wird. Dies ist hauptsächlich nützlich für Suchen in Dateien.

Beispiel:

öffneLeser "box.lg
setzeLeser "box.lg  zeige liesListeFlach
;[to box repeat 4 fd 100 rt 90 rt 30 end]
setzeLeser []
schließe "box.lg

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

liesListe liesListeFlachZeile


HC / Kommunikation / Empfänger / liesListeFlachZeile

liesListeFlachZeile

HC [image] Kommunikation [image] Empfänger [image] liesListeFlachZeile
liesListeFlach liesListeFlachRoh

liesListeFlachZeile

liest eine ganze Datei vom Leser und gibt seinen Inhalt als eine große Liste aus, wobei Leerraum ignoriert wird. Dies ist hauptsächlich nützlich für Suchen in Dateien.

Beispiel:

öffneLeser "box.lg
setzeLeser "box.lg  solange [nicht DateiZuende?][zeige liesListeFlachZeile]

Ausgabe:

[to box]
[repeat 4]
[fd 100 rt 90]
[]
[rt 30]
[end]

Vergessen Sie nicht, danach die Datei wieder zu schließen:

setzeLeser []
schließe "box.lg

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

liesListeFlach liesListeFlachRoh


HC / Kommunikation / Empfänger / liesListeFlachRoh

liesListeFlachRoh

HC [image] Kommunikation [image] Empfänger [image] liesListeFlachRoh
liesListeFlachZeile liesListeFlachTags

liesListeFlachRoh

liest eine ganze Datei vom Leser und gibt seinen Inhalt als eine große Liste aus. Dies ist hauptsächlich nützlich für das Parsen von Dateien.

Beispiel:

öffneLeser "box.lg
setzeLeser "box.lg  zeige liesListeFlachRoh

Ausgabe:

[to   box
      repeat   4
      [ 	 fd   100   rt   90
      ]
      rt   30
 end
]

Vergessen Sie nicht, danach die Datei wieder zu schließen:

setzeLeser []
schließe "box.lg

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

liesListeFlachZeile liesListeFlachTags


HC / Kommunikation / Empfänger / liesListeFlachTags

liesListeFlachTags

HC [image] Kommunikation [image] Empfänger [image] liesListeFlachTags
liesListeFlachRoh liesRoheZeile

liesListeFlachTags

liest eine ganze Datei vom Leser und gibt seinen Inhalt als eine große Liste aus. HTML- oder XML-Tags bleiben erhalten als je ein Wort, genauso der Rest dazwischen. Dies ist hauptsächlich nützlich für das Parsen von HTML- oder XML-Dateien.

Beispiel:

öffneLeser "colors_by_name.html
setzeLeser "colors_by_name.html  zeige liesListeFlachTags
[
 <html>
      <body>
           <table>
                <tbody>
                     <tr>
                     </tr>
                     <tr>
                          <td width="100" bgcolor="#F0F8FF"> </td>
                     <td> ALICEBLUE </td>
                          <td width="100" bgcolor="#FAEBD7"> </td>
                     <td> ANTIQUEWHITE </td>
                          <td width="100" bgcolor="#FFEFDB"> </td>
                     <td> ANTIQUEWHITE1 </td>
                          <td width="100" bgcolor="#EEDFCC"> </td>
                     <td> ANTIQUEWHITE2 </td>
                     </tr>
                     <tr>
                          <td width="100" bgcolor="#CDC0B0"> </td>
                     <td> ANTIQUEWHITE3 </td>
...

Vergessen Sie nicht, danach die Datei wieder zu schließen:

setzeLeser []
schließe "colors_by_name.html


HC / Kommunikation / Empfänger / liesRoheZeile

liesRoheZeile

HC [image] Kommunikation [image] Empfänger [image] liesRoheZeile
liesListeFlachTags liesWort

liesRoheZeile

liest eine ganze Zeile vom Leser und gibt seinen Inhalt als ein Wort aus, ohne es weiter zu verarbeiten.

Beispiel:

öffneLeser "box.lg
setzeLeser "box.lg  solange [nicht DateiZuende?][zeige liesRoheZeile]

Ausgabe:

to box
    repeat 4
    [	fd 100 rt 90
    ]
    rt 30
end

Vergessen Sie nicht, danach die Datei wieder zu schließen:

setzeLeser []
schließe "colors_by_name.html

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

liesListeFlachTags liesWort


HC / Kommunikation / Empfänger / liesWort

liesWort

HC [image] Kommunikation [image] Empfänger [image] liesWort
liesRoheZeile liesZeichen

liesWort

liest eine Zeile vom Leser-Strom und gibt diese Zeile als ein Wort aus. Die Ausgabe ist sogar dann ein einzelnes Wort, wenn die Zeile Leerzeichen, Klammern etc. enthält. Wenn der Leser-Strom eine Datei ist, und das Dateiende erreicht ist, gibt LIESWORT die leere Liste aus (nicht das leere Wort). LIESWORT verarbeitet Backslash, vertikale Striche und Tilden-Zeichen im Leser-Strom. Im Fall einer für Zeilenfortsetzung benutzten Tilde, schließt das Ausgabe-Wort das Tilden- und das Zeilenvorschub-Zeichen ein, so dass das Anwenderprogramm genau sagen kann, was der Benutzer eingegeben hat. Vertikale Striche in der Zeile werden auch in der Ausgabe erhalten. Backslash-Zeichen werden nicht in der Ausgabe erhalten, aber zur Darstellung des Zeichens nach dem Backslash wird 128 hinzugezählt. Programme können SchrägstrichP benutzen, um diesen Code zu überprüfen. (Backslashedness wird nur gewisse Zeichen erhalten. Siehe SCHRÄGSTRICHP.)

Beispiel:

liesWort
a b c (1+2)*3		;a b c (1+2)*3  ;-)

See also:

  • liesMehrereZeichen
  • Tokenisierung
  • Systemaufruf
  • liesZeichen

Examples:

  • öffneZumLesen
  • _Makro

References:

    Tokenisierung(6), Systemaufruf, Volltext, _Makro, klammere, liesMehrereZeichen, liesZeichen, öffneZumLesen

liesRoheZeile liesZeichen


HC / Kommunikation / Empfänger / liesZeichen

liesZeichen

HC [image] Kommunikation [image] Empfänger [image] liesZeichen
liesWort liesZeichenErweitert

liesZeichen

liest ein einzelnes Zeichen vom Leser-Strom und gibt dieses Zeichen als ein Wort aus. Wenn der Leser-Strom eine Datei ist, und das Dateiende erreicht ist, gibt LIESZEICHEN die leere Liste aus (nicht das leere Wort). Wenn der Leser-Strom eine Konsole ist, wird das Echo ausgeschaltet, wenn LIESZEICHEN aufgerufen wird, und bleibt aus bis liesListe oder liesWort aufgerufen wird oder ein Logo-Prompt geschrieben wird. Backslash, vertikale Striche und Tilden-Zeichen haben keine Sonderbedeutung in diesem Zusammenhang.

Erweiterungen: Wenn der Leser-Strom die Tastatur ist, und Sondertasten wie die Pfeiltasten oder Ziffernblock-Tasten getippt werden, dann gibt liesZeichen Zeichen 255 zurück, und ein nachfolgender Aufruf von liesZeichenErweitert gibt den erweiterten Zeichen-Wert zurück.

Beispiel:

to keyptest
    dauernd
    [	wenn taste?
        [	c=lieszeichen
            wennsonst c == zeichen 255
            [	c=liesZeichenErweitert
                (schreibe "ext c)
            ]
            [	(schreibe ASCIIroh c c)
            ]
        ]
    ]
end

Examples:

  • liesZeichenErweitert
  • öffneZumLesenBinär
  • setzeSchreiber
  • ASCIIroh

References:

    öffneZumLesenBinär(3), ASCIIroh(2), liesZeichenErweitert(2), setzeSchreiber

liesWort liesZeichenErweitert


HC / Kommunikation / Empfänger / liesZeichenErweitert

liesZeichenErweitert

HC [image] Kommunikation [image] Empfänger [image] liesZeichenErweitert
liesZeichen liesMehrereZeichen

liesZeichenErweitert liesZeichenErweitert

Wenn der Leser-Strom die Tastatur ist, und Sondertasten wie die Pfeiltasten getippt werden, dann gibt liesZeichen das Zeichen 255 und ein nachfolgender Aufruf von liesZeichenErweitert den erweiterten Zeichenwert zurück.

Ausgabe ist der erweiterte Zeichen-Wert als eine ganze Zahl.

Beispiel:

to keyptest
    dauernd
    [	wenn key?
        [	c=lieszeichen
            wennsonst c == zeichen 255
            [	c=liesZeichenErweitert
                (schreibe "ext c)
            ]
            [	(schreibe ASCIIroh c c)
            ]
        ]
    ]
end

Example:

  • liesZeichen

References:

    Release Notes für Version 4.64(2), liesZeichen(2), Release Notes für Version 4.685

liesZeichen liesMehrereZeichen


HC / Kommunikation / Empfänger / liesMehrereZeichen

liesMehrereZeichen

HC [image] Kommunikation [image] Empfänger [image] liesMehrereZeichen
liesZeichenErweitert liesGanzzahlBinär

liesMehrereZeichen num

Liest "num" Zeichen vom Leser-Strom und gibt diese Zeichen als ein Wort aus. Wenn der Leser-Strom eine Datei ist, und das Dateiende erreicht ist, gibt LIESMEHREREZEICHEN die leere Liste aus (nicht das leere wort). Wenn der Leser-Strom eine Konsole ist, wird das Echo ausgeschaltet, wenn LIESMEHREREZEICHEN aufgerufen wird, und bleibt aus bis liesListe oder liesWort aufgerufen wird oder ein Logo-Promppt geschrieben wird. Backslash, vertikale Striche und Tilden-Zeichen haben keine Sonderbedeutung in diesem Zusammenhang.


HC / Kommunikation / Empfänger / liesGanzzahlBinär

liesGanzzahlBinär

HC [image] Kommunikation [image] Empfänger [image] liesGanzzahlBinär
liesMehrereZeichen lies16BitZahlBinär

liesGanzzahlBinär

Liest eine Ganzzahl (32 Bits) vom Leser-Strom und gibt sie als eine neue Ganzzahl aus.

References:

    Release Notes für Version 4.67, setReader

liesMehrereZeichen lies16BitZahlBinär


HC / Kommunikation / Empfänger / lies16BitZahlBinär

lies16BitZahlBinär

HC [image] Kommunikation [image] Empfänger [image] lies16BitZahlBinär
liesGanzzahlBinär lies8BitZahlBinär

lies16BitZahlBinär

Liest eine Ganzzahl (16 Bits) vom Leser-Strom und gibt sie als eine neue 16BitZahl aus.

Reference:

    Release Notes für Version 4.67

liesGanzzahlBinär lies8BitZahlBinär


HC / Kommunikation / Empfänger / lies8BitZahlBinär

lies8BitZahlBinär

HC [image] Kommunikation [image] Empfänger [image] lies8BitZahlBinär
lies16BitZahlBinär liesPositive8BitZahlBinär

lies8BitZahlBinär

Liest eine Ganzzahl (8 Bits) vom Leser-Strom und gibt sie als eine neue 8BitZahl aus.

Reference:

    Release Notes für Version 4.67

lies16BitZahlBinär liesPositive8BitZahlBinär


HC / Kommunikation / Empfänger / liesPositive8BitZahlBinär

liesPositive8BitZahlBinär

HC [image] Kommunikation [image] Empfänger [image] liesPositive8BitZahlBinär
lies8BitZahlBinär liesZahlBinär

liesPositive8BitZahlBinär

Liest eine Ganzzahl (8 Bits) vom Leser-Strom und gibt sie als eine neue positive8BitZahl aus.

Reference:

    Release Notes für Version 4.67

lies8BitZahlBinär liesZahlBinär


HC / Kommunikation / Empfänger / liesZahlBinär

liesZahlBinär

HC [image] Kommunikation [image] Empfänger [image] liesZahlBinär
liesPositive8BitZahlBinär liesKomplexeZahlBinär

liesZahlBinär

Liest eine Fließkommazahl (64 Bits) vom Leser-Strom und gibt sie als eine neue Zahl aus.

Reference:

    Release Notes für Version 4.67

liesPositive8BitZahlBinär liesKomplexeZahlBinär


HC / Kommunikation / Empfänger / liesKomplexeZahlBinär

liesKomplexeZahlBinär

HC [image] Kommunikation [image] Empfänger [image] liesKomplexeZahlBinär
liesZahlBinär liesGanzzahlenBinär

liesKomplexeZahlBinär

Liest eine komplexe Fliesskommazahl (2*64 Bits) vom Leser-Strom und gibt sie als eine neue KomplexeZahl aus.

Reference:

    Release Notes für Version 4.67

liesZahlBinär liesGanzzahlenBinär


HC / Kommunikation / Empfänger / liesGanzzahlenBinär

liesGanzzahlenBinär

HC [image] Kommunikation [image] Empfänger [image] liesGanzzahlenBinär
liesKomplexeZahlBinär lies16BitZahlenBinär

liesGanzzahlenBinär Größe

Liest Größe ganzer Zahlen (Größe*32 Bits) vom Leser-Strom und gibt sie als eine neue Ganzzahlen aus.

Reference:

    Release Notes für Version 4.67

liesKomplexeZahlBinär lies16BitZahlenBinär


HC / Kommunikation / Empfänger / lies16BitZahlenBinär

lies16BitZahlenBinär

HC [image] Kommunikation [image] Empfänger [image] lies16BitZahlenBinär
liesGanzzahlenBinär liesZahlenBinär

lies16BitZahlenBinär Größe

Liest Größe ganzer Zahlen (Größe*16 Bits) vom Leser-Strom und gibt sie als eine neue 16BitGanzzahlen aus.

Example:

  • spieleWaveSchnell

References:

    Release Notes für Version 4.67, spieleWaveSchnell

liesGanzzahlenBinär liesZahlenBinär


HC / Kommunikation / Empfänger / liesZahlenBinär

liesZahlenBinär

HC [image] Kommunikation [image] Empfänger [image] liesZahlenBinär
lies16BitZahlenBinär liesStrukturBinär

liesZahlenBinär Größe

Liest Größe Fliesskomma-Zahlen (Größe*64 Bits) vom Leser-Strom und gibt sie als eine neue reelleZahlen aus.


HC / Kommunikation / Empfänger / liesStrukturBinär

liesStrukturBinär

HC [image] Kommunikation [image] Empfänger [image] liesStrukturBinär
liesZahlenBinär Systemaufruf

liesStrukturBinär astruct

Liest eine Struktur des Types astruct vom Leser-Strom und gibt sie als eine neue Struktur aus.

Example:

  • setzeSchreiber

References:

    Release Notes für Version 4.67, setzeSchreiber

liesZahlenBinär Systemaufruf


HC / Kommunikation / Empfänger / Systemaufruf

Systemaufruf

HC [image] Kommunikation [image] Empfänger [image] Systemaufruf
liesStrukturBinär SystemaufrufAbspalten

Systemaufruf befehl
(Systemaufruf befehls wordflag)

Gibt das Ergebnis der Ausführung von "befehl" als Systemaufruf aus. (Der befehl wird geschickt zu /bin/sh, Nicht csh oder andere Alternativen.) Wenn der befehl eine wörtliche Liste in der Anweisungs-Zeile ist, und wenn Sie ein Backslash-Zeichen zum Systemaufruf schicken wollen, müssen Sie benutzen um den Backslash durch der Leser des Logos intakt zu bekommen. Die Ausgabe ist eine Liste, die je ein Element für jede vom Systemaufruf Befehl erzeugte Zeile enthält. Normalerweise wird jede solche Zeile von einer Liste in der Ausgabe repräsentiert, als ob die Zeile unter Benützung von liesListe gelesen würde. Wenn eine zweite Eingabe angegeben wird, wird jedes Zeile ungeachtet des Wertes der Eingabe von einem Wort in der Ausgabe repräsentiert, als ob es mit liesWort gelesen wurde.

Beispiel:

to dir
    fürAlle ohneErstes ohneErstes ohneErstes systemaufruf [dir]
    [	wenn nicht leer? ?
        [	(schreibe letztes ? "; ohneletztes ohneErstes ohneErstes ?)
        ]
    ]
end

References:

    SystemaufrufAbspalten(2), Release Notes für Version 4.64, Release Notes für Version 4.65, Starten und Verlassen von Logo, setzeLogoComspec

liesStrukturBinär SystemaufrufAbspalten


HC / Kommunikation / Empfänger / SystemaufrufAbspalten

SystemaufrufAbspalten

HC [image] Kommunikation [image] Empfänger [image] SystemaufrufAbspalten
Systemaufruf Konsole-Funktionen

SystemaufrufAbspalten Befehl

Lässt "Befehl" als einen Systemaufruf laufen, aber im Gegensatz zu Systemaufruf sammelt es nicht die Ausgaben, und wartet nicht auf den Abschluss der Operation.

Beispiel:

setze "WebBrowser   "C:\Progra~1\Intern~1\iexplore
;	setze "WebBrowser   "C:\bin\netscape\program\netscape.exe	;als ein anderes Beispiel
setze "HTMLHelpDir   "C:\aUCBLogo\Hilfe

wenn nicht systemaufrufabspalten (liste (wort :WebBrowser "  :HTMLHelpDir " "index.frame.html))
[	schreibe [Fehler: Datei nicht gefunden]
]

Reference:

    Release Notes für Version 4.64

Systemaufruf Konsole-Funktionen


HC / Kommunikation / Konsole-Funktionen

Konsole-Funktionen

HC [image] Kommunikation [image] Konsole-Funktionen
SystemaufrufAbspalten TasteP

Konsole-Funktionen

Dies sind die Funktionen zur Steuerung der Text-Konsole.

Konsole-Funktionen

  • TasteP
  • löscheText
  • setzeCursor
  • Cursor
  • ZeichenUnterCursor
  • WortUnterCursor
  • setzeRänder
  • setzeTextfarbe
  • setzeTextschrift
  • setzeTextgröße
  • fetterTextModus
  • Normaltextmodus
  • EinfügeModus
  • Überschreibmodus
  • setzeTextauswahl
  • TextMausEreignisseAn
  • TextMausEreignisseAus
  • zeigeLogoConsolew
  • versteckeLogoConsolew
  • zeigeLogoHauptfenster
  • versteckeLogoHauptfenster
  • ladeAnsicht
  • speichereAnsicht
  • setzeBackslashErweiterung
  • SchreibtiefenGrenze
  • setzeSchreibTiefenGrenze
  • SchreibBreitenGrenze
  • setzeSchreibBreitenGrenze


HC / Kommunikation / Konsole-Funktionen / TasteP

TasteP

HC [image] Kommunikation [image] Konsole-Funktionen [image] TasteP
Konsole-Funktionen löscheText

TasteP
Taste?

Prädikat. Gibt WAHR aus, wenn es wartende, zu lesende Zeichen vom Leser-Strom gibt. Wenn der Leser-Strom eine Datei ist, ist dies gleichwertig zu nicht EOFP. Wenn der Leser-Strom die Konsole ist, wird das Echo ausgeschalten und die Konsole in den CBREAK-Modus gesetzt (zeichenweise an Stelle von zeilenweise). Sie bleibt in diesem Modus bis etwas zeilenweise gelesen wird (z. B. liesListe). Das Unix-Betriebssystem vergisst noch ausstehende Zeichen, wenn es Modi umschaltet, so dass der erste Aufruf von Taste? immer FALSCH ausgibt.


HC / Kommunikation / Konsole-Funktionen / löscheText

löscheText

HC [image] Kommunikation [image] Konsole-Funktionen [image] löscheText
TasteP setzeCursor

löscheText

Kommando. Löscht den Text der Konsole.

Example:

  • verkleinereStapel

Reference:

    verkleinereStapel

TasteP setzeCursor


HC / Kommunikation / Konsole-Funktionen / setzeCursor

setzeCursor

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeCursor
löscheText Cursor

setzeCursor Vektor

Kommando. Die Eingabe ist eine Liste zweier Zahlen, die X und Y Koordinaten einer Schirmposition (Ursprung in der oberen linken Ecke, positive Richtung ist Südosten). Die Schirm-Einfügemarke wird zur verlangten Position bewegt. Dieses Kommando erzwingt auch das unmittelbare Schreiben von gepufferten Zeichen.

Beispiele:

setzeCursor [10 3]
setzeCursor [0 0]

See also:

  • tippe

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiRechtsGeklickterTextmaus
  • beendeteTöne

References:

    beendeteTöne, beiRechtsDoppeltgeklickterTextmaus, beiRechtsGeklickterTextmaus, tippe

löscheText Cursor


HC / Kommunikation / Konsole-Funktionen / Cursor

Cursor

HC [image] Kommunikation [image] Konsole-Funktionen [image] Cursor
setzeCursor ZeichenUnterCursor

Cursor

Ausgabe ist eine Liste, die die gegenwärtigen X Und Y Koordinaten des Schirmcursors enthalten. Logo kann verwirrt werden über die gegenwärtige Einfügemarken-Position, wenn Sie z. B. eine lange Zeile tippen, die umbricht, oder Ihrem Programm entgehen Escape-Codes, die sich auf den Anschluss besonders auswirken.

Example:

  • beendeteTöne

References:

    ZeichenUnterCursor, beendeteTöne

setzeCursor ZeichenUnterCursor


HC / Kommunikation / Konsole-Funktionen / ZeichenUnterCursor

ZeichenUnterCursor

HC [image] Kommunikation [image] Konsole-Funktionen [image] ZeichenUnterCursor
Cursor WortUnterCursor

ZeichenUnterCursor

Ausgabe ist das Zeichen unter der Einfügemarke in der Text Konsole. Dies ist sehr schön für Cursor-Spiele. Siehe cursorgame.lg!

Reference:

    Release Notes für Version 4.67

Cursor WortUnterCursor


HC / Kommunikation / Konsole-Funktionen / WortUnterCursor

WortUnterCursor

HC [image] Kommunikation [image] Konsole-Funktionen [image] WortUnterCursor
ZeichenUnterCursor setzeRänder

WortUnterCursor

Ausgabe ist das Wort unter der Einfügemarke in der Text Konsole. Dies ist sehr schön für Textmodus-Menüs. Siehe die verlinkte Hilfe helpwalk.lg!

Examples:

  • beiRechtsGeklickterTextmaus
  • beiLinksGeklickterTextmaus
  • beiMitteGeklickterTextmaus

References:

    Release Notes für Version 4.672, beiLinksGeklickterTextmaus, beiMitteGeklickterTextmaus, beiRechtsGeklickterTextmaus

ZeichenUnterCursor setzeRänder


HC / Kommunikation / Konsole-Funktionen / setzeRänder

setzeRänder

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeRänder
WortUnterCursor setzeTextfarbe

setzeRänder Vektor

funktioniert noch nicht.


HC / Kommunikation / Konsole-Funktionen / setzeTextfarbe

setzeTextfarbe

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeTextfarbe
setzeRänder setzeTextschrift

setzeTextfarbe Vordergrund Hintergrund
setzeTextfarbe Vordergrund Hintergrund

Kommando. (nur Windows und DOS erweitert). Die Eingaben sind Farbzahlen wie für Igel-Grafik. Künftiges Schreiben ins Text-Fenster wird die spezifizierten Farben für Vordergrund (die gedruckten Zeichen) und Hintergrund (der freie Platz unter den Zeichen) verwenden. Wenn Sie hervorheben verwenden, wird zu den Standart-Textfenster-Farben zurückgewechselt.

Siehe auch setzeStiftfarbe und die Farbdatenbank.


HC / Kommunikation / Konsole-Funktionen / setzeTextschrift

setzeTextschrift

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeTextschrift
setzeTextfarbe setzeTextgröße

setzeTextschrift schriftName

Kommando, das die Schrift schriftName im Konsolfenster auswählt. schriftName ist ein Wort oder eine Liste von Worten.

Beispiel:

setzeTextschrift [Courier New]
schreibe [Hallo]

Reference:

    Release Notes für Version 4.64

setzeTextfarbe setzeTextgröße


HC / Kommunikation / Konsole-Funktionen / setzeTextgröße

setzeTextgröße

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeTextgröße
setzeTextschrift fetterTextModus

setzeTextgröße Größe

Kommando, das die Größe von neuem Text im Konsolfenster setzt. Größe sollte in mäßigem Bereich sein (0..600).

Beispiel:

setzeTextgröße 20

Reference:

    Release Notes für Version 4.67

setzeTextschrift fetterTextModus


HC / Kommunikation / Konsole-Funktionen / fetterTextModus

fetterTextModus

HC [image] Kommunikation [image] Konsole-Funktionen [image] fetterTextModus
setzeTextgröße Normaltextmodus

fetterTextModus

Schalter die Konsole in den Fettdruck-Modus.

Reference:

    Release Notes für Version 4.67

setzeTextgröße Normaltextmodus


HC / Kommunikation / Konsole-Funktionen / Normaltextmodus

Normaltextmodus

HC [image] Kommunikation [image] Konsole-Funktionen [image] Normaltextmodus
fetterTextModus EinfügeModus

Normaltextmodus

Schaltet den Fettdruck-Modus in der Konsole aus.

Reference:

    Release Notes für Version 4.67

fetterTextModus EinfügeModus


HC / Kommunikation / Konsole-Funktionen / EinfügeModus

EinfügeModus

HC [image] Kommunikation [image] Konsole-Funktionen [image] EinfügeModus
Normaltextmodus Überschreibmodus

EinfügeModus

Kommando. Schaltet die Konsole in den Einfüge-Modus. Siehe cursorgame.lg!

Example:

  • beendeteTöne

References:

    Release Notes für Version 4.64, beendeteTöne, reset

Normaltextmodus Überschreibmodus


HC / Kommunikation / Konsole-Funktionen / Überschreibmodus

Überschreibmodus

HC [image] Kommunikation [image] Konsole-Funktionen [image] Überschreibmodus
EinfügeModus setzeTextauswahl

Überschreibmodus

Kommando. Schalter die Konsole in den Überschreibmodus. Siehe cursorgame.lg!

Example:

  • beendeteTöne

References:

    Release Notes für Version 4.64, beendeteTöne

EinfügeModus setzeTextauswahl


HC / Kommunikation / Konsole-Funktionen / setzeTextauswahl

setzeTextauswahl

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeTextauswahl
Überschreibmodus TextMausEreignisseAn

setzeTextauswahl startposlist endposlist

Kommando. Setzt die momentane Auswahl in der Text-Konsole zu dem Bereich von startposlist zu endposlist. Die poslists sollten gültige Einfügemarken-Orte sein.

Beispiel:

setzeTextauswahl [1 1][10 1]
setzeTextauswahl [0 0][0 0]

Reference:

    Release Notes für Version 4.672

Überschreibmodus TextMausEreignisseAn


HC / Kommunikation / Konsole-Funktionen / TextMausEreignisseAn

TextMausEreignisseAn

HC [image] Kommunikation [image] Konsole-Funktionen [image] TextMausEreignisseAn
setzeTextauswahl TextMausEreignisseAus

TextMausEreignisseAn

ermöglicht automatische Verarbeitung von Mausereignissen in der Text Konsole. Dies ist der Vorgabezustand, so können Sie die Einfügemarke durch Klicken mit der Maus setzen, und Text auswählen mit der Maus.

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiRechtsGeklickterTextmaus

References:

    beiRechtsDoppeltgeklickterTextmaus, beiRechtsGeklickterTextmaus

setzeTextauswahl TextMausEreignisseAus


HC / Kommunikation / Konsole-Funktionen / TextMausEreignisseAus

TextMausEreignisseAus

HC [image] Kommunikation [image] Konsole-Funktionen [image] TextMausEreignisseAus
TextMausEreignisseAn zeigeLogoConsolew

TextMausEreignisseAus

sperrt automatische Verarbeitung von Mausereignissen in der Text Konsole. Dies kann sehr nützliche sein, wenn Sie volle Kontrolle über die Einfügemarken-Position und über Text-Auswahl brauchen, wie in textmodevalues.lg. Sie können dann nicht mehr die Einfügemarke durch Klicken mit der Maus setzen, oder Text mit der Maus auswählen.

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiRechtsGeklickterTextmaus

References:

    beiRechtsDoppeltgeklickterTextmaus, beiRechtsGeklickterTextmaus

TextMausEreignisseAn zeigeLogoConsolew


HC / Kommunikation / Konsole-Funktionen / zeigeLogoConsolew

zeigeLogoConsolew

HC [image] Kommunikation [image] Konsole-Funktionen [image] zeigeLogoConsolew
TextMausEreignisseAus versteckeLogoConsolew

zeigeLogoConsolew

Kommando, um das mit Logo assoziierte Konsole-Fenster anzuzeigen. Unter Linux ist das momentan noch nicht möglich.

Beispiel:

zeigeLogoConsolew
versteckeLogoConsolew

Example:

  • versteckeLogoConsolew

Reference:

    versteckeLogoConsolew

TextMausEreignisseAus versteckeLogoConsolew


HC / Kommunikation / Konsole-Funktionen / versteckeLogoConsolew

versteckeLogoConsolew

HC [image] Kommunikation [image] Konsole-Funktionen [image] versteckeLogoConsolew
zeigeLogoConsolew zeigeLogoHauptfenster

versteckeLogoConsolew

Kommando, um das mit Logo assoziierte Konsole-Fenster zu verstecken. Unter Linux ist das momentan noch nicht möglich.

Beispiel:

zeigeLogoConsolew
versteckeLogoConsolew

Example:

  • zeigeLogoConsolew

Reference:

    zeigeLogoConsolew

zeigeLogoConsolew zeigeLogoHauptfenster


HC / Kommunikation / Konsole-Funktionen / zeigeLogoHauptfenster

zeigeLogoHauptfenster

HC [image] Kommunikation [image] Konsole-Funktionen [image] zeigeLogoHauptfenster
versteckeLogoConsolew versteckeLogoHauptfenster

zeigeLogoHauptfenster

Kommando zum Zeigen der graphischen Benutzeroberfläche, dem Logo-Hauptfenster. Dies ist nützlich, wenn Sie Fehler in Logo-Programmen suchen, die mit dem Befehlszeilen-Schalter -nogui laufen sollen.

Beispiel:

versteckeLogoHauptfenster
zeigeLogoHauptfenster

Examples:

  • Versions-Informationen für Version 4.7
  • versteckeLogoHauptfenster

References:

    Versions-Informationen für Version 4.7, versteckeLogoHauptfenster

versteckeLogoConsolew versteckeLogoHauptfenster


HC / Kommunikation / Konsole-Funktionen / versteckeLogoHauptfenster

versteckeLogoHauptfenster

HC [image] Kommunikation [image] Konsole-Funktionen [image] versteckeLogoHauptfenster
zeigeLogoHauptfenster ladeAnsicht

versteckeLogoHauptfenster

Kommando zum Verstecken der graphischen Benutzeroberfläche, dem Logo-Hauptfenster. Dies ist nützlich, wenn Sie Fehler in Logo-Programmen suchen, die mit dem Befehlszeilen-Schalter -nogui laufen sollen.

Beispiel:

versteckeLogoHauptfenster
zeigeLogoHauptfenster

Examples:

  • Versions-Informationen für Version 4.7
  • zeigeLogoHauptfenster

References:

    Versions-Informationen für Version 4.7, zeigeLogoHauptfenster

zeigeLogoHauptfenster ladeAnsicht


HC / Kommunikation / Konsole-Funktionen / ladeAnsicht

ladeAnsicht

HC [image] Kommunikation [image] Konsole-Funktionen [image] ladeAnsicht
versteckeLogoHauptfenster speichereAnsicht

ladeAnsicht ansichtname

Kommando. Lädt die Logo-Hauptfenster-Ansicht namens ansichtname von den momentanen Einstellungen.

Beispiel:

speichereAnsicht "editscreen
ladeAnsicht "1
ladeAnsicht "editscreen

Examples:

  • Versions-Informationen für Version 4.7
  • speichereAnsicht

References:

    speichereAnsicht(2), Versions-Informationen für Version 4.7

versteckeLogoHauptfenster speichereAnsicht


HC / Kommunikation / Konsole-Funktionen / speichereAnsicht

speichereAnsicht

HC [image] Kommunikation [image] Konsole-Funktionen [image] speichereAnsicht
ladeAnsicht setzeBackslashErweiterung

speichereAnsicht ansichtname

Kommando. Speichert die Logo-Hauptfenster-Ansicht namens ansichtname in den momentanen Einstellungen.

Beispiel:

speichereAnsicht "editscreen
ladeAnsicht "1
ladeAnsicht "editscreen

Examples:

  • Versions-Informationen für Version 4.7
  • ladeAnsicht

References:

    Versions-Informationen für Version 4.7, ladeAnsicht

ladeAnsicht setzeBackslashErweiterung


HC / Kommunikation / Konsole-Funktionen / setzeBackslashErweiterung

setzeBackslashErweiterung

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeBackslashErweiterung
speichereAnsicht SchreibtiefenGrenze

setzeBackslashErweiterung einaus

Kommando. Setzt die interne Zustandsvariable, die die Erweiterung von Backslashes steuert, wenn Sie ein backslashed Wort schreiben. Nützlich, wenn Sie Logo Quellcode erstellen wollen, der einige Backslashes enthalten soll.

Beispiel:

setzeBackslashErweiterung falsch  schreibe erweitereBackslashes [a
b	c d]
a
b	c d
setzeBackslashErweiterung wahr  schreibe erweitereBackslashes [a
b	c d]
a
b	c d


HC / Kommunikation / Konsole-Funktionen / SchreibtiefenGrenze

SchreibtiefenGrenze

HC [image] Kommunikation [image] Konsole-Funktionen [image] SchreibtiefenGrenze
setzeBackslashErweiterung setzeSchreibTiefenGrenze

SchreibtiefenGrenze

gibt die Obergrenze der Schreibtiefe aus. Wenn es eine nichtnegative ganze Zahl ist, stellt es die maximale Tiefe von Unterlisten-Strukturen dar, die geschrieben werden von schreibe, etc.


HC / Kommunikation / Konsole-Funktionen / setzeSchreibTiefenGrenze

setzeSchreibTiefenGrenze

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeSchreibTiefenGrenze
SchreibtiefenGrenze SchreibBreitenGrenze

setzeSchreibTiefenGrenze Grenze

Kommando. Grenze muss eine ganze Zahl sein. Wenn Grenze eine nichtnegative ganze Zahl ist, stellt sie die maximale Tiefe von Unterlisten-Strukturen dar, die von schreibe geschrieben werden. D. h. Elemente von Elementen von ... von Elementen werden nur so weit erlaubt. Die gerade über der Grenze liegenden ausgelassenen Elemente werden durch eine Ellipse ... dargestellt, daher wird eine zu tiefe Liste mit zwei Elementen als [... ...] geschrieben.


HC / Kommunikation / Konsole-Funktionen / SchreibBreitenGrenze

SchreibBreitenGrenze

HC [image] Kommunikation [image] Konsole-Funktionen [image] SchreibBreitenGrenze
setzeSchreibTiefenGrenze setzeSchreibBreitenGrenze

SchreibBreitenGrenze

gibt die Obergrenze der Schreibbreite aus. Wenn es eine nichtnegative ganze Zahl ist, stellt es die maximale Anzahl von Elementen in einer Liste dar, die geschrieben werden von schreibe, etc.


HC / Kommunikation / Konsole-Funktionen / setzeSchreibBreitenGrenze

setzeSchreibBreitenGrenze

HC [image] Kommunikation [image] Konsole-Funktionen [image] setzeSchreibBreitenGrenze
SchreibBreitenGrenze Dateien öffnen

setzeSchreibBreitenGrenze Grenze

Kommando. Grenze muss eine ganze Zahl sein. Wenn Grenze eine nichtnegative ganze Zahl ist, stellt sie die maximale Tiefe von Unterlisten-Strukturen dar, die von schreibe geschrieben werden. Eine einzelne Ellipse ersetzt alle fehlenden Daten innerhalb der Struktur. Die Breiten-Grenze wird auch beim Schreiben in ein Wort bezüglich der Anzahl an schreibbarer Zeichen angewandt, mit der Ausnahme, dass eine Grenze zwischen 0 und 9 wie 10 behandelt wird. Diese Grenze wird nicht nur auf die äußere Datenstruktur angewandt, sondern auch auf jede Unterstruktur in ihr.


HC / Kommunikation / Dateien öffnen

Dateien öffnen

HC [image] Kommunikation [image] Dateien öffnen
setzeSchreibBreitenGrenze öffneZumLesen

Dateien öffnen

Funktionen zum Öffnen von Dateien, zum Setzen und Abfragen des Logo-Lesers und -Schreibers, sowie eine Abfrage, welche Dateien gerade offen sind.

Dateien öffnen

  • öffneZumLesen
  • öffneZumLesenBinär
  • öffneZumSchreiben
  • öffneZumSchreibenBinär
  • öffneZumAnhängen
  • öffneZumAnhängenBinär
  • öffneZumAktualisieren
  • öffneZumAktualisierenBinär
  • Protokolliere
  • offeneDateien
  • setReader
  • setzeSchreiber
  • Leser
  • Schreiber


HC / Kommunikation / Dateien öffnen / öffneZumLesen

öffneZumLesen

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumLesen
Dateien öffnen öffneZumLesenBinär

öffneZumLesen Dateiname

Kommando. Öffnet die angegebene Datei zum Lesen. Der Leser-Ort ist zunächst am Anfang der Datei.

Beispiel:

öffneZumLesen "tree.lg
setReader "tree.lg
solange [nicht dateiende?] [schreibe liesWort]

Dessen Ausgabe ist:

to tree [level 7][size 100]
    wenn level==0 [stop]
    vorwärts size
    links 80
    tree2 level-1 size/2
    rechts 70
    (tree level-1 size*2/3)
    rechts 90
    tree2 level-1 size/2
    links 80
    zurück size
end size

to tree2 level size
    wenn level==0 [stop]
    vorwärts size
    rechts 80
    (tree level-1 size/2)
    links 70
    tree2 level-1 size*2/3
    links 90
    (tree level-1 size/2)
    rechts 40
    (tree level-1 size*4/5)
    rechts 40
    zurück size
end size

Dann können Sie fragen:

LeserPosition		;387  ;-)

Examples:

  • setzeSchreiberOrt
  • offeneDateien
  • setzeLeserOrt
  • DateiGröße
  • Schließe

References:

    setReader(2), DateiGröße, Schließe, offeneDateien, setzeLeserOrt, setzeSchreiberOrt

Dateien öffnen öffneZumLesenBinär


HC / Kommunikation / Dateien öffnen / öffneZumLesenBinär

öffneZumLesenBinär

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumLesenBinär
öffneZumLesen öffneZumSchreiben

öffneZumLesenBinär Dateibezeichnung

Kommando. Öffnet die angegebene Datei zum binären Lesen. Die Leserposition ist zunächst am Anfang der Datei.

Beispiel:

to loadpalette file
    lokal [mypal]
    mypal=reihe 2^8
    öffneZumLesenBinär file
    setReader file
    solange [nicht dateiende?]
    [	mypal.repcount=(rgb
            (ASCIIroh liesZeichen)/2^8
            (ASCIIroh liesZeichen)/2^8
            (ASCIIroh liesZeichen)/2^8)
    ]
    schließe file
    setReader []
    output mypal
end
loadpalette "topograf.pal

Example:

  • spieleWaveSchnell

Reference:

    spieleWaveSchnell

öffneZumLesen öffneZumSchreiben


HC / Kommunikation / Dateien öffnen / öffneZumSchreiben

öffneZumSchreiben

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumSchreiben
öffneZumLesenBinär öffneZumSchreibenBinär

öffneZumSchreiben Dateibezeichnung

Kommando. Öffnet die angegebene Datei zum Schreiben. Wenn die Datei schon existierte, wird die alte Version gelöscht und eine neue, leere Datei erzeugt.

Beispiel:

öffneZumSchreiben "temp.txt
setzeSchreiber "temp.txt
schreibe [Dies ist eine Testdatei!]
setzeSchreiber []
schließe "temp.txt

Und die Datei "temp.txt" enthält dann die Zeile:

    Dies ist eine Testdatei!

See also:

  • setzeSchreiber
  • Protokolliere

Examples:

  • öffneZumSchreibenBinär
  • setzeSchreiberOrt
  • setzeSchreiber
  • setzeLeserOrt
  • speichere

References:

    setzeSchreiber(2), Protokolliere, setzeLeserOrt, setzeSchreiberOrt, speichere, öffneZumSchreibenBinär

öffneZumLesenBinär öffneZumSchreibenBinär


HC / Kommunikation / Dateien öffnen / öffneZumSchreibenBinär

öffneZumSchreibenBinär

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumSchreibenBinär
öffneZumSchreiben öffneZumAnhängen

öffneZumSchreibenBinär Dateibezeichnung

Kommando. Öffnet die angegebene Datei zum binären Schreiben. Wenn die Datei schon existierte, wird die alte Version gelöscht und eine neue, leere Datei erzeugt.

Beispiel:

öffneZumSchreiben "temp.txt
setzeSchreiber "temp.txt
wiederhole 256 [tippe zeichen repcount]
setzeSchreiber []
schließe "temp.txt

Und die Datei "temp.txt" sollte dann alle 256 ASCII-Zeichen enthalten.


HC / Kommunikation / Dateien öffnen / öffneZumAnhängen

öffneZumAnhängen

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumAnhängen
öffneZumSchreibenBinär öffneZumAnhängenBinär

öffneZumAnhängen Dateibezeichnung

Kommando. Öffnet die angegebene Datei zum Schreiben. Wenn die Datei schon existiert, wird die Schreibposition zuerst auf das Ende der alten Datei gesetzt, so dass neu geschriebene Daten daran angehängt werden.

Beispiel:

öffneZumAnhängen "temp.txt
setzeSchreiber "temp.txt
schreibe [und eine Zeile mehr]
schließe "temp.txt
schreiber		;[temp.txt] ;-)
setzeSchreiber []

Und "temp.txt" mag dies enthalten:

Dies ist eine Testdatei!
und eine Zeile mehr

See also:

  • setzeSchreiber

References:

    setzeSchreiber, öffneZumAnhängenBinär

öffneZumSchreibenBinär öffneZumAnhängenBinär


HC / Kommunikation / Dateien öffnen / öffneZumAnhängenBinär

öffneZumAnhängenBinär

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumAnhängenBinär
öffneZumAnhängen öffneZumAktualisieren

öffneZumAnhängenBinär Dateibezeichnung

Kommando. Öffnet die angegebene Datei zum binären Schreiben. Wenn die Datei schon existiert, wird die Schreibposition zuerst auf das Ende der alten Datei gesetzt, so dass neu geschriebene Daten daran angehängt werden.

Siehe öffneZumAnhängen!


HC / Kommunikation / Dateien öffnen / öffneZumAktualisieren

öffneZumAktualisieren

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumAktualisieren
öffneZumAnhängenBinär öffneZumAktualisierenBinär

öffneZumAktualisieren Dateibezeichnung

Kommando. Öffnet die angegebene Datei für Lesen und Schreiben. Die Lese- und Schreibposition wird zunächst zum Ende der alten Datei gesetzt, wenn sie existiert. Anmerkung: jede offene Datei hat nur eine Position, sowohl für Lesen als auch Schreiben. Wenn eine für Aktualisierung aufgemachte Datei sowohl Leser als auch Schreiber gleichzeitig ist, wird sich setzeLeserOrt dann auch auf SchreiberOrt und umgekehrt auswirken. Auch, wenn Sie zwischen Lesen und Schreiben hinundherwechseln, müssen Sie setzeSchreiberOrt zwischen einem Schreib- und einem Lesevorgang und SETZESCHREIBERORT zwischen einem Lese- und einem Schreibvorgang aufrufen.

Beispiel:

öffneZumAktualisieren "temp.txt
setReader "temp.txt
schreibe liesliste		;Dies ist eine Testdatei!
schreibe liesliste		;und eine Zeile mehr
setReader []
schließe "temp.txt

See also:

  • setzeSchreiber

References:

    setReader, setzeSchreiber, öffneZumAktualisierenBinär

öffneZumAnhängenBinär öffneZumAktualisierenBinär


HC / Kommunikation / Dateien öffnen / öffneZumAktualisierenBinär

öffneZumAktualisierenBinär

HC [image] Kommunikation [image] Dateien öffnen [image] öffneZumAktualisierenBinär
öffneZumAktualisieren Protokolliere

öffneZumAktualisierenBinär Dateibezeichnung

Kommando. Öffnet die angegebene Datei für binäres Lesen und Schreiben. Die Lese- und Schreibposition wird zunächst zum Ende der alten Datei gesetzt, wenn sie existiert. Anmerkung: jede offene Datei hat nur eine Position, sowohl für Lesen als auch Schreiben. Wenn eine für Aktualisierung aufgemachte Datei sowohl Leser als auch Schreiber gleichzeitig ist, wird sich setzeLeserOrt dann auch auf SchreiberOrt und umgekehrt auswirken. Auch, wenn Sie zwischen Lesen und Schreiben hinundherwechseln, müssen Sie setzeSchreiberOrt zwischen einem Schreib- und einem Lesevorgang und SETZESCHREIBERORT zwischen einem Lese- und einem Schreibvorgang aufrufen. Siehe öffneZumAktualisieren!


HC / Kommunikation / Dateien öffnen / Protokolliere

Protokolliere

HC [image] Kommunikation [image] Dateien öffnen [image] Protokolliere
öffneZumAktualisierenBinär offeneDateien

Protokolliere Dateibezeichnung

Kommando. Erzeugt eine neue Datei, deren Name die Eingabe ist, wie öffneZumSchreiben, und beginnt in dieser Datei alles zu protokollieren, das von der Tastatur gelesen oder zur Konsole geschrieben wird. Das heißt, dieses Schreiben geschieht zusätzlich zum Schreiben in den Schreiber. Die Absicht ist, eine Mitschrift von einer Logo-Sitzung, einschließlich Dingen wie Prompt-Zeichen und Interaktionen zu erstellen.

Beispiel:

protokolliere "temp.txt
callttt

Dann spielen Sie Tic-Tac-Toe und führen aus:

nichtProtokollieren

Danach sollte eine Mitschrift des Spiels in der Datei "temp.txt" sein.


HC / Kommunikation / Dateien öffnen / offeneDateien

offeneDateien

HC [image] Kommunikation [image] Dateien öffnen [image] offeneDateien
Protokolliere setReader

offeneDateien

Ausgabe ist eine Liste, deren Elemente die Namen aller momentan offnenen Dateien sind. Dieses Liste schließt nicht die Protokollier-Datei ein, wenn es eine gibt.

Beispiel:

öffneZumLesen "temp.txt
zeige offeneDateien		;[temp.txt]
schließe "temp.txt

Reference:

    closeall

Protokolliere setReader


HC / Kommunikation / Dateien öffnen / setReader

setReader

HC [image] Kommunikation [image] Dateien öffnen [image] setReader
offeneDateien setzeSchreiber

setReader Dateibezeichnung
setReader einintarray
setReader einint16array

Kommando. Macht die genannte Datei, einintarray oder einint16array zum Leser-Strom, für liesListe verwendet, etc. Die Datei muss schon geöffnet worden sein mit öffneZumLesen oder öffneZumAktualisieren. Wenn die Eingabe die leere Liste ist, dann wird der Lesestrom wie gewöhnlich die Konsole. Ändern des Lesestroms schließt die Datei nicht, die vorher der Lesestrom war, so ist es möglich, zwischen Dateien zu hin und her zu wechseln.

Siehe auch: öffneZumLesen, setzeSchreiber, liesGanzzahlBinär

Examples:

  • öffneZumAktualisieren
  • öffneZumLesenBinär
  • spieleWaveSchnell
  • setzeSchreiber
  • öffneZumLesen

References:

    setzeSchreiber(2), spieleWaveSchnell(2), öffneZumAktualisieren(2), öffneZumLesenBinär(2), öffneZumLesen

offeneDateien setzeSchreiber


HC / Kommunikation / Dateien öffnen / setzeSchreiber

setzeSchreiber

HC [image] Kommunikation [image] Dateien öffnen [image] setzeSchreiber
setReader Leser

setzeSchreiber Dateibezeichnung
setzeSchreiber einintarray
setzeSchreiber einint16array

Kommando. Macht die genannte Datei, einintarray oder einint16array zum Schreib-Strom, der für SCHREIB, etc. verwendet wird. Die Datei muss schon geöffnet sein mit öffneZumSchreiben, öffneZumAnhängen, oder öffneZumAktualisieren. Wenn die Eingabe die leere Liste ist, dann wird der Schreib-Strom die Konsole, wie gewöhnlich. Den Schreibstrom zu ändern schließt nicht die Datei, die früher der Schreibstrom war, so ist es möglich zwischen Dateien hin- und herzuwechseln. Um auf einintarray oder einint16array zu schreiben, brauchen Sie diese nicht zu öffnen.

Beispiele:

öffneZumSchreiben "temp.txt
setzeSchreiber "temp.txt
schreibe [This is a temp file]
setzeSchreiber []
schließe "temp.txt

to makewav3
    rate=44100
    size=rate
    wavHeaderType=(liste
        [ChunkID Wort RIFF]
        [wavfilesize Ganzzahl]
        [RIFFtype Wort 4]	;the letztes element is the string length

        [formatChunkID Wort fmt ]
        [formatChunkSize Ganzzahl 16]
        [compressionCode 16BitZahl 1]
        [NumberOfChannels 16BitZahl 1]
        (liste "SampleRate "Ganzzahl rate)
        (liste "BytesPerSecond "Ganzzahl rate*2)
        [BlockAlign 16BitZahl 2]
        [BitsPerSample 16BitZahl 16]

        [DataChunkID wort data]
        (liste "DataChunkSize "Ganzzahl size*2)
    )
    wavHeader=struktur wavHeaderType
    wavsize=(GrößeVon wavHeader)+size*2
    wavHeader'RIFFtype=[WAVE]	;example für setting a string
    wavHeader'wavfilesize=wavsize
    schreibe wavHeader
    wav=16BitZahlen ganzzahl wavsize/2
    setzeSchreiber wav
    tippeBinär wavHeader
    wiederhole size
    [	phi=360*repcount/rate
        tippebinär 16BitZahl 16383*( (sinus 40*phi)
                            - (sinus 41*phi) )
    ]
    setzeSchreiber []
    setReader wav
    wh=liesStrukturBinär wavHeaderType
    schreibe wh
    setReader []
    spieleWave wav 1+8
    ignoriere liesZeichen
    spieleWave [] 0
end

Examples:

  • öffneZumSchreibenBinär
  • setzeSchreiberOrt
  • öffneZumSchreiben
  • öffneZumAnhängen
  • setzeLeserOrt
  • speichere

References:

    setzeLeserOrt(2), setzeSchreiberOrt(2), speichere(2), öffneZumAnhängen(2), öffneZumSchreiben(2), öffneZumSchreibenBinär(2), 16BitZahlen, Ganzzahlen, setReader

setReader Leser


HC / Kommunikation / Dateien öffnen / Leser

Leser

HC [image] Kommunikation [image] Dateien öffnen [image] Leser
setzeSchreiber Schreiber

Leser

Ausgabe ist der Name der gegenwärtigen Leserstromdatei, oder die leere Liste, wenn der Leser-Strom die Konsole ist.

See also:

  • öffneZumAktualisierenBinär
  • öffneZumAktualisieren

References:

    liesZeichen(4), TasteP(3), liesListe(3), liesMehrereZeichen(3), liesWort(3), Systemaufruf, lies16BitZahlBinär, lies16BitZahlenBinär, lies8BitZahlBinär, liesGanzzahlBinär, liesGanzzahlenBinär, liesKomplexeZahlBinär, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesPositive8BitZahlBinär, liesRoheZeile, liesStrukturBinär, liesZahlBinär, liesZahlenBinär, liesZeichenErweitert, setReader, setzeLeserOrt, setzeLogoBibliotheksVerzeichnis, setzeSchreiberOrt, öffneZumAktualisieren, öffneZumAktualisierenBinär, öffneZumLesen

setzeSchreiber Schreiber


HC / Kommunikation / Dateien öffnen / Schreiber

Schreiber

HC [image] Kommunikation [image] Dateien öffnen [image] Schreiber
Leser Datei-Zugriff

Schreiber

Ausgabe ist der Name der momentanen Schreibstrom-Datei, oder die leere Liste, wenn der Schreiber-Strom die Konsole ist.

See also:

  • öffneZumAktualisierenBinär
  • öffneZumAktualisieren

Examples:

  • öffneZumAnhängen
  • speichere

References:

    Protokolliere, Sender, schreibe, setzeSchreiberOrt, speichere, öffneZumAktualisieren, öffneZumAktualisierenBinär, öffneZumAnhängen

Leser Datei-Zugriff


HC / Kommunikation / Datei-Zugriff

Datei-Zugriff

HC [image] Kommunikation [image] Datei-Zugriff
Schreiber Schließe

Datei-Zugriff

Hier sind Funktionen zum Arbeiten mit Dateien.

Datei-Zugriff

  • Schließe
  • closeall
  • löscheDatei
  • DateiUmbenennen
  • nichtProtokollieren
  • setzeLeserOrt
  • setzeSchreiberOrt
  • LeserOrt
  • SchreiberOrt
  • DateiendeP
  • DateiGröße
  • DateiZeit
  • DateiP
  • loadpalette


HC / Kommunikation / Datei-Zugriff / Schließe

Schließe

HC [image] Kommunikation [image] Datei-Zugriff [image] Schließe
Datei-Zugriff closeall

Schließe Dateibezeichnung

Kommando. Schliesst die genannte Datei.

Beispiel:

öffneZumLesen "temp.txt
schließe "temp.txt

Examples:

  • öffneZumSchreibenBinär
  • öffneZumAktualisieren
  • liesListeFlachZeile
  • liesListeFlachTags
  • öffneZumLesenBinär
  • liesListeFlachRoh
  • setzeSchreiberOrt
  • spieleWaveSchnell
  • öffneZumSchreiben
  • öffneZumAnhängen
  • liesListeFlach
  • setzeSchreiber
  • liesRoheZeile
  • offeneDateien
  • setzeLeserOrt
  • DateiGröße
  • speichere

References:

    setzeLeserOrt(2), setzeSchreiberOrt(2), DateiGröße, Release Notes für Version 4.685, closeall, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesRoheZeile, offeneDateien, setzeSchreiber, speichere, spieleWaveSchnell, öffneZumAktualisieren, öffneZumAnhängen, öffneZumLesenBinär, öffneZumSchreiben, öffneZumSchreibenBinär

Datei-Zugriff closeall


HC / Kommunikation / Datei-Zugriff / closeall

closeall

HC [image] Kommunikation [image] Datei-Zugriff [image] closeall
Schließe löscheDatei

closeall (Bibliotheksprozedur)

Kommando. Schliesst alle offenen Dateien. Die ist eine Abkürzung für

    fürAlle offeneDateien [schließe ?]


HC / Kommunikation / Datei-Zugriff / löscheDatei

löscheDatei

HC [image] Kommunikation [image] Datei-Zugriff [image] löscheDatei
closeall DateiUmbenennen

löscheDatei Dateibezeichnung

Kommando. Löscht (streicht, entfernt) die genannte Datei, die momentan nicht offen sein sollte.

Beispiel:

löscheDatei "temp.txt

Reference:

    Löschen

closeall DateiUmbenennen


HC / Kommunikation / Datei-Zugriff / DateiUmbenennen

DateiUmbenennen

HC [image] Kommunikation [image] Datei-Zugriff [image] DateiUmbenennen
löscheDatei nichtProtokollieren

DateiUmbenennen Dateiname

Kommando. Benennt die genannte Datei, die momentan nicht offen sein sollte, um.

Beispiel:

DateiUmbenennen "t.ifs "d.ifs
DateiUmbenennen "d.ifs "t.ifs	;um es wieder rückgängig zu machen

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

löscheDatei nichtProtokollieren


HC / Kommunikation / Datei-Zugriff / nichtProtokollieren

nichtProtokollieren

HC [image] Kommunikation [image] Datei-Zugriff [image] nichtProtokollieren
DateiUmbenennen setzeLeserOrt

nichtProtokollieren

Kommando. Stoppt das Kopieren von Information in die Protokollier-Datei, und schließt die Datei.

Example:

  • Protokolliere

Reference:

    Protokolliere

DateiUmbenennen setzeLeserOrt


HC / Kommunikation / Datei-Zugriff / setzeLeserOrt

setzeLeserOrt

HC [image] Kommunikation [image] Datei-Zugriff [image] setzeLeserOrt
nichtProtokollieren setzeSchreiberOrt

setzeLeserOrt zeichenpos

Kommando. Setzt den Dateizeiger der Leserdatei so der daß die nächste liesListe, etc., am Zeichen Nummer zeichenpos in der Datei anfängt zu lesen, von 0 zählend. (Das heißt, SETZELESERORT 0 setzt den Dateizeiger auf den Anfang der Datei.) Sinnlos wenn der Leser die Konsole ist.

Beispiel:

öffneZumSchreiben "temp.txt
setzeSchreiber "temp.txt
schreibe [This is a temp file]
setzeSchreiber []
schließe "temp.txt

öffneZumLesen "temp.txt
setzeLeser "temp.txt
schreibe liesListe		;Dies ist eine Tempdatei
setzeSchreiberOrt 6
schreibe liesListe		;st eine Tempdatei
LeserPosition		;24  ;-)
schließe "temp.txt
setzeLeser []

See also:

  • öffneZumAktualisierenBinär
  • öffneZumAktualisieren

References:

    öffneZumAktualisieren, öffneZumAktualisierenBinär

nichtProtokollieren setzeSchreiberOrt


HC / Kommunikation / Datei-Zugriff / setzeSchreiberOrt

setzeSchreiberOrt

HC [image] Kommunikation [image] Datei-Zugriff [image] setzeSchreiberOrt
setzeLeserOrt LeserOrt

setzeSchreiberOrt zeichenpos

Kommando. Setzt den Dateizeiger der Schreiber-Datei, so daß die nächste liesListe, etc., am Zeichen Nummer zeichenpos in der Datei anfängt zu schreiben, von 0 zählend. (Das heißt, SETZESCHREIBERORT 0 setzt den Dateizeiger auf den Anfang der Datei.) Sinnlos wenn der Leser die Konsole ist.

Beispiel:

öffneZumSchreiben "temp.txt
setzeSchreiber "temp.txt
schreibe [Dies ist eine Tempdatei]
setzeSchreiber []
schließe "temp.txt

öffneZumLesen "temp.txt
setzeLeser "temp.txt
schreibe liesListe		;Dies ist eine Tempdatei
setzeSchreiberOrt 6
schreibe liesListe		;st eine Tempdatei
LeserPosition		;24  ;-)
schließe "temp.txt
setzeLeser []

See also:

  • öffneZumAktualisierenBinär
  • öffneZumAktualisieren

Example:

  • setzeLeserOrt

References:

    öffneZumAktualisieren(2), öffneZumAktualisierenBinär(2), setzeLeserOrt

setzeLeserOrt LeserOrt


HC / Kommunikation / Datei-Zugriff / LeserOrt

LeserOrt

HC [image] Kommunikation [image] Datei-Zugriff [image] LeserOrt
setzeSchreiberOrt SchreiberOrt

LeserOrt

Ausgabe ist die Dateiposition der momentanen Leserstromdatei.


HC / Kommunikation / Datei-Zugriff / SchreiberOrt

SchreiberOrt

HC [image] Kommunikation [image] Datei-Zugriff [image] SchreiberOrt
LeserOrt DateiendeP

SchreiberOrt

Ausgabe ist die Dateiposition der momentanen Schreibstrom-Datei.

See also:

  • öffneZumAktualisierenBinär
  • öffneZumAktualisieren

References:

    öffneZumAktualisieren, öffneZumAktualisierenBinär

LeserOrt DateiendeP


HC / Kommunikation / Datei-Zugriff / DateiendeP

DateiendeP

HC [image] Kommunikation [image] Datei-Zugriff [image] DateiendeP
SchreiberOrt DateiGröße

DateiendeP
Dateiende?

Abfrage. Gibt wahr aus, wenn es keine zu lesenden Zeichen mehr in der Leserstromdatei gibt, sonst falsch.


HC / Kommunikation / Datei-Zugriff / DateiGröße

DateiGröße

HC [image] Kommunikation [image] Datei-Zugriff [image] DateiGröße
DateiendeP DateiZeit

DateiGröße Dateibezeichnung

Ausgabe ist die Größe der genannten Datei. Die Datei muss offen sein.

Beispiel:

öffnezumlesen "bounce3.lg
dateigröße "bounce3.lg	;3784  ;-)
schließe "bounce3.lg

Example:

  • spieleWaveSchnell

References:

    Release Notes für Version 4.67, spieleWaveSchnell

DateiendeP DateiZeit


HC / Kommunikation / Datei-Zugriff / DateiZeit

DateiZeit

HC [image] Kommunikation [image] Datei-Zugriff [image] DateiZeit
DateiGröße DateiP

DateiZeit Dateibezeichnung

Ausgabe ist der Änderungszeitpunkt der genannten Datei in der folgenden Liste: [Stunden Minuten Sekunden Millisekunden Wochentag Tag Monat Jahr]

Beispiel:

DateiZeit "bounce3.lg

References:

    Release Notes für Version 4.683, Release Notes für Version 4.685

DateiGröße DateiP


HC / Kommunikation / Datei-Zugriff / DateiP

DateiP

HC [image] Kommunikation [image] Datei-Zugriff [image] DateiP
DateiZeit loadpalette

DateiP Dateibezeichnung
Datei? Dateibezeichnung

Abfrage. Ausgabe ist wahr, wenn eine Datei des spezifizierten Namens existiert und gelesen werden kann, sonst falsch.

Beispiele:

DateiP "bounce.lg		;wahr  ;-)
DateiP "csls			;falsch  ;-)

Reference:

    Release Notes für Version 4.685

DateiZeit loadpalette


HC / Kommunikation / Datei-Zugriff / loadpalette

loadpalette

HC [image] Kommunikation [image] Datei-Zugriff [image] loadpalette
DateiP Datei-Verzeichnisse

loadpalette palname

Operation, die ein Reihe von 256 Ganzzahlen ausgibt, die die Rgb Farben der Palettendatei Palname repräsentieren.

Beispiel:

topograf=loadpalette "topograf.pal
setzeStiftdicke [10 10]
wiederhole 256 [
    setzeStiftfarbe topograf.repcount
    vorwärts 1
]

Example:

  • öffneZumLesenBinär

Reference:

    öffneZumLesenBinär(2)

DateiP Datei-Verzeichnisse


HC / Kommunikation / Datei-Verzeichnisse

Datei-Verzeichnisse

HC [image] Kommunikation [image] Datei-Verzeichnisse
loadpalette Dateien

Datei-Verzeichnisse

Hier sind Funktionen zum Auflisten, Wechseln, Erzeugen und Abfragen von Datei-Verzeichnissen zusammengefaßt.

Datei-Verzeichnisse

  • Dateien
  • dir
  • dirlg
  • liesArbeitsVerzeichnis
  • wechsleVerzeichnis
  • neuesVerzeichnis
  • VerzeichnisP


HC / Kommunikation / Datei-Verzeichnisse / Dateien

Dateien

HC [image] Kommunikation [image] Datei-Verzeichnisse [image] Dateien
Datei-Verzeichnisse dir

Ausgabe ist eine Liste von Dateien,
die das aktuellen Arbeitsverzeichnis unter Berücksichtigung der Wildcards filespec enthält.

filespec ist ein String, der Platzhalter enthalten darf.

schalter darf eine Kombination sein von:

wxdir_files schließt Dateien ein

wxdir_dirs schließt Verzeichnisse ein

wxdir_hidden schließt versteckte Dateien ein

wxdir_dotdot schließt '.' und '..' ein.

Beispiele:

zeige Dateien
;...
zeige (Dateien [a*.lg] wxdir_files)
;[am.lg am2.lg ant.lg ant2.lg arc2test.lg axes.lg]

References:

    Release Notes für Version 4.685(3), Dateien öffnen(2), 16BitZahl, 8BitZahl, Datei-Zugriff, DateiAuswahl, Einführung in die Logo-Programmierung, Hilfe, Kommandozeilen-Schalter -run, LogoHilfeVerzeichnis, LogoTemporäresVerzeichnis, Release Notes für Version 4.68, Release Notes für Version 4.686, Starten und Verlassen von Logo, closeall, dirlg, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, offeneDateien, positive8BitZahl, setReader, setzeLogoHilfeVerzeichnis, setzeLogoTemporäresVerzeichnis, setzeSchreiber

Datei-Verzeichnisse dir


HC / Kommunikation / Datei-Verzeichnisse / dir

dir

HC [image] Kommunikation [image] Datei-Verzeichnisse [image] dir
Dateien dirlg

dir (Bibliotheksprozedur)

Kommando. Schreibt die Datei-Liste des gegenwärtigen Arbeitsdateiverzeichnisses, unter Verwendung der Ausgabe eines Betriebssystemaufrufes.

Example:

  • Systemaufruf

References:

    Release Notes für Version 4.65(2), Systemaufruf(2), Release Notes für Version 4.685

Dateien dirlg


HC / Kommunikation / Datei-Verzeichnisse / dirlg

dirlg

HC [image] Kommunikation [image] Datei-Verzeichnisse [image] dirlg
dir liesArbeitsVerzeichnis

dirlg (Bibliotheksprozedur)

Kommando. Schreibt die Logo-Dateien-Liste des aktuellen Arbeitsverzeichnisses, unter Verwendung der Ausgabe eines Betriebssystemaufrufes. Dies ist ein sehr nützlicher Kommando, um die *.lg Beispiele anschauen zu können.

Reference:

    Release Notes für Version 4.65(2)

dir liesArbeitsVerzeichnis


HC / Kommunikation / Datei-Verzeichnisse / liesArbeitsVerzeichnis

liesArbeitsVerzeichnis

HC [image] Kommunikation [image] Datei-Verzeichnisse [image] liesArbeitsVerzeichnis
dirlg wechsleVerzeichnis

liesArbeitsVerzeichnis

Ausgabe ist das aktuelle Arbeitsverzeichnis.

Beispiel:

liesArbeitsVerzeichnis		;C:\aucblogo  ;-)

Reference:

    Release Notes für Version 4.685

dirlg wechsleVerzeichnis


HC / Kommunikation / Datei-Verzeichnisse / wechsleVerzeichnis

wechsleVerzeichnis

HC [image] Kommunikation [image] Datei-Verzeichnisse [image] wechsleVerzeichnis
liesArbeitsVerzeichnis neuesVerzeichnis

wechsleVerzeichnis Pfad
wechsleVerzeichnis Pfad

Kommando, das das aktuelle Arbeitsverzeichnis zu Pfad wechselt.

Beispiele:

wechsleVerzeichnis "csls
ttt
wechsleVerzeichnis "..
bounce

Reference:

    Release Notes für Version 4.65(2)

liesArbeitsVerzeichnis neuesVerzeichnis


HC / Kommunikation / Datei-Verzeichnisse / neuesVerzeichnis

neuesVerzeichnis

HC [image] Kommunikation [image] Datei-Verzeichnisse [image] neuesVerzeichnis
wechsleVerzeichnis VerzeichnisP

neuesVerzeichnis dirname

Kommando, das ein neues Verzeichnis namens dirname im aktuellen Arbeitsverzeichnis anlegt.

Beispiele:

neuesVerzeichnis [TestDir]
neuesVerzeichnis "testdir2

Reference:

    Release Notes für Version 4.685

wechsleVerzeichnis VerzeichnisP


HC / Kommunikation / Datei-Verzeichnisse / VerzeichnisP

VerzeichnisP

HC [image] Kommunikation [image] Datei-Verzeichnisse [image] VerzeichnisP
neuesVerzeichnis Umgebung

VerzeichnisP dirname
Verzeichnis? dirname

Ausgabe ist wahr, wenn das dirname genannte Verzeichnis existiert.

Beispiele:

Verzeichnis? "csls		;wahr  ;-)
Verzeichnis? "bounce.lg	;falsch  ;-)

Reference:

    Release Notes für Version 4.685

neuesVerzeichnis Umgebung


HC / Kommunikation / Umgebung

Umgebung

HC [image] Kommunikation [image] Umgebung
VerzeichnisP setzeUmgebung

Umgebung

Um die Logo-Umgebung anpassen zu können, können die wichtigsten Datei-Pfade geändert und gelesen werden:

Umgebung

  • setzeUmgebung
  • liesUmgebung
  • liesUmgebungstabelle
  • LogoComspec
  • setzeLogoComspec
  • LogoEditor
  • setzeLogoEditor
  • LogoSchriftenVerzeichnis
  • setzeLogoSchriftenVerzeichnis
  • LogoHilfeVerzeichnis
  • setzeLogoHilfeVerzeichnis
  • LogoBibliotheksVerzeichnis
  • setzeLogoBibliotheksVerzeichnis
  • LogoTemporäresVerzeichnis
  • setzeLogoTemporäresVerzeichnis

References:

    Release Notes für Version 4.685, runSecure

VerzeichnisP setzeUmgebung


HC / Kommunikation / Umgebung / setzeUmgebung

setzeUmgebung

HC [image] Kommunikation [image] Umgebung [image] setzeUmgebung
Umgebung liesUmgebung

setzeUmgebung Name Wert

Kommando. Setzt die Umgebungsvariable Name des Betriebssystems auf Wert, der dabei implizit in ein Wort konvertiert wird.

Beispiel:

setzeUmgebung "meinevar [Etwas Text...]
liesUmgebung "meinevar	;Etwas Text...   ;-)

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

Umgebung liesUmgebung


HC / Kommunikation / Umgebung / liesUmgebung

liesUmgebung

HC [image] Kommunikation [image] Umgebung [image] liesUmgebung
setzeUmgebung liesUmgebungstabelle

liesUmgebung Name

Kommando. Liest den Wert der Umgebungsvariable Name des Betriebssystems. Name muss ein Wort sein.

Beispiel:

liesUmgebung "alogolib	;D:\Users\AndreasM\aucblogo\Lib  ;-)

Example:

  • setzeUmgebung

Reference:

    setzeUmgebung

setzeUmgebung liesUmgebungstabelle


HC / Kommunikation / Umgebung / liesUmgebungstabelle

liesUmgebungstabelle

HC [image] Kommunikation [image] Umgebung [image] liesUmgebungstabelle
liesUmgebung LogoComspec

liesUmgebungstabelle

Ausgabe ist eine Liste aller Umgebungsvariablen und ihrer Werte. Jeder Listeneintrag enthält den Namen der Umgebungsvariable als erstes Element, und dessen Wert als zweites Element.


HC / Kommunikation / Umgebung / LogoComspec

LogoComspec

HC [image] Kommunikation [image] Umgebung [image] LogoComspec
liesUmgebungstabelle setzeLogoComspec

LogoComspec

Ausgabe ist die Betriebssystem-Umgebungsvariable COMSPEC oder der Pfad, der durch von setzeLogoComspec gesetzt wurde, der auf den Betriebssystem-Befehlsinterpreter zeigen sollte.

Beispiel:

zeige LogoComspec	;C:\WINDOWS\system32\cmd.exe

Reference:

    Release Notes für Version 4.685

liesUmgebungstabelle setzeLogoComspec


HC / Kommunikation / Umgebung / setzeLogoComspec

setzeLogoComspec

HC [image] Kommunikation [image] Umgebung [image] setzeLogoComspec
LogoComspec LogoEditor

setzeLogoComspec Pfad

Kommando, um die interne Umgebungsvariable COMSPEC zum neuen Pfad zu ändern. Diese Variable wird benutzt, um den Befehlszeilen-Interpreter des Betriebssystems zu lokalisieren, der in Systemaufruf und ShellSpawn aufgerufen wird.

Beispiel:

setzeLogoComspec "D:\WINXP\system32\cmd.exe

References:

    LogoComspec, Release Notes für Version 4.685

LogoComspec LogoEditor


HC / Kommunikation / Umgebung / LogoEditor

LogoEditor

HC [image] Kommunikation [image] Umgebung [image] LogoEditor
setzeLogoComspec setzeLogoEditor

LogoEditor

Ausgabe ist die Umgebungsvariable AEDITOR oder der von setzeLogoEditor gesetzte Pfad, der entweder ein leeres wort oder der Pfad zum externen Editor sollte, den Logo aufrufen soll.

Beispiel:

zeige LogoEditor	;c:\programme\crimson editor\cedt.exe

Reference:

    Release Notes für Version 4.685

setzeLogoComspec setzeLogoEditor


HC / Kommunikation / Umgebung / setzeLogoEditor

setzeLogoEditor

HC [image] Kommunikation [image] Umgebung [image] setzeLogoEditor
LogoEditor LogoSchriftenVerzeichnis

setzeLogoEditor Pfad

Kommando um die interne Umgebungsvariable AEDITOR zum Pfad zu ändern. Die Funktion Bearbeite wird das Programm, auf das Pfad zeigt, aufrufen.

Beispiele:

setzeLogoEditor [C:\Programme\Crimson Editor\cedt.exe]
setzeLogoEditor "

References:

    LogoEditor, LogoHilfeVerzeichnis, Release Notes für Version 4.685

LogoEditor LogoSchriftenVerzeichnis


HC / Kommunikation / Umgebung / LogoSchriftenVerzeichnis

LogoSchriftenVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] LogoSchriftenVerzeichnis
setzeLogoEditor setzeLogoSchriftenVerzeichnis

LogoSchriftenVerzeichnis

Ausgabe ist die Umgebungsvariable AFONTS oder der Pfad, der mittels setzeLogoSchriftenVerzeichnis gesetzt wurde. Dies ist entweder ein leeres Wort oder der Pfad zum TrueType-Schriften-Verzeichnis, worin Logo seine grafischen Schriften suchen soll.

Beispiel:

zeige LogoSchriftenVerzeichnis	;C:\WINXP\fonts  ;-)

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

setzeLogoEditor setzeLogoSchriftenVerzeichnis


HC / Kommunikation / Umgebung / setzeLogoSchriftenVerzeichnis

setzeLogoSchriftenVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] setzeLogoSchriftenVerzeichnis
LogoSchriftenVerzeichnis LogoHilfeVerzeichnis

setzeLogoSchriftenVerzeichnis Pfad

Kommando, um die interne Umgebungsvariable AFONTS auf den neuen Pfad zu setzen. Das Kommando IgelText wird in dem Verzeichnis, auf das Pfad zeigt, suchen.

Beispiel:

setzeLogoSchriftenVerzeichnis [C:\WINDOWS\FONTS]

Example:

  • Versions-Informationen für Version 4.7

References:

    Versions-Informationen für Version 4.7(2), LogoSchriftenVerzeichnis

LogoSchriftenVerzeichnis LogoHilfeVerzeichnis


HC / Kommunikation / Umgebung / LogoHilfeVerzeichnis

LogoHilfeVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] LogoHilfeVerzeichnis
setzeLogoSchriftenVerzeichnis setzeLogoHilfeVerzeichnis

LogoHilfeVerzeichnis

Ausgabe ist die Umgebungsvariable ALOGOHELP oder der Pfad, der durch setzeLogoEditor gesetzt wurde. Sie wird als der Pfad zu den Hilfe-Dateien in aucblogo/help/*.txt. angenommen.

Beispiel:

zeige LogoHilfeVerzeichnis	;help

Reference:

    Release Notes für Version 4.685

setzeLogoSchriftenVerzeichnis setzeLogoHilfeVerzeichnis


HC / Kommunikation / Umgebung / setzeLogoHilfeVerzeichnis

setzeLogoHilfeVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] setzeLogoHilfeVerzeichnis
LogoHilfeVerzeichnis LogoBibliotheksVerzeichnis

setzeLogoHilfeVerzeichnis Pfad

Kommmando, um die interne Umgebungsvariable ALOGOHELP zum angegebenen Pfad zu ändern. Das Grundwort Hilfe wird das Hilfe-Dateien von diesem Pfad lesen.

Beispiel:

setzeLogoHilfeVerzeichnis [C:/aucblogo/Hilfe]	;für einen absoluten Pfad

Reference:

    Release Notes für Version 4.685

LogoHilfeVerzeichnis LogoBibliotheksVerzeichnis


HC / Kommunikation / Umgebung / LogoBibliotheksVerzeichnis

LogoBibliotheksVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] LogoBibliotheksVerzeichnis
setzeLogoHilfeVerzeichnis setzeLogoBibliotheksVerzeichnis

LogoBibliotheksVerzeichnis

Ausgabe ist die Umgebungsvariable ALOGOLIB oder der Pfad, durch setzeLogoBibliotheksVerzeichnis gesetzt, der als Pfad zum den Bibliotheks-Prozeduren, man normalerweise in aucblogo/lib/*.lg findet, angenommen wird.

Beispiel:

zeige LogoBibliotheksVerzeichnis	;C:/aUCBLogo/lib

Reference:

    Release Notes für Version 4.685

setzeLogoHilfeVerzeichnis setzeLogoBibliotheksVerzeichnis


HC / Kommunikation / Umgebung / setzeLogoBibliotheksVerzeichnis

setzeLogoBibliotheksVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] setzeLogoBibliotheksVerzeichnis
LogoBibliotheksVerzeichnis LogoTemporäresVerzeichnis

setzeLogoBibliotheksVerzeichnis Pfad

Kommando, um die interne Umgebungsvariable ALOGOLIB zu Pfad zu ändern. Der Logo Leser wird Bibliotheks-Prozeduren von diesem Pfad laden.

Beispiel:

setzeLogoBibliotheksVerzeichnis [C:/aucblogo/lib]

References:

    LogoBibliotheksVerzeichnis, Release Notes für Version 4.685

LogoBibliotheksVerzeichnis LogoTemporäresVerzeichnis


HC / Kommunikation / Umgebung / LogoTemporäresVerzeichnis

LogoTemporäresVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] LogoTemporäresVerzeichnis
setzeLogoBibliotheksVerzeichnis setzeLogoTemporäresVerzeichnis

LogoTemporäresVerzeichnis

Ausgabe ist die Umgebungsvariable ATEMP oder der von setzeLogoTemporäresVerzeichnis gesetzte Pfad, wo temporäre Bearbeite-Sitzungs-Dateien gespeichert werden. Dies ist normalerweise aucblogo/temp.

Beispiel:

zeige LogoTemporäresVerzeichnis	;C:/aUCBLogo/TEMP

Reference:

    Release Notes für Version 4.685

setzeLogoBibliotheksVerzeichnis setzeLogoTemporäresVerzeichnis


HC / Kommunikation / Umgebung / setzeLogoTemporäresVerzeichnis

setzeLogoTemporäresVerzeichnis

HC [image] Kommunikation [image] Umgebung [image] setzeLogoTemporäresVerzeichnis
LogoTemporäresVerzeichnis Port-Eingabe Und Ausgabe

setzeLogoTemporäresVerzeichnis

Kommando, um die interne Umgebungsvariable ATEMP zum angegeben Pfad zu ändern. Das ist wo temporäre Bearbeite-Sitzungs-Dateien gespeichert werden.

Beispiel:

setzeLogoTemporäresVerzeichnis [C:/aucblogo/temp]

References:

    LogoTemporäresVerzeichnis, Release Notes für Version 4.685

LogoTemporäresVerzeichnis Port-Eingabe Und Ausgabe


HC / Kommunikation / Port-Eingabe Und Ausgabe

Port-Eingabe Und Ausgabe

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe
setzeLogoTemporäresVerzeichnis PortAusgang

Port-Eingabe Und Ausgabe

Hier ist eine Gruppe von Funktionen, um Ein-/Ausgabe-Ports zu setzen, zu lesen und zu verändern mit io.dll.

Port-Eingabe Und Ausgabe

  • PortAusgang
  • PortEingang
  • setzePortBit
  • löschePortBit
  • liesPortBit
  • nichtPortBit
  • schiebePortLinks
  • schiebePortRechts


HC / Kommunikation / Port-Eingabe Und Ausgabe / PortAusgang

PortAusgang

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] PortAusgang
Port-Eingabe Und Ausgabe PortEingang

PortAusgang adresse wert

Kommando, den Port adresse auf die vorzeichenlose 8 Bit Ganzzahl wert setzt.

Beispiel:

PortAusgang 888 255
;...setzt alle Bits am Standart-Parallelport


HC / Kommunikation / Port-Eingabe Und Ausgabe / PortEingang

PortEingang

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] PortEingang
PortAusgang setzePortBit

PortEingang adresse

Ausgabe ist der Wert der Bits des Portes Nummer adresse.

Beispiel:

zeige PortEingang 888


HC / Kommunikation / Port-Eingabe Und Ausgabe / setzePortBit

setzePortBit

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] setzePortBit
PortEingang löschePortBit

setzePortBit addresse bitnr

Kommando, das das Bit Nummer bitnr des Ports addresse auf logisch hoch setzt.

Beispiel:

setzePortBit 888 3


HC / Kommunikation / Port-Eingabe Und Ausgabe / löschePortBit

löschePortBit

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] löschePortBit
setzePortBit liesPortBit

löschePortBit addresse bitnr

Kommando, das das Bit Nummer Bitnr vom Port addresse auf logisch low setzt.

Beispiel:

löschePortBit 888 3

Reference:

    Release Notes für Version 4.67

setzePortBit liesPortBit


HC / Kommunikation / Port-Eingabe Und Ausgabe / liesPortBit

liesPortBit

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] liesPortBit
löschePortBit nichtPortBit

liesPortBit addresse bitnr

Ausgabe ist der boolsche Wert des Bits bitnr des Ports addresse.


HC / Kommunikation / Port-Eingabe Und Ausgabe / nichtPortBit

nichtPortBit

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] nichtPortBit
liesPortBit schiebePortLinks

nichtPortBit adress bitnr

Kommando, das das Bit Nummer bitnr auf der Port-Addresse addresse umschaltet.


HC / Kommunikation / Port-Eingabe Und Ausgabe / schiebePortLinks

schiebePortLinks

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] schiebePortLinks
nichtPortBit schiebePortRechts

schiebePortLinks addresse bitnr

Kommando, das die Bits des Ports Nummmer addresse um bitnr Bits nach links versetzt.


HC / Kommunikation / Port-Eingabe Und Ausgabe / schiebePortRechts

schiebePortRechts

HC [image] Kommunikation [image] Port-Eingabe Und Ausgabe [image] schiebePortRechts
schiebePortLinks Zeitmessung

schiebePortRechts addresse bitnr

Kommando, das die Bits des Ports Nummmer addresse um bitnr Bits nach rechts versetzt.

Reference:

    Release Notes für Version 4.67

schiebePortLinks Zeitmessung


HC / Kommunikation / Zeitmessung

Zeitmessung

HC [image] Kommunikation [image] Zeitmessung
schiebePortRechts ZeitFein

Zeitmessung

Diese Funktionen sind gut um maschinenunabhängige Zeitabläufe einzusetzen, und, um die Systemzeit zu lesen.

Zeitmessung

  • ZeitFein
  • ZeitMilli
  • ZeitMikro
  • ZeitMikroAuflösung
  • ZeitgeberFrequenz
  • Zeit
  • MillionenBefehleProSekunde


HC / Kommunikation / Zeitmessung / ZeitFein

ZeitFein

HC [image] Kommunikation [image] Zeitmessung [image] ZeitFein
Zeitmessung ZeitMilli

ZeitFein

Ausgabe ist die System-Zeit in Sekunden als eine Gleitpunktzahl.


HC / Kommunikation / Zeitmessung / ZeitMilli

ZeitMilli

HC [image] Kommunikation [image] Zeitmessung [image] ZeitMilli
ZeitFein ZeitMikro

ZeitMilli

Ausgabe ist die System-Zeit in Millisekunden als eine Gleitpunktzahl.


HC / Kommunikation / Zeitmessung / ZeitMikro

ZeitMikro

HC [image] Kommunikation [image] Zeitmessung [image] ZeitMikro
ZeitMilli ZeitMikroAuflösung

ZeitMikro

Ausgaben die System-Zeit in Mikrosekunden als eine Gleitpunktzahl.


HC / Kommunikation / Zeitmessung / ZeitMikroAuflösung

ZeitMikroAuflösung

HC [image] Kommunikation [image] Zeitmessung [image] ZeitMikroAuflösung
ZeitMikro ZeitgeberFrequenz

ZeitMikroAuflösung

Ausgabe ist die System-Zeit-Auflösung in Mikrosekunden als eine Gleitpunktzahl.


HC / Kommunikation / Zeitmessung / ZeitgeberFrequenz

ZeitgeberFrequenz

HC [image] Kommunikation [image] Zeitmessung [image] ZeitgeberFrequenz
ZeitMikroAuflösung Zeit

ZeitgeberFrequenz

Ausgabe ist die System-Zeitgeber-Frequenz in MegaHertz als eine Gleitpunktzahl.

Reference:

    Release Notes für Version 4.64

ZeitMikroAuflösung Zeit


HC / Kommunikation / Zeitmessung / Zeit

Zeit

HC [image] Kommunikation [image] Zeitmessung [image] Zeit
ZeitgeberFrequenz MillionenBefehleProSekunde

datetimelist Zeit

Ausgabe ist eine Liste, die die momentane Echtzeituhr-Zeit in einer Liste enthält: [Stunden Minuten Sekunden Millisekunden Wochentag Tag Monat Jahr]

Example:

  • Midi Kontroll-Tabelle

References:

    Standart-Ereignis-Behandler(2), LogoKonstanten, LogoSprache, Midi Kontroll-Tabelle, Pause, Release Notes für Version 4.64, Release Notes für Version 4.682, Release Notes für Version 4.685, Release Notes für Version 4.69, Schreibstift- und Hintergrund-Kontolle, Versions-Informationen für Version 4.7, ZeitFein, ZeitMikro, ZeitMikroAuflösung, ZeitMilli, profil, setzeNebelModus, spieleWaveSchnell

ZeitgeberFrequenz MillionenBefehleProSekunde


HC / Kommunikation / Zeitmessung / MillionenBefehleProSekunde

MillionenBefehleProSekunde

HC [image] Kommunikation [image] Zeitmessung [image] MillionenBefehleProSekunde
Zeit Dynamische Bibliotheken

MillionenBefehleProSekunde mipsvalue MillionenBefehleProSekunde

Ausgabe ist die Zahl der Millionen Anweisungen pro Sekunde der aktuellen Maschine, die für das Schreiben von maschinenunabhängigen Timings sehr nützlich ist.

Reference:

    Release Notes für Version 4.64

Zeit Dynamische Bibliotheken


HC / Kommunikation / Dynamische Bibliotheken

Dynamische Bibliotheken

HC [image] Kommunikation [image] Dynamische Bibliotheken
MillionenBefehleProSekunde DynamischeBibliothek

Dynamische Bibliotheken

Hier sind ein Konstrukteur für einen dynamischen Bibliotheksknoten, der einer Variablen und zugewiesen werden kann, und eine Aufruffunktion für Funktionen von dynamisch gebundenen Bibliotheken.

Dynamische Bibliotheken

  • DynamischeBibliothek
  • rufeDynamischeBibliothekAuf


HC / Kommunikation / Dynamische Bibliotheken / DynamischeBibliothek

DynamischeBibliothek

HC [image] Kommunikation [image] Dynamische Bibliotheken [image] DynamischeBibliothek
Dynamische Bibliotheken rufeDynamischeBibliothekAuf

DynamischeBibliothek dlname

Ausgabe ist ein neuer dynamischer Bibliotheksknoten mit namens dlname, der einer Variablen zugewiesen werden kann, zur Verwendung mit rufeDynamischeBibliothekAuf. Die dynamische Bibliothek wird geladen und bleibt im Speicher, solange die Variable, der sie zugewiesen wurde, existiert.

Beispiele:

to FindWindowA title
    output DLCall user32 [FindWindowA] (liste "Ganzzahl
        "Class "Ganzzahl 0
        "Title "Wort title)
end
to SetFocus hWnd
    ignoriere DLCall user32 [SetFocus] (liste "Ganzzahl
        "hWnd "Ganzzahl hWnd)
end
user32=DynamischeBibliothek "user32
hWnd=FindWindowA [aUCBLogo-4.67]
SetFocus hWnd

to GetCurrentDirectory
    lokal [buf status w]
    buf=TextPuffer 256
    status=DLCall kernel32 [GetCurrentDirectoryA] (liste "Ganzzahl
        "bufferLength "Ganzzahl 4*zähle buf
        "buffer "Wort buf)
    output TextPufferInWort buf
end
kernel32=DynamischeBibliothek "kernel32
zeige GetCurrentDirectory

Examples:

  • rufeDynamischeBibliothekAuf
  • TextPuffer

References:

    TextPuffer, rufeDynamischeBibliothekAuf

Dynamische Bibliotheken rufeDynamischeBibliothekAuf


HC / Kommunikation / Dynamische Bibliotheken / rufeDynamischeBibliothekAuf

rufeDynamischeBibliothekAuf

HC [image] Kommunikation [image] Dynamische Bibliotheken [image] rufeDynamischeBibliothekAuf
DynamischeBibliothek Betriebssystem

rufeDynamischeBibliothekAuf aDynamicLibrary dlfunctionname paramlist

Kommando oder Operation, je nach erstem Element von paramlist. Die Funktion namens dlfunctionname in der dynamischen Bibliothek aDynamicLibrary wird aufgerufen, wenn aDynamicLibrary auf eine geladene DynamicLibrary gesetzt wurde. dlfunctionname darf auch ein Liste mit einem Element sein, weil Sie so Groß-/Kleinschreibung in Variablen-Namen benutzen können, ohne zu setzeGroßKleinEgal falsch zu haben.

Das erstes Element von paramlist ist der Rückgabe-Typ der Funktion. Er darf eins der folgenden Wörter sein:

"Ganzzahl
"16BitZahl
"8BitZahl
"positive8BitZahl
"Float
"Wort
"Void

Dann folgen die Parameter der Funktion in Gruppen zu je drei:

1.) Der Name des Parameters, nur zur Dokumentation verwendet,

2.) Der Typ des Parameters, der eines der folgenden Wörter sein darf:

"Ganzzahl
"IntPtr
"16BitZahl
"Int16Ptr
"8BitZahl
"Int8Ptr
"positive8BitZahl
"UInt8Ptr
"Float
"FloatPtr
"Wort
"Ganzzahlen
"16BitZahlen

Die DLCall Funktion unterstützt jetzt auch Argumente alsZeiger, wenn "IntPtr, "Int16Ptr, "Int8Ptr, "UInt8Ptr oder "FloatPtr als Argumententyp angegeben werden.

3.) Der Wert des Parameters, der zum dem Typ passen muss.

Beispiele:

to FindWindowA title
    output DLCall user32 [FindWindowA] (liste "Ganzzahl
        "Class "Ganzzahl 0
        "Title "Wort title)
end
to GetWindowRect hWnd
    lokal [status iarr]
    iarr=Ganzzahlen 4
    status=DLCall user32 [GetWindowRect] (liste "Ganzzahl
        "hWnd "Ganzzahl hWnd
        "rect "Ganzzahlen iarr)
    output iarr
end
to MoveWindow hWnd x y
    lokal [xy status]
    rect=GetWindowRect hWnd
    status=DLCall user32 [MoveWindow] (liste "Ganzzahl
        "hWnd "Ganzzahl hWnd
        "X "Ganzzahl x
        "Y "Ganzzahl y
        "nWidth "Ganzzahl rect.3-rect.1
        "nHeight "Ganzzahl rect.4-rect.2
        "bRepaint "Ganzzahl 1)
end
user32=DynamischeBibliothek "user32
hWnd=FindWindowA [aUCBLogo-4.67]
MoveWindow hWnd 200 100

Reference:

    DynamischeBibliothek

DynamischeBibliothek Betriebssystem


HC / Kommunikation / Betriebssystem

Betriebssystem

HC [image] Kommunikation [image] Betriebssystem
rufeDynamischeBibliothekAuf LogoVersion

Betriebssystem

Hier sind verschiedene Funktionen bezüglich des Betriebssystems, auf dem Logo läuft, zusammengefaßt.

Betriebssystem

  • LogoVersion
  • Bildschirmgröße
  • liesArchitekturName
  • liesEndiannessName
  • liesBetriebssystemFamilienname
  • liesBetriebssystemIdName
  • liesPortIdName
  • liesProzessId
  • liesThreadId

References:

    LogoComspec(2), Versions-Informationen für Version 4.7(2), Empfänger, Füllfarbe, Grafiken, Kommandozeilen-Schalter -nogui, Starten und Verlassen von Logo, Stiftfarbe, TasteP, Tschüß, liesBetriebssystemFamilienname, liesBetriebssystemIdName, wirf

rufeDynamischeBibliothekAuf LogoVersion


HC / Kommunikation / Betriebssystem / LogoVersion

LogoVersion

HC [image] Kommunikation [image] Betriebssystem [image] LogoVersion
Betriebssystem Bildschirmgröße

LogoVersion

Ausgabe ist eine Liste mit vier Elementen:

1) Name des Logo-Interpreters,

2) Versionsnummer des Logo-Interpreters (Gleitpunktzahl),

3) Betriebssystemname,

4) Versionsnummer des Betriebssystems.

Beispiel:

zeige LogoVersion		;[aUCBLogo 4.689 Windows NT 5.1]

References:

    Release Notes für Version 4.67, Release Notes für Version 4.689

Betriebssystem Bildschirmgröße


HC / Kommunikation / Betriebssystem / Bildschirmgröße

Bildschirmgröße

HC [image] Kommunikation [image] Betriebssystem [image] Bildschirmgröße
LogoVersion liesArchitekturName

Bildschirmgröße

Ausgabe ist eine Liste zweier ganzer Zahlen, Breite und Höhe der momentanen Bildschirmauflösung des Computers.

Beispiel:

zeige Bildschirmgröße		;[1280 1024]

Reference:

    Vollbildmodus

LogoVersion liesArchitekturName


HC / Kommunikation / Betriebssystem / liesArchitekturName

liesArchitekturName

HC [image] Kommunikation [image] Betriebssystem [image] liesArchitekturName
Bildschirmgröße liesEndiannessName

liesArchitekturName

Ausgabe ist der Architekturename des Computers, auf dem Logo läuft, als ein Wort.

Beispiel:

liesArchitekturName		;32 bit  ;-)


HC / Kommunikation / Betriebssystem / liesEndiannessName

liesEndiannessName

HC [image] Kommunikation [image] Betriebssystem [image] liesEndiannessName
liesArchitekturName liesBetriebssystemFamilienname

liesEndiannessName

Ausgabe ist die Endianness des Computers, auf dem Logo läuft, als ein Wort.

Beispiel:

liesEndiannessName		;Little endian  ;-)

Example:

  • liesBetriebssystemFamilienname

Reference:

    liesBetriebssystemFamilienname

liesArchitekturName liesBetriebssystemFamilienname


HC / Kommunikation / Betriebssystem / liesBetriebssystemFamilienname

liesBetriebssystemFamilienname

HC [image] Kommunikation [image] Betriebssystem [image] liesBetriebssystemFamilienname
liesEndiannessName liesBetriebssystemIdName

liesBetriebssystemFamilienname

Ausgabe ist der Betriebssystem-Familienname des Computers, auf dem Logo läuft, als ein Wort.

Beispiel:

liesEndiannessName		;Windows  ;-)


HC / Kommunikation / Betriebssystem / liesBetriebssystemIdName

liesBetriebssystemIdName

HC [image] Kommunikation [image] Betriebssystem [image] liesBetriebssystemIdName
liesBetriebssystemFamilienname liesPortIdName

liesBetriebssystemIdName

Ausgabe ist der Betriebssystem-Familienname des Computers, auf dem Logo läuft, als ein Wort.

Beispiel:

liesBetriebssystemIdName	;Microsoft Windows NT  ;-)


HC / Kommunikation / Betriebssystem / liesPortIdName

liesPortIdName

HC [image] Kommunikation [image] Betriebssystem [image] liesPortIdName
liesBetriebssystemIdName liesProzessId

liesPortIdName

Ausgabe ist der Port-Name der zugrundeliegenden wxWidgets-Version, als ein Wort.

Beispiel:

liesPortIdName		;wxMSW  ;-)


HC / Kommunikation / Betriebssystem / liesProzessId

liesProzessId

HC [image] Kommunikation [image] Betriebssystem [image] liesProzessId
liesPortIdName liesThreadId

liesProzessId

Ausgabe ist die Prozess-Nummer als eine ganze Zahl.

Beispiel:

liesProzessId		;2268  ;-)


HC / Kommunikation / Betriebssystem / liesThreadId

liesThreadId

HC [image] Kommunikation [image] Betriebssystem [image] liesThreadId
liesProzessId Arithmetik

liesThreadId

Ausgabe ist die Thread-Nummer des gerade aktiven Threads bei paralleler Ausführung, als eine ganze Zahl.

Beispiel:

liesThreadId		;1136  ;-)


HC / Arithmetik

Arithmetik

HC [image] Arithmetik
liesThreadId Logische Operationen

Arithmetik

In dieser Gruppe sind numerische Operationen für die Berechnung, arithmetische Mutatoren, die Daten selbst mathematisch verändern, arithmetische Prädikate, um um boolsche Fragen zu Zahlen zu stellen, Funktionen für random Zahlen-Und Rationalzahlen (Brüche), Schreib Formatierungs- und bitweise Operationen.

Arithmetik

  • Logische Operationen
  • Lineare Operationen
  • Numerische Operationen
  • Zahlen-Generatoren
  • Zufallszahlen
  • Irrationale Zahlen
  • Trigonometrische Funktionen
  • Typen-Konverter
  • Druck-Formatierung
  • Bitweise Operationen
  • Arithmetische Mutatoren
  • Arithmetik-Prädikate
  • Rationale Zahlen


HC / Arithmetik / Logische Operationen

Logische Operationen

HC [image] Arithmetik [image] Logische Operationen
Arithmetik und

Logische Operationen

...operieren alle auf den zwei Wörtern WAHR und FALSCH, die einen Boolschen Wert darstellen.

Logische Operationen

  • und
  • oder
  • und2
  • oder2
  • nicht


HC / Arithmetik / Logische Operationen / und

und

HC [image] Arithmetik [image] Logische Operationen [image] und
Logische Operationen oder

und wf1 wf2
(und wf1 wf2 wf3...)

Ausgabe ist wahr, wenn alle Eingaben wahr sind, sonst falsch. Alle Eingaben müssen wahr oder falsch sein.

Wenn einige der Eingaben Listen sind statt boolschen Werten, so werden diese von links nach rechts ausgewertet, jedoch stoppt die Auswertung bei dem ersten falschen Argument. Dadurch ist es möglich, viele geschachtelte wennSonst-Sätze zu vermeiden, die in früheren aUCBLogo-Versionen notwendig waren.

Wichtig: die Listen werden nur ausgewertet bis irgendein Ergebnis daraus hervorgeht. Es ist ein Fehler, wenn weitere Befehle in dem Ausdruck folgen, nachdem der Ausdruck einen Wert zurückgegeben hat.

Beispiel für diesen Fehler:

zeige und [1==1 zeige 2][zeige 3 1==2]
wahr  ;-)

Beispiele:

und wahr falsch		;falsch  ;-)
und wahr wahr		;wahr  ;-)
und falsch wahr		;falsch  ;-)
und falsch falsch		;falsch  ;-)
(und wahr wahr wahr)		;wahr  ;-)
(und wahr wahr falsch)		;falsch  ;-)

Examples:

  • Versions-Informationen für Version 4.7
  • Berkeley Logo-Anwenderdokumentation
  • beiLosgelassenerTasteInAuswahlbox
  • beiLosgelassenerTasteInKombiBox
  • setzeAuswahlboxHintergrundfarbe
  • beiGedrückterTasteInAuswahlbox
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • beiLosgelassenerTasteInGraph
  • setzeAuswahlboxMöglichkeiten
  • setzeAuswahlboxSchriftdicke
  • setzeAuswahlboxSchriftgröße
  • setzeListenboxMöglichkeiten
  • setzeAuswahlboxSchriftname
  • setzeAuswahlboxSchriftstil
  • setzeKombiBoxMöglichkeiten
  • beiGedrückterTasteInGraph
  • entferneAuswahlboxElement
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • entferneKombiBoxElement
  • beiZeichenInAuswahlbox
  • setzeAuswahlboxAuswahl
  • setzeAuswahlboxElement
  • öffneZumAktualisieren
  • beiAuswahlboxAuswahl
  • setzeAuswahlboxFarbe
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • beiKombiBoxÄnderung
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • setzeKombiBoxFarbe
  • zerstöreAuswahlbox
  • AuswahlboxAuswahl
  • setzeKombiBoxWert
  • zurAuswahlboxDazu
  • hängeAnListenbox
  • zerstöreKombiBox
  • öffneZumAnhängen
  • beiGraphZeichen
  • KombiBoxAuswahl
  • zurKombiBoxDazu
  • zähleAuswahlbox
  • speichereBild
  • zähleKombiBox
  • AuswahlboxAn
  • Faktorisiere
  • KombiBoxWert
  • Auswahlbox
  • KombiBoxAn
  • ladeBild

References:

    Release Notes für Version 4.685(27), Versions-Informationen für Version 4.7(14), Release(13), Release Notes für Version 4.65(13), Tokenisierung(13), zu(12), Release Notes für Version 4.686(10), Zahlbox(10), TextControl(9), ladeBild(9), speichereBild(9), Berkeley Logo-Anwenderdokumentation(8), Fehler-Verarbeitung(8), öffneZumAktualisieren(8), Fenster-Stile(7), Schieberegler(7), Vorlagen-basierte Iteration(7), zumGestellDazu(7), öffneZumAktualisierenBinär(7), Release Notes für Version 4.672(6), Release Notes für Version 4.682(6), liesZeichen(6), 16BitZahlen(5), Arbeitsbereiche(5), Auswahlbox(5), Einführung in die Logo-Programmierung(5), GanzzahlBox(5), Ganzzahlen(5), Release Notes für Version 4.64(5), Starten und Verlassen von Logo(5), setzePunktXYZ(5), Diagramm(4), Grafiken(4), ListControls(4), Midi Glossary(4), Release Notes für Version 4.67(4), Release Notes für Version 4.69(4), TSH(4), TSHA(4), _Makro(4), liesMehrereZeichen(4), liesWort(4), reelleZahlen(4), setzePunktXY(4), wirf(4), CheckBoxen(3), ChoiceBoxes(3), Element(3), EllipsenBogen(3), Filter(3), Geltungsbereich der Variablen(3), KombiBoxen(3), Listenboxen(3), Löschen(3), Protokolliere(3), Reihe(3), Release Notes für Version 4.683(3), Schaltknopf(3), Standart-Ereignis-Behandler(3), Struktur(3), TextControls(3), Versions-Informationen(3), Zylinder(3), bearbeite(3), bearbeiteDatei(3), bildeAbSatz(3), bildeab(3), entferneAuswahlboxElement(3), entferneKombiBoxElement(3), fülle(3), liesListe(3), löscheSchirm(3), setzeAuswahlboxElement(3), setzeKombiBoxElement(3), setzeOrt(3), setzeTextfarbe(3), setzelokal(3), speichereSchirmVektoriell(3), öffneZumAnhängen(3), ASCII(2), Arithmetik(2), AuswahlboxAn(2), AuswahlboxAuswahl(2), Balken(2), BitmapKopieren(2), Dateien öffnen(2), Diagramme(2), Dynamische Bibliotheken(2), Editieren(2), Fall(2), GUI Programmierung(2), GanzzahlBoxen(2), GrafikGroß(2), Ignoriere(2), KombiBoxAn(2), KombiBoxAuswahl(2), KombiBoxWert(2), Kreuzprodukt(2), MidiAusgabestrom(2), Numerische Operationen(2), Oberfläche(2), Oberflächenstart(2), Parameteranzahl(2), ProzedurText(2), RadioButtons(2), Randsprung(2), Release Notes für Version 4.66(2), Release Notes für Version 4.68(2), Textmodus(2), ToggleButtons(2), Vieleck(2), VieleckStart(2), Zaun(2), _setzeOrt(2), `(2), arc2(2), beiAuswahlboxAuswahl(2), beiGedrückterTasteInAuswahlbox(2), beiGedrückterTasteInKombiBox(2), beiKombiBoxAuswahl(2), beiKombiBoxEingabe(2), beiKombiBoxZeichen(2), beiKombiBoxÄnderung(2), beiLosgelassenerTasteInAuswahlbox(2), beiLosgelassenerTasteInKombiBox(2), beiZeichenInAuswahlbox(2), erneuereAufrufliste(2), finde(2), fürAlle(2), geheZu(2), geteilterBildschirm(2), hängeAnListenbox(2), kaskadiere(2), kopiereDefinition(2), lade(2), liesUmgebungstabelle(2), liesZeichenErweitert(2), listeTSH(2), listeTitel(2), profil(2), reduziere(2), sei(2), setzeAuswahlboxAuswahl(2), setzeAuswahlboxFarbe(2), setzeAuswahlboxHintergrundfarbe(2), setzeAuswahlboxMöglichkeiten(2), setzeAuswahlboxSchriftdicke(2), setzeAuswahlboxSchriftgröße(2), setzeAuswahlboxSchriftname(2), setzeAuswahlboxSchriftstil(2), setzeElemente(2), setzeGroßKleinEgal(2), setzeKombiBoxAuswahl(2), setzeKombiBoxFarbe(2), setzeKombiBoxHintergrundfarbe(2), setzeKombiBoxMöglichkeiten(2), setzeKombiBoxSchriftdicke(2), setzeKombiBoxSchriftgröße(2), setzeKombiBoxSchriftname(2), setzeKombiBoxSchriftstil(2), setzeKombiBoxWert(2), setzeListenboxMöglichkeiten(2), setzeQuetschung(2), setzeRedefinierbar(2), setzeTexturXY(2), setzeTexturort(2), setzeVariablenFensterteiler(2), speichere(2), spieleWaveSchnell(2), tippe(2), verstecke(2), zeichneBitmapSkaliertAuf(2), zerstöreAuswahlbox(2), zerstöreFenster(2), zerstöreGraph(2), zerstöreKombiBox(2), zurAuswahlboxDazu(2), zurKombiBoxDazu(2), zähleAuswahlbox(2), zähleKombiBox(2), öffneZumSchreiben(2), öffneZumSchreibenBinär(2), 16BitZahl, 8BitZahl, ASCIIroh, Absolute Igel-Bewegung, Ankreuzbox, Arbeitsbereichs-Abfragen, Arbeitsbereichs-Kontrolle, Bilder, Bildschirmgröße, BitUnd, BitmapGrößeX, BitmapGrößeY, Bitmaps, Bogen, Cursor, Datei-Verzeichnisse, DateiAuswahl, DateiP, Dateien, Daten-Struktur Grundwörter, Differenz, DoppelPufferung, DynamischeBibliothek, Einzelschritt, ElementeAb, Ellipse, Ellipsoid, EllipsoidenTeil, Faktorisiere, Fehlersuche, Fenster, Fenster-Kontrolle, FensterAn, FensterModus, Füllfarbe, Ganzzahl, Geräusche, Grafik, GroßKleinEgalP, GroßeZahlSetzGenauigkeit, Halt, Hilfe, Igel- und Fenster-Fragen, Igel-Kontrolle, IgelText, Inhalt, KammSort, Knopf, Knöpfe, KombiBox, Kommunikation, Kontroll-Strukturen, Kreis, Kugel, Linie, ListControl, Listenbox, Logische Operationen, MandelIterate, Meldungsbox, MidiNoteAn, ModelviewMatrix, Müllsammeln, NebelAn, Ort, OrtXYZ, Parallele Ausführung, Pause, Port-Eingabe Und Ausgabe, Produkt, Projektions-Matrix, Prozedur-Definition, Prozeduren, Quetschung, RGB, RGBA, Radioknopf, Rahmen, Rahmen-Fenster, Rationale Zahlen, Relative Igel-Bewegung, Release Notes für Version 4.688, Release Notes für Version 4.689, RestDerDivision, Schalterfunktionen, Schatten, Schiebe-Regler, Schleifen, Schreibstift, Sounds, SpeicherungGröße, Stiftfarbe, Summe, Systemaufruf, SystemaufrufAbspalten, TasteP, Tastenwert, TeileMitRest, Tesselation, Text Zeichnen, TextAusrichtung, TextMausEreignisseAn, TextMausEreignisseAus, TextMausOrt, TextPuffer, Textur, Threads, Töne, Umgebung, UmkehrStift, VariablenNamen, Verhältnis, VerzeichnisAuswahl, VideoEnde, VideoFrame, VideoStart, VieleckEnde, Volltext, Zahlboxen, Zahlen-Generatoren, Zeichen, Zeitmessung, Zufallszahlen, _setzeOrtXYZ, _vielleichtAusgabe, addiereFarben, addiereFarbenRest, aktiviereFenster, alleErste, ausSchlange, beiGedrückterTasteInGraph, beiGraphZeichen, beiLosgelassenerTasteInGraph, beschäftigtP, betreteGrafik, crossmap, deckeauf, entferneListenboxElement, erbe, erneuereVariablenliste, erneuereVariablenlisteBeiSchritt, fange, float2ratio, formatiere, fügeSpalteInListenControlEin, fülleBitmap, fülleEllipse, fülleRechteck, für, hilfesuche, holeAuswahl, holeAuswahlZahl, holeAuswahlmöglichkeiten, holeFarbeVomBenutzer, holePasswortVomBenutzer, holeTextVomBenutzer, holeZahlVomBenutzer, kalibriereScrolling, klammereFürAusführung, ladeGraph, ladeGraphText, lies16BitZahlBinär, lies16BitZahlenBinär, lies8BitZahlBinär, liesFarbDatenbank, liesGanzzahlBinär, liesGanzzahlenBinär, liesKomplexeZahlBinär, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesPositive8BitZahlBinär, liesRoheZeile, liesStrukturBinär, liesZahlBinär, liesZahlenBinär, listeProzedur, listeRGB, listeRGBA, listeTSHA, löscheSchatten, macroexpand, makeTree, makeTreeFromBody, minus, mische, nicht, nichtAufzeichnen, nichtProtokollieren, normalerStift, ohneErste, perspektivisch, positive8BitZahl, radd, radiere, rdiv, rmul, rotatescene, rsub, scrolle, setReader, settFensterform, setzeBalkenBereich, setzeBenutzer, setzeCursor, setzeErallOnRun, setzeFensterteilerAufrufe, setzeFüllfarbe, setzeGanzzahlBoxBereich, setzeGraphErneuern, setzeHintergrundfarbe, setzeInnereFenstergröße, setzeListenboxElement, setzeLogoComspec, setzeLogoSprache, setzeMaterialShininess, setzeNebelBereich, setzeOrtXYZ, setzeReelleZahlboxBereich, setzeSchiebereglerBereich, setzeSchreibBreitenGrenze, setzeSchreiber, setzeSchreibpräzision, setzeSchriftausrichtung, setzeSchriftgröße, setzeSpeicherungsGröße, setzeStiftfarbe, setzeTiefentestFunktion, setzeXY, setzeXYZ, setzestift, sichtbarP, speichereGraphText, speichereListe, statischerText, stoppeMidiAusgabestrom, teile, tiefeKopie, transponiere, und2, unterbrich, verfolge, vergiß, vergißAlle, verkleinereStapel, verlasseGrafik, vomStapel, waituS, weiter, weiterMitSchleife, wendeAn, wirfSchatten, zeichneGrafik, Über Komplexität, öffneMidi, überprüfe, übertrage

Logische Operationen oder


HC / Arithmetik / Logische Operationen / oder

oder

HC [image] Arithmetik [image] Logische Operationen [image] oder
und und2

oder wf1 wf2
(oder wf1 wf2 wf3...)

Ausgabe ist wahr, wenn eine oder mehrere Eingaben wahr sind, sonst falsch. Alle Eingaben müssen wahr oder falsch sein.

Wenn einige der Eingaben Listen sind statt boolschen Werten, so werden diese von links nach rechts ausgewertet, jedoch stoppt die Auswertung bei dem ersten wahren Argument. Dadurch ist es möglich, viele geschachtelte wennSonst-Sätze zu vermeiden, die in früheren aUCBLogo-Versionen notwendig waren.

Wichtig: die Listen werden nur ausgewertet bis irgendein Ergebnis daraus hervorgeht. Es ist ein Fehler, wenn weitere Befehle in dem Ausdruck folgen, nachdem der Ausdruck einen Wert zurückgegeben hat.

Beispiel für diesen Fehler:

zeige oder [1==2 zeige 2][zeige 3 1==1]
falsch  ;-)

Beispiele:

oder falsch falsch		;falsch  ;-)
oder falsch wahr		;wahr  ;-)
oder wahr falsch		;wahr  ;-)
oder wahr wahr		;wahr  ;-)
(oder falsch falsch wahr)		;wahr  ;-)

See also:

  • zumGestellDazu

Examples:

  • Versions-Informationen für Version 4.7
  • Berkeley Logo-Anwenderdokumentation
  • SchrägstrichP
  • wähleZufällig
  • hex

References:

    Tokenisierung(17), Einführung in die Logo-Programmierung(8), Versions-Informationen für Version 4.7(8), _Makro(7), Release Notes für Version 4.685(6), Zahlbox(6), für(6), GUI Programmierung(5), TextControl(5), Berkeley Logo-Anwenderdokumentation(4), Filter(4), KombiBoxen(4), Starten und Verlassen von Logo(4), Vorlagen-basierte Iteration(4), setzeFüllfarbe(4), setzeStiftfarbe(4), tippe(4), BitOder(3), BitXOder(3), Diagramm(3), Fehler-Verarbeitung(3), Fenster-Stile(3), GanzzahlBoxen(3), Listenboxen(3), Release Notes für Version 4.65(3), TextSchriftgröße(3), liesZeichen(3), lokal(3), setzeSchreiber(3), teste(3), zu(3), Über Komplexität(3), Balken(2), BitUnd(2), BogenTangens(2), DateiAuswahl(2), Editieren(2), ElementeAb(2), Empfänger(2), Grafik(2), Grafiken(2), ListControl(2), LogoEditor(2), LogoSchriftenVerzeichnis(2), Midi Glossary(2), MidiGeräteInfo(2), Müllsammeln(2), Oberfläche(2), Reihe(2), Schiebe-Regler(2), Schreibstift- und Hintergrund-Kontolle(2), SchrägstrichP(2), SubStringP(2), Tesselation(2), Vieleck(2), Zahlboxen(2), ZufallsZahl(2), führeAusMitAusgabe(2), fülle(2), größerGleichP(2), hilfesuche(2), kaskadiere(2), kleinerGleichP(2), liesListeFlachTags(2), liesMehrereZeichen(2), oder2(2), radBogenTangens(2), rufeDynamischeBibliothekAuf(2), runSecure(2), setReader(2), setzeErallOnRun(2), setzeIgel(2), setzeTiefentestFunktion(2), statischerText(2), wähleZufällig(2), zumGestellDazu(2), 16BitZahl, 16BitZahlen, 8BitZahl, Abfragen, Ankreuzbox, Arbeitsbereichs-Abfragen, Arbeitsbereichs-Fragen, Arithmetische Mutatoren, Auswahlbox, AuswahlboxAuswahl, Balken-Anzeigen, Bedingung, BitElement, BitNicht, CheckBoxen, Cursor, Daten-Struktur Grundwörter, DitheringAn, Einzelschritt, Element, ElementP, Elemente, EllipsenBogen, Fenster, FensterAn, GanzzahlBox, GanzzahlBoxWert, Ganzzahlen, GanzzahlenFolge, Geltungsbereich der Variablen, Gestell, GroßeZahl, Igel Bewegungs-Abfragen, IgelFormen, IgelText, Irrationale Zahlen, Knopf, KombiBox, KombiBoxAuswahl, KombiBoxWert, Kommandozeilen-Schalter -nogui, Kurven-Zeichnen, Leser, Linie, Listenbox, ListenboxAuswahl, LogoBibliotheksVerzeichnis, LogoComspec, LogoHilfeVerzeichnis, LogoSprache, LogoTemporäresVerzeichnis, Meldungsbox, MidiAusgabestrom, Parallele Ausführung, Pause, Protokolliere, Radioknopf, Rahmen, Rahmen-Fenster, Release Notes für Version 4.64, Release Notes für Version 4.686, Release Notes für Version 4.689, Satz, Schaltknopf, Schatten, SchattenAn, Schieberegler, SchiebereglerWert, Schreiber, Sounds, Standart-Ereignis-Behandler, StaticTexts, StiftModus, Struktur, Systemaufruf, Tabelle, Tastenwert, TesselationStart, TextControls, TextMausEreignisseAus, Textbox, Textur, TiefpaßFilter, TiefpaßFilter2, Trigonometrische Funktionen, Töne, VideoStart, Volltext, ZahlboxWert, Zylinder, _vielleichtAusgabe, aufzeichnen, beiAktiviertemListenControlElement, beiAuswahlboxAuswahl, beiGedrückterTaste, beiGedrückterTasteInGraph, beiGraphZeichen, beiKombiBoxAuswahl, beiKombiBoxEingabe, beiListenboxAuswahl, beiZeichen, bildeAbSatz, bildeab, bis, entferneElement, erneuereVariablenlisteBeiSchritt, fange, finde, fügeSpalteInListenControlEin, führeAus, geheZu, gleichP, größerP, hex, holeAuswahl, holeAuswahlZahl, holeAuswahlmöglichkeiten, holeFarbeVomBenutzer, kleinerP, kopiereDefinition, lade, ladeBild, ladeGraphText, leerP, löscheTexturen, mdarray, minus, namensliste, neuerIgel, neuerZufall, nichtAufzeichnen, pllist, pon, positive8BitZahl, reduziere, reelleZahl, reelleZahlen, rufeAuf, schließeMidi, schreibe, sei, setzeDiffusesLicht, setzeElement, setzeGraphErneuern, setzeLogoSprache, setzePunktXY, setzePunktXYZ, setzeSpecularLicht, setzeStapelAusführlich, setzeStiftdicke, setzeTextschrift, setzeUmgebungslicht, setzeXY, setzeXYZ, solange, speichereBild, speichereGraph, speicherePostScript, speichereSchirmVektoriell, spieleWave, spieleWaveSchnell, sättigeOberhalb, sättigeUnterhalb, tue_bis, tue_solang, und, verfolge, verstecke, wendeAn, wennFalsch, wennSonst, wennWahr, zeichneGrafik, zeige, zähle, zähleThreads, übertrage

und und2


HC / Arithmetik / Logische Operationen / und2

und2

HC [image] Arithmetik [image] Logische Operationen [image] und2
oder oder2

tf1 und2 tf2

Ausgabe Wahr Wenn beide boolsche Eingaben wahr sind, sonst falsch.

Anmerkung: Dies ist ein Infixoperator mit der gleichen Funktionalität wie und.

Beispiele:

falsch und2 falsch		;falsch  ;-)
falsch und2 wahr		;falsch  ;-)
wahr und2 falsch		;falsch  ;-)
wahr und2 wahr		;wahr  ;-)


HC / Arithmetik / Logische Operationen / oder2

oder2

HC [image] Arithmetik [image] Logische Operationen [image] oder2
und2 nicht

tf1 oder2 tf2

Ausgabe wahr wenn eine oder mehrere der boolschen Eingaben ist wahr, sonst falsch.

Anmerkung: Dies ist ein Infixoperator mit der gleichen Funktionalität wie oder.

Beispiele:

falsch oder2 falsch		;falsch  ;-)
falsch oder2 wahr		;wahr  ;-)
wahr oder2 falsch		;wahr  ;-)
wahr oder2 wahr		;wahr  ;-)
zeige 1==0 oder2 1<0		;falsch
zeige 1==0 oder2 1>0		;wahr


HC / Arithmetik / Logische Operationen / nicht

nicht

HC [image] Arithmetik [image] Logische Operationen [image] nicht
oder2 Lineare Operationen

nicht tf

Ausgabe wahr wenn die Eingabe falsch ist, und umgekehrt.

Beispiele:

nicht falsch		;wahr  ;-)
nicht wahr		;falsch  ;-)

See also:

  • Tokenisierung
  • _Makro
  • TasteP

Examples:

  • Berkeley Logo-Anwenderdokumentation
  • SystemaufrufAbspalten
  • zeichneBitmapSchnell
  • liesListeFlachZeile
  • setzeGroßKleinEgal
  • öffneZumLesenBinär
  • liesRoheZeile
  • öffneZumLesen
  • Systemaufruf
  • liesFehler
  • reduziere
  • solange
  • Ding

References:

    Tokenisierung(8), Fehler-Verarbeitung(6), Fenster-Stile(6), TextControl(5), _Makro(5), Einführung in die Logo-Programmierung(4), Knoten(4), SystemaufrufAbspalten(4), fülle(4), Grafiken(3), Starten und Verlassen von Logo(3), kopiereDefinition(3), liesListe(3), verlasseGrafik(3), wirf(3), zu(3), Berkeley Logo-Anwenderdokumentation(2), Ding(2), Editieren(2), Müllsammeln(2), Release Notes für Version 4.64(2), Release Notes für Version 4.65(2), Release Notes für Version 4.682(2), Systemaufruf(2), Versions-Informationen für Version 4.7(2), Vieleck(2), _setzeElement(2), _setzeErstes(2), _setzeNächstes(2), _vielleichtAusgabe(2), buglist für Version 4.65(2), liesListeFlachZeile(2), liesRoheZeile(2), liesWort(2), reduziere(2), setzeSchreiber(2), solange(2), speichere(2), speicherePostScript(2), speichereSchirmVektoriell(2), teile(2), tippe(2), verstecke(2), zerstöreGraph(2), zähle(2), übertrage(2), 16BitZahlen, Ausgabe, Bedingung, BitNicht, Bogen, BogenTangens, DateiUmbenennen, Diagramm, Eigenschaften, ElementeAb, Ganzzahlen, Grafik, GrafikEnde, GroßKleinEgalP, GrundwortP, Halt, Inhalt, Irrationale Zahlen, Kugel, Kurven-Zeichnen, Löschen, ModelviewMatrix, NebelAn, Oberfläche, PrimzahlP, ProzedurP, Prozeduren, Quetschung, Release Notes für Version 4.66, Release Notes für Version 4.672, Release Notes für Version 4.68, Release Notes für Version 4.685, Release Notes für Version 4.686, Release Notes für Version 4.689, Schatten, Schieberegler, SchrägstrichP, Standart-Ereignis-Behandler, Tag, TasteP, Tesselation, TextMausEreignisseAus, TextboxÜberschreibmodus, TexturschriftAn, Threads, Variablen-Definition, VariablenNamen, Versions-Informationen, VieleckStart, Volltext, Zahlbox, Zylinder, _setzeOrt, betreteGrafik, cngon, crossmap, entferneElement, fange, gleichP, hervorheben, klammereFürAusführung, ladeGraphText, liesFehler, liesListeFlachRoh, liesListeFlachTags, liesMehrereZeichen, liesZeichen, listeTSH, löscheBild, löscheDatei, löscheSchatten, nichtAufzeichnen, offeneDateien, ohneErstes, poall, pons, popls, pops, pots, radBogenTangens, reelleZahlen, runSecure, schiebeLogisch, sei, setReader, setze, setzeAnkreuzbox, setzeElement, setzeElemente, setzeFüllfarbe, setzeGraphErneuern, setzeGroßKleinEgal, setzeLinienmuster, setzeLogoSprache, setzeNebeldichte, setzePunktXY, setzePunktXYZ, setzeQuetschung, setzeRadioknopf, setzeRänder, setzeSchaltknopfZustand, setzeSchreibBreitenGrenze, setzeSchriftdicke, setzeStiftfarbe, speichereGraph, speichereGraphText, spieleWave, vergiß, vergißAlle, vergißProzeduren, vergißTabellen, vergißVariablen, versteckeLogoConsolew, vorherP, weiter, wenn, wirfSchatten, zeichneBitmapSchnell, zeigeLogoConsolew, zerstöreFenster, zumGestellDazu, Über Komplexität, öffneZumLesen, öffneZumLesenBinär

oder2 Lineare Operationen


HC / Arithmetik / Lineare Operationen

Lineare Operationen

HC [image] Arithmetik [image] Lineare Operationen
nicht Summe

Lineare Operationen

...genügen den zwei Bedingungen
    f(x+y)=f(x)+f(y)
    f(a*x)=a*f(x)

Lineare Operationen

  • Summe
  • Differenz
  • minus
  • Produkt


HC / Arithmetik / Lineare Operationen / Summe

Summe

HC [image] Arithmetik [image] Lineare Operationen [image] Summe
Lineare Operationen Differenz

Summe zahl1 zahl2
(Summe zahl1 zahl2 zahl3...)
zahl1 + zahl2

Ausgabe ist die Summe der Eingaben.

Es ist ein nichtkommutatives Grundwort (wie alle binären arithmetischen Operationen), daher ist die Reihenfolge der Argumente wichtig, wenn das eine Argument ein zusammengesetzter Typ und das andere ein Skalar ist.

Beispiel:

1+2		;3  ;-)
1.2+2.4		;3.6  ;-)
1i+2i		;0+3i  ;-)
[1 2]+[3 4]		;[4 6] ;-)
[1 2]+3		;[4 5] ;-)
1+[2 3]		;6  ;-)

Summe 1 2		;3  ;-)
Summe 1.2 2.4		;3.6  ;-)
Summe 1i 2i		;0+3i  ;-)
Summe [1 2][3 4]		;[4 6] ;-)
Summe [1 2] 3		;[4 5] ;-)
Summe 1 [2 3]		;6  ;-)
(Summe 1 2 3 4 5)		;15  ;-)

Examples:

  • Vorlagen-basierte Iteration
  • Parameteranzahl
  • wendeAn

References:

    reduziere(3), Parameteranzahl, Vorlagen-basierte Iteration, radd, wendeAn

Lineare Operationen Differenz


HC / Arithmetik / Lineare Operationen / Differenz

Differenz

HC [image] Arithmetik [image] Lineare Operationen [image] Differenz
Summe minus

Differenz zahl1 zahl2
zahl1 - zahl2

Ausgabe ist die Differenz der Eingaben.

Es ist ein nichtkommutatives Grundwort (wie alle binären arithmetischen Operationen), daher ist die Reihenfolge der Argumente wichtig, wenn das eine Argument ein zusammengesetzter Typ und das andere ein Skalar ist.

Beispiele:

1-2		;-1  ;-)
1.2-2.4		;-1.2  ;-)
1i-2i		;0-1i  ;-)
[1 2]-[3 4]		;[-2 -2] ;-)
[1 2]- 3		;[-2 -1] ;-)
1-[2 3]		;-4  ;-)

Differenz 1 2		;-1  ;-)
Differenz 1.2 2.4		;-1.2  ;-)
Differenz 1i 2i		;0-1i  ;-)
Differenz [1 2][3 4]		;[-2 -2] ;-)
Differenz [1 2] 3		;[-2 -1] ;-)
Differenz 1 [2 3]		;-4  ;-)

Example:

  • TiefentestAus

References:

    Zylinder(2), TiefentestAus, rsub

Summe minus


HC / Arithmetik / Lineare Operationen / minus

minus

HC [image] Arithmetik [image] Lineare Operationen [image] minus
Differenz Produkt

minus zahl
- zahl

Ausgabe ist das Negative der Eingabe. Minus-Zeichen bedeutet unärese Minus, wenn unmittelbar vor ihm etwas davorsteht, das eine Eingabe benötigt, oder Leerraum vor ihm und hinter ihm kein Leerraum ist. Es gibt einen Unterschied in der Bindungstärke zwischen den zwei Formen:

MINUS 3 + 4	bedeutet	-(3+4)
- 3 + 4		bedeutet	(-3)+4


HC / Arithmetik / Lineare Operationen / Produkt

Produkt

HC [image] Arithmetik [image] Lineare Operationen [image] Produkt
minus Numerische Operationen

Produkt zahl1 zahl2
(Produkt zahl1 zahl2 zahl3...)
zahl1 * zahl2

Ausgabe ist das Produkt der Eingaben.

Es ist ein nichtkommutatives Grundwort (wie alle binären arithmetischen Operationen), daher ist die Reihenfolge der Argumente wichtig, wenn das eine Argument ein zusammengesetzter Typ und das andere ein Skalar ist.

Beispiele:

2*3		;6  ;-)
2*pi		;6.28319  ;-)
[1 2 3]*[4 5 6]		;[4 10 18] ;-)
0+[1 2 3]*[4 5 6]		;32  ;-)	==Skalarprodukt!
1*[2 3 4]	;24  ;-)  multipliziert alle Zahlen in einer Liste
[2 3 4]*2	;[4 6 8] ;-)

Produkt 2 3		;6  ;-)
Produkt 2 pi		;6.28319  ;-)
Produkt [1 2 3] [4 5 6]		;[4 10 18] ;-)
0+Produkt [1 2 3] [4 5 6]		;32  ;-)	==Skalarprodukt!

Example:

  • Vorlagen-basierte Iteration

References:

    Vorlagen-basierte Iteration, rmul

minus Numerische Operationen


HC / Arithmetik / Numerische Operationen

Numerische Operationen

HC [image] Arithmetik [image] Numerische Operationen
Produkt teile

Numerische Operationen

...werden für numerische Rechnungen benötigt.

Die meisten von ihnen funktionieren auch auf Listen- und Reihen-Strukturen, die Zahlen enthalten (wenn sie auf Listen wirken, dann wirken sie auch auf Reihen). In solch einem Fall setzt die erste Eingabe für eine binäre Funktion die Ausgabestruktur, so dass, wenn die erste Eingabe eine Zahl ist, dann ist das Ergebnis auch eine Zahl.

Die numerischen Operationen, die zwei Argumente nehmen (binäre Arithmetische Funktionen), sind nichtkommutative Grundwörter, so ist die Reihenfolge der Argumente wichtig, wenn ein Argument eine Liste und das andere ein Skalar ist. Es war viel leichter, alle binären arithmetischen Funktioen nichtkommutativ zu machen, als nur einige von ihnen.

Sie können natürlich auch die numerischen Infixoperatoren + - * / ^ für Rechnungen benutzen.

Numerische Operationen

  • teile
  • RestDerDivision
  • TeileMitRest
  • abs
  • konjugiere
  • quadriere
  • Fakultät
  • Faktorisiere
  • kleinstes
  • größtes
  • MaximumsNorm
  • GGT
  • kgv
  • vergrößere
  • TiefpaßFilter
  • TiefpaßFilter2
  • sättigeOberhalb
  • sättigeUnterhalb
  • Kreuzprodukt
  • invertiere
  • transponiere
  • MandelIterate

Reference:

    Arithmetik

Produkt teile


HC / Arithmetik / Numerische Operationen / teile

teile

HC [image] Arithmetik [image] Numerische Operationen [image] teile
Numerische Operationen RestDerDivision

teile zahl1 zahl2
(teile zahl)
zahl1 / zahl2

Ausgabe ist der Quotient der Eingaben. Das Ergebnis von teile zweier Ganzzahlen ist dann und nur dann auch eine Ganzzahl, wenn der Dividend ein Vielfaches des Divisors ist. (Mit anderen Worten ist TEILE 5 2 2.5, ist nicht 2, aber TEILE 4 2 ist 2, nicht 2.0 -- es versucht, es richtig zu machen.) Mit einer einzelnen Eingabe gibt TEILE den Kehrwert der Eingabe aus.

Beispiele:

2/3		;0.666667  ;-)
pi/2		;1.5708  ;-)
[1 2 3]/[4 5 6]		;[0.25 0.4 0.5] ;-)

teile 2 3		;0.666667  ;-)
teile pi 2		;1.5708  ;-)
teile [1 2 3] [4 5 6]		;[0.25 0.4 0.5] ;-)
(teile 4)		;0.25  ;-)

References:

    Auswähler, Grafiken

Numerische Operationen RestDerDivision


HC / Arithmetik / Numerische Operationen / RestDerDivision

RestDerDivision

HC [image] Arithmetik [image] Numerische Operationen [image] RestDerDivision
teile TeileMitRest

RestDerDivision zahl1 zahl2

Ausgabe ist der Rest der Ganzzahl-Division von zahl1 durch zahl2; beide müssen Ganzzahlen sein, und das Ergebnis ist eine Ganzzahl mit dem gleichen Vorzeichen wie zahl1.

Beispiele:

RestDerDivision 4 3		;1  ;-)
RestDerDivision 5 3		;2  ;-)
RestDerDivision 6 3		;0  ;-)
RestDerDivision 7 3		;1  ;-)
RestDerDivision -7 3		;-1  ;-)
TeileMitRest -7 3		;2  ;-)
RestDerDivision [9 10 11][9 9 9]	;[0 1 2] ;-)

Example:

  • TeileMitRest

References:

    Release Notes für Version 4.64, TeileMitRest

teile TeileMitRest


HC / Arithmetik / Numerische Operationen / TeileMitRest

TeileMitRest

HC [image] Arithmetik [image] Numerische Operationen [image] TeileMitRest
RestDerDivision abs

TeileMitRest zahl1 zahl2

Ausgabe ist der Rest der Division von zhal1 durch zahl2; beide müssen Ganzzahlen sein, und das Ergebnis ist eine Ganzzahl mit dem gleichen Vorzeichen wie num2.

Beispiele:

mod 4 3		;1  ;-)
mod 5 3		;2  ;-)
mod 6 3		;0  ;-)
mod 7 3		;1  ;-)
mod -7 3		;2  ;-)
RestDerDivision -7 3		;-1  ;-)
mod [9 10 11][9 9 9]	;[0 1 2] ;-)

Example:

  • RestDerDivision

Reference:

    RestDerDivision

RestDerDivision abs


HC / Arithmetik / Numerische Operationen / abs

abs

HC [image] Arithmetik [image] Numerische Operationen [image] abs
TeileMitRest konjugiere

abs zahl

Ausgabe ist der Absolutwert der zahl, das ist betragsmäßig die gleiche Zahl wie die Eingabe, jedoch mit positivem Vorzeichen.

Beispiele:

abs -1		;1  ;-)
abs -1.2		;1.2  ;-)
abs [-1 -2.2]		;[1 2.2] ;-)

Reference:

    Release Notes für Version 4.64

TeileMitRest konjugiere


HC / Arithmetik / Numerische Operationen / konjugiere

konjugiere

HC [image] Arithmetik [image] Numerische Operationen [image] konjugiere
abs quadriere

konjugiere komplexezahl

Ausgabe ist die komplex konjugierte Zahl zur Eingabe. Das heißt, das Vorzeichen des Imaginärteils wird umgedreht. Folgender Ausdruck ist zu konjugiere gleichwertig:

(real z)-1i*(imag z)


HC / Arithmetik / Numerische Operationen / quadriere

quadriere

HC [image] Arithmetik [image] Numerische Operationen [image] quadriere
konjugiere Fakultät

quadriere zahl

Ausgabe ist das Quadrat (zahl*zahl) der Eingabe.

Beispiele:

quadriere 2		;4  ;-)
quadriere 0.25		;0.0625  ;-)
quadriere 1i		;-1+0i  ;-)
quadriere [2 0.25 1i]		;[4 0.0625 -1+0i] ;-)

Reference:

    Release Notes für Version 4.64

konjugiere Fakultät


HC / Arithmetik / Numerische Operationen / Fakultät

Fakultät

HC [image] Arithmetik [image] Numerische Operationen [image] Fakultät
quadriere Faktorisiere

Fakultät Ganzzahl

Ausgabe ist die Fakultät der Ganzzahl. Diese Funktion ist exact, wenn möglich.

Fakultät 0		;1  ;-)
Fakultät 1		;1  ;-)
Fakultät 2		;2  ;-)
Fakultät 3		;6  ;-)
Fakultät 4		;24  ;-)
Fakultät 5		;120  ;-)

Example:

  • Faktorisiere

Reference:

    Faktorisiere

quadriere Faktorisiere


HC / Arithmetik / Numerische Operationen / Faktorisiere

Faktorisiere

HC [image] Arithmetik [image] Numerische Operationen [image] Faktorisiere
Fakultät kleinstes

Faktorisiere Ganzzahl

Ausgabe ist eine Liste der Primfaktoren der Ganzzahl.

Beispiele:

faktorisiere 12		;[3 2 2] ;-)
faktorisiere 120		;[5 3 2 2 2] ;-)
bigFloatSetPrecision 800
zeige faktorisiere Fakultät 333	;warte ein paar Sekunden und schau!

Reference:

    Release Notes für Version 4.64

Fakultät kleinstes


HC / Arithmetik / Numerische Operationen / kleinstes

kleinstes

HC [image] Arithmetik [image] Numerische Operationen [image] kleinstes
Faktorisiere größtes

kleinstes zahl1 zahl2
(kleinstes zahl1 zahl2...)

Ausgabe ist das Minimum, d.h. das Kleinste der Zahlenparameter.

Beispiele:

kleinstes 1 2		;1  ;-)
(kleinstes 5 2 2.3 5.0 2.9 3.0)		;2  ;-)
(kleinstes [1 2 3 4])	;1  ;-)
(kleinstes {4 3 2 1})	;1  ;-)

References:

    GanzzahlBox(5), Schieberegler(5), Zahlbox(5), holeZahlVomBenutzer(3), setzeGanzzahlBoxBereich(2), setzeReelleZahlboxBereich(2), setzeSchiebereglerBereich(2), Release Notes für Version 4.64

Faktorisiere größtes


HC / Arithmetik / Numerische Operationen / größtes

größtes

HC [image] Arithmetik [image] Numerische Operationen [image] größtes
kleinstes MaximumsNorm

größtes zahl1 zahl2
(größtes zahl1 zahl2...)

Ausgaben das Maximum aller Zahlenparameter.

Beispiele:

größtes 1 2		;2  ;-)
(größtes 5 2 2.3 5.0 2.9 3.0)		;5  ;-)
(größtes [1 2 3 4])	;4  ;-)
(größtes {4 3 2 1})	;4  ;-)

References:

    GanzzahlBox(5), Schieberegler(5), Zahlbox(5), holeZahlVomBenutzer(3), setzeBalkenBereich(2), setzeGanzzahlBoxBereich(2), setzeReelleZahlboxBereich(2), setzeSchiebereglerBereich(2), MaximumsNorm, Release Notes für Version 4.64

kleinstes MaximumsNorm


HC / Arithmetik / Numerische Operationen / MaximumsNorm

MaximumsNorm

HC [image] Arithmetik [image] Numerische Operationen [image] MaximumsNorm
größtes GGT

MaximumsNorm zahl
(MaximumsNorm zahl1 zahl2...)

Ausgabe ist die Maximumsnorm der Zahlen, wie (größtes zahl1 zahl2...)

Beispiele:

(MaximumsNorm 3 4)		;4  ;-)
MaximumsNorm [3 4]		;4  ;-)

Reference:

    Release Notes für Version 4.64

größtes GGT


HC / Arithmetik / Numerische Operationen / GGT

GGT

HC [image] Arithmetik [image] Numerische Operationen [image] GGT
MaximumsNorm kgv

GGT zahl1 zahl2

Ausgabe ist der größte gemeinsame Teiler der beiden Eingaben.

Beispiele:

GGT 8 12		;4  ;-)
GGT 10 20		;10  ;-)


HC / Arithmetik / Numerische Operationen / kgv

kgv

HC [image] Arithmetik [image] Numerische Operationen [image] kgv
GGT vergrößere

kgv zahl1 zahl2 (Bibliotheksprozedur)

Ausgabe ist das kleinste gemeinsame Vielfache der zwei Eingaben.

Beispiel:

kgv 8 12
24  ;-)


HC / Arithmetik / Numerische Operationen / vergrößere

vergrößere

HC [image] Arithmetik [image] Numerische Operationen [image] vergrößere
kgv TiefpaßFilter

vergrößere reihe groß

Ausgabe ist eine interpolierte Reihe der neuen Größe groß. Kann auch zum verkleinern verwendet werden.

Beispiele:

vergrößere {1 1} 5		;{1 1 1 1 1}  ;-)
vergrößere {1 2} 5		;{1 1.25 1.5 1.75 2}  ;-)
vergrößere {1 2 3} 5		;{1 1.5 2 2.5 3}  ;-)
vergrößere {1 2 3} 6		;{1 1.5 2 2.33333 2.66667 3}  ;-)

Example:

  • spieleWaveSchnell

References:

    Release Notes für Version 4.64, spieleWaveSchnell, zerstöreGraph

kgv TiefpaßFilter


HC / Arithmetik / Numerische Operationen / TiefpaßFilter

TiefpaßFilter

HC [image] Arithmetik [image] Numerische Operationen [image] TiefpaßFilter
vergrößere TiefpaßFilter2

TiefpaßFilter in Gewicht

Ausgabe ist eine neue Reihe reelleZahlen, Ganzzahlen oder 16BitZahlen, die die mit einem Tiefpass gefilterte Eingabe in enthält, je nach Typ der Eingabe. Gewicht ist die Gewichtung des für die Rechnung benutzten Mittelwerts. Der angewandte einfache Algorithmus ist

m.(1)=in.(1)
für [n 1 [zähle in]]
[	out.n=(m.n*weight+in.n)/(weight+1)
    m.(n+1)=out.n
]

Beispiel:

x=reelleZahlenFolge -1 1 1000
y=(sinus x*x*20*360)*300
x=x*400
setzeStiftfarbe 0
setzeXY x y
setzeStiftfarbe 4
setzeXY x reelleZahlen TiefpaßFilter y 10
löscheSchirm
setzeXY x reelleZahlen TiefpaßFilter Ganzzahlen y 10
löscheSchirm
setzeXY x reelleZahlen TiefpaßFilter 16BitZahlen y 10

Examples:

  • TiefpaßFilter2
  • setzeXY

References:

    TiefpaßFilter2(3), Release Notes für Version 4.686, setzeXY

vergrößere TiefpaßFilter2


HC / Arithmetik / Numerische Operationen / TiefpaßFilter2

TiefpaßFilter2

HC [image] Arithmetik [image] Numerische Operationen [image] TiefpaßFilter2
TiefpaßFilter sättigeOberhalb

TiefpaßFilter2 in Gewicht

Ausgabe ist eine neue Reihe reelleZahlen, Ganzzahlen oder 16BitZahlen, die die mit einem Tiefpass gefilterte Eingabe in enthält, je nach Typ der Eingabe. Gewicht ist die Gewichtung des für die Rechnung benutzten Mittelwerts. Der angewandte einfache Algorithmus ist

m.(1)=in.(1)
für [n 1 [zähle in]]
[	out.n=(m.n*weight+in.n)/(weight+1)
    m.(n+1)=out.n
]

Example:

x=reelleZahlenFolge -1 1 1000
y=(sinus x*x*20*360)*300
x=x*400
setzeStiftfarbe 0
setzeXY x y
setzeStiftfarbe 4
setzeXY x reelleZahlen TiefpaßFilter y 10
löscheSchirm
setzeXY x reelleZahlen TiefpaßFilter Ganzzahlen y 10
löscheSchirm
setzeXY x reelleZahlen TiefpaßFilter 16BitZahlen y 10


HC / Arithmetik / Numerische Operationen / sättigeOberhalb

sättigeOberhalb

HC [image] Arithmetik [image] Numerische Operationen [image] sättigeOberhalb
TiefpaßFilter2 sättigeUnterhalb

sättigeOberhalb Grenze in

Ausgabe ist ein neue Reihe reelleZahlen, Ganzzahlen oder 16BitZahlen, je nach Typ der Eingabe, die die gesättigte Eingabe in zum Inhalt hat. Jedes Element von in wird überprüft, ob es oberhalb der Grenze liegt. Wenn ja, wird die Grenze ausgegeben, andernfalls das Element selbst.

Beispiel:

sättigeOberhalb 50 rseqFA 1 100 10
;{1 12 23 34 45 50 50 50 50 50}  ;-)

Reference:

    Release Notes für Version 4.686

TiefpaßFilter2 sättigeUnterhalb


HC / Arithmetik / Numerische Operationen / sättigeUnterhalb

sättigeUnterhalb

HC [image] Arithmetik [image] Numerische Operationen [image] sättigeUnterhalb
sättigeOberhalb Kreuzprodukt

sättigeUnterhalb Grenze in

Ausgabe ist ein neue Reihe reelleZahlen, Ganzzahlen oder 16BitZahlen, je nach Typ der Eingabe, die die gesättigte Eingabe in zum Inhalt hat. Jedes Element von in wird überprüft, ob es unterhalb der Grenze liegt. Wenn ja, wird die Grenze ausgegeben, andernfalls das Element selbst.

Beispiel:

sättigeUnterhalb 50 rseqFA 1 100 10
;{50 50 50 50 50 56 67 78 89 100}  ;-)

Reference:

    Release Notes für Version 4.686

sättigeOberhalb Kreuzprodukt


HC / Arithmetik / Numerische Operationen / Kreuzprodukt

Kreuzprodukt

HC [image] Arithmetik [image] Numerische Operationen [image] Kreuzprodukt
sättigeUnterhalb invertiere

Kreuzprodukt z Kreuzprodukt x y
Ausgabe ist das Kreuzprodukt der 3 D Reihen x und y.
Das Skalarprodukt aus Ergebnis z mit je einem der beiden Eingabevektoren ist stets 0. D. h. z steht senkrecht auf x, und z steht senkrecht auf y.

Beispiel:

Kreuzprodukt {1 0 0}{0 1 0}		;{0 0 1}  ;-)

Reference:

    Release Notes für Version 4.64

sättigeUnterhalb invertiere


HC / Arithmetik / Numerische Operationen / invertiere

invertiere

HC [image] Arithmetik [image] Numerische Operationen [image] invertiere
Kreuzprodukt transponiere

invertiere
invertierteMatrix invertiereMatrix EingabeMatrix

Ausgabe ist die invertierte Matrix der EingabeMatrix. Wenn die Determinante null ist, wird ein Fehler ausgeworfen. Es gibt interne Sonderfälle für d=1x1, 2x2, 3x3, so dass die Laufzeit optimal ist.

EingabeMatrix: Reihe n von Reihe n.

Beispiel:

invertMatrix {{1 0 1}{2 1 2}{3 2 1}}
{	{1.5 -1 0.5}
    {-2 1 0}
    {-0.5 1 -0.5}
}  ;-)


HC / Arithmetik / Numerische Operationen / transponiere

transponiere

HC [image] Arithmetik [image] Numerische Operationen [image] transponiere
invertiere MandelIterate

transponiere eineMatrix

Ausgabe ist die transponierte Eingabe-Matrix. D. h. Spalten und Zeilen werden vertauscht.

Beispiel:

transponiere [[1 2][3 4][5 6]]
    [	[1 3 5]
        [2 4 6]
    ]
 ;-)


HC / Arithmetik / Numerische Operationen / MandelIterate

MandelIterate

HC [image] Arithmetik [image] Numerische Operationen [image] MandelIterate
transponiere Zahlen-Generatoren

MandelIterate z ca maxiter

ist ein schönes Beispiel für ein Benutzer-definierte Funktion. Es hilft die Mandelbrot-Menge schneller zu berechnen. Wie in:

zu mandelIterateLogo z ca maxiter wiederhole maxiter [z*=z z+=c wenn z > 4 [Ausgabe-Repcount]]
wiederhole maxiter
[	z*=z
    z+=c
    wenn z > 4 [output repcount]
]
output maxiter

Zusätzlich können z und c vom Typ Reihe von komplexen Zahlen sein, so dass man mehrere Pixel in einem Schritt berechnen kann. Für Beispiele siehe mandel.lg...mandel5.lg!

Reference:

    Release Notes für Version 4.686

transponiere Zahlen-Generatoren


HC / Arithmetik / Zahlen-Generatoren

Zahlen-Generatoren

HC [image] Arithmetik [image] Zahlen-Generatoren
MandelIterate GanzzahlFolge

Zahlen-Generatoren

...erzeugen Ansammlungen von Zahlen (Listen und Reihen).

Zahlen-Generatoren

  • GanzzahlFolge
  • GanzzahlenFolge
  • ZahlenFolge
  • reelleZahlenFolge


HC / Arithmetik / Zahlen-Generatoren / GanzzahlFolge

GanzzahlFolge

HC [image] Arithmetik [image] Zahlen-Generatoren [image] GanzzahlFolge
Zahlen-Generatoren GanzzahlenFolge

GanzzahlFolge von zu

Ausgabe ist eine Liste der Ganzzahlen von VON zu zu, inklusive der Grenzen.

Beispiele:

GanzzahlFolge 3 7		;[3 4 5 6 7] ;-)
GanzzahlFolge 7 3		;[7 6 5 4 3] ;-)

Examples:

  • setzePunktXYZ
  • setzePunktXY

References:

    setzePunktXY(2), setzePunktXYZ(2), GanzzahlenFolge

Zahlen-Generatoren GanzzahlenFolge


HC / Arithmetik / Zahlen-Generatoren / GanzzahlenFolge

GanzzahlenFolge

HC [image] Arithmetik [image] Zahlen-Generatoren [image] GanzzahlenFolge
GanzzahlFolge ZahlenFolge

GanzzahlenFolge von zu Anzahl

Ausgabe ist eine Ganzzahlen-Reihe mit Anzahlk Elementen von VON zu zu, inklusive der Grenzen. Intern funktioniert es wie reelleZahlenFolge, nur werden die resultierenden Zahlen auf die nächste ganze Zahl gerundet, bevor sie in das Ganzzahlen-Ergebnis geschrieben werden. Diese Funktion kann bequem sein, wenn Sie ein Ganzzahlen-Ergebnis auf schnelle Weise erzeugen wollen, ohne z.B. temporäre reelleZahlen zu generieren mit reelleZahlenReihe, oder noch langsamer, einer Liste mit GanzzahlFolge. Verwendung von schleifen ist natürlich noch langsamer.

Beispiele:

GanzzahlenFolge 3 7		;[3 4 5 6 7] ;-)
GanzzahlenFolge 7 3		;[7 6 5 4 3] ;-)


HC / Arithmetik / Zahlen-Generatoren / ZahlenFolge

ZahlenFolge

HC [image] Arithmetik [image] Zahlen-Generatoren [image] ZahlenFolge
GanzzahlenFolge reelleZahlenFolge

ZahlenFolge von zu Anzahl

Ausgabe ist eine Liste von Anzahl Zahlen, die in gleichen Abständen von VON bis zu aufeinander folgen. ZahlenFolge ist auch nützlich, um eine Liste von gleichen Zahlen, wie im letzten Beispiel, zu erzeugen.

Beispiele:

ZahlenFolge 3 5 9		;[3 3.25 3.5 3.75 4 4.25 4.5 4.75 5] ;-)
ZahlenFolge 3 5 5		;[3 3.5 4 4.5 5] ;-)
ZahlenFolge pi pi 4		;[3.14159 3.14159 3.14159 3.14159] ;-)

Examples:

  • radBogenKosinus
  • radBogenSinus
  • setzePunktXYZ
  • BogenTangens
  • setzePunktXY
  • setzeXY
  • Sounds

References:

    Sounds(4), BogenTangens, Release, radBogenKosinus, radBogenSinus, setzePunktXY, setzePunktXYZ, setzeXY

GanzzahlenFolge reelleZahlenFolge


HC / Arithmetik / Zahlen-Generatoren / reelleZahlenFolge

reelleZahlenFolge

HC [image] Arithmetik [image] Zahlen-Generatoren [image] reelleZahlenFolge
ZahlenFolge Zufallszahlen

reelleZahlenFolge von zu Anzahl

Ausgabe ist eine Reihe von Anzahl reeller Zahlen, die in gleichem Abstand aufeinander folgen von VON bis zu, inklusive der Grenzen. reelleZahlenFolge ist auch nützlich, um reelleZahlen von gleichen Zahlen, wie im letzten der Beispiele, zu erzeugen.

Beispiele:

reelleZahlenFolge 3 5 9		;[3 3.25 3.5 3.75 4 4.25 4.5 4.75 5] ;-)
reelleZahlenFolge 3 5 5		;[3 3.5 4 4.5 5] ;-)
reelleZahlenFolge pi pi 4		;[3.14159 3.14159 3.14159 3.14159] ;-)

Examples:

  • setzeNebeldichte
  • setzeNebelModus
  • TiefpaßFilter2
  • setzePunktXYZ
  • TiefpaßFilter
  • setzePunktXY

References:

    setzeNebelModus(3), setzeNebeldichte(3), Release(2), GanzzahlenFolge, TiefpaßFilter, TiefpaßFilter2, setzePunktXY, setzePunktXYZ

ZahlenFolge Zufallszahlen


HC / Arithmetik / Zufallszahlen

Zufallszahlen

HC [image] Arithmetik [image] Zufallszahlen
reelleZahlenFolge ZufallsZahl

Zufallszahlen

...werden bei der Benutzung von "ZufallsZahl" und "zufällig" erzeugt.

Der Zufallszahlengenerator kann mit neuerZufall auf eine reproduzierbare Folge von Zahlen gesetzt werden.

Zufallszahlen

  • ZufallsZahl
  • neuerZufall
  • zufällig


HC / Arithmetik / Zufallszahlen / ZufallsZahl

ZufallsZahl

HC [image] Arithmetik [image] Zufallszahlen [image] ZufallsZahl
Zufallszahlen neuerZufall

ZufallsZahl Zahl

Ausgabe ist eine zufällige, nichtnegative Ganzzahl kleiner als die Eingabe Zahl, die eine Ganzzahl sein muss, oder ein Liste oder Reihe von Ganzzahlen.

Beispiele:

random 10	;4 ;-)
random [100 200 300]	;[18 113 208] ;-)
random {100 200 300}	;{78 100 135}  ;-)

References:

    neuerZufall(3), Zufallszahlen

Zufallszahlen neuerZufall


HC / Arithmetik / Zufallszahlen / neuerZufall

neuerZufall

HC [image] Arithmetik [image] Zufallszahlen [image] neuerZufall
ZufallsZahl zufällig

neuerZufall
(neuerZufall Zahl)

Kommando. Macht die Ergebnisse von ZufallsZahl reproduzierbar. Normalerweise ist die Abfolge von ZufallsZahl Zahlen unterschiedlich jedes Mal, wenn Logo benutzt wird. Wenn Sie die gleiche Abfolge von pseudo-zufälligen Zahlen immer wieder brauchen, z. B. zur Fehlersuche in einem Programm, verwenden Sie neuerZufall vor dem ersten Aufruf von ZufallsZahl oder zufällig. Wenn Sie mehr als eine wiederholbare Sequenz benötigen, können Sie neuerZufall eine ganzzahlige Eingabe geben; jede mögliche Eingabe wählt eine einmalige Sequenz von Zahlen aus.

Reference:

    Zufallszahlen

ZufallsZahl zufällig


HC / Arithmetik / Zufallszahlen / zufällig

zufällig

HC [image] Arithmetik [image] Zufallszahlen [image] zufällig
neuerZufall Irrationale Zahlen

zufällig

Ausgabe ist eine zufällige Gleitkommaanzahl im Bereich von 0 bis 1.

Example:

  • zeichneBitmapSchnell

References:

    zeichneBitmapSchnell(2), Release Notes für Version 4.64, Zufallszahlen, mische, neuerZufall, wähleZufällig

neuerZufall Irrationale Zahlen


HC / Arithmetik / Irrationale Zahlen

Irrationale Zahlen

HC [image] Arithmetik [image] Irrationale Zahlen
zufällig Quadratwurzel

Irrationale Zahlen

...lassen sich nicht als abbrechende Dezimalbrüche darstellen. Jedoch kann man sie bis zu sehr großer Genauigkeit annähern. Hierzu dienen die in diesem Abschnitt beschriebenen Funktionen.

Beispiele von irrationalen Zahlen sind z.B. Pi, exp 1 oder die Lösung der Gleichung
    (x*x)==2,
die als
    x=sqrt 2
geschrieben werden kann.

Irrationale Zahlen

  • Quadratwurzel
  • Potenz
  • exp
  • natürlicherLogarithmus
  • ZehnerLogarithmus
  • Norm


HC / Arithmetik / Irrationale Zahlen / Quadratwurzel

Quadratwurzel

HC [image] Arithmetik [image] Irrationale Zahlen [image] Quadratwurzel
Irrationale Zahlen Potenz

Quadratwurzel Zahl

Ausgabe ist die Quadratwurzel der Eingabe.

Beispiele:

Quadratwurzel 4		;2  ;-)
Quadratwurzel 2		;1.41421  ;-)
Quadratwurzel -1		;0+1i  ;-)
Quadratwurzel [4 2 -1]		;[2 1.41421 0+1i] ;-)

Examples:

  • TesselationStart
  • radBogenKosinus
  • radBogenTangens
  • radBogenSinus
  • BogenKosinus
  • BogenTangens
  • BogenSinus

References:

    BogenKosinus(4), radBogenKosinus(4), BogenSinus(2), BogenTangens(2), TesselationStart(2), radBogenSinus(2), Norm, Release Notes für Version 4.64, radBogenTangens

Irrationale Zahlen Potenz


HC / Arithmetik / Irrationale Zahlen / Potenz

Potenz

HC [image] Arithmetik [image] Irrationale Zahlen [image] Potenz
Quadratwurzel exp

Potenz zahl1 zahl2
zahl1 ^ zahl2

Ausgabe ist zahl1 hoch zahl2. Wenn zahl1 negativ ist, dann muss zahl2 muss eine Ganzzahl sein.

Beispiele:

2^0		;1  ;-)
2^1		;2  ;-)
2^2		;4  ;-)
2^3		;8  ;-)
2^(1/12)		;1.05946  ;-)
4^2		;16  ;-)
10^300		;1e+300  ;-)
Potenz [2 2 2 2 2 4 10] (liste 0 1 2 3 1/12 2 300)
;[1 2 4 8 1.05946 16 1e+300] ;-)

See also:

  • Fehler-Verarbeitung

References:

    Fehler-Verarbeitung, Release Notes für Version 4.64, verkleinereStapel

Quadratwurzel exp


HC / Arithmetik / Irrationale Zahlen / exp

exp

HC [image] Arithmetik [image] Irrationale Zahlen [image] exp
Potenz natürlicherLogarithmus

exp Zahl

Ausgabe ist e (=2.718281828...) hoch der Eingabe.

Beispiele:

exp 0		;1  ;-)
exp 1		;2.71828  ;-)
exp 2		;7.38906  ;-)
exp 1i*pi		;-1+1.22461e-016i  ;-)	nearly -1, so nearly correct
exp 1i*2*pi		;1-2.44921e-016i  ;-)  nearly 1, so nearly correct
exp (liste 0 1 2 1i*pi 2i*pi)
;[1 2.71828 7.38906 -1+1.22461e-016i 1-2.44921e-016i] ;-)

Examples:

  • Release Notes für Version 4.64
  • natürlicherLogarithmus
  • setzeSchreibpräzision
  • Über Komplexität
  • formatiere

References:

    natürlicherLogarithmus(5), Release Notes für Version 4.64(2), Irrationale Zahlen, formatiere, setzeSchreibpräzision, Über Komplexität

Potenz natürlicherLogarithmus


HC / Arithmetik / Irrationale Zahlen / natürlicherLogarithmus

natürlicherLogarithmus

HC [image] Arithmetik [image] Irrationale Zahlen [image] natürlicherLogarithmus
exp ZehnerLogarithmus

natürlicherLogarithmus Zahl

Ausgabe ist der natürliche Logarithmus (Logarithmus Naturalis) der Eingabe.

Beispiele:

natürlicherLogarithmus exp 1		;1  ;-)
natürlicherLogarithmus (exp 1)^2		;2  ;-)
natürlicherLogarithmus (liste (exp 1)^-1 1 exp 1 (exp 1)^2)		;[-1 0 1 2] ;-)

Reference:

    Release Notes für Version 4.64

exp ZehnerLogarithmus


HC / Arithmetik / Irrationale Zahlen / ZehnerLogarithmus

ZehnerLogarithmus

HC [image] Arithmetik [image] Irrationale Zahlen [image] ZehnerLogarithmus
natürlicherLogarithmus Norm

ZehnerLogarithmus Zahl

Ausgaben der Zehnerlogarithmus der Eingabe.

Beispiele:

ZehnerLogarithmus 10		;1  ;-)
ZehnerLogarithmus 100		;2  ;-)
ZehnerLogarithmus 1000		;3  ;-)
ZehnerLogarithmus 1		;0  ;-)
ZehnerLogarithmus 1/10		;-1  ;-)
ZehnerLogarithmus (liste 1/10 1 10 100 1000)		;[-1 0 1 2 3] ;-)

Reference:

    Release Notes für Version 4.64

natürlicherLogarithmus Norm


HC / Arithmetik / Irrationale Zahlen / Norm

Norm

HC [image] Arithmetik [image] Irrationale Zahlen [image] Norm
ZehnerLogarithmus Trigonometrische Funktionen

Norm Zahl
(Norm Zahl1 Zahl2...)
Norm VektorListeOderArray

Ausgabe ist die euklidische Norm der Zahlen, Bedeutung quadratwurzel(Zahl1*Zahl1 + Zahl2*Zahl2 + ...)

Beispiele:

(Norm 3 4)		;5  ;-)
Norm [3 4]		;5  ;-)

Example:

  • Versions-Informationen für Version 4.7

References:

    Release Notes für Version 4.64, Versions-Informationen für Version 4.7

ZehnerLogarithmus Trigonometrische Funktionen


HC / Arithmetik / Trigonometrische Funktionen

Trigonometrische Funktionen

HC [image] Arithmetik [image] Trigonometrische Funktionen
Norm Sinus

Trigonometrische Funktionen

...sind mathematische Funktionen, mit denen Berechnungen an Dreiecken (tri=drei, gonos=Eck) durchgeführt werden können. Ihre Eingaben sind Winkel in Grad oder im Bogenmaß. 360 Grad entsprechen einer ganzen Drehung im Kreis, 180 Grad einer halben Drehung. Im Bogenmaß repräsentiert 2*pi eine ganze Drehung, pi eine halbe Drehung. Das Bogenmaß bezieht sich eigentlich auf den Einheitskreis, das ist der Kreis mit Radius Eins. 2*pi ist bekanntlich der Umfang des Einheitskreises.

In dieser Gruppe sind auch noch die Umkehrfunktionen der trigonometrischen Funktionen.

Trigonometrische Funktionen

  • Sinus
  • radSinus
  • Kosinus
  • radKosinus
  • Tangens
  • radTangens
  • BogenSinus
  • radBogenSinus
  • BogenKosinus
  • radBogenKosinus
  • BogenTangens
  • radBogenTangens


HC / Arithmetik / Trigonometrische Funktionen / Sinus

Sinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] Sinus
Trigonometrische Funktionen radSinus

Sinus Grad

Ausgabe ist der Sinus der Eingabe, die in Grad angenommen wird.

Beispiele:

Sinus 0		;0  ;-)
Sinus 90		;1  ;-)
Sinus 180		;5.30717e-017  ;-)
Sinus 270		;-1  ;-)
Sinus 360		;0  ;-)
Sinus 45		;0.707107  ;-)
Sinus [0 45 90 135 180 225 270 315 360]
;[0 0.707107 1 0.707107 5.30717e-017 -0.707107 -1 -0.707107 0] ;-)
Sinus {0 45 90 135 180 225 270 315 360}
;{0 0.707107 1 0.707107 5.30717e-017 -0.707107 -1 -0.707107 0}  ;-)

Examples:

  • setzeSchreiber
  • TiefpaßFilter2
  • setzePunktXYZ
  • TiefpaßFilter
  • setzeXYZ
  • setzeXY
  • Sounds

References:

    setzeXYZ(5), Sounds(2), setzePunktXYZ(2), setzeSchreiber(2), BogenSinus, PC-Lautsprecher, Release Notes für Version 4.64, TiefpaßFilter, TiefpaßFilter2, radBogenSinus, radSinus, setzeXY

Trigonometrische Funktionen radSinus


HC / Arithmetik / Trigonometrische Funktionen / radSinus

radSinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] radSinus
Sinus Kosinus

radSinus rad

Ausgabe ist der Sinus der Eingabe, die im Bogenmaß angenommen wird.

Beispiele:

radSinus 0		;0  ;-)
radSinus pi/2		;1  ;-)
radSinus pi		;1.22461e-016  ;-)
radSinus 2*pi		;-2.44921e-016  ;-)
radSinus (liste 0 pi/2 pi 3/2*pi 2*pi)
;[0 1 1.22461e-016 -1 -2.44921e-016] ;-)

Reference:

    Release Notes für Version 4.64

Sinus Kosinus


HC / Arithmetik / Trigonometrische Funktionen / Kosinus

Kosinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] Kosinus
radSinus radKosinus

Kosinus Grad

Ausgabe ist der Kosinus der Eingabe, die in Grad angenommen wird.

Beispiele:

Kosinus 0		;1  ;-)
Kosinus 90		;2.65358e-017  ;-)
Kosinus 180		;-1  ;-)
Kosinus 270		;-7.96075e-017  ;-)
Kosinus 360		;1  ;-)
Kosinus [0 45 90 135 180 225 270 315 360]
;[1 0.707107 2.65358e-017 -0.707107 -1 -0.707107 -7.96075e-017 0.707107 1] ;-)

Examples:

  • Oberflächenspalte
  • Oberflächenstart
  • Oberflächenende
  • setzePunktXYZ
  • Oberfläche
  • Fall
  • für

References:

    Oberfläche(4), Oberflächenende(4), Oberflächenspalte(4), Oberflächenstart(4), Fall(2), setzePunktXYZ(2), BogenKosinus, Release Notes für Version 4.64, für, radBogenKosinus, radKosinus

radSinus radKosinus


HC / Arithmetik / Trigonometrische Funktionen / radKosinus

radKosinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] radKosinus
Kosinus Tangens

radKosinus rad

Ausgabe ist der Kosinus der Eingabe, die im Bogenmaß angenommen wird.

Beispiele:

radKosinus 0		;1  ;-)
radKosinus pi/2		;6.12303e-017  ;-)
radKosinus pi		;-1  ;-)
radKosinus 2*pi		;1  ;-)
radKosinus (liste 0 pi/2 pi 3/2*pi 2*pi)
;[1 6.12303e-017 -1 -1.83691e-016 1] ;-)

Reference:

    Release Notes für Version 4.64

Kosinus Tangens


HC / Arithmetik / Trigonometrische Funktionen / Tangens

Tangens

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] Tangens
radKosinus radTangens

Tangens Grad

Ausgabe ist der Tangens der Eingabe, die in Grad angenommen wird.

Beispiele:

Tangens 0		;0  ;-)
Tangens 45		;1  ;-)
Tangens 60		;1.73205  ;-)
Tangens -45		;-1  ;-)
Tangens [0 45 60]		;[0 1 1.73205] ;-)

Example:

  • Farb-Datenbank

References:

    Farb-Datenbank(2), Release Notes für Version 4.64(2), BogenTangens, radBogenTangens, radTangens

radKosinus radTangens


HC / Arithmetik / Trigonometrische Funktionen / radTangens

radTangens

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] radTangens
Tangens BogenSinus

radTangens rad

Ausgabe ist der Tangens der Eingabe, die im Bogenmaß angenommen wird.

Beispiele:

radTangens 0		;0  ;-)
radTangens pi/4		;1  ;-)
radTangens pi/3		;1.73205  ;-)
radTangens (liste 0 pi/4 pi/3)		;[0 1 1.73205] ;-)

Reference:

    Release Notes für Version 4.64(2)

Tangens BogenSinus


HC / Arithmetik / Trigonometrische Funktionen / BogenSinus

BogenSinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] BogenSinus
radTangens radBogenSinus

BogenSinus x

Ausgabe ist die Umkehrfunktion des Sinus der Eingabe. Das Ergebnis ist in Graden.

Beispiele:

BogenSinus 0		;0  ;-)
BogenSinus 1/2		;30  ;-)
BogenSinus (quadratwurzel 3)/2		;60  ;-)
BogenSinus 1		;90  ;-)
BogenSinus -1		;-90  ;-)
BogenSinus (liste 0 1/2 (Quadratwurzel 3)/2 1)		;[0 30 60 90] ;-)

Reference:

    Release Notes für Version 4.65

radTangens radBogenSinus


HC / Arithmetik / Trigonometrische Funktionen / radBogenSinus

radBogenSinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] radBogenSinus
BogenSinus BogenKosinus

radBogenSinus x

Ausgabe ist die Umkehrfunktion des Sinus der Eingabe. Das Ergebnis ist im Bogenmaß.

Beispiele:

radBogenSinus 0		;0  ;-)
pi/(radBogenSinus 1/2)		;6  ;-)
pi/(radBogenSinus (Quadratwurzel 3)/2)		;3  ;-)
pi/radBogenSinus 1		;2  ;-)
as=radBogenSinus (liste 1/2 (Quadratwurzel 3)/2 1)
(zahlenfolge pi pi 3)/as		;[6 3 2] ;-)


HC / Arithmetik / Trigonometrische Funktionen / BogenKosinus

BogenKosinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] BogenKosinus
radBogenSinus radBogenKosinus

BogenKosinus x

Ausgabe ist die Umkehrfunktion des Kosinus der Eingabe. Das Ergebnis ist in Graden.

Beispiele:

BogenKosinus 1		;0  ;-)
BogenKosinus (Quadratwurzel 3)/2		;30  ;-)
BogenKosinus 1/Quadratwurzel 2		;45  ;-)
BogenKosinus 1/2		;60  ;-)
BogenKosinus 0		;90  ;-)
BogenKosinus (liste 1 (Quadratwurzel 3)/2 1/Quadratwurzel 2 1/2 0)		;[0 30 45 60 90] ;-)

Reference:

    radBogenKosinus

radBogenSinus radBogenKosinus


HC / Arithmetik / Trigonometrische Funktionen / radBogenKosinus

radBogenKosinus

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] radBogenKosinus
BogenKosinus BogenTangens

radBogenKosinus x

Ausgabe ist die Umkehrfunktion des Kosinus der Eingabe. Das Ergebnis ist in Radianten. Siehe BogenKosinus!

Beispiele:

radBogenKosinus 1		;0  ;-)
pi/radBogenKosinus (Quadratwurzel 3)/2		;6  ;-)
pi/radBogenKosinus 1/Quadratwurzel 2		;4  ;-)
pi/radBogenKosinus 1/2		;3  ;-)
pi/radBogenKosinus 0		;2  ;-)
pi/radBogenKosinus -1		;1  ;-)
as=radBogenKosinus (liste (Quadratwurzel 3)/2 1/Quadratwurzel 2 1/2 0)
(zahlenfolge pi pi 4)/as		;[6 4 3 2] ;-)

Examples:

  • GroßeZahlSetzGenauigkeit
  • GroßeZahl

References:

    GroßeZahl, GroßeZahlSetzGenauigkeit

BogenKosinus BogenTangens


HC / Arithmetik / Trigonometrische Funktionen / BogenTangens

BogenTangens

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] BogenTangens
radBogenKosinus radBogenTangens

BogenTangens x y

Ausgabe ist die Umkehrfunktion des Tangens von y/x, in Grad, von der Eingabe, wenn x nicht Null ist, oder 90 oder -90 je nach dem Vorzeichen von y, wenn x Null ist.

Beispiele:

BogenTangens 1 0		;0  ;-)
BogenTangens 1 1		;45  ;-)
BogenTangens 1 Quadratwurzel 3		;60  ;-)
BogenTangens 1 1e300		;90  ;-)
BogenTangens -1 1		;135  ;-)
BogenTangens -1 -1		;-135  ;-)
BogenTangens 1 -1		;-45  ;-)
BogenTangens zahlenfolge 1 1 5 (liste 0 1 Quadratwurzel 3 1e300 -1)
;[0 45 60 90 -45] ;-)

Reference:

    Release Notes für Version 4.64

radBogenKosinus radBogenTangens


HC / Arithmetik / Trigonometrische Funktionen / radBogenTangens

radBogenTangens

HC [image] Arithmetik [image] Trigonometrische Funktionen [image] radBogenTangens
BogenTangens Typen-Konverter

radBogenTangens x y

Ausgabe ist die Umkehrfunktion des Tangens von y/x, im Bogenmaß, von der Eingabe, wenn x nicht Null ist, oder pi/2 oder -pi/2 je nach dem Vorzeichen von y, wenn x Null ist.

Der Ausdruck

2*(RADBOGENTANGENS 0 1)

can be used to get the value of pi.

Examples:

radBogenTangens 1 0		;0  ;-)
pi/(radBogenTangens 1 1)		;4  ;-)
pi/(radBogenTangens 1 Quadratwurzel 3)		;3  ;-)
pi/(radBogenTangens 1 1e300)		;2  ;-)

Reference:

    Release Notes für Version 4.64

BogenTangens Typen-Konverter


HC / Arithmetik / Typen-Konverter

Typen-Konverter

HC [image] Arithmetik [image] Typen-Konverter
radBogenTangens reelleZahl

Typen-Konverter

...sind Funktionen, die Zahlen eines bestimmten Types ausgeben, die aus ihren Eingaben berechnet werden.

Typen-Konverter

  • reelleZahl
  • GroßeZahl
  • GroßeZahlSetzGenauigkeit
  • Ganzzahl
  • 16BitZahl
  • 8BitZahl
  • positive8BitZahl
  • runde
  • schneideAb
  • Vorzeichen
  • konjugieren


HC / Arithmetik / Typen-Konverter / reelleZahl

reelleZahl

HC [image] Arithmetik [image] Typen-Konverter [image] reelleZahl
Typen-Konverter GroßeZahl

reelleZahl Zahl

Ausgabe ist die in die Gleitkomma-Darstellung umgewandelte Eingabe Zahl. Zahl kann ein Zahl, Liste oder Reihe von Zahlen sein.

Beispiele:

Float 1	;1  ;-)
TypVon 1	;Ganzzahl  ;-)
TypVon Float 1	;Float  ;-)
Float [1 2 3]	;[1 2 3] ;-)
Float {1 2 3}	;{1 2 3}  ;-)

Example:

  • reelleZahlP

Reference:

    reelleZahlP(8)

Typen-Konverter GroßeZahl


HC / Arithmetik / Typen-Konverter / GroßeZahl

GroßeZahl

HC [image] Arithmetik [image] Typen-Konverter [image] GroßeZahl
reelleZahl GroßeZahlSetzGenauigkeit

GroßeZahl Zahl

Ausgabe ist die in GroßeZahl Zahlen umgewandelte Eingabe Zahl. Zahl kann eine Zahl, Liste oder Reihe von Zahlen sein.

Beispiel:

zeige 2*radBogenKosinus GroßeZahl 0

Example:

  • GroßeZahlSetzGenauigkeit

References:

    GroßeZahlSetzGenauigkeit(2), Release Notes für Version 4.685

reelleZahl GroßeZahlSetzGenauigkeit


HC / Arithmetik / Typen-Konverter / GroßeZahlSetzGenauigkeit

GroßeZahlSetzGenauigkeit

HC [image] Arithmetik [image] Typen-Konverter [image] GroßeZahlSetzGenauigkeit
GroßeZahl Ganzzahl

GroßeZahlSetzGenauigkeit Genauigkeit

Kommando, um die interne und Schreib-Präzision von Zahlen des Types GroßeZahl auf die Genauigkeit zu setzen.

Beispiel:

GroßeZahlSetzGenauigkeit 128
zeige 2*radBogenKosinus GroßeZahl 0	;gives Pi

Reference:

    Release Notes für Version 4.685

GroßeZahl Ganzzahl


HC / Arithmetik / Typen-Konverter / Ganzzahl

Ganzzahl

HC [image] Arithmetik [image] Typen-Konverter [image] Ganzzahl
GroßeZahlSetzGenauigkeit 16BitZahl

Ganzzahl Zahl

Ausgabe ist die Eingabe ohne ihre Nachkommastellen, d. h., eine Ganzzahl mit dem gleichen Vorzeichen wie die Eingabe, deren Absolutwert die größte Ganzzahl kleiner als der Absolutwert der Eingabe ist.

Anmerkung: Im Computer werden Zahlen in mehreren unterschiedlichen Formen gespeichert, einer für Ganzzahlen (Integer) und einer für Kommazahlen (Float). Allerdings ist die größte Zahl, die im Ganzzahl-Format repräsentiert werden kann, auf den meisten Computern kleiner als die größte Ganzzahl, die (sogar mit exakter Genauigkeit) in Gleitkomma-Darstellung gespeichert werden kann.

Beispiele:

Ganzzahl 1.2		;1  ;-)
Ganzzahl -1.2		;-1  ;-)
Ganzzahl 1.9		;1  ;-)
Ganzzahl -1.9		;-1  ;-)
Ganzzahl [1.2 -1.2 1.9 -1.9]		;[1 -1 1 -1] ;-)

Examples:

  • rufeDynamischeBibliothekAuf
  • DynamischeBibliothek
  • setzeSchreiber
  • setzePunktXYZ
  • setzePunktXY
  • reelleZahl
  • TextPuffer
  • GanzzahlP
  • GrößeVon
  • Struktur
  • solange
  • TypVon
  • xMinus
  • xPlus

References:

    rufeDynamischeBibliothekAuf(13), GanzzahlP(12), Ganzzahlen(7), DynamischeBibliothek(6), Struktur(6), setzeSchreiber(6), runSecure(5), PrimzahlP(4), TypVon(3), Zeichen(3), setzePunktXYZ(3), 16BitZahlen(2), EllipsoidenTeil(2), Faktorisiere(2), Fakultät(2), GrößeVon(2), MidiAusgabestrom(2), MidiNoteAn(2), MidiNoteAus(2), Reihe(2), RestDerDivision(2), TextPuffer(2), ZufallsZahl(2), holeListenControlElement(2), liesGanzzahlBinär(2), setzeListenControlElement(2), setzePunktXY(2), wechsleMidiProgramm(2), 16BitZahl, 8BitZahl, ASCII, ASCIIroh, AuswahlboxAuswahl, BitNicht, Füllfarbe, GanzzahlBoxen, KombiBoxAuswahl, PortAusgang, Potenz, RGB, RGBA, Release Notes für Version 4.64, Release Notes für Version 4.685, SchirmFarbe, SoundsFinished, Stiftfarbe, TSH, TSHA, TeileMitRest, Textur, Ton, Zahlbox, beendeteTöne, buglist für Version 4.65, entferneListenControlElement, fülle, holeListenControlSpalte, holeListenControlZeile, kalibriereScrolling, kaskadiere, lies16BitZahlBinär, lies8BitZahlBinär, liesFehler, liesPositive8BitZahlBinär, mdarray, positive8BitZahl, reelleZahl, reelleZahlen, runde, setzeDiffusesLicht, setzeFüllfarbe, setzeGenSym, setzeListenControlSpalte, setzeListenControlZeile, setzeSpecularLicht, setzeStiftfarbe, setzeUmgebungslicht, solange, teile, xMinus, xPlus, xRest, zuGanzzahl

GroßeZahlSetzGenauigkeit 16BitZahl


HC / Arithmetik / Typen-Konverter / 16BitZahl

16BitZahl

HC [image] Arithmetik [image] Typen-Konverter [image] 16BitZahl
Ganzzahl 8BitZahl

16BitZahl Zahl

Ausgabe ist eine 16-Bit Ganzzahl, deren Wert die Zahl ohne ihre Nachkommastellen ist. Dies interessiert hauptsächlich, wenn man in binäre Dateien schreibt oder eine Struktur definiert und diese in eine binäre Datei schreibt.

Beispiele:

zeige 16BitZahl 32767	;32767
zeige 16BitZahl 32768	;  16bitzahl doesn't like 32768 as input
zeige 16BitZahl -32768	;-32768
zeige 16BitZahl -32769	;  16bitzahl doesn't like -32769 as input
zeige 16BitZahl [1.2 -1.2 1.9 -1.9]	;[1 -1 1 -1]
zeige 16BitZahl {1.2 -1.2 1.9 -1.9}	;{1 -1 1 -1}

Examples:

  • rufeDynamischeBibliothekAuf
  • setzeSchreiber
  • 16BitZahlP
  • GrößeVon
  • Struktur
  • TypVon

References:

    16BitZahlP(13), 16BitZahlen(5), Struktur(5), setzeSchreiber(5), GrößeVon(2), TypVon(2), rufeDynamischeBibliothekAuf(2), Release Notes für Version 4.67, lies16BitZahlBinär

Ganzzahl 8BitZahl


HC / Arithmetik / Typen-Konverter / 8BitZahl

8BitZahl

HC [image] Arithmetik [image] Typen-Konverter [image] 8BitZahl
16BitZahl positive8BitZahl

8BitZahl Zahl

Ausgabe ist eine 8-Bit Ganzzahl, deren Wert die Zahl ohne ihre Nachkommastellen ist. Dies interessiert hauptsächlich, wenn man in binäre Dateien schreibt oder eine Struktur definiert und diese in eine binäre Datei schreibt.

Beispiele:

zeige 8BitZahl 127	;127
zeige 8BitZahl 128	;  8bitzahl doesn't like 128 as input
zeige 8BitZahl -128	;-128
zeige 8BitZahl -129	;  8bitzahl doesn't like -129 as input
zeige 8BitZahl [1.2 -1.2 1.9 -1.9]	;[1 -1 1 -1]
zeige 8BitZahl {1.2 -1.2 1.9 -1.9}	;{1 -1 1 -1}

Examples:

  • rufeDynamischeBibliothekAuf
  • BitElement
  • 8BitZahlP
  • GrößeVon
  • TypVon

References:

    8BitZahlP(10), TypVon(3), BitElement(2), GrößeVon(2), rufeDynamischeBibliothekAuf(2), Release Notes für Version 4.67, Struktur, lies8BitZahlBinär

16BitZahl positive8BitZahl


HC / Arithmetik / Typen-Konverter / positive8BitZahl

positive8BitZahl

HC [image] Arithmetik [image] Typen-Konverter [image] positive8BitZahl
8BitZahl runde

positive8BitZahl Zahl

Ausgabe ist eine positive 8-Bit Ganzzahl, deren Wert die Zahl ohne ihre Nachkommastellen ist. Es wird ein Fehler ausgeworfen, wenn die Eingabe negatives Vorzeichen besitzt. Diese Funktion ist hauptsächlich dann interessant, wenn man in binäre Dateien schreibt oder eine Struktur definiert und diese in eine binäre Datei schreibt.

Beispiele:

zeige positive8BitZahl 255	;255
zeige positive8BitZahl 256	;  positive8bitzahl doesn't like 256 as input
zeige positive8BitZahl 0		;0
zeige positive8BitZahl -1	;  positive8bitzahl doesn't like -1 as input
zeige positive8BitZahl [1.2 -1.2 1.9 -1.9]	;  positive8bitzahl doesn't like -1.2 as input
zeige positive8BitZahl {1.2 -1.2 1.9 -1.9}	;  positive8bitzahl doesn't like -1.2 as input

Examples:

  • rufeDynamischeBibliothekAuf
  • positive8BitZahlP
  • GrößeVon
  • TypVon

References:

    positive8BitZahlP(6), Release Notes für Version 4.67(2), TypVon(2), rufeDynamischeBibliothekAuf(2), GrößeVon, Struktur, liesPositive8BitZahlBinär

8BitZahl runde


HC / Arithmetik / Typen-Konverter / runde

runde

HC [image] Arithmetik [image] Typen-Konverter [image] runde
positive8BitZahl schneideAb

runde num

Ausgabe ist die nächste Ganzzahl zur Eingabe.

Beispiele:

round 1.2		;1  ;-)
round -1.2		;-1  ;-)
round 1.9		;2  ;-)
round -1.9		;-2  ;-)
round [1.2 -1.2 1.9 -1.9]		;[1 -1 2 -2] ;-)

References:

    kaskadiere(2), Versions-Informationen für Version 4.7

positive8BitZahl schneideAb


HC / Arithmetik / Typen-Konverter / schneideAb

schneideAb

HC [image] Arithmetik [image] Typen-Konverter [image] schneideAb
runde Vorzeichen

schneideAb Zahl

Ausgabe ist die größte ganze Zahl, vom Betrag her kleiner ist als die Zahl.

Beispiele:

rundeAb 1.2		;1  ;-)
rundeAb -1.2		;-1  ;-)
rundeAb 1.9		;1  ;-)
rundeAb -1.9		;-1  ;-)
rundeAb [1.2 -1.2 1.9 -1.9]		;[1 -1 1 -1] ;-)


HC / Arithmetik / Typen-Konverter / Vorzeichen

Vorzeichen

HC [image] Arithmetik [image] Typen-Konverter [image] Vorzeichen
schneideAb konjugieren

Vorzeichen Zahl

Ausgabe ist 1, wenn die Zahl größer Null ist. Ausgabe ist -1, wenn die Zahl kleiner Null ist. Ausgabe ist 0, wenn die Zahl gleich Null ist.

Beispiele:

Vorzeichen 0		;0  ;-)
Vorzeichen 1234		;1  ;-)
Vorzeichen -4321		;-1  ;-)
Vorzeichen pi		;1  ;-)
Vorzeichen -pi		;-1  ;-)
Vorzeichen 1.2+0i		;1  ;-)
Vorzeichen -1.2+0i		;-1  ;-)
Vorzeichen 1i		;  Vorzeichen doesn't like 0+1i as input
Vorzeichen (liste 1234 -4321 0 1.2 -1.2 pi+0i -pi+0i)
;[1 -1 0 1 -1 1 -1] ;-)

References:

    für(2), BogenTangens, Ganzzahl, RestDerDivision, TeileMitRest, abs, konjugiere, positive8BitZahl, radBogenTangens

schneideAb konjugieren


HC / Arithmetik / Typen-Konverter / konjugieren

konjugieren

HC [image] Arithmetik [image] Typen-Konverter [image] konjugieren
Vorzeichen Druck-Formatierung

konjugiert complexNumber konjugieren

Ausgaben der zu dem complexNumber konjugierte Komplex. Dies ist wie (wirkliches z)-1i*(imag Z).

Beispiel:

zeige conjugate 1+2i		;1-2i
zeige conjugate liste 1+2i 3+4i		;[1-2i 3-4i]


HC / Arithmetik / Druck-Formatierung

Druck-Formatierung

HC [image] Arithmetik [image] Druck-Formatierung
konjugieren formatiere

Druck-Formatierung

...ist manchmal eine praktische Weise Zahlen zu zeigen.

Druck-Formatierung

  • formatiere
  • formatiereGanzzahl
  • zuGanzzahl
  • setzeSchreibpräzision
  • hex


HC / Arithmetik / Druck-Formatierung / formatiere

formatiere

HC [image] Arithmetik [image] Druck-Formatierung [image] formatiere
Druck-Formatierung formatiereGanzzahl

formatiere Zahl Breite Genauigkeit
(formatiere Wort Breite)

Die erste Form gibt ein Wort aus, das eine schreibbare Darstellung der Zahl enthält, möglicherweise am Anfagne mit Leerzeichen aufgefüllt (und deswegen keine für Rechenoperationen verwendbare Zahl), mit mindestens Breite Zeichen, einschließlich genau "Genauigkeit" Ziffern nach dem Dezimalpunkt. (Wenn "Genauigkeit" 0 ist, dann gibt es keinen Dezimalpunkt in der Ausgabe.)

Beispiele:

formatiereZahl pi 16 14		;3.14159265358979  ;-)
formatiereZahl exp 1 10 8		;2.71828183  ;-)

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

Druck-Formatierung formatiereGanzzahl


HC / Arithmetik / Druck-Formatierung / formatiereGanzzahl

formatiereGanzzahl

HC [image] Arithmetik [image] Druck-Formatierung [image] formatiereGanzzahl
formatiere zuGanzzahl

formatiereGanzzahl Zahl Breite Basis

Ausgabe ist ein Wort aus Ziffern, die die Zahl in der Basis "Basis" darstellen. D. h. wenn Basis 10 ist, dann wird die Zahl als Dezimalzahl ausgegeben, wenn Basis 2 ist, wird die Zahl binär ausgegeben, wenn Basis 16 ist, wird die Ausgabe hexadezimal sein, etc.

Negative Ganzzahlen werden in vorzeichenlose Ganzzahlen umgewandelt, so dass -1 in Basis 16 FFFFFFFF ist.

Beispiele:

formatiereGanzzahl 1234 0 10		;1234  ;-)
formatiereGanzzahl 1234 0 16		;4D2  ;-)
formatiereGanzzahl 1234 0 2		;10011010010  ;-)
formatiereGanzzahl -1 0 16		;FFFFFFFF  ;-)
formatiereGanzzahl -2 0 16		;FFFFFFFE  ;-)

Examples:

  • ProzedurText
  • Volltext

References:

    ProzedurText, Volltext

formatiere zuGanzzahl


HC / Arithmetik / Druck-Formatierung / zuGanzzahl

zuGanzzahl

HC [image] Arithmetik [image] Druck-Formatierung [image] zuGanzzahl
formatiereGanzzahl setzeSchreibpräzision

zuGanzzahl Wort Basis

gibt eine Ganzzahl aus, die das Wort "Wort" in eine Zahl konvertiert enthält, ähnlich wie die Funktion scanf in C.

Beispiele:

zuGanzzahl "1234 10	;1234  ;-)
zuGanzzahl "8A 16	;138  ;-)
zuGanzzahl "101101 2	;45  ;-)

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

formatiereGanzzahl setzeSchreibpräzision


HC / Arithmetik / Druck-Formatierung / setzeSchreibpräzision

setzeSchreibpräzision

HC [image] Arithmetik [image] Druck-Formatierung [image] setzeSchreibpräzision
zuGanzzahl hex

setzeSchreibpräzision Präzision

Kommando, das die Präzision beim Schreiben von Zahlen und komplexen Zahlen setzt.

Beispiel:

setzeSchreibpräzision 15
pi-(exp 1)*1i
3.14159265358979-2.71828182845905i  ;-)

Reference:

    Release Notes für Version 4.64

zuGanzzahl hex


HC / Arithmetik / Druck-Formatierung / hex

hex

HC [image] Arithmetik [image] Druck-Formatierung [image] hex
setzeSchreibpräzision Bitweise Operationen

hex Zahl (Bibliotheksprozedur)

Ausgabe ist die hexadezimal dargestellte Zahl als ein Wort. Dies ist z. B. gut für schnelle Überprüfung von Farbwerten.

Beispiele:

hex 16		;10  ;-)
hex 256		;100  ;-)
hex 255		;FF  ;-)
hex Stiftfarbe		;FF000000  ;-) (oder whatever value Stiftfarbe has)

Examples:

  • ProzedurText
  • Stiftfarbe
  • Volltext
  • RGBA

References:

    Volltext(3), ProzedurText(2), Stiftfarbe(2), RGBA

setzeSchreibpräzision Bitweise Operationen


HC / Arithmetik / Bitweise Operationen

Bitweise Operationen

HC [image] Arithmetik [image] Bitweise Operationen
hex BitUnd

Bitweise Operationen

...ermöglichen bitweise Rechnungen wie in C.

Bitweise Operationen

  • BitUnd
  • BitOder
  • BitXOder
  • BitNicht
  • schiebeArithmetisch
  • schiebeLogisch

Reference:

    Arithmetik

hex BitUnd


HC / Arithmetik / Bitweise Operationen / BitUnd

BitUnd

HC [image] Arithmetik [image] Bitweise Operationen [image] BitUnd
Bitweise Operationen BitOder

BitUnd Zahl1 Zahl2
(BitUnd Zahl1 Zahl2 Zahl3...)

Ausgabe ist das bitwise Und der Eingaben, die Ganzzahlen oder eine Liste oder Reihe von Ganzzahlen sein dürfen.

Beispiele:

BitUnd 1 2		;0  ;-)
BitUnd 3 2		;2  ;-)
BitUnd [1 2 3][1 1 1]	;[1 0 1] ;-)

Reference:

    Release Notes für Version 4.64

Bitweise Operationen BitOder


HC / Arithmetik / Bitweise Operationen / BitOder

BitOder

HC [image] Arithmetik [image] Bitweise Operationen [image] BitOder
BitUnd BitXOder

BitOder Zahl1 Zahl2
(BitOder Zahl1 Zahl2 Zahl3...)

Ausgabe ist das bitwise Oder der Eingaben, die Ganzzahlen oder eine Liste oder Reihe von Ganzzahlen sein dürfen.

Beispiele:

BitOder 1 2		;3  ;-)
BitOder 3 2		;3  ;-)
BitOder [1 2 3][0 0 0]	;[1 2 3] ;-)

References:

    Release Notes für Version 4.64, zumGestellDazu

BitUnd BitXOder


HC / Arithmetik / Bitweise Operationen / BitXOder

BitXOder

HC [image] Arithmetik [image] Bitweise Operationen [image] BitXOder
BitOder BitNicht

BitXOder Zahl1 Zahl2
(BitXOder Zahl1 Zahl2 Zahl3...)

Ausgabe ist das bitwise ausschliessliche Oder der Eingaben, die Ganzzahlen oder eine Liste oder Reihe von Ganzzahlen sein dürfen.

Beispiele:

BitXOder 1 1		;0  ;-)
BitXOder 1 0		;1  ;-)
BitXOder [1 2 3][1 1 1]	;[0 3 2] ;-)

Reference:

    Release Notes für Version 4.64

BitOder BitNicht


HC / Arithmetik / Bitweise Operationen / BitNicht

BitNicht

HC [image] Arithmetik [image] Bitweise Operationen [image] BitNicht
BitXOder schiebeArithmetisch

BitNicht Zahl

Ausgabe ist das bitweise Nicht der Eingabe Zahl, die eine Ganzzahl, eine Liste oder eine Reihe von Ganzzahlen sein darf.

Beispiele:

BitNicht 1		;-2  ;-)
BitNicht 0		;-1  ;-)
BitNicht [1 2 3]	;[-2 -3 -4] ;-)
BitNicht {1 2 3}	;{-2 -3 -4}  ;-)

Reference:

    Release Notes für Version 4.64

BitXOder schiebeArithmetisch


HC / Arithmetik / Bitweise Operationen / schiebeArithmetisch

schiebeArithmetisch

HC [image] Arithmetik [image] Bitweise Operationen [image] schiebeArithmetisch
BitNicht schiebeLogisch

schiebeArithmetisch Zahl Bits

Ausgabe ist die arithmetisch um Bits nach links verschobene Zahl. Wenn Bits negativ ist, erfolgt die Verschiebung nach rechts mit Vorzeichenerweiterung.

Beispiele:

schiebeArithmetisch 1 1		;2  ;-)
schiebeArithmetisch 2 -1		;1  ;-)
schiebeArithmetisch -2 -1		;-1  ;-)
schiebeArithmetisch [1 2 3][1 2 3]	;[2 8 24] ;-)

Reference:

    Release Notes für Version 4.64

BitNicht schiebeLogisch


HC / Arithmetik / Bitweise Operationen / schiebeLogisch

schiebeLogisch

HC [image] Arithmetik [image] Bitweise Operationen [image] schiebeLogisch
schiebeArithmetisch Arithmetische Mutatoren

schiebeLogisch Zahl Bits

hat einen Fehler: rechts-Schieben mit Null-Füllen funktioniert noch nicht!

Ausgabe ist die logisch um Bits nach links verschobene Zahl. Wenn Bits negativ ist, erfolgt die Verschiebung nach rechts durch Füllen mit Nullen.

Beispiele:

schiebeLogisch 1 1		;2  ;-)
schiebeLogisch 2 -1		;1  ;-)
schiebeLogisch [1 2 3][1 2 3]	;[2 8 24] ;-)

Reference:

    Release Notes für Version 4.64

schiebeArithmetisch Arithmetische Mutatoren


HC / Arithmetik / Arithmetische Mutatoren

Arithmetische Mutatoren

HC [image] Arithmetik [image] Arithmetische Mutatoren
schiebeLogisch xKopieren

Arithmetische Mutatoren

...verändern die Eingabedaten mathematisch. Für ein schönes Beispiel siehe pixtest.lg!

Aber seien Sie vorsichtig: die xBefehle sind sehr zickig bezüglich ihrer Argumenttypen, sie müssen ganz genau gleich sein. Wenn Sie z. B. eine Liste von Zahlen haben, so müssen Sie sicher sein, entweder nur Ganzzahlen oder nur Gleitpunkt-Zahlen darin zu haben. Eine Mischung wird wahrscheinlich einen Fehler hervorrufen.

Arithmetische Mutatoren

  • xKopieren
  • xPlus
  • xMinus
  • xMal
  • xDividieren
  • xRest

Reference:

    Arithmetik

schiebeLogisch xKopieren


HC / Arithmetik / Arithmetische Mutatoren / xKopieren

xKopieren

HC [image] Arithmetik [image] Arithmetische Mutatoren [image] xKopieren
Arithmetische Mutatoren xPlus

xKopieren var Wert

weist Wert der Variablen var zu, ohne ein neues Objekt zu erzeugen, was schneller ist als =. Aber dies ist eine gefährliche Funktion, besonders mit Reihen.

Reference:

    Release Notes für Version 4.64

Arithmetische Mutatoren xPlus


HC / Arithmetik / Arithmetische Mutatoren / xPlus

xPlus

HC [image] Arithmetik [image] Arithmetische Mutatoren [image] xPlus
xKopieren xMinus

xPlus var Wert
var+=value

addiert Wert zur Variablen var, ohne einen neue Zahl-Knoten zu erzeugen, was schneller ist als +.

Beispiele:

a=ganzzahl 0
wiederhole 1000000 [a+=1]
a		;1000000  ;-)

Reference:

    Release Notes für Version 4.64

xKopieren xMinus


HC / Arithmetik / Arithmetische Mutatoren / xMinus

xMinus

HC [image] Arithmetik [image] Arithmetische Mutatoren [image] xMinus
xPlus xMal

xMinus var Wert
var-=value

subtrahiert Wert von der Variablen var, ohne einen neue Zahl-Knoten zu erzeugen, was schneller ist als -.

Beispiel:

a=ganzzahl 1000000
wiederhole 1000000 [a-=1]
a		;0  ;-)

Reference:

    Release Notes für Version 4.64

xPlus xMal


HC / Arithmetik / Arithmetische Mutatoren / xMal

xMal

HC [image] Arithmetik [image] Arithmetische Mutatoren [image] xMal
xMinus xDividieren

xMal var Wert
var*=value

multipliziert Wert mit der Variablen var, ohne einen neue Zahl-Knoten zu erzeugen, was schneller ist als *.

Reference:

    Release Notes für Version 4.64

xMinus xDividieren


HC / Arithmetik / Arithmetische Mutatoren / xDividieren

xDividieren

HC [image] Arithmetik [image] Arithmetische Mutatoren [image] xDividieren
xMal xRest

xDividieren var Wert
var/=value

teilt die Variable var durch Wert, ohne einen neuen Zahl-Knoten zu erzeugen, was schneller ist als /.

Reference:

    Release Notes für Version 4.64

xMal xRest


HC / Arithmetik / Arithmetische Mutatoren / xRest

xRest

HC [image] Arithmetik [image] Arithmetische Mutatoren [image] xRest
xDividieren Arithmetik-Prädikate

xRest var Wert

speichert den Rest der Ganzzahl-Division der Variablen var durch Wert in var, ohne einen neuen Zahl-Knoten zu erzeugen, was schneller ist als /.

Reference:

    Release Notes für Version 4.64

xDividieren Arithmetik-Prädikate


HC / Arithmetik / Arithmetik-Prädikate

Arithmetik-Prädikate

HC [image] Arithmetik [image] Arithmetik-Prädikate
xRest kleinerP

Arithmetik-Prädikate

...sind Arithmetische Fragen mit boolschen Antworten. Viele Beispiele können Sie in checks\checkcompare.lg sehen!

Arithmetik-Prädikate

  • kleinerP
  • größerP
  • kleinerGleichP
  • größerGleichP
  • PrimzahlP


HC / Arithmetik / Arithmetik-Prädikate / kleinerP

kleinerP

HC [image] Arithmetik [image] Arithmetik-Prädikate [image] kleinerP
Arithmetik-Prädikate größerP

kleinerP thing1 thing2
kleiner? thing1 thing2
thing1 < thing2

Ausgaben WAHR wenn, das erstes Eingabe streng weniger ist als Sekunde.

Wenn die args Zahlen sind, werden sie von ihrem Zahlenwert verglichen. Wenn sie Linien sind sind sie Linie verglich. wenn, das sie sind, listet Oder Reihen auf, sie sind verglichenes elementwise. Sonst werden die Knotenzeiger verglichen.

Beispiele:

1 < 2		;wahr  ;-)
1 < 1		;falsch  ;-)
"a < "b		;wahr  ;-)
[1 0] < [0 1]		;falsch  ;-)
[1 0] < [1 1]		;wahr  ;-)


HC / Arithmetik / Arithmetik-Prädikate / größerP

größerP

HC [image] Arithmetik [image] Arithmetik-Prädikate [image] größerP
kleinerP kleinerGleichP

größerP thing1 thing2
größer? thing1 thing2
thing1 > thing2

Ausgaben WAHR wenn erstes Eingabe ist streng größer als Sekunde.

Wenn die args Zahlen sind, werden sie von ihrem Zahlenwert verglichen. Wenn sie Linien sind sind sie Linie verglich. wenn, das sie sind, listet Oder Reihen auf, sie sind verglichenes elementwise. Sonst werden die Knotenzeiger verglichen.

Beispiele:

1 > 1		;falsch  ;-)
2 > 1		;wahr  ;-)
"b > "a		;wahr  ;-)
[1 1] > [1 0]		;wahr  ;-)


HC / Arithmetik / Arithmetik-Prädikate / kleinerGleichP

kleinerGleichP

HC [image] Arithmetik [image] Arithmetik-Prädikate [image] kleinerGleichP
größerP größerGleichP

kleinerGleichP thing1 thing2
kleinerGleich? thing1 thing2
thing1 <= thing2

Ausgaben WAHR wenn erstes Eingabe ist weniger gleiches oder als Sekunde.

Wenn die args Zahlen sind, werden sie von ihrem Zahlenwert verglichen. Wenn sie Linien sind sind sie Linie verglich. wenn, das sie sind, listet Oder Reihen auf, sie sind verglichenes elementwise. Sonst werden die Knotenzeiger verglichen.

Beispiele:

1 <= 1		;wahr  ;-)
1 <= 2		;wahr  ;-)
1 <= 0		;falsch  ;-)
"a <= "b		;wahr  ;-)
"a <= "a		;wahr  ;-)
"b <= "a		;falsch  ;-)
[1 0] <= [1 1]		;wahr  ;-)

Reference:

    Release Notes für Version 4.64

größerP größerGleichP


HC / Arithmetik / Arithmetik-Prädikate / größerGleichP

größerGleichP

HC [image] Arithmetik [image] Arithmetik-Prädikate [image] größerGleichP
kleinerGleichP PrimzahlP

größerGleichP thing1 thing2
größerGleich? thing1 thing2
thing1 >= thing2

Ausgaben WAHR wenn erstes Eingabe ist bedeutenderer Oder Gleichgestellter als Sekunde.

Wenn die args Zahlen sind, werden sie von ihrem Zahlenwert verglichen. Wenn sie Linien sind sind sie Linie verglich. wenn, das sie sind, listet Oder Reihen auf, sie sind verglichenes elementwise. Sonst werden die Knotenzeiger verglichen.

Beispiele:

1>=1		;wahr  ;-)
2>=1		;wahr  ;-)
1>=2		;falsch  ;-)
"a >= "b		;falsch  ;-)
[1 1] >= [1 0]		;wahr  ;-)

Reference:

    Release Notes für Version 4.64

kleinerGleichP PrimzahlP


HC / Arithmetik / Arithmetik-Prädikate / PrimzahlP

PrimzahlP

HC [image] Arithmetik [image] Arithmetik-Prädikate [image] PrimzahlP
größerGleichP Rationale Zahlen

PrimzahlP Ganzzahl
Primzahl? Ganzzahl
Isprime Ganzzahl (Bibliotheksprozedur)

Ausgaben-Wahr Wenn die Ganzzahl ist eine Primzahl, sonst nicht wahr.

Beispiele:

primzahl? 0		;wahr  ;-)
primzahl? 1		;wahr  ;-)
primzahl? 2		;wahr  ;-)
primzahl? 3		;wahr  ;-)
primzahl? 4		;falsch  ;-)
primzahl? 5		;wahr  ;-)
primzahl? 6		;falsch  ;-)
primzahl? 7		;wahr  ;-)
primzahl? 8		;falsch  ;-)
primzahl? 9		;falsch  ;-)
primzahl? 431		;wahr  ;-)
primzahl? 2^32-5		;wahr  ;-)


HC / Arithmetik / Rationale Zahlen

Rationale Zahlen

HC [image] Arithmetik [image] Rationale Zahlen
PrimzahlP Verhältnis

Rationale Zahlen

...sind als Listen zweier Zahlen realisierte Zahlen, dem Zähler und dem Nenner. Es gibt noch keinen internen Logo-Knoten vom Typ "Ratio".

Rationale Zahlen

  • Verhältnis
  • float2ratio
  • ratio2float
  • radd
  • rsub
  • rmul
  • rdiv


HC / Arithmetik / Rationale Zahlen / Verhältnis

Verhältnis

HC [image] Arithmetik [image] Rationale Zahlen [image] Verhältnis
Rationale Zahlen float2ratio

Verhältnis Zähler Nenner (Bibliotheksprozedur)

Ausgabe ist eine gekürzte rationale Zahl als eine Liste von zwei Zahlen, Zähler und Nenner.

Beispiele:

ratio 20 10		;2  ;-)
ratio 10 20		;[1 2] ;-)
ratio 3 4		;[3 4] ;-)
ratio 12 8		;[3 2] ;-)

References:

    zumGestellDazu(4), geteilterBildschirm(3), setzeFensterteilerAufrufe(3), setzeVariablenFensterteiler(3)

Rationale Zahlen float2ratio


HC / Arithmetik / Rationale Zahlen / float2ratio

float2ratio

HC [image] Arithmetik [image] Rationale Zahlen [image] float2ratio
Verhältnis ratio2float

float2ratio Zahl (Bibliotheksprozedur)

Ausgabe ist eine Liste von Zähler und Nenner äquivalent zur Gleitpunktzahl "Zahl".

Beispiele:

float2ratio 0.25		;[1 4] ;-)
float2ratio 1.2		;[6 5] ;-)
float2ratio 3.14		;[157 50] ;-)


HC / Arithmetik / Rationale Zahlen / ratio2float

ratio2float

HC [image] Arithmetik [image] Rationale Zahlen [image] ratio2float
float2ratio radd

ratio2float rationr (Bibliotheksprozedur)

Ausgabe ist eine Gleitpunktzahl, die äquivalent zur rationalen Zahl rationr ist.

Beispiele:

ratio2float [1 10]		;0.1  ;-)
ratio2float [2 3]		;0.666667  ;-)


HC / Arithmetik / Rationale Zahlen / radd

radd

HC [image] Arithmetik [image] Rationale Zahlen [image] radd
ratio2float rsub

radd ratio1 ratio2 (Bibliotheksprozedur)

Ausgabe ist eine rationale Zahl als eine Liste zweier Zahlen, Zähler und Nenner, die die Summe der zwei Eingabe-Brüche ist.

Beispiel:

radd [1 2][1 2]		;1  ;-)
radd [1 2][3 4]		; 1/2+3/4=5/4	;[5 4] ;-)


HC / Arithmetik / Rationale Zahlen / rsub

rsub

HC [image] Arithmetik [image] Rationale Zahlen [image] rsub
radd rmul

rsub ratio1 ratio2 (Bibliotheksprozedur)

Ausgabe ist eine rationale Zahl als eine Liste zweier Zahlen, Zähler und Nenner, die die Differenz der zwei Eingabe-Brüche ist.

Beispiel:

rsub [1 2][3 4]	; 1/2-3/4=-1/4	;[-1 4] ;-)


HC / Arithmetik / Rationale Zahlen / rmul

rmul

HC [image] Arithmetik [image] Rationale Zahlen [image] rmul
rsub rdiv

rmul ratio1 ratio2 (Bibliotheksprozedur)

Ausgabe ist eine rationale Zahl als eine Liste zweier Zahlen, Zähler und Nenner, die das Produkt der zwei Eingabe-Brüche ist.

Beispiel:

rmul [1 2][3 4]	; (1/2)*(3/4)=3/8	;[3 8] ;-)


HC / Arithmetik / Rationale Zahlen / rdiv

rdiv

HC [image] Arithmetik [image] Rationale Zahlen [image] rdiv
rmul Daten-Struktur Grundwörter

rdiv ratio1 ratio2 (Bibliotheksprozedur)

Ausgabe ist eine rationale Zahl als eine Liste zweier Zahlen, Zähler und Nenner, die der Quotient der zwei Eingabe-Brüche ist.

Beispiel:

rdiv [1 2][3 4]	; (1/2)/(3/4)=2/3	;[2 3] ;-)


HC / Daten-Struktur Grundwörter

Daten-Struktur Grundwörter

HC [image] Daten-Struktur Grundwörter
rdiv Konstrukteure

Daten-Struktur Grundwörter

...sind Funktionen, die Daten aus einer oder mehreren Eingaben konstruieren (Konstrukteure),

Funktionen, die Unterbereiche der Eingabedaten auswählen (Wähler),

Funktionen, die die Daten verändern (Mutatoren),

Funktionen, die boolsche Eigenschaften der Eingabedaten ausgeben (Abfragen),

und Funktionen, die nichtboolsche Eigenschaften der Eingabedaten ausgeben (Eigenschaften).

Daten-Struktur Grundwörter

  • Konstrukteure
  • Umordner
  • Auswähler
  • Mutatoren
  • Abfragen
  • Eigenschaften


HC / Daten-Struktur Grundwörter / Konstrukteure

Konstrukteure

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure
Daten-Struktur Grundwörter Wort

Konstrukteure

...sind Funktionen, die neue von ihren Eingaben gebildete Daten ausgeben.

Konstrukteure

  • Wort
  • Liste
  • Satz
  • vornhin
  • hängeAn
  • Reihe
  • Ganzzahlen
  • 16BitZahlen
  • reelleZahlen
  • mdarray
  • Tabelle
  • Struktur
  • inListe
  • verbinde
  • erzeugeSymbol
  • ersetze
  • Anführungszeichen
  • TextPuffer
  • TextPufferInWort
  • tiefeKopie
  • erweitereBackslashes
  • makeTree
  • makeTreeFromBody
  • renderLogoAsHTML
  • renderLogoFileAsHTML

References:

    Daten-Struktur Grundwörter, Parallele Ausführung, Release Notes für Version 4.685

Daten-Struktur Grundwörter Wort


HC / Daten-Struktur Grundwörter / Konstrukteure / Wort

Wort

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Wort
Konstrukteure Liste

Wort Wort1 Wort2
(Wort Wort1 Wort2 Wort3...)

Ausgabe ist ein neues Wort, das durch Verketten der Eingaben gebildet wird.

Beispiele:

zeige wort "hal "lo	;hallo
zeige (wort [wor ld])	;wor ld
zeige (wort {a b c})	;{a b c}
zeige wort "12 "34		;1234

Examples:

  • Versions-Informationen für Version 4.7
  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • beiGeklickterListencontrolSpalte
  • Starten und Verlassen von Logo
  • rufeDynamischeBibliothekAuf
  • Vorlagen-basierte Iteration
  • holeListenControlZeile
  • SystemaufrufAbspalten
  • DynamischeBibliothek
  • ListenControlSpalte
  • _vielleichtAusgabe
  • ListenControlZeile
  • ListenControlText
  • setzeSchreiber
  • macroexpand
  • kaskadiere
  • TextPuffer
  • crossmap
  • Struktur
  • bildeab
  • _Makro
  • TypVon
  • Hilfe
  • WortP
  • Ding
  • Satz

References:

    Tokenisierung(11), Hilfe(9), Struktur(8), ListenControlSpalte(5), ListenControlText(5), ListenControlZeile(5), bildeab(5), TextControl(4), für(4), liesWort(4), setzeSchreiber(4), Vorlagen-basierte Iteration(3), WortP(3), _Makro(3), rufeDynamischeBibliothekAuf(3), zuGanzzahl(3), DynamischeBibliothek(2), ElementP(2), ElementeAb(2), Filter(2), IgelText(2), Knoten(2), Satz(2), TextPuffer(2), TypVon(2), `(2), beiAktiviertemListenControlElement(2), beiAusgewähltemListenControlElement(2), fange(2), formatiere(2), kaskadiere(2), klammere(2), liesMehrereZeichen(2), liesZeichen(2), ohneErstes(2), ohneLetztes(2), statischerText(2), verbinde(2), Anführungszeichen, Arbeitsbereichs-Abfragen, DateiAuswahl, Ding, Element, Elemente, Fall, Liste, LogoEditor, LogoSchriftenVerzeichnis, Namensraum, Release Notes für Version 4.67, Release Notes für Version 4.685, Starten und Verlassen von Logo, SubStringP, Systemaufruf, SystemaufrufAbspalten, Tabelle, Tag, TextPufferInWort, TextSchriftgröße, Textbox, Versions-Informationen für Version 4.7, VerzeichnisAuswahl, Volltext, WortUnterCursor, ZeichenP, _vielleichtAusgabe, beiGeklickterListencontrolSpalte, crossmap, entferneElement, ersetze, erstes, erzeugeSymbol, formatiereGanzzahl, geheZu, großbuchstabig, hex, holeListenControlZeile, kleinbuchstabig, leerP, letztes, liesArchitekturName, liesBetriebssystemFamilienname, liesBetriebssystemIdName, liesEndiannessName, liesListe, liesListeFlachTags, liesPortIdName, liesRoheZeile, liesUmgebung, lokal, macroexpand, reduziere, renderLogoAsHTML, renderLogoFileAsHTML, setze, setzeBackslashErweiterung, setzeKombiBoxWert, setzeLogoSprache, setzeSchreibBreitenGrenze, setzeSchriftname, setzeStatischenText, setzeTextschrift, setzeUmgebung, wähleZufällig, zu, zähle

Konstrukteure Liste


HC / Daten-Struktur Grundwörter / Konstrukteure / Liste

Liste

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Liste
Wort Satz

Liste Ding1 Ding2
(Liste Ding1 Ding2 Ding3...)

Ausgabe ist eine Liste, deren Elemente die Eingaben sind, die je ein Logo-Datum sein können (Wort, Liste, Reihe, etc.).

Beispiele:

zeige liste "hallo "world	;[hallo world]
zeige liste [] []	;[[][]]
zeige (liste "dies "is "a "longer "Liste)	;[dies is a longer liste]
zeige liste {arrays in}{a Liste}	;[{arrays in} {a Liste}]

Examples:

  • Berkeley Logo-Anwenderdokumentation
  • rufeDynamischeBibliothekAuf
  • natürlicherLogarithmus
  • SystemaufrufAbspalten
  • DynamischeBibliothek
  • Oberflächenspalte
  • ZehnerLogarithmus
  • Oberflächenstart
  • ModelviewMatrix
  • Oberflächenende
  • radBogenKosinus
  • setzeSchreiber
  • setzeTexturort
  • radBogenSinus
  • beendeteTöne
  • BogenKosinus
  • BogenTangens
  • bildeAbSatz
  • Grundwörter
  • konjugieren
  • BogenSinus
  • Oberfläche
  • radKosinus
  • radTangens
  • TextPuffer
  • Vorzeichen
  • alleErste
  • ohneErste
  • imaginär
  • radSinus
  • Realteil
  • setzeOrt
  • Struktur
  • Produkt
  • _Makro
  • ListeP
  • Potenz
  • ReiheP
  • TypVon
  • Hilfe
  • Linie
  • WortP
  • zeige
  • Satz
  • exp
  • sei

References:

    _Makro(12), Struktur(6), Vorlagen-basierte Iteration(6), `(6), Farb-Datenbank(5), ModelviewMatrix(5), Versions-Informationen für Version 4.7(5), für(5), ohneErste(5), setzeOrt(5), setzeSchreiber(5), ListeP(4), Tokenisierung(4), alleErste(4), bildeAbSatz(4), crossmap(4), entferneElement(4), inSchlange(4), rufeDynamischeBibliothekAuf(4), Auswahlbox(3), Diagramm(3), DynamischeBibliothek(3), Element(3), GanzzahlBox(3), KombiBoxen(3), ListControls(3), Listenboxen(3), Prozeduren(3), Satz(3), Systemaufruf(3), TextSchriftgröße(3), Zahlbox(3), _setzeErstes(3), _setzeNächstes(3), aufStapel(3), hängeAn(3), inListe(3), inListenListe(3), liesFehler(3), liesListe(3), setzeListenControl(3), zeige(3), übertrage(3), Arbeitsbereichs-Abfragen(2), Berkeley Logo-Anwenderdokumentation(2), ElementeAb(2), Filter(2), Grundwörter(2), IgelText(2), Inhalt(2), Knoten(2), Linie(2), ListControl(2), Oberfläche(2), Oberflächenende(2), Oberflächenspalte(2), Oberflächenstart(2), Quetschung(2), Schaltknopf(2), TypVon(2), VariablenNamen(2), Volltext(2), WortP(2), ZahlenFolge(2), Zeit(2), bildeab(2), erstes(2), finde(2), führeAusMitAusgabe(2), fürAlle(2), holeAuswahl(2), holeAuswahlZahl(2), holeAuswahlmöglichkeiten(2), holeListenControlWert(2), lade(2), letztes(2), namensliste(2), offeneDateien(2), ohneErstes(2), ohneLetztes(2), sei(2), settFensterform(2), setzeListenControlSpalte(2), setzeListenControlZeile(2), setzeListenboxAuswahl(2), setzeOrientierung(2), setzestift(2), vornhin(2), wenn(2), wähleZufällig(2), zu(2), Anführungszeichen, Arithmetische Mutatoren, Aufrufliste, Bedingung, Bildschirmgröße, BitNicht, BitOder, BitUnd, BitXOder, BogenKosinus, BogenSinus, BogenTangens, ChoiceBoxes, Cursor, DateiAuswahl, DateiZeit, Dateien, Einführung in die Logo-Programmierung, ElementP, Faktorisiere, GUI Programmierung, GanzzahlFolge, GanzzahlenFolge, GroßeZahl, Hilfe, IgelFormen, KombiBox, Kommandozeilen-Schalter -run, Leser, Listenbox, ListenboxAuswahl, LogoKonstanten, LogoVersion, Mausort, MidiAusgabestrom, MidiMeldung, Numerische Operationen, Orientierung, Ort, OrtXYZ, Parameteranzahl, Pause, Potenz, Produkt, ProzedurText, Realteil, Reihe, ReiheP, Release Notes für Version 4.64, Release Notes für Version 4.65, Release Notes für Version 4.686, Schieberegler, SchreibBreitenGrenze, Schreiber, Schreibstift, SpeicherungGröße, SubStringP, SystemaufrufAbspalten, Tabelle, TextAusrichtung, TextMausOrt, TextPuffer, TextboxCursor, Threads, Verhältnis, Versions-Informationen, VerzeichnisAuswahl, Vorzeichen, ZehnerLogarithmus, ZufallsZahl, _setzeOrt, _setzeOrtXYZ, beendeThread, beendeteTöne, dir, dirlg, ern, exp, fange, float2ratio, führeAus, holeListenControlSpalte, holeListenControlZeile, holePasswortVomBenutzer, holeSchriftVomBenutzer, holeTextVomBenutzer, holeZahlVomBenutzer, imaginär, inRichtungXYZ, klammere, klammereFürAusführung, konjugieren, leerP, liesBenutzer, liesFarbDatenbank, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesMehrereZeichen, liesUmgebungstabelle, liesWort, liesZeichen, listeRGB, listeRGBA, listeTSH, listeTSHA, lokal, makeTree, makeTreeFromBody, mdarray, mergeSort, natürlicherLogarithmus, pllist, radBogenKosinus, radBogenSinus, radKosinus, radSinus, radTangens, radd, rdiv, reduziere, reelleZahl, rmul, rsub, rufeAuf, schreibe, setReader, setzeAuswahlboxMöglichkeiten, setzeCursor, setzeElement, setzeFehlerAktion, setzeKombiBoxMöglichkeiten, setzeListenboxMöglichkeiten, setzeOrtXYZ, setzeSchreibTiefenGrenze, setzeSchriftgröße, setzeStiftdicke, setzeTextboxCursor, setzeTextschrift, setzeTexturort, speichereSchirm, verbinde, verschmelze, verschmelzePaare, verstecke, zähle

Wort Satz


HC / Daten-Struktur Grundwörter / Konstrukteure / Satz

Satz

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Satz
Liste vornhin

Satz Ding1 Ding2
(Satz Ding1 Ding2 Ding3...)

Ausgabe ist eine Liste, deren Elemente die Eingaben sind, wenn diese Eingaben keine Listen sind,

oder die Elemente der Eingaben, wenn diese Eingaben Listen sind.

Beispiele:

zeige Satz "Hallo "World	;[hallo world]
zeige Satz [Hallo][World]	;[Hallo World]
zeige (Satz [This is] "a "mixed [longer] [Satz])
;[This is a mixed longer Satz]
zeige (Satz "wort [liste] {reihe})	;[wort liste {reihe}]

Examples:

  • _Makro
  • Sounds

References:

    Tokenisierung(2), Sounds, _Makro, bildeAbSatz

Liste vornhin


HC / Daten-Struktur Grundwörter / Konstrukteure / vornhin

vornhin

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] vornhin
Satz hängeAn

vornhin Wert Liste
vornhin Wert Reihe

Ausgabe ist eine neue Liste, die bis auf das zusätzliche Element Wert als erstes Element gleich der Eingabe List ist.

vornhin ist schneller als hängeAn, weil Listen in Logo aus Erstes+Rest Paaren gebaut sind.

Reihen-Typen werden jetzt auch unterstützt (4.689).

Beispiele:

zeige vornhin "Hallo [World]	;[hallo World]
zeige vornhin [Hallo] [World]	;[[Hallo] World]
zeige vornhin "12 "34
;  vornhin doesn't like 34 as input
zeige vornhin "12 [34]	;[12 34]
zeige vornhin "12 {34}		;{12 34}
zeige vornhin 12 reelleZahlen {34}		;{12 34}

Example:

  • alleErste

References:

    Release Notes für Version 4.689, alleErste

Satz hängeAn


HC / Daten-Struktur Grundwörter / Konstrukteure / hängeAn

hängeAn

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] hängeAn
vornhin Reihe

hängeAn wert liste

Ausgabe ist eine neue Liste, die bis auf das zusätzliche Element Wert als letztes Element gleich der Eingabe List ist.

hängeAn ist langsam, weil die Liste intern bis zu ihrem Ende durchgegangen werden muss, damit wert dann angehängt werden kann.

Reihen-Typen werden jetzt von dieser Funktion unterstützt (4.689).

Beispiele:

zeige hängean "World [Hallo]	;[Hallo world]
zeige hängean [World] [Hallo]	;[Hallo [World]]
zeige hängean 34 12
;  hängean doesn't like 12 as input
zeige hängean 34 [12]		;[12 34]
zeige hängean 34 {12}		;{12 34}

Example:

  • kaskadiere

References:

    Release Notes für Version 4.689, kaskadiere, vornhin

vornhin Reihe


HC / Daten-Struktur Grundwörter / Konstrukteure / Reihe

Reihe

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Reihe
hängeAn Ganzzahlen

Reihe Größe
(Reihe Größe Ursprung)
Reihe eineListe
Reihe einintarray
Reihe einint16array
Reihe eineReihe
Ausgabe ist eine neue Reihe, die Größe Elemente hat.
Größe muss eine positive Ganzzahl sein. Jedes dieser Elemente ist am Anfang eine leere Liste. Reihen-Elemente können mit Element ausgewählt werden, und mit setzeElement verändert werden. Das erste Element der Reihe ist Element Nummer 1, außer wenn es ein "Ursprung" angegeben wurde (muss eine Ganzzahl sein), in welchem Fall das erste Element der Reihe diese Zahl als Index hat. (Typischerweise wird 0 als Ursprung - wenn überhaupt - benutzt.) Reihen werden von schreibe und Freunden geschrieben, und können in geschweiften Klammern eingegeben werden. @ zeigt einen Ursprung an. Dieses Grundwort kann auch benutzt werden, um eineListe, einint16array oder einintarray in eine Reihe umzuwandeln, oder, um die Reihe eineReihe zu klonen.

Beispiele:

zeige reihe 3		;{[] [] []}
zeige (reihe 3 0)		;{[] [] []}@0
zeige {h a l l o}		;{h a l l o}
zeige {a b c}@2		;{a b c}@2
zeige Element 3 {a b c}@2	;b

a={H a l l o}
setzeElement 2 a "e
zeige a		;{H e l l o}
Reihe [1 2 3]	;{1 2 3}  ;-)
Reihe ganzzahlen [1 2 3]	;{1 2 3}  ;-)
Reihe 16bitzahlen [1 2 3]	;{1 2 3}  ;-)

Examples:

  • öffneZumLesenBinär
  • spieleWaveSchnell
  • setzeIgelFormen
  • setzePunktXYZ
  • setzePunktXY
  • IgelFormen
  • schreibe
  • dreheum
  • Element
  • ListeP
  • ReiheP
  • TypVon
  • WortP
  • Satz

References:

    ReiheP(9), Element(5), IgelFormen(3), Rotiere(3), mdarray(3), setzeIgelFormen(3), setzePunktXY(3), setzePunktXYZ(3), zähle(3), 16BitZahlen(2), Ganzzahlen(2), ListeP(2), Release(2), Release Notes für Version 4.686(2), Satz(2), dreheum(2), erstes(2), invertiere(2), letztes(2), mdElement(2), mische(2), ohneErstes(2), ohneLetztes(2), reelleZahlen(2), schreibe(2), setzeMdElement(2), vergrößere(2), BitNicht, BitOder, BitUnd, BitXOder, ElementP, Elemente, ElementeAb, GanzzahlenFolge, GroßeZahl, KammSortAufDerStelle, Knoten, Linie, Liste, MandelIterate, Mehrere Igel, Release Notes für Version 4.685, Release Notes für Version 4.688, Release Notes für Version 4.689, SubStringP, TiefpaßFilter, TiefpaßFilter2, TypVon, Versions-Informationen für Version 4.7, WortP, ZufallsZahl, loadpalette, reelleZahl, reelleZahlenFolge, setzeElement, setzeLichtOrt, spieleWaveSchnell, sättigeOberhalb, sättigeUnterhalb, verbinde, vornhin, wähleZufällig, öffneZumLesenBinär

hängeAn Ganzzahlen


HC / Daten-Struktur Grundwörter / Konstrukteure / Ganzzahlen

Ganzzahlen

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Ganzzahlen
Reihe 16BitZahlen

(Ganzzahlen Größenursprung)
Ganzzahlen eineReihe
Ganzzahlen eineListe
Ganzzahlen 16BitZahlen
Ganzzahlen ganzzahlen

Ausgabe ist eine neue Reihe_von_ganzen_Zahlen, die Größe Elemente hat. Größe muss eine positive Ganzzahl sein. Jedes dieser Elemente ist eine Ganzzahl, die am Anfang zu Null gesetzt ist. Ganzzahlen-Elemente können mit Element ausgewählt werden, und mit setzeElement verändert werden. Das erste Element der Ganzzahlen ist Element Nummer 1, außer wenn ein "Ursprung" angegeben wurde (muss eine Ganzzahl sein), in welchem Fall das erste Element der Ganzzahlen diese Zahl als Index hat. (Typischerweise wird 0 als Ursprung - wenn überhaupt - benutzt.) Ganzzahlen werden von schreibe und Verwandten geschrieben, und können in geschweiften Klammern eingegeben werden. @ zeigt einen Ursprung an. Dieses Grundwort kann auch benutzt werden, um eineListe, eineReihe oder 16BitZahlen in Ganzzahlen umzuwandeln, wobei die Werte beim Maximum und Miminum einer Ganzzahl sättigen.

Es kann auch zum Klonen von ganzzahlen verwendet werden.

Reihen-Operationen auf Ganzzahlen sind sehr effizient und schnell, so dass z. B. Addition einer Ganzzahl zu Ganzzahlen, deren Elemente-Anzehl ausreichend groß ist, fast so schnell ist wie in C, da Ganzzahlen in einem C-Array gespeichert werden, im Gegensatz zu einer generellen Reihe, bei der jede Ganzzahl in einem eigenen Logo-Knoten gespeichert wird. Jeder Logo-Knoten belegt sehr viel mehr Speicher als eine Ganzzahl selbst.

Ein anderer Vorteil ist, dass Sie Ganzzahlen an eine dynamische Bibliothek mit DLCall exportieren können, was nicht direkt mit einer Reihe von ganzen Zahlen möglich ist.

Sie können auch setzeSchreiber verwenden, um beliebige Daten in Ganzzahlen zu schreiben, z. B. für Verwendung in einer .wav-Datei.

Beispiele:

zeige Ganzzahlen 3	;{0 0 0}
zeige (Ganzzahlen 3 0)	;{0 0 0}@0
zeige Ganzzahlen {1 2 3}	;{1 2 3}
zeige Ganzzahlen [1 2 3]	;{1 2 3}
zeige Ganzzahlen 16bitzahlen {1 2 3}	;{1 2 3}
zeige ganzzahlen {a b c}	;  ganzzahlen doesn't like {a b c} as input
zeige Element 3 ganzzahlen [1 2 3]		;3

Examples:

  • rufeDynamischeBibliothekAuf
  • KammSortAufDerStelle
  • setzeNebeldichte
  • setzeNebelModus
  • TiefpaßFilter2
  • setzePunktXYZ
  • TiefpaßFilter
  • setzePunktXY
  • 16BitZahlen
  • GrößeVon
  • KammSort
  • verbinde
  • Element
  • mische
  • TypVon
  • Reihe

References:

    16BitZahlen(3), GanzzahlenFolge(3), rufeDynamischeBibliothekAuf(3), setzeNebelModus(3), setzeNebeldichte(3), setzePunktXY(3), setzePunktXYZ(3), BitOder(2), BitUnd(2), BitXOder(2), Release Notes für Version 4.67(2), Struktur(2), TiefpaßFilter(2), TiefpaßFilter2(2), TypVon(2), formatiereGanzzahl(2), reelleZahlen(2), verbinde(2), Arithmetische Mutatoren, BitNicht, Element, Elemente, Ganzzahl, GanzzahlBox, GanzzahlBoxen, GanzzahlFolge, GrößeVon, KammSort, KammSortAufDerStelle, ListenboxAuswahl, Reihe, Release Notes für Version 4.685, RestDerDivision, Schiebe-Regler, TeileMitRest, TextAusrichtung, TextMausOrt, TextSchriftgröße, TextboxCursor, Threads, ZufallsZahl, inListe, liesGanzzahlenBinär, loadpalette, mdarray, mische, setzeElemente, spieleWave, spieleWaveSchnell, sättigeOberhalb, sättigeUnterhalb, teile

Reihe 16BitZahlen


HC / Daten-Struktur Grundwörter / Konstrukteure / 16BitZahlen

16BitZahlen

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] 16BitZahlen
Ganzzahlen reelleZahlen

(16BitZahlen Größenursprung)
16BitZahlen eineReihe
16BitZahlen eineListe
16BitZahlen Ganzzahlen
16BitZahlen 16BitZahlen

Ausgabe ist eine neue Reihe_von_ganzen_16Bit_Zahlen, die "Größe" Elemente hat. Größe muss eine positive Ganzzahl sein. Jedes dieser Elemente ist eine 16BitZahl, die am Anfang zu Null gesetzt ist. 16BitZahlen-Elemente können mit Element ausgewählt werden, und mit setzeElement verändert werden. Das erste Element der 16BitZahlen ist Element Nummer 1, außer wenn ein "Ursprung" angegeben wurde (muss eine Ganzzahl sein), in welchem Fall das erste Element der 16BitZahlen diese Zahl als Index hat. (Typischerweise wird 0 als Ursprung - wenn überhaupt - benutzt.) 16BitZahlen werden von schreibe und Verwandten geschrieben, und können in geschweiften Klammern eingegeben werden. @ zeigt einen Ursprung an. Dieses Grundwort kann auch benutzt werden, um eineListe, eineReihe oder Ganzzahlen in 16BitZahlen umzuwandeln, wobei die Werte beim Maximum und Miminum einer 16BitZahl sättigen.

Es kann auch zum Klonen von 16BitZahlen verwendet werden.

Reihen-Operationen auf 16BitZahlen sind sehr effizient und schnell, so dass z. B. Addition einer 16BitZahl zu 16BitZahlen, deren Elemente-Anzahl ausreichend groß ist, fast so schnell ist wie in C, da 16BitZahlen in einem C-Array gespeichert werden, im Gegensatz zu einer generellen Reihe, bei der jede 16BitZahl in einem eigenen Logo-Knoten gespeichert wird. Jeder Logo-Knoten belegt sehr viel mehr Speicher als eine 16BitZahl selbst.

Ein anderer Vorteil ist, dass Sie 16BitZahlen an eine dynamische Bibliothek mit DLCall exportieren können, was nicht direkt mit einer Reihe von ganzen 16Bit-Zahlen möglich ist.

Sie können auch setzeSchreiber verwenden, um beliebige Daten in 16BitZahlen zu schreiben, z. B. für Verwendung in einer .wav-Datei.

Beispiele:

zeige 16BitZahlen 3		;16BitZahlen {0 0 0}
zeige (16BitZahlen 3 0)	;16BitZahlen {0 0 0}@0
zeige 16BitZahlen {1 2 3}	;16BitZahlen {1 2 3}
zeige 16BitZahlen [1 2 3]	;16BitZahlen {1 2 3}
zeige 16BitZahlen ganzzahlen {1 2 3}	;16BitZahlen {1 2 3}
zeige 16bitzahlen {a b c}	;  16bitzahlen doesn't like {a b c} as input
zeige Element 3 16bitzahlen [1 2 3]	;3

Examples:

  • rufeDynamischeBibliothekAuf
  • KammSortAufDerStelle
  • spieleWaveSchnell
  • setzeSchreiber
  • TiefpaßFilter2
  • TiefpaßFilter
  • reelleZahlen
  • Ganzzahlen
  • GrößeVon
  • KammSort
  • verbinde
  • setzeXY
  • mische
  • Reihe

References:

    Ganzzahlen(3), reelleZahlen(3), Struktur(2), TiefpaßFilter(2), TiefpaßFilter2(2), spieleWaveSchnell(2), verbinde(2), Elemente, GrößeVon, KammSort, KammSortAufDerStelle, Reihe, Release Notes für Version 4.67, Release Notes für Version 4.685, inListe, mische, rufeDynamischeBibliothekAuf, setzeElemente, setzeSchreiber, setzeXY, spieleWave, sättigeOberhalb, sättigeUnterhalb

Ganzzahlen reelleZahlen


HC / Daten-Struktur Grundwörter / Konstrukteure / reelleZahlen

reelleZahlen

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] reelleZahlen
16BitZahlen mdarray

(reelleZahlen Größenursprung)
reelleZahlen eineReihe
reelleZahlen eineListe
reelleZahlen 16BitZahlen
reelleZahlen ganzzahlen
reelleZahlen reelleZahlen

Ausgabe ist eine neue Reihe_von_reellen_Zahlen, die Größe Elemente hat. Größe muss eine positive reelle Zahl sein. Jedes dieser Elemente ist eine Zahl, die am Anfang zu Null gesetzt ist. reelleZahlen-Elemente können mit Element ausgewählt werden, und mit setzeElement verändert werden. Das erste Element der reelleZahlen ist Element Nummer 1, außer wenn ein "Ursprung" angegeben wurde (muss eine Ganzzahl sein), in welchem Fall das erste Element der reelleZahlen diese Zahl als Index hat. (Typischerweise wird 0 als Ursprung - wenn überhaupt - benutzt.) reelleZahlen werden von schreibe und Verwandten geschrieben, und können in geschweiften Klammern eingegeben werden. @ zeigt einen Ursprung an. Dieses Grundwort kann auch benutzt werden, um eineListe, eineReihe, Ganzzahlen oder 16BitZahlen in reelleZahlen umzuwandeln. Es kann auch zum Klonen von reelleZahlen verwendet werden.

Reihen-Operationen auf reelleZahlen sind sehr effizient und schnell, so dass z. B. Addition einer Zahl zu reelleZahlen, deren Elemente-Anzehl ausreichend groß ist, fast so schnell ist wie in C, da reelleZahlen in einem C-Array gespeichert werden, im Gegensatz zu einer generellen Reihe, bei der jede Zahl in einem eigenen Logo-Knoten gespeichert wird. Jeder Logo-Knoten belegt sehr viel mehr Speicher als eine Zahl selbst.

Ein anderer Vorteil ist, dass Sie reelleZahlen an eine dynamische Bibliothek mit DLCall exportieren können, was nicht direkt mit einer Reihe von Zahlen möglich ist.

Beispiele:

zeige reelleZahlen 3	;{0 0 0}
zeige (reelleZahlen 3 0)	;{0 0 0}@0
zeige reelleZahlen {1 2 3}	;{1 2 3}
zeige reelleZahlen [1 2 3]	;{1 2 3}
zeige reelleZahlen 16bitzahlen {1 2 3}	;{1 2 3}
zeige reelleZahlen {a b c}	;  reellezahlen doesn't like {a b c} as input
zeige Element 3 reelleZahlen [1 2 3]		;3

Examples:

  • KammSortAufDerStelle
  • setzeNebeldichte
  • setzeNebelModus
  • TiefpaßFilter2
  • TiefpaßFilter
  • setzePunkt
  • KammSort
  • verbinde
  • Element
  • vornhin
  • mische

References:

    TiefpaßFilter(4), TiefpaßFilter2(4), Release(3), setzeNebelModus(3), setzeNebeldichte(3), Struktur(2), setzePunkt(2), verbinde(2), Element, GanzzahlenFolge, KammSort, KammSortAufDerStelle, Release Notes für Version 4.685, liesZahlenBinär, mische, reelleZahlenFolge, setzePunktXY, setzePunktXYZ, setzeXY, setzeXYZ, sättigeOberhalb, sättigeUnterhalb, vornhin

16BitZahlen mdarray


HC / Daten-Struktur Grundwörter / Konstrukteure / mdarray

mdarray

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] mdarray
reelleZahlen Tabelle

mdarray Größenliste
(mdarray Größenliste Ursprung) (Bibliotheksprozedur)

Ausgabe ist eine multidimensionale Reihe. Die erste Eingabe muss eine Liste von einer oder mehreren positiven Ganzzahlen sein. Die zweite Eingabe, wenn gegeben, muss eine einzelne Ganzzahl sein, die sich auf jede Dimension der Reihe bezieht.

Beispiel:

(mdarray [3 5] 0)

gibt eine zweidimensionale Reihe aus, deren Elemente mit Indices von [0 0] bis [2 4] addressiert werden.

Beispiele:

mdarray [2]		;{[] []}  ;-)
mdarray [2 3]		;{{[] [] []}{[] [] []}}  ;-)
mdarray [2 3 4]
{	{	{[] [] [] []}
        {[] [] [] []}
        {[] [] [] []}
    }
    {	{[] [] [] []}
        {[] [] [] []}
        {[] [] [] []}
    }
}  ;-)


HC / Daten-Struktur Grundwörter / Konstrukteure / Tabelle

Tabelle

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Tabelle
mdarray Struktur

Tabelle Größe
Tabelle eineListe

Ausgabe ist eine neue Nachschlage-Tabelle der Größe "Größe", die anfänglich keine Elemente hat, wenn Sie die erste Form verwenden, sonst werden die Elemente von eineListe eingefügt. Sie können neue Elemente durch die Benutzung von setzeElement oder dem "t's=x"-Operator hinzufügen.

Nachschlage-Tabellen sind sehr schnell für Wort-Anfrage, viel schneller durchsuchbar (O(1)) als in einer großen Liste (O(n)).

Beispiel:

t=Tabelle 5
setzeElement "a t 1234
zeige Element "a t		;1234
t'b=5678
zeige t'b		;5678
tabelle [[a 1234][b 1.2]]	;[a 1234][b 1.2]  ;-)

Examples:

  • Versions-Informationen für Version 4.7
  • entferneElement
  • NameInTabelleP
  • _setzeElement
  • Element
  • inListe
  • zähle

References:

    NameInTabelleP(4), zähle(4), Versions-Informationen für Version 4.7(2), _setzeElement(2), entferneElement(2), erbe(2), Arbeitsbereichs-Abfragen, Element, Fehlersuche, Release Notes für Version 4.686, Starten und Verlassen von Logo, erpl, inListe, profil, wähleZufällig

mdarray Struktur


HC / Daten-Struktur Grundwörter / Konstrukteure / Struktur

Struktur

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Struktur
Tabelle inListe

Struktur Typliste

Ausgabe ist eine neue Struktur, die Elemente werden mit Typliste gefüllt. Typliste ist ein Liste von Listen, die einen Feldnamen, einen Feldtyp und optional einen Feldinhalt enthalten. Der Feldtype kann eines von Ganzzahl, 16BitZahl, 8BitZahl, positive8BitZahl, Wort, Ganzzahlen, 16BitZahlen und reelleZahlen sein. Die Typen Wort, Ganzzahlen, 16BitZahlen und reelleZahlen benötigen ein drittes Listenelement, die Größe. Beim Typ Wort ist Größe die Anzahl von Zeichen des Wortes. Sie können Elemente durch die Benutzung von setzeElement oder dem "t's=x"-Operator ändern.

Strukturen sind wie Tabellen sehr schnell für Wort-Anfrage (O(1)), viel schneller durchsuchbar als in einer großen Liste (O(n)).

Beispiel:

wavHeaderType=(liste
    [ChunkID Wort RIFF]
    [wavfilesize Ganzzahl]
    [RIFFtype Wort 4]	;the letztes element is the string length

    [formatChunkID Wort fmt ]
    [formatChunkSize Ganzzahl 16]
    [compressionCode 16BitZahl 1]
    [NumberOfChannels 16BitZahl 1]
    (liste "SampleRate "Ganzzahl rate)
    (liste "BytesPerSecond "Ganzzahl rate*2)
    [BlockAlign 16BitZahl 2]
    [BitsPerSample 16BitZahl 16]

    [DataChunkID wort data]
    (liste "DataChunkSize "Ganzzahl size*2)
)
wavHeader=struktur wavHeaderType
wavsize=(GrößeVon wavHeader)+size*2
wavHeader'RIFFtype=[WAVE]	;example für setting a string
wavHeader'wavfilesize=wavsize
schreibe wavHeader

Examples:

  • setzeSchreiber
  • GrößeVon
  • TypVon

References:

    TypVon(2), liesStrukturBinär(2), 16BitZahl, 8BitZahl, GrößeVon, Release Notes für Version 4.67, Versions-Informationen für Version 4.7, _vielleichtAusgabe, holeSchriftVomBenutzer, positive8BitZahl, setzeSchreibBreitenGrenze, setzeSchreiber

Tabelle inListe


HC / Daten-Struktur Grundwörter / Konstrukteure / inListe

inListe

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] inListe
Struktur verbinde

inListe eineTabelle
inListe eineReihe
inListe Ganzzahlen
inListe 16BitZahlen
inListe einWort
inliste eineZahl

Wenn eineTabelle die Eingabe ist, ist die Ausgabe eine neue Liste mit Unterlisten der Form [Name Wert]. Die Namen sind die Namen der Elemente, die Werte sind die Werte der Elemente. Sonst konvertiert inListe nur den Eingabe-Typ in eine Liste. einWort wird in eine Liste von Zeichen umgewandelt, genauso eineZahl.

Beispiel:

t=Tabelle 5
t'a=1234
zeige t'a		;1234
t'b=[Hallo World!]
zeige t		;[a 1234][b [Hallo World!]]
l=TableToList t
zeige l		;[[a 1234][b [Hallo World!]]]

zeige inListe {a b c}	;[a b c]
zeige inListe intArray {1 2 3}	;[1 2 3]
zeige inListe int16Array {1 2 3}	;[1 2 3]

zeige inListe "Hallo	;[h a l l o]
zeige inListe 1234	;[1 2 3 4]
zeige inListe 12.345	;[1 2 . 3 4 5]

Example:

  • setzeXY

References:

    Release Notes für Version 4.67, setzeXY

Struktur verbinde


HC / Daten-Struktur Grundwörter / Konstrukteure / verbinde

verbinde

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] verbinde
inListe erzeugeSymbol

verbinde Ding1 Ding2
(verbinde Ding1 Ding2...)

wenn Ding2 ein Wort ist, ist die Ausgabe Wort Ding1 Ding2. Wenn Ding2 ein Liste ist, ist die Ausgabe fPut Ding1 Ding2.

Wenn die Dinge vom gleichen Reihentyp sind, ist eine neue Reihe des gleichen Typstippe, aber mit allen Elementen der Eingabereihen die Ausgabe.

Beispiele:

zeige verbinde "ha "llo		;hallo
zeige verbinde "Hallo [World]		;[hallo World]
zeige verbinde {1 2 3}{4 5 6}		;{1 2 3 4 5 6}
zeige (verbinde {1 2 3}{4 5 6}{7 8}{9})		;{1 2 3 4 5 6 7 8 9}
zeige verbinde reelleZahlen {1 2 3} reelleZahlen {4 5 6}		;{1 2 3 4 5 6}
zeige verbinde Ganzzahlen {1 2 3} Ganzzahlen {4 5 6}		;{1 2 3 4 5 6}
zeige verbinde 16BitZahlen {1 2 3} 16BitZahlen {4 5 6}		;{1 2 3 4 5 6}

References:

    Release Notes für Version 4.688, Release Notes für Version 4.689

inListe erzeugeSymbol


HC / Daten-Struktur Grundwörter / Konstrukteure / erzeugeSymbol

erzeugeSymbol

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] erzeugeSymbol
verbinde ersetze

erzeugeSymbol

Ausgabe ist ein einmaliges Wort jedes Mal, wenn es aufgerufen wird. Die Wörter sind von der Form g1, g2, g3, etc.

Beispiel:

zeige erzeugeSymbol 	;g1, g2, g3...


HC / Daten-Struktur Grundwörter / Konstrukteure / ersetze

ersetze

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] ersetze
erzeugeSymbol Anführungszeichen

ersetze einWord mitEinemWord inEinemDing

Ausgabe ist ein neues Wort, das inEinemDing enthält, worin das erste Vorkommen von einWort mitEinemWort inEinemDing ersetzt wurde.

Beispiele:

zeige ersetze "a "e "hallo		;"hello
zeige ersetze "abba "elle "jabbai		;"jellei
zeige ersetze "a "b [aaa]		;"abb
zeige ersetze "b "x {a b c}		;{a x c}

References:

    Release Notes für Version 4.65, Release Notes für Version 4.67

erzeugeSymbol Anführungszeichen


HC / Daten-Struktur Grundwörter / Konstrukteure / Anführungszeichen

Anführungszeichen

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] Anführungszeichen
ersetze TextPuffer

Anführungszeichen Wert (Bibliotheksprozedur)

Ausgabe ist die Eingabe, wenn ein Liste; Ausgabe ist die Eingabe mit einem Anführungszeichen davor, wenn ein Wort.

References:

    Versions-Informationen für Version 4.7(2), Tag, _setzeElement, zu

ersetze TextPuffer


HC / Daten-Struktur Grundwörter / Konstrukteure / TextPuffer

TextPuffer

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] TextPuffer
Anführungszeichen TextPufferInWort

TextPuffer Länge

Ausgabe ist ein Wort der Länge "Länge", das nur Null-Zeichen enthält. Dies kann nötig sein, wenn ein DLCall benutzt und es einen String-Puffer braucht.

Beispiel:

to GetCurrentDirectory
    lokal [buf status w]
    buf=TextPuffer 256
    status=DLCall kernel32 [GetCurrentDirectoryA] (liste "Ganzzahl
        "bufferLength "Ganzzahl 4*zähle buf
        "buffer "Wort buf)
    output TextPufferInWort buf
end
kernel32=DynamischeBibliothek "kernel32
zeige GetCurrentDirectory

Example:

  • DynamischeBibliothek

References:

    DynamischeBibliothek, Release Notes für Version 4.672, TextPufferInWort

Anführungszeichen TextPufferInWort


HC / Daten-Struktur Grundwörter / Konstrukteure / TextPufferInWort

TextPufferInWort

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] TextPufferInWort
TextPuffer tiefeKopie

TextPufferInWort Puffer

Ausgabe ist ein neues Wort, das die ersten Zeichen des TextPuffers Puffer bis zum ersten Null-Zeichen enthält. Diese Funktion macht eigentlich nur Sinn mit DLCall, sonst werden Sie sie wahrscheinlich niemals benutzen. Für ein Beispiel siehe TextPuffer.

Examples:

  • DynamischeBibliothek
  • TextPuffer

References:

    DynamischeBibliothek, Release Notes für Version 4.672, TextPuffer

TextPuffer tiefeKopie


HC / Daten-Struktur Grundwörter / Konstrukteure / tiefeKopie

tiefeKopie

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] tiefeKopie
TextPufferInWort erweitereBackslashes

tiefeKopie irgendwas

Ausgabe ist eine Kopie von "irgendwas". In Listen und Reihen wird hinein iteriert, so wenn man diese Kopie verändert, bleibt das ursprüngliche "irgendwas" das gleiche.

Beispiele:

a={1 2 3}
b=tiefeKopie a
a.2="hallo
b		;{1 2 3}  ;-)

l=[1 2 3]
b=tiefeKopie l
l.2="hallo
b		;[1 2 3] ;-)

Reference:

    Release Notes für Version 4.686

TextPufferInWort erweitereBackslashes


HC / Daten-Struktur Grundwörter / Konstrukteure / erweitereBackslashes

erweitereBackslashes

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] erweitereBackslashes
tiefeKopie makeTree

erweitereBackslashes einWort

Ausgabe ist einWort mit erweiterten Backslashes. Sie können seinen Effekt am einfachsten im Beispiel sehen.

Beispiel:

[a
     b]
    [a
     b]
 ;-)
expandBackslashes [a
     b]
a
     b  ;-)

Examples:

  • Versions-Informationen für Version 4.7
  • setzeBackslashErweiterung

References:

    setzeBackslashErweiterung(2), Versions-Informationen für Version 4.7

tiefeKopie makeTree


HC / Daten-Struktur Grundwörter / Konstrukteure / makeTree

makeTree

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] makeTree
erweitereBackslashes makeTreeFromBody

makeTree eineListe

Ausgabe ist ein neuer Tree für das erste Statement in der Liste. Ein Tree ist die fundamentale Datenstruktur, die direkt ausgewertet werden kann. Er enthält die Information, wieviele Argumente tatsächlich vorhanden sind für einen Prozeduraufruf, und gruppiert sie.

Beispiel:

makeTree [ifelse 1 != 2 [pr 5 repeat 4 [fd 100 rt 90]][pr "no,no]]

Es sollte schreiben:

[ifelse 	[!= 1 2]
"[pr 5 repeat 4 	[fd 100 rt 90]
] "[pr "no,no]]
 ;-)

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

erweitereBackslashes makeTreeFromBody


HC / Daten-Struktur Grundwörter / Konstrukteure / makeTreeFromBody

makeTreeFromBody

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] makeTreeFromBody
makeTree renderLogoAsHTML

makeTreeFromBody eineListe

Ausgabe ist ein neuer Tree, was eine Liste mit spezieller interner Darstellung ist. Ein Tree ist die fundamentale Datenstruktur, die direkt ausgewertet werden kann. Er enthält die Information, wieviele Argumente tatsächlich vorhanden sind für einen Prozeduraufruf, und gruppiert sie. Das Grundwort makeTreeFromBody ist nützlich, um diese Datenstruktur zu untersuchen, möglicherweise um sie als Ausgangsbasis für einen Quellcode-Editor zu verwenden, wie erste Versuche in formulatest2.lg zeigen.

Beispiel:

show makeTreeFromBody [
    fd 100 repeat 4 [right 90 fd 50 if repcount==2 [pr 2]] back 100
]

Es sollte ausgeben:

[	[fd 100]
    [repeat 4 	[right 90]
    ]
    [fd 50]
    [if 	[== 	[repCount]
        2]
        [pr 2]
    ]
    [back 100]
]

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

makeTree renderLogoAsHTML


HC / Daten-Struktur Grundwörter / Konstrukteure / renderLogoAsHTML

renderLogoAsHTML

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] renderLogoAsHTML
makeTreeFromBody renderLogoFileAsHTML

renderLogoAsHTML Ding

Ausgabe ist ein Wort bestehend aus HTML-Code, den der Logo Editor erzeugt beim Syntaxhighlighting der Eingabe Ding, wie wenn es irgend eine Logo-Datei wäre.

Beispiel:

renderLogoAsHTML [
    print 5
    if pc==0
    [	forward 100
    ]
    output "Hallo
]

<font color="#0000FF">print </font><font color="#FF0000">5 </font><font color="#0000FF"><b>if </font><font color="#0000FF">pc</font><font color="#000000"><b>==</b></font><font color="#FF0000">0    </font><font color="#000000"><b>[</b></font><font color="#0000FF">forward </font><font color="#FF0000">100</font><font color="#000000"><b>]
<br /></font><font color="#0000FF"><b>output </font><font color="#FF0000">"Hallo</font>  ;-)

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

makeTreeFromBody renderLogoFileAsHTML


HC / Daten-Struktur Grundwörter / Konstrukteure / renderLogoFileAsHTML

renderLogoFileAsHTML

HC [image] Daten-Struktur Grundwörter [image] Konstrukteure [image] renderLogoFileAsHTML
renderLogoAsHTML Umordner

renderLogoFileAsHTML Dateiname

Ausgabe ist ein Wort bestehend aus HTML-Code, den der Logo Editor erzeugt beim Syntaxhighlighting der Eingabe Ding, wie wenn es irgendeine Logo-Datei wäre.

Beispiel:

renderLogoFileAsHTML "box.lg

<font color="#0000FF"><b>to </b></font><font color="#8E2323">box</font><font color="#000000"> <br />   </font><font color="#0000FF"><b>repeat </font><font color="#FF0000">4</font><font color="#000000"> <br />   </font><font color="#000000"><b>[   </font><font color="#0000FF">fd </font><font color="#FF0000">100 </font><font color="#0000FF">rt </font><font color="#FF0000">90</font><font color="#000000"> <br />   </font><font color="#000000"><b>]</b></font><font color="#000000"> <br />   </font><font color="#0000FF">rt </font><font color="#FF0000">30</font><font color="#000000"> <br /></font><font color="#0000FF"><b>end</b></font><font color="#000000"> <br /></font>  ;-)

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

renderLogoAsHTML Umordner


HC / Daten-Struktur Grundwörter / Umordner

Umordner

HC [image] Daten-Struktur Grundwörter [image] Umordner
renderLogoFileAsHTML dreheum

Umordner

...sind Funktionen, die ihre Eingabedaten in einer anderen Reihenfolge ausgeben.

Umordner

  • dreheum
  • Rotiere
  • mische
  • mergeSort
  • KammSort
  • KammSortAufDerStelle
  • verschmelze
  • verschmelzePaare
  • inListenListe


HC / Daten-Struktur Grundwörter / Umordner / dreheum

dreheum

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] dreheum
Umordner Rotiere

dreheum Ding

Ausgabe ist ein Ding, dessen Elemente die Eingabe-Elemente in umgedrehter Reihenfolge sind.

Beispiele:

zeige dreheum "HalloWorld		;dlrowollah  ;-)
zeige dreheum [Hallo World]	;[World Hallo]
zeige dreheum [[a b][c d]]	;[	[c d]	[a b]	]
zeige dreheum {an reihe}		;{reihe an}

Reference:

    Listenboxen

Umordner Rotiere


HC / Daten-Struktur Grundwörter / Umordner / Rotiere

Rotiere

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] Rotiere
dreheum mische

Rotiere Reihe Plätze

Ausgabe ist eine neue Reihe, die die um "Plätze" Plätze gedrehte Eingabe-Reihe enthält.

Beispiele:

zeige rotiere {h a l l o} 1		;{o h a l l}
zeige rotiere {h a l l o} -1		;{a l l o h}
zeige rotiere {1 2 3} 2		;{2 3 1}

Examples:

  • setzePunktXYZ
  • setzePunktXY

References:

    Release Notes für Version 4.64, setzePunktXY, setzePunktXYZ

dreheum mische


HC / Daten-Struktur Grundwörter / Umordner / mische

mische

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] mische
Rotiere mergeSort

mische Reihe

Ausgabe ist eine neue Reihe von gleichem Typ und Länge wie die Eingabe, aber mit zufällig umsortierten Elementen.

Beispiele:

zeige mische {1 2 3 4 5 6 7 8 9}		;{7 2 9 4 5 1 6 8 3}
zeige mische reelleZahlen {1 2 3 4 5 6 7 8 9}		;{1 5 4 7 2 6 8 3 9}
zeige mische Ganzzahlen {1 2 3 4 5 6 7 8 9}		;{5 1 3 6 9 8 4 7 2}
zeige mische 16BitZahlen {1 2 3 4 5 6 7 8 9}		;{8 5 7 2 6 3 1 4 9}

Reference:

    Release Notes für Version 4.688

Rotiere mergeSort


HC / Daten-Struktur Grundwörter / Umordner / mergeSort

mergeSort

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] mergeSort
mische KammSort

mergeSort Liste1

Ausgabe ist eine neue Liste, die die Elemente von Liste1 in alphabetischer Ordnung enthält.

Beispiel:

zeige mergeSort [5 3 2 4 1 12]		;[1 12 2 3 4 5]
zeige mergeSort [d b c a aa]		;[a aa b c d]

References:

    KammSort, Release Notes für Version 4.64

mische KammSort


HC / Daten-Struktur Grundwörter / Umordner / KammSort

KammSort

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] KammSort
mergeSort KammSortAufDerStelle

KammSort Ding1

Ausgabe ist eine neuer Knoten vom gleichen Typ wie die Eingabe der die Elemente von Ding1 in alphabetischer Ordnung enthält.

Die Funktion verwendet den Algorithmus CombSort, der bei Reihen recht schnell ist und schneller sein kann als mergeSort.

Beispiel:

zeige KammSort [b a A 5 h _ 6 B 8 4 3 d]	;[3 4 5 6 8 _ A a b B d h]
zeige KammSort {b a A 5 h _ 6 B 8 4 3 d}	;{3 4 5 6 8 _ A a b B d h}
zeige KammSort Ganzzahlen {9 4 6 3 6 2 0}	;{0 2 3 4 6 6 9}
zeige KammSort 16BitZahlen {9 4 6 3 6 2 0}	;{0 2 3 4 6 6 9}
zeige KammSort reelleZahlen {9.5 4.3 6.2 3.1 6.8 2 0}	;{0 2 3.1 4.3 6.2 6.8 9.5}

Example:

  • Versions-Informationen für Version 4.7

References:

    KammSortAufDerStelle, Versions-Informationen für Version 4.7

mergeSort KammSortAufDerStelle


HC / Daten-Struktur Grundwörter / Umordner / KammSortAufDerStelle

KammSortAufDerStelle

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] KammSortAufDerStelle
KammSort verschmelze

KammSortAufDerStelle Ding1

Ausgabe ist eine neue Reihe vom gleichen Typ wie die Eingabe, die die Elemente von Ding1 in alphabetischer Ordnung enthält.

Die Funktion verwendet den Algorithmus CombSort, der bei Reihen recht schnell ist.

Sofern die Eingabe ein Reihentyp ist, ist diese Funktion schneller als KammSort, da sie keine neuen Knoten produziert. Aber sie kann keine Listen direkt verarbeiten.

Beispiel:

a={b a A 5 h _ 6 B 8 4 3 d} KammSortAufDerStelle a  zeige a	;{3 4 5 6 8 _ A a b B d h}
a=Ganzzahlen {9 4 6 3 6 2 0} KammSortAufDerStelle a  zeige a	;{0 2 3 4 6 6 9}
a=16BitZahlen {9 4 6 3 6 2 0} KammSortAufDerStelle a  zeige a	;{0 2 3 4 6 6 9}
a=reelleZahlen {9.5 4.3 6.2 3.1 6.8 2 0} KammSortAufDerStelle a  zeige a	;{0 2 3.1 4.3 6.2 6.8 9.5}

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

KammSort verschmelze


HC / Daten-Struktur Grundwörter / Umordner / verschmelze

verschmelze

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] verschmelze
KammSortAufDerStelle verschmelzePaare

verschmelze Liste1 Liste2

Ausgabe ist eine Liste bestehend aus den Elementen der zwei Listen in durch elementweisen Vergleich geordneter Reihenfolge.

Beispiel:

verschmelze [1 2 3][2 3 4]
[1 2 2 3 3 4]

Reference:

    Release Notes für Version 4.64

KammSortAufDerStelle verschmelzePaare


HC / Daten-Struktur Grundwörter / Umordner / verschmelzePaare

verschmelzePaare

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] verschmelzePaare
verschmelze inListenListe

verschmelzePaare ListeAus2Listen

Ausgabe ist eine Liste, die die Elemente der zwei Listen elementweise sortiert enthält.

Beispiel:

verschmelzePaare [[2 4 1][3 6 5]]
[	[2 3 4 1 6 5]
]
 ;-)

Reference:

    Release Notes für Version 4.64

verschmelze inListenListe


HC / Daten-Struktur Grundwörter / Umordner / inListenListe

inListenListe

HC [image] Daten-Struktur Grundwörter [image] Umordner [image] inListenListe
verschmelzePaare Auswähler

inListenListe Liste

Ausgabe ist eine neue Liste, die Listen von je einem Element der Liste enthält.

Beispiel:

inListenListe [2 4 1 3]
[	[2]
    [4]
    [1]
    [3]
]

Reference:

    Release Notes für Version 4.64

verschmelzePaare Auswähler


HC / Daten-Struktur Grundwörter / Auswähler

Auswähler

HC [image] Daten-Struktur Grundwörter [image] Auswähler
inListenListe erstes

Auswähler

...geben ausgewählte Teile der Eingabe(n) aus.

Auswähler

  • erstes
  • letztes
  • ohneErstes
  • ohneLetztes
  • Element
  • wähleZufällig
  • Elemente
  • entferne
  • entferneDuplikate
  • mdElement
  • BitElement
  • alleErste
  • ohneErste
  • Realteil
  • imaginär


HC / Daten-Struktur Grundwörter / Auswähler / erstes

erstes

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] erstes
Auswähler letztes

erstes Ding

Wenn die Eingabe ein Wort ist, ist die Ausgabe das erste Zeichen des Wortes.

Wenn die Eingabe eine Liste ist, ist die Ausgabe des erste Element der Liste.

Wenn die Eingabe ein Reihe ist, ist die Ausgabe das erstes Element der Reihe.

Komplexität ist O(1).

Beispiele:

zeige erstes "Hallo		;h
zeige erstes [H a l l o]		;H
zeige erstes {H a l l o}		;H

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiLinksDoppeltGeklickterTextmaus
  • beiMitteDoppeltgeklickterTextmaus
  • beiLosgelassenerTasteInListenbox
  • setzeListenboxHintergrundfarbe
  • beiDoppeltgeklickterListenbox
  • beiGedrückterTasteInListenbox
  • setzeListenboxSchriftdicke
  • setzeListenboxSchriftgröße
  • setzeListenboxSchriftname
  • setzeListenboxSchriftstil
  • entferneListenboxElement
  • holeListenControlZeile
  • setzeListenboxElement
  • beiListenboxAuswahl
  • beiListenboxZeichen
  • beiTextMausbewegung
  • setzeListenboxFarbe
  • führeAusMitAusgabe
  • zähleListenbox
  • _setzeErstes
  • ListenboxAn
  • kaskadiere
  • alleErste
  • _Makro
  • zu

References:

    kaskadiere(5), alleErste(2), beiLinksDoppeltGeklickterTextmaus(2), beiMitteDoppeltgeklickterTextmaus(2), beiRechtsDoppeltgeklickterTextmaus(2), beiTextMausbewegung(2), vornhin(2), zumGestellDazu(2), Fall, Knoten, Linie, ListenControlText, ListenboxAn, MidiGeräteInfo, Release Notes für Version 4.689, Starten und Verlassen von Logo, TextControl, Vorlagen-basierte Iteration, _Makro, _setzeErstes, ausSchlange, beiDoppeltgeklickterListenbox, beiGedrückterTasteInListenbox, beiListenboxAuswahl, beiListenboxZeichen, beiLosgelassenerTasteInListenbox, entferneListenboxElement, führeAusMitAusgabe, für, größerGleichP, größerP, holeListenControlZeile, kleinerGleichP, kleinerP, liesUmgebungstabelle, reduziere, rufeDynamischeBibliothekAuf, setzeListenboxElement, setzeListenboxFarbe, setzeListenboxHintergrundfarbe, setzeListenboxSchriftdicke, setzeListenboxSchriftgröße, setzeListenboxSchriftname, setzeListenboxSchriftstil, zu, zähleListenbox

Auswähler letztes


HC / Daten-Struktur Grundwörter / Auswähler / letztes

letztes

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] letztes
erstes ohneErstes

letztes Ding

Wenn die Eingabe ein Wort ist, ist die Ausgabe das letzte Zeichen des Wortes (O(1)).

Wenn die Eingabe eine Liste ist, ist die Ausgabe das letzte Element der Liste (O(n)).

Wenn die Eingabe ein Reihe ist, ist die Ausgabe das letzte Element der Reihe (O(1)).

Beispiele:

zeige letztes "Hallo		;o
zeige letztes [H a l l o]		;o
zeige letztes {H a l l o}		;o

Examples:

  • beiLosgelassenerTasteInAuswahlbox
  • beiLosgelassenerTasteInKombiBox
  • setzeAuswahlboxHintergrundfarbe
  • beiGedrückterTasteInAuswahlbox
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • setzeAuswahlboxMöglichkeiten
  • setzeAuswahlboxSchriftdicke
  • setzeAuswahlboxSchriftgröße
  • setzeListenboxMöglichkeiten
  • setzeAuswahlboxSchriftname
  • setzeAuswahlboxSchriftstil
  • setzeKombiBoxMöglichkeiten
  • entferneAuswahlboxElement
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • entferneKombiBoxElement
  • beiZeichenInAuswahlbox
  • setzeAuswahlboxAuswahl
  • setzeAuswahlboxElement
  • beiAuswahlboxAuswahl
  • setzeAuswahlboxFarbe
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • beiKombiBoxÄnderung
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • setzeKombiBoxFarbe
  • zerstöreAuswahlbox
  • AuswahlboxAuswahl
  • setzeKombiBoxWert
  • zurAuswahlboxDazu
  • hängeAnListenbox
  • zerstöreKombiBox
  • KombiBoxAuswahl
  • zurKombiBoxDazu
  • zähleAuswahlbox
  • setzeSchreiber
  • zähleKombiBox
  • AuswahlboxAn
  • KombiBoxWert
  • Systemaufruf
  • Auswahlbox
  • KombiBoxAn
  • Struktur

References:

    Tokenisierung(4), AuswahlboxAuswahl(2), KombiBoxAuswahl(2), Release Notes für Version 4.685(2), Auswahlbox, AuswahlboxAn, KombiBoxAn, KombiBoxWert, Release, Release Notes für Version 4.65, Release Notes für Version 4.689, Struktur, Systemaufruf, _Makro, beiAuswahlboxAuswahl, beiGedrückterTasteInAuswahlbox, beiGedrückterTasteInKombiBox, beiKombiBoxAuswahl, beiKombiBoxEingabe, beiKombiBoxZeichen, beiKombiBoxÄnderung, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInKombiBox, beiZeichenInAuswahlbox, entferneAuswahlboxElement, entferneKombiBoxElement, hängeAn, hängeAnListenbox, setzeAuswahlboxAuswahl, setzeAuswahlboxElement, setzeAuswahlboxFarbe, setzeAuswahlboxHintergrundfarbe, setzeAuswahlboxMöglichkeiten, setzeAuswahlboxSchriftdicke, setzeAuswahlboxSchriftgröße, setzeAuswahlboxSchriftname, setzeAuswahlboxSchriftstil, setzeKombiBoxAuswahl, setzeKombiBoxElement, setzeKombiBoxFarbe, setzeKombiBoxHintergrundfarbe, setzeKombiBoxMöglichkeiten, setzeKombiBoxSchriftdicke, setzeKombiBoxSchriftgröße, setzeKombiBoxSchriftname, setzeKombiBoxSchriftstil, setzeKombiBoxWert, setzeListenboxMöglichkeiten, setzeSchreiber, zerstöreAuswahlbox, zerstöreKombiBox, zurAuswahlboxDazu, zurKombiBoxDazu, zähleAuswahlbox, zähleKombiBox

erstes ohneErstes


HC / Daten-Struktur Grundwörter / Auswähler / ohneErstes

ohneErstes

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] ohneErstes
letztes ohneLetztes

ohneErstes Ding
ohneErstes Ding

Wenn die Eingabe ein Wort ist, ist die Ausgabe ein neues Wort, das alle bis auf das erste Zeichen der Eingabe enthält (O(N)).

Wenn die Eingabe eine Liste ist, ist die Ausgabe eine Liste, die alle Elemente der Eingabe bis auf das erste enthält. Die Listenelemente werden dabei nicht kopiert, es wird nur ein Verweis auf den zweiten Listenknoten zurückgegeben (O(1)).

Wenn die Eingabe eine Reihe ist, ist die Ausgabe ein neue Reihe des gleichen Typs wie die Eingabe, die bis auf das erste Element alle Elemente der Eingabe enthält (O(N)).

Beispiele:

zeige ohneErstes "Hallo		;allo
zeige ohneErstes [Ha llo]		;[llo]
zeige ohneErstes {Ha llo}		;{llo}

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiLinksDoppeltGeklickterTextmaus
  • beiMitteDoppeltgeklickterTextmaus
  • holeListenControlZeile
  • beiTextMausbewegung
  • GroßKleinEgalP
  • Systemaufruf
  • kaskadiere
  • ohneErste
  • `

References:

    Systemaufruf(5), GroßKleinEgalP(2), `(2), kaskadiere(2), ohneErste(2), ElementeAb, Release Notes für Version 4.689, beiLinksDoppeltGeklickterTextmaus, beiMitteDoppeltgeklickterTextmaus, beiRechtsDoppeltgeklickterTextmaus, beiTextMausbewegung, holeListenControlZeile, ohneLetztes

letztes ohneLetztes


HC / Daten-Struktur Grundwörter / Auswähler / ohneLetztes

ohneLetztes

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] ohneLetztes
ohneErstes Element

ohneLetztes Ding
ohneLetztes Ding

Wenn die Eingabe ein Wort ist, ist die Ausgabe ein neues Wort, das alle bis auf das letzte Zeichen der Eingabe enthält (O(N)).

Wenn die Eingabe eine Liste ist, ist die Ausgabe eine neue Liste, die alle Elemente der Eingabe bis auf das letzte enthält. Die Listenelemente werden dabei kopiert, daher ist diese Funktion im Vergleich zu ohneErstes langsam (O(N)).

Wenn die Eingabe eine Reihe ist, ist die Ausgabe ein neue Reihe des gleichen Typs wie die Eingabe, die bis auf das erste Element alle Elemente der Eingabe enthält (O(N)).

Beispiel:

zeige ohneLetztes [Hallo World]	;[Hallo]
zeige ohneLetztes "Hallo		;hall
zeige ohneLetztes {Hallo World}		;{Hallo}

Example:

  • Systemaufruf

References:

    Release Notes für Version 4.689, Systemaufruf

ohneErstes Element


HC / Daten-Struktur Grundwörter / Auswähler / Element

Element

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] Element
ohneLetztes wähleZufällig

Element Index Ding
Variablenname.Index Tabellenname'Index

Wenn Ding ein Wort ist, ist die Ausgabe das "Index"te Zeichen des Wortes (O(1)).

Wenn Ding eine Liste ist, ist die Ausgabe das "Index"te Element der Liste (O(N)).

Wenn Ding eine Reihe ist, ist die Ausgabe das "Index"te Element der Reihe (O(1)).

Index hat seinen Ursprung bei 1 für Worte und Listen; bei Reihentypen wird der Startindex bei der Konstruktion der Reihe angegeben.

Wenn Index und Ding beide Listen oder Reihen sind, dann ist die Ausgabe eine Liste bzw. Reihe der Elemente von Ding, die durch jedes Index-Element in Ding nachgeschlagen wurden. Die Komplexität erhöht sich im Vergleich zu einem Zahlen-Index um den Faktor der Anzahl der Elemente in Index.

Die Punkt- und Anführungsstrich-Notation ist experimental, aber recht komfortabel, daher wurde sie eingeführt. Sie kann durch

    setzeLogoSprache "ucblogo
nun auch abgeschaltet werden.

Beispiele:

w="hallo
zeige Element 2 w		;a
w.2		;a

l=[a b c]
zeige l.3		;c

a=reihe 4
zeige a.1		;[]

l=[[a b][c d][e f]]
zeige (l.3).1		;e

t=tabelle 5
t'a=1234
zeige element "a t		;1234
zeige t'a		;1234

Element [1 3 6][10 20 30 40 50 60]		;[10 30 60]
Element Ganzzahlen [1 3 6] reelleZahlen[10 20 30 40 50 60]	;{10 30 60}  ;-)
Element {1 3 6}{10 20 30 40 50 60}		;{10 30 60}  ;-)

a={1 2 3 4 5 6}
p={6 3 4 5 1 2}
wiederhole 6 [a=Element p a  schreibe a]
{6 3 4 5 1 2}
{2 4 5 1 6 3}
{3 5 1 6 2 4}
{4 1 6 2 3 5}
{5 6 2 3 4 1}
{1 2 3 4 5 6}

Examples:

  • setzeAuswahlboxElement
  • setzeListenboxElement
  • setzeKombiBoxElement
  • Parameteranzahl
  • setzeSchreiber
  • reelleZahlen
  • 16BitZahlen
  • ElementeAb
  • Ganzzahlen
  • ElementP
  • Struktur
  • Tabelle
  • Reihe

References:

    16BitZahlen(5), ElementP(5), Ganzzahlen(5), Reihe(5), reelleZahlen(5), zumGestellDazu(5), `(4), ElementeAb(3), Listenboxen(3), Vorlagen-basierte Iteration(3), bildeab(3), rufeDynamischeBibliothekAuf(3), setzeListenControlElement(3), Filter(2), Knoten(2), Release Notes für Version 4.686(2), ausSchlange(2), entferneElement(2), erstes(2), finde(2), fügeElementInListenControlEin(2), für(2), fürAlle(2), hängeAn(2), letztes(2), liesUmgebungstabelle(2), setzeAuswahlboxElement(2), setzeKombiBoxElement(2), setzeListenboxElement(2), sättigeOberhalb(2), sättigeUnterhalb(2), vornhin(2), übertrage(2), Fall, GroßKleinEgalP, KombiBoxen, ListControl, ListControls, ListenControlText, MidiGeräteInfo, NameInTabelleP, Parameteranzahl, Release Notes für Version 4.65, Struktur, Systemaufruf, Tabelle, Volltext, _setzeElement, _setzeErstes, alleErste, bildeAbSatz, entferneAuswahlboxElement, entferneKombiBoxElement, entferneListenboxElement, führeAusMitAusgabe, holeListenControlElement, holeListenControlWert, inListenListe, mdElement, ohneErste, ohneErstes, ohneLetztes, reduziere, setzeElement, setzeListenControl, setzeMdElement, setzeSchreiber, verstecke, vomStapel, wähleZufällig, zähleListenControlElemente

ohneLetztes wähleZufällig


HC / Daten-Struktur Grundwörter / Auswähler / wähleZufällig

wähleZufällig

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] wähleZufällig
Element Elemente

wähleZufällig liste

Ausgabe ist ein zufällig gewähltes Element der Eingabeliste.

Im Mittel O(1) bei Wort, Reihe oder Tabelle, O(N/2) bei Liste.

Beispiel:

zeige wähleZufällig [a b c]		;a, b oder c randomly
zeige wähleZufällig "abc			;the same output

Examples:

  • führeAus
  • Bässe

References:

    Bässe, führeAus

Element Elemente


HC / Daten-Struktur Grundwörter / Auswähler / Elemente

Elemente

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] Elemente
wähleZufällig entferne

Elemente StartIndex EndIndex Ding

Ausgabe ist ein Ding gleichen Typs wie die Eingabe, das die Elemente von StartIndex bis EndIndex von Ding enthält. Ding kann ein Wort, eine Reihe, Ganzzahlen oder 16BitZahlen sein.

O(EndIndex-StartIndex).

Beispiele:

zeige elemente 1 3 {a b c d e f}	;{a b c}
zeige elemente 3 5 {a b c d e f}	;{c d e}

Examples:

  • Versions-Informationen für Version 4.7
  • spieleWaveSchnell

References:

    16BitZahlen(4), Ganzzahlen(4), reelleZahlen(4), Reihe(3), Tabelle(3), setzeListenControl(3), Element(2), ListControls(2), Satz(2), Struktur(2), Vorlagen-basierte Iteration(2), bildeAbSatz(2), crossmap(2), dreheum(2), holeListenControlWert(2), inListe(2), ohneErstes(2), ohneLetztes(2), setzeElemente(2), setzeListenControlSpalte(2), setzeListenControlZeile(2), setzeSchreibTiefenGrenze(2), spieleWaveSchnell(2), Arbeitsbereichs-Abfragen, Auswahlbox, Einzelschritt, ElementP, FensterVollbild, Filter, Inhalt, KammSort, KammSortAufDerStelle, Knoten, KombiBox, KombiBoxen, Liste, Listenbox, Release Notes für Version 4.672, Release Notes für Version 4.686, Versions-Informationen für Version 4.7, `, aufStapel, bearbeite, deckeauf, entferne, entferneDuplikate, für, gleichP, holeAuswahl, holeAuswahlZahl, holeAuswahlmöglichkeiten, holeListenControlSpalte, holeListenControlZeile, inSchlange, klammereFürAusführung, liesFehler, mdarray, mergeSort, nichteinzelschritt, offeneDateien, setzeAuswahlboxMöglichkeiten, setzeKombiBoxMöglichkeiten, setzeListenboxMöglichkeiten, verfolge, verfolgenicht, verfolgt, verschmelzePaare, versteckt, vomStapel, zumGestellDazu

wähleZufällig entferne


HC / Daten-Struktur Grundwörter / Auswähler / entferne

entferne

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] entferne
Elemente entferneDuplikate

entferne Wert Ding

Ausgabe ist eine Kopie von Ding, bei der alle Elemente, die gleich Wert sind, entfernt wurden (O(N)).

Beispiele:

zeige entferne "lo [Hal lo Wor ld]		;[Hal Wor ld]
zeige entferne "l "HalloWorld		;haoword
zeige entferne [] [[] a [] b [] c []]		;[a b c]

Example:

  • Versions-Informationen für Version 4.7

References:

    Versions-Informationen für Version 4.7, entferneAuswahlboxElement, entferneKombiBoxElement, entferneListenboxElement

Elemente entferneDuplikate


HC / Daten-Struktur Grundwörter / Auswähler / entferneDuplikate

entferneDuplikate

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] entferneDuplikate
entferne mdElement

entferneDuplikate Ding

Ausgabe ist eine Kopie von Ding, bei der mehrfach vorkommende Elemente bis auf das je erste entfernt wurden. O(N).

Beispiele:

zeige entferneDuplikate [H a l l o  W o r l d]	;[H a W o r l d]
zeige entferneDuplikate "HalloWorld		;haworld


HC / Daten-Struktur Grundwörter / Auswähler / mdElement

mdElement

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] mdElement
entferneDuplikate BitElement

mdElement IndexListe Reihe

Ausgabe ist das Element der mehrdimensionalen Reihe, ausgewählt durch die ganzahligen Indices in der IndexListe.

Beispiel:

a={{{1 2}{3 4}}{3 4}}
mdElement [1 2 1] a		;3

a=[[[1 2][3 4]][5 6]]
mdElement [1 2 1] a		;3

a=[Hallo World]
mdElement [2 3] a		;r


HC / Daten-Struktur Grundwörter / Auswähler / BitElement

BitElement

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] BitElement
mdElement alleErste

BitElement Index Ding

Ausgabe ist entweder wahr oder falsch, je nach dem Wert des "Index"ten Bits von Ding.

Beispiele:

zeige BitElement 0 5	;wahr
zeige BitElement 1 5	;falsch
zeige BitElement 2 5	;wahr
zeige BitElement 3 5	;falsch
zeige BitElement 7 8bitzahl -1	;wahr
zeige BitElement 0 8bitzahl -1	;wahr

Reference:

    Release Notes für Version 4.672

mdElement alleErste


HC / Daten-Struktur Grundwörter / Auswähler / alleErste

alleErste

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] alleErste
BitElement ohneErste

alleErste Liste1

Ausgabe ist eine Liste, die das Erste jedes Elements der Eingabeliste enthält. Es ist ein Fehler, Wenn ein Element der Eingabe-Liste leer ist. (Die Eingabe selbst kann leer sein, in welchem Fall die Ausgabe auch leer ist.) O(count Liste1).

Dies könnte auch geschrieben werden als

zu alleErste :liste
    output map "erstes :liste
end

aber es wird als Grundwort angeboten, um die Template-Werkzeuge map, map_se und fürjedes schneller zu machen.

Neu in 4.689 ist, dass Reihen-Arugmente nun auch erlaubt sind.

Beispiele:

zeige alleErste [[H a l l o] [W o r l d]]		;[H W]

zu transpose2 :matrix
    wenn leerp erstes :matrix [op []]
    gibaus vornhin alleErste :matrix transpose2 ohneErste :matrix
end

zeige alleErste {{1 2 3}[a b c]}		;{1 a}

Reference:

    Release Notes für Version 4.689

BitElement ohneErste


HC / Daten-Struktur Grundwörter / Auswähler / ohneErste

ohneErste

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] ohneErste
alleErste Realteil

ohneErste liste

Ausgabe ist eine Liste, die das ohneErstes jedes Elements der Eingabeliste enthält. Es ist ein Fehler, wenn ein Element der Eingabe-Liste leer ist. (Die Eingabe selbst kann leer sein, in welchem Fall die Ausgabe auch leer ist.)

In 4.689 Reihen-Unterstützung hinzugefügt.

Dies könnte geschrieben werden als

to ohneerste :liste
    output map "ohneerstes :liste
end

aber es wird als Grundwort angeboten, um die Template-Werkzeuge map, map_se und füralle zu beschleunigen.

Beispiele:

zeige ohneErste [[Ha llo][Wor ld]]	;[[llo][ld]]
zeige ohneErste {{Ha llo}[Wor ld]}		;{{llo}[ld]}

Example:

  • alleErste

References:

    Release Notes für Version 4.689, alleErste

alleErste Realteil


HC / Daten-Struktur Grundwörter / Auswähler / Realteil

Realteil

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] Realteil
ohneErste imaginär

Realteil komplexeZahl
Ausgabe ist der Realteil einer komplexen Zahl
als eine reelle Gleitpunktzahl.

Beispiel:

zeige real 3+4i		;3
zeige real liste 1+2i 3+4i	;[1 3]


HC / Daten-Struktur Grundwörter / Auswähler / imaginär

imaginär

HC [image] Daten-Struktur Grundwörter [image] Auswähler [image] imaginär
Realteil Mutatoren

imaginär komplexeZahl

Ausgabe ist der Imaginärteil der komplexen Zahl als eine reelle Gleitpunktzahl.

Beispiel:

zeige imag 3+4i		;4
zeige imag liste 1+2i 3+4i	;[2 4]


HC / Daten-Struktur Grundwörter / Mutatoren

Mutatoren

HC [image] Daten-Struktur Grundwörter [image] Mutatoren
imaginär setzeElement

Mutatoren

...verändern die Eingabedaten.

Mutatoren

  • setzeElement
  • _setzeElement
  • setzeMdElement
  • setzeElemente
  • entferneElement
  • _setzeErstes
  • _setzeNächstes
  • aufStapel
  • vomStapel
  • inSchlange
  • ausSchlange

Reference:

    Daten-Struktur Grundwörter

imaginär setzeElement


HC / Daten-Struktur Grundwörter / Mutatoren / setzeElement

setzeElement

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] setzeElement
Mutatoren _setzeElement

setzeElement Index Ding Wert

Kommando. Ersetzt das "Index"te Element von Ding mit dem neuen Wert. setzeElement stellt sicher, dass die sich ergebende Datenstruktur keine Ringstruktur ist, d. h., Wert kann nicht ein Liste oder Reihe sein, die Ding enthält.

Beispiele:

a=[H a l l o]
setzeElement 2 a "e
zeige a		;[H e l l o]

a={W o r l d}
setzeElement 3 a "a
zeige a		;{W o a l d}

a="hallo
setzeElement 2 a "e
zeige a		;hello

Examples:

  • _setzeElement
  • Tabelle
  • Reihe

References:

    Reihe(2), Tabelle(2), _setzeElement(2), 16BitZahlen, Ganzzahlen, Release Notes für Version 4.672, Release Notes für Version 4.686, Struktur, reelleZahlen

Mutatoren _setzeElement


HC / Daten-Struktur Grundwörter / Mutatoren / _setzeElement

_setzeElement

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] _setzeElement
setzeElement setzeMdElement

_setzeElement Index Ding Wert
Wert.Index=Wert Tabelle'Index=Wert

Kommando. Ändert das "Index"te Element von Ding zum Wert "Wert", wie setzeElement, aber, ohne zu überprüfen, ob eine Ringstruktur entsteht.

Warnung: Grundwörter, die mit einem Unterstrich anfangen, sind gefährlich. Ihre Benutzung durch Nicht-Experten wird nicht empfohlen. Die Verwendung von _setztElement kann zu ringförmigen Datenstrukturen führen, die einige (noch fehlerhafte) Logo-Grundwörter in endlose Schleifen bringen.

Die experimentelle Punkt-Notation ist noch in der Test-Phase; Index kann noch kein komplizierterer Ausdruck sein.

Die Anführungszeichen-Notation ist auch noch experimentell.

Beispiele:
l=[a b c]
l.2="hallo
l
    [a hallo c]
 ;-)
_setzeElement 3 l 333
l
    [a hallo 333]
 ;-)
t=tabelle 5
setzeElement "a t 1234
t		;[a 1234] ;-)
t'b=5678
t		;[a 1234][b 5678] ;-)


HC / Daten-Struktur Grundwörter / Mutatoren / setzeMdElement

setzeMdElement

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] setzeMdElement
_setzeElement setzeElemente

setzeMdElement IndexListe Reihe Wert

Kommando. Ersetzt das Element von Reihe, ausgewählt durch IndexListe, durch den neuen Wert. O(zähle IndexListe).

Beispiele:

a={{1 2}{3 4 5}}
setzeMdElement [2 3] a "so
zeige a		;{{1 2}{3 4 so}}

a=[Hallo World]
setzeMdElement [2 3] a "a
zeige a		;[Hallo Woald]

Reference:

    Release Notes für Version 4.686

_setzeElement setzeElemente


HC / Daten-Struktur Grundwörter / Mutatoren / setzeElemente

setzeElemente

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] setzeElemente
setzeMdElement entferneElement

setzeElemente StartIndex Ding neueElemente

Kommando. Es setzt die bei StartIndex startenden Elemente von Ding auf die neuen Elemente neueElemente. Ding und neueElemente brauchen nicht vom gleichen Typ sein, aber nur Reihen, Ganzzahlen und 16BitZahlen werden bisher unterstützt.

Beispiel:

a={1 2 3 4}
setzeelemente 2 a {7 8}
zeige a
{1 7 8 4}

Example:

  • spieleWaveSchnell

References:

    spieleWaveSchnell(2), Release Notes für Version 4.672

setzeMdElement entferneElement


HC / Daten-Struktur Grundwörter / Mutatoren / entferneElement

entferneElement

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] entferneElement
setzeElemente _setzeErstes

entferneElement Index Ding

entfernt das Index-te Element aus der Eingabe Ding, die ein Wort, eine Liste, oder Tabelle sein kann.

Im Fall, dass Ding eine Liste mit nur einem Element ist, wird die Liste nach dem Entfernen des ersten Elements eine leere Liste enthalten. Das mag seltsam erscheinen, aber es ist nicht möglich, das zu vermeiden, außer man würde removeItem als Selektor schreiben anstatt eines Mutators, was es wesentlich verlangsamen würde.

Beispiele:

w="einWort
entferneElement 2 w
w		;inWort  ;-)
l=[a b c]
entferneElement 2 l
l		;[a c] ;-)
entferneElement 1 l
l		;[c] ;-)
entferneElement 1 l
l		;[[]] ;-)
t=Tabelle 3
t'a=1234
t'b=5678
t'c=9012
entferneElement "b t
t		;[a 1234][c 9012] ;-)

Example:

  • zähle

Reference:

    zähle

setzeElemente _setzeErstes


HC / Daten-Struktur Grundwörter / Mutatoren / _setzeErstes

_setzeErstes

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] _setzeErstes
entferneElement _setzeNächstes

_setzeErstes Liste Wert

Kommando. Ändert das erste Element der Liste zum Wert.

Warnung: Grundwörter, die mit einem Unterstrich anfangen, sind gefährlich. Ihre Benutzung durch Nicht-Experten wird nicht empfohlen. Die Verwendung von _setzeErstes kann zu ringförmigen Datenstrukturen führen, die einige (noch fehlerhafte) Logo-Grundwörter in endlose Schleifen bringen. Unerwartete Änderungen in anderen Datenstrukturen, die die selben Knoten teilen mit der zu verändernden Liste.

Beispiel:

a=[1 2]
_setzeErstes a -erstes a
zeige a		;[-1 2]

Example:

  • KreisStrukturP

Reference:

    KreisStrukturP

entferneElement _setzeNächstes


HC / Daten-Struktur Grundwörter / Mutatoren / _setzeNächstes

_setzeNächstes

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] _setzeNächstes
_setzeErstes aufStapel

_setzeNächstes Liste Wert

Kommando. Ändert den Rest der Liste zum Wert.

Warnung: Grundwörter, die mit einem Unterstrich anfangen, sind gefährlich. Ihre Benutzung durch Nicht-Experten wird nicht empfohlen. Die Verwendung von _setzeNächstes kann zu ringförmigen Datenstrukturen führen, die einige, noch fehlerhafte Logo-Grundwörter in endlose Schleifen bringen. Unerwartete Änderungen in anderen Datenstrukturen, die die selben Knoten teilen mit der zu verändernden Liste.

Beispiel:

a=[1 2]
_setbf a [-2]
zeige a		;[1 -2]

Reference:

    Release Notes für Version 4.64

_setzeErstes aufStapel


HC / Daten-Struktur Grundwörter / Mutatoren / aufStapel

aufStapel

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] aufStapel
_setzeNächstes vomStapel

aufStapel Stapelname Wert

Kommando. Legt den Wert auf den Stapel, der in der Variablen namens Stapelname liegt. Diese Variable muss eine Liste als Wert haben; der Anfangswert sollte die leere Liste sein. Neue Elemente werden vorn in der Liste hinzugefügt.

Beispiele:

s=[]
staple "s "Hallo
zeige s		;[hallo]
staple "s "World
zeige s		;[world hallo]


HC / Daten-Struktur Grundwörter / Mutatoren / vomStapel

vomStapel

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] vomStapel
aufStapel inSchlange

vomStapel Stapelname

Ausgabe ist das oberste, zuletzt auf den Stapel gelegte Element, der in der Variablen namens Stapelname liegt, und entfernt jenes Elemente von dem Stapel.

Beispiele:

s=[world hallo]
zeige vomStapel "s		;world
zeige s		;[hallo]
zeige vomStapel "s		;hallo
zeige s		;[]

Reference:

    ausSchlange

aufStapel inSchlange


HC / Daten-Struktur Grundwörter / Mutatoren / inSchlange

inSchlange

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] inSchlange
vomStapel ausSchlange

inSchlange Schlangenname Wert

Kommando. Schiebt den Wert in die Schlange, die der Wert der Variablen namens Schlangenname ist. Diese Variable muss eine Liste als Wert haben; der Anfangswert sollte die leere Liste sein. Neue Elemente werden ans Ende der Liste hinzugefügt, daher ist es ein bisschen langsam, weil die ganze Liste bis zum Ende durchgegangen werden muß.

Beispiele:

q=[]
inSchlange "q "Hallo
zeige q		;[hallo]
inSchlange "q "World
zeige q		;[hallo world]


HC / Daten-Struktur Grundwörter / Mutatoren / ausSchlange

ausSchlange

HC [image] Daten-Struktur Grundwörter [image] Mutatoren [image] ausSchlange
inSchlange Abfragen

ausSchlange Schlange

Ausgabe ist das als erstes in die Schlange geschobene Element, die der Wert der Variablen namens Schlange ist, und entfernt dieses Element von der Schlange.

ausSchlange ist ein anderer Name für vomStapel.

Beispiele:

q=[Hallo World]
zeige ausSchlange "q		;Hallo
zeige q		;[World]
zeige ausSchlange "q		;World
zeige q		;[]


HC / Daten-Struktur Grundwörter / Abfragen

Abfragen

HC [image] Daten-Struktur Grundwörter [image] Abfragen
ausSchlange WortP

Abfragen

...fragen nach boolschen Eigenschaften der Eingabedaten (wahr oder falsch).

Abfragen

  • WortP
  • ListeP
  • ReiheP
  • leerP
  • gleichP
  • vorherP
  • _gleich
  • ElementP
  • SubStringP
  • NameInTabelleP
  • ZahlP
  • ZeichenP
  • GanzzahlP
  • 16BitZahlP
  • 8BitZahlP
  • positive8BitZahlP
  • reelleZahlP
  • komplexP
  • SchrägstrichP
  • KreisStrukturP
  • alphanumerischP
  • alphabetischP
  • ASCIIP
  • KontrollzeichenP
  • CSymbolP
  • ZifferP
  • grafischP
  • kleinbuchstabigP
  • druckbarP
  • InterpunktionP
  • LeerraumP
  • großbuchstabigP
  • HexadezimalzifferP

References:

    Arbeitsbereiche, Datei-Verzeichnisse, Dateien öffnen, Daten-Struktur Grundwörter, Parallele Ausführung

ausSchlange WortP


HC / Daten-Struktur Grundwörter / Abfragen / WortP

WortP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] WortP
Abfragen ListeP

WortP Ding
Wort? Ding

Ausgabe ist wahr, wenn die Eingabe ein Wort ist, sonst falsch.

Beispiele:

Word? "		;wahr  ;-)
Word? []		;falsch  ;-)
Word? "aWord		;wahr  ;-)
Word? [a liste]		;falsch  ;-)
Word? {an reihe}		;falsch  ;-)
Word? (Wort [a liste])		;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / ListeP

ListeP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] ListeP
WortP ReiheP

ListeP Ding
Liste? Ding

Ausgabe ist wahr, wenn die Eingabe eine Liste ist, sonst falsch.

Beispiele:

List? [Hallo World]		;wahr  ;-)
List? []		;wahr  ;-)
List? "		;falsch  ;-)
List? "Hallo		;falsch  ;-)
List? {an reihe}		;falsch  ;-)
List? (liste "Hallo)		;wahr  ;-)
List? (liste {an reihe})		;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / ReiheP

ReiheP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] ReiheP
ListeP leerP

ReiheP Ding
Reihe? Ding

Ausgabe ist wahr, wenn die Eingabe eine Reihe ist, sonst falsch.

Beispiele:

Reihe? {Hallo World}		;wahr  ;-)
Reihe? {}		;wahr  ;-)
Reihe? {1 2 3}		;wahr  ;-)
Reihe? []		;falsch  ;-)
Reihe? [a liste]		;falsch  ;-)
Reihe? "aWord		;falsch  ;-)
Reihe? ListToArray [Hallo World]		;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / leerP

leerP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] leerP
ReiheP gleichP

leerP Ding
leer? Ding

Ausgabe ist wahr, wenn die Eingabe das leere Wort oder die leere Liste ist, sonst falsch.

Beispiele:

leer? "		;wahr  ;-)
leer? []		;wahr  ;-)
leer? "Hallo		;falsch  ;-)
leer? [Hallo]		;falsch  ;-)
leer? {}		;falsch  ;-)

Examples:

  • führeAusMitAusgabe
  • alleErste
  • _Makro

References:

    _Makro, alleErste, führeAusMitAusgabe

ReiheP gleichP


HC / Daten-Struktur Grundwörter / Abfragen / gleichP

gleichP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] gleichP
leerP vorherP

gleichP Ding1 Ding2
gleich? Ding1 Ding2
Ding1==Ding2

Ausgabe ist wahr, wenn die Eingaben sind gleich, sonst falsch.

Zwei Zahlen sind gleich, wenn sie den gleichen numerischen Wert haben.

Zwei nicht numerische Wörter sind gleich, wenn sie die gleichen Zeichen in der gleichen Reihenfolge enthalten.

Wenn GroßKleinEgal? auf wahr gesetzt wurde, mit

    setzeGroßKleinEgal wahr
gesetzt, dann wird ein großer Buchstabe als gleich angesehen zum entsprechende kleinen Buchstaben (Dies ist der Normalfall.).

Zwei Listen oder Reihen sind gleich, wenn ihre Elemente gleich sind.

Beispiele:

gleich? wahr falsch		;falsch  ;-)
gleich? wahr wahr		;wahr  ;-)
gleich? falsch falsch		;wahr  ;-)
gleich? 1234 2345		;falsch  ;-)
gleich? pi 3.14		;falsch  ;-)
gleich? "A "a		;wahr  ;-)
gleich? "Hallo "World		;falsch  ;-)
gleich? [Hallo] [World]		;falsch  ;-)
gleich? [Hallo] [Hallo]		;wahr  ;-)
gleich? {1 2} {1 2}		;wahr  ;-)
gleich? {1 2} {3 4}		;falsch  ;-)

See also:

  • Tokenisierung

Reference:

    Tokenisierung

leerP vorherP


HC / Daten-Struktur Grundwörter / Abfragen / vorherP

vorherP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] vorherP
gleichP _gleich

vorherP Wort1 Wort2
vorher? Wort1 Wort2

Ausgabe ist wahr, wenn Wort1 vor Wort2 kommt im ASCII-Code (für Wörter von Buchstaben, in alphabetischer Ordnung). Groß-Kleinschreibungs wird vom Wert von CaseIgnoredP bestimmt. Beachten Sie, dass, wenn die Eingaben Zahlen sind, das Ergebnis nicht das gleiche sein muss wie mit kleiner?;

zum Beispiel,

    vorher? 3 12
ist falsch weil 3 im ASCII-Code nach 1 kommt.

Beispiels:

vorher? 3 12		;falsch  ;-)
kleiner? 3 12		;wahr  ;-)
vorher? "A "B		;wahr  ;-)
vorher? [A] [B]		;wahr  ;-)
vorher? [World] [Hallo]		;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / _gleich

_gleich

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] _gleich
vorherP ElementP

_gleich Ding1 Ding2

Ausgabe ist wahr, wenn die zwei Eingaben der gleiche Logo-Knoten sind, so dass die Anwendung eines Mutators auf Ding1 ebenso Ding2 verändern wird.

Ausgabe ist falsch sonst, sogar wenn die Eingaben in ihrem Wert gleich sind.

Beispiele:

_gleich 1 1		;falsch  ;-)
a=1
_gleich a a		;wahr  ;-)
_gleich a 1		;falsch  ;-)

_gleich [a] [a]		;falsch  ;-)
a=[a]
_gleich a [a]		;falsch  ;-)
_gleich a a		;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / ElementP

ElementP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] ElementP
_gleich SubStringP

ElementP Ding1 Ding2
Element? Ding1 Ding2

Wenn Ding2 eine Liste oder eine Reihe ist, ist die Ausgabe wahr, wenn Ding1 gleich? zu einem der Elemente von Ding2 ist, sonst falsch.

Wenn Ding2 ein Wort ist, ist die Ausgabe wahr, wenn Ding1 ein Ein-Zeichen-Wort gleich? zu einem Zeichen von Ding2 ist, sonst falsch.

Beispiele:

Element? "a "Hallo		;wahr  ;-)
Element? "Hallo [Hallo World]		;wahr  ;-)
Element? "Hallo {Hallo World}		;wahr  ;-)
Element? " []		;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / SubStringP

SubStringP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] SubStringP
ElementP NameInTabelleP

SubStringP Ding1 Ding2
SubString? Ding1 Ding2

Wenn Ding1 oder Ding2 eine Liste oder eine Reihe ist, ist die Ausgabe falsch. Wenn Ding2 ein Wort ist, ist die Ausgabe wahr, wenn Ding1 gleich? zu einer Teilkette von Ding2 ist, sonst falsch.

Beispiele:

subString? "Hal "Hallo		;wahr  ;-)
subString? "Hal [Hallo]		;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / NameInTabelleP

NameInTabelleP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] NameInTabelleP
SubStringP ZahlP

NameInTabelleP Name Tabelle
NameInTabelle? Name Tabelle

Ausgabe ist wahr, wenn es in der Tabelle ein Element namens Name gibt, sonst falsch.

Beispiele:

t=tabelle [[a 1234][b 5678]]
NameInTabelle? "a t	;wahr  ;-)
NameInTabelle? "c t	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / ZahlP

ZahlP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] ZahlP
NameInTabelleP ZeichenP

ZahlP Ding
Zahl? Ding

Ausgabe ist wahr, wenn die Eingabe eine Zahl ist, sonst falsch.

Beispiele:

Zahl? 1234		;wahr  ;-)
Zahl? "1234		;falsch  ;-)
Zahl? 2i		;wahr  ;-)
Zahl? 2.2		;wahr  ;-)
Zahl? [1234]		;falsch  ;-)
Zahl? {1}		;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / ZeichenP

ZeichenP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] ZeichenP
ZahlP GanzzahlP

ZeichenP Ding
Zeichen? Ding

Ausgabe ist wahr, wenn die Eingabe ein Zeichen (ein Wort mit Länge 1) ist, sonst falsch.

Beispiele:

Zeichen? "A		;wahr  ;-)
Zeichen? Zeichen 27		;wahr  ;-)
Zeichen? "Hallo		;falsch  ;-)
Zeichen? [A]		;falsch  ;-)
Zeichen? 1		;falsch  ;-)
Zeichen? "1		;wahr  ;-)
Zeichen? "		;falsch  ;-)
Zeichen? []		;falsch  ;-)

Reference:

    Release Notes für Version 4.64

ZahlP GanzzahlP


HC / Daten-Struktur Grundwörter / Abfragen / GanzzahlP

GanzzahlP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] GanzzahlP
ZeichenP 16BitZahlP

GanzzahlP wert
Ganzzahl? wert

Ausgabe ist wahr, wenn die Eingabe eine Ganzzahl ist (32 Bits), sonst falsch.

Beispiele:

ganzzahl? 1234		;wahr  ;-)
ganzzahl? 1.2		;falsch  ;-)
ganzzahl? -IntMax		;wahr  ;-)
ganzzahl? ganzzahl 1.2		;wahr  ;-)
ganzzahl? [1]		;falsch  ;-)
ganzzahl? {1}		;falsch  ;-)
ganzzahl? "1		;falsch  ;-)
ganzzahl? ganzzahl "1		;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / 16BitZahlP

16BitZahlP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] 16BitZahlP
GanzzahlP 8BitZahlP

16BitZahlP Ding
16BitZahl? Ding

Ausgabe ist wahr, wenn die Eingabe eine 16-Bit-Zahl ist, sonst falsch.

Beispiele:

16bitzahl? 16bitzahl 1234	;wahr  ;-)
16bitzahl? 1234	;falsch  ;-)
16bitzahl? 1.2	;falsch  ;-)
16bitzahl? Int16Max	;wahr  ;-)
16bitzahl? 16BitZahl 1.2	;wahr  ;-)
16bitzahl? [1]	;falsch  ;-)
16bitzahl? {1}	;falsch  ;-)
16bitzahl? "1	;falsch  ;-)
16bitzahl? 16BitZahl "1	;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / 8BitZahlP

8BitZahlP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] 8BitZahlP
16BitZahlP positive8BitZahlP

8BitZahlP Ding
8BitZahl? Ding

Ausgabe ist wahr, wenn die Eingabe eine 8-Bit-Zahl ist, sonst falsch.

Beispiele:

8bitzahl? 8bitzahl 127	;wahr  ;-)
8bitzahl? 1234	;falsch  ;-)
8bitzahl? Int8Max	;wahr  ;-)
8bitzahl? 1.2		;falsch  ;-)
8bitzahl? [1]		;falsch  ;-)
8bitzahl? "1		;falsch  ;-)
8bitzahl? 8bitzahl "1	;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / positive8BitZahlP

positive8BitZahlP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] positive8BitZahlP
8BitZahlP reelleZahlP

positive8BitZahlP Ding
positive8BitZahl? Ding

Ausgabe ist wahr, wenn die Eingabe eine vorzeichenlose 16-Bit-Zahl ist, sonst falsch.

Beispiele:

positive8bitzahl? positive8bitzahl 255	;wahr  ;-)
positive8bitzahl? 1234		;falsch  ;-)
positive8bitzahl? UInt8Max	;wahr  ;-)
positive8bitzahl? 1.2		;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / reelleZahlP

reelleZahlP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] reelleZahlP
positive8BitZahlP komplexP

reelleZahlP wert
reellezahl? wert

Ausgabe ist wahr, wenn die Eingabe eine Gleikommazahl ist, sonst falsch.

Beispiele:

reellezahl? 1.2		;wahr  ;-)
reellezahl? 1e-10		;wahr  ;-)
reellezahl? pi		;wahr  ;-)
reellezahl? FloatMax		;wahr  ;-)
reellezahl? "1		;falsch  ;-)
reellezahl? "1.2		;falsch  ;-)
reellezahl? float "1.2		;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / komplexP

komplexP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] komplexP
reelleZahlP SchrägstrichP

komplexP wert
komplex? wert

Ausgabe ist wahr, wenn die Eingabe eine komplexe Zahl ist, sonst falsch.

Beispiele:

complex? 1i		;wahr  ;-)
complex? 1.2+2.3e6i		;wahr  ;-)
complex? 1.2		;falsch  ;-)
complex? "1i		;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / SchrägstrichP

SchrägstrichP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] SchrägstrichP
komplexP KreisStrukturP

SchrägstrichP zeichen
Schrägstrich? zeichen

TODO: neu schreiben! nicht aktuell!!!

Ausgabe ist wahr, wenn das Eingabezeichen ursprünglich in Logo mit einem Rückstrich () davor eingegeben wurde oder innerhalb vertikaler Striche (), um die übliche besondere syntaktische Bedeutung zu verhindern, sonst falsch. (Ausgabe ist nur wahr, wenn das Zeichen ein

backslashed space, tab, newline, carriage return oder eines von

()[]{}<>;~"+-*/^=:?.

ist.)

Beispiele:

Schrägstrich? "		;wahr  ;-)
Schrägstrich? "[		;wahr  ;-)
Schrägstrich? "=		;wahr  ;-)
Schrägstrich? "\a		;falsch  ;-)

See also:

  • Tokenisierung
  • liesWort

References:

    Tokenisierung(2), liesWort(2)

komplexP KreisStrukturP


HC / Daten-Struktur Grundwörter / Abfragen / KreisStrukturP

KreisStrukturP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] KreisStrukturP
SchrägstrichP alphanumerischP

KreisStrukturP wert
KreisStruktur? wert

Ausgabe ist wahr, wenn die Eingabe ist eine ringförmige Datenstruktur ist. Dies hilft, Endlosschleifen-Fehler zu entdecken, wenn Sie Unterstrich-_Funktionen benutzen.

Beispiele:

a=[1]
_setzeErstes a a
KreisStruktur? a		;wahr  ;-)

a=[1]
_setbf a a
KreisStruktur? a		;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / alphanumerischP

alphanumerischP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] alphanumerischP
KreisStrukturP alphabetischP

alphanumerischP achar
alphanumerisch? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge von alphanumerischen Zeichen ist.

Beispiele:

alphanumerisch? "a	;wahr  ;-)
alphanumerisch? "A	;wahr  ;-)
alphanumerisch? "1	;wahr  ;-)
alphanumerisch? 1	;falsch  ;-)
alphanumerisch? "µe  ;-)
alphanumerisch? "!	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / alphabetischP

alphabetischP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] alphabetischP
alphanumerischP ASCIIP

alphabetischP achar
alphabetisch? achar

Ausgabe ist wahr, wenn die Eingabe ist ein Zeichen in der Teilmenge der Buchstaben ist.

Beispiele:

alphabetisch? "a	;wahr  ;-)
alphabetisch? "A	;wahr  ;-)
alphabetisch? "1	;falsch  ;-)
alphabetisch? 1	;falsch  ;-)
alphabetisch? "µe  ;-)
alphabetisch? "!	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / ASCIIP

ASCIIP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] ASCIIP
alphabetischP KontrollzeichenP

ASCIIP achar
ASCII? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge der ASCII-Zeichen ist.

Beispiele:

ASCII? "a	;wahr  ;-)
ASCII? "A	;wahr  ;-)
ASCII? "1	;wahr  ;-)
ASCII? 1	;falsch  ;-)
ASCII? "lse  ;-)
ASCII? "!	;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / KontrollzeichenP

KontrollzeichenP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] KontrollzeichenP
ASCIIP CSymbolP

KontrollzeichenP achar
Kontrollzeichen? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge der Steuerzeichen ist.

Beispiele:

kontrollzeichen? "a	;falsch  ;-)
kontrollzeichen? "A	;falsch  ;-)
kontrollzeichen? "1	;falsch  ;-)
kontrollzeichen? 1	;falsch  ;-)
kontrollzeichen? "µe  ;-)
kontrollzeichen? "!	;falsch  ;-)
kontrollzeichen? zeichen 13	;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / CSymbolP

CSymbolP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] CSymbolP
KontrollzeichenP ZifferP

CSymbolP achar
CSymbol? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge der C-Symbol-Zeichen ist.

Beispiele:

c_zeichen? "a	;wahr  ;-)
c_zeichen? "A	;wahr  ;-)
c_zeichen? "1	;wahr  ;-)
c_zeichen? 1	;falsch  ;-)
c_zeichen? "µe  ;-)
c_zeichen? "!	;falsch  ;-)
c_zeichen? zeichen 13	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / ZifferP

ZifferP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] ZifferP
CSymbolP grafischP

ZifferP achar
Ziffer? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge der numerischen Ziffern-Zeichen ist.

Beispiele:

ziffer? "a	;falsch  ;-)
ziffer? "A	;falsch  ;-)
ziffer? "1	;wahr  ;-)
ziffer? 1	;falsch  ;-)
ziffer? "µe  ;-)	<= dies seems to be a bug!!!
ziffer? "!	;falsch  ;-)
ziffer? zeichen 13	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / grafischP

grafischP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] grafischP
ZifferP kleinbuchstabigP

grafischP achar
grafisch? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge der sichbaren Zeichen ist.

Beispiele:

graph? "a	;wahr  ;-)
graph? "A	;wahr  ;-)
graph? "1	;wahr  ;-)
graph? 1	;falsch  ;-)
graph? "µe  ;-)
graph? "!	;wahr  ;-)
graph? zeichen 13	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / kleinbuchstabigP

kleinbuchstabigP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] kleinbuchstabigP
grafischP druckbarP

kleinbuchstabigP achar
kleinbuchstabig? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge der kleinen Buchstaben ist.

Beispiele:

kleinbuchstabig? "a	;wahr  ;-)
kleinbuchstabig? "A	;wahr  ;-)  <= in Fall-insensitive mode!!!
kleinbuchstabig? "1	;falsch  ;-)
kleinbuchstabig? 1	;falsch  ;-)
kleinbuchstabig? "lse  ;-)  <= bug?
kleinbuchstabig? "!	;falsch  ;-)
kleinbuchstabig? zeichen 13	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / druckbarP

druckbarP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] druckbarP
kleinbuchstabigP InterpunktionP

druckbarP Achar
druckbar? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge von druckbaren Zeichen ist.

Beispiele:

print? "a	;wahr  ;-)
print? "A	;wahr  ;-)
print? "1	;wahr  ;-)
print? 1	;falsch  ;-)
print? "µe  ;-)
print? "!	;wahr  ;-)
print? zeichen 13	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / InterpunktionP

InterpunktionP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] InterpunktionP
druckbarP LeerraumP

InterpunktionP achar
Interpunktion? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge von Interpunktionszeichen ist.

Beispiele:

interpunktion? "a	;falsch  ;-)
interpunktion? "A	;falsch  ;-)
interpunktion? "1	;falsch  ;-)
interpunktion? 1	;falsch  ;-)
interpunktion? "µe  ;-)	<= bug?
interpunktion? "!	;wahr  ;-)
interpunktion? zeichen 13	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / LeerraumP

LeerraumP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] LeerraumP
InterpunktionP großbuchstabigP

LeerraumP achar
Leerraum? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge von Leerraum-Zeichen ist.

Beispiele:

leerraum? "a	;falsch  ;-)
leerraum? "A	;falsch  ;-)
leerraum? "1	;falsch  ;-)
leerraum? 1	;falsch  ;-)
leerraum? "lse  ;-)
leerraum? "!	;falsch  ;-)
leerraum? zeichen 13	;wahr  ;-)
leerraum? " 	;wahr  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / großbuchstabigP

großbuchstabigP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] großbuchstabigP
LeerraumP HexadezimalzifferP

großbuchstabigP achar
großbuchstabig? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge der großen Buchstaben ist.

Beispiele:

großbuchstabig? "a	;falsch  ;-)
großbuchstabig? "A	;falsch  ;-)	<= in Fall-insensitive mode!!!
großbuchstabig? "1	;falsch  ;-)
großbuchstabig? 1	;falsch  ;-)
großbuchstabig? "µe  ;-)	<= bug!
großbuchstabig? "!	;falsch  ;-)
großbuchstabig? zeichen 13	;falsch  ;-)
großbuchstabig? " 	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Abfragen / HexadezimalzifferP

HexadezimalzifferP

HC [image] Daten-Struktur Grundwörter [image] Abfragen [image] HexadezimalzifferP
großbuchstabigP Eigenschaften

HexadezimalzifferP achar
Hexadezimalziffer? achar

Ausgabe ist wahr, wenn die Eingabe ein Zeichen in der Teilmenge von Hexdezimalziffern ist.

Beispiele:

hexadezimalziffer? "a	;wahr  ;-)
hexadezimalziffer? "A	;wahr  ;-)
hexadezimalziffer? "1	;wahr  ;-)
hexadezimalziffer? 1	;falsch  ;-)
hexadezimalziffer? "lse  ;-)
hexadezimalziffer? "!	;falsch  ;-)
hexadezimalziffer? zeichen 13	;falsch  ;-)
hexadezimalziffer? " 	;falsch  ;-)


HC / Daten-Struktur Grundwörter / Eigenschaften

Eigenschaften

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften
HexadezimalzifferP zähle

Eigenschaften

...fragen (nicht-boolsche) Eigenschaften der Eingabedaten ab.

Eigenschaften

  • zähle
  • GrößeVon
  • TypVon
  • ASCII
  • ASCIIroh
  • Zeichen
  • ElementeAb
  • kleinbuchstabig
  • großbuchstabig
  • hervorheben
  • klammere
  • klammereFürAusführung
  • KodiereSchrägstrich
  • dies

References:

    Daten-Struktur Grundwörter(3), Abfragen, Arbeitsbereichs-Kontrolle, Igel Bewegungs-Abfragen, Schreibstift-Abfragen, Text Zeichnen, sei

HexadezimalzifferP zähle


HC / Daten-Struktur Grundwörter / Eigenschaften / zähle

zähle

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] zähle
Eigenschaften GrößeVon

zähle Ding

Ausgabe ist die Anzahl von Zeichen in der Eingabe, wenn die Eingabe ein Wort ist.

Ausgabe ist die Anzahl von Elementen in der Eingabe, wenn sie ein Liste, Reihe oder Tabelle ist (Bei einer Reihe braucht der Index des letzten Elements nicht mit der Ausgabe dieser Funktion übereinzustimmen, je nach dem Ursprung der Reihe.). Für eine Tabelle gibt zähle nicht die Tabelle-Größe, sondern die Anzahl von gesetzten Elementen aus.

Beispiele:

zähle "Hallo		;5  ;-)
zähle 1234		;4  ;-)
zähle [Hallo World]		;2  ;-)
zähle {a b c}		;3  ;-)
zähle [[][]]		;2  ;-)

t=tabelle 3
zähle t		;0  ;-)
t'a=1234
zähle t		;1  ;-)
t'b=567
zähle t		;2  ;-)
t'c=890
zähle t		;3  ;-)
entferneElement "b t
zähle t		;2  ;-)
t		;[a 1234][c 890] ;-)

Examples:

  • DynamischeBibliothek
  • spieleWaveSchnell
  • TiefpaßFilter2
  • setzePunktXYZ
  • TiefpaßFilter
  • setzePunktXY
  • Grundwörter
  • TextPuffer

References:

    spieleWaveSchnell(3), Grundwörter(2), setzePunktXY(2), setzePunktXYZ(2), DynamischeBibliothek, ListenControlSpaltenanzahl, TextPuffer, TiefpaßFilter, TiefpaßFilter2, setzeMdElement, zähleListenControlElemente

Eigenschaften GrößeVon


HC / Daten-Struktur Grundwörter / Eigenschaften / GrößeVon

GrößeVon

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] GrößeVon
zähle TypVon

GrößeVon x

Ausgabe ist die Größe in Bytes, die bei

    tippebinär x
benötigt werden.

Beispiele:

größevon ganzzahl 1	;4  ;-)
größevon 16bitzahl 1	;2  ;-)
größevon 8bitzahl 1	;1  ;-)
größevon positive8BitZahl 1	;1  ;-)
größevon 1.1	;8  ;-)
größevon 1i		;16  ;-)
größevon "abc	;3  ;-)
größevon ganzzahlen 3	;12  ;-)
größevon 16bitzahlen 5	;10  ;-)
größevon [123456 a]	;7  ;-) (counting the characters)
größevon {1 2 3}	;3  ;-) (counting the characters)
größevon struktur [[a ganzzahl][b 16bitzahl][c 8bitzahl]]	;7  ;-)

Examples:

  • setzeSchreiber
  • Struktur

References:

    Release Notes für Version 4.67, Struktur, setzeSchreiber

zähle TypVon


HC / Daten-Struktur Grundwörter / Eigenschaften / TypVon

TypVon

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] TypVon
GrößeVon ASCII

TypVon x

Ausgabe ist ein Wort, das den Typ von x repräsentiert.

Beispiele:

typvon ganzzahl 1	;Ganzzahl  ;-)
typvon 16bitzahl 1	;16BitZahl  ;-)
typvon 8bitzahl 1	;8BitZahl  ;-)
typvon positive8bitzahl 1	;positive8BitZahl  ;-)
typvon 1.1	;Float  ;-)
typvon 1i		;Complex  ;-)
typvon "abc	;Wort  ;-)
typvon []		;Liste  ;-)
typvon [1 2 3]	;Liste  ;-)
typvon {1 2 3}	;Reihe  ;-)
typvon ganzzahlen 3	;Ganzzahlen  ;-)
typvon struktur [[a ganzzahl][b 8bitzahl]]	;Struktur  ;-)

Example:

  • reelleZahl

References:

    reelleZahl(2), Release Notes für Version 4.67

GrößeVon ASCII


HC / Daten-Struktur Grundwörter / Eigenschaften / ASCII

ASCII

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] ASCII
TypVon ASCIIroh

ASCII Zeichen

Ausgabe ist die Ganzzahl (zwischen 0 und 255), die das Eingabe-Zeichen im ASCII-Code repräsentiert. Interpretiert Steuerzeichen wie Backslashed Interpunktion und gibt den Zeichencode für das entsprechende Interpunktions-Zeichen ohne Backslash aus. (Vergleiche ASCIIroh.)

Beispiele:

ASCII "a		;97  ;-)
ASCII 0		;48  ;-)
ASCII "[		;91  ;-)
ASCII Zeichen 1		;40  ;-)
Zeichen 40		;(  ;-)

See also:

  • öffneZumSchreibenBinär
  • Tastenwert
  • ASCIIroh
  • ladeBild
  • Release
  • vorherP
  • Zeichen
  • ASCIIP

Example:

  • ASCIIP

References:

    ASCIIP(8), ASCIIroh(2), vorherP(2), Release, Tastenwert, Zeichen, ladeBild, öffneZumSchreibenBinär

TypVon ASCIIroh


HC / Daten-Struktur Grundwörter / Eigenschaften / ASCIIroh

ASCIIroh

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] ASCIIroh
ASCII Zeichen

ASCIIroh zeichen

Ausgabe ist die Ganzzahl (zwischen 0 und 255), die das Eingabe-Zeichen im ASCII-Code repräsentiert. Interpretiert Steuerzeichen wie sie selbst dargestellt werden. Um den ASCII-Code eines beliebigen Tastendrucks herauszufinden, benutzen Sie

    zeige ASCIIroh liesZeichen
Beispiel:

dauernd [zeige ASCIIroh liesZeichen]

Examples:

  • liesZeichenErweitert
  • öffneZumLesenBinär
  • liesZeichen

References:

    öffneZumLesenBinär(3), ASCII, liesZeichen, liesZeichenErweitert

ASCII Zeichen


HC / Daten-Struktur Grundwörter / Eigenschaften / Zeichen

Zeichen

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] Zeichen
ASCIIroh ElementeAb

Zeichen Ganzzahl

Ausgabe ist das im ASCII-Code dargestellte Zeichen mit der Nummer Ganzzahl, die eine Ganzzahl zwischen 0 und 255 sein kann.

Beispiele:

Zeichen 65		;A  ;-)
Zeichen 66		;B  ;-)
Zeichen 97		;a  ;-)
Zeichen 98		;b  ;-)
Zeichen 48		;0  ;-)
Zeichen 49		;1  ;-)

Examples:

  • öffneZumSchreibenBinär
  • liesZeichenErweitert
  • KodiereSchrägstrich
  • HexadezimalzifferP
  • kleinbuchstabigP
  • KontrollzeichenP
  • großbuchstabigP
  • InterpunktionP
  • liesZeichen
  • druckbarP
  • grafischP
  • LeerraumP
  • CSymbolP
  • ZeichenP
  • ZifferP
  • ASCII

References:

    ZeichenP(11), liesZeichen(6), ASCII(5), KodiereSchrägstrich(4), liesWort(4), CSymbolP(3), LeerraumP(3), SchrägstrichP(3), ZifferP(3), druckbarP(3), grafischP(3), liesMehrereZeichen(3), liesZeichenErweitert(3), tippe(3), ASCIIP(2), ASCIIroh(2), ElementP(2), Filter(2), HexadezimalzifferP(2), InterpunktionP(2), KontrollzeichenP(2), TasteP(2), TextPufferInWort(2), alphanumerischP(2), beiGraphZeichen(2), beiZeichen(2), großbuchstabigP(2), kleinbuchstabigP(2), setzeTextfarbe(2), öffneZumSchreibenBinär(2), DateiendeP, Element, Fenster-Stile, Knoten, Protokolliere, Release Notes für Version 4.685, Struktur, Systemaufruf, Tastenwert, TextMausOrt, TextMausX, TextMausY, TextPuffer, VieleckEnde, ZeichenUnterCursor, alphabetischP, beiFensterZeichen, beiKombiBoxZeichen, beiListenboxZeichen, beiTextboxZeichen, beiZeichenInAuswahlbox, beiZeichenInListenControl, erstes, finde, formatiere, fürAlle, gleichP, inListe, klammere, klammereFürAusführung, letztes, liesListe, minus, ohneErstes, ohneLetztes, reduziere, setzeCursor, setzeGroßKleinEgal, setzeLeserOrt, setzeSchreibBreitenGrenze, setzeSchreiberOrt, warte, zähle

ASCIIroh ElementeAb


HC / Daten-Struktur Grundwörter / Eigenschaften / ElementeAb

ElementeAb

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] ElementeAb
Zeichen kleinbuchstabig

ElementeAb Ding1 Ding2

wenn Ding2 ein Wort oder eine Liste ist, und wenn Element? mit diesen Eingaben wahr ausgeben würde, ist die Ausgabe der Teil von Ding2 ab dem ersten Auftreten von Ding1 bis zum Ende von Ding2.

Wenn Element? falsch ausgeben würde, ist die Ausgabe das leere Wort oder die leere Liste, je nach Typ von Ding2. Es ist ein Fehler, wenn Ding2 eine Reihe ist (weil ohneErstes für Reihen nicht funktioniert).

Beispiele:

ElementeAb "a "Hallo		;allo  ;-)
ElementeAb "Hal "Hallo		;  ;-)
Element? "Hal "Hallo		;falsch  ;-)
ElementeAb "World [Hallo World]		;[World] ;-)
ElementeAb "b {a b c}		;  elementeab doesn't like {a b c} as input

Example:

  • Berkeley Logo-Anwenderdokumentation

Reference:

    Berkeley Logo-Anwenderdokumentation

Zeichen kleinbuchstabig


HC / Daten-Struktur Grundwörter / Eigenschaften / kleinbuchstabig

kleinbuchstabig

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] kleinbuchstabig
ElementeAb großbuchstabig

kleinbuchstabig Wort

Ausgabe ist eine Kopie des Eingabe-Worts, aber mit allen Großbuchstaben in die entsprechenden Kleinbuchstaben umgewandelt.

Beispiele:

kleinbuchstabig "HALLO		;hallo  ;-)
zeige kleinbuchstabig [H A L L O]		;h a l l o
zeige kleinbuchstabig {H A L L O}		;{h a l l o}

Examples:

  • kleinbuchstabigP
  • Grundwörter

References:

    kleinbuchstabigP(8), Grundwörter, IgelText, Release, setzeGroßKleinEgal

ElementeAb großbuchstabig


HC / Daten-Struktur Grundwörter / Eigenschaften / großbuchstabig

großbuchstabig

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] großbuchstabig
kleinbuchstabig hervorheben

großbuchstabig wort

Ausgabe ist eine Kopie des Eingabe-Worts, aber mit allen Kleinbuchstaben in die entsprechenden Großbuchstaben umgewandelt.

Beispiele:

großbuchstabig "hallo		;HALLO  ;-)
zeige großbuchstabig [h a l l o]		;H A L L O
zeige großbuchstabig {h a l l o}		;{H A L L O}

Example:

  • großbuchstabigP

References:

    großbuchstabigP(9), Release

kleinbuchstabig hervorheben


HC / Daten-Struktur Grundwörter / Eigenschaften / hervorheben

hervorheben

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] hervorheben
großbuchstabig klammere

hervorheben wert

funktioniert noch nicht.

See also:

  • setzeTextfarbe

Reference:

    setzeTextfarbe

großbuchstabig klammere


HC / Daten-Struktur Grundwörter / Eigenschaften / klammere

klammere

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] klammere
hervorheben klammereFürAusführung

klammere wort

Ausgabe ist die Liste, die sich ergeben würde, wenn das Eingabe-Wort als Antwort auf eine liesListe-Operation eingegeben würde. Das heißt,

    klammere liesWort
hat den gleichen Wert, wie liesListe für die gleichen gelesenen Zeichen.

Beispiel:

klammere "vorwärts 100		;[vorwärts 100] ;-)

See also:

  • Tokenisierung

Reference:

    Tokenisierung(2)

hervorheben klammereFürAusführung


HC / Daten-Struktur Grundwörter / Eigenschaften / klammereFürAusführung

klammereFürAusführung

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] klammereFürAusführung
klammere KodiereSchrägstrich

klammereFürAusführung WortOderListe

Ausgabe ist die Liste, die sich ergeben würde, wenn die Eingabe WortOderListe als eine Befehlszeile eingegeben würde; Zeichen wie Infix-Operatoren und Klammern werden einzelne Ausgabe-Elemente. Beachten Sie, dass Unterlisten nicht geklammert werden, sondern wörtlich gespeichert werden.

Beispiele:

klammereFürAusführung "1+2		;[1 + 2] ;-)
klammereFürAusführung [(1+2)*3]		;[( 1 + 2 ) * 3] ;-)

See also:

  • Tokenisierung

Reference:

    Tokenisierung(2)

klammere KodiereSchrägstrich


HC / Daten-Struktur Grundwörter / Eigenschaften / KodiereSchrägstrich

KodiereSchrägstrich

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] KodiereSchrägstrich
klammereFürAusführung dies

KodiereSchrägstrich Zeichen

Ausgabe ist ein neuer vbarstring mit verschlüsselten Backslashes von Zeichen.

Beispiel:

KodiereSchrägstrich zeichen 9
      ;-)
KodiereSchrägstrich zeichen 13

  ;-)

Reference:

    Release Notes für Version 4.686

klammereFürAusführung dies


HC / Daten-Struktur Grundwörter / Eigenschaften / dies

dies

HC [image] Daten-Struktur Grundwörter [image] Eigenschaften [image] dies
KodiereSchrägstrich Bedingte Ausführung

dies

Ausgabe ist das Logo-Objekt, mit dem momentan gearbeitet wird.

Beispiel:

be testobj4
    be point x y c
        be print
            (::print this'x this'y)
            ;just as an example, "this" is not really neccessary
        end
        be draw
            setPixelXY x y c
        end
    end
    p=point 200 100 "red
    p'print
    p'draw
end

Examples:

  • Versions-Informationen für Version 4.7
  • Berkeley Logo-Anwenderdokumentation
  • öffneZumAktualisieren
  • setzeSchreiberOrt
  • öffneZumSchreiben
  • öffneZumAnhängen
  • setzeLeserOrt
  • TiefentestAus
  • ZifferP
  • Liste
  • zeige
  • Ding

References:

    Fenster-Stile(6), Versions-Informationen für Version 4.7(6), Tokenisierung(5), _Makro(4), Berkeley Logo-Anwenderdokumentation(3), Release Notes für Version 4.64(3), Grafiken(2), Liste(2), NebelAn(2), Release Notes für Version 4.65(2), Schieberegler(2), TextControl(2), _vielleichtAusgabe(2), setzeSchreiberOrt(2), tippe(2), zeige(2), öffneZumAnhängen(2), öffneZumSchreiben(2), 16BitZahl, 8BitZahl, BeleuchtungAus, Diagramm, Ding, Direkte Grafik, DitheringAn, DitheringAus, DoppelPufferung, Einfachpuffer, Knoten, Konsole-Funktionen, KreisStrukturP, LogoSchriftenVerzeichnis, LogoSprache, LogoTemporäresVerzeichnis, ModelviewMatrix, Müllsammeln, NebelAus, Pause, PunktglättungAn, PunktglättungAus, Randsprung, Release, Release Notes für Version 4.66, Release Notes für Version 4.672, Release Notes für Version 4.682, Release Notes für Version 4.686, Starten und Verlassen von Logo, TasteP, Tastenwert, TesselationStart, TextMausEreignisseAn, TextMausEreignisseAus, TextPuffer, TiefentestAus, UmkehrStift, Variablen-Definition, VieleckEnde, VieleckStart, VieleckglättungAn, WortUnterCursor, ZeichenUnterCursor, ZifferP, achsen, alleErste, beendeteMidiAusgabeströme, dirlg, erneuereGraph, erneuereVariablenliste, erneuereVariablenlisteBeiSchritt, führeAus, fülle, gleichP, hex, kalibriereScrolling, kaskadiere, konjugieren, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, löscheSchatten, namensliste, oder2, ohneErste, pllist, rundeLinienendenAn, sei, setzeGenSym, setzeLeserOrt, setzeNamensraum, setzePlayOnSwap, setzeRedefinierbar, setzeTiefentestFunktion, speichereSchirmVektoriell, und2, versteckeLogoHauptfenster, verteileMeldungen, wirf, wirfSchatten, xKopieren, zeigeLogoHauptfenster, zumGestellDazu, Überprüfung, öffneZumAktualisieren

KodiereSchrägstrich Bedingte Ausführung


HC / Bedingte Ausführung

Bedingte Ausführung

HC [image] Bedingte Ausführung
dies wenn

Bedingte Ausführung

...faßt einige Befehle zusammen, die Befehlslisten als Eingaben annehmen, welche nur ausgeführt werden, wenn bestimmte Bedingungen erfüllt werden.

Bedingte Ausführung

  • wenn
  • wennSonst
  • wennWahr
  • wennFalsch
  • teste
  • Fall
  • Bedingung
  • wirf
  • fange
  • liesFehler
  • _vielleichtAusgabe


HC / Bedingte Ausführung / wenn

wenn

HC [image] Bedingte Ausführung [image] wenn
Bedingte Ausführung wennSonst

wenn wf Befehlsliste1
(wenn wf Befehlsliste1 Befehlsliste2)

Kommando. Wenn die erste Eingabe den Wert wahr hat, dann lässt "wenn" die zweite Eingabe laufen. Wenn die erste Eingabe den Wert falsch hat, dann führt "wenn" nichts aus. (Wenn dem "wenn" eine dritte Eingabe gegeben wird, funktioniert "wenn" wie "wennSonst", wie unten beschrieben.) Es ist ein Fehler, wenn die erste Eingabe weder wahr noch falsch ist.

Für Kompatibilität mit früheren Logo-Versionen, wenn eine "wenn"-Anweisung nicht in Klammern eingeschlossen wird, aber der erste Wert auf der Befehlszeile nach dem zweiten Eingabeausdruck eine wörtliche Liste (d. h., eine Liste in eckigen Klammern) ist, wird das "wenn" wie ein "wennSonst" betrachtet, aber eine warnende Meldung ausgegeben. Wenn dieses anomale "wenn" in einem Prozedur-Körper erscheint, wird die Warnung nur das erste Mal in jeder Logo-Sitzung ausgegeben, wenn die Prozedur aufgerufen wird.

Beispiele:

wenn wahr [schreibe wahr]		;wahr
wenn wahr [wahr]		;wahr  ;-) (outputs wahr)
wenn falsch [schreibe falsch]
wenn 1==1 [schreibe wahr]		;wahr

See also:

  • Tokenisierung

Examples:

  • Berkeley Logo-Anwenderdokumentation
  • beiGeklicktemRadioKnopf
  • SystemaufrufAbspalten
  • liesZeichenErweitert
  • führeAusMitAusgabe
  • setzeGraphErneuern
  • zerstöreRadioknopf
  • verkleinereStapel
  • weiterMitSchleife
  • setzeRadioknopf
  • RadioknopfWert
  • addiereFarben
  • MandelIterate
  • öffneZumLesen
  • beendeteTöne
  • RadioknopfAn
  • Systemaufruf
  • liesZeichen
  • unterbrich
  • alleErste
  • reduziere
  • _Makro
  • Halt

References:

    Tokenisierung(13), Fehler-Verarbeitung(11), _Makro(11), zu(11), Fenster-Stile(8), unterbrich(8), weiterMitSchleife(8), Starten und Verlassen von Logo(7), fange(7), setzeTiefentestFunktion(7), Release Notes für Version 4.65(6), Versions-Informationen für Version 4.7(6), Vorlagen-basierte Iteration(6), wirf(6), Einführung in die Logo-Programmierung(5), KombiBox(5), Release Notes für Version 4.685(5), Zahlbox(5), bearbeite(5), gleichP(5), liesZeichen(5), zumGestellDazu(5), Element(4), ElementP(4), ElementeAb(4), Filter(4), Systemaufruf(4), TasteP(4), TextControl(4), `(4), addiereFarben(4), bildeAbSatz(4), bildeab(4), finde(4), fürAlle(4), größerGleichP(4), größerP(4), kaskadiere(4), kleinerGleichP(4), kleinerP(4), reduziere(4), Über Komplexität(4), GanzzahlBox(3), Geltungsbereich der Variablen(3), KombiBoxen(3), ListControl(3), Listenboxen(3), Müllsammeln(3), Numerische Operationen(3), RadioknopfAn(3), Standart-Ereignis-Behandler(3), SubStringP(3), Textur(3), Volltext(3), Vorzeichen(3), erstes(3), formatiereGanzzahl(3), für(3), kopiereDefinition(3), letztes(3), liesMehrereZeichen(3), neuerZufall(3), oder(3), ohneErstes(3), ohneLetztes(3), setze(3), setzeRadioknopf(3), und(3), verbinde(3), wennSonst(3), öffneZumAktualisieren(3), öffneZumAktualisierenBinär(3), 16BitZahlen(2), Absolute Igel-Bewegung(2), Anführungszeichen(2), AnkreuzboxAn(2), Auswahlbox(2), AuswahlboxAn(2), BogenTangens(2), ChoiceBoxes(2), Diagramm(2), Editieren(2), FensterModus(2), GanzzahlBoxAn(2), Ganzzahlen(2), Halt(2), Ignoriere(2), KnopfAn(2), Knoten(2), KombiBoxAn(2), KreisStrukturP(2), ListControls(2), ListenControlAn(2), Listenbox(2), ListenboxAn(2), MandelIterate(2), Pause(2), RadioknopfWert(2), Reihe(2), Relative Igel-Bewegung(2), Release Notes für Version 4.64(2), Release Notes für Version 4.69(2), Satz(2), SchaltknopfAn(2), Schieberegler(2), SchiebereglerAn(2), Schreibstift- und Hintergrund-Kontolle(2), SchrägstrichP(2), StiftAbP(2), TextboxAn(2), ZahlboxAn(2), Zylinder(2), _gleich(2), alleErste(2), arc2(2), beschäftigtP(2), führeAusMitAusgabe(2), holeAuswahl(2), holeAuswahlZahl(2), holeAuswahlmöglichkeiten(2), holePasswortVomBenutzer(2), holeTextVomBenutzer(2), lade(2), liesFehler(2), liesWort(2), liesZeichenErweitert(2), positive8BitZahl(2), radBogenTangens(2), reelleZahlen(2), rufeDynamischeBibliothekAuf(2), sei(2), setzeAnkreuzbox(2), setzeBackslashErweiterung(2), setzeErallOnRun(2), setzeGraphErneuern(2), setzeLadeMitAusgabe(2), setzeSchaltknopfZustand(2), setzeStapelAusführlich(2), setzeStartup(2), setzeTexturXY(2), sichtbarP(2), solange(2), speichereSchirmVektoriell(2), verfolge(2), vorherP(2), vorwärts(2), weiter(2), wirfSchatten(2), zurück(2), zähle(2), öffneZumLesen(2), übertrage(2), 16BitZahl, 16BitZahlP, 8BitZahl, 8BitZahlP, ASCIIP, Ankreuzbox, AnkreuzboxWert, Arithmetische Mutatoren, AuswahlboxAuswahl, Balken, Bedingte Ausführung, Berkeley Logo-Anwenderdokumentation, CSymbolP, CheckBoxen, Cursor, DateiP, DateiendeP, Differenz, Ding, DoppelPufferung, Fakultät, FehlerAktion, Fenster, FensterAn, FensterGroß, FensterKlein, FensterVollbild, GanzzahlBoxWert, GanzzahlP, GanzzahlenFolge, Grafik, Grafiken, GroßKleinEgalP, GrundwortP, HexadezimalzifferP, Hilfe, InterpunktionP, Knopf, Knöpfe, KombiBoxAuswahl, KombiBoxWert, Kommandozeilen-Schalter -nogui, Kommandozeilen-Schalter -run, KontrollzeichenP, LeerraumP, Leser, Linie, ListeP, ListenboxAuswahl, MakroP, Mitte, NameInTabelleP, NebelAn, Oberfläche, Parameteranzahl, Potenz, PrimzahlP, Produkt, ProzedurP, PunktglättungAn, RadioButtons, Radioknopf, Randsprung, ReiheP, Release, Release Notes für Version 4.68, Release Notes für Version 4.686, Release Notes für Version 4.689, Schaltknopf, SchaltknopfZustand, SchattenAn, SchiebereglerWert, SchreibBreitenGrenze, Schreiber, SchreibtiefenGrenze, Sound, SoundsStop, Summe, SystemaufrufAbspalten, Tabelle, Tesselation, TesselationStart, TextMausEreignisseAus, TextPuffer, Textbox, ToggleButtons, Variablen-Definition, VariablenNameP, Versions-Informationen, VerzeichnisP, Vieleck, WiederholZahl, WortP, ZahlP, ZahlboxWert, Zaun, ZeichenP, ZifferP, ZylinderlinienAn, ZylinderlinienAus, _vielleichtAusgabe, aktiviereKonsole, alphabetischP, alphanumerischP, aufzeichnenP, bearbeiteDatei, beendeteTöne, beiAuswahlboxAuswahl, beiGedrückterTaste, beiGedrückterTasteInGraph, beiGeklicktemRadioKnopf, beiGraphZeichen, beiKombiBoxAuswahl, beiKombiBoxEingabe, beiKombiBoxÄnderung, beiListenboxAuswahl, beiLosgelassenerTaste, beiLosgelassenerTasteInGraph, beiZeichen, betreteGrafik, bis, crossmap, definiertP, druckbarP, erneuereAufrufliste, erneuereVariablenlisteBeiSchritt, erzeugeSymbol, formatiere, führeAus, fülle, fülleBitmap, grafischP, großbuchstabigP, inListe, invertiere, kalibriereScrolling, klammere, klammereFürAusführung, kleinbuchstabigP, komplexP, ladeMitAnzeige, leerP, liesBenutzer, liesListe, listeTSH, löscheSchatten, löscheTexturen, mdarray, minus, nicht, oder2, offeneDateien, ohneErste, positive8BitZahlP, reelleZahlP, renderLogoAsHTML, renderLogoFileAsHTML, schiebeArithmetisch, schiebeLogisch, schreibe, setReader, setzeGroßKleinEgal, setzeKurs, setzeLeserOrt, setzeLogoSprache, setzeNamensraum, setzeOrt, setzePlayOnSwap, setzeQuetschung, setzeRedefinierbar, setzeSchirmbereich, setzeSchreibBreitenGrenze, setzeSchreibTiefenGrenze, setzeSchreiber, setzeSchreiberOrt, setzeStiftdicke, setzeTextfarbe, setzeTexturort, speichereBild, statischerText, stoppeTöne, sättigeOberhalb, sättigeUnterhalb, teile, tiefeKopie, tippe, tue_bis, tue_solang, und2, verfolgealle, vergiß, verkleinereStapel, verlasseGrafik, versteckeLogoHauptfenster, wendeAn, wennFalsch, wennWahr, yield, zeichneBitmapAuf, zeichneBitmapSkaliertAuf, zeige, zeigeLogoHauptfenster, zerstöreFenster, zerstöreGraph, zerstöreRadioknopf, öffneZumAnhängen, öffneZumAnhängenBinär, öffneZumSchreiben, öffneZumSchreibenBinär

Bedingte Ausführung wennSonst


HC / Bedingte Ausführung / wennSonst

wennSonst

HC [image] Bedingte Ausführung [image] wennSonst
wenn wennWahr

wennSonst wf Befehlsliste1 Befehlsliste2

Kommando oder Operation. Wenn die erste Eingabe den Wert wahr hat, dann lässt wennSonst die zweite Eingabe laufen. Wenn die erste Eingabe den Wert falsch hat, dann lässt wennSonst die dritte Eingabe laufen.

wennSonst gibt einen Wert aus, wenn die Befehlsliste einen Ausdruck enthält, der einen Wert ausgibt.

Beispiele:

wennSonst wahr [schreibe wahr][schreibe falsch]		;wahr
wennSonst falsch [schreibe wahr][schreibe falsch]		;falsch

Examples:

  • beiGeklicktemSchaltknopf
  • beiGeklickterAnkreuzbox
  • setzeSchaltknopfZustand
  • liesZeichenErweitert
  • beiTextMausbewegung
  • zerstöreSchaltknopf
  • SchaltknopfZustand
  • ZerstöreAnkreuzbox
  • setzeAnkreuzbox
  • AnkreuzboxWert
  • SchaltknopfAn
  • AnkreuzboxAn
  • liesZeichen
  • Schaltknopf
  • reduziere
  • sei

References:

    Schaltknopf(2), beiGeklicktemSchaltknopf(2), beiGeklickterAnkreuzbox(2), reduziere(2), sei(2), wenn(2), AnkreuzboxAn, AnkreuzboxWert, SchaltknopfAn, SchaltknopfZustand, ZerstöreAnkreuzbox, beiTextMausbewegung, liesZeichen, liesZeichenErweitert, oder, setzeAnkreuzbox, setzeSchaltknopfZustand, und, zerstöreSchaltknopf

wenn wennWahr


HC / Bedingte Ausführung / wennWahr

wennWahr

HC [image] Bedingte Ausführung [image] wennWahr
wennSonst wennFalsch

wennWahr Befehlsliste

Kommando. Läßt seine Eingabe laufen, wenn die vorherige "teste"-Anweisung eine wahre Eingabe hatte. Das "teste" muss in der gleichen Prozedur oder einer Superprozedur gewesen sein.

Beispiel:

to t
    teste wahr
    wennwahr [schreibe wahr]
end
;t defined
t		;wahr

Reference:

    teste(2)

wennSonst wennFalsch


HC / Bedingte Ausführung / wennFalsch

wennFalsch

HC [image] Bedingte Ausführung [image] wennFalsch
wennWahr teste

wennFalsch Befehlsliste

Kommando. Läßt seine Eingabe laufen, wenn die vorherige "teste"-Anweisung eine wahre Eingabe hatte. Das "teste" muss in der gleichen Prozedur oder einer Superprozedur gewesen sein.

Beispiel:

to t
    teste falsch
    wennfalsch [schreibe falsch]
end
;t defined
t		;falsch

Reference:

    teste(2)

wennWahr teste


HC / Bedingte Ausführung / teste

teste

HC [image] Bedingte Ausführung [image] teste
wennFalsch Fall

teste tf

Kommando. Speichert seine Eingabe, die wahr oder falsch sein muss, für Verwendung von späteren wennWahr oder wennFalsch Anweisungen. Die Wirkung von "teste" ist lokal zu der Prozedur, in dem es benutzt wird; entsprechende wennWahr oder wennFalsch müssen in der gleichen Prozedur einer Überprozedur sein.

Examples:

  • wennFalsch
  • wennWahr

References:

    wennFalsch(3), wennWahr(3)

wennFalsch Fall


HC / Bedingte Ausführung / Fall

Fall

HC [image] Bedingte Ausführung [image] Fall
teste Bedingung

Fall Wert cliste

führt wie eine Fallunterscheidung je nach Wert die entsprechende Befehlsliste aus, und gibt deren Ausgabe aus. Jede cliste muss einen Wert als erstes Element haben, darauf können Anweisungen folgen. Ist der Bedingungswert in einer cliste das Wort "else" und wurde vorher keine andere Bedingung erfüllt, so wird deren Befehlsliste ausgeführt.

Beispiel:

Fall 2 [[1 "a] [2 "b] [3 "c]]		;b  ;-)
Fall 2 [[1 "a][else "b]]		;b  ;-)
Fall 2 [[1 schreibe "a] [[(Kosinus 0)+Kosinus 0] schreibe "b] [else schreibe "els]]		;b

Examples:

  • kleinbuchstabigP
  • großbuchstabigP

References:

    kaskadiere(4), _Makro(3), wirf(3), Schreibstift- und Hintergrund-Kontolle(2), setzeOrt(2), 16BitZahlen, Ganzzahlen, ListControls, Numerische Operationen, Reihe, Release Notes für Version 4.65, Release Notes für Version 4.67, Starten und Verlassen von Logo, Tokenisierung, _vielleichtAusgabe, alleErste, bildeab, crossmap, entferneElement, fange, fürAlle, großbuchstabigP, kleinbuchstabigP, liesWort, ohneErste, reelleZahlen

teste Bedingung


HC / Bedingte Ausführung / Bedingung

Bedingung

HC [image] Bedingte Ausführung [image] Bedingung
Fall wirf

Bedingung cliste (Bibliotheksprozedur)

Befehl oder Operation. cliste ist eine Liste von Listen aus [Bedingung Anweisungen]. Ergebnis ist der Wert, den die Anweisungen ausgeben. Aber verwenden Sie nicht das Grundwort Ausgabe in den Anweisungen, weil das den Aufrufer von "Bedingung" beenden würde.

Beispiel:

cond [[falsch 1] [wahr 2] [else 3]]		;2  ;-)
cond [[1==2 1234][3==3 4321][else [Hallo]]]		;4321  ;-)

References:

    Fall, kaskadiere

Fall wirf


HC / Bedingte Ausführung / wirf

wirf

HC [image] Bedingte Ausführung [image] wirf
Bedingung fange

wirf Marke
(wirf Marke Wert)

Kommando. Muss innerhalb des Geltungsbereichs eines "fange" mit einer gleichen Marke benutzt werden. Beendet das Laufen des Befehlsliste des "fange". Wenn "wirf" mit nur einer Eingabe benutzt wird, gibt das entsprechende "fange" keinen Wert aus. Wenn "wirf" mit zwei Eingaben benutzt wird, stellt die zweite eine Ausgabe für das "fange" zur Verfügung.

    wirf "toplevel
kann benutzt werden, um alle laufenden Prozeduren und interaktive Pausen zubeenden und zurückzukehren zum äusersten Befehlsprompt. Drücken der System-Pausen-Taste [Strg-Pause] hat den gleichen Effekt.
    wirf "error
kann verwendet werden, um einen Fehler zu generieren. Wenn der Fehler nicht gefangen wird, wird er die Fehlermeldung schreiben (wirf "error) mit der üblichen Anzeige, wo der Fehler auftrat (in diesem Fall beim "wirf"). Wenn eine zweite Eingabe zusammen mit einer Marke "error verwendet wird, wird diese zweite Eingabe als Text der Fehlermeldung anstatt der Standart-Meldung verwendet. Auch wird in diesem Fall der Ort, der für den Fehler angegeben wird, nicht der Ort des "wirf" sein, sondern der Ort, an dem die Prozedur, die das "wirf" enthielt, aufgerufen wurde. Dies erlaubt benutzerdefinierten Prozeduren, Fehlermeldungen zu generieren, als wenn sie Grundwörter wären. Beachte: in diesem Fall wird das entsprechende
    fange "error
wenn existent, nichts ausgeben, da die zweite Eingabe an "wirf" nicht als Ausgabewert betrachtet wird.
    wirf "system
verläßt Logo unmittelbar, und kehrt ins Betriebssystem zurück, ohne die übliche Abschiedsmeldung und ohne die temporäre Editor-Datei zu löschen, die von "edit" geschrieben wurde.

Beispiel:

zu t
    fange "Hallo
    [	schreibe 1
        wirf "Hallo
        schreibe 2
    ]
    schreibe 3
ende
;t definiert
t
;1
;3

See also:

  • Starten und Verlassen von Logo
  • Fehler-Verarbeitung

Examples:

  • reduziere
  • _Makro
  • fange

References:

    fange(4), Fehler-Verarbeitung(2), Grafik, Oberfläche, Starten und Verlassen von Logo, Tesselation, Vieleck, _Makro, reduziere

Bedingung fange


HC / Bedingte Ausführung / fange

fange

HC [image] Bedingte Ausführung [image] fange
wirf liesFehler

fange Marke Befehlsliste

Kommando oder Operation. Läßt seine zweite Eingabe laufen. Gibt etwas aus, wenn die Befehlsliste etwas ausgibt. Wenn, solange das Befehlsliste läuft, eine "wirf"-Anweisung mit einer Marke gleich zur ersten Eingabe ausgeführt wird, dann wird das Laufen des Befehlsliste sofort abgebrochen. Im diesem Fall gibt das "fange" einen Wert aus, wenn ein Eingabewert an "wirf" gegeben wurde. Die Marke muss ein Wort sein.

Wenn die Marke das Wort error ist, dann hat jeder Fehlerzustand, der während des Laufens der Befehlsliste entsteht, die Wirkung von

    wirf "error
anstatt eine Fehlermeldung zu schreiben und zu Toplevel zurückzukehren. Das "fange" gibt nichts aus, wenn ein Fehler gefangen wird. Auch ist während des Laufens der Befehlsliste die Variable erract temporär ungebunden. (Wenn ein Fehler auftritt, solange erract einen Wert hat, wird dieser Wert als Befehlsliste genommen, die nach Ausgabe der Fehlermeldung ausgeführt wird. Typischer Wert von erract ist, wenn nicht [], die Liste [Pause].)

Beispiel:

zu t
    gibAus fange "Hallo
    [	schreibe 1
        (wirf "Hallo 1234)
        schreibe 2
    ]
    schreibe 3
ende
;t definiert
t
;1
;1234  ;-)

See also:

  • Fehler-Verarbeitung

Examples:

  • liesFehler
  • _Makro
  • wirf

References:

    wirf(6), Fehler-Verarbeitung(3), _Makro, liesFehler

wirf liesFehler


HC / Bedingte Ausführung / liesFehler

liesFehler

HC [image] Bedingte Ausführung [image] liesFehler
fange _vielleichtAusgabe

liesFehler

Ausgabe ist eine den gerade gefangenen Fehler beschreibende Liste, wenn überhaupt. Wenn kein Fehler seit der letzten Verwendung von FEHLER gefangen wurde, wird die leere Liste ausgegeben. Die Fehler-Liste enthält vier Elemente:

Ganzzahl-Code entsprechend dem Typ des Fehlers,

Text der Fehlermeldung,

Name der Prozedur, in dem der Fehler auftrat,

Anweisungs-Zeile, in der der Fehler auftrat.

Beispiel:

zu t
    schreibe 1
    fange "error
    [	asdfsfg
    ]
    zeige error
ende
;t definiert
t
;1
;[13 [; Ich kenne nicht  zu asdfsfg] t 3]

Reference:

    Fehler-Verarbeitung

fange _vielleichtAusgabe


HC / Bedingte Ausführung / _vielleichtAusgabe

_vielleichtAusgabe

HC [image] Bedingte Ausführung [image] _vielleichtAusgabe
liesFehler Schleifen

_vielleichtAusgabe Wert (besondere Form)

funktioniert wie "gibAus", außer, dass der Ausdruck, der den Eingabewert liefert, möglicherweise keinen Wert ausgibt, in welchem Fall die Wirkung wie stop ist. Dies ist gedacht für Kontroll-Struktur-Definitionen, für Fälle, in denen Sie nicht wissen, ob ein Ausdruck einen Wert produziert oder nicht.

Beispiel:

to invoke :function [:inputs] 2
    _vielleichtAusgabe wendeAn :function :inputs
end

(invoke "schreibe "a "b "c)		;a b c
schreibe (invoke "wort "a "b "c)		;abc

Dies ist eine Alternative zu runResult. Es ist schnell und einfach zu verwenden, bei dem Nachteil, eine Ausnahme von Logo's Auswertungsregeln zu sein. (Normalerweise sollte es ein Fehler sein, wenn der Ausdruck, von dem angenommen wird, dass er eine Eingabe zu Verfügung stellt, keinen Wert liefert.)

Example:

  • _Makro

Reference:

    _Makro

liesFehler Schleifen


HC / Schleifen

Schleifen

HC [image] Schleifen
_vielleichtAusgabe wiederhole

Schleifen

...sind spezielle Kontroll-Strukturen, mit deren Hilfe man Befehlslisten wiederholt ausführen lassen kann.

In diesem Kapitel werden auch Befehle zum Unterbrechen und Fortsetzen von Schleifen beschrieben.

Schleifen

  • wiederhole
  • WiederholZahl
  • fürImmer
  • für
  • solange
  • bis
  • tue_solang
  • tue_bis
  • unterbrich
  • weiterMitSchleife

References:

    GanzzahlenFolge, Release Notes für Version 4.685, Versions-Informationen für Version 4.7, Zahlbox, _setzeElement, _setzeErstes, _setzeNächstes

_vielleichtAusgabe wiederhole


HC / Schleifen / wiederhole

wiederhole

HC [image] Schleifen [image] wiederhole
Schleifen WiederholZahl

wiederhole wieOft Befehlsliste

Kommando. Führt die Befehlsliste wieOft Male wiederholt aus.

Beispiel:

wiederhole 4
[	vorwärts 100
    rechts 90
    schreibe repCount
]

Es sollte ein Quadrat zeichnen sowie in die Konsole schreiben:

    1
    2
    3
    4

Examples:

  • öffneZumSchreibenBinär
  • TesselationKontour
  • spieleWaveSchnell
  • weiterMitSchleife
  • setzeIgelFormen
  • setzePunktgröße
  • MidiGeräteInfo
  • setzeSchreiber
  • MandelIterate
  • setzePunktXYZ
  • WiederholZahl
  • BitmapGrößeX
  • BitmapGrößeY
  • setzePunktXY
  • zähleThreads
  • loadpalette
  • rolleRechts
  • IgelFormen
  • rolleLinks
  • unterbrich
  • führeAus
  • vorwärts
  • Element
  • Vieleck
  • _Makro
  • Grafik
  • runter
  • xMinus
  • Faser
  • xPlus
  • rauf
  • RGBA
  • TSHA

References:

    _Makro(5), WiederholZahl(3), Faser(2), MandelIterate(2), Vieleck(2), spieleWaveSchnell(2), zähleThreads(2), BitmapGrößeX, BitmapGrößeY, Element, Grafik, IgelFormen, MidiGeräteInfo, RGBA, Release, TSHA, TesselationKontour, führeAus, loadpalette, rauf, rolleLinks, rolleRechts, runter, setzeIgelFormen, setzePunktXY, setzePunktXYZ, setzePunktgröße, setzeSchreiber, solange, unterbrich, vorwärts, weiterMitSchleife, xMinus, xPlus, öffneZumSchreibenBinär

Schleifen WiederholZahl


HC / Schleifen / WiederholZahl

WiederholZahl

HC [image] Schleifen [image] WiederholZahl
wiederhole fürImmer

WiederholZahl

Ausgabe ist der Wiederholungs-Zähler des innersten momentanen wiederhole, von 1 startend. Wenn kein wiederhole aktiv ist, ist die Ausgabe 0.

Beispiel:

zeige repCount	;0
wiederhole 4
[	schreibe repCount	;1 2 3 4
]
zeige repCount	;0

Example:

  • Faser

References:

    Faser, weiterMitSchleife

wiederhole fürImmer


HC / Schleifen / fürImmer

fürImmer

HC [image] Schleifen [image] fürImmer
WiederholZahl für

fürImmer Befehlsliste

Kommando. Führt die Befehlsliste wiederholt aus, unendlich oft.

Beispiel:
dauernd
[	schreibe repcount
]


HC / Schleifen / für

für

HC [image] Schleifen [image] für
fürImmer solange

für forcontrol Befehlsliste

Kommando. Die erste Eingabe muss eine drei oder vier Elemente enthaltende Liste sein:

(1) ein Wort, das als der Name einer Lokal Variablen benutzt wird;

(2) ein Wort oder eine Liste, die von führeAus ausgewertet wird, um eine Zahl zu bestimmen, den Start-Wert der Variablen;

(3) ein Wort oder eine Liste, die ausgewertet wird, um eine Zahl zu bestimmen, den Grenzwert der Variablen;

(4) ein optionales Wort oder eine Liste, was ausgewertet wird, um die Schrittgröße zu bestimmen. Wenn das vierte Element fehlt, wird die Schrittgröße 1 oder -1, je nachdem, ob der Grenzwert größer oder kleiner als der Startwert ist.

Die zweite Eingabe ist eine Befehlsliste.

Die Wirkung von "für" ist, die Befehlsliste immer wieder auszuführen, wobei der Laufvariablen (diejenige, die als erstes Element der forcontrol-Liste angegeben wurde) jedes Mal ein neuen Wert zugewiesen wird. Zuerst wird der Start-Wert der Laufvariablen zugewiesen. Dann wird der Wert mit dem Grenzwert verglichen. "für" ist fertig, wenn das Vorzeichen von (aktuell - Grenze) das gleiche wie das Vorzeichen der Schrittgröße ist. (Wenn für keine explizite Einzelschritt Größe gesorgt wird, wird die Befehlsliste immer mindestens einmal ausgeführt. Eine explizite Schrittgröße kann zu einer Nulloperation führen, z. B., FÜR [i 1 0 1]...) Sonst wird die Befehlsliste ausgeführt, dann wird der Schritt zum aktuellen Wert der Laufvariablen addiert und "für" kehrt zum Vergleichsschritt zurück.

Beispiele:

für [i 2 7 1.5] [schreibe :i]
;2
;3.5
;5
;6.5

für [i [kosinus 0] 3+1][schreibe i]
;1
;2
;3
;4

Examples:

  • Versions-Informationen für Version 4.7
  • Berkeley Logo-Anwenderdokumentation
  • setzeOrtInKugelkoordinaten
  • setzeLogoHilfeVerzeichnis
  • Oberflächenspalte
  • weiterMitSchleife
  • Oberflächenstart
  • setzeZylinderOrt
  • Oberflächenende
  • orthographisch
  • setzeSchreiber
  • TiefpaßFilter2
  • speichereBild
  • TiefpaßFilter
  • Oberfläche
  • unterbrich
  • VideoFrame
  • VideoStart
  • VideoEnde
  • ladeBild
  • setzeXYZ
  • Struktur

References:

    Release Notes für Version 4.685(27), ladeBild(13), speichereBild(12), Fenster-Stile(9), Vorlagen-basierte Iteration(6), Berkeley Logo-Anwenderdokumentation(5), Release Notes für Version 4.64(5), Versions-Informationen für Version 4.7(5), _Makro(5), kaskadiere(5), zu(5), Release Notes für Version 4.67(4), crossmap(4), orthographisch(4), setzeOrtInKugelkoordinaten(4), setzeZylinderOrt(4), Filter(3), Numerische Operationen(3), Release(3), Release Notes für Version 4.65(3), Starten und Verlassen von Logo(3), TextControl(3), Tokenisierung(3), setzeXYZ(3), Über Komplexität(3), öffneZumAktualisieren(3), öffneZumAktualisierenBinär(3), Arbeitsbereichs-Abfragen(2), Arithmetik(2), Diagramm(2), Ding(2), Direkte Grafik(2), Dynamische Bibliotheken(2), Einzelschritt(2), Fehler-Verarbeitung(2), Ganzzahl(2), Knoten(2), MandelIterate(2), ModelviewMatrix(2), Oberfläche(2), Oberflächenende(2), Oberflächenspalte(2), Oberflächenstart(2), Projektions-Matrix(2), RGBA(2), Release Notes für Version 4.686(2), Release Notes für Version 4.689(2), Standart-Ereignis-Behandler(2), Struktur(2), Tastenwert(2), TextAusrichtung(2), TiefpaßFilter(2), TiefpaßFilter2(2), VideoEnde(2), VideoFrame(2), VideoStart(2), VieleckStart(2), _vielleichtAusgabe(2), bearbeite(2), betreteGrafik(2), erbe(2), fülle(2), fürAlle(2), lokal(2), makeTree(2), makeTreeFromBody(2), setzeNamensraum(2), setzePunktXY(2), setzePunktXYZ(2), setzeSchreiber(2), setzeSchriftausrichtung(2), setzeTextfarbe(2), speichereSchirmVektoriell(2), unterbrich(2), verlasseGrafik(2), weiterMitSchleife(2), wirf(2), zumGestellDazu(2), 16BitZahlen, ASCII, Arithmetische Mutatoren, BitmapGrößeX, BitmapGrößeY, BitmapPunkt, BitmapSetzePunkt, DateiAuswahl, Einfachpuffer, Element, ElementeAb, Faser, Füllfarbe, GanzzahlBoxen, Ganzzahlen, Geräusche, GrafikEnde, Grafiken, GraphOnMouseLeftDown, GroßKleinEgalP, Igel, ListControls, MillionenBefehleProSekunde, Release Notes für Version 4.672, Release Notes für Version 4.68, Release Notes für Version 4.688, Schattenfarbe, Schiebe-Regler, Schreibstift, Systemaufruf, TSHA, Tabelle, Tesselation, TesselationStart, TextPufferInWort, TextSchriftgröße, Textmodus, Variablen-Definition, VariablenNamen, Versions-Informationen, Vieleck, WortUnterCursor, Zahlbox, Zahlboxen, ZeichenUnterCursor, ausSchlange, beendeteMidiAusgabeströme, beiAktiviertemListenControlElement, beiAusgewähltemListenControlElement, beiAuswahlboxAuswahl, beiDoppeltgeklickterListenbox, beiFensterZeichen, beiGedrückterTaste, beiGedrückterTasteInAuswahlbox, beiGedrückterTasteInFenster, beiGedrückterTasteInGraph, beiGedrückterTasteInKombiBox, beiGedrückterTasteInListenControl, beiGedrückterTasteInListenbox, beiGedrückterTasteInTextbox, beiGeklickterListencontrolSpalte, beiGraphMausBewegung, beiGraphMausLinksDoppelKlick, beiGraphMausLinksLosgelassen, beiGraphMausMitteDoppelKlick, beiGraphMausMitteLosgelassen, beiGraphMausRechtsDoppelKlick, beiGraphZeichen, beiKombiBoxAuswahl, beiKombiBoxEingabe, beiKombiBoxZeichen, beiKombiBoxÄnderung, beiLinksDoppeltGeklickterTextmaus, beiLinksDoppeltgeklickerMaus, beiLinksGeklickterGraphMaus, beiLinksGeklickterTextmaus, beiLinksLosgelasserMaus, beiListenboxAuswahl, beiListenboxZeichen, beiLosgelassenerTaste, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInFenster, beiLosgelassenerTasteInGraph, beiLosgelassenerTasteInKombiBox, beiLosgelassenerTasteInListenControl, beiLosgelassenerTasteInListenbox, beiLosgelassenerTasteInTextbox, beiMausBewegung, beiMitteDoppeltgeklickerMaus, beiMitteDoppeltgeklickterTextmaus, beiMitteGeklickterGraphMaus, beiMitteGeklickterMaus, beiMitteGeklickterTextmaus, beiMitteLosgelasserMaus, beiRechtsDoppeltgeklickerMaus, beiRechtsDoppeltgeklickterTextmaus, beiRechtsGeklickterGraphMaus, beiRechtsGeklickterMaus, beiRechtsGeklickterTextmaus, beiRechtsLosgelasserMaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, beiTextMausbewegung, beiTextboxEingabe, beiTextboxZeichen, beiTextboxÄnderung, beiZeichen, beiZeichenInAuswahlbox, beiZeichenInListenControl, buglist für Version 4.65, closeall, deckenamenauf, edall, edn, edns, edpl, edpls, edps, erneuereGraph, erpl, finde, formatiere, geteilterBildschirm, hex, invertiere, klammere, kopiereDefinition, ladeGraphText, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesWort, listeRGB, listeRGBA, löscheTexturen, nichteinzelschritt, oder, perspektivisch, poall, pon, pons, popl, popls, pops, reduziere, sei, setReader, setzeFPUStatusFlags, setzeFenstersizer, setzeGraphErneuern, setzeGroßKleinEgal, setzeLogoHilfeVerzeichnis, setzeLogoSprache, setzeMaterialDiffus, setzeMaterialEmission, setzeMaterialSpecular, setzeMaterialUmgebung, setzeNebeldichte, setzeOrtXYZ, setzePunkt, setzeSchriftname, setzeTesselationRegeln, setzeTiefentestFunktion, setzeZ, speichereGraph, speichereGraphText, spieleWaveSchnell, stepall, teste, und, verfolge, verfolgealle, vergißAlle, vergißProzeduren, vergißTabellen, vergißVariablen, versteckealle, versteckename, verteileMeldungen, vorherP, waituS, warte, wendeAn, wenn, zeichneGrafik, zweidimensional, zähle, Überprüfung, überprüfe, übertrage

fürImmer solange


HC / Schleifen / solange

solange

HC [image] Schleifen [image] solange
für bis

solange wfAusdruck Befehlsliste

Kommando. Die "Befehlsliste" wird immer wieder ausgewertet, solange der ausgewertete "wfAusdruck" wahr bleibt. "solange" Bewertet die erste Eingabe als zuerst, daher kann die "Befehlsliste" möglicherweise auch kein einziges Mal ausgeführt werden. Der "wfAusdruck" muss eine Ausdrucksliste sein, deren Wert, wenn er ausgewertet wird, entweder wahr oder falsch ist.

"solange" ist gut, wenn Sie vor der Schleife nicht wissen, wie oft die Schleife ausgeführt werden soll, aber es ist ein bisschen langsamer ist als wiederhole.

Beispiele:

a=Ganzzahl 0  solange [a<1000000] [a+=1]  schreibe a		;1000000
solange [nicht key?][schreibe repcount]

Examples:

  • zeichneBitmapSchnell
  • liesListeFlachZeile
  • öffneZumLesenBinär
  • weiterMitSchleife
  • liesRoheZeile
  • öffneZumLesen
  • beendeteTöne
  • unterbrich

References:

    fange(2), DynamischeBibliothek, beendeteTöne, bis, fülle, kaskadiere, liesListeFlachZeile, liesRoheZeile, setzePunktXY, setzePunktXYZ, tue_bis, tue_solang, unterbrich, weiterMitSchleife, zeichneBitmapSchnell, zumGestellDazu, öffneZumLesen, öffneZumLesenBinär

für bis


HC / Schleifen / bis

bis

HC [image] Schleifen [image] bis
solange tue_solang

bis wfAusdruck Befehlsliste

Kommando. Die "Befehlsliste" wird immer wieder ausgewertet, solange der bewertete "wfAusdruck" falsch bleibt. "bis" bewertet die erste Eingabe zuerst, daher kann die "Befehlsliste" möglicherweise auch nie ausgeführt werden. Der "wfAusdruck" muss eine Ausdrucksliste sein, deren Wert, wenn es ausgewertet wird, entweder wahr oder falsch sein darf.

Beispiele:

bis [wahr][schreibe repcount]		;does nothing
bis [key?][schreibe repcount]		;prints numbers bis a key is pressed

Examples:

  • weiterMitSchleife
  • unterbrich

References:

    geheZu(3), ohneErstes(3), ohneLetztes(3), hängeAn(2), übertrage(2), Auswahlbox, Einzelschritt, Elemente, ElementeAb, EllipsenBogen, Fenster, GrafikAnfang, GrafikEnde, Grafiken, Irrationale Zahlen, Release Notes für Version 4.69, Schatten, TasteP, TextPufferInWort, Versions-Informationen für Version 4.7, Vorlagen-basierte Iteration, ZahlenFolge, Zylinder, entferneDuplikate, inSchlange, liesMehrereZeichen, liesZeichen, mdarray, oder, reduziere, reelleZahlenFolge, setzeLogoSprache, speichereSchirm, spieleWaveSchnell, tippe, und, unterbrich, vornhin, weiterMitSchleife, zu, zufällig

solange tue_solang


HC / Schleifen / tue_solang

tue_solang

HC [image] Schleifen [image] tue_solang
bis tue_bis

tue_solang Befehlsliste wfAusdruck

Kommando. Die "Befehlsliste" wird immer wieder ausgewertet, solange der ausgewertete "wfAusdruck" falsch bleibt. Bewertet die erste Eingabe zuerst, daher wird die "Befehlsliste" immer mindestens einmal ausgeführt. Der "wfAusdruck" muss eine Ausdrucksliste sein, deren Wert, wenn er ausgewertet wird, entweder wahr oder falsch ist.

Beispiele:

tue_solang [schreibe repcount][falsch]		;1
tue_solang [schreibe repcount][repcount < 3]		;1 2 3

Examples:

  • weiterMitSchleife
  • unterbrich

References:

    unterbrich, weiterMitSchleife

bis tue_bis


HC / Schleifen / tue_bis

tue_bis

HC [image] Schleifen [image] tue_bis
tue_solang unterbrich

tue_bis Befehlsliste wfAusdruck

Kommando. Die "Befehlsliste" wird immer wieder ausgewertet, solange der ausgewertete "wfAusdruck" wahr bleibt. Bewertet die erste Eingabe zuerst, daher wird die "Befehlsliste" immer mindestens einmal ausgeführt. Der "wfAusdruck" muss eine Ausdrucksliste sein, deren Wert, wenn er ausgewertet wird, entweder wahr oder falsch ist.

Beispiele:

tue_bis [schreibe repcount][repcount > 2]		;1 2 3
tue_bis [schreibe repcount][key?]

Examples:

  • weiterMitSchleife
  • unterbrich

References:

    unterbrich, weiterMitSchleife

tue_solang unterbrich


HC / Schleifen / unterbrich

unterbrich

HC [image] Schleifen [image] unterbrich
tue_bis weiterMitSchleife

unterbrich

Kommando, das die momentan ausführende Schleife sofort stoppt, und mit der Ausführung hinter der Schleife weitermacht.

Beispiele:

wiederhole 10 [schreibe #  wenn #==5 [unterbrich] schreibe "so]
solange [# < 10][schreibe #  wenn #==5 [unterbrich] schreibe "so]
bis [# >= 10][schreibe #  wenn #==5 [unterbrich] schreibe "so]
tue_solang [schreibe #  wenn #==5 [unterbrich] schreibe "so][# < 10]
tue_bis [schreibe #  wenn #==5 [unterbrich] schreibe "so][# >= 10]
für [i 1 10][schreibe i  wenn i==5 [unterbrich] schreibe "so]
für [i 1.1 10.1][schreibe i  wenn i==5.1 [unterbrich] schreibe "so]
fürAlle [1 2 3 4 5 6 7 8 9 10][schreibe #  wenn #==5 [unterbrich] schreibe "so]

References:

    Release Notes für Version 4.685(2), Grafik, Oberfläche, Tesselation, Vieleck

tue_bis weiterMitSchleife


HC / Schleifen / weiterMitSchleife

weiterMitSchleife

HC [image] Schleifen [image] weiterMitSchleife
unterbrich Variablen-Definition

weiterMitSchleife

Kommando, das mit der momentan ausführenden Schleife am Anfang des Schleifenkörpers fortfährt und dabei die WiederholZahl um eins erhöht.

Beispiele:

wiederhole 10 [schreibe #  wenn #==5 [weiterMitSchleife] schreibe "so]
solange [# < 10][schreibe #  wenn #==5 [weiterMitSchleife] schreibe "so]
bis [# >= 10][schreibe #  wenn #==5 [weiterMitSchleife] schreibe "so]
tue_solang [schreibe #  wenn #==5 [weiterMitSchleife] schreibe "so][# < 10]
tue_bis [schreibe #  wenn #==5 [weiterMitSchleife] schreibe "so][# >= 10]
für [i 1 10][schreibe i  wenn i==5 [weiterMitSchleife] schreibe "so]
für [i 1.1 10.1][schreibe i  wenn i==5.1 [weiterMitSchleife] schreibe "so]
fürAlle [1 2 3 4 5 6 7 8 9 10][schreibe #  wenn #==5 [weiterMitSchleife] schreibe "so]

Reference:

    Release Notes für Version 4.685

unterbrich Variablen-Definition


HC / Variablen-Definition

Variablen-Definition

HC [image] Variablen-Definition
weiterMitSchleife setze

Variablen-Definition

...ist eine Methode, Dinge in Kisten zu packen, die Namen haben. Wenn man nicht gerade komplett funktional programmieren möchte, so ist dies eine übliche Strategie, Dinge für spätere Verwendung zu speichern.

Variablen-Definition

  • setze
  • lokal
  • setzelokal
  • Ding
  • name


HC / Variablen-Definition / setze

setze

HC [image] Variablen-Definition [image] setze
Variablen-Definition lokal

setze Varname Wert
VarName=value

Kommando. Weist den Wert "Wert" der Variablen namens "Varname" zu, der ein Wort sein muß. Die Groß-/Kleinschreibung wird bei Variablennamen nur dann beachtet, wenn GroßKleinEgal? falsch ausgibt. Wenn es schon eine Variable mit demselben Namen gibt, wird der Wert dieser Variablen geändert. Wenn nicht, wird eine neue Variable im aktuellen Geltungsbereich erstellt.

Siehe auch "Geltungsbereich der Variablen".

Beispiele:

setze "a 1234
:a		;1234  ;-)
a=2345
a		;2345  ;-)
a=[Hallo World!]
schreibe a		;Hallo World!

See also:

  • Tokenisierung

Examples:

  • Versions-Informationen für Version 4.7
  • SystemaufrufAbspalten
  • führeAusMitAusgabe
  • setzeStiftfarbe
  • VariablenNameP
  • listeProzedur
  • macroexpand
  • speichere
  • _Makro
  • poall
  • pons

References:

    _Makro(7), SystemaufrufAbspalten(3), pon(3), Release Notes für Version 4.64(2), Versions-Informationen für Version 4.7(2), macroexpand(2), pons(2), setzelokal(2), Fenster-Stile, Geltungsbereich der Variablen, Release Notes für Version 4.65, Release Notes für Version 4.67, Release Notes für Version 4.68, Tokenisierung, VariablenNameP, führeAusMitAusgabe, kopiereDefinition, listeProzedur, lokal, name, poall, setzeStiftfarbe, speichere, verfolge, zumGestellDazu

Variablen-Definition lokal


HC / Variablen-Definition / lokal

lokal

HC [image] Variablen-Definition [image] lokal
setze setzelokal

lokal VarName
lokal VarNamenListe
(lokal VarName1 VarName2...)

Kommando. Akzeptiert als Eingaben eins oder mehr Wörter, oder ein Liste von Wörtern. Eine Variable wird für jedes dieser Wörter erstellt, mit dem Wort als ihr Name. Die Variablen sind lokal zu der gegenwärtig laufenden Prozedur. Logo-Variable folgen dynamischen Geltungsbereichsregeln, sofern die Prozeduren mit "zu" oder "to" definiert wurden; eine Variable, die lokal zu einer Prozedur ist, ist verfügbar für jede von dieser Prozedur aufgerufene Unterprozedur. Die von "lokal" erstellte Variablen haben keinen Anfangswert (sie sind "ungebunden"); ihnen muss ein Wert zugewiesen werden (z. B., mit "setze"), bevor die Prozedur versucht, ihren Wert zu lesen.

Beispiele:

zu proc
    lokal [a b c]
    a=1234
    b=[Hallo World!]
    c={1 2 3}
    (schreibe a b c)
ende
;proc defined
proc		;1234 Hallo World! {1 2 3}
a		; I don't know how  to a
b		; I don't know how  to b
c		; I don't know how  to c

Examples:

  • rufeDynamischeBibliothekAuf
  • DynamischeBibliothek
  • führeAusMitAusgabe
  • öffneZumLesenBinär
  • addiereFarbenRest
  • spieleWaveSchnell
  • addiereFarben
  • Einzelschritt
  • macroexpand
  • TextPuffer
  • speichere
  • _Makro
  • sei

References:

    Einzelschritt(4), _Makro(4), Geltungsbereich der Variablen(3), setzelokal(3), macroexpand(2), rufeDynamischeBibliothekAuf(2), spieleWaveSchnell(2), DynamischeBibliothek, Fehler-Verarbeitung, Fenster, TextPuffer, addiereFarben, addiereFarbenRest, führeAusMitAusgabe, für, sei, speichere, teste, öffneZumLesenBinär

setze setzelokal


HC / Variablen-Definition / setzelokal

setzelokal

HC [image] Variablen-Definition [image] setzelokal
lokal Ding

setzelokal Varname Wert (Bibliotheksprozedur)

Kommando. Macht die "Varname" genannte Variable lokal wie "lokal", und weist ihm den bestimmten Wert "Wert" wie mit "setze" zu.

Beispiel:

to proc
    localmake "a 1234
    schreibe a
end
;proc defined
proc		;1234
a		; I don't know how  to a

Ich glaube, es ist besser, die Deklaration von der Initialisierung zu trennen und eher "lokal" und "setze" zu verwenden als "setzelokal".

Daher soll "setzelokal" auch nur eine Bibliotheksprozedur bleiben.


HC / Variablen-Definition / Ding

Ding

HC [image] Variablen-Definition [image] Ding
setzelokal name

Ding Varname
:quoted_varname

Ausgabe ist der Wert der Variablen, deren Name die Eingabe ist. Wenn es mehr als eine solche Variable gibt, wird die innerste lokale Variable jenes Namens gewählt. Die Doppelpunktnotation ist ein Abkürzung, nicht für "Ding", sondern für die Kombination

    Ding "
so daß
    :bla
eigentlich bedeutet:
    Ding "bla
Auch die Doppelpunkte können in aUCBLogo in den allermeisten Fällen weggelassen werden, da sie intern beim Klammern erkannt werden.

Beispiele:

a=1234
Ding "a		;1234  ;-)	here Wert "  is nicht really neccessary.
ab=[Hallo World!]
Ding Wort "a "b		;[Hallo World!] ;-)
;dies zweite Beispiel demonstriert die Ausdruckskraft von Ding!

References:

    Element(7), Elemente(4), entferneElement(3), setzeElement(3), setzeElemente(3), 16BitZahlP(2), 8BitZahlP(2), BitElement(2), ListeP(2), ReiheP(2), WortP(2), ZahlP(2), ZeichenP(2), _setzeElement(2), dreheum(2), entferne(2), entferneDuplikate(2), leerP(2), ohneErstes(2), ohneLetztes(2), positive8BitZahlP(2), renderLogoAsHTML(2), erstes, letztes, renderLogoFileAsHTML, setzeBenutzer, zähle

setzelokal name


HC / Variablen-Definition / name

name

HC [image] Variablen-Definition [image] name
Ding Prozedur-Definition

name Wert Varname (Bibliotheksprozedur)

Kommando. Gleiche Funktion wie "setze", aber mit vertauschten Eingaben.

Beispiel:

name 1234 "a
a		;1234  ;-)

Ich glaube, ein Zuweisungs-Grundwort ist genug, daher lasse ich "name" eine Bibliotheksprozedur.

Examples:

  • fügeSpalteInListenControlEin
  • Midi Kontroll-Tabelle
  • Midi Tabelle
  • macroexpand
  • _Makro

References:

    _Makro(6), GanzzahlBox(5), Balken(4), KombiBox(4), Schieberegler(4), Vorlagen-basierte Iteration(4), GrundwortP(3), MakroP(3), NameInTabelleP(3), ProzedurP(3), TextControl(3), VariablenNameP(3), definiertP(3), liesUmgebung(3), macroexpand(3), Diagramm(2), Starten und Verlassen von Logo(2), Tokenisierung(2), Zahlbox(2), fügeSpalteInListenControlEin(2), setzeUmgebung(2), Auswahlbox, Ding, Fenster-Stile, Hilfe, Leser, ListControl, Listenbox, LogoVersion, Midi Kontroll-Tabelle, Midi Tabelle, Namensraum, Parameteranzahl, Protokolliere, Release Notes für Version 4.64, Schreiber, VideoStart, ausSchlange, für, inListe, liesBenutzer, liesFehler, liesPortIdName, lokal, reduziere, rufeDynamischeBibliothekAuf, setzeAuswahlboxSchriftname, setzeKombiBoxSchriftname, setzeListenControlSchriftname, setzeListenboxSchriftname

Ding Prozedur-Definition


HC / Prozedur-Definition

Prozedur-Definition

HC [image] Prozedur-Definition
name zu

Prozedur-Definition

...hilft in der Strukturierten Programmierung, Gruppen von Anweisungen zusammenzufassen, die mit Platzhaltern definiert werden können und mit Argumenten als Parameter aufgerufen werden können.

Prozedur-Definition

  • zu
  • sei
  • kopiereDefinition
  • def
  • ProzedurText
  • Volltext

Reference:

    Versions-Informationen für Version 4.7

name zu


HC / Prozedur-Definition / zu

zu

HC [image] Prozedur-Definition [image] zu
Prozedur-Definition sei

zu Prozedurname :Eingabe1 :Eingabe2... (besondere Form)

Kommando. Bereitet Logo darauf vor, eine Prozeduredefiniton anzunehmen. Die Prozedur wird "Prozedurename" heißen und es darf noch kein Grundwort mit demselben Namen geben. Die Eingaben werden "Eingabe1" etc. gennant. Jede Anzahl an Eingaben ist erlaubt, einschließlich keiner. Bei Namen von Prozeduren und Eingaben wird normalerweise die Groß-/Kleinschreibung nicht beachtet, außer sie wurde explizit eingeschaltet mittels:

    setztGroßKleinEgal wahr
Wie keine andere Logo-Prozedur nimmt "zu" als seine Argumente die tatsächlichen Worte, die in die Befehlszeile getippt wurden, als wären sie alle mit Anführungszeichen versehen, anstatt die Ergebnisse der ausgewerteten Ausdrücke als Eingaben zu liefern. (Das ist, was "besondere Form" heißt.)

Diese Version von Logo erlaubt eine variable Anzahl von Eingaben an eine Prozedur. Jede Prozedur hat eine minimale, normale und naximale Anzahl von Eingaben. (Letzter kann unendlich sein.)

Die minimale Anzahl von Eingaben ist die Anzahl von erforderlichen Eingaben, welche zuerst angegebnen werden müssen. Eine notwendige Eingabe ist durch die Notation

:Eingabename

gekennzeichnet.

Beispiele:

zu gehen
    vorwärts 100
Ende

zu schreibabc :a :b :c
    (schreibe :a :b :c)
Ende

Als Test können Sie eintippen: "gehen", was den Igel 100 Schritte vorwärts bewegen wird. Wenn Sie tippen "schreibabc 1 2 3", wird schreibabc aufgerufen und wird schreiben 1 2 3.

Nach allen notwendigen Eingaben können Null oder mehrere optionale Eingaben folgen, representiert durch die folgende Notation:
    [:Eingabename Standartwert_Ausdruck]
Wenn die Prozedur aufgerufen wird, und wenn keine tatsächlichen Eingaben angegeben werden für diese optionalen Eingaben, dann werden die Standartwert-Ausdrücke ausgewertet, um Werte für die entsprechenden Eingaben zu setzen. Die Eingaben werden von links nach rechts verarbeitet, daher kann ein Standartwert-Ausdruck auf vorherigen Eingaben basieren.

Beispiel:

zu proc :inlist [:startwert erstes :inlist]
;...ein paar Befehle hier...
Ende

Wenn die Prozedur aufgerufen wird durch
    proc [a b c]
dann wird die Variable inlist den Wert [A B C] haben und die Variable startwert wird den Wert A haben. Wenn die Prozedur aufgerufen wird durch
    (proc [a b c] "x)
dann wildr inlist den Wert [A B C] und startwert den Wert X haben.

Beispiel:

zu geh [:Schritte 100]
    vorwärts :Schritte
Ende

Sie können dann tippen "geh", was "vorwärts 100" bewirken wird, oder Sie könne tippen "(geh 10)", was "vorwärts 10" bewirken wird.

Nach allen erforderlichen und optionalen Eingaben darf es eine einzelne "Rest"-Eingabe geben, representiert durch die folgende Notation:
    [:Eingabename]
Das ist eher eine Rest-Eingabe als eine optionale Eingabe, weil kein Standartausdruck vorhanden ist. Es darf höchstens eine Rest-Eingabe geben. Wenn die Prozedur aufgerufen wird, wird der Wert dieser Eingabe eine Liste sein, die alle tatsächlich angegebenen Eingaben enthält, die nicht für erforderliche oder optionale Eingaben gebraucht werden.

Beispiel:

zu proc :in1 [:in2 "foo] [:in3]
;...ein paar Befehle hier...
end

Wenn diese Prozedur aufgerufen wird durch
    proc "x
dann hat in1 den Wert x, in2 den Wert foo und IN3 hat den Wert [] (die leere Liste). Wenn sie aufgerufen wird durch
    (proc "a "b "c "d)
dann hat in1 den Wert "a, in2 hat den Wert "b und in3 hat den Wert [c d].

Die maximale Anzahl von Eingaben für eine Prozedur ist unendlich, wenn eine Rest-Eingabe gegeben ist; anderenfalls ist sie gleich der Anzahl erforderlicher Eingaben plus der Anzahl an optionalen Eingaben.

Die normale Anzahl von Eingaben für eine Prozedur, was die Anzahl von Eingaben ist, die angenommen werden, wenn der Aufruf nicht in Klammern geschrieben wird, ist normalerweise gleich der minimalen Anzahl. Wenn Sie eine andere normale Anzahl wollen, können Sie sie durch Schreiben dieser Zahl als letzten Wert in der zu-Zeile erreichen:

Beispiel:

zu proc :in1 [:in2 "foo] [:in3] 3
;...ein parr Befehle hier...
end

Diese Prozedur hat ein Minimum von einer Eingabe, eine normale Anzahl von drei Eingaben, und ein unendliches Maximum.

Logo antwortet auf das "zu"-Kommando durch Eintritt in den Prozedur-Definitions-Modus. In UCBLogo gibt es ein Prompt: Dieses Prompt wechselt von "?" nach ">" und welche Befehle auch immer Sie tippen, wird Teil der Definition bis Sie eine Zeile tippen, die nur das Wort Ende enthält.

See also:

  • reelleZahlenFolge
  • GanzzahlenFolge
  • GanzzahlFolge
  • ZahlenFolge

Examples:

  • Versions-Informationen für Version 4.7
  • Vorlagen-basierte Iteration
  • zeichneBitmapSkaliertAuf
  • setzeTesselationRegeln
  • zeichneBitmapSchnell
  • führeAusMitAusgabe
  • setzeGraphErneuern
  • addiereFarbenRest
  • verkleinereStapel
  • Oberflächenstart
  • zeichneBitmapAuf
  • DateiUmbenennen
  • addiereFarben
  • listeProzedur
  • beendeteTöne
  • GrafikAnfang
  • fülleBitmap
  • kaskadiere
  • liesFehler
  • listeTitel
  • Namensraum
  • Oberfläche
  • alleErste
  • reduziere
  • speichere
  • verstecke
  • führeAus
  • Ausgabe
  • _Makro
  • fange
  • lokal
  • Pause
  • poall
  • Halt
  • pops
  • pots
  • wirf

References:

    Versions-Informationen für Version 4.7(14), Release Notes für Version 4.685(12), Fenster-Stile(11), Release Notes für Version 4.65(11), Einführung in die Logo-Programmierung(8), Vorlagen-basierte Iteration(8), zumGestellDazu(8), Release(7), reduziere(7), Fehler-Verarbeitung(6), lokal(5), 16BitZahlen(4), Ganzzahlen(4), GanzzahlenFolge(4), Grafiken(4), Oberfläche(4), Release Notes für Version 4.686(4), _Makro(4), _vielleichtAusgabe(4), für(4), sei(4), tippe(4), wirf(4), GanzzahlFolge(3), Midi Glossary(3), Oberflächenstart(3), Pause(3), Port-Eingabe Und Ausgabe(3), Release Notes für Version 4.64(3), Release Notes für Version 4.672(3), Release Notes für Version 4.689(3), Tesselation(3), TextControl(3), Vieleck(3), ZahlenFolge(3), alleErste(3), fange(3), kaskadiere(3), löscheSchatten(3), reelleZahlen(3), reelleZahlenFolge(3), rufeDynamischeBibliothekAuf(3), setzeNeigung(3), setzeSchreiber(3), setzelokal(3), warte(3), zerstöreGraph(3), öffneMidi(3), Absolute Igel-Bewegung(2), Arithmetik(2), Ausgabe(2), Auswahlbox(2), DateiAuswahl(2), Direkte Grafik(2), Editieren(2), ElementP(2), FensterModus(2), GUI Programmierung(2), Geltungsbereich der Variablen(2), GrafikAnfang(2), GrafikGroß(2), Halt(2), Kommandozeilen-Schalter -nogui(2), MandelIterate(2), Müllsammeln(2), Namensraum(2), Protokolliere(2), Randsprung(2), Relative Igel-Bewegung(2), Release Notes für Version 4.66(2), Release Notes für Version 4.67(2), Release Notes für Version 4.69(2), SchattenAn(2), Schieberegler(2), Systemaufruf(2), TasteP(2), Variablen-Definition(2), VieleckEnde(2), Volltext(2), Zahlbox(2), Zaun(2), _setzeElement(2), _setzeErstes(2), _setzeNächstes(2), _setzeOrt(2), _setzeOrtXYZ(2), bearbeiteDatei(2), beiAktiviertemListenControlElement(2), beiAusgewähltemListenControlElement(2), beiAuswahlboxAuswahl(2), beiDoppeltgeklickterListenbox(2), beiFensterZeichen(2), beiGedrückterTasteInAuswahlbox(2), beiGedrückterTasteInFenster(2), beiGedrückterTasteInKombiBox(2), beiGedrückterTasteInListenControl(2), beiGedrückterTasteInListenbox(2), beiGedrückterTasteInTextbox(2), beiGeklickterListencontrolSpalte(2), beiKombiBoxAuswahl(2), beiKombiBoxEingabe(2), beiKombiBoxZeichen(2), beiKombiBoxÄnderung(2), beiListenboxAuswahl(2), beiListenboxZeichen(2), beiLosgelassenerTasteInAuswahlbox(2), beiLosgelassenerTasteInFenster(2), beiLosgelassenerTasteInKombiBox(2), beiLosgelassenerTasteInListenControl(2), beiLosgelassenerTasteInListenbox(2), beiLosgelassenerTasteInTextbox(2), beiSchiebereglerVerschiebung(2), beiTextboxEingabe(2), beiTextboxZeichen(2), beiTextboxÄnderung(2), beiZeichenInAuswahlbox(2), beiZeichenInListenControl(2), beiÄnderungInReellerZahlbox(2), betreteGrafik(2), buglist für Version 4.65(2), führeAus(2), fülle(2), geheZu(2), geteilterBildschirm(2), hilfesuche(2), holeAuswahl(2), holeAuswahlZahl(2), holeAuswahlmöglichkeiten(2), kopiereDefinition(2), liesFehler(2), liesRoheZeile(2), listeProzedur(2), listeTitel(2), makeTreeFromBody(2), poall(2), pops(2), pots(2), setReader(2), setzeAnkreuzbox(2), setzeAuswahlboxMöglichkeiten(2), setzeAuswahlboxSchriftgröße(2), setzeAuswahlboxSchriftname(2), setzeBalkenBereich(2), setzeFensterSchriftgröße(2), setzeFensterSchriftname(2), setzeGanzzahlBoxBereich(2), setzeGraphErneuern(2), setzeGroßKleinEgal(2), setzeKombiBoxSchriftgröße(2), setzeKombiBoxSchriftname(2), setzeListenControlSchriftgröße(2), setzeListenControlSchriftname(2), setzeListenboxMöglichkeiten(2), setzeListenboxSchriftgröße(2), setzeListenboxSchriftname(2), setzeLogoBibliotheksVerzeichnis(2), setzeLogoComspec(2), setzeNebelModus(2), setzePunkt(2), setzePunktXY(2), setzePunktXYZ(2), setzeRadioknopf(2), setzeReelleZahlboxBereich(2), setzeRollWinkel(2), setzeSchaltknopfZustand(2), setzeSchattenfarbe(2), setzeSchiebereglerBereich(2), setzeStatischerTextSchriftgröße(2), setzeStatischerTextSchriftname(2), setzeTesselationRegeln(2), setzeTextauswahl(2), setzeTextboxCursor(2), setzeTextboxInhalt(2), setzeTextboxSchriftgröße(2), setzeTextboxSchriftname(2), setzeTexturort(2), speichere(2), verfolgealle(2), verkleinereStapel(2), wechsleMidiProgramm(2), xKopieren(2), zeichneBitmapAuf(2), Abstand, AbstandXYZ, Arbeitsbereichs-Fragen, Arithmetische Mutatoren, Beleuchtung, BitmapSetzePunkt, DateiUmbenennen, DateiendeP, Druck-Formatierung, Element, EllipsoidenTeil, FehlerAktion, Fehlersuche, Fenster-Kontrolle, FensterAn, FensterGroß, FensterKlein, FensterVollbild, FloatControlDestroy, Geräusche, Grafik, GroßeZahlSetzGenauigkeit, Igel-Kontrolle, Irrationale Zahlen, KreisStrukturP, Kugel, Kurven-Zeichnen, LogoHilfeVerzeichnis, Löschen, Meldungsbox, MidiAlleGeräuscheAus, MidiAusgabestrom, MidiMeldung, Mitte, NebelAn, Neigung, Numerische Operationen, Oberflächenende, Oberflächenspalte, Orientierung, Parallele Ausführung, Reihe, Release Notes für Version 4.68, Release Notes für Version 4.682, RollWinkel, Schaltknopf, Schatten, Schreibstift- und Hintergrund-Kontolle, SchrägstrichP, SoundsStop, Starten und Verlassen von Logo, StiftAb, StiftHoch, SubStringP, SystemaufrufAbspalten, TesselationEnde, TesselationKontour, TesselationStart, TextControls, TextSchriftgröße, TextboxÜberschreibmodus, Textmodus, Texturierung, Umgebung, UmkehrStift, Versions-Informationen, VerzeichnisAuswahl, VideoStart, VieleckStart, Vollbildmodus, Zeitmessung, Zylinder, achsen, addiereFarben, addiereFarbenRest, aktiviereFenster, aktiviereGraph, aufzeichnen, beendeThread, beendeteTöne, beiGanzzahlBoxÄnderung, beiGeklicktemRadioKnopf, beiGeklicktemSchaltknopf, beiGeklickterAnkreuzbox, beiKnopfdruck, crossmap, dirlg, entferneElement, entferneListenControlElement, erneuereAufrufliste, erneuereVariablenlisteBeiSchritt, führeAusMitAusgabe, fülleBitmap, holeFarbeVomBenutzer, holePasswortVomBenutzer, holeSchriftVomBenutzer, holeTextVomBenutzer, holeZahlVomBenutzer, hängeAn, inRichtungXYZ, konjugiere, konjugieren, lade, ladeGraph, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesWort, löscheSchirm, löscheTexturen, macheBitmapDurchsichtig, nichtAufzeichnen, normalerStift, oder, ohneErste, ohneLetztes, orthographisch, radiere, reset, rolleLinks, rolleRechts, rotatescene, runSecure, schreibeInTextbox, settFensterform, setze, setzeAuge, setzeAuswahlboxAuswahl, setzeAuswahlboxElement, setzeAuswahlboxFarbe, setzeAuswahlboxHintergrundfarbe, setzeAuswahlboxSchriftdicke, setzeAuswahlboxSchriftstil, setzeBalkenFarbe, setzeBalkenHintergrundfarbe, setzeBalkenWert, setzeBenutzer, setzeDiffusesLicht, setzeFehlerAktion, setzeFensterFarbe, setzeFensterHintergundfarbe, setzeFensterSchriftdicke, setzeFensterSchriftstil, setzeFenstersizer, setzeGanzzahlBoxWert, setzeGenSym, setzeIgel, setzeInnereFenstergröße, setzeKombiBoxAuswahl, setzeKombiBoxElement, setzeKombiBoxFarbe, setzeKombiBoxHintergrundfarbe, setzeKombiBoxMöglichkeiten, setzeKombiBoxSchriftdicke, setzeKombiBoxSchriftstil, setzeKombiBoxWert, setzeLeserOrt, setzeListenControl, setzeListenControlElement, setzeListenControlFarbe, setzeListenControlHintergrundfarbe, setzeListenControlSchriftdicke, setzeListenControlSchriftstil, setzeListenControlSpalte, setzeListenControlZeile, setzeListenboxAuswahl, setzeListenboxElement, setzeListenboxFarbe, setzeListenboxHintergrundfarbe, setzeListenboxSchriftdicke, setzeListenboxSchriftstil, setzeLogoEditor, setzeLogoHilfeVerzeichnis, setzeLogoSchriftenVerzeichnis, setzeLogoSprache, setzeLogoTemporäresVerzeichnis, setzeMaterialDiffus, setzeMaterialEmission, setzeMaterialSpecular, setzeMaterialUmgebung, setzeMatrix, setzeNamensraum, setzeNebelBereich, setzeNebeldichte, setzeNebelfarbe, setzeOrientierung, setzeOrt, setzeOrtXYZ, setzeQuetschung, setzeRedefinierbar, setzeReelleZahlboxWert, setzeSchiebereglerWert, setzeSchirmbereich, setzeSchreibTiefenGrenze, setzeSchreiberOrt, setzeSchriftname, setzeSpecularLicht, setzeSpeicherungsGröße, setzeStatischenText, setzeStatischerTextFarbe, setzeStatischerTextHintergrundfarbe, setzeStatischerTextSchriftdicke, setzeStatischerTextSchriftstil, setzeStiftdicke, setzeTextboxEinfügepunktAnsEnde, setzeTextboxFarbe, setzeTextboxHintergrundfarbe, setzeTextboxSchriftdicke, setzeTextboxSchriftstil, setzeTextfarbe, setzeUmgebungslicht, setzeX, setzeXY, setzeXYZ, setzeY, setzeZ, setzeZylinderOrt, sortiereListenControl, speichereGraph, speichereSchirmVektoriell, spieleWave, spieleWaveSchnell, starteMidiAusgabestrom, stoppeMidiAusgabestrom, teile, teste, und, verlasseGrafik, verstecke, versteckeLogoConsolew, waituS, wechsleVerzeichnis, wendeAn, wirfSchatten, xDividieren, xMal, xMinus, xPlus, xRest, zeichneBitmapSchnell, zeichneBitmapSkaliertAuf, zerstöreBalken, zerstöreFenster, zerstöreGanzzahlBox, zerstöreGestell, zerstöreSchieberegler, zerstöreTextbox

Prozedur-Definition sei


HC / Prozedur-Definition / sei

sei

HC [image] Prozedur-Definition [image] sei
zu kopiereDefinition

sei procname :Eingabe1 :Eingabe2 ... (besondere Form)

Kommando. Wie "zu" bereitet es die Definition einer Prozedur vor, aber anders als "zu" wird der Geltungsbereich der Variablen lexikalisch. Auch kann "sei" geschachtelt werden, weitere "sei"-Definitionen innerhalb einer "sei"-Definition ist möglich.

Beispiel:

sei test1 :a :b
    schreibe :a
    schreibe :a+:b
Ende
test1 2 3
;2
;5
sei test2 :a :b
    sei adder :a :b
        ausgabe :a+:b
    Ende
    (schreibe :a :b)
    schreibe adder :a :b
Ende
test2 2 3
;2 3
;5

Zusätzlich ist es möglich, eine mit "sei" definierte Prozedur als Konstruktor für ein Objekt zu verwenden. Um dies zu tun, erzeugen Sie eine Prozedur, die einige lokale Variablen in ihrem Haupt-Körper enthält, und zuszätlich definieren Sie ein paar Unterprozeduren, auch genannt Methoden.

Beispiel:

sei testobj3
    sei myNumber :a
        sei add :b
            wennSonst Zahl? :b
            [	tmp=sum :a :b
            ][	tmp=sum :a :b'a
            ]
            führeAus :expr1
            (tippe "+)
            führeAus :expr2
            Ausgabe myNumber :tmp
        Ende
        lokal [expr1 expr2]
        expr1=[(tippe :a)]
        expr2=[(tippe wennSonst Zahl? :b [:b][:b'a] "= :tmp) (schreibe)]
    Ende
    a=myNumber 2
    b=myNumber 5
    ignoriere (((a'add 3)'add 4)'add (b'add 6))
Ende
testobj3

sollte schreiben:

    2+3=5
    5+4=9
    5+6=11
    9+11=20
Eine Klasse kann Eigenschaften von einer oder mehreren Basisklassen erben durch Verwenden des Kommandos "erbe" innerhalb des Konstruktors.

Alle Methodenfunktionsaufrufe geschehen "virtual", das heißt, wenn eine Klasse eine Methode ADD, und eine abgeleitete Klasse hat auch eine Methode ADD, dann wird die Methode der abgeleiteten Klasse aufgerufen, auch innerhalb von Methoden der Basisklasse. Nicht-virtuelle Aufrufe können explicitly gemacht werden, durch Verwenden des Namensraum-Operators :: wie in C++. Wenn Sie einen Funktionsaufruf :: voranstellen, bedeutet das globaler Namensraum.

Beispiel:

sei testobj
    p=Punkt_ 3 4
    p2=Punkt_ 6 7
    (zeige p'x p'y)
    (zeige p2'x p2'y)
    zeige (p'distance p2)
    m=Matrix_ p p2
    (m'add m)
    m'print
    zeige m'det
    zeige (m'x)'x
    p'hallo
    p'grüße
    p2'hallo
    p2'grüße
    m'hallo
    (m'x)'hallo
Ende

sei Halloer mytype
    sei hallo
        (tippe [Hallo, Ich bin ] mytype "  string [.])
        (schreibe)
    Ende
Ende

sei Grüßer mytype
    sei grüße
        (tippe [Grusse von einem ] mytype [!])
        (schreibe)
    Ende
Ende

sei Punkt_ x y
    erbe Halloer "Punkt_
    erbe Grüßer "Punkt_
    sei distance b
        output sqrt (sqr x-b'x)+(sqr y-b'y)
    Ende
    sei incx
        x=x+1
    Ende
    sei add p
        x=x+p'x
        y=y+p'y
    Ende
    sei print
        ::print Liste x y
    Ende
    sei string
        output Liste x y
    Ende
Ende

sei Matrix_ x y
    erbe Halloer "Matrix_
    sei det
        output x'x*y'y-x'y*y'x
    Ende
    sei add m
        (x'add m'x)
        (y'add m'y)
    Ende
    sei print
        x'print
        y'print
        ::print Point::string
    Ende
    sei string
        output list x'string y'string
    Ende
Ende

sollte schreiben:
    3 4
    6 7
    4.24264
    6 8
    12 14
        [6 8]
        [12 14]

    -12
    6
    Hallo, Ich bin punkt_ 6 8.
    Grusse von einem punkt_!
    Hallo, Ich bin punkt_ 12 14.
    Grusse von einem punkt_!
    Hallo, Ich bin matrix_ 	[6 8]
        [12 14]
    .
    Hallo, Ich bin punkt_ 6 8.

Examples:

  • Versions-Informationen für Version 4.7
  • ladeLokal
  • überprüfe

References:

    Über Komplexität(3), Einführung in die Logo-Programmierung, Geltungsbereich der Variablen, Versions-Informationen für Version 4.7, erbe, lade, ladeLokal, überprüfe

zu kopiereDefinition


HC / Prozedur-Definition / kopiereDefinition

kopiereDefinition

HC [image] Prozedur-Definition [image] kopiereDefinition
sei def

kopiereDefinition neuerName alterName

Kommande. Setzt "neuerName" auf die identische Prozedur zu "alterName". Letztere kann auch ein Grundwort sein. Wenn "neuerName" schon definiert war, ist seine vorherige Definition verloren. Wenn "neuerName" bereits ein Grundwort war, ist die Umdefinierung nicht erlaubt, außer, Sie verwenden:

    setzeUmdefinierbar wahr
Definitionen, die mit kopiereDefinition erzeugt wurden, werden nicht von "speichere" gespeichert; Grundwörter werden nie gespeichert, und benutzerdefinierte Prozeduren von kopiereDefinition erstellt werden versteckt. (Sie können leicht verwirrt sein, wenn Sie pO oder poT einer Prozedur definiert mit kopiereDefinition versuchen, weil ihre Titelzeile den alten Namen enthalten wird. Das ist der Grund, warum sie versteckt werden.)

Beachte: Dialekte von Logo unterscheiden sich in der Reihenfolge der Eingaben an kopiereDefinition. Dieser Dialekt verwendet dieselbe Reihenfolge wie in "setze".

Eine neuer Zusatz, der nicht so einfach zu implementieren war, ist, dass Sie jetzt auch Kopien von "to", "be", "_Macro", "_beMacro" und "end" machen können. Das kann wichtig sein für die Übersetzung in andere Sprachen.

Beispiel:

kopiereDefinition "write "print
write 1234		;1234

kopiereDefinition "def "to
kopiereDefinition "ende "end
def go :steps
    forward :steps
ende

Example:

  • liesBesitzer

Reference:

    liesBesitzer

sei def


HC / Prozedur-Definition / def

def

HC [image] Prozedur-Definition [image] def
kopiereDefinition ProzedurText

def procname Text

Kommando. Definiert ein
def "go [[] [vorwärts 100]]
go
löscheSchirm
def "go [[steps] [vorwärts 300*steps]]		;so go is a "scaled vorwärts"
go .5
go .25
go .125
löscheSchirm
def "go [[[steps 1]] [vorwärts 300*steps]]
go		;moves the igel to the upper border, drawing
löscheSchirm
(go 0.5)		;moves the igel till half the upper border

Examples:

  • kopiereDefinition
  • fürAlle

References:

    kopiereDefinition(2), Tokenisierung, fürAlle

kopiereDefinition ProzedurText


HC / Prozedur-Definition / ProzedurText

ProzedurText

HC [image] Prozedur-Definition [image] ProzedurText
def Volltext

ProzedurText procname

Ausgabe ist der Text der Prozedur "procname" in der von "definiere" erwarteten Form: eine Liste von Listen, die erste davon beschreibt die Eingaben der Prozedur und der Rest sind die Zeilen ihres Körpers. Der Text beinhaltet keine Formatierungsinformationen wie Fortsetzungszeilen und zusätzliche Leerräume.

Beispiel:

hex Stiftfarbe		;FF000000  ;-)
ProzedurText "hex
    [	[num]
    [op formatiereGanzzahl :num 8 16]]
 ;-)

Examples:

  • setzeStatischerTextHintergrundfarbe
  • setzeStatischerTextSchriftdicke
  • setzeStatischerTextSchriftgröße
  • setzeTextboxEinfügepunktAnsEnde
  • setzeStatischerTextSchriftname
  • setzeStatischerTextSchriftstil
  • setzeStatischerTextFarbe
  • zerstöreStatischenText
  • StatischerTextInhalt
  • setzeStatischenText
  • setzeTextboxCursor
  • setzeTextboxInhalt
  • schreibeInTextbox
  • zerstöreTextbox
  • statischerText
  • TextboxCursor
  • zuTextboxDazu
  • Textbox

References:

    Vorlagen-basierte Iteration(4), holeTextVomBenutzer(2), setzeTextboxInhalt(2), Auswahlbox, CheckBoxen, ChoiceBoxes, KombiBox, ListControl, ListControls, Listenbox, Meldungsbox, Schiebe-Regler, StaticTexts, StatischerTextInhalt, TextControl, Textbox, TextboxCursor, _Makro, beiKombiBoxEingabe, fügeSpalteInListenControlEin, holeAuswahl, holeAuswahlZahl, holeAuswahlmöglichkeiten, holeZahlVomBenutzer, schreibeInTextbox, setzeSchriftausrichtung, setzeStatischenText, setzeStatischerTextFarbe, setzeStatischerTextHintergrundfarbe, setzeStatischerTextSchriftdicke, setzeStatischerTextSchriftgröße, setzeStatischerTextSchriftname, setzeStatischerTextSchriftstil, setzeTextboxCursor, setzeTextboxEinfügepunktAnsEnde, statischerText, zerstöreStatischenText, zerstöreTextbox, zuTextboxDazu

def Volltext


HC / Prozedur-Definition / Volltext

Volltext

HC [image] Prozedur-Definition [image] Volltext
ProzedurText Kontroll-Strukturen

Volltext procname

Ausgabe ist eine Darstellung der Prozedur "procname", in der die Formatierungsinformationen bewahrt wurden. Wenn die Prozedur definiert wurde mit "zu", "bearbeite" oder "laden", dann ist die Ausgabe ein Liste von Wörtern. Jedes Wort repräsentiert eine ganze Zeile der Definition in der Form, die von liesWort ausgegeben wird, einschließlich zusätzlichem Leerraum und Fortsetzungszeilen. Das letzte Element der Ausgabe stellt die "Ende"-Zeile dar. Wenn die Prozedur mit "definiere" definiert wurde, dann ist die Ausgabe eine Liste von Listen. Wenn diese Listen geschrieben werden, eine pro Zeile, wird das Ergebnis wie eine Definition mit "zu" aussehen. Anmerkung: die Ausgabe von Volltext ist nicht als Eingabe an "definiere" geeignet!

Beispiel:

hex Stiftfarbe		;FF000000  ;-)
Volltext "hex
    [to hex :num 	op formatiereGanzzahl :num 8 16 end]
 ;-)


HC / Kontroll-Strukturen

Kontroll-Strukturen

HC [image] Kontroll-Strukturen
Volltext Halt

Kontroll-Strukturen

Hier sind verschiedenste Befehle zur Kontrolle über die Ausführungs-Reihenfolge und -Geschwindigkeit erklärt.

Kontroll-Strukturen

  • Halt
  • Ausgabe
  • Ignoriere , Kommentar
  • `
  • warte
  • warteMilliSekunden
  • waituS
  • Pause
  • weiter
  • geheZu
  • Tag
  • führeAus
  • führeAusMitAusgabe
  • runSecure
  • Tschüß
  • führeParallelAus
  • Faser
  • yield
  • überprüfe
  • profil
  • erbe
  • beendeThread

References:

    _Makro(2), Schleifen, führeAusMitAusgabe

Volltext Halt


HC / Kontroll-Strukturen / Halt

Halt

HC [image] Kontroll-Strukturen [image] Halt
Kontroll-Strukturen Ausgabe

Halt

Kommando. Beendet das Laufen der Prozedur, in der es auftaucht. Die Kontrolle wird zu dem Zusammenhang zurückgegeben, in dem diese Prozedur aufgerufen wurde. Die gestoppte Prozedur gibt keinen Wert aus.

Beispiel:

zu t
    dauernd [wenn Taste? [Halt]]
    schreibe [Hallo!]
Ende
;t definiert
t

Wenn Sie eine Taste drücken, wird t anhalten und das "schreibe" will nicht ausgeführt, weil Halt die gerade aktive Prozedur unmittelbar verläßt.

Examples:

  • führeAusMitAusgabe
  • setzeGraphErneuern
  • Pause

References:

    Vorlagen-basierte Iteration(2), Grafik, Oberfläche, Pause, Tesselation, Vieleck, _Makro, führeAusMitAusgabe, setzeGraphErneuern

Kontroll-Strukturen Ausgabe


HC / Kontroll-Strukturen / Ausgabe

Ausgabe

HC [image] Kontroll-Strukturen [image] Ausgabe
Halt Ignoriere

Ausgabe wert

Kommando. Beendet das Laufen der Prozedur, in der es erscheint. Die Prozedur gibt den Wert "Wert" zu dem Zusammenhang aus, in dem sie aufgerufen wurde. Lassen Sie sich nicht verwirren: Ausgabe selbst ist ein Kommando, aber die Prozedur, die Ausgabe aufruft, ist eine Operation.

Beispiel:

zu t
    schreibe 1
    Ausgabe [Hallo!]
    schreibe 2
Ende
;t definiert
zeige t

will schreibe:

1
[Hallo!]

Examples:

  • Vorlagen-basierte Iteration
  • führeAusMitAusgabe
  • addiereFarbenRest
  • addiereFarben
  • liesRoheZeile
  • reduziere
  • sei

References:

    Vorlagen-basierte Iteration(7), Volltext(5), Element(4), bildeab(4), führeAusMitAusgabe(4), kaskadiere(4), liesWort(4), reduziere(4), Systemaufruf(3), Vorzeichen(3), bildeAbSatz(3), erstes(3), letztes(3), ohneErstes(3), ohneLetztes(3), verbinde(3), zähle(3), Anführungszeichen(2), ElementP(2), ElementeAb(2), Fehler-Verarbeitung(2), Filter(2), Grafik(2), GrafikEnde(2), MidiGeräteInfo(2), SchrägstrichP(2), SubStringP(2), WiederholZahl(2), _Makro(2), _gleich(2), `(2), addiereFarben(2), addiereFarbenRest(2), alleErste(2), crossmap(2), formatiereGanzzahl(2), klammereFürAusführung(2), liesBenutzer(2), ohneErste(2), sei(2), zähleThreads(2), 16BitZahl, 16BitZahlP, 16BitZahlen, 8BitZahl, 8BitZahlP, ASCII, ASCIIP, ASCIIroh, Abstand, AbstandXYZ, Aufrufliste, Bedingung, Bildschirmgröße, BitElement, BitNicht, BitOder, BitUnd, BitXOder, BitmapGrößeX, BitmapGrößeY, BitmapKopieren, BitmapPunkt, BogenKosinus, BogenSinus, BogenTangens, CSymbolP, Cursor, DateiAuswahl, DateiGröße, DateiP, DateiZeit, Dateien, Diagramm, Differenz, Ding, DynamischeBibliothek, Elemente, Faktorisiere, Fakultät, Fall, FehlerAktion, Füllfarbe, GGT, Ganzzahl, GanzzahlBox, GanzzahlFolge, GanzzahlP, Ganzzahlen, GanzzahlenFolge, GroßKleinEgalP, GroßeZahl, GrundwortP, Grundwörter, GrößeVon, HexadezimalzifferP, Igel, IgelFormen, Inhalt, InterpunktionP, KammSort, KammSortAufDerStelle, Knoten, KodiereSchrägstrich, Kommunikation, KontrollzeichenP, Kosinus, KreisStrukturP, Kreuzprodukt, Kurs, LeerraumP, Leser, LeserOrt, Liste, ListeP, LogoBibliotheksVerzeichnis, LogoComspec, LogoEditor, LogoHilfeVerzeichnis, LogoKonstanten, LogoSchriftenVerzeichnis, LogoSprache, LogoTemporäresVerzeichnis, LogoVersion, MakroP, MandelIterate, Mausort, Maustasten, MaximumsNorm, MillionenBefehleProSekunde, NameInTabelleP, Namensraum, Neigung, Norm, Oberfläche, Orientierung, Ort, OrtXYZ, Parameteranzahl, Port-Eingabe Und Ausgabe, PortEingang, Potenz, Produkt, ProzedurP, ProzedurText, Prozeduren, Punkt, Quadratwurzel, Quetschung, RGB, RGBA, Realteil, Reihe, ReiheP, RestDerDivision, RollWinkel, Rotiere, Satz, Schattenfarbe, SchirmFarbe, Schreiber, SchreiberOrt, Schreibstift, Sender, Sinus, SoundsFinished, SpeicherungGröße, StiftAbP, StiftModus, Stiftfarbe, Stiftgröße, Struktur, Summe, TSH, TSHA, Tabelle, Tangens, TeileMitRest, Tesselation, TextAusrichtung, TextMausOrt, TextMausX, TextMausY, TextPuffer, TextPufferInWort, TextSchriftart, TextSchriftdicke, Textur, Threads, TiefpaßFilter, TiefpaßFilter2, TypVon, VariablenNameP, VariablenNamen, Verhältnis, Versions-Informationen für Version 4.7, VerzeichnisAuswahl, VerzeichnisP, Vieleck, Wort, WortP, WortUnterCursor, ZahlP, ZahlenFolge, Zeichen, ZeichenP, ZeichenUnterCursor, Zeit, ZeitFein, ZeitMikroAuflösung, ZeitMilli, ZeitgeberFrequenz, ZifferP, ZufallsZahl, abs, alphabetischP, alphanumerischP, aufzeichnenP, ausSchlange, beendeteTöne, definiertP, dies, dir, dirlg, dreheum, druckbarP, entferne, entferneDuplikate, ersetze, erweitereBackslashes, erzeugeSymbol, exp, fange, finde, float2ratio, formatiere, gleichP, grafischP, großbuchstabig, großbuchstabigP, hex, holeFarbeVomBenutzer, holeListenControlSpalte, holeListenControlWert, holeListenControlZeile, holePasswortVomBenutzer, holeSchriftVomBenutzer, holeTextVomBenutzer, holeZahlVomBenutzer, hängeAn, imaginär, inListe, inListenListe, inRichtung, inRichtungXYZ, invertiere, kalibriereScrolling, kaskadier2, kgv, klammere, kleinbuchstabig, kleinbuchstabigP, kleinstes, komplexP, konjugiere, ladeBild, ladeMitAnzeige, leerP, liesArbeitsVerzeichnis, liesArchitekturName, liesBesitzer, liesBetriebssystemFamilienname, liesBetriebssystemIdName, liesEndiannessName, liesFarbDatenbank, liesFehler, liesListe, liesListeFlachRoh, liesListeFlachZeile, liesPortBit, liesPortIdName, liesProzessId, liesRoheZeile, liesThreadId, liesUmgebungstabelle, liesZeichenErweitert, listeRGB, listeRGBA, listeTSH, listeTSHA, makeTree, makeTreeFromBody, mdElement, mdarray, mergeSort, minus, mische, namensliste, natürlicherLogarithmus, neuerIgel, nicht, oder, oder2, offeneDateien, pllist, positive8BitZahl, positive8BitZahlP, quadriere, radBogenKosinus, radBogenSinus, radBogenTangens, radKosinus, radSinus, radTangens, radd, ratio2float, rdiv, reelleZahl, reelleZahlP, reelleZahlen, reelleZahlenFolge, renderLogoAsHTML, renderLogoFileAsHTML, rmul, rsub, runde, schiebeArithmetisch, schiebeLogisch, schneideAb, sichtbarP, speichereSchirmVektoriell, spieleWave, sättigeOberhalb, sättigeUnterhalb, teile, tiefeKopie, transponiere, und, und2, verfolgt, vergrößere, verschmelze, verschmelzePaare, versteckt, vomStapel, vorherP, vornhin, weiter, wirf, wähleZufällig, xKoor, yKoor, zKoor, zufällig, öffneZumLesen, überprüfe, übertrage

Halt Ignoriere


HC / Kontroll-Strukturen / Ignoriere

Ignoriere

HC [image] Kontroll-Strukturen [image] Ignoriere
Ausgabe Kommentar

Ignoriere Wert
Kommentar Wert (Bibliotheksprozedur)

Kommando. Tut nichts. Benutzt, wenn ein Ausdruck wegen seiner Nebenwirkung ausgewertet wird und sein eigentlicher Ergebniswert unwichtig ist.

Examples:

  • DynamischeBibliothek
  • setzeSchreiber
  • sei

References:

    DynamischeBibliothek, Kommentar, Release Notes für Version 4.65, sei, setzeSchreiber

Ausgabe Kommentar


HC / Kontroll-Strukturen / Kommentar

Kommentar

HC [image] Kontroll-Strukturen [image] Kommentar
Ignoriere `

Ignoriere Wert
Kommentar Wert (Bibliotheksprozedur)

Kommando. Tut nichts. Benutzt, wenn ein Ausdruck wegen seiner Nebenwirkung ausgewertet wird und sein eigentlicher Ergebniswert unwichtig ist.

Reference:

    Ignoriere

Ignoriere `


HC / Kontroll-Strukturen / `

`

HC [image] Kontroll-Strukturen [image] `
Ignoriere warte

` Liste (Bibliotheksprozedur)

Ausgabe ist eine Liste gleich der Eingabe, aber mit gewissen Substitutionen.

Wenn ein Element der Eingabe-Liste das Wort "," (Komma) ist, dann sollte das folgende Element eine Befehlsliste sein, die eine Ausgabe erzeugt, wenn sie ausgeführt wird. Der Ausgabewert ersetzt das Komma und die Befehlsliste.

Wenn ein Element der Eingabe-Liste das Wort ",@" (Komma-Atsign) ist, sollte das folgende Element eine Befehlsliste sein, die eine Liste ausgibt, wenn sie ausgeführt wird. Die Elemente von dieser Liste ersetzen das ,@ und die Befehlsliste.

Beispiel:

zeige `[foo baz ,[ohneErstes [a b c]] garply ,@[ohneErstes [a b c]]]

wird schreiben:

    [foo baz [b c] garply b c]

See also:

  • _Makro

Examples:

  • macroexpand
  • _Makro

References:

    _Makro(3), macroexpand

Ignoriere warte


HC / Kontroll-Strukturen / warte

warte

HC [image] Kontroll-Strukturen [image] warte
` warteMilliSekunden

warte ZeitInSechsigstelSekunden

Kommando. Verzögert weitere Ausführung für "ZeitInSechsigstelSekunden". Auch werden gepufferte Zeichen durch diesen Aufruf sofort geschrieben. WARTE 0 kann benutzt werden, um diesen Zeichenpuffer zu sofort zu schreiben, ohne eigentlich zu warten.

Beispiel:

warte 60		;wartet eine Sekunde

See also:

  • tippe

Examples:

  • verteileMeldungen
  • zweidimensional
  • Faktorisiere
  • tippe

References:

    tippe(3), Faktorisiere, verteileMeldungen, zweidimensional

` warteMilliSekunden


HC / Kontroll-Strukturen / warteMilliSekunden

warteMilliSekunden

HC [image] Kontroll-Strukturen [image] warteMilliSekunden
warte waituS

warteMilliSekunden Millisekunden

Kommando. Verzögert die weitere Ausführung um Millisekunden.

Beispiel:

warteMilliSekunden 1000		;wartet eine Sekunde

Examples:

  • spieleWaveSchnell
  • beendeteTöne
  • zähleThreads
  • Sounds

References:

    beendeteTöne(2), Release Notes für Version 4.64, Sounds, spieleWaveSchnell, zähleThreads

warte waituS


HC / Kontroll-Strukturen / waituS

waituS

HC [image] Kontroll-Strukturen [image] waituS
warteMilliSekunden Pause

waituS Mikrosekunden

Kommando. Verzögerungt die weitere Ausführung für Mikrosekunden. Dieses Kommando versucht, so genau wie möglich zu sein, je nach den Möglichkeiten des Betriebssystems und der Hardware.

Beispiel:

waituS 10500	;waits 10.5 milliseconds

Reference:

    Release Notes für Version 4.67

warteMilliSekunden Pause


HC / Kontroll-Strukturen / Pause

Pause

HC [image] Kontroll-Strukturen [image] Pause
waituS weiter

Pause

Befehl oder Operation. Wechselt in einen interaktiven Pause-Zustand. Der Benutzer wird zu neuen Befehlen aufgefordert, wie im Toplevel. Lokale Variablen dieser Prozedur sind während der Pause verfügbar. PAUSE gibt aus, wenn die Pause von einem weiter mit einer Eingabe beendet wird.

Wenn "FehlerAktion" einen von der leeren Liste unterschiedlichen Wert hat, und ein Fehlerzustand auftritt, wird der Inhalt von "FehlerAktion" als ein Befehlsliste ausgeführt. Typisch wird der Wert [PAUSE] gegeben, so dass eine interaktive Pause bei dem Ereignis eines Fehlers eintritt. Dies erlaubt dem Benutzer, Werte von lokalen Variablen zur Zeit des Fehlers zu überprüfen.

Beim Tippen der Taste [Pause] tritt auch eine Pause ein.

Beispiel:

zu t
    dauernd
    [	pause
    ]
Ende
;t definiert
t		;weiter ; Pause bei t in Zeile 2...
Halt

See also:

  • Starten und Verlassen von Logo
  • Fehler-Verarbeitung
  • fange

Examples:

  • Berkeley Logo-Anwenderdokumentation
  • Starten und Verlassen von Logo
  • weiter

References:

    Fehler-Verarbeitung(7), weiter(6), Starten und Verlassen von Logo(5), Release(2), Berkeley Logo-Anwenderdokumentation, FehlerAktion, fange, geheZu, setzeFehlerAktion, wirf

waituS weiter


HC / Kontroll-Strukturen / weiter

weiter

HC [image] Kontroll-Strukturen [image] weiter
Pause geheZu

weiter Wert
(weiter)

Kommando. Beendet die momentane interaktive Pause, zum Kontext des Aufrufs von Pause zurückkehrend, die sie begann. Wenn "weiter" eine Eingabe gegeben wird, wird dieser Wert als die Ausgabe der Pause benutzt. Wenn nicht, gibt die Pause Nichts aus.

Ausnahmsweise kann der "weiter"-Befehl ohne seine Standarteingabe und ohne Klammern benutzt werden, vorausgesetzt, dass ihm nichts auf der Befehlszeile folgt.

Beispiele:

to t
    pause
    schreibe 5
end
;t defined
t
weiter ; Pausing t in linie 2...
;5
to tt
    schreibe pause
end
;tt defined
tt
weiter 1234; Pausing tt in linie 1...
;1234

See also:

  • Fehler-Verarbeitung
  • Pause

Example:

  • Pause

References:

    Pause(2), übertrage(2), Fehler-Verarbeitung, Release Notes für Version 4.685, Vorlagen-basierte Iteration, _Makro, bearbeiteDatei, buglist für Version 4.65, kaskadiere, liesRoheZeile, Über Komplexität

Pause geheZu


HC / Kontroll-Strukturen / geheZu

geheZu

HC [image] Kontroll-Strukturen [image] geheZu
weiter Tag

geheZu wort

Kommando. Sucht nach einem "Marke" Befehl mit der gleichen Eingabe in der gleichen Prozedur, und setzt die Ausführung der Prozedur ab dem Ort dieser Marke fort. Es ist bedeutungslos, geheZu außerhalb einer Prozedur zu benutzen.

Aber seien Sie sich bewusst, geheZu ist ein ziemlich langsames Kommando, da es die aktuelle Prozedur durchsucht, bis es die Marke findet oder bis zu ihrem Ende (mit einer Fehlermeldung).

Beispiele:

to t
    Tag "one
    schreibe 1
    gehezu "two
    schreibe 5
    Tag "two
    schreibe 2
    gehezu "one
end
;t defined
t

Wird abwechselnd 1 und 2 schreiben, bis Sie [Strg]+[Pause] drücken.

Reference:

    Tag

weiter Tag


HC / Kontroll-Strukturen / Tag

Tag

HC [image] Kontroll-Strukturen [image] Tag
geheZu führeAus

Tag quoted_word

Kommando. Tut nichts. Die Eingabe muss ein wörtliches Wort nach einem Anführungszeichen sein ("), nicht das Ergebnis einer Rechnung. Marken werden vom Befehl "geheZu" benutzt.

Example:

  • geheZu

References:

    geheZu(2), DateiZeit, Zeit

geheZu führeAus


HC / Kontroll-Strukturen / führeAus

führeAus

HC [image] Kontroll-Strukturen [image] führeAus
Tag führeAusMitAusgabe

führeAus Befehlsliste

Befehl oder Operation. Läßt die Logo-Anweisungen in der Eingabeliste laufen; Gibt, wenn die Liste einen Ausdruck enthält, der etwas ausgibt, dies aus.

Beispiele:

führeAus [schreibe 1 schreibe 2 schreibe 3]

schreibt:

1
2
3

zu a
    schreibe "a
Ende
a definiert
zu b
    schreibe "b
Ende
b definiert
wiederhole 10 [führeAus wähleZufällig [a b]]

schreibt sowas wie:

a
a
b
b
a
b
a
a
a
a

See also:

  • Tokenisierung

Examples:

  • _Makro
  • sei

References:

    Tokenisierung(4), KombiBox(3), ListControl(3), Listenbox(2), Starten und Verlassen von Logo(2), _Makro(2), sei(2), Auswahlbox, CheckBoxen, ChoiceBoxes, KombiBoxen, ListControls, Listenboxen, RadioButtons, Release Notes für Version 4.685, Schieberegler, ToggleButtons, Zahlbox, für

Tag führeAusMitAusgabe


HC / Kontroll-Strukturen / führeAusMitAusgabe

führeAusMitAusgabe

HC [image] Kontroll-Strukturen [image] führeAusMitAusgabe
führeAus runSecure

führeAusMitAusgabe Befehlsliste

Läßt Anweisungen in der Eingabe laufen; Ausgabe ist eine leere Liste, wenn die Anweisungen keine Ausgabe produzieren, oder eine Liste, deren einziges Element die Ausgabe der gelaufenen Eingabe-Befehlsliste ist. Nützlich zum Erfinden von Kontroll-Strukturen, die Kommand oder Operation sein können.

Beispiel:

zu t something
        lokal "result
        setze "result führeausmitausgabe something
        wenn leerp :result [Halt]
        Ausgabe erstes :result
Ende
;t definiert
t [1]		;1  ;-)

gibt 1 aus, aber

t [schreibe 5]		;5

gibt nichts aus, sondern schreibt bloß 5.

Example:

  • _Makro

Reference:

    _Makro

führeAus runSecure


HC / Kontroll-Strukturen / runSecure

runSecure

HC [image] Kontroll-Strukturen [image] runSecure
führeAusMitAusgabe Tschüß

runSecure Sicherheitsstufe Befehlsliste
(runSecure Stufe Befehlsliste Stapelgröße Recordergröße Speichergröße Knoten Timeout Namensraum Vars)

Kommando oder Operation. Läßt die Befehlsliste in einer mehr oder weniger sicheren "Sandkasten"-artigen Umgebung laufen, abhängig von den verschiedenen Parametern.

Sicherheitsstufe: kann eine Kombination dieser Logo Konstanten sein: SECURITY_DLCALL SECURITY_IODLL SECURITY_SHELL SECURITY_FILEWRITE SECURITY_FILEREAD SECURITY_DIRS SECURITY_THREAD SECURITY_KEYBOARD SECURITY_GUI SECURITY_ERASE SECURITY_CONNECT SECURITY_GLOBAL SECURITY_BURIED SECURITY_NAMESPACE SECURITY_USER

Stapelgröße: Ganzzahl, die die maximale Stapelgröße des Sandkasten-Evaluators darstellt.

Recordergröße: Ganzzahl, die die maximale Anzahl Grafik-Kommandos darstellt, die im Sandkasten aufgenommen werden können.

Speichergröße: Ganzzahl, die die maximale Speicherbelegung des Sandkastens angibt.

Knoten: Ganzzahl, die die maximale Anzahl an Knoten angibt, die der Sandkasten belegen darf.

Timeout: Ganzzahl, die die maximale Laufzeit der Sandbox bestimmt. Nach dem der Timeout abgelaufen ist, endet der Sandkasten mit einem Unbound-Ergebnis (=nichts).

Namensraum: der Namensraum, in dem der Sandkasten laufen soll.

Vars: Variablen, die im Namensraum des Sandkastens als Parameter verfügbar sein sollen.

Beispiel:

be testrunsecure
    docommands=[rboxdemo]
    username="guest
;	catch "error [
        (runSecure
            security_dlcall
            +security_iodll
            +security_shell
            +security_filewrite
            ;+security_fileread
            ;+security_dirs
            +security_thread
            ;+security_keyboard
            +security_gui
            ;+security_erase
            +security_buried
            +security_namespace
            1024	;stack size (in bytes)
            100000	;graphic record size (in graphic primitives)
            1000000	;memory size (in bytes)
            65536	;max. number of nodes
            7000	;timeout (in milliseconds)
;			username
;			[username]
            ; ^-- get pushed on the varStack in Namespace username
            docommands)
;  runSecure is not allowed to use less security
;	]
end

Es wird höchstwahrscheinlich halten mit einer Fehlermeldung wie dieser:

    ;  fd ist nicht erlaubt, mehr Speicher zu verwenden


HC / Kontroll-Strukturen / Tschüß

Tschüß

HC [image] Kontroll-Strukturen [image] Tschüß
runSecure führeParallelAus

Tschüß

Kommando. Beendet Logo; kehrt zurück zum Betriebssystem.

Example:

  • Starten und Verlassen von Logo

References:

    Kommandozeilen-Schalter -nogui(2), Starten und Verlassen von Logo(2), Kommandozeilen-Schalter -run

runSecure führeParallelAus


HC / Kontroll-Strukturen / führeParallelAus

führeParallelAus

HC [image] Kontroll-Strukturen [image] führeParallelAus
Tschüß Faser

führeParallelAus Befehlsliste

Kommando. Es erzeugt einen neuen Thread, der eine Einheit eines parallelen Ausführungsstrangs von Logo-Befehlen ist.

Beispiel:

    5001
    4001
    3001
    2001
    1001
    3002
    1002
    3003
    2002
    5002
    4002
    3004
    1003
    5003
    1004
    1005
    2003
    2004
    4003
    3005
    5004
    5005
    1006
    2005
    5006
    3006
    4004
    5007
    1007
    1008
    3007
    2006
    5008
    4005
    1009
    5009
    2007
    3008
    3009
    1010
    2008
    5010
    4006
    3010
    4007
    2009
    4008
    2010
    4009
    4010


HC / Kontroll-Strukturen / Faser

Faser

HC [image] Kontroll-Strukturen [image] Faser
führeParallelAus yield

Faser Befehlsliste

Kommand. Es erzeugt eine neue Faser, die eine Einheit von pseudo-paralleler Ausführung von Logo-Befehlen ist, wie ein Thread. Fasern haben sich als ein gutes Stück schneller herausgestellt als Threads, aber Sie müssen einen Thread erzeugen, worin Sie nur Fasern erzeugen können. Am Ende des Threads, der Fasern hat, müssen Sie ein

    repeat 1 []
Kommando anhängen, sonst wird er wahrscheinlich am Ende abstürzen.

Beispiel:

Thread [Faser [wiederhole 10 [schreibe WiederholZahl]] wiederhole 1 []]

Siehe testfiber.lg für mehr Beispiele!

Examples:

  • Versions-Informationen für Version 4.7
  • Parallele Ausführung

References:

    Parallele Ausführung, Versions-Informationen für Version 4.7, yield

führeParallelAus yield


HC / Kontroll-Strukturen / yield

yield

HC [image] Kontroll-Strukturen [image] yield
Faser überprüfe

yield

Kommando. Ruft zunächst dispatchMessages auf, wechselt dann zur nächsten Faser, wenn es welche im aktuellen Thread gibt.

Examples:

  • Versions-Informationen für Version 4.7
  • Parallele Ausführung

References:

    Parallele Ausführung, Versions-Informationen für Version 4.7

Faser überprüfe


HC / Kontroll-Strukturen / überprüfe

überprüfe

HC [image] Kontroll-Strukturen [image] überprüfe
yield profil

überprüfe Befehlsliste Wert (Bibliotheksprozedur)

Kommando, das die Befehlsliste laufen lässt und die Ergebnis-Ausgabe der Ausführung vergleicht mit Wert. Es ist gut für Konsistenz-Prüfung von Operationen.

Beispiel:

sei checkbutfirst
    local [::ok]
    ::ok=0

    überprüfe [butFirst "abc] "bc
    überprüfe [butFirst 123] 23
    überprüfe [butFirst [a b c]][b c]
    überprüfe [butFirst {a b c}]{b c}
    überprüfe [butFirst FloatArray {1.2 2.3 3.4}] FloatArray {2.3 3.4}
    überprüfe [butFirst IntArray {1 2 3}] IntArray {2 3}
    überprüfe [butFirst Int16Array {1 2 3}] Int16Array {2 3}

;	überprüfe [bF       [1 2 3] ] [2 3]	;only available in English
    überprüfe [butFirst [1 2 3] ] [2 3]
    überprüfe [butFirst     [1] ] []
    überprüfe [butFirst "hello  ] "ello
    überprüfe [butFirst "h      ] "

    ; bad number of inputs
    runnotenoughinputstest [(butFirst)]
    runtoomanyinputstest   [(butFirst "Word "toomany)]

    ; bad inputs
    runbadinputtest [butFirst []  ]
    runbadinputtest [butFirst " ]

    type [; The butFirst function ]
    ifelse ::ok != 0
    [	(print [IS NOT CORRECT!] ::ok [ERRORS])
    ][	print [looks OK.]
    ]
    output ::ok
end


HC / Kontroll-Strukturen / profil

profil

HC [image] Kontroll-Strukturen [image] profil
überprüfe erbe

profil Befehlsliste (Bibliotheksprozedur)

Läßt die Befehlsliste laufen, nachdem sie alle Benutzer-Prozeduren umbenannt und aufrufende Prozeduren definiert hat, die die Ausführungs-Zeit und -Anzahl der umbenannten Prozeduren speichern. Diese Daten werden nach der Ausführung der Befehlsliste in einer Tabelle als ein Profil gezeigt.

Beispiel:

lade "bounce3.lg
profil [bounce3]

Reference:

    Release

überprüfe erbe


HC / Kontroll-Strukturen / erbe

erbe

HC [image] Kontroll-Strukturen [image] erbe
profil beendeThread

erbe Klasse

Kommando, um eine Basisklasse für ein Logo-Objekt in seinem Konstruktor einzurichten. Das konstruierte Objekt wird alle Methoden und lokalen Variablen der Basisklasse enthalten. Tatsächlich müssen Sie die richtigen Argumente an den Basisklassen-Konstruktor übergeben, denn danach wird "erbe" dessen Objekt-Tabelle in die Tabelle des gerade im Entstehen begriffene LogoObject kopieren.

Siehe "sei" für einige Beipiele.

Example:

  • sei

Reference:

    sei(4)

profil beendeThread


HC / Kontroll-Strukturen / beendeThread

beendeThread

HC [image] Kontroll-Strukturen [image] beendeThread
erbe Vorlagen-basierte Iteration

beendeThread threadId
beendeThread listOfThreadIds

Kommando. Versucht, den Thread mit Thread-Id Nummer threadId zu beenden. In seiner zweiten Form kann das Argument eine Liste von threadIds sein.

Examples:

  • Versions-Informationen für Version 4.7
  • Parallele Ausführung

References:

    Parallele Ausführung, Versions-Informationen für Version 4.7

erbe Vorlagen-basierte Iteration


HC / Vorlagen-basierte Iteration

Vorlagen-basierte Iteration

HC [image] Vorlagen-basierte Iteration
beendeThread wendeAn

Vorlagen-basierte Iteration

Die Prozeduren in diesem Abschnitt sind Iterationswerkzeuge, basierend auf der Idee einer "Vorlage." Das ist eine Generalisierung einer Anweisungs-Liste oder eine Ausdrucks-Liste, in dem Platzhalter für das Werkzeug zur Verfügung gestellt werden, um variierende Daten einzufügen. Vier unterschiedliche Formen von Vorlage können benutzt werden.

Das am meisten übliche benutzte Format für eine Vorlage ist das "explizite Platzhalter"-Format, oder das "Fragezeichen"-Format.

Beispiel:

zeige map [? * ?] [2 3 4 5]		;[4 9 16 25]

In diesem Beispiel, bewertet das MAP-Werkzeug die Vorlage [? *?] wiederholt, wobei es die Fragezeichen durch jeweils eines der Elemente der Daten-Liste [2 3 4 5] ersetzt. Der gleiche Wert wurde für jedes Fragezeichen in einer bestimmten Auswertung verwendet. Einige Werkzeuge können mehr als ein zu ersetzendes Datum parallel erlauben; In diesen Fällen werden die Platzhalter durch ?1 für das erste Datum, ?2 für das zweite, und so weiter dargestellt:

zeige (map [(Wort ?1 ?2 ?1)] [a b c] [d e f]); [ada beb cfc]

Wenn die Vorlage die Datum-Nummer berechnen will, ist die Form (? 1) äquivalent zu ?1, daher bedeutet (? ?1) das Datum, dessen Zahl im Datum Nummer 1 gegenben ist. Einige Werkzeuge ermöglichen zusätzliche Platzhalter-Bezeichnungen, wie in den einzelnen Beschreibungen gezeigt wird.

Die zweite Form von Vorlage ist die "benannte Prozedur"-Form. Wenn die Vorlage ein Wort anstelle einer Liste ist, wird sie als Name einer Prozedur angenommen. Diese Prozedur muss eine Anzahl von Eingaben gleich der Anzahl der parallelen Daten-Platzhalter des Werkzeugs annehmen; Das Verfahren wird auf alle verfügbaren Daten in richtiger Reihenfolge angewandt. Das heißt, wenn Daten ?1 bis ?3 verfügbar sind, ist die Vorlage "PROC ist äquivalent zu [PROC ?1 ?2 ?3].

zeige (map "Wort [a b c] [d e f])		;[ad be cf]

zu dotprod :a :b	;Skalarprodukt
    Ausgabe wendeAn "Summe (map "Produkt :a :b)
Ende

Die dritte Form von Vorlage ist die "Namen-Platzhalter" oder "Lambda"-Form. Diese From wird durch eine Vorlagenliste angezeigt, die mehr als ein Element enthält, deren erstes Element selbst wieder eine Liste ist. Das erste Element wird als Liste von Variablennamen angenommen; lokale Variablen mit jenen Variablennamen werden erzeugt und auf die verfügbaren Daten gesetzt in der Reihenfolge ihrer Werte. Die Anzahl von Variablennamen muss gleich der Anzahl der verfügbaren Daten sein. Diese Form wird in erster Linie gebraucht, wenn ein Iterations-Werkzeug innerhalb einer Vorlagenliste eines anderen verwendet werden muss, und die ? Notation mehrdeutig wäre in der inneren Vorlage.

Beispiel:

zu matmul :m1 :m2 [:tm2 transpose :m2]	; multiply two matrices
    Ausgabe map [[row] map [[col] dotprod :row :col] :tm2] :m1
Ende

Die vierte Form ist die "Prozedurtext"-Form, einer Variante der Lambda-Form. In dieser Form enthält die Vorlagenliste mindestens zwei Elemente, die alle Listen sind. Diese Form wird von den "definiere" und "ProzedurText" Grundwörtern verwendet, und "wendeAn" akzeptiert sie, so dass der Text einer definierten Prozedur als Vorlage verwendet werden kann.

Beachte: Die vierte Form von Vorlage wird anders ausgewertet als die anderen, darin, dass Logo sie als eine unabhängig definierte Prozedur ansieht für die Zwecke von Ausgabe und Halt.

Zum Beipsiel sind die folgenden zwei Anweisungen identisch:

zeige wendeAn [[x] :x+3] [5]		;8
zeige wendeAn [[x] [Ausgabe :x+3]] [5]		;8

obwohl die erste Anweisung in Name-Platzhalter-Form und die zweite in der Prozedurtext Form ist. Die Name-Platzhalter-Form kann so verstanden werden, wie wenn man Logo fragt, den Ausdruck :x+3 auszuwerten an Stelle des Gesamten Aufrufs von "wendeAn", mit der Variable x temporär auf den Wert 5 gesetzt. Die Prozedurtext-Form kann verstanden werden wie der Aufruf der Prozedur

to foo :x
    output :x+3
end

mit Eingabe 5, aber ohne der Prozedur tatsächlich einen Namen zu geben. Wenn der Gebrauch von "Ausgabe" in diesen zwei Beispielen vertauscht würde, würden wir Fehler bekommen:

schreibe wendeAn [[x] output :x+3] [5]
;Kann Ausgabe nur innerhalb einer Prozeudr verwenden
schreibe wendeAn [[x] [:x+3]] [5]		;8 ;-)

Die Name-Platzhalter-Form kann mit "Halt" oder "Ausgabe" innerhalb einer Prozedur verwendet werden, um die einschließende Prozedur zu stoppen.

Die folgenden Iterationswerkzeuge sind erweiterte Versionen derer in

Appendix B of the book
Computer Science Logo Style, Volume 3:
Advanced Topics
by Brian Harvey [MIT Press, 1987].

Die Erweiterungen sind primär, um eine variable Anzahl an Eingaben zu erlauben.

Vorlagen-basierte Iteration

  • wendeAn
  • rufeAuf
  • fürAlle
  • bildeab
  • bildeAbSatz
  • Filter
  • finde
  • reduziere
  • crossmap
  • kaskadiere
  • kaskadier2
  • übertrage


HC / Vorlagen-basierte Iteration / wendeAn

wendeAn

HC [image] Vorlagen-basierte Iteration [image] wendeAn
Vorlagen-basierte Iteration rufeAuf

wendeAn Vorlage DatenListe

Kommando oder Operation. Läßt die "Vorlage" laufen und füllt dabei die Platzhalter mit den Elementen der Datenliste. Die Anzahl von Elementen in der Datenliste muss eine annehmbare Anzahl von Platzhaltern für "Vorlage" sein. Es ist ungültig, das Grundwort "zu" als Vorlage anzuwenden, aber alles andere ist ok. "wendeAn" gibt aus, was die "Vorlage" ausgibt, wenn überhaupt.

Beispiel:

zeige wendeAn [?+?] [1 3 5]		;2
zeige wendeAn [?1+?2] [1 3 5]		;4
zeige wendeAn "Summe [1 2 3]		;6
zeige wendeAn [[x] :x+3] [5]		;8
zeige wendeAn [[x] [output :x+3]] [5]		;8

Examples:

  • Berkeley Logo-Anwenderdokumentation
  • Vorlagen-basierte Iteration
  • _vielleichtAusgabe
  • macroexpand
  • _Makro

References:

    Vorlagen-basierte Iteration(7), _Makro(4), macroexpand(2), Berkeley Logo-Anwenderdokumentation, Fenster-Stile, Tokenisierung, _vielleichtAusgabe, reduziere, rufeAuf, zumGestellDazu

Vorlagen-basierte Iteration rufeAuf


HC / Vorlagen-basierte Iteration / rufeAuf

rufeAuf

HC [image] Vorlagen-basierte Iteration [image] rufeAuf
wendeAn fürAlle

rufeAuf Vorlageneingabe (Bibliotheksprozedur)
(rufeAuf Vorlage Eingabe1 Eingabe2...)

Kommando oder Operation. Genau wie "wendeAn", ausser dass die Eingaben als einzelne Ausdrücke anstatt in einer Liste angegeben werden.

Beispiel:

zeige (invoke [?1+?2*?3] 1 2 3)		;7


HC / Vorlagen-basierte Iteration / fürAlle

fürAlle

HC [image] Vorlagen-basierte Iteration [image] fürAlle
rufeAuf bildeab

fürAlle Daten Vorlage
(fürAlle Daten1 Daten2... Vorlage)

Kommando. Bewertet die Vorlagen-Liste immer wieder, einmal für jedes Element der Datenliste. Wenn mehr als eine Daten-Liste gegeben werden, muss jede von ihnen die gleiche Länge haben (Die Dateneingaben können Wörter sein, in welchem Fall die Vorlage einmal für jedes Zeichen ausgewertet wird).

In einer Vorlage repräsentiert das Symbol ?rest den Teil der Dateneingabe rechts von dem Element, das augenblicklich benutzt wird, wie der ? Platzhalter. Das heißt, wenn die Daten-Eingabe [A B C D E] ist, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde ?rest ersetzt durch [C D E]. Wenn mehrere parallele Platzhalter verwendet werden, dann geht (?rest 1) mit ?1, etc.

In einer Vorlage repräsentiert das Symbol # die Position in der Daten-Eingabe des momentan verwendeten Platzhalter-Füllers. D.h. wenn die Eingabe-Daten [A B C D E] sind, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde # ersetzt durch 2.

Beispiele:

fürAlle [A B C] [(zeige # ? ?rest)]
;1 A [B C]
;2 B [C]
;3 C []
(fürAlle [1 2 3][4 5 6] [(zeige ?1 ?2)])
;1 4
;2 5
;3 6
(fürAlle [1 2 3][4 5 6] [[a b] (zeige a b)])
;1 4
;2 5
;3 6
(fürAlle [1 2 3][4 5 6] [[a b] [(zeige a b)]])
;1 4
;2 5
;3 6
fürAlle "Hallo [zeige ?]
;h
;a
;l
;l
;o
fürAlle [Abc Def Ghi] [fürAlle ? [(zeige # ? ?rest)]]
;1 A bc
;2 b c
;3 c
;1 D ef
;2 e f
;3 f
;1 G hi
;2 h i
;3 i

Examples:

  • weiterMitSchleife
  • LogoKonstanten
  • Systemaufruf
  • unterbrich
  • versteckt

References:

    versteckt(2), LogoKonstanten, Systemaufruf, closeall, ohneErste, unterbrich, weiterMitSchleife

rufeAuf bildeab


HC / Vorlagen-basierte Iteration / bildeab

bildeab

HC [image] Vorlagen-basierte Iteration [image] bildeab
fürAlle bildeAbSatz

bildeab Vorlage Datenliste (Bibliotheksprozedur)
(bildeab Vorlage Daten1 Daten2...)

Ausgabe ist ein Wort oder eine Liste, je nach dem Typ der Eingabe-Daten, von der gleichen Länge wie die Eingabe-Daten. (Wenn mehr als ein Eingabe-Datum gegeben wird, ist die Ausgabe vom gleichen Typ wie Daten1.) Jedes Element der Ausgabe ist das Ergebnis der Auswertung der Vorlagen-Liste, wobei die Platzhalter mit dem entsprechenden Element(en) der Eingabe-Daten gefüllt werden. (Alle Dateneingaben müssen die gleiche Länge haben.) Im Fall einer Wort-Ausgabe müssen die Ergebnisse der Vorlagenauswertung Wörter sein, und sie werden mit "Wort" verkettet.

In einer Vorlage repräsentiert das Symbol ?rest den Teil der Dateneingabe rechts von dem Element, das augenblicklich benutzt wird, wie der ? Platzhalter. Das heißt, wenn die Daten-Eingabe [A B C D E] ist, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde ?rest ersetzt durch [C D E]. Wenn mehrere parallele Platzhalter verwendet werden, dann geht (?rest 1) mit ?1, etc.

In einer Vorlage repräsentiert das Symbol # die Position in der Daten-Eingabe des momentan verwendeten Platzhalter-Füllers. D.h. wenn die Eingabe-Daten [A B C D E] sind, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde # ersetzt durch 2.

Beispiele:

map [?*?] [2 3 4 5]		;[4 9 16 25] ;-)
(map "wort [a b c] [d e f])		;[ad be cf] ;-)
(map [(wort ?1 ?2 ?1)] [a b c] [d e f])		;[ada beb cfc] ;-)


HC / Vorlagen-basierte Iteration / bildeAbSatz

bildeAbSatz

HC [image] Vorlagen-basierte Iteration [image] bildeAbSatz
bildeab Filter

bildeAbSatz Vorlage Datenliste (Bibliotheksprozedur)
(bildeAbSatz Vorlage Daten1 Daten2...)

Ausgabe ist eine Liste, geformt durch wiederholtes Auswerten der Vorlage-Liste und Verketten der Ergebnisse mittels "Satz". D.h. die Elemente der Ausgabe sind Elemente der Ergebnisse der Auswertungen. Die Ausgabeliste kann daher von unterschiedlicher Länge sein gegenüber den Eingabedatenlisten. (Wenn das Ergebnis einer Auswertung die leere Liste ist, so trägt sie Nichts zur endgültigen Ausgabe bei.) Die Eingabedaten dürfen Worte oder Listen sein.

In einer Vorlage repräsentiert das Symbol ?rest den Teil der Dateneingabe rechts von dem Element, das augenblicklich benutzt wird, wie der ? Platzhalter. Das heißt, wenn die Daten-Eingabe [A B C D E] ist, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde ?rest ersetzt durch [C D E]. Wenn mehrere parallele Platzhalter verwendet werden, dann geht (?rest 1) mit ?1, etc.

In einer Vorlage repräsentiert das Symbol # die Position in der Daten-Eingabe des momentan verwendeten Platzhalter-Füllers. D.h. wenn die Eingabe-Daten [A B C D E] sind, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde # ersetzt durch 2.

Beispiel:

(map_se [liste ?1 ?2] [a b c][d e f])		;[a d b e c f] ;-)


HC / Vorlagen-basierte Iteration / Filter

Filter

HC [image] Vorlagen-basierte Iteration [image] Filter
bildeAbSatz finde

Filter Tftemplate Daten (Bibliotheksprozedur)

Ausgabe ist ein Wort oder eine Liste, je nach dem Typ der Eingabe-Daten, das eine Teilmenge der Elemente (für ein Liste), oder Zeichen (für ein wort) der Eingabe enthält. Die Vorlage wird einmal für jedes Element oder Zeichen der Daten ausgewertet, und muss einen boolschen Wert, wahr oder falsch, erzeugen. Wenn der Wert wahr ist, wird das entsprechende Eingabeelement in die Ausgabe eingeschlossen.

Beispiel:

filter "vowelp "elephant		;eea  ;-)

In einer Vorlage repräsentiert das Symbol ?rest den Teil der Dateneingabe rechts von dem Element, das augenblicklich benutzt wird, wie der ? Platzhalter. Das heißt, wenn die Daten-Eingabe [A B C D E] ist, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde ?rest ersetzt durch [C D E]. Wenn mehrere parallele Platzhalter verwendet werden, dann geht (?rest 1) mit ?1, etc.

In einer Vorlage repräsentiert das Symbol # die Position in der Daten-Eingabe des momentan verwendeten Platzhalter-Füllers. D.h. wenn die Eingabe-Daten [A B C D E] sind, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde # ersetzt durch 2.


HC / Vorlagen-basierte Iteration / finde

finde

HC [image] Vorlagen-basierte Iteration [image] finde
Filter reduziere

finde wfVorlage Daten (Bibliotheksprozedur)

Ausgabe ist das erste Strukturelement der Eingabe-Daten (das erste Element einer Liste, oder das erste Zeichen eines Worts) für das der durch Auswerten der Vorlage mit diesem Strukturelement im Platzhalter produzierte Wert wahr ist. Wenn es kein solches Strukturelement gibt, wird die leere Liste ausgegeben.

In einer Vorlage repräsentiert das Symbol ?rest den Teil der Dateneingabe rechts von dem Element, das augenblicklich benutzt wird, wie der ? Platzhalter. Das heißt, wenn die Daten-Eingabe [A B C D E] ist, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde ?rest ersetzt durch [C D E]. Wenn mehrere parallele Platzhalter verwendet werden, dann geht (?rest 1) mit ?1, etc.

In einer Vorlage repräsentiert das Symbol # die Position in der Daten-Eingabe des momentan verwendeten Platzhalter-Füllers. D.h. wenn die Eingabe-Daten [A B C D E] sind, und die Vorlage gerade ausgewertet würde mit ? ersetzt durch B, dann würde # ersetzt durch 2.

Beispiele:

find [?=="a] [H a l l o]		;a  ;-)
find [?=="b] [H a l l o]		;[] ;-)


HC / Vorlagen-basierte Iteration / reduziere

reduziere

HC [image] Vorlagen-basierte Iteration [image] reduziere
finde crossmap

reduziere Vorlage Daten (Bibliotheksprozedur)

Ausgabe ist das Ergebnis, die Vorlage anzuwenden um die Eingabedatenelemente zu akkumulieren. Die Vorlage muss eine Zwei-Platzhalter-Funktion sein. Typischerweise ist es ein assoziativer Funktionsname wie "Summe. Wenn die Dateneingabe nur ein Strukturelement hat (Element in einer Liste oder Zeichen in einem Wort), ist die Ausgabe jenes Strukturelement. Sonst wird die Vorlage als erstes mit ?1 gefüllt mit dem vorletzten Strukturelement und ?2 gefüllt mit dem letzten Strukturelement angewandt. Dann, wenn es mehr Strukturelemente gibt, wird die Vorlage mit ?1 gefüllt mit dem nächsten Strukturelement nach links und ?2 mit dem Ergebnis der bisherigen Auswertung angewandt. Dieser Prozess setzt sich fort, bis alle Strukturelemente benutzt worden sind. Die Eingabe-Daten dürfen nicht leer sein.

Anmerkung: Wenn die Vorlage wie "Summe der Name eines Prozedur ist, die fähig ist, beliebig viele Eingaben zu akzeptieren, ist es effizienter, wendeAn an Stelle von reduziere zu benutzen. Das letztere ist gut für assoziative Prozeduren, die geschrieben worden sind, um genau zwei Eingaben zu akzeptieren:

zu größtes_ :a :b
    Ausgabe wennSonst :a > :b [:a] [:b]
Ende

schreibe reduziere "größtes_ [5 2 6 8 4 2 6 0 6]		;8

Alternativ kann reduziere verwendet werden, um größtes_ als Prozedur zu schreiben, die beliebig viele Eingaben annimmt, wie Summe es tut:

zu größtes_ [:Eingaben] 2
    wenn leer? :Eingaben ~
        [(wirf "error [nicht genug Eingaben an größtes_])]
    Ausgabe reduziere [wennSonst ?1 > ?2 [?1] [?2]] :Eingaben
Ende


HC / Vorlagen-basierte Iteration / crossmap

crossmap

HC [image] Vorlagen-basierte Iteration [image] crossmap
reduziere kaskadiere

crossmap Vorlage Listeliste (Bibliotheksprozedur)
(crossmap Vorlage Daten1 Daten2...)

Ausgabe ist eine Liste mit den Ergebnisse der Vorlagenauswertungen. Jede Daten-Liste liefert Werte für einen Platzhalter in der Vorlage; die Anzahl von Platzhaltern ist gleich von der Anzahl von Eingabe-Datenlisten. Als ein besonderer Fall, wenn nur eine Eingabe-Datenliste angegeben wird, wird diese Liste als Liste von Datenlisten angenommen, und jedes ihrer Elemente liefert Werte für einen Platzhalter. crossmap unterscheidet sich von map dadurch, dass es an Stelle die Elemente der Dateneingaben parallel zu nehmen, alle Kombinationsmöglichkeiten von Eingabe-Datenelementen nimmt, die nicht von gleicher Länge sein brauchen.

Beispiel:

zeige (crossmap [wort ?1 ?2] [a b c] [1 2 3 4])
;[a1 a2 a3 a4 b1 b2 b3 b4 c1 c2 c3 c4]

Für Kompatibilität mit der Version in der ersten Ausgabe von CSLS, dürfen crossmap Vorlagen die Notation :1 anstatt von ?1 für Platzhalter verwenden.


HC / Vorlagen-basierte Iteration / kaskadiere

kaskadiere

HC [image] Vorlagen-basierte Iteration [image] kaskadiere
crossmap kaskadier2

kaskadiere Endtest Vorlage Startwert (Bibliotheksprozedur)
(kaskadiere Endtest V1 SW1 V2 SW2...)
(kaskadiere Endtest V1 SW1 V2 SW2... letzteVorlage)

Ausgabe ist das Ergebnis der wiederholten Anwendung einer Vorlage (oder mehrerer Vorlagen, wie unten erklärt), wobei jeder der Platzhalter zunächst mit dem jeweiligen Startwert gefüllt wird, und das Ergebnis jeder Anwendung der jeweiligen Vorlage den Platzhalter für die folgende Anwendung füllt.

Im einfachsten Fall hat "kaskadiere" drei Eingaben. Die zweite Eingabe ist eine Ausdrucks-Vorlage mit einem Platzhalter. Diese Vorlage wird einige Male von ausgewertet (vielleicht Null mal). Bei der erstes Auswertung wird der Platzhalter mit der dritten Eingabe gefüllt; bei nachfolgenden Auswertungen wird der Platzhalter mit dem Ergebnis der bisherigen Auswertung gefüllt. Die Anzahl von Auswertungen wird von der erstes Eingabe bestimmt. Dies kann entweder eine nichtnegative Ganzzahl sein, in welchem Fall die Vorlage genauso viele Male ausgewertet wird, oder eine Abfrageausdrucks-Vorlage, in welchem Fall die Vorlage immer wieder ausgewertet wird (mit dem gleichen Platzhalter gefüllt, der für die Auswertung der zweiten Eingabe benutzt wird) solange die boolsche Abfrage falsch liefert. (Mit anderen Worten zeigt die boolsche Vorlage die Bedingung für das Aufhören an.)

Wenn die Vorlage Null Mal ausgewertet wird, ist die Ausgabe von "kaskadiere" die dritte Eingabe (Startwert). Sonst ist die Ausgabe der von der letzten Vorlagenauswertung erzeugte Wert.

"kaskadiere"-Vorlagen können das Symbol # enthalten, um die Anzahl von Durchläufen zu repräsentieren, die Vorlage schon ausgewertet wurde. Dieser Platzhalter wird mit 1 für die erste Auswertung gefüllt, 2 für die zweite, und so weiter.

Beispiel:

zeige kaskadiere 5 [hängean # ?] []		;[1 2 3 4 5]
zeige kaskadiere [vowelp erstes ?] [ohneErstes ?] "spring		;ing
zeige kaskadiere 5 [# * ?] 1		;120

Mehrere kaskadierte Ergebnisse können parallel ausgewertet werden durch zusätzliche Vorlagen-Startwert-Paare als Eingaben an "kaskadiere". In diesem Fall sind alle Vorlagen (einschließlich der Endtest-Vorlage, wenn verwendet) multi-slot, mit der Anzahl von Platzhaltern gleich der Anzahl von Eingabepaaren. In jeder Runde von Auswertungen repräsentiert ?2 dase Ergebnis der Auswertung der zweiten Vorlage in der vorherigen Runde. Wenn die ganze Anzahl an Eingaben (einschließlich der ersten, Endtest-Eingabe) ungerade ist, dann ist das Ergebnis von "kaskadiere" der letzte Wert der ersten Vorlage. Wenn die ganze Anzahl an Eingaben gerade ist, dann ist die letzte Eingabe eine Vorlage, die einmalig ausgewertet wird, nämlich nachdem der Endtest erfüllt wird, um die Ausgabe von "kaskadiere" festzulegen.

Beispiele:

zu fibonacci :n
    output (kaskadiere :n [?1 + ?2] 1 [?1] 0)
Ende

zu piglatin :aword
    output (kaskadiere [vowelp erstes ?]
            [wort ohneErstes ? erstes ?]
            :aword
            [wort ? "ay])
Ende
;piglatin defined
piglatin "greetings		;eetingsgray  ;-)

Reference:

    kaskadier2

crossmap kaskadier2


HC / Vorlagen-basierte Iteration / kaskadier2

kaskadier2

HC [image] Vorlagen-basierte Iteration [image] kaskadier2
kaskadiere übertrage

kaskadier2 endtest temp1 startval1 temp2 startval2 (Bibliotheksprozedur)

Ausgabe ist das Ergebnis des Aufrufs von "kaskadiere" mit den gleichen Eingaben. Der einzige Unterschied ist, dass die Standartanzahl von Eingaben fünf an Stelle von dreien ist.


HC / Vorlagen-basierte Iteration / übertrage

übertrage

HC [image] Vorlagen-basierte Iteration [image] übertrage
kaskadier2 Arbeitsbereiche

übertrage Endtest Vorlagen Eingangskorb (Bibliotheksprozedur)

Ausgabe ist das Ergebnis der mehrmaligen Auswertung der Vorlage. Die Vorlage wird einmal für jedes Element des Liste "Eingangskorb ausgewertet." TRANSFER verwaltet einen "Ausgangskorb", der anfänglich die leere Liste ist. Nach jeder Auswertung der Vorlage wird der sich ergebende Wert der neue Ausgangskorb.

In der Vorlage repräsentiert das Symbol ?IN das gegenwärtige Element vom Eingangskorb; das Symbol ?OUT repräsentiert den ganzen gegenwärtigen Ausgangskorb. Andere Platzhalter sollten nicht benutzt werden.

Wenn die erste (Endtest) Eingabe eine leere Liste ist, macht Auswertung weiter, bis alle Eingangskorbelemente benutzt worden sind. Wenn nicht, muss die erste Eingabe eine boolsche Abfrage-Vorlage sein, und die Auswertung macht weiter, bis entweder ist der Wert jener Vorlage wahr ist oder der Eingangskorb verbraucht ist.


HC / Arbeitsbereiche

Arbeitsbereiche

HC [image] Arbeitsbereiche
übertrage Arbeitsbereichs-Abfragen

Arbeitsbereiche

Dieses Kapitel beschreibt Funktionen zum Verwalten des Logo-Knoten-Speichers, auch genannt Arbeitsbereich.

Das beinhaltet z.B. Abfragen der Prozeduren, Grundwörter und Konstanten, Anzeigen von Prozeduren, Verstecken und Aufdecken, Laden und Speichern von Prozeduren und Variablen, Bearbeiten und Löschen.

Arbeitsbereiche

  • Arbeitsbereichs-Abfragen
  • Überprüfung
  • Arbeitsbereichs-Kontrolle
  • Arbeitsbereichs-Fragen
  • Editieren
  • Löschen


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen

Arbeitsbereichs-Abfragen

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen
Arbeitsbereiche Inhalt

Arbeitsbereichs-Abfragen

...sind Fragen zur Logo-Wurzel-Tabelle und ihrer Elemente.

Anmerkung: Alle Prozeduren, deren Eingabe als "Inhaltsliste" angezeigt wird, werden ein einzelnes Wort (für einen Prozedurnamen gehalten) akzeptieren, ein Liste von Wörtern (für Namen von Prozeduren gehalten), oder ein Liste dreier Listen, wie unter dem "Inhalt" Befehl beschrieben.

Arbeitsbereichs-Abfragen

  • Inhalt
  • Grundwörter
  • Prozeduren
  • VariablenNamen
  • LogoKonstanten
  • versteckt
  • verfolgt
  • namensliste
  • pllist
  • Parameteranzahl
  • Knoten
  • Threads
  • zähleThreads
  • liesBesitzer
  • liesBenutzer
  • Namensraum
  • ladeMitAnzeige
  • FehlerAktion
  • LogoSprache


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / Inhalt

Inhalt

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] Inhalt
Arbeitsbereichs-Abfragen Grundwörter

Inhalt

Ausgabe ist eine "Inhaltsliste", d. h. ein Liste dreier Listen, die jeweils die Namen der definierten Prozeduren, Variablen und Tabellen enthalten. Diese Liste schließt alle nicht versteckten, genannten Elemente im Arbeitsbereich ein.

Beispiele:

tree
inhalt		;[[tree tree2][][]] ;-)
a=1234
inhalt		;[[tree tree2][a][]] ;-)
pprop "b "greetings [Hallo World]
inhalt		;[[tree tree2][a][b]] ;-)
reset
inhalt		;[[][][]] ;-)

Examples:

  • nichteinzelschritt
  • speichereListe
  • deckenamenauf
  • versteckealle
  • deckealleauf
  • ladeLokal
  • verstecke
  • deckeauf
  • vergiß
  • Hilfe
  • poall

References:

    deckeauf(3), verstecke(3), Textbox(2), vergiß(2), versteckealle(2), Arbeitsbereichs-Abfragen, GUI Programmierung, Hilfe, Pause, Starten und Verlassen von Logo, StatischerTextInhalt, _Makro, deckealleauf, deckenamenauf, edall, ladeLokal, liesListeFlach, liesListeFlachRoh, liesListeFlachTags, liesListeFlachZeile, liesRoheZeile, nichteinzelschritt, poall, setzeAuswahlboxMöglichkeiten, setzeFehlerAktion, setzeKombiBoxMöglichkeiten, setzeListenboxMöglichkeiten, speichereListe, spieleWave, spieleWaveSchnell, stepall, sättigeOberhalb, sättigeUnterhalb, verfolgealle, vergißAlle

Arbeitsbereichs-Abfragen Grundwörter


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / Grundwörter

Grundwörter

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] Grundwörter
Inhalt Prozeduren

Ausgabe ist eine Liste der Namen aller Grundwörter.

Beispiele:

zeige grundwörter		;dann werden Sie die lange Liste der Grundwörter sehen
zähle grundwörter		;970  ;-)
zähle entferneDoppelte kleinbuchstabig grundwörter		;551  ;-)

Example:

  • Hilfe

References:

    Release Notes für Version 4.685(25), Versions-Informationen für Version 4.7(3), Release(2), Release Notes für Version 4.64(2), Release Notes für Version 4.686(2), Release Notes für Version 4.689(2), _setzeElement(2), _setzeErstes(2), _setzeNächstes(2), Arbeitsbereiche, Direkte Grafik, GrundwortP, Hilfe, Knöpfe, Numerische Operationen, ProzedurP, Release Notes für Version 4.65, Release Notes für Version 4.67, Release Notes für Version 4.672, Release Notes für Version 4.68, Release Notes für Version 4.682, Release Notes für Version 4.683, Tokenisierung, kopiereDefinition, reset, setzeRedefinierbar, verfolgealle, wirf, Über Komplexität

Inhalt Prozeduren


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / Prozeduren

Prozeduren

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] Prozeduren
Grundwörter VariablenNamen

Prozeduren

Ausgabe ist eine Liste der Namen aller nicht versteckten Benutzerdefinierten Prozeduren im Arbeitsbereich. Beachten Sie, dass ein Liste von Namen ist und keine Inhaltsliste. (Allerdings werden Prozeduren, die eine Inhaltsliste als Eingabe erfordern, diese Liste akzeptieren.)

Beispiele:

Prozeduren		;[] ;-)
tree
Prozeduren		;[tree tree2] ;-)

Example:

  • Versions-Informationen für Version 4.7

References:

    Arbeitsbereiche(3), profil(3), speichere(3), Arbeitsbereichs-Abfragen(2), GrundwortP(2), Versions-Informationen für Version 4.7(2), pops(2), pots(2), vergiß(2), vergißProzeduren(2), verstecke(2), wirf(2), Editieren, Geltungsbereich der Variablen, Inhalt, LogoBibliotheksVerzeichnis, Makros, Release Notes für Version 4.65, Release Notes für Version 4.67, Release Notes für Version 4.682, Starten und Verlassen von Logo, Tokenisierung, VariablenNamen, Vorlagen-basierte Iteration, _Makro, deckeauf, edps, kopiereDefinition, ladeMitAnzeige, listeProzedur, listeTitel, lokal, namensliste, pllist, reduziere, setzeLadeMitAusgabe, setzeLogoBibliotheksVerzeichnis, setzeLogoSprache, setzeStartup, speichereListe, vergißAlle, zu, Überprüfung

Grundwörter VariablenNamen


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / VariablenNamen

VariablenNamen

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] VariablenNamen
Prozeduren LogoKonstanten

VariablenNamen

Ausgabe ist eine Inhaltsliste bestehend aus einer leeren Liste (die für "keine Prozeduren" steht) und einer Liste der Namen jeder nicht versteckten Variablen im Arbeitsbereich.

Beispiel:

a=1234
b=[Hallo World!]
VariablenNamen		;[[][a b]] ;-)

References:

    Vorlagen-basierte Iteration(3), Müllsammeln, Release, Release Notes für Version 4.685, Tokenisierung, _Makro, edns, pons, setze, vergißVariablen

Prozeduren LogoKonstanten


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / LogoKonstanten

LogoKonstanten

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] LogoKonstanten
VariablenNamen versteckt

LogoKonstanten

Ausgabe ist die Liste der Namen aller intern definierten Konstanten, die Logo zur Zeit hat.

Beispiel:

fürAlle LogoKonstanten [zeige ?]

Es wird ungefähr folgendes schreiben:

    FALSCH
    WAHR
    cgicounter_ifs::cgi::%errout
    cgicounter_ifs::cgi::c
    cgicounter_ifs::cgi::counter
    cgicounter_ifs::cgi::frames
    cgicounter_ifs::cgi::graphs
    cgicounter_ifs::cgi::t
    cgicounter_ifs::tmp
    errormessage_out_of_mem
    errormessage_security_memsize
    errormessage_security_nodes
    errormessage_stack_overflow
    falsch
    fill_normal
    fill_small
    fill_small_surface
    fill_small_surface_tolerant
    fill_small_tolerant
    fill_surface
    fill_surface_tolerant
    fill_tolerant
    gl2ps_best_root
    gl2ps_bsp_sort
    gl2ps_compress
    gl2ps_draw_background
    gl2ps_landscape
    gl2ps_no_blending
    gl2ps_no_pixmap
    gl2ps_no_ps3_shading
    gl2ps_no_sort
    gl2ps_no_text
    gl2ps_none
    gl2ps_occlusion_cull
    gl2ps_silent
    gl2ps_simple_line_offset
    gl2ps_simple_sort
    gl2ps_tight_bounding_box
    gl2ps_use_current_viewport
    gl_and
    gl_and_inverted
    gl_and_reverse
    gl_clear
    gl_copy
    gl_copy_inverted
    gl_equiv
    gl_exp
    gl_exp2
    gl_invert
    gl_linear
    gl_nand
    gl_noop
    gl_nor
    gl_or
    gl_or_inverted
    gl_or_reverse
    gl_set
    gl_xor
    security_buried
    security_connect
    security_dirs
    security_dlcall
    security_erase
    security_fileread
    security_filewrite
    security_global
    security_gui
    security_iodll
    security_keyboard
    security_language
    security_namespace
    security_shell
    security_thread
    security_user
    wahr
    wxalign_bottom
    wxalign_center
    wxalign_center_horizontal
    wxalign_center_vertical
    wxalign_centre
    wxalign_left
    wxalign_right
    wxalign_top
    wxall
    wxalways_show_sb
    wxbackward
    wxbg_style_colour
    wxbg_style_custom
    wxbg_style_system
    wxboth
    wxbottom
    wxbu_bottom
    wxbu_exactfit
    wxbu_left
    wxbu_right
    wxbu_top
    wxcancel
    wxcaption
    wxcb_dropdown
    wxcb_readonly
    wxcb_simple
    wxcb_sort
    wxcentre
    wxcentre_on_screen
    wxchange_dir
    wxchk_2state
    wxchk_3state
    wxchk_allow_3rd_state_for_user
    wxclip_children
    wxclose_box
    wxdd_default_style
    wxdd_new_dir_button
    wxdefault_dialog_style
    wxdefault_frame_style
    wxdialog_ex_contexthelp
    wxdialog_ex_metal
    wxdialog_no_parent
    wxdir_default
    wxdir_dirs
    wxdir_dotdot
    wxdir_files
    wxdir_hidden
    wxdouble_border
    wxexpand
    wxfile_must_exist
    wxfixed_minsize
    wxfontstyle_italic
    wxfontstyle_normal
    wxfontstyle_slant
    wxfontweight_bold
    wxfontweight_light
    wxfontweight_normal
    wxforward
    wxframe_ex_contexthelp
    wxframe_ex_metal
    wxframe_float_on_parent
    wxframe_no_taskbar
    wxframe_shaped
    wxframe_tool_window
    wxfull_repaint_on_resize
    wxfullscreen_all
    wxfullscreen_noborder
    wxfullscreen_nocaption
    wxfullscreen_nomenubar
    wxfullscreen_nostatusbar
    wxfullscreen_notoolbar
    wxga_horizontal
    wxga_smooth
    wxga_vertical
    wxhelp
    wxhorizontal
    wxhscroll
    wxicon_asterisk
    wxicon_error
    wxicon_exclamation
    wxicon_hand
    wxicon_information
    wxicon_mask
    wxicon_question
    wxicon_stop
    wxicon_warning
    wxiconize
    wxid_add
    wxid_apply
    wxid_backward
    wxid_bold
    wxid_cancel
    wxid_clear
    wxid_close
    wxid_copy
    wxid_cut
    wxid_delete
    wxid_down
    wxid_exit
    wxid_find
    wxid_forward
    wxid_help
    wxid_home
    wxid_indent
    wxid_index
    wxid_italic
    wxid_justify_center
    wxid_justify_fill
    wxid_justify_left
    wxid_justify_right
    wxid_new
    wxid_no
    wxid_ok
    wxid_open
    wxid_paste
    wxid_preferences
    wxid_preview
    wxid_print
    wxid_properties
    wxid_redo
    wxid_refresh
    wxid_remove
    wxid_replace
    wxid_revert_to_saved
    wxid_save
    wxid_saveas
    wxid_stop
    wxid_undelete
    wxid_underline
    wxid_undo
    wxid_unindent
    wxid_up
    wxid_yes
    wxid_zoom_100
    wxid_zoom_fit
    wxid_zoom_in
    wxid_zoom_out
    wxk_add
    wxk_alt
    wxk_back
    wxk_cancel
    wxk_capital
    wxk_clear
    wxk_command
    wxk_control
    wxk_decimal
    wxk_delete
    wxk_divide
    wxk_down
    wxk_end
    wxk_escape
    wxk_execute
    wxk_f1
    wxk_f10
    wxk_f11
    wxk_f12
    wxk_f13
    wxk_f14
    wxk_f15
    wxk_f16
    wxk_f17
    wxk_f18
    wxk_f19
    wxk_f2
    wxk_f20
    wxk_f21
    wxk_f22
    wxk_f23
    wxk_f24
    wxk_f3
    wxk_f4
    wxk_f5
    wxk_f6
    wxk_f7
    wxk_f8
    wxk_f9
    wxk_help
    wxk_home
    wxk_insert
    wxk_lbutton
    wxk_left
    wxk_mbutton
    wxk_menu
    wxk_multiply
    wxk_next
    wxk_numlock
    wxk_numpad0
    wxk_numpad1
    wxk_numpad2
    wxk_numpad3
    wxk_numpad4
    wxk_numpad5
    wxk_numpad6
    wxk_numpad7
    wxk_numpad8
    wxk_numpad9
    wxk_numpad_add
    wxk_numpad_begin
    wxk_numpad_decimal
    wxk_numpad_delete
    wxk_numpad_divide
    wxk_numpad_down
    wxk_numpad_end
    wxk_numpad_enter
    wxk_numpad_equal
    wxk_numpad_f1
    wxk_numpad_f2
    wxk_numpad_f3
    wxk_numpad_f4
    wxk_numpad_home
    wxk_numpad_insert
    wxk_numpad_left
    wxk_numpad_multiply
    wxk_numpad_next
    wxk_numpad_pagedown
    wxk_numpad_pageup
    wxk_numpad_prior
    wxk_numpad_right
    wxk_numpad_separator
    wxk_numpad_space
    wxk_numpad_subtract
    wxk_numpad_tab
    wxk_numpad_up
    wxk_pagedown
    wxk_pageup
    wxk_pause
    wxk_print
    wxk_prior
    wxk_rbutton
    wxk_return
    wxk_right
    wxk_scroll
    wxk_select
    wxk_separator
    wxk_shift
    wxk_snapshot
    wxk_space
    wxk_start
    wxk_subtract
    wxk_tab
    wxk_up
    wxk_windows_left
    wxk_windows_menu
    wxk_windows_right
    wxlb_always_sb
    wxlb_extended
    wxlb_hscroll
    wxlb_multiple
    wxlb_needed_sb
    wxlb_single
    wxlb_sort
    wxlc_align_left
    wxlc_align_top
    wxlc_autoarrange
    wxlc_edit_labels
    wxlc_hrules
    wxlc_icon
    wxlc_list
    wxlc_no_header
    wxlc_report
    wxlc_single_sel
    wxlc_small_icon
    wxlc_sort_ascending
    wxlc_sort_descending
    wxlc_virtual
    wxlc_vrules
    wxleft
    wxlist_format_centre
    wxlist_format_left
    wxlist_format_right
    wxmaximize
    wxmaximize_box
    wxminimize
    wxminimize_box
    wxmore
    wxmultiple
    wxno
    wxno_3d
    wxno_border
    wxno_default
    wxno_full_repaint_on_resize
    wxnot_found
    wxok
    wxopen
    wxoverwrite_prompt
    wxraised_border
    wxrb_group
    wxrb_single
    wxrb_use_checkbox
    wxreset
    wxresize_border
    wxright
    wxsave
    wxsetup
    wxshaped
    wxsimple_border
    wxsl_both
    wxsl_bottom
    wxsl_horizontal
    wxsl_inverse
    wxsl_labels
    wxsl_left
    wxsl_right
    wxsl_selrange
    wxsl_ticks
    wxsl_top
    wxsl_vertical
    wxsp_arrow_keys
    wxsp_wrap
    wxst_no_autoresize
    wxstatic_border
    wxstay_on_top
    wxsunken_border
    wxsystem_menu
    wxtab_traversal
    wxte_auto_url
    wxte_bestwrap
    wxte_capitalize
    wxte_centre
    wxte_charwrap
    wxte_dontwrap
    wxte_left
    wxte_multiline
    wxte_nohidesel
    wxte_password
    wxte_process_enter
    wxte_process_tab
    wxte_readonly
    wxte_rich
    wxte_rich2
    wxte_right
    wxte_wordwrap
    wxthick_frame
    wxtop
    wxtransparent_window
    wxvertical
    wxvscroll
    wxwants_chars
    wxws_ex_block_events
    wxws_ex_process_idle
    wxws_ex_process_ui_updates
    wxws_ex_transient
    wxws_ex_validate_recursively
    wxyes
    wxyes_no

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

VariablenNamen versteckt


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / versteckt

versteckt

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] versteckt
LogoKonstanten verfolgt

versteckt

Ausgabe ist eine Inhaltsliste, die alle versteckten benannten Elemente im Arbeitsbereich enthält.

Beispiele:

versteckt
    [	[]
        [-1 0 1 determinant falsch floatmax intmax pi wahr]
        []
    ]
 ;-)
fürAlle [Hallo World] [schreibe ?]
Hallo
World
versteckt
    [	[?rest fürAlle foreach1 foreach_done]
        [-1 0 1 determinant falsch floatmax intmax pi wahr]
        []
    ]
 ;-)

Examples:

  • deckenamenauf
  • versteckealle
  • verstecke

References:

    kopiereDefinition(2), verstecke(2), deckenamenauf, sichtbarP, versteckealle

LogoKonstanten verfolgt


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / verfolgt

verfolgt

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] verfolgt
versteckt namensliste

verfolgt

Ausgabe ist eine Inhaltsliste, die alle verfolgten benannten Elemente im Arbeitsbereich enthält.

Beispiel:

verfolge "vorwärts
verfolgt
    [	[vorwärts]
        []
        []
    ]
 ;-)
vorwärts 100
( vorwärts 100 )
vorwärts stops

Reference:

    Release Notes für Version 4.64

versteckt namensliste


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / namensliste

namensliste

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] namensliste
verfolgt pllist

namensliste VarName
namensliste VarNamenListe (Bibliotheksprozedur)

Ausgabe ist eine Inhaltsliste bestehend aus einer leeren Liste gefolgt von einer Liste des oder der als Eingaben gegebenen Variablen-Namen. Dies ist nützlich zusammen mit Arbeitsbereichs-Kontroll-Prozeduren, die eine Inhaltsliste als Eingabe benötigen.

Beispiele:

namelist "a
    [	[]
        [a]
    ]
 ;-)
namelist [a b c]
    [	[]
        [a b c]
    ]
 ;-)

Example:

  • pon

References:

    pon(2), deckenamenauf, edn, versteckename

verfolgt pllist


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / pllist

pllist

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] pllist
namensliste Parameteranzahl

pllist plname
pllist plnamelist (Bibliotheksprozedur)

Ausgabe ist eine Inhaltsliste bestehend aus zwei leeren Listen gefolgt von einer Liste des oder der als Eingabe gegebenen Variablen-Namen. Dies ist nützlich zusammen mit Arbeitsbereichs-Kontroll-Prozeduren, die eine Inhaltsliste als Eingabe benötigen.

Beispiele:

pllist "a
    [	[]
        []
        [a]
    ]
 ;-)
pllist [a b c]
    [	[]
        []
        [a b c]
    ]
 ;-)

References:

    edpl, erpl, popl

namensliste Parameteranzahl


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / Parameteranzahl

Parameteranzahl

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] Parameteranzahl
pllist Knoten

Parameteranzahl Prozedurname

Ausgabe ist eine Liste von vier Zahlen: das Minimum, die Standart- und Maximumanzahl von Eingaben und die Priorität der Prozedur, dessen Name die Eingabe ist. Es ist ein Fehler, wenn es keine solche Prozedur gibt. Ein Maximum von -1 bedeutet, dass die Anzahl von Eingaben unbegrenzt ist.

Beispiele:

parameteranzahl "vorwärts		;[1 1 1 10] ;-)
parameteranzahl "element		;[2 2 3 10] ;-)
parameteranzahl "Summe		;[0 2 -1 10] ;-)
parameteranzahl "+		;[1 1 1 12] ;-)
parameteranzahl "*		;[1 1 1 13] ;-)
parameteranzahl "^		;[1 1 1 14] ;-)
parameteranzahl "--		;[1 1 1 16] ;-)

Reference:

    Release Notes für Version 4.64

pllist Knoten


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / Knoten

Knoten

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] Knoten
Parameteranzahl Threads

Knoten

Ausgabe ist eine Liste dreier Zahlen. Die erstes repräsentiert die Anzahl von Knoten von Speicher, der momentan in Verwendung ist. Die zweite zeigt die maximale Anzahl von Knoten, die irgendwann seit dem letzten Aufruf von "Knoten" in Verwendung waren. (Ein Knoten ist ein kleiner Block von Computerspeicher, wie er von Logo benutzt wird. Jede Zahl benutzt einen Knoten. Jedes nicht numerische Wort benutzt einen Knoten plus etwas Nicht-Knoten-Speicher für die Zeichen im Wort. Für jede Reihe braucht man einen Knoten, plus etwas Nicht-Knoten-Speicher, so wie den von ihren Elementen benötigten Speicher. Jede Liste benötigt einen Knoten pro Element, so wie den Speicher der Elemente selbst.)

Wenn Sie die Speicher-Verwendung eines Algorithmus verfolgen wollen, ist es am besten, wenn Sie am Anfang jeder Iteration "Müllsammeln" aufrufen, da sonst das Maximum Speicher einschließen wird, die unbenutzt ist, aber noch nicht wieder freigegeben wurde.

Es wurden Erweiterungen zum Speicher-Zuweisungs-Code gemacht: es ist nun auch möglich, die Speicherbelegung in Bytes auf einer per-Thread-Basis anzusehen. Das ist das dritte Element des Ergebnisses von "Knoten". Dies war nötig um Speicher-Kontingente einzuführen, die von "führeSicherAus" verwendet werden können.

Beispiele:

Knoten		;[3105 3471] ;-)
Knoten		;[3105 3125] ;-)
a=1234
Knoten		;[3108 3143] ;-)
Knoten		;[3108 3128] ;-)
vergiß [[][a]]
Knoten		;[3105 3145] ;-)
Knoten		;[3105 3125] ;-)

Example:

  • Versions-Informationen für Version 4.7

References:

    Müllsammeln(4), Release Notes für Version 4.685(3), runSecure(3), 16BitZahlen(2), Ganzzahlen(2), Versions-Informationen für Version 4.7(2), reelleZahlen(2), Arbeitsbereiche, KammSort, KammSortAufDerStelle, Rationale Zahlen, Release Notes für Version 4.686, Release Notes für Version 4.687, Release Notes für Version 4.689, _gleich, _setzeErstes, _setzeNächstes, xDividieren, xMal, xMinus, xPlus, xRest

Parameteranzahl Threads


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / Threads

Threads

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] Threads
Knoten zähleThreads

Threads

Ausgabe ist die Liste von Ganzzahlen, die die Nummern aller Logo-Threads repräsentieren, sogenannten ThreadIds, die gestartet wurden und noch nicht beendet wurden.

Examples:

  • Versions-Informationen für Version 4.7
  • Parallele Ausführung

References:

    Faser(2), Versions-Informationen für Version 4.7(2), Parallele Ausführung, SoundsFinished, SoundsStop, beendeteTöne, liesThreadId, setzeBenutzer, verlasseGrafik, zähleThreads

Knoten zähleThreads


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / zähleThreads

zähleThreads

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] zähleThreads
Threads liesBesitzer

zähleThreads

Ausgabe ist die momentane Anzahl von Logo-Threads, die durch das Grundwort "Thread" oder "parallelAusführen" gestartet wurden.

Beispiel:

wiederhole 10 [Thread [wiederhole 1000 [schreibe zähleThreads warteMillisekunden 100]]]

Seine Ausgabe kann ungefähr so aussehen:

    3
    3
    6
    6
    8
    10
    10
    ...	;viele 10er...
    10
    10
    9
    9
    8

Examples:

  • Versions-Informationen für Version 4.7
  • Parallele Ausführung

References:

    Parallele Ausführung, Versions-Informationen für Version 4.7

Threads liesBesitzer


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / liesBesitzer

liesBesitzer

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] liesBesitzer
zähleThreads liesBenutzer

liesBesitzer etwas

Ausgabe ist der Besitzer von "etwas". Der Besitzer eines Dings ist normallerweise der Benutzer der aktiv war zum Zeitpunkt der Erstellung des Dings.

Beispiel:

liesBesitzer "forward
[]  ;-)
setzeBenutzer "andreas
kopiereDefinition "myfd "forward
liesBesitzer "myfd
andreas  ;-)

Example:

  • setzeBenutzer

Reference:

    setzeBenutzer

zähleThreads liesBenutzer


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / liesBenutzer

liesBenutzer

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] liesBenutzer
liesBesitzer Namensraum

liesBenutzer

Ausgabe ist der Name des momentanen Benutzers. Wenn kein Benutzer zuvor spezifiziert wurde durch setztBenutzer, ist die Ausgabe die leere Liste, mit der Bedeutung, dass der Benutzer Vollzugriff auf die Logo-Wurzeltabelle hat.

Beispiel:

liesBenutzer
[]  ;-)
setzeBenutzer "andreas
liesBenutzer
andreas  ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / Namensraum

Namensraum

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] Namensraum
liesBenutzer ladeMitAnzeige

Namensraum

Ausgabe ist der ganze Name des aktuellen Namensraums als ein Wort.

Beispiel:

zu pr5
    schreibe 5
Ende
setzeNamensraum "a
zu pr5
    schreibe "a5
Ende
zeige Namensraum
::a
setzeNamensraum "
pr5
5
a::pr5
a5

Example:

  • Versions-Informationen für Version 4.7

References:

    runSecure(4), ladeLokal(3), sei(2), setzeNamensraum(2), Versions-Informationen für Version 4.7, setzeLogoSprache

liesBenutzer ladeMitAnzeige


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / ladeMitAnzeige

ladeMitAnzeige

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] ladeMitAnzeige
Namensraum FehlerAktion

ladeMitAnzeige

Ausgabe ist der Zustand der internen Variable ladeMitAusgabe. Wenn wahr, werden die Namen der Prozeduren, die beim Laden eines Logo-Programms (einschließlich der temporären Datei von "bearbeite") definiert werden, angezeigt.


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / FehlerAktion

FehlerAktion

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] FehlerAktion
ladeMitAnzeige LogoSprache

FehlerAktion

Ausgabe ist die interne Variable erract. Sie enthält eine Befehlsliste, die laufen wird, wenn ein Fehler auftritt. Typischerweise hat sie den Wert [pause] um interaktives Debugging zu ermöglichen. Standartwert ist [].

Reference:

    Pause(2)

ladeMitAnzeige LogoSprache


HC / Arbeitsbereiche / Arbeitsbereichs-Abfragen / LogoSprache

LogoSprache

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Abfragen [image] LogoSprache
FehlerAktion Überprüfung

LogoSprache

Ausgabe ist die momentane Logo Sprache. Zur Zeit kann dies eines der Worte "ucblogo oder "aucblogo sein.

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

FehlerAktion Überprüfung


HC / Arbeitsbereiche / Überprüfung

Überprüfung

HC [image] Arbeitsbereiche [image] Überprüfung
LogoSprache listeProzedur

Überprüfung

Dies sind Anzeigefunktionen für Prozeduren, mit vielen Abkürzungen.

Überprüfung

  • listeProzedur
  • poall
  • pops
  • pons
  • popls
  • pon
  • popl
  • listeTitel
  • pots

Reference:

    hex

LogoSprache listeProzedur


HC / Arbeitsbereiche / Überprüfung / listeProzedur

listeProzedur

HC [image] Arbeitsbereiche [image] Überprüfung [image] listeProzedur
Überprüfung poall

listeProzedur Inhaltsliste

Kommando. Schreibt auf den Schreibstrom die Definitionen von allen Prozeduren, Variablen und Tabellen, die in der Eingabe Inhaltsliste genannt werden.

Beispiel:

a=1234
zu t
    schreibe a
Ende
;t definiert
listeProzedur [[t][a]]

was schreiben wird:

zu t
    schreibe a
Ende

setze "a 1234

Example:

  • poall

References:

    Release Notes für Version 4.64, poall

Überprüfung poall


HC / Arbeitsbereiche / Überprüfung / poall

poall

HC [image] Arbeitsbereiche [image] Überprüfung [image] poall
listeProzedur pops

poall (Bibliotheksprozedur)

Kommando. Schreibt alle nicht-versteckten Definitionen des Arbeitsbereichs. Abkürzung für po contents. Beispiel:

a=1234
zu t
    schreibe a
Ende
;t definiert
listeProzedur Inhalt

was schreiben wird:

zu t
    schreibe a
Ende

setze "a 1234

Example:

  • speichere

References:

    speichere, verstecke

listeProzedur pops


HC / Arbeitsbereiche / Überprüfung / pops

pops

HC [image] Arbeitsbereiche [image] Überprüfung [image] pops
poall pons

pops (Bibliotheksprozedur)

Kommando. Schreibt alle nicht-versteckten Prozeduren des Arbeitsbereichs. Abkürzung für:

    po Prozeduren
Beispiel:

zu t
    schreibe 1234
Ende
t definiert
pops

was schreiben wird:

zu t
    schreibe 1234
Ende


HC / Arbeitsbereiche / Überprüfung / pons

pons

HC [image] Arbeitsbereiche [image] Überprüfung [image] pons
pops popls

pons (Bibliotheksprozedur)

Kommando. Schreibt alle nicht-versteckten Variablen des Arbeitsbereichs. Abkürzung für:

    po VariablenNamen
Beispiel:

a=1234
b=[Hallo Welt!]
pons

was schreiben wird:

setze "a 1234
setze "b [Hallo Welt!]


HC / Arbeitsbereiche / Überprüfung / popls

popls

HC [image] Arbeitsbereiche [image] Überprüfung [image] popls
pons pon

popls (Bibliotheksprozedur)

Kommando. Schreibt alle nicht-versteckten Tabellen des Arbeitsbereichs. Abkürzung für:

    po Tabellen


HC / Arbeitsbereiche / Überprüfung / pon

pon

HC [image] Arbeitsbereiche [image] Überprüfung [image] pon
popls popl

pon VarName
pon VarNamenListe (Bibliotheksprozedur)

Kommando. Schreibt die Definitionen der genannten Variable(n). Ist eine Abkürzung für:

po namensliste VarName

oder

po namensliste VarNamensliste

Beispiele:

a=1234
b=[Hallo Welt!]
pon "a

wird schreiben:

    setze "a 1234

pon [a b]
wird schreiben:
    setze "a 1234
    setze "b [Hallo Welt!]


HC / Arbeitsbereiche / Überprüfung / popl

popl

HC [image] Arbeitsbereiche [image] Überprüfung [image] popl
pon listeTitel

popl plname
popl plnamelist (Bibliotheksprozedur)

Kommando. Schreibt die Definitionen der genannten Tabellen. Abkürzung für:

    po pllist Tabellenname


HC / Arbeitsbereiche / Überprüfung / listeTitel

listeTitel

HC [image] Arbeitsbereiche [image] Überprüfung [image] listeTitel
popl pots

listeTitel Inhaltsliste

Kommando. Schreibt die Titelzeilen der genannten Prozeduren und die Definitionen der genannten Variablen und Tabellen.

Beispiel:

a=1234
zu t
    schreibe 5
Ende
;t definiert
listeTitel [[t][a]]

wird schreiben:

zu t
a=1234

Reference:

    Release Notes für Version 4.64

popl pots


HC / Arbeitsbereiche / Überprüfung / pots

pots

HC [image] Arbeitsbereiche [image] Überprüfung [image] pots
listeTitel Arbeitsbereichs-Kontrolle

pots (Bibliotheksprozedur)

Kommando. Schreibe die Titelzeilen von allem nicht-versteckten Prozeduren im Arbeitsbereich. kürzt ab:

    pot Prozeduren
Beispiel:

tree
pots

wird schreiben:

zu tree [level 7][size 100]
zu tree2 level size

Example:

  • lade

Reference:

    lade

listeTitel Arbeitsbereichs-Kontrolle


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle

Arbeitsbereichs-Kontrolle

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle
pots setzeGroßKleinEgal

Arbeitsbereichs-Kontrolle

Hier werden Kommandos zum Laden, Speichern, Verstecken, Verfolgen und Einzelschritt-setzen, sowie zum Setzen verschiedener, den Arbeitsbereich betreffender Eigenschaften beschrieben.

Arbeitsbereichs-Kontrolle

  • setzeGroßKleinEgal
  • verstecke
  • versteckealle
  • versteckename
  • deckeauf
  • deckealleauf
  • deckenamenauf
  • verfolge
  • verfolgealle
  • verfolgenicht
  • Einzelschritt
  • stepall
  • nichteinzelschritt
  • speichere
  • speichereListe
  • lade
  • ladeLokal
  • Hilfe
  • hilfesuche
  • Müllsammeln
  • verkleinereStapel
  • setzeStapelAusführlich
  • setzeErallOnRun
  • setzeFPUStatusFlags
  • setzeGenSym
  • setzeNamensraum
  • setzeRedefinierbar
  • setzeStartup
  • setzeBenutzer
  • setzeLadeMitAusgabe
  • setzeFehlerAktion
  • setzeLogoSprache


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeGroßKleinEgal

setzeGroßKleinEgal

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeGroßKleinEgal
Arbeitsbereichs-Kontrolle verstecke

setzeGroßKleinEgal bool

setzt den internen Zustand, empfindlich für Groß-/Kleinschreibung zu sein. Setzen Sie es zu falsch, wenn das Sie groß- und kleinbuchstabige Zeichen erkennen wollen.

Aber beachten Sie: Auch die Prozedur- und Grundwort-Namen sind dann auf Groß-/klein empfindlich.

Es gibt zwei Formen jedes Grundworts, eines vollkommen kleinbuchstabig, das andere wie in der Hilfe.

Beispiel:

setzeGroßKleinEgal falsch
löscheschirm	;funktioniert!
löscheSchirm	;funktioniert!
LöscheSchirm
; Kenne ich nicht:  to LöscheSchirm

Example:

  • GroßKleinEgalP

References:

    GroßKleinEgalP, Release Notes für Version 4.64, gleichP, reset, rufeDynamischeBibliothekAuf

Arbeitsbereichs-Kontrolle verstecke


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / verstecke

verstecke

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] verstecke
setzeGroßKleinEgal versteckealle

verstecke contentslist

Kommando. Versteckt die in der Eingabe genannten Prozeduren, Variablen und Tabellen. Ein verstecktes Element wird nicht in die Listen von "Inhalt", "Prozeduren" und "Tabellen" eingeschlossen, aber es wird in die von "versteckte" ausgegebene Liste eingeschlossen. Daraus folgt, dass versteckte Dinge nicht von "poall" ausgegeben oder von "speichere" gespeichert werden.

Beispiel:

zu t
Ende
;t definiert
Inhalt		;[[t][][]] ;-)
verstecke "t
Inhalt		;[[][][]] ;-)
versteckt
    [	[t]
        [-1 0 1 determinant falsch floatmax intmax pi wahr]
        []
    ]
 ;-)

Examples:

  • deckealleauf
  • deckeauf

References:

    deckealleauf, deckeauf, versteckealle, versteckename

setzeGroßKleinEgal versteckealle


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / versteckealle

versteckealle

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] versteckealle
verstecke versteckename

versteckealle (Bibliotheksprozedur)

Kommando. Abkürzung für:

    verstecke Inhalt
Beispiel:

a=1234
tree
buryall
Inhalt		;[[][][]] ;-)
versteckt
    [	[buryall tree tree2]
        [-1 0 1 a determinant falsch floatmax intmax pi wahr]
        []
    ]
 ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / versteckename

versteckename

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] versteckename
versteckealle deckeauf

versteckename VarName
versteckename VarNamenListe (Bibliotheksprozedur)

Kommando. Abkürzung für:

    verstecke namensliste VarName


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / deckeauf

deckeauf

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] deckeauf
versteckename deckealleauf

deckeauf contentslist

Kommando. Deckt die in der Eingabe genannten Prozeduren, Variablen und Tabellen auf. Das heißt, dass die genannten Elemente von "Inhalt", etc. ausgeegeben werden.

Beispiel:

a=1234
verstecke namelist "a
Inhalt		;[[][][]] ;-)
deckeauf namelist "a
Inhalt		;[[][a][]] ;-)

References:

    deckealleauf, deckenamenauf

versteckename deckealleauf


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / deckealleauf

deckealleauf

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] deckealleauf
deckeauf deckenamenauf

deckealleauf (Bibliotheksprozedur)

Kommando. Abkürzung von

    deckeAuf versteckte
Beispiel:

a=1234
verstecke namelist "a
unburyall
Inhalt		;[[namelist unburyall][a][]] ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / deckenamenauf

deckenamenauf

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] deckenamenauf
deckealleauf verfolge

deckenamenauf Varname (Bibliotheksprozedur)
deckenamenauf Varnamenliste

Kommando. Abkürzung für

    deckeauf namensliste VarName
Beispiel:

a=1234
buryname "a
versteckt		;[[buryname namelist][a][]] ;-)
unburyname "a
Inhalt		;[[][a][]] ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / verfolge

verfolge

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] verfolge
deckenamenauf verfolgealle

verfolge Inhaltsliste

Kommando. Markiere die genannten Elemente für Mitverfolgung der Ausführung. Eine Meldung wird ausgegeben, wann immer eine Prozedur aufgerufen wird, einschließlich den tatsächlichen übergebenen Eingabewerten, und wenn eine verfolgte Prozedur anhält oder etwas ausgibt. Eine Meldung wird auch ausgegeben, wenn ein neuer Wert einer verfolgten Variablen durch "setze" zugewiesen wird.

Beispiele:

a=1234
verfolge namelist "a
a=4321;		Make "a 4321

lade "tree.lg
verfolge "tree
tree

Das zweite Beispiel wird eine ziemlich lange Mitschrift der tree-Aufrufe schreiben.

Examples:

  • verfolgenicht
  • verfolgt

References:

    verfolgealle(2), verfolgenicht, verfolgt

deckenamenauf verfolgealle


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / verfolgealle

verfolgealle

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] verfolgealle
verfolge verfolgenicht

verfolgealle (Bibliotheksprozedur)

Kommando. Abkürzung für

    verfolge Inhalt
Wenn Sie eine noch detailiertere Mitschrift benötigen, um einen schwer zu findenden Fehler zu entdecken, können Sie auch noch
    verfolge Grundwörter
aufrufen.

Beispiel:

lade "am.lg
traceall
am

wird eine sehr lange Mitschrift des Asteroid Miner-Spiels ergeben.


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / verfolgenicht

verfolgenicht

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] verfolgenicht
verfolgealle Einzelschritt

verfolgenicht Inhaltsliste

Kommando. Schaltet das Verfolgen der genannten Elemente aus.

Beispiel:

verfolge namelist "a
a=1234
Make "a 1234
verfolgenicht namelist "a
a=4321


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / Einzelschritt

Einzelschritt

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] Einzelschritt
verfolgenicht stepall

Einzelschritt Contentslist

Kommando. Markiere die genannten Elemente für Einzelschritt-Ausführung. Wann immer eine für Einzelschritt markierte Prozeudr aufgerufen wird, wird jede Befehlszeile des Prozedur-Körpers ausgegeben, bevor sie ausgeführt wird, und Logo wartet dann auf den Benutzer, bis er einen Zeilenvorschub in die Konsole eingegeben hat. Eine Meldung wird ausgegeben, wann immer eine Einzelschritt-Variable überschattet wird durch die der Erstellung einer neuen lokalen Variablen mit dem selben Namen entweder als Prozedureingabe oder den "lokal"-Befehl.

Beispiele:

Einzelschritt namelist "a
a=1234
to t
    lokal "a
    a=4321
    schreibe a
end
t defined
Einzelschritt "t
t
lokal "a >>>
;  a shadowed by lokal in procedure call  in t linie 1

= "a 4321 >>>
schreibe :a >>>
4321

References:

    Versions-Informationen für Version 4.7(2), Arbeitsbereichs-Kontrolle, erneuereVariablenlisteBeiSchritt, für, stepall

verfolgenicht stepall


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / stepall

stepall

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] stepall
Einzelschritt nichteinzelschritt

stepall (Bibliotheksprozedur)

Kommando. Abkürzung für

    Einzelschritt Inhalt
Beispiel:

lade "bounce3.lg
stepall
bounce3

Example:

  • nichteinzelschritt

Reference:

    nichteinzelschritt

Einzelschritt nichteinzelschritt


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / nichteinzelschritt

nichteinzelschritt

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] nichteinzelschritt
stepall speichere

nichteinzelschritt contentslist

Kommando. Schaltet den Einzelschrittmodus für die genannten Elemente aus.

Beispiel:

lade "bounce3.lg
stepall
nichteinzelschritt Inhalt
bounce3


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / speichere

speichere

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] speichere
nichteinzelschritt speichereListe

speichere Dateiname

Kommando. Speichert die Definitionen aller nicht-versteckten Prozeduren, Variablen und Tabellen in der genannten Datei. Äquivalent zu

zu speichere :filename
    lokal "oldwriter
    setze "oldwriter schreiber

    öffnezumschreiben :filename
    setzeschreiber :filename

    poall
    setzeschreiber :oldwriter
    schließe :filename
Ende

Beachten Sie, dass Logo nicht wissen kann, in welcher Reihenfolge die Prozeduren gespeichert werden sollen, daher werden sie in alphabetischer Reihenfolge gespeichert.

Beispiel:

lade "si.lg
speichere "temp.txt

Nun enthält temp.txt die gleichen Definitionen wie si.lg (plus aller vorher im Arbeitsbereich befindlichen Prozeduren und Variablen).

Example:

  • Versions-Informationen für Version 4.7

References:

    Release Notes für Version 4.685, Versions-Informationen für Version 4.7, bearbeiteDatei, kopiereDefinition, verstecke

nichteinzelschritt speichereListe


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / speichereListe

speichereListe

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] speichereListe
speichere lade

speichereListe Inhaltsliste Dateiname (Bibliotheksprozedur)

Kommando. Speichert die Definitionen der Prozeduren, Variablen und Tabellen in der "Inhaltsliste" in der "Dateiname" genannten Datei.

Beispiel:

lade "si.lg
inhalt		;[[fractal image_right si triangle][][]] ;-)
savel "triangle "temp.txt

Nun enthält temp.txt die Definition von triangle.


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / lade

lade

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] lade
speichereListe ladeLokal

lade Dateiname

Kommando. Liest Anweisungen vom der genannten Datei und führt sie aus. Die Datei kann Prozedur-Definitionen mit "zu" oder "sei" enthalten, und diese werden sogar akzeptiert, wenn ein Prozedur gleichen Namens schon existiert. Wenn die Datei mittels "setzeStartup" eine Liste der internen Variablen "startup" zuweist, wird diese Liste als Befehlsliste ausgeführt, nachdem die Datei geladen wurde.

Beispiel:

lade "bounce3.lg
pots

wird schreiben:

to ballinit
to bat
to batinit
to bounce3
to circ size
to courtinit
to drawBall
to drawExplosions
to explosioninit
to fractal size level
to image_right tilt
to moveBall
to moveBat
to myfrbox size
to noball
to nobat
to si
to smallfrbox size size2
to stonesinit
to triangle

Examples:

  • nichteinzelschritt
  • speichereListe
  • verfolgealle
  • speichere
  • verfolge
  • stepall
  • profil

References:

    Starten und Verlassen von Logo, Versions-Informationen für Version 4.7, bearbeiteDatei, ladeLokal, nichteinzelschritt, profil, setzeStartup, speichere, speichereListe, stepall, verfolge, verfolgealle

speichereListe ladeLokal


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / ladeLokal

ladeLokal

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] ladeLokal
lade Hilfe

ladeLokal Dateiname Namensraum

Kommando. Wie "lade", lädt "ladeLokal" Logo-Anweisungenvon einer Datei gennant in "Dateiname". Aber es lädt alles in den Namensraum "Namensraum".

Beispiel:

sei p1
    ladeLokal "box.lg "p1
    zeige Inhalt
Ende
p1
[[p1 p1::box][][p1]]

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

lade Hilfe


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / Hilfe

Hilfe

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] Hilfe
ladeLokal hilfesuche

Hilfe Name
(Hilfe)

Kommando. Schreibt Information vom Handbuch über das von der Eingabe genannte Grundwort. Ohne Eingabe listet es alle Stichpunkte auf, über die Hilfe verfügbar ist. Wenn es eine Umgebungsvariable ALOGOHELP gibt, dann wird ihr Wert als das Verzeichnis angenommen, in der die Hilfe-Dateien an Stelle des Standart-Hilfe Verzeichnisses gesucht werden.

Ausnahmsweise kann der "Hilfe"-Befehl ohne seine Standart-Eingabe und ohne Klammern benutzt werden, vorausgesetzt dass ihm nichts auf der Anweisungszeile folgt.

Beispiel:

Hilfe [wort]

wird schreiben:

Help Inhalt / Data Structure Grundwörter / Constructors / Wort

Wort word1 word2
(Wort word1 word2 word3 ...)

outputs a wort formed by concatenating its inputs.

Examples:

    zeige wort "hal "lo	;hallo
    zeige (wort [wor ld])	;wor ld
    zeige (wort {a b c})	;{a b c}
    zeige wort "12 "34		;1234

next: Liste

Beispiel:

helpwalk

dient als Hilfe-Browser in der Text-Konsole, falls Sie Probleme mit der Anzeige der aucblogo.chm Datei auf ihrem Computer haben, was bei sehr hoch eingestellten Sicherheitsrichtlinien passieren kann.

Examples:

  • Versions-Informationen für Version 4.7
  • setzeLogoHilfeVerzeichnis
  • SystemaufrufAbspalten

References:

    Release Notes für Version 4.68(3), setzeLogoHilfeVerzeichnis(3), Release Notes für Version 4.65(2), LogoHilfeVerzeichnis, Release, Release Notes für Version 4.64, Release Notes für Version 4.67, Schleifen, SystemaufrufAbspalten, Versions-Informationen, Versions-Informationen für Version 4.7, WortUnterCursor, hilfesuche, setzeGroßKleinEgal

ladeLokal hilfesuche


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / hilfesuche

hilfesuche

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] hilfesuche
Hilfe Müllsammeln

hilfesuche SymbolWort (Bibliotheksprozedur)
hilfesuche ListeVonSymbolen

Sucht die Hilfe-Seiten, die zu einem oder mehreren Symbolen der Eingaben passen, und öffnet entweder einen Web-Browser, der das Thema anzeigt, oder schreibt hilfesuche-Kommandos zu Symbolen, die nahezu mit ListeVonSymbolen übereinstimmen.

Beispiele:

helpsearch [graphic]
Loading help index file c:\aucblogo\help\indexarr.txt ...
I don`t know " graphic " directly, therefore I`m searching the semantics now...
helpsearch "bg		; 789
helpsearch "loadpic		; 789
helpsearch "clearscreen		; 789
helpsearch "savepic		; 938
helpsearch "clean		; 938
helpsearch "right		; 938
helpsearch "refresh		; 1154
helpsearch "pc		; 1154
helpsearch "label		; 1154
helpsearch "background		; 1218
helpsearch "not		; 1875
helpsearch "epspict		; 2182
helpsearch "turtle-motion-queries		; 3750
helpsearch "fillrect		; 3750
helpsearch "hsb		; 3750
helpsearch "turtle-&-window-queries		; 3750
helpsearch "line		; 3750
helpsearch "turtle-&-window-control		; 3750
helpsearch "moveline		; 3750
helpsearch "rgb		; 3750
helpsearch "movepixel		; 3750
helpsearch "rergb		; 3750
helpsearch "pen-queries		; 3750
helpsearch "projection-matrix		; 3750
helpsearch "pictures		; 3750
helpsearch "pen-&-background-control		; 4056
helpsearch "turtle-motion		; 4125
helpsearch "graphelpsearchics		; 5536
helpsearch "setpixel		; 5893
helpsearch "direct-graphelpsearchics		; 8750


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / Müllsammeln

Müllsammeln

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] Müllsammeln
hilfesuche verkleinereStapel

Müllsammeln
(Müllsammeln irgendetwas)

Kommando. Läßt den Müllsammler laufen, um unbenutzte Knoten zurückzugewinnen. Logo führt dies ohnehin aus, wenn es nötig ist, aber vielleicht wollen Sie diesen Befehl benutzen, um genau zu kontrollieren, wann Logo es tut. Im Besonderen werden die Zahlen, die von der "Knoten"-Operation ausgegeben werden, nicht sehr sinnvoll sein, außer wenn Müll gesammelt worden ist. Ein anderer Grund, "Müllsammeln" zu benutzen, ist, dass eine Müllsammlung einige Augenblicke brauchen kann, und dass Sie vielleicht lieber vor oder nach einer zeitkritischen Operation Müllsammeln wollen. Wenn "Müllsammeln" mit einer Eingabe aufgerufen wird (mit beliebigem Wert), wird das komplette Müllsammeln laufengelassen, einschließlich GCTWA (Sammle Wahrlich Wertlose Knoten, was bedeutet, dass es Wörter vom Logo-Speicher entfernt, die Prozedur- oder Variablennamen waren, aber nicht mehr sind); ohne eine Eingabe führt Müllsammeln ein Generations-Müllsammeln aus, was bedeutet, dass nur die kürzlich erzeugten Knoten geprüft werden (Das letztere ist üblicherweise genug gut).

Beispiel:

(Müllsammeln wahr)

Examples:

  • setzeFensterHintergundfarbe
  • setzeFensterSchriftdicke
  • setzeFensterSchriftgröße
  • setzeFensterSchriftname
  • setzeFensterSchriftstil
  • setzeInnereFenstergröße
  • setzeFenstersizer
  • settFensterform
  • FensterAn

References:

    FensterAn, Knoten, Release Notes für Version 4.685, settFensterform, setzeFensterHintergundfarbe, setzeFensterSchriftdicke, setzeFensterSchriftgröße, setzeFensterSchriftname, setzeFensterSchriftstil, setzeFenstersizer, setzeInnereFenstergröße

hilfesuche verkleinereStapel


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / verkleinereStapel

verkleinereStapel

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] verkleinereStapel
Müllsammeln setzeStapelAusführlich

verkleinereStapel

Kommando zum Schrumpfen aller Stapel von Logo zur kleinsten Potenz von 2 größer als PAGE_SIZE (0x100) und der Anzahl von Elementen auf dem jeweiligen Stapel.

Beispiel:

zu testeStapel
    löscheText
    fülleStapel 1000000
Ende
zu fülleStapel n
    wenn n > 0 [fülleStapel n-1]
    n=n
Ende
testeStapel
verkleinereStapel

Reference:

    Release Notes für Version 4.686

Müllsammeln setzeStapelAusführlich


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeStapelAusführlich

setzeStapelAusführlich

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeStapelAusführlich
verkleinereStapel setzeErallOnRun

setzeStapelAusführlich einaus

Kommando. Setzt den Zustand der Stapel auf "ausführlich". Wenn einaus wahr ist, werden die Stapel ihre Größe schreiben, wenn sie wachsen oder schrumpfen.

Beispiel:

setzeStapelAusführlich wahr


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeErallOnRun

setzeErallOnRun

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeErallOnRun
setzeStapelAusführlich setzeFPUStatusFlags

setzeErallOnRun einaus

Kommando. einaus kann entweder wahr oder falsch sein. Wenn wahr, dann wird jedesmal, wenn der Benutzer ein Programm vom Editor aus mittels Testlauf-Abkürzungs-Tasten oder mit dem Menü ausführt, vor seiner Ausführung der Arbeitsbereich gelöscht. Das ist der Standart. Diese Zustandvariable wird beim Verlassen von Logo in die Konfiguration geschrieben, und wird beim erneuten Start von Logo wiederhergestellt.


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeFPUStatusFlags

setzeFPUStatusFlags

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeFPUStatusFlags
setzeErallOnRun setzeGenSym

setzeFPUStatusFlags ungültigeOperation denormalisierterOperand DivisionDurchNull Überlauf Unterlauf Genaugikeit maskiereUnterbrechungen

Kommando. Hauptsächlich für die Fehlersuche in aUCBLogo, kann man damit die verschiedenen Zustände der Fließkomma-Einheit setzen. Alle Parameter müssen von boolschem Typ sein.

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

setzeErallOnRun setzeGenSym


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeGenSym

setzeGenSym

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeGenSym
setzeFPUStatusFlags setzeNamensraum

setzeGenSym ganzzahl

Kommando. Setzt die interne Variable, die den Wert des genSym Zählers enthält. Dies kann nützlich sein, um dieselbe Symbol-Folge bei jedem Testlauf eines Logo-Programms erzeugen zu können, was die Fehlersuche vereinfachen kann.

Beispiel:

setzeGenSym 10
zeige GenSym		;g11

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

setzeFPUStatusFlags setzeNamensraum


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeNamensraum

setzeNamensraum

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeNamensraum
setzeGenSym setzeRedefinierbar

setzeNamensraum einname

Kommando. Setzt den aktuellen Namensraum zu einname. Dies ist nützlich für Mehrbenutzer-Anwendungen, besonders, wenn die Benutzer Logo-Befehle ausführen dürfen. Mit einem Namensraum für jeden Benutzer sind Konflikte vermeidbar. Die Benutzer können voneinander isoliert arbeiten, was Logo sicherer macht.

Beispiel:

to pr5
    schreibe 5
end
setnamespace "a
to pr5
    schreibe "a5
end
show namespace		;::a
setnamespace "
pr5		;5
a::pr5		;a5

Examples:

  • Versions-Informationen für Version 4.7
  • Namensraum

References:

    Namensraum(2), Versions-Informationen für Version 4.7

setzeGenSym setzeRedefinierbar


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeRedefinierbar

setzeRedefinierbar

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeRedefinierbar
setzeNamensraum setzeStartup

setzeRedefinierbar einaus

Kommando. Setzt die interne Zustandsvariable redefp auf den Boolschen Wert einaus. Wenn einaus wahr ist, können Grundwörter und Logo-Konstanten umdefiniert und gelöscht werden. Andernfalls ist es ein Fehler, dies zu versuchen.

Beispiel:

setzeRedefinierbar wahr
to fd :x
    forward 10*:x
end

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

setzeNamensraum setzeStartup


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeStartup

setzeStartup

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeStartup
setzeRedefinierbar setzeBenutzer

setzeStartup kommandos

Kommando. Setzt die interne Variable Startup auf die Befehlsliste kommandos. Wenn setzeStartup in einem Logo-Programm außerhalb aller Prozeduren aufgerufen wird, dann werden die kommandos am Ende des Ladevorgangs ausgeführt.

Beispiel:

setzeStartup [schreibe "bereit]

Speichern Sie dieses Beispiel als Datei xxx.lg. Wenn Sie die Datei dann mit

    lade "xxx.lg
laden, so sollte sie
    bereit
in die Konsole schreiben.

Example:

  • Versions-Informationen für Version 4.7

References:

    Versions-Informationen für Version 4.7, lade

setzeRedefinierbar setzeBenutzer


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeBenutzer

setzeBenutzer

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeBenutzer
setzeStartup setzeLadeMitAusgabe

setzeBenutzer jemand

Kommando. Setzt den Benutzer des aktiven Threads zu jemand. Der Besitzer von einem Ding ist normalerweise der Benutzer, der aktiv war zum Zeitpunkt der Erstellung des Dings. Ist der jemand das Nullwort " so ist jeder der Besitzer eines von ihm erstellten Dings, und jeder darf es z.B. löschen.

Beispiel:

setzeBenutzer "Andreas
copydef "myfd "forward
liesBesitzer "myfd		;Andreas  ;-)
setzeBenutzer "

Examples:

  • Versions-Informationen für Version 4.7
  • liesBenutzer
  • liesBesitzer

References:

    Versions-Informationen für Version 4.7, liesBenutzer, liesBesitzer

setzeStartup setzeLadeMitAusgabe


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeLadeMitAusgabe

setzeLadeMitAusgabe

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeLadeMitAusgabe
setzeBenutzer setzeFehlerAktion

setzeLadeMitAusgabe einaus

Kommando. Setzt die interne Zustandsvariable loadNoisliy. Wenn einaus wahr ist, so werden die Namen der Prozeduren bei ihrer Definiton gechrieben, wenn sie von einer Datei (auch einschließlich der Zwischendatei, die der Befehl Edit erstellt) geladen werden.


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeFehlerAktion

setzeFehlerAktion

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeFehlerAktion
setzeLadeMitAusgabe setzeLogoSprache

setzeFehlerAktion befehle

Kommando. Setzt die interne Variable erract auf die Befehlsliste befehle, die dann im Fehlerfall ausgeführt wird. Der typische Inhalt von befehle ist [pause], um interaktive Fehlersuche zu erlauben. Standartwert von erract ist die leere Liste [].


HC / Arbeitsbereiche / Arbeitsbereichs-Kontrolle / setzeLogoSprache

setzeLogoSprache

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Kontrolle [image] setzeLogoSprache
setzeFehlerAktion Arbeitsbereichs-Fragen

setzeLogoSprache sprache

Kommando. Setzt die Logo-Sprache auf das Wort sprache.

sprache: entweder "ucblogo oder "aucblogo bis jetzt.

Wenn Sie "ucblogo wählen, versucht aUCBLogo, UCBLogo so gut wie möglich zu immitieren. Ein Problem stellen allerdings die getrennten Namensräume für Variablen und Prozeduren in UCBLogo dar, was in aUCBLogo nicht möglich ist, da es dort nur einen gemeinsamen Namensraum gibt.

Example:

  • Versions-Informationen für Version 4.7

References:

    Einführung in die Logo-Programmierung, Element, Versions-Informationen für Version 4.7

setzeFehlerAktion Arbeitsbereichs-Fragen


HC / Arbeitsbereiche / Arbeitsbereichs-Fragen

Arbeitsbereichs-Fragen

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Fragen
setzeLogoSprache ProzedurP

Arbeitsbereichs-Fragen

...stellen boolsche Fragen zu Wurzel-Tabellen-Einträgen, d.h. z.B. ob etwas eine Prozedur, ein Grundwort oder eine Variable ist.

Arbeitsbereichs-Fragen

  • ProzedurP
  • GrundwortP
  • definiertP
  • VariablenNameP
  • GroßKleinEgalP


HC / Arbeitsbereiche / Arbeitsbereichs-Fragen / ProzedurP

ProzedurP

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Fragen [image] ProzedurP
Arbeitsbereichs-Fragen GrundwortP

ProzedurP Name
Prozedur? Name

Ausgabe ist wahr, wenn die Eingabe der Name einer Prozedur ist. Logo kennt keine Prozedur, die noch nicht geladen wurde. Es kennt nur die Grundwörter beim Start.

Beispiele:

Prozedur? "vorwärts		;wahr  ;-)
Prozedur? "tree		;falsch  ;-)
tree
Prozedur? "tree		;wahr  ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Fragen / GrundwortP

GrundwortP

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Fragen [image] GrundwortP
ProzedurP definiertP

GrundwortP Name
Grundwort? Name

Ausgabe ist wahr, wenn die Eingabe der Name eines Grundworts ist (ein in Logo eingebautes). Beachten Sie, dass einige in diesem Dokument beschriebene Prozeduren Bibliotheks-Prozeduren sind, nicht Grundwörter.

Beispiele:

Grundwort? "vorwärts		;wahr  ;-)
tree
Grundwort? "tree		;falsch  ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Fragen / definiertP

definiertP

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Fragen [image] definiertP
GrundwortP VariablenNameP

definiertP Name
Definiert? Name

Ausgabe ist wahr, wenn die Eingabe der Name einer Benutzer-definierten Prozedur ist, einschließlich einer Bibliotheksprozedur ist. (Allerdings, weiß Logo nichts über eine Bibliotheksprozedur, ehe diese Prozedur aufgerufen worden wurde.)

Beispiele:

definiert? "vorwärts		;falsch  ;-)
definiert? "tree		;falsch  ;-)
tree
definiert? "tree		;wahr  ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Fragen / VariablenNameP

VariablenNameP

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Fragen [image] VariablenNameP
definiertP GroßKleinEgalP

VariablenNameP Name
VariablenName? Name

Ausgabe ist wahr, wenn die Eingabe der Name einer Variablen ist.

Beispiele:

setze "a 1234
VariablenName? "a		;wahr  ;-)
b=[something]
VariablenName? "b		;wahr  ;-)


HC / Arbeitsbereiche / Arbeitsbereichs-Fragen / GroßKleinEgalP

GroßKleinEgalP

HC [image] Arbeitsbereiche [image] Arbeitsbereichs-Fragen [image] GroßKleinEgalP
VariablenNameP Editieren

GroßKleinEgalP
GroßKleinEgal?

Ausgabe ist wahr, wenn Groß- und Kleingeschriebene Buchstaben für "gleich?", "vorher?", "Element?" etc. nicht unterschieden werden sollen. Logo setzt diesen internen Zustand am Anfang auf wahr.

Beispiel:

setzeGroßKleinEgal falsch
GroßKleinEgal?		;falsch  ;-)
bUtFirst "Hallo		; I don't know how  to bUtFirst
ohneErstes "World		;orld  ;-)
ohneerstes [so so]		;[so] ;-)

Reference:

    Release Notes für Version 4.64

VariablenNameP Editieren


HC / Arbeitsbereiche / Editieren

Editieren

HC [image] Arbeitsbereiche [image] Editieren
GroßKleinEgalP bearbeite

Editieren

Hie sind Kommandos zu Aufrufen eines externen Editors mit entweder einer temporären Datei ("bearbeite") oder einer bestimmten Datei ("bearbeiteDatei"). Und es gibt Mengen von Abkürzungen.

Aber wahrscheinlich werden Sie diese Kommandos nicht brauchen, wenn Sie Ihre Programme im internen Logo-Editor oder in einem externen Editor wie Crimson Editor bearbeiten. Wenn Sie ein Programm x.lg haben und eine Prozedur X in x.lg, dann können Sie x ausführen durch den Aufruf in der Befehlszeile
    aucblogo.exe x.lg
Solch ein Kommando können Sie einer Abkürzungstaste wie F9 in Ihrem Editor zuweisen, dann ist die Fehlersuche wirklich bequemer als bei Benützung von edall. Ein weiterer Vorteil dabei, "aucblogo.exe x.lg" lieber zu benutzen, als edall, ist, dass die Reihenfolge Ihrer Prozeduren nicht verändert wird.

Editieren

  • bearbeite
  • bearbeiteDatei
  • edall
  • edps
  • edns
  • edpls
  • edn
  • edpl

References:

    Versions-Informationen für Version 4.7, bearbeite

GroßKleinEgalP bearbeite


HC / Arbeitsbereiche / Editieren / bearbeite

bearbeite

HC [image] Arbeitsbereiche [image] Editieren [image] bearbeite
Editieren bearbeiteDatei

bearbeite Inhaltsliste
(bearbeite)

Kommando. Wenn "bearbeite" mit einer Eingabe aufgerufen wird, schreibt es die Definitionen der genannten Elemente in eine temporäre Datei und ruft Ihren bevorzugten Editor auf, wie er mit der AEDITOR Umgebungsvariablen festgelegt wurde. Wenn Sie keine AEDITOR Variable haben, verwendet "bearbeite" den internen Editor.

Wenn Sie den Editor verlassen, liest Logo die überarbeiteten Definitionen und varändert den Arbeitsbereich dementsprechend. Es ist kein Fehler, wenn die Eingabe Namen enthält, für die es keine bisherige Definition gibt.

Wenn es eine ATEMP genannte Umgebungsvariable gibt, dann verwendet Logo ihren Wert als das Verzeichnis, in dem die temporäre Datei geschrieben wird, die für das Editieren benutzt wird.

Ausnahmsweise kann der "bearbeite"-Befehl ohne seine Standart-Eingabe und ohne Klammern benutzt werden, vorausgesetzt dass ihm nichts auf der Anweisungszeile folgt.

Beispiel:

si		;227.375
bearbeite "si

See also:

  • bearbeiteDatei

References:

    bearbeiteDatei(3), KombiBox(2), Editieren, KombiBoxWert, KombiBoxen, LogoTemporäresVerzeichnis, Release Notes für Version 4.67, Release Notes für Version 4.682, TextControls, Volltext, Zahlboxen, beiKombiBoxÄnderung, edall, edn, edns, edpl, edpls, edps, ladeMitAnzeige, setzeKombiBoxWert, setzeLogoEditor, setzeLogoTemporäresVerzeichnis

Editieren bearbeiteDatei


HC / Arbeitsbereiche / Editieren / bearbeiteDatei

bearbeiteDatei

HC [image] Arbeitsbereiche [image] Editieren [image] bearbeiteDatei
bearbeite edall

bearbeiteDatei Dateibezeichnung

Kommando. Startet den Logo-Editor, wie bearbeite, aber an Stelle eine temporäre Datei zu verwenden, wird die durch die Eingabe angegebene Datei verwendet. Wenn Sie den Editor verlassen, liest Logo die bearbeitete Datei, wie bei "bearbeite". "bearbeiteDatei" erinnert sich auch an die Dateibezeichnung, so dass ein nachfolgender "bearbeite"-Befehl ohne Eingabe wieder die gleiche Datei bearbeiten wird.

"bearbeiteDatei" ist als Alternative zu "lade" und "speichere" gedacht. So können Sie eine Arbeitsbereichsdatei selbst managen, und selbst die Reihenfolge festlegen, in der Definitionen aufeinander folgen, Bemerkungen in der Datei aufrechterhalten, und so weiter.

Beispiel:

bearbeitedatei "si.lg

References:

    Editieren, Release Notes für Version 4.682

bearbeite edall


HC / Arbeitsbereiche / Editieren / edall

edall

HC [image] Arbeitsbereiche [image] Editieren [image] edall
bearbeiteDatei edps

edall

Kommando. Abkürzung für

    bearbeite Inhalt

Reference:

    Editieren(2)

bearbeiteDatei edps


HC / Arbeitsbereiche / Editieren / edps

edps

HC [image] Arbeitsbereiche [image] Editieren [image] edps
edall edns

edps (Bibliotheksprozedur)

Kommando. Abkürzung für


HC / Arbeitsbereiche / Editieren / edns

edns

HC [image] Arbeitsbereiche [image] Editieren [image] edns
edps edpls

edns (Bibliotheksprozedur)

Kommando. Abkürzung für


HC / Arbeitsbereiche / Editieren / edpls

edpls

HC [image] Arbeitsbereiche [image] Editieren [image] edpls
edns edn

edpls (Bibliotheksprozedur)

Kommando. Abkürzung für

    bearbeite Tabellen


HC / Arbeitsbereiche / Editieren / edn

edn

HC [image] Arbeitsbereiche [image] Editieren [image] edn
edpls edpl

edn VarName (Bibliotheksprozedur)
edn VarNamenListe

Kommando. Abkürzung für

    bearbeite namensliste VarName


HC / Arbeitsbereiche / Editieren / edpl

edpl

HC [image] Arbeitsbereiche [image] Editieren [image] edpl
edn Löschen

edpl plname
edpl plnamelist (Bibliotheksprozedur)

Kommando. Abkürzung für

    bearbeite pllist plname


HC / Arbeitsbereiche / Löschen

Löschen

HC [image] Arbeitsbereiche [image] Löschen
edpl vergiß

Löschen

...ist oft praktischer als Herausgehen aus Logo - und es nochmals zu starten. Deswegen gibt es den "vergiß"-Befehl und seine Abkürzungen.

Aber verwechseln Sie "vergiß" nicht mit "löscheDatei"! "vergiß" und seine Abkürzungen werden nur etwas vom Arbeitsbereich vergessen.

Löschen

  • vergiß
  • vergißAlle
  • vergißProzeduren
  • vergißVariablen
  • vergißTabellen
  • ern
  • erpl
  • reset

References:

    Release Notes für Version 4.65(2), Versions-Informationen für Version 4.7(2), Arbeitsbereiche, löscheSchatten, setzeBenutzer, wirf

edpl vergiß


HC / Arbeitsbereiche / Löschen / vergiß

vergiß

HC [image] Arbeitsbereiche [image] Löschen [image] vergiß
Löschen vergißAlle

vergiß Inhaltsliste

Kommando. Löscht vom Arbeitsbereich die in der Eingabe genannten Prozeduren, Variablen und Tabellen. Grundwort-Prozeduren können nicht gelöscht werden, außer wenn "umdefinierbar?" den Wert wahr hat.

Beispiel:

si		;170.634
Inhalt		;[[fractal image_right si triangle][t][]] ;-)
vergiß "si
Inhalt		;[[fractal image_right triangle][t][]] ;-)

See also:

  • ern

Example:

  • Knoten

References:

    Löschen(3), Knoten, ern, erpl, vergißAlle, vergißProzeduren, vergißTabellen, vergißVariablen

Löschen vergißAlle


HC / Arbeitsbereiche / Löschen / vergißAlle

vergißAlle

HC [image] Arbeitsbereiche [image] Löschen [image] vergißAlle
vergiß vergißProzeduren

vergißAlle

Kommando. Löscht alle nicht versteckten Prozeduren, Variablen und Tabellen vom Arbeitsbereich. Abkürzung für

    vergiß Inhalt

References:

    Release Notes für Version 4.64, reset

vergiß vergißProzeduren


HC / Arbeitsbereiche / Löschen / vergißProzeduren

vergißProzeduren

HC [image] Arbeitsbereiche [image] Löschen [image] vergißProzeduren
vergißAlle vergißVariablen

vergißProzeduren

Kommando. Löscht alle nicht versteckten Prozeduren vom Arbeitsbereich. Abkürzung für

    vergiß Prozeduren

Reference:

    Release Notes für Version 4.64

vergißAlle vergißVariablen


HC / Arbeitsbereiche / Löschen / vergißVariablen

vergißVariablen

HC [image] Arbeitsbereiche [image] Löschen [image] vergißVariablen
vergißProzeduren vergißTabellen

vergißVariablen (Bibliotheksprozedur)

Kommando. Löscht alle nicht versteckten Variablen vom Arbeitsbereich. Abkürzung für

    vergiß VariablenNamen

Reference:

    Release Notes für Version 4.64

vergißProzeduren vergißTabellen


HC / Arbeitsbereiche / Löschen / vergißTabellen

vergißTabellen

HC [image] Arbeitsbereiche [image] Löschen [image] vergißTabellen
vergißVariablen ern

vergißTabellen

Kommando. Löscht alle nicht versteckten Tabellen vom Arbeitsbereich. Abgkürzung für

    vergiß Tabellen


HC / Arbeitsbereiche / Löschen / ern

ern

HC [image] Arbeitsbereiche [image] Löschen [image] ern
vergißTabellen erpl

ern VarName
ern VarNamenListe (Bibliotheksprozedur)

Kommando. Löscht von dem Arbeitsbereich, den das variable(s) in der Eingabe nannte. Abkürzt vergiß NAMELIST VarName(liste).

Beispiel:

a=1234
ern "a
a		; I don't know how  to a

Examples:

  • setzeFensterHintergundfarbe
  • setzeFensterSchriftdicke
  • setzeFensterSchriftgröße
  • setzeFensterSchriftname
  • setzeFensterSchriftstil
  • setzeInnereFenstergröße
  • setzeFenstersizer
  • settFensterform
  • FensterAn

References:

    FensterAn, settFensterform, setzeFensterHintergundfarbe, setzeFensterSchriftdicke, setzeFensterSchriftgröße, setzeFensterSchriftname, setzeFensterSchriftstil, setzeFenstersizer, setzeInnereFenstergröße

vergißTabellen erpl


HC / Arbeitsbereiche / Löschen / erpl

erpl

HC [image] Arbeitsbereiche [image] Löschen [image] erpl
ern reset

erpl plname
erpl plnamelist (Bibliotheksprozedur)

Kommando. Löscht vom Arbeitsbereich die in der Eingabe genannte Tabelle. Abkürzung für

    vergiß pllist plname


HC / Arbeitsbereiche / Löschen / reset

reset

HC [image] Arbeitsbereiche [image] Löschen [image] reset
erpl Makros

reset (Bibliotheksprozedur)

Kommando, das verschiedenste Grundwörter verwendet, um den Interpreter in einen bekannten Zustand zurückzusetzen.

reset.lg sieht momentan so aus:

zu reset
    setzeGroßKleinEgal wahr
    vergißAlle
    löscheSchirm
    setzeGraphAktualisieren wahr
    setzeStiftfarbe 0
    setzeHintergrundfarbe 7
    setzeFüllfarbe 0
    setzeStiftdicke [1 1]
    ZylinderlinienAus
    LinienglättungAn
    setzeSchriftname [Times]
    zeigIgel
    StiftAb
    setzeUmgebungslicht rgb 0.1 0.1 0.1
    setzeDiffusesLicht rgb 1 1 1
    zweidimensional
    aufzeichnen
    DoppelPufferung
    Randsprung
    EinfügeModus
Ende

Examples:

  • beiLosgelassenerTasteInGraph
  • beiGedrückterTasteInGraph
  • beiGraphZeichen
  • Midi Tabelle
  • Inhalt

References:

    Inhalt, Midi Tabelle, Release, beiGedrückterTasteInGraph, beiGraphZeichen, beiLosgelassenerTasteInGraph

erpl Makros


HC / Makros

Makros

HC [image] Makros
reset _Makro

Makros

...sind Prozeduren, die eine Befehlsliste ausgeben, die dann im Kontext des Aufrufers ausgeführt wird.

Makros

  • _Makro
  • MakroP
  • macroexpand

References:

    _Makro(2), MakroP, macroexpand

reset _Makro


HC / Makros / _Makro

_Makro

HC [image] Makros [image] _Makro
Makros MakroP

_Makro Prozedurname :Eingabe1 :Eingabe2... (besondere Form)
_defMakro Prozedurname ProzedurText

TODO: noch fertig übersetzen

Ein Makro ist eine besondere Art von Prozedur, deren Ausgabe als Logo-Anweisungen im Kontext des Aufrufers des Makros ausgewertet wird. _makro ist genau wie "zu", ausser dass die neue Prozedur ein Makro wird; _defmakro ist genau wie "definiere", mit derselben Ausnahme.

Makros sind nützlich für das Erfinden neuer Kontroll-Strukturen, die vergleichbar zu "wiederhole", "wenn", und so weiter, sind. Solche Kontroll-Strukturen können fast, aber nicht ganz, mit normalen Logo-Prozeduren nachgebaut werden.

Zum Beispiel, hier ist eine einfache Prozedur-Version von "wiederhole":

zu my_repeat :num :instructions
    wenn :num=0 [stop]
    führeAus :instructions
    my_repeat :num-1 :instructions
Ende

Diese Version funktioniert gut für die meisten Zwecke, z.B.,

my_repeat 5 [schreibe "hello]

Aber sie funktioniert nicht, wenn die auszuführenden Anweisungen Ausgabe, Halt oder lokal enthalten.

Zum Beispiel, betrachten Sie diese Prozedur:

zu example
    schreibe [Guess my secret word.  You get three guesses.]
    wiederhole 3 ~
    [
        tippe "??
        wenn lieswort = "secret [schreibe "Right! stop]
    ]
    schreibe [Sorry, the wort was "secret"!]
Ende

This procedure works as written, but wenn MY_REPEAT is used instead of WIEDERHOLE, it won't work because the STOP will stop MY_REPEAT instead of stopping EXAMPLE as desired.

The solution is to setze MY_REPEAT a macro. Instead of actually carrying out the computation, a macro must return a liste containing Logo instructions. The inhalt of that liste are evaluated as wenn they appeared in place of the call to the macro. Here's a macro version of WIEDERHOLE:

_makro my_repeat :num :instructions
    wenn :num=0 [output []]
    output satz :instructions ~
        (liste "my_repeat :num-1 :instructions)
end

Every macro is an operation -- it must always output something. Even in the base Fall, MY_REPEAT outputs an empty instruction list.

To zeige how MY_REPEAT works, let's take the example

my_repeat 5 [schreibe "hello]

For dies example, MY_REPEAT will output the instruction liste

[schreibe "hello my_repeat 4 [schreibe "hello]]

Logo then executes these instructions in place of the original invocation of MY_REPEAT; dies prints "hello" once und invokes another repetition.

The technique just shown, although fairly easy to understand, has the defect of slowness because each repetition has to construct an instruction liste für evaluation. Another approach is to setze my_repeat a macro that works just like the non-macro version unless the instructions to be repeated include OUTPUT oder STOP:

_makro my_repeat :num :instructions
    fange "repeat_catchtag ~
          [op repeat_done führeausmitausgabe [repeat1 :num :instructions]]
    op []
end

to repeat1 :num :instructions
    wenn :num=0 [wirf "repeat_catchtag]
    führeAus :instructions
    _vielleichtAusgabe repeat1 :num-1 :instructions
end

to repeat_done :repeat_result
    wenn leerp :repeat_result [op [stop]]
    op liste "output quoted erstes :repeat_result
end

If the instructions do nicht include STOP oder OUTPUT, then REPEAT1 will reach its base Fall und invoke THROW. As a result, my_repeat's letztes instruction linie will output an empty liste, so the second evaluation of the macro result will do nothing. But wenn a STOP oder OUTPUT happens, then REPEAT_DONE will output a STOP oder OUTPUT instruction that will be re-executed in the caller's context.

The macro-defining commands have variablennamen starting with a dot because macros are an advanced feature of Logo; it's easy to get in trouble by defining a macro that doesn't terminate, oder by failing to construct the instruction liste properly.

Lisp users should note that Logo macros are nicht special forms. That is, the inputs to the macro are evaluated normally, as they would be für any other Logo procedure. It's only the output from the macro that's handled unusually.

Here's another example:

_makro localmake :name :value
    output (liste "lokal		~
             wort "" :name	~
             "wendeAn		~
             ""setze		~
             (liste :name :value))
end

It's used dies way:

to try
    localmake "garply "hello
    schreibe :garply
end

LOCALMAKE outputs the liste

    [lokal "garply wendeAn "setze [garply hello]]
The reason für the use of WENDEAN is to avoid having to decide whether oder nicht the second input to SETZE requires a quotation mark before it. (In dies Fall it would -- SETZE "GARPLY "HELLO -- but the quotation mark would be wrong wenn the value were a list.)

It's often convenient to use the ` function to construct the instruction liste:

_makro localmake :name :value
    op `[lokal ,[wort "" :name] wendeAn "setze [,[:name] ,[:value]]]
end

On the other hand, ` is pretty slow, since it's tree recursive und written in Logo.

Example:

  • macroexpand

Reference:

    macroexpand

Makros MakroP


HC / Makros / MakroP

MakroP

HC [image] Makros [image] MakroP
_Makro macroexpand

MakroP Name
Makro? Name

Ausgabe ist wahr, wenn die Eingabe der Name eines Makros ist.


HC / Makros / macroexpand

macroexpand

HC [image] Makros [image] macroexpand
MakroP Grafiken

macroexpand expr (Bibliotheksprozedur)

nimmt als ihre Eingabe einen Logo-Ausdruck, der ein Makro aufruft (das ist einer, der mit dem Namen eines Makros anfängt) und gibt den Logo Ausdruck aus, in den das Makro den Eingabeausdruck übersetzen würde.

_makro localmake :name :value
    op `[lokal ,[wort "" :name] wendeAn "setze [,[:name] ,[:value]]]
Ende

zeige macroexpand [localmake "pi 3.14159]
;[lokal "pi wendeAn "setze [pi 3.14159]]


HC / Grafiken

Grafiken

HC [image] Grafiken
macroexpand Farb-Datenbank

Grafiken

aUCBLogo bietet traditionelle Logo-Igel Grafik mit einem oder mehreren Igeln. Zusammenstösse werden noch nicht erkannt. Dies ist einer der am meisten hardwareabhängigen Teile von Logo; einige Merkmale können auf einer bestimmten Maschine existieren, andere nicht. Trotzdem war das Ziel, Logo-Programme so übertragbar wie möglich zu machen, eher als sämtliche Möglichkeiten jeder Maschine zu nutzen. Im Besonderen versucht Logo, das Grafik-Fenster so zu skalieren, dass die Igel-Koordinaten [-400 -300] und [400 300] ins Grafik-Fenster passen, und so, dass der Abbildungsmaßstab 1:1 ist, obwohl einige Bildschirme nichtstandardmäßige Abbildungsmaßstäbe haben.

Das Zentrum vom Grafik-Fenster (das mag oder mag nicht der ganze Bildschirm sein, je nach der benutzten Maschine) ist Igel Standort [0 0]. Positives X ist nach rechts; positives Y ist nach oben. Richtungen (Winkel) werden in Grad im Uhrzeigersinn gemessen, ausgehend von der Y-Achse (dies weicht von der üblichen mathematischen Übereinkunft der Winkelmessung im Uhrzeigersinn ausgehend von der X-Achse ab). Der Igel wird als gleichschenkliges Dreieck dargestellt; der eigentliche Igel-Ort befindet sich in der Mitte der Basis (der kurzen Linie).

Farben sind, natürlich, hardwareabhängig. Jedoch bietet Logo teilweise Hardware-Unabhängigkeit dadurch, daß es die Farbnummern 0 bis 7 auf allen Rechnern gleich auslegt:

0  Schwarz      1  Blau         2  Grün         3  Cyan
4  Rot          5  Magenta      6  Gelb         7  Weiss

Wo es möglich ist, bietet Logo zusätzliche benutzerdefinierbare Farben; wieviele jedoch verfügbar sind, hängt von der Hardware und dem Betriebssystem ab. Wenn wenigstens 16 Farben verfügbar sind, versucht Logo auch für die Farbnummern 8..15 einheitliche Anfangsbedingungen zu setzen:

 8  Braun      9  Tang          10  Wald         11  wasser
12  Lachs     13  Violett       14  Orange       15  Grau

Logo beginnt mit einem weissen Hintergrund und einem schwarzen Stift.

Grafiken

  • Farb-Datenbank
  • Relative Igel-Bewegung
  • Absolute Igel-Bewegung
  • Igel Bewegungs-Abfragen
  • Igel-Kontrolle
  • Fenster-Kontrolle
  • Igel- und Fenster-Fragen
  • Mehrere Igel
  • Schreibstift- und Hintergrund-Kontolle
  • Schalterfunktionen
  • Schreibstift-Abfragen
  • Kurven-Zeichnen
  • Text Zeichnen
  • Zeichnung gefüllter Formen
  • Beleuchtung
  • Nebel
  • Bilder
  • Bitmaps
  • Direkte Grafik
  • Projektions-Matrix
  • Texturierung
  • Schatten

References:

    IgelFormen, Relative Igel-Bewegung, setzeIgelFormen

macroexpand Farb-Datenbank


HC / Grafiken / Farb-Datenbank

Farb-Datenbank

HC [image] Grafiken [image] Farb-Datenbank
Grafiken Relative Igel-Bewegung

Farb-Datenbank

Farben können auch durch Namen gesetzt werden, aber die Farbdatenbank von wxWidgets ist auf die Folgende Liste beschränkt (RGB8 ist wie RGB r/255 g/255 b/255), aber beachten Sie, es gibt eine zweite Liste von noch mehr Farben nach dem Ende der ersten Farbliste. Die Farbwerte des zuerst in der Liste gefundenen Farbnamens werden genommen. Sie können die vollständige Liste von verfügbaren Farben holen mit dem Grundwort liesFarbDatenbank.

"AQUAMARINE RGB8 112 219 147
"BLACK RGB8 0 0 0
"BLUE RGB8  0 0 255
"BLUE VIOLET RGB8  159 95 159
"BROWN RGB8  165 42 42
"CADET BLUE RGB8  95 159 159
"CORAL RGB8  255 127 0
"CORNFLOWER BLUE RGB8  66 66 111
"CYAN RGB8  0 255 255
"DARK GREY RGB8  47 47 47
"DARK GREEN RGB8  47 79 47
"DARK OLIVE GREEN RGB8  79 79 47
"DARK ORCHID RGB8  153 50 204
"DARK SLATE BLUE RGB8  107 35 142
"DARK SLATE GREY RGB8  47 79 79
"DARK TURQUOISE RGB8  112 147 219
"DIM GREY RGB8  84 84 84
"FIREBRICK RGB8  142 35 35
"FOREST GREEN RGB8  35 142 35
"GOLD RGB8  204 127 50
"GOLDENROD RGB8  219 219 112
"GREY RGB8  128 128 128
"GREEN RGB8  0 255 0
"GREEN YELLOW RGB8  147 219 112
"INDIAN RED RGB8  79 47 47
"KHAKI RGB8  159 159 95
"LIGHT BLUE RGB8  191 216 216
"LIGHT GREY RGB8  192 192 192
"LIGHT STEEL BLUE RGB8  143 143 188
"LIME GREEN RGB8  50 204 50
"LIGHT MAGENTA RGB8  255 0 255
"MAGENTA RGB8  255 0 255
"MAROON RGB8  142 35 107
"MEDIUM AQUAMARINE RGB8  50 204 153
"MEDIUM GREY RGB8  100 100 100
"MEDIUM BLUE RGB8  50 50 204
"MEDIUM FOREST GREEN RGB8  107 142 35
"MEDIUM GOLDENROD RGB8  234 234 173
"MEDIUM ORCHID RGB8  147 112 219
"MEDIUM SEA GREEN RGB8  66 111 66
"MEDIUM SLATE BLUE RGB8  127 0 255
"MEDIUM SPRING GREEN RGB8  127 255 0
"MEDIUM TURQUOISE RGB8  112 219 219
"MEDIUM VIOLET RED RGB8  219 112 147
"MIDNIGHT BLUE RGB8  47 47 79
"NAVY RGB8  35 35 142
"ORANGE RGB8  204 50 50
"ORANGE RED RGB8  255 0 127
"ORCHID RGB8  219 112 219
"PALE GREEN RGB8  143 188 143
"PINK RGB8  188 143 234
"PLUM RGB8  234 173 234
"PURPLE RGB8  176 0 255
"RED RGB8  255 0 0
"SALMON RGB8  111 66 66
"SEA GREEN RGB8  35 142 107
"SIENNA RGB8  142 107 35
"SKY BLUE RGB8  50 153 204
"SLATE BLUE RGB8  0 127 255
"SPRING GREEN RGB8  0 255 127
"STEEL BLUE RGB8  35 107 142
"TANGENS RGB8  219 147 112
"THISTLE RGB8  216 191 216
"TURQUOISE RGB8  173 234 234
"VIOLET RGB8  79 47 79
"VIOLET RED RGB8  204 50 153
"WHEAT RGB8  216 216 191
"WHITE RGB8  255 255 255
"YELLOW RGB8  255 255 0
"YELLOW GREEN RGB8  153 204 50

Hier ist eine lange Liste von zusätzlichen Farben, die ich als farben.h in die wxWidgets-Bibliotheks-Datei gdicmn.cpp eingefügt habe, so dass sie jetzt alle in aUCBLogo verfügbar sind.

"ALICEBLUE RGB8 240 248 255
"ANTIQUEWHITE RGB8 250 235 215
"ANTIQUEWHITE1 RGB8 255 239 219
"ANTIQUEWHITE2 RGB8 238 223 204
"ANTIQUEWHITE3 RGB8 205 192 176
"ANTIQUEWHITE4 RGB8 139 131 120
"AQUAMARINE RGB8 127 255 212
"AQUAMARINE1 RGB8 127 255 212
"AQUAMARINE2 RGB8 118 238 198
"AQUAMARINE3 RGB8 102 205 170
"AQUAMARINE4 RGB8 69 139 116
"AZURE RGB8 240 255 255
"AZURE1 RGB8 240 255 255
"AZURE2 RGB8 224 238 238
"AZURE3 RGB8 193 205 205
"AZURE4 RGB8 131 139 139
"BEIGE RGB8 245 245 220
"BISQUE RGB8 255 228 196
"BISQUE1 RGB8 255 228 196
"BISQUE2 RGB8 238 213 183
"BISQUE3 RGB8 205 183 158
"BISQUE4 RGB8 139 125 107
"BLACK RGB8 0 0 0
"BLANCHEDALMOND RGB8 255 235 205
"BLUE RGB8 0 0 255
"BLUE1 RGB8 0 0 255
"BLUE2 RGB8 0 0 238
"BLUE3 RGB8 0 0 205
"BLUE4 RGB8 0 0 139
"BLUEVIOLET RGB8 138 43 226
"BROWN RGB8 165 42 42
"BROWN1 RGB8 255 64 64
"BROWN2 RGB8 238 59 59
"BROWN3 RGB8 205 51 51
"BROWN4 RGB8 139 35 35
"BURLYWOOD RGB8 222 184 135
"BURLYWOOD1 RGB8 255 211 155
"BURLYWOOD2 RGB8 238 197 145
"BURLYWOOD3 RGB8 205 170 125
"BURLYWOOD4 RGB8 139 115 85
"CADETBLUE RGB8 95 158 160
"CADETBLUE1 RGB8 152 245 255
"CADETBLUE2 RGB8 142 229 238
"CADETBLUE3 RGB8 122 197 205
"CADETBLUE4 RGB8 83 134 139
"CHARTREUSE RGB8 127 255 0
"CHARTREUSE1 RGB8 127 255 0
"CHARTREUSE2 RGB8 118 238 0
"CHARTREUSE3 RGB8 102 205 0
"CHARTREUSE4 RGB8 69 139 0
"CHOCOLATE RGB8 210 105 30
"CHOCOLATE1 RGB8 255 127 36
"CHOCOLATE2 RGB8 238 118 33
"CHOCOLATE3 RGB8 205 102 29
"CHOCOLATE4 RGB8 139 69 19
"CORAL RGB8 255 127 80
"CORAL1 RGB8 255 114 86
"CORAL2 RGB8 238 106 80
"CORAL3 RGB8 205 91 69
"CORAL4 RGB8 139 62 47
"CORNFLOWERBLUE RGB8 100 149 237
"CORNSILK RGB8 255 248 220
"CORNSILK1 RGB8 255 248 220
"CORNSILK2 RGB8 238 232 205
"CORNSILK3 RGB8 205 200 177
"CORNSILK4 RGB8 139 136 120
"CYAN RGB8 0 255 255
"CYAN1 RGB8 0 255 255
"CYAN2 RGB8 0 238 238
"CYAN3 RGB8 0 205 205
"CYAN4 RGB8 0 139 139
"DARKBLUE RGB8 0 0 139
"DARKCYAN RGB8 0 139 139
"DARKGOLDENROD RGB8 184 134 11
"DARKGOLDENROD1 RGB8 255 185 15
"DARKGOLDENROD2 RGB8 238 173 14
"DARKGOLDENROD3 RGB8 205 149 12
"DARKGOLDENROD4 RGB8 139 103 11
"DARKGREEN RGB8 0 100 0
"DARKGREY RGB8 169 169 169
"DARKKHAKI RGB8 189 183 107
"DARKMAGENTA RGB8 139 0 139
"DARKOLIVEGREEN RGB8 85 107 47
"DARKOLIVEGREEN1 RGB8 202 255 112
"DARKOLIVEGREEN2 RGB8 188 238 104
"DARKOLIVEGREEN3 RGB8 162 205 90
"DARKOLIVEGREEN4 RGB8 110 139 61
"DARKORANGE RGB8 255 140 0
"DARKORANGE1 RGB8 255 127 0
"DARKORANGE2 RGB8 238 118 0
"DARKORANGE3 RGB8 205 102 0
"DARKORANGE4 RGB8 139 69 0
"DARKORCHID RGB8 153 50 204
"DARKORCHID1 RGB8 191 62 255
"DARKORCHID2 RGB8 178 58 238
"DARKORCHID3 RGB8 154 50 205
"DARKORCHID4 RGB8 104 34 139
"DARKRED RGB8 139 0 0
"DARKSALMON RGB8 233 150 122
"DARKSEAGREEN RGB8 143 188 143
"DARKSEAGREEN1 RGB8 193 255 193
"DARKSEAGREEN2 RGB8 180 238 180
"DARKSEAGREEN3 RGB8 155 205 155
"DARKSEAGREEN4 RGB8 105 139 105
"DARKSLATEBLUE RGB8 72 61 139
"DARKSLATEGRAY RGB8 47 79 79
"DARKSLATEGRAY1 RGB8 151 255 255
"DARKSLATEGRAY2 RGB8 141 238 238
"DARKSLATEGRAY3 RGB8 121 205 205
"DARKSLATEGRAY4 RGB8 82 139 139
"DARKTURQUOISE RGB8 0 206 209
"DARKVIOLET RGB8 148 0 211
"DEEPPINK RGB8 255 20 147
"DEEPPINK1 RGB8 255 20 147
"DEEPPINK2 RGB8 238 18 137
"DEEPPINK3 RGB8 205 16 118
"DEEPPINK4 RGB8 139 10 80
"DEEPSKYBLUE RGB8 0 191 255
"DEEPSKYBLUE1 RGB8 0 191 255
"DEEPSKYBLUE2 RGB8 0 178 238
"DEEPSKYBLUE3 RGB8 0 154 205
"DEEPSKYBLUE4 RGB8 0 104 139
"DIMGREY RGB8 105 105 105
"DODGERBLUE RGB8 30 144 255
"DODGERBLUE1 RGB8 30 144 255
"DODGERBLUE2 RGB8 28 134 238
"DODGERBLUE3 RGB8 24 116 205
"DODGERBLUE4 RGB8 16 78 139
"FIREBRICK RGB8 178 34 34
"FIREBRICK1 RGB8 255 48 48
"FIREBRICK2 RGB8 238 44 44
"FIREBRICK3 RGB8 205 38 38
"FIREBRICK4 RGB8 139 26 26
"FLORALWHITE RGB8 255 250 240
"FORESTGREEN RGB8 34 139 34
"GAINSBORO RGB8 220 220 220
"GHOSTWHITE RGB8 248 248 255
"GOLD RGB8 255 215 0
"GOLD1 RGB8 255 215 0
"GOLD2 RGB8 238 201 0
"GOLD3 RGB8 205 173 0
"GOLD4 RGB8 139 117 0
"GOLDENROD RGB8 218 165 32
"GOLDENROD1 RGB8 255 193 37
"GOLDENROD2 RGB8 238 180 34
"GOLDENROD3 RGB8 205 155 29
"GOLDENROD4 RGB8 139 105 20
"GRAY81 RGB8 207 207 207
"GRAY91 RGB8 232 232 232
"GREEN RGB8 0 255 0
"GREEN1 RGB8 0 255 0
"GREEN2 RGB8 0 238 0
"GREEN3 RGB8 0 205 0
"GREEN4 RGB8 0 139 0
"GREENYELLOW RGB8 173 255 47
"GREY RGB8 190 190 190
"GREY11 RGB8 28 28 28
"GREY21 RGB8 54 54 54
"GREY31 RGB8 79 79 79
"GREY41 RGB8 105 105 105
"GREY51 RGB8 130 130 130
"GREY61 RGB8 156 156 156
"GREY71 RGB8 181 181 181
"HONEYDEW RGB8 240 255 240
"HONEYDEW1 RGB8 240 255 240
"HONEYDEW2 RGB8 224 238 224
"HONEYDEW3 RGB8 193 205 193
"HONEYDEW4 RGB8 131 139 131
"HOTPINK RGB8 255 105 180
"HOTPINK1 RGB8 255 110 180
"HOTPINK2 RGB8 238 106 167
"HOTPINK3 RGB8 205 96 144
"HOTPINK4 RGB8 139 58 98
"INDIANRED RGB8 205 92 92
"INDIANRED1 RGB8 255 106 106
"INDIANRED2 RGB8 238 99 99
"INDIANRED3 RGB8 205 85 85
"INDIANRED4 RGB8 139 58 58
"IVORY RGB8 255 255 240
"IVORY1 RGB8 255 255 240
"IVORY2 RGB8 238 238 224
"IVORY3 RGB8 205 205 193
"IVORY4 RGB8 139 139 131
"KHAKI1 RGB8 255 246 143
"KHAKI2 RGB8 238 230 133
"KHAKI3 RGB8 205 198 115
"KHAKI4 RGB8 139 134 78
"LAVENDER RGB8 230 230 250
"LAVENDERBLUSH RGB8 255 240 245
"LAVENDERBLUSH1 RGB8 255 240 245
"LAVENDERBLUSH2 RGB8 238 224 229
"LAVENDERBLUSH3 RGB8 205 193 197
"LAVENDERBLUSH4 RGB8 139 131 134
"LAWNGREEN RGB8 124 252 0
"LEMONCHIFFON RGB8 255 250 205
"LEMONCHIFFON1 RGB8 255 250 205
"LEMONCHIFFON2 RGB8 238 233 191
"LEMONCHIFFON3 RGB8 205 201 165
"LEMONCHIFFON4 RGB8 139 137 112
"LIGHTBLUE RGB8 173 216 230
"LIGHTBLUE1 RGB8 191 239 255
"LIGHTBLUE2 RGB8 178 223 238
"LIGHTBLUE3 RGB8 154 192 205
"LIGHTBLUE4 RGB8 104 131 139
"LIGHTCORAL RGB8 240 128 128
"LIGHTCYAN RGB8 224 255 255
"LIGHTCYAN1 RGB8 224 255 255
"LIGHTCYAN2 RGB8 209 238 238
"LIGHTCYAN3 RGB8 180 205 205
"LIGHTCYAN4 RGB8 122 139 139
"LIGHTGOLDENROD RGB8 238 221 130
"LIGHTGOLDENROD1 RGB8 255 236 139
"LIGHTGOLDENROD2 RGB8 238 220 130
"LIGHTGOLDENROD3 RGB8 205 190 112
"LIGHTGOLDENROD4 RGB8 139 129 76
"LIGHTGRAY RGB8 211 211 211
"LIGHTGREEN RGB8 144 238 144
"LIGHTPINK RGB8 255 182 193
"LIGHTPINK1 RGB8 255 174 185
"LIGHTPINK2 RGB8 238 162 173
"LIGHTPINK3 RGB8 205 140 149
"LIGHTPINK4 RGB8 139 95 101
"LIGHTSALMON RGB8 255 160 122
"LIGHTSALMON1 RGB8 255 160 122
"LIGHTSALMON2 RGB8 238 149 114
"LIGHTSALMON3 RGB8 205 129 98
"LIGHTSALMON4 RGB8 139 87 66
"LIGHTSEAGREEN RGB8 32 178 170
"LIGHTSKYBLUE RGB8 135 206 250
"LIGHTSKYBLUE1 RGB8 176 226 255
"LIGHTSKYBLUE2 RGB8 164 211 238
"LIGHTSKYBLUE3 RGB8 141 182 205
"LIGHTSKYBLUE4 RGB8 96 123 139
"LIGHTSLATEBLUE RGB8 132 112 255
"LIGHTSLATEGRAY RGB8 119 136 153
"LIGHTSTEELBLUE RGB8 176 196 222
"LIGHTSTEELBLUE1 RGB8 202 225 255
"LIGHTSTEELBLUE2 RGB8 188 210 238
"LIGHTSTEELBLUE3 RGB8 162 181 205
"LIGHTSTEELBLUE4 RGB8 110 123 139
"LIGHTYELLOW RGB8 255 255 224
"LIGHTYELLOW1 RGB8 255 255 224
"LIGHTYELLOW2 RGB8 238 238 209
"LIGHTYELLOW3 RGB8 205 205 180
"LIGHTYELLOW4 RGB8 139 139 122
"LIMEGREEN RGB8 50 205 50
"LINEN RGB8 250 240 230
"LTGOLDENRODYELLO RGB8 250 250 210
"MAGENTA RGB8 255 0 255
"MAGENTA1 RGB8 255 0 255
"MAGENTA2 RGB8 238 0 238
"MAGENTA3 RGB8 205 0 205
"MAGENTA4 RGB8 139 0 139
"MAROON RGB8 176 48 96
"MAROON1 RGB8 255 52 179
"MAROON2 RGB8 238 48 167
"MAROON3 RGB8 205 41 144
"MAROON4 RGB8 139 28 98
"MEDIUMAQUAMARINE RGB8 102 205 170
"MEDIUMBLUE RGB8 0 0 205
"MEDIUMORCHID RGB8 186 85 211
"MEDIUMORCHID1 RGB8 224 102 255
"MEDIUMORCHID2 RGB8 209 95 238
"MEDIUMORCHID3 RGB8 180 82 205
"MEDIUMORCHID4 RGB8 122 55 139
"MEDIUMPURPLE RGB8 147 112 219
"MEDIUMPURPLE1 RGB8 171 130 255
"MEDIUMPURPLE2 RGB8 159 121 238
"MEDIUMPURPLE3 RGB8 137 104 205
"MEDIUMPURPLE4 RGB8 93 71 139
"MEDIUMSEAGREEN RGB8 60 179 113
"MEDIUMSLATEBLUE RGB8 123 104 238
"MEDIUMTURQUOISE RGB8 72 209 204
"MEDIUMVIOLETRED RGB8 199 21 133
"MEDSPRINGGREEN RGB8 0 250 154
"MIDNIGHTBLUE RGB8 25 25 112
"MINTCREAM RGB8 245 255 250
"MISTYROSE RGB8 255 228 225
"MISTYROSE1 RGB8 255 228 225
"MISTYROSE2 RGB8 238 213 210
"MISTYROSE3 RGB8 205 183 181
"MISTYROSE4 RGB8 139 125 123
"MOCCASIN RGB8 255 228 181
"NAVAJOWHITE RGB8 255 222 173
"NAVAJOWHITE1 RGB8 255 222 173
"NAVAJOWHITE2 RGB8 238 207 161
"NAVAJOWHITE3 RGB8 205 179 139
"NAVAJOWHITE4 RGB8 139 121 94
"NAVYBLUE RGB8 0 0 128
"OLDLACE RGB8 253 245 230
"OLIVEDRAB RGB8 107 142 35
"OLIVEDRAB1 RGB8 192 255 62
"OLIVEDRAB2 RGB8 179 238 58
"OLIVEDRAB3 RGB8 154 205 50
"OLIVEDRAB4 RGB8 105 139 34
"ORANGE RGB8 255 165 0
"ORANGE1 RGB8 255 165 0
"ORANGE2 RGB8 238 154 0
"ORANGE3 RGB8 205 133 0
"ORANGE4 RGB8 139 90 0
"ORANGERED RGB8 255 69 0
"ORANGERED1 RGB8 255 69 0
"ORANGERED2 RGB8 238 64 0
"ORANGERED3 RGB8 205 55 0
"ORANGERED4 RGB8 139 37 0
"ORCHID RGB8 218 112 214
"ORCHID1 RGB8 255 131 250
"ORCHID2 RGB8 238 122 233
"ORCHID3 RGB8 205 105 201
"ORCHID4 RGB8 139 71 137
"PALEGOLDENROD RGB8 238 232 170
"PALEGREEN RGB8 152 251 152
"PALEGREEN1 RGB8 154 255 154
"PALEGREEN2 RGB8 144 238 144
"PALEGREEN3 RGB8 124 205 124
"PALEGREEN4 RGB8 84 139 84
"PALETURQUOISE RGB8 175 238 238
"PALETURQUOISE1 RGB8 187 255 255
"PALETURQUOISE2 RGB8 174 238 238
"PALETURQUOISE3 RGB8 150 205 205
"PALETURQUOISE4 RGB8 102 139 139
"PALEVIOLETRED RGB8 219 112 147
"PALEVIOLETRED1 RGB8 255 130 171
"PALEVIOLETRED2 RGB8 238 121 159
"PALEVIOLETRED3 RGB8 205 104 137
"PALEVIOLETRED4 RGB8 139 71 93
"PAPAYAWHIP RGB8 255 239 213
"PEACHPUFF RGB8 255 218 185
"PEACHPUFF1 RGB8 255 218 185
"PEACHPUFF2 RGB8 238 203 173
"PEACHPUFF3 RGB8 205 175 149
"PEACHPUFF4 RGB8 139 119 101
"PERU RGB8 205 133 63
"PINK RGB8 255 192 203
"PINK1 RGB8 255 181 197
"PINK2 RGB8 238 169 184
"PINK3 RGB8 205 145 158
"PINK4 RGB8 139 99 108
"PLATINUM RGB8 085 088 090
"PLUM RGB8 221 160 221
"PLUM1 RGB8 255 187 255
"PLUM2 RGB8 238 174 238
"PLUM3 RGB8 205 150 205
"PLUM4 RGB8 139 102 139
"POWDERBLUE RGB8 176 224 230
"PURPLE RGB8 160 32 240
"PURPLE1 RGB8 155 48 255
"PURPLE2 RGB8 145 44 238
"PURPLE3 RGB8 125 38 205
"PURPLE4 RGB8 85 26 139
"RED RGB8 255 0 0
"RED1 RGB8 255 0 0
"RED2 RGB8 238 0 0
"RED3 RGB8 205 0 0
"RED4 RGB8 139 0 0
"ROSYBROWN RGB8 188 143 143
"ROSYBROWN1 RGB8 255 193 193
"ROSYBROWN2 RGB8 238 180 180
"ROSYBROWN3 RGB8 205 155 155
"ROSYBROWN4 RGB8 139 105 105
"ROYALBLUE RGB8 65 105 225
"ROYALBLUE1 RGB8 72 118 255
"ROYALBLUE2 RGB8 67 110 238
"ROYALBLUE3 RGB8 58 95 205
"ROYALBLUE4 RGB8 39 64 139
"SADDLEBROWN RGB8 139 69 19
"SALMON RGB8 250 128 114
"SALMON1 RGB8 255 140 105
"SALMON2 RGB8 238 130 98
"SALMON3 RGB8 205 112 84
"SALMON4 RGB8 139 76 57
"SANDYBROWN RGB8 244 164 96
"SEAGREEN RGB8 46 139 87
"SEAGREEN1 RGB8 84 255 159
"SEAGREEN2 RGB8 78 238 148
"SEAGREEN3 RGB8 67 205 128
"SEAGREEN4 RGB8 46 139 87
"SEASHELL RGB8 255 245 238
"SEASHELL1 RGB8 255 245 238
"SEASHELL2 RGB8 238 229 222
"SEASHELL3 RGB8 205 197 191
"SEASHELL4 RGB8 139 134 130
"SIENNA RGB8 160 82 45
"SIENNA1 RGB8 255 130 71
"SIENNA2 RGB8 238 121 66
"SIENNA3 RGB8 205 104 57
"SIENNA4 RGB8 139 71 38
"SKYBLUE RGB8 135 206 235
"SKYBLUE1 RGB8 135 206 255
"SKYBLUE2 RGB8 126 192 238
"SKYBLUE3 RGB8 108 166 205
"SKYBLUE4 RGB8 74 112 139
"SLATEBLUE RGB8 106 90 205
"SLATEBLUE1 RGB8 131 111 255
"SLATEBLUE2 RGB8 122 103 238
"SLATEBLUE3 RGB8 105 89 205
"SLATEBLUE4 RGB8 71 60 139
"SLATEGRAY1 RGB8 198 226 255
"SLATEGRAY2 RGB8 185 211 238
"SLATEGRAY3 RGB8 159 182 205
"SLATEGRAY4 RGB8 108 123 139
"SLATEGREY RGB8 112 128 144
"SNOW RGB8 255 250 250
"SNOW1 RGB8 255 250 250
"SNOW2 RGB8 238 233 233
"SNOW3 RGB8 205 201 201
"SNOW4 RGB8 139 137 137
"SPRINGGREEN RGB8 0 255 127
"SPRINGGREEN1 RGB8 0 255 127
"SPRINGGREEN2 RGB8 0 238 118
"SPRINGGREEN3 RGB8 0 205 102
"SPRINGGREEN4 RGB8 0 139 69
"STEELBLUE RGB8 70 130 180
"STEELBLUE1 RGB8 99 184 255
"STEELBLUE2 RGB8 92 172 238
"STEELBLUE3 RGB8 79 148 205
"STEELBLUE4 RGB8 54 100 139
"TANGENS RGB8 210 180 140
"TAN1 RGB8 255 165 79
"TAN2 RGB8 238 154 73
"TAN3 RGB8 205 133 63
"TAN4 RGB8 139 90 43
"THISTLE RGB8 216 191 216
"THISTLE1 RGB8 255 225 255
"THISTLE2 RGB8 238 210 238
"THISTLE3 RGB8 205 181 205
"THISTLE4 RGB8 139 123 139
"TOMATO RGB8 255 99 71
"TOMATO1 RGB8 255 99 71
"TOMATO2 RGB8 238 92 66
"TOMATO3 RGB8 205 79 57
"TOMATO4 RGB8 139 54 38
"TURQUOISE RGB8 64 224 208
"TURQUOISE1 RGB8 0 245 255
"TURQUOISE2 RGB8 0 229 238
"TURQUOISE3 RGB8 0 197 205
"TURQUOISE4 RGB8 0 134 139
"VIOLET RGB8 238 130 238
"VIOLETRED RGB8 208 32 144
"VIOLETRED1 RGB8 255 62 150
"VIOLETRED2 RGB8 238 58 140
"VIOLETRED3 RGB8 205 50 120
"VIOLETRED4 RGB8 139 34 82
"WHEAT RGB8 245 222 179
"WHEAT1 RGB8 255 231 186
"WHEAT2 RGB8 238 216 174
"WHEAT3 RGB8 205 186 150
"WHEAT4 RGB8 139 126 102
"WHITE RGB8 255 255 255
"WHITESMOKE RGB8 245 245 245
"YELLOW RGB8 255 255 0
"YELLOW1 RGB8 255 255 0
"YELLOW2 RGB8 238 238 0
"YELLOW3 RGB8 205 205 0
"YELLOW4 RGB8 139 139 0

Reference:

    Release Notes für Version 4.685

Grafiken Relative Igel-Bewegung


HC / Grafiken / Relative Igel-Bewegung

Relative Igel-Bewegung

HC [image] Grafiken [image] Relative Igel-Bewegung
Farb-Datenbank vorwärts

Relative Igel-Bewegung

Dieser Abschnitt beschreibt die Grundmenge von Kommandos, um den Igel relativ zu seiner Position zu bewegen, einschließlich Kommandos zum Ändern des Igel-Kurses.

Wenn der Stift nach unten gesetzt ist (mit StiftAb), dann wird der Igel eine gerade Linie entlang seinem Pfad zeichnen.

Relative Bewegungen sind die Stärke von Igel Grafik, besonders wenn Sie vollständige Zeichnungen wiederholen und sie iterativ aufrufen, so können Sie zum Beispiel schöne fraktale Grafiken mit Leichtigkeit erzeugen.

Relative Igel-Bewegung

  • vorwärts
  • zurück
  • links
  • rechts
  • rolleLinks
  • rolleRechts
  • rauf
  • runter


HC / Grafiken / Relative Igel-Bewegung / vorwärts

vorwärts

HC [image] Grafiken [image] Relative Igel-Bewegung [image] vorwärts
Relative Igel-Bewegung zurück

vorwärts Strecke
_vw Strecke

bewegt den Igel um die "Strecke" (in Igel-Schritten gemessen) vorwärts, in die Richtung, in die er zeigt.

Wenn StiftAb? wahr ist, dann zeichnet der Igel eine Linie auf seinem Weg. Wenn Zylinder-Linien eingeschaltet sind, dann zeichnet er einen Zlinder auf seinem Weg.

Beispiele:

wiederhole 4 [vorwärts 100 rechts 90]

löscheSchirm
vorwärts 100
rechts 90
vorwärts 100
links 60
vorwärts 50

löscheSchirm
perspektivisch
ZylinderlinienAn
setzeStiftGröße 50
setzeStiftfarbe 4
vorwärts 100
rechts 90
vorwärts 100

Examples:

  • macheBitmapDurchsichtig
  • setzeTesselationRegeln
  • holeMatrixVomStapel
  • rundeLinienendenAus
  • rundeLinienendenAn
  • TesselationKontour
  • setzeFenstersizer
  • setzeFüllToleranz
  • setzeSchriftname
  • TesselationStart
  • ZylinderlinienAn
  • ModelviewMatrix
  • Parameteranzahl
  • setzeIgelFormen
  • setzeIgelMatrix
  • setzeStiftdicke
  • beiKnopfdruck
  • inRichtungXYZ
  • setzeTexturXY
  • zerstöreKnopf
  • öffneZumLesen
  • FensterModus
  • GrafikAnfang
  • stapleMatrix
  • loadpalette
  • rolleRechts
  • AbstandXYZ
  • definiertP
  • GrundwortP
  • IgelFormen
  • inRichtung
  • Randsprung
  • rolleLinks
  • wiederhole
  • FensterAn
  • ProzedurP
  • klammere
  • verfolgt
  • Zylinder
  • Abstand
  • Ellipse
  • Gestell
  • KnopfAn
  • Vieleck
  • dreheX
  • dreheY
  • dreheZ
  • Grafik
  • rechts
  • runter
  • zurück
  • fülle
  • links
  • Igel
  • rauf
  • RGBA
  • TSHA
  • Zaun
  • def
  • RGB
  • TSH
  • zu

References:

    TesselationKontour(5), TesselationStart(5), links(5), rechts(5), setzeTesselationRegeln(5), verfolgt(5), zu(5), def(4), setzeTexturXY(4), FensterModus(2), GrafikAnfang(2), IgelFormen(2), Randsprung(2), Vieleck(2), ZylinderlinienAn(2), beiKnopfdruck(2), fülle(2), klammere(2), rolleLinks(2), rolleRechts(2), setzeFenstersizer(2), setzeIgelFormen(2), setzeStiftdicke(2), öffneZumLesen(2), Abstand, AbstandXYZ, Ellipse, FensterAn, Gestell, Grafik, GrundwortP, Igel, KnopfAn, ModelviewMatrix, Parameteranzahl, ProzedurP, RGB, RGBA, TSH, TSHA, Zaun, Zylinder, buglist für Version 4.65, definiertP, dreheX, dreheY, dreheZ, holeMatrixVomStapel, inRichtung, inRichtungXYZ, loadpalette, macheBitmapDurchsichtig, rauf, rundeLinienendenAn, rundeLinienendenAus, runter, setzeFüllToleranz, setzeIgelMatrix, setzeSchriftname, stapleMatrix, wiederhole, zerstöreKnopf, zurück

Relative Igel-Bewegung zurück


HC / Grafiken / Relative Igel-Bewegung / zurück

zurück

HC [image] Grafiken [image] Relative Igel-Bewegung [image] zurück
vorwärts links

zurück Strecke
_zr Strecke

bewegt den Igel um die "Strecke" (in Igel-Schritten gemessen) rückwärts, also in die entgegengesetzte Richtung, in die er zeigt.

Wenn StiftAb? wahr ist, dann zeichnet der Igel eine Linie auf seinem Weg. Wenn Zylinder-Linien eingeschaltet sind, dann zeichnet er einen Zlinder auf seinem Weg.

Beispiel:

StiftHoch vorwärts 100 StiftAb
zurück 200

Examples:

  • setzeTesselationRegeln
  • setzeSchattenfarbe
  • setzeFenstersizer
  • BitmapKopieren
  • zeichneBitmap
  • öffneZumLesen
  • wirfSchatten
  • SchattenAn
  • Gestell

References:

    liesZeichen(2), setzeFenstersizer(2), öffneZumLesen(2), BitmapKopieren, DoppelPufferung, Gestell, Release, Release Notes für Version 4.64, SchattenAn, Tschüß, Versions-Informationen für Version 4.7, für, liesZeichenErweitert, setzeSchattenfarbe, setzeTesselationRegeln, wirf, wirfSchatten, zeichneBitmap

vorwärts links


HC / Grafiken / Relative Igel-Bewegung / links

links

HC [image] Grafiken [image] Relative Igel-Bewegung [image] links
zurück rechts

links Grad
_li Grad

Dreht den Igel gegen den Uhrzeigersinn um den angegebenen Winkel, in Grad gemessen (1 Grad ist 1/360 eines Kreises).

Beispiele:

links 90
vorwärts 100
links 180
vorwärts 100
links 45
vorwärts 100
links 135
vorwärts 100
links 45
vorwärts 100

Examples:

  • TesselationKontour
  • TesselationStart
  • öffneZumLesen
  • GrafikAnfang
  • rolleLinks
  • vorwärts
  • Gestell
  • arc2
  • RGBA
  • TSHA

References:

    öffneZumLesen(4), Gestell, GrafikAnfang, ListControl, RGBA, Schieberegler, TSHA, TesselationKontour, TesselationStart, TextAusrichtung, arc2, buglist für Version 4.65, oder, reduziere, rolleLinks, schiebeArithmetisch, schiebeLogisch, schiebePortLinks, setzeSchriftausrichtung, setzeX, und, vorwärts, wirfSchatten, zu

zurück rechts


HC / Grafiken / Relative Igel-Bewegung / rechts

rechts

HC [image] Grafiken [image] Relative Igel-Bewegung [image] rechts
links rolleLinks

rechts Grad
_re Grad

Dreht den Igel im Uhrzeigersinn um den angegebenen Winkel, in Grad gemessen (1 Grad ist 1/360 eines Kreises).

Beispiele:

rechts 90
vorwärts 100
rechts 180
vorwärts 100
rechts 45
vorwärts 100
rechts 135
vorwärts 100
rechts 45
vorwärts 100

Examples:

  • setzeSchriftausrichtung
  • setzeTesselationRegeln
  • holeMatrixVomStapel
  • setzeGraphErneuern
  • TesselationKontour
  • setzeFüllToleranz
  • TesselationStart
  • ZylinderlinienAn
  • ModelviewMatrix
  • setzeIgelFormen
  • setzeIgelMatrix
  • speichereSchirm
  • TexturschriftAn
  • fülleRechteck
  • setzeTexturXY
  • öffneZumLesen
  • fülleEllipse
  • GrafikAnfang
  • stapleMatrix
  • fülleKuchen
  • rolleRechts
  • IgelFormen
  • VideoFrame
  • VideoStart
  • wiederhole
  • VideoEnde
  • vorwärts
  • Ellipse
  • Gestell
  • Vieleck
  • runter
  • fülle
  • arc2
  • rauf
  • RGBA
  • TSHA

References:

    TesselationKontour(5), setzeTesselationRegeln(5), öffneZumLesen(5), setzeTexturXY(4), TesselationStart(3), vorwärts(3), Ellipse(2), Vieleck(2), arc2(2), fülle(2), schiebeLogisch(2), setzeSchriftausrichtung(2), BitmapKopieren, EllipsenBogen, Ellipsoid, Filter, Gestell, GrafikAnfang, Grafiken, IgelFormen, ModelviewMatrix, RGBA, Schieberegler, TSHA, TextAusrichtung, TexturschriftAn, VideoEnde, VideoFrame, VideoStart, ZylinderlinienAn, bildeAbSatz, bildeab, finde, fülleEllipse, fülleKuchen, fülleRechteck, fürAlle, holeMatrixVomStapel, oder, rauf, rolleRechts, runter, schiebeArithmetisch, schiebePortRechts, scrolle, setzeFüllToleranz, setzeGraphErneuern, setzeIgelFormen, setzeIgelMatrix, setzeX, speichereSchirm, stapleMatrix, und, wiederhole, wirfSchatten, zu

links rolleLinks


HC / Grafiken / Relative Igel-Bewegung / rolleLinks

rolleLinks

HC [image] Grafiken [image] Relative Igel-Bewegung [image] rolleLinks
rechts rolleRechts

rolleLinks Grad

Rollt den Igel (auf seine linke Seite) um den Vorwärts-Vektor um den angegebenen Winkel, in Graden gemessen (1 Grad entspricht 1/360 eines Kreises). Dieses Kommando ist vorgesehen, im perspektivischen Modus ausgeführt zu werden.

Beispiel:

perspektivisch
rolleLinks 45
wiederhole 3 [vorwärts 100 links 120]

Reference:

    Release Notes für Version 4.64

rechts rolleRechts


HC / Grafiken / Relative Igel-Bewegung / rolleRechts

rolleRechts

HC [image] Grafiken [image] Relative Igel-Bewegung [image] rolleRechts
rolleLinks rauf

rolleRechts Winkel

Rollt den Igel (auf seine rechte Seite) um den Vorwärts-Vektor um den angegebenen Winkel, in Graden gemessen (1 Grad entspricht 1/360 eines Kreises). Dieses Kommando ist vorgesehen, im perspektivischen Modus ausgeführt zu werden.

Beispiel:

perspektivisch
rollRechts 45
wiederhole 3 [vorwärts 100 rechts 120]

Example:

  • Grafik

Reference:

    Grafik

rolleLinks rauf


HC / Grafiken / Relative Igel-Bewegung / rauf

rauf

HC [image] Grafiken [image] Relative Igel-Bewegung [image] rauf
rolleRechts runter

rauf Winkel

Neigt die Igel-Nase nach oben um seine Basis, um den angegebenen Winkel, in Grad gemessen (1 Grad entspricht 1/360 eines Kreises). Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
rauf 45
wiederhole 3 [vorwärts 100 rechts 120]

Examples:

  • beiGraphMausLinksLosgelassen
  • beiGraphMausMitteLosgelassen
  • beiLinksGeklickterGraphMaus
  • beiRechtsLosgelasserMaus
  • beiLinksLosgelasserMaus
  • beiMitteLosgelasserMaus
  • Grafik

References:

    GanzzahlBoxen(2), Release Notes für Version 4.64(2), beiGraphMausLinksLosgelassen(2), beiGraphMausMitteLosgelassen(2), beiLinksGeklickterGraphMaus(2), beiLinksLosgelasserMaus(2), beiLosgelassenerTaste(2), beiLosgelassenerTasteInGraph(2), beiMitteLosgelasserMaus(2), beiRechtsLosgelasserMaus(2), Balken-Anzeigen, Grafik, Release Notes für Version 4.685, Tastenwert, Versions-Informationen für Version 4.7, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInFenster, beiLosgelassenerTasteInKombiBox, beiLosgelassenerTasteInListenControl, beiLosgelassenerTasteInListenbox, beiLosgelassenerTasteInTextbox, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, öffneMidi

rolleRechts runter


HC / Grafiken / Relative Igel-Bewegung / runter

runter

HC [image] Grafiken [image] Relative Igel-Bewegung [image] runter
rauf Absolute Igel-Bewegung

runter Winkel

Neigt die Igel-Nase nach unten um seine Basis, um den angegebenen Winkel, in Grad gemessen (1 Grad entspricht 1/360 eines Kreises). Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
runter 45
wiederhole 3 [vorwärts 100 rechts 120]

Example:

  • Grafik

References:

    beiGedrückterTaste(3), beiGedrückterTasteInGraph(3), KombiBoxen(2), Release Notes für Version 4.64(2), Auswahlbox, GanzzahlBoxen, Grafik, GraphOnMouseLeftDown, Tastenwert, beiGedrückterTasteInAuswahlbox, beiGedrückterTasteInFenster, beiGedrückterTasteInKombiBox, beiGedrückterTasteInListenControl, beiGedrückterTasteInListenbox, beiGedrückterTasteInTextbox, beiGraphZeichen, beiLinksGeklickterTextmaus, beiMitteGeklickterGraphMaus, beiMitteGeklickterMaus, beiMitteGeklickterTextmaus, beiRechtsGeklickterGraphMaus, beiRechtsGeklickterMaus, beiRechtsGeklickterTextmaus, beiZeichen

rauf Absolute Igel-Bewegung


HC / Grafiken / Absolute Igel-Bewegung

Absolute Igel-Bewegung

HC [image] Grafiken [image] Absolute Igel-Bewegung
runter Mitte

Absolute Igel-Bewegung

Diese zusätzlichen Kommandos ermöglichen Ihnen, die Igel-Absolutposition und seinen Kurs zu setzen.

Auch der "Mitte" Befehl ist wirklich nützlich, wenn Sie im Dreidimensionalen Raum Ihren Igel verloren haben.

Wenn der Schreibstift nach unten gesetzt wird (mit StiftAb), wird der Igel eine gerade Linie von seiner letzten Position zu seiner neuen Position zeichnen.

Absolute Igel-Bewegung

  • Mitte
  • setzeX
  • setzeY
  • setzeZ
  • setzeXY
  • setzeXYZ
  • setzeOrt
  • _setzeOrt
  • setzeOrtXYZ
  • _setzeOrtXYZ
  • setzeOrtInKugelkoordinaten
  • setzeZylinderOrt
  • setzeKurs
  • setzeNeigung
  • setzeRollWinkel
  • setzeOrientierung
  • dreheX
  • dreheY
  • dreheZ


HC / Grafiken / Absolute Igel-Bewegung / Mitte

Mitte

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] Mitte
Absolute Igel-Bewegung setzeX

Mitte

Bewegt den Igel zum Zentrum des Grafik-Bildschirms. Wenn StiftAb? wahr ist, wird auf dem Weg dorthin eine gerade Linie gezeichnet. Äquivalent zu

    setzeOrt [0 0].
Beispiel:

setzeXY 100 100
Mitte

Examples:

  • zeichneBitmapSkaliertAuf
  • zeichneBitmapSchnell
  • zeichneBitmapAuf
  • setzeIgelMatrix
  • TexturschriftAn
  • fülleBitmap

References:

    zeichneBitmapAuf(4), fülleBitmap(2), zeichneBitmapSkaliertAuf(2), Absolute Igel-Bewegung, FensterModus, Grafiken, Release Notes für Version 4.685, TexturschriftAn, löscheSchirm, setzeIgelMatrix, zeichneBitmapSchnell

Absolute Igel-Bewegung setzeX


HC / Grafiken / Absolute Igel-Bewegung / setzeX

setzeX

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeX
Mitte setzeY

setzeX xkoor

Bewegt den Igel horizontal (links..rechts) entlang der X-Achse von seiner gegenwärtigen Position zu einer neuen absoluten X-Koordinate.

Das Argument ist die neue X-Koordinate.

Beispiel:

setzeX 100
setzeY 100
setzeX 0
setzeY 0

Examples:

  • beiÄnderungInReellerZahlbox
  • setzeReelleZahlboxBereich
  • beiGanzzahlBoxÄnderung
  • setzeReelleZahlboxWert
  • FloatControlDestroy
  • ZahlboxWert
  • ZahlboxAn
  • Zahlbox
  • setzeY
  • setzeZ
  • xKoor

References:

    setzeY(2), FloatControlDestroy, Zahlbox, ZahlboxAn, ZahlboxWert, beiGanzzahlBoxÄnderung, beiÄnderungInReellerZahlbox, setzeReelleZahlboxBereich, setzeReelleZahlboxWert, setzeZ, xKoor

Mitte setzeY


HC / Grafiken / Absolute Igel-Bewegung / setzeY

setzeY

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeY
setzeX setzeZ

setzeY ykoor

Bewegt den Igel vertikal (unten..oben) entlang der Y-Achse von seiner gegenwärtigen Position zu einer neuen absoluten Y-Koordinate.

Das Argument ist die neue Y-Koordinate.

Beispiel:

setzeX 100
setzeY 100
setzeX 0
setzeY 0

Examples:

  • setzeX
  • setzeZ
  • yKoor

References:

    setzeX(2), setzeZ(2), yKoor

setzeX setzeZ


HC / Grafiken / Absolute Igel-Bewegung / setzeZ

setzeZ

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeZ
setzeY setzeXY

setzeZ zkoor

Bewegt den Igel entlang der Z-Achse (normalerweise senkrecht zur Bild-Ebene) von seiner gegenwärtigen Position zu einer neuen absoluten Z-Koordinate.

Das Argument ist die neue Z-Koordinate.

Dieses Kommando ist für die Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
StiftHoch setzeX 100 StiftAb
setzeZ 100
setzeY 100
setzeZ 0
setzeY 0

Example:

  • zKoor

References:

    Release Notes für Version 4.64, zKoor

setzeY setzeXY


HC / Grafiken / Absolute Igel-Bewegung / setzeXY

setzeXY

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeXY
setzeZ setzeXYZ

setzeXY xkoor ykoor

Bewegt den Igel zu einer absoluten Schirmposition. Die zwei Eingaben sind Zahlen, Listen, Reihen oder reelleZahlen, die die X- und Y-Koordinaten repräsentieren.

Beispiele:

setzeXY 100 0
setzeXY 100 100
setzeXY 0 100
setzeXY 0 0

x=ZahlenFolge -1 1 1000
y=(sinus x*x*20*360)*300
x=x*400
setzeStiftfarbe 0
setzeXY x y
setzeStiftfarbe 4
setzeXY x inListe TiefpaßFilter 16BitZahlen y 10

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiLinksDoppeltGeklickterTextmaus
  • beiMitteDoppeltgeklickterTextmaus
  • zeichneBitmapSkaliertAuf
  • zeichneBitmapSchnell
  • beiTextMausbewegung
  • zeichneBitmapAuf
  • TiefpaßFilter2
  • TiefpaßFilter
  • fülleBitmap
  • löscheBild
  • Mitte

References:

    TiefpaßFilter(4), TiefpaßFilter2(4), zeichneBitmapAuf(4), fülleBitmap(2), zeichneBitmapSkaliertAuf(2), Mitte, beiLinksDoppeltGeklickterTextmaus, beiMitteDoppeltgeklickterTextmaus, beiRechtsDoppeltgeklickterTextmaus, beiTextMausbewegung, löscheBild, zeichneBitmapSchnell

setzeZ setzeXYZ


HC / Grafiken / Absolute Igel-Bewegung / setzeXYZ

setzeXYZ

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeXYZ
setzeXY setzeOrt

setzeXYZ xkoor ykoor zkoor

Bewegt den Igel zu einer absoluten 3D-Position. Die drei Argumente sind Zahlen, Listen, Reihen oder reelleZahlen, die die X-, Y- und Z-Koordinaten repräsentieren.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen. Siehe auch PosXYZ.

Beispiel (zeichnet einen Draht-Würfel):

perspektivisch
l=100
setzeXYZ l 0 0
setzeXYZ l l 0
setzeXYZ 0 l 0
setzeXYZ 0 0 0
setzeXYZ l 0 0
setzeXYZ l 0 l
setzeXYZ 0 0 l
setzeXYZ 0 0 0
setzeXYZ 0 0 l
setzeXYZ 0 l l
setzeXYZ l l l
setzeXYZ l 0 l
setzeXYZ l l l
setzeXYZ l l 0
setzeXYZ 0 l 0
setzeXYZ 0 l l
rotatescene

Beispiel (zeichnet einige Sinus-Wellen in 3D):

perspektivisch
für [i 0 360 10] ~
[	für [j 0 360] ~
    [	setzexyz j 200*(sinus j)*sinus i -i
    ]
    StiftHoch
    setzexyz 0 0 -:i
    StiftAb
]
rotatescene

Es kann auch mit nur einer Schleife geschrieben werden:

perspektivisch
z0=rSeqFA 0 0 361
für [i 0 360 10] ~
[	x=rSeqFA 0 360 361
    setzexyz x (sinus x)*(sinus i)*200 z0-i
    StiftHoch
    setzexyz 0 0 -i
    StiftAb
]
rotatescene

Example:

  • orthographisch

References:

    Release Notes für Version 4.64, Release Notes für Version 4.65, orthographisch

setzeXY setzeOrt


HC / Grafiken / Absolute Igel-Bewegung / setzeOrt

setzeOrt

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeOrt
setzeXYZ _setzeOrt

setzeOrt ort

Bewegt den Igel zu einer absoluten (X,Y)-Koordinate. Das Argument ist ein Liste zweier Zahlen, der X- und Y-Koordinate. Siehe auch Ort.

Beispiel 1 (zeichnet ein Quadrat):

löscheSchirm
setzeort [0 100]
setzeort [100 100]
setzeort [100 0]
setzeort [0 0]

Beispiel 2 (die häufigste Logo-Frage):

x=0
y=0

Dann wird

setzeOrt [:x :y]

fehlschlagen, aber

setzeOrt (Liste :x :y)

wird funktionieren.

Warum?

Weil im ersten Fall [:x :y] eine wörtliche Liste ist, die die zwei Worte ":x und ":y enthält. Im zweiten Fall wird eine Liste aufgebaut, die das Ergebnis der Auswertung von :x und :y enthält, also die Werte der Variablen x uznd y. Sie können das deutlicher sehen, wenn Sie den "zeige" Befehl verwenden:

zeige [:x :y]		;[:x :y]
zeige (Liste :x :y)		;[0 100]

Example:

  • Ort

References:

    _setzeOrt(2), Mitte, Ort

setzeXYZ _setzeOrt


HC / Grafiken / Absolute Igel-Bewegung / _setzeOrt

_setzeOrt

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] _setzeOrt
setzeOrt setzeOrtXYZ

_setzeOrt ort

Bewegt den Igel zu einer absoluten Schirmposition. Die Eingabe ist eine Liste zweier Zahlen, der X- und Y-Koordinate. _setzeOrt ändert im Gegensatz zu setzeOrt nicht den Igel-Kurs und führt keinen Randsprung am Rand des Bildes durch, dafür ist es schneller als setzeOrt.

Beispiel:

_setzeOrt [200 100]

Example:

  • kalibriereScrolling

Reference:

    kalibriereScrolling

setzeOrt setzeOrtXYZ


HC / Grafiken / Absolute Igel-Bewegung / setzeOrtXYZ

setzeOrtXYZ

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeOrtXYZ
_setzeOrt _setzeOrtXYZ

setzeOrtXYZ ort

Bewegt den Igel zu einer absoluten (X,Y,Z)-Koordinate. Das Argument ist ein Liste von drei Zahlen, den X, Y und Z Koordinaten. Dieses Kommando ist für den perspektivischen Modus vorgesehen. Siehe auch OrtXYZ.

Beispiel (zeichnet einen Würfel):

perspektivisch
setzeortxyz [0 100 0]
setzeortxyz [100 100 0]
setzeortxyz [100 0 0]
setzeortxyz [0 0 0]
setzeortxyz [0 0 100]
setzeortxyz [100 0 100]
setzeortxyz [100 100 100]
setzeortxyz [0 100 100]
setzeortxyz [0 0 100]
setzeortxyz [0 100 100]
setzeortxyz [0 100 0]
setzeortxyz [100 100 0]
setzeortxyz [100 100 100]
setzeortxyz [100 0 100]
setzeortxyz [100 0 0]

Examples:

  • beiRechtsGeklickterGraphMaus
  • beiRechtsGeklickterMaus
  • beiGraphMausBewegung
  • GraphOnMouseLeftDown
  • Oberflächenspalte
  • Oberflächenstart
  • beiMausBewegung
  • Oberflächenende
  • Oberfläche
  • OrtXYZ

References:

    Oberfläche(2), Oberflächenende(2), Oberflächenspalte(2), Oberflächenstart(2), _setzeOrtXYZ(2), GraphOnMouseLeftDown, OrtXYZ, Release Notes für Version 4.64, beiGraphMausBewegung, beiMausBewegung, beiRechtsGeklickterGraphMaus, beiRechtsGeklickterMaus

_setzeOrt _setzeOrtXYZ


HC / Grafiken / Absolute Igel-Bewegung / _setzeOrtXYZ

_setzeOrtXYZ

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] _setzeOrtXYZ
setzeOrtXYZ setzeOrtInKugelkoordinaten

_setzeOrtXYZ ort

Bewegt den Igel zu einer absoluten Schirmposition. Die Eingabe ist ein Liste von drei Zahlen, den X-, Y- und Z-Koordinaten. _setzeOrtXYZ führt im Gegensatz zu setzeOrtXYZ keinen Randsprung aus, dafür ist es schneller als setzeOrtXYZ.

Beispiel:

_setzeOrtXYZ [100 200 300]

Reference:

    Release Notes für Version 4.64

setzeOrtXYZ setzeOrtInKugelkoordinaten


HC / Grafiken / Absolute Igel-Bewegung / setzeOrtInKugelkoordinaten

setzeOrtInKugelkoordinaten

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeOrtInKugelkoordinaten
_setzeOrtXYZ setzeZylinderOrt

setzeOrtInKugelkoordinaten r phi theta

Bewegt den Igel zur Position (phi,theta) auf der Kugel mit Radius "r".

phi: XY-Winkel

theta: Neigung

Beispiel (Teil einer Draht-Kugel in 3D):

StiftHoch
für [s 48 360 24]
[	für [t 45 180 16]
    [	setzeOrtInKugelkoordinaten r s t StiftAb
    ]
    StiftHoch
]
StiftHoch
für [t 45 180 16]
[	für [s 48 360 24]
    [	setzeOrtInKugelkoordinaten r s t StiftAb
    ]
    StiftHoch
]

References:

    Release Notes für Version 4.64, Release Notes für Version 4.65

_setzeOrtXYZ setzeZylinderOrt


HC / Grafiken / Absolute Igel-Bewegung / setzeZylinderOrt

setzeZylinderOrt

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeZylinderOrt
setzeOrtInKugelkoordinaten setzeKurs

setzeZylinderOrt r phi y

Bewegt den Igel zu der Position (phi,y) auf dem Zylinder mit Radius "r".

phi: XY-Winkel

Y: Y-Position

Beispiel (Draht-Zylinder in 3 D):

StiftHoch
für [s 0 360 24]
[	für [h 0 180 20]
    [	setzeZylinderOrt 100 s h
        StiftAb
    ]
    StiftHoch
]
StiftHoch
für [h 0 180 20]
[	für [s 0 360 24]
    [	setzeZylinderOrt 100 s h
        StiftAb
    ]
    StiftHoch
]

References:

    Release Notes für Version 4.64, Release Notes für Version 4.65

setzeOrtInKugelkoordinaten setzeKurs


HC / Grafiken / Absolute Igel-Bewegung / setzeKurs

setzeKurs

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeKurs
setzeZylinderOrt setzeNeigung

setzeKurs Winkel
setzeKurs Winkel

Dreht den Igel auf einen neuen absoluten Kurs.

Das Argument ist ein Winkel, der Kurs in Grad in Uhrzeigerrichtung von der positiven Y-Achse.

Siehe auch "Kurs".

Wenn Sie im perspektivischen Modus sind, dann ist der Kurs in Grad positiv von der positiven X-Achse zur positiven Y-Achse, drehend um die Z-Achse.

Beispiel:

setzekurs 45
zeige kurs		;45

Examples:

  • beiTextMausRechtsLosgelassen
  • beiRechtsGeklickterTextmaus
  • beiTextMausLinksLosgelassen
  • beiTextMausMitteLosgelassen
  • beiLinksGeklickterTextmaus
  • beiMitteGeklickterTextmaus
  • inRichtung
  • löscheBild
  • Abstand
  • Kurs

References:

    Abstand, Kurs, beiLinksGeklickterTextmaus, beiMitteGeklickterTextmaus, beiRechtsGeklickterTextmaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, inRichtung, löscheBild

setzeZylinderOrt setzeNeigung


HC / Grafiken / Absolute Igel-Bewegung / setzeNeigung

setzeNeigung

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeNeigung
setzeKurs setzeRollWinkel

setzeNeigung Winkel

TODO: erst mal verstehen, dann ausbessern!

Neigt den Igel zu einer neuen absoluten Neigung.

Das Argument ist ein Winkel, die Neigung in Grad, positiv von der negativen Z-Achse zu der über die X-Achse drehbaren Positions-Y-Achs ist.

Es ist wichtig Ihre "Orientierung" in 3D zu verstehen.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen. Siehe auch "Neigung".

Beispiel:

perspektivisch
setzeNeigung 45
zeige Neigung		;45

Example:

  • Neigung

References:

    Neigung, Release Notes für Version 4.64

setzeKurs setzeRollWinkel


HC / Grafiken / Absolute Igel-Bewegung / setzeRollWinkel

setzeRollWinkel

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeRollWinkel
setzeNeigung setzeOrientierung

setzeRollWinkel Winkel

Rollt den Igel zu einem neuen absoluten Roll-Winkel.

Das Argument ist ein Winkel, der RollWinkel in Grad, der von der positiven X-Achse zur negativen Z-Axis, drehend um die Y-Achse, positiv ist.

Es ist wichtig Ihre Orientierung in 3D zu verstehen.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen. Siehe auch "RollWinkel".

Beispiel:

perspektivisch
setzeRollWinkel 45
zeige RollWinkel		;45

Example:

  • RollWinkel

References:

    RollWinkel(2), Release Notes für Version 4.64

setzeNeigung setzeOrientierung


HC / Grafiken / Absolute Igel-Bewegung / setzeOrientierung

setzeOrientierung

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] setzeOrientierung
setzeRollWinkel dreheX

setzeOrientierung liste

Richtet den Igel auf eine neue absolute Orientierung aus.

Das Argument ist eine Liste, der [RollWinkel Neigung Kurs] in Grad.

Es ist wichtig Ihre Orientierung in 3D zu verstehen.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen. Siehe auch "Orientierung".

Beispiel:

setzeOrientierung [180 45 90]
zeige Orientierung		;[180 45 90]

Examples:

  • inRichtungXYZ
  • Orientierung
  • AbstandXYZ

References:

    AbstandXYZ, Orientierung, Release Notes für Version 4.64, inRichtungXYZ

setzeRollWinkel dreheX


HC / Grafiken / Absolute Igel-Bewegung / dreheX

dreheX

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] dreheX
setzeOrientierung dreheY

dreheX Winkel

Rotiert den Igel um die X-Achse. Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
löscheSchirm
dreheX 30
vorwärts 100

Reference:

    Release

setzeOrientierung dreheY


HC / Grafiken / Absolute Igel-Bewegung / dreheY

dreheY

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] dreheY
dreheX dreheZ

dreheY Winkel

Rotiert den Igel um die Y-Achse. Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
löscheSchirm
dreheY 30
vorwärts 100

Reference:

    Release

dreheX dreheZ


HC / Grafiken / Absolute Igel-Bewegung / dreheZ

dreheZ

HC [image] Grafiken [image] Absolute Igel-Bewegung [image] dreheZ
dreheY Igel Bewegungs-Abfragen

dreheZ Winkel

Rotiert den Igel um die z-Achse. Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
löscheSchirm
dreheZ 30
vorwärts 100

Reference:

    Release

dreheY Igel Bewegungs-Abfragen


HC / Grafiken / Igel Bewegungs-Abfragen

Igel Bewegungs-Abfragen

HC [image] Grafiken [image] Igel Bewegungs-Abfragen
dreheZ xKoor

Igel Bewegungs-Abfragen

...sind Fragen, die dem Igel gestellt werden können, wobei man Zahlen oder Listen von Zahlen der Eigenschaften des Igels als Antworten bekommt.

Igel Bewegungs-Abfragen

  • xKoor
  • yKoor
  • zKoor
  • Ort
  • OrtXYZ
  • Kurs
  • Neigung
  • RollWinkel
  • Orientierung
  • inRichtung
  • inRichtungXYZ
  • Abstand
  • AbstandXYZ
  • Punkt
  • Quetschung
  • IgelFormen


HC / Grafiken / Igel Bewegungs-Abfragen / xKoor

xKoor

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] xKoor
Igel Bewegungs-Abfragen yKoor

xKoor

Ausgabe ist eine Zahl, die X-Koordinate des Igel.

Beispiel:

setzeX 100
zeige xKoor		;100

References:

    Release Notes für Version 4.64, setzeX, setzeXY, setzeXYZ

Igel Bewegungs-Abfragen yKoor


HC / Grafiken / Igel Bewegungs-Abfragen / yKoor

yKoor

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] yKoor
xKoor zKoor

yKoor

Ausgabe ist eine Zahl, die Y-Koordinate des Igel.

Beispiel:

setzeY 100
zeige yKoor		;100

References:

    Release Notes für Version 4.64, setzeXY, setzeXYZ, setzeY

xKoor zKoor


HC / Grafiken / Igel Bewegungs-Abfragen / zKoor

zKoor

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] zKoor
yKoor Ort

zKoor

Ausgabe ist eine Zahl, die Z-Koordinate des Igel.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
setzeZ 100
zeige zKoor		;100

References:

    Release Notes für Version 4.64, setzeXYZ, setzeZ

yKoor Ort


HC / Grafiken / Igel Bewegungs-Abfragen / Ort

Ort

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] Ort
zKoor OrtXYZ

Ort

Ausgabe ist die momentane Position des Igels, als ein Liste zweier Zahlen, der X- und Y-Koordinate.

Beispiel:

setzeOrt [100 100]
zeige Ort		;[100 100]

Example:

  • Versions-Informationen für Version 4.7

References:

    wirf(3), Abstand(2), AbstandXYZ(2), Auswahlbox(2), DateiAuswahl(2), Diagramm(2), Fenster(2), GanzzahlBox(2), VerzeichnisAuswahl(2), Zahlbox(2), holeAuswahlZahl(2), holeAuswahlmöglichkeiten(2), holePasswortVomBenutzer(2), holeTextVomBenutzer(2), holeZahlVomBenutzer(2), inRichtung(2), inRichtungXYZ(2), setzeOrt(2), setzeTextboxCursor(2), Balken, EllipsenBogen, Fehler-Verarbeitung, Grafiken, KombiBox, ListControl, Listenbox, Meldungsbox, Radioknopf, Release Notes für Version 4.672, Schieberegler, TextControl, TextSchriftgröße, Versions-Informationen für Version 4.7, _setzeOrt, _setzeOrtXYZ, fülleEllipse, geheZu, holeAuswahl, setzeOrtXYZ, statischerText, öffneZumLesen

zKoor OrtXYZ


HC / Grafiken / Igel Bewegungs-Abfragen / OrtXYZ

OrtXYZ

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] OrtXYZ
Ort Kurs

OrtXYZ

Ausgabe ist die momentane Position des Igels, als eine Liste von drei Zahlen, der X-, Y- und Z-Koordinate.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
setzeOrtXYZ [100 100 50]
zeige OrtXYZ		;[100 100 50]

References:

    Release Notes für Version 4.64, setzeOrtXYZ

Ort Kurs


HC / Grafiken / Igel Bewegungs-Abfragen / Kurs

Kurs

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] Kurs
OrtXYZ Neigung

Ausgabe ist ein Winkel, der Igel-Kurs in Grad.

Beispiel:

setzeKurs 90
zeige Kurs		;90

Example:

  • setzeKurs

References:

    setzeKurs(5), Absolute Igel-Bewegung, Ellipse, Orientierung, _setzeOrt, fülleEllipse, fülleKuchen, inRichtung, inRichtungXYZ, löscheBild, setzeOrientierung, setzeQuetschung

OrtXYZ Neigung


HC / Grafiken / Igel Bewegungs-Abfragen / Neigung

Neigung

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] Neigung
Kurs RollWinkel

Ausgabe ist ein Winkel, die Igel-Neigung in Grad.

Es ist wichtig Ihre Orientierung in 3D zu verstehen. Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

setzeNeigung 90
zeige Neigung		;90

Example:

  • setzeNeigung

References:

    setzeNeigung(4), MidiNoteAn(3), MidiNoteAus(3), Midi Glossary(2), MidiAusgabestrom, Orientierung, inRichtungXYZ, setzeOrientierung, setzeOrtInKugelkoordinaten

Kurs RollWinkel


HC / Grafiken / Igel Bewegungs-Abfragen / RollWinkel

RollWinkel

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] RollWinkel
Neigung Orientierung

Ausgabe ist ein Winkel, der Igel-RollWinkel in Grad.

Es ist wichtig Ihre Orientierung in 3D zu verstehen. Siehe auch "setzeRollWinkel".

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

setzeRollWinkel 90
zeige RollWinkel		;90

Example:

  • setzeRollWinkel

References:

    setzeRollWinkel(3), Orientierung, inRichtungXYZ, setzeOrientierung

Neigung Orientierung


HC / Grafiken / Igel Bewegungs-Abfragen / Orientierung

Orientierung

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] Orientierung
RollWinkel inRichtung

Orientierung

Ausgabe ist eine Liste, der [RollWinkel Neigung Kurs] des Igels, jedes in Grad.

Es ist wichtig Ihre Orientierung in 3D zu verstehen. Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

setzeOrientierung [180 45 90]
zeige Orientierung		;[180 45 90]

Example:

  • setzeOrientierung

References:

    setzeOrientierung(4), Versions-Informationen für Version 4.7(2), EllipsoidenTeil, Gestell, Neigung, Objekte, Release Notes für Version 4.64, RollWinkel, achsen, inRichtungXYZ, setzeNeigung, setzeRollWinkel, zeichneGrafik, zumGestellDazu

RollWinkel inRichtung


HC / Grafiken / Igel Bewegungs-Abfragen / inRichtung

inRichtung

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] inRichtung
Orientierung inRichtungXYZ

inRichtung Ort

Ausgabe ist ein Winkel, der Kurs in Grad, auf dem der Igel geführt werden sollte, so dass er von seiner gegenwärtigen Position aus den angegebenen Ort geradlinig erreichen würde.

Beispiel:

zeige inRichtung [100 100]		;45
setzeKurs inRichtung [300 400] vorwärts Abstand [300 400]

Example:

  • Abstand

References:

    Abstand, Release Notes für Version 4.64

Orientierung inRichtungXYZ


HC / Grafiken / Igel Bewegungs-Abfragen / inRichtungXYZ

inRichtungXYZ

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] inRichtungXYZ
inRichtung Abstand

inRichtungXYZ Ort

Ausgabe ist eine Liste, die [RollWinkel Neigung Kurs] enthält, nach der der Igel ausgerichtet werden sollte, so dass er von seiner gegenwärtigen Position geradlinig die Position "Ort" erreichen würde.

Es ist wichtig Ihre Orientierung in 3D zu verstehen.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

zeige inRichtungXYZ [100 100 0]		;[0 0 45]
setzeOrientierung inRichtungXYZ [100 100 100]
vorwärts AbstandXYZ [100 100 100]

Example:

  • AbstandXYZ

References:

    AbstandXYZ(3), Release Notes für Version 4.64, Release Notes für Version 4.65

inRichtung Abstand


HC / Grafiken / Igel Bewegungs-Abfragen / Abstand

Abstand

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] Abstand
inRichtungXYZ AbstandXYZ

Abstand Ort

Ausgabe ist eine Zahl, der Abstand, den der Igel entlang einer geraden Linie zurücklegen muss, um die als Argument gegebene Position "Ort" zu erreichen.

Beispiel:

zeige Abstand [0 100]		;100
zeige Abstand [300 400]		;500
setzeKurs inRichtung [300 400]
vorwärts Abstand [300 400]

Example:

  • inRichtung

References:

    AbstandXYZ, Release Notes für Version 4.64, inRichtung, reelleZahlenFolge

inRichtungXYZ AbstandXYZ


HC / Grafiken / Igel Bewegungs-Abfragen / AbstandXYZ

AbstandXYZ

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] AbstandXYZ
Abstand Punkt

AbstandXYZ Ort

Ausgabe ist eine Zahl, der Abstand, den der Igel entlang einer geraden Linie zurücklegen muss, um die als das Argument angegebene XYZ-Position "Ort" zu erreichen.

Dieses Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

zeige inRichtungXYZ [0 100 0]		;100
zeige inRichtungXYZ [100 100 100]		;173.205080756888
setzeOrientierung inRichtungXYZ [100 100 100]
vorwärts AbstandXYZ [100 100 100]

Example:

  • inRichtungXYZ

References:

    Release Notes für Version 4.65, inRichtungXYZ

Abstand Punkt


HC / Grafiken / Igel Bewegungs-Abfragen / Punkt

Punkt

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] Punkt
AbstandXYZ Quetschung

Punkt

Ausgabe ist die Farbe des Bildpunkts unter dem Igel.

Beispiel:

setzePunkt [0 0] RGB 1 0 0
listeRGBA Punkt		;[1 0 0 1] ;-)

References:

    Versions-Informationen für Version 4.7(4), BitmapPunkt, BitmapSetzePunkt, Element, Release Notes für Version 4.64, Release Notes für Version 4.65, Zahlbox, _setzeElement, zeichneBitmapAuf, zeichneBitmapSkaliertAuf

AbstandXYZ Quetschung


HC / Grafiken / Igel Bewegungs-Abfragen / Quetschung

Quetschung

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] Quetschung
Punkt IgelFormen

Quetschung

Ausgabe ist eine Liste zweier Zahlen, die die X- und Y-Quetschungs-Faktoren enthält, wie von "setzeQuetschung" benutzt. (Aber beachten Sie, dass "setzeQuetschung" zwei Zahlen als Eingaben braucht, nicht ein Liste von Zahlen.)

References:

    Zylinder(2), setzeQuetschung

Punkt IgelFormen


HC / Grafiken / Igel Bewegungs-Abfragen / IgelFormen

IgelFormen

HC [image] Grafiken [image] Igel Bewegungs-Abfragen [image] IgelFormen
Quetschung Igel-Kontrolle

IgelFormen

Ausgabe ist die Reihe der Igel-Formen des aktiven Igles. Sie ist entweder die leere Liste oder eine Reihe von Grafiken.

Beispiel:

a=Reihe 2
a.1=Grafik [Kreis 10]
a.2=Grafik [wiederhole 5 [vorwärts 20 rechts 144]]
setzeIgelFormen a
vorwärts 100
zeige IgelFormen

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

Quetschung Igel-Kontrolle


HC / Grafiken / Igel-Kontrolle

Igel-Kontrolle

HC [image] Grafiken [image] Igel-Kontrolle
IgelFormen zeigeIgel

Igel-Kontrolle

Hier sind verschiedene Kommandos und ein paar Operationen, um den Igel zu steuern.

Igel-Kontrolle

  • zeigeIgel
  • versteckeIgel
  • Randsprung
  • FensterModus
  • Zaun
  • aufzeichnen
  • nichtAufzeichnen
  • aufzeichnenP
  • setzeIgelFormen
  • achsen


HC / Grafiken / Igel-Kontrolle / zeigeIgel

zeigeIgel

HC [image] Grafiken [image] Igel-Kontrolle [image] zeigeIgel
Igel-Kontrolle versteckeIgel

zeigeIgel

macht den Igel sichtbar.

Beispiel:

versteckeIgel
tree
zeigeIgel

Example:

  • versteckeIgel

References:

    sichtbarP, versteckeIgel

Igel-Kontrolle versteckeIgel


HC / Grafiken / Igel-Kontrolle / versteckeIgel

versteckeIgel

HC [image] Grafiken [image] Igel-Kontrolle [image] versteckeIgel
zeigeIgel Randsprung

versteckeIgel

macht den Igel unsichtbar.

Beispiel:

versteckeIgel
tree
zeigeIgel

Examples:

  • beiTextMausRechtsLosgelassen
  • beiRechtsGeklickterTextmaus
  • beiTextMausLinksLosgelassen
  • beiTextMausMitteLosgelassen
  • beiLinksGeklickterTextmaus
  • beiMitteGeklickterTextmaus
  • beiGeklicktemSchaltknopf
  • beiGeklickterAnkreuzbox
  • setzeSchaltknopfZustand
  • setzeTesselationRegeln
  • zerstöreSchaltknopf
  • SchaltknopfZustand
  • setzeGraphErneuern
  • ZerstöreAnkreuzbox
  • Oberflächenspalte
  • Oberflächenstart
  • Oberflächenende
  • setzeAnkreuzbox
  • AnkreuzboxWert
  • SchaltknopfAn
  • AnkreuzboxAn
  • Schaltknopf
  • Oberfläche
  • zeigeIgel
  • Linie

References:

    Linie(2), AnkreuzboxAn, AnkreuzboxWert, Oberfläche, Oberflächenende, Oberflächenspalte, Oberflächenstart, Schaltknopf, SchaltknopfAn, SchaltknopfZustand, ZerstöreAnkreuzbox, beiGeklicktemSchaltknopf, beiGeklickterAnkreuzbox, beiLinksGeklickterTextmaus, beiMitteGeklickterTextmaus, beiRechtsGeklickterTextmaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, setzeAnkreuzbox, setzeGraphErneuern, setzeSchaltknopfZustand, setzeTesselationRegeln, sichtbarP, zeigeIgel, zerstöreSchaltknopf

zeigeIgel Randsprung


HC / Grafiken / Igel-Kontrolle / Randsprung

Randsprung

HC [image] Grafiken [image] Igel-Kontrolle [image] Randsprung
versteckeIgel FensterModus

sagt dem aktuellen Igel, in den Randsprung-Modus zu wechseln:
Von jetzt an, wenn der Igel gefragt wird, sich über den Rand des Grafik-Fenster hinaus zu bewegen, springt er um und erscheint am entgegengesetzten Rand des Fensters wieder. Der obere Rand ist mit dem unteren Rand verbunden, während der linke Rand mit dem rechten Rand verbunden ist. (So ist das Fenster topologisch einem Torus gleichwertig.) Dies ist der Anfangsmodus des Igel. Vergleiche "FensterModus" und "Zaun".

Beispiel:

FensterModus
vorwärts 400
Randsprung
löscheSchirm
vorwärts 400

Example:

  • FensterModus

References:

    FensterModus(2), Bogen, Ellipse, EllipsenBogen, Kreis, TextControl, Zaun, _setzeOrt, _setzeOrtXYZ, reset

versteckeIgel FensterModus


HC / Grafiken / Igel-Kontrolle / FensterModus

FensterModus

HC [image] Grafiken [image] Igel-Kontrolle [image] FensterModus
Randsprung Zaun

FensterModus

sagt dem aktuellen Igel, in den Fenster-Modus zu wechseln: Von jetzt an, wenn der Igel gefragt wird, sich über die Grenze des Grafik-Fenster zu bewegen, wird er sich außerhab des Bildschirms bewegen. Das sichtbare Grafik-Fenster wird so einfach als Teil einer unendlichen Grafik-Ebene angenommen; der Igel kann irgendwo in der Ebene sein. (Wenn Sie den Igel verlieren, wird ihn "Mitte" zum Zentrum des Fensters zurückbringen.) Vergleiche "Randsprung" und "Zaun".

Beispiel:

FensterModus
vorwärts 400
Randsprung
löscheSchirm
vorwärts 400

Examples:

  • setzeTesselationRegeln
  • Randsprung
  • SchattenAn

References:

    Randsprung(2), Bogen, EllipsenBogen, Kreis, SchattenAn, Zaun, setzeTesselationRegeln

Randsprung Zaun


HC / Grafiken / Igel-Kontrolle / Zaun

Zaun

HC [image] Grafiken [image] Igel-Kontrolle [image] Zaun
FensterModus aufzeichnen

sagt dem aktuellen Igel, in den Zaun-Modus zu wechseln:
Von jetzt an, wenn der Igel gefragt wird, sich über den Rand des Grafik-Fenster zu bewegen, wird er sich bewegen, soweit er kann und dann am Rand stehenbleiben mit einer "außerhalb der Grenzen" Fehlermeldung. Vergleiche "Randsprung" und "FensterModus".

Beispiel:

Zaun
vorwärts 400		; igel out of bounds

References:

    Bogen, Ellipse, EllipsenBogen, FensterModus, Kreis, Randsprung

FensterModus aufzeichnen


HC / Grafiken / Igel-Kontrolle / aufzeichnen

aufzeichnen

HC [image] Grafiken [image] Igel-Kontrolle [image] aufzeichnen
Zaun nichtAufzeichnen

aufzeichnen

sagt Logo, sich die Bewegungen des Igels zu merken, so dass sie mit einer anderen Augen-Position oder in anderer Größe wieder abgespielt werden können.

References:

    aufzeichnenP, reset

Zaun nichtAufzeichnen


HC / Grafiken / Igel-Kontrolle / nichtAufzeichnen

nichtAufzeichnen

HC [image] Grafiken [image] Igel-Kontrolle [image] nichtAufzeichnen
aufzeichnen aufzeichnenP

nichtAufzeichnen

sagt Logo, sich die Bewegungen des Igels nicht zu merken. Das erhöht die Geschwindigkeit und verringert den Speicherbedarf von Zeichnungen, aber verhindert die Möglichkeit zum Wiederabspielen in anderer Größe oder von einer anderen Perspektive.


HC / Grafiken / Igel-Kontrolle / aufzeichnenP

aufzeichnenP

HC [image] Grafiken [image] Igel-Kontrolle [image] aufzeichnenP
nichtAufzeichnen setzeIgelFormen

aufzeichnenP
aufzeichnen?

Ausgabe ist wahr, wenn sich Logo die Grafik-Kommandos merkt, sonst falsch.


HC / Grafiken / Igel-Kontrolle / setzeIgelFormen

setzeIgelFormen

HC [image] Grafiken [image] Igel-Kontrolle [image] setzeIgelFormen
aufzeichnenP achsen

setzeIgelFormen GrafikReihe

Kommando. Es setzt dei Igel-Formen-Reihe des aktiven Igels zur "GrafikReihe", die eine Reihe von Grafiken sein muss.

Beispiel:

a=Reihe 2
a.1=Grafik [Kreis 10]
a.2=Grafik [wiederhole 5 [vorwärts 20 rechts 144]]
setzeIgelFormen a
vorwärts 100

Examples:

  • Versions-Informationen für Version 4.7
  • IgelFormen

References:

    IgelFormen, Versions-Informationen für Version 4.7

aufzeichnenP achsen


HC / Grafiken / Igel-Kontrolle / achsen

achsen

HC [image] Grafiken [image] Igel-Kontrolle [image] achsen
setzeIgelFormen Fenster-Kontrolle

achsen (Bibliotheksprozedur)

Kommando, das ein Achsenkreuz zeichnet, um ein Koordinatensystem zu sehen. Dies ist sehr nützlich zur Orientierung im perspektivischen Modus.

Example:

  • orthographisch

Reference:

    orthographisch

setzeIgelFormen Fenster-Kontrolle


HC / Grafiken / Fenster-Kontrolle

Fenster-Kontrolle

HC [image] Grafiken [image] Fenster-Kontrolle
achsen löscheBild

Fenster-Kontrolle

Hier sind verschiedene Kommandos und ein paar Operationen, um das aktive Graph-Fenster zu kontrollieren.

Fenster-Kontrolle

  • löscheBild
  • löscheSchirm
  • perspektivisch
  • zweidimensional
  • orthographisch
  • setzeAuge
  • Textmodus
  • GrafikGroß
  • geteilterBildschirm
  • setzeVariablenFensterteiler
  • setzeFensterteilerAufrufe
  • Vollbildmodus
  • keinVollbildmodus
  • setzeQuetschung
  • Einfachpuffer
  • DoppelPufferung
  • zeichneNochmal
  • setzeGraphErneuern
  • erneuereGraph
  • erneuereVariablenliste
  • erneuereVariablenlisteBeiSchritt
  • Aufrufliste
  • erneuereAufrufliste
  • verteileMeldungen
  • scrolle
  • kalibriereScrolling
  • rotatescene
  • setzeSchirmbereich
  • betreteGrafik
  • verlasseGrafik
  • setzePlayOnSwap


HC / Grafiken / Fenster-Kontrolle / löscheBild

löscheBild

HC [image] Grafiken [image] Fenster-Kontrolle [image] löscheBild
Fenster-Kontrolle löscheSchirm

löscheBild

löscht alle Zeichnungen des aktiven Grafik-Fensters. Der Zustand des Igels (Position, Kurs, Stiftmodus, etc.) wird nicht verändert.

Beispiel:

setzeXY 200 100
setzeKurs 30
löscheBild

Examples:

  • setzeGraphErneuern
  • Gitarren

References:

    Gitarren, löscheSchirm, setzeGraphErneuern, zerstöreGraph

Fenster-Kontrolle löscheSchirm


HC / Grafiken / Fenster-Kontrolle / löscheSchirm

löscheSchirm

HC [image] Grafiken [image] Fenster-Kontrolle [image] löscheSchirm
löscheBild perspektivisch

löscheSchirm löscheSchirm

löscht das aktive Grafik-Fenster und schickt den Igel zu seiner Ausgangsstellung und auf seinen Ausgangskurs. Wie "Mitte" und "LöscheBild" zusammen.

Examples:

  • beiTextMausRechtsLosgelassen
  • beiRechtsGeklickterTextmaus
  • beiTextMausLinksLosgelassen
  • beiTextMausMitteLosgelassen
  • beiLinksGeklickterTextmaus
  • beiMitteGeklickterTextmaus
  • zeichneBitmapSkaliertAuf
  • setzeTiefentestFunktion
  • setzeTesselationRegeln
  • zeichneBitmapSchnell
  • kalibriereScrolling
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeGroßKleinEgal
  • setzeSchattenfarbe
  • setzeSpecularLicht
  • setzeFüllToleranz
  • setzeNebeldichte
  • zeichneBitmapAuf
  • ModelviewMatrix
  • setzeNebelModus
  • setzePunktgröße
  • setzeStiftdicke
  • speichereSchirm
  • TexturschriftAn
  • orthographisch
  • TiefpaßFilter2
  • EllipsenBogen
  • setzeLichtOrt
  • setzePunktXYZ
  • TiefpaßFilter
  • FensterModus
  • GrafikAnfang
  • setzePunktXY
  • wirfSchatten
  • fülleBitmap
  • fülleKuchen
  • Randsprung
  • SchattenAn
  • VideoFrame
  • VideoStart
  • Ellipsoid
  • setzeAuge
  • VideoEnde
  • setzeOrt
  • vorwärts
  • Zylinder
  • Vieleck
  • dreheX
  • dreheY
  • dreheZ
  • Grafik
  • Textur
  • fülle
  • RGBA
  • TSHA
  • def

References:

    Zylinder(4), setzeGroßKleinEgal(4), def(3), setzePunktXYZ(3), EllipsenBogen(2), ModelviewMatrix(2), TiefpaßFilter(2), TiefpaßFilter2(2), vorwärts(2), zeichneBitmapAuf(2), zeichneBitmapSchnell(2), Ellipsoid, FensterModus, Grafik, GrafikAnfang, RGBA, Randsprung, SchattenAn, TSHA, Textur, TexturschriftAn, VideoEnde, VideoFrame, VideoStart, Vieleck, beiLinksGeklickterTextmaus, beiMitteGeklickterTextmaus, beiRechtsGeklickterTextmaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, buglist für Version 4.65, dreheX, dreheY, dreheZ, fülle, fülleBitmap, fülleKuchen, kalibriereScrolling, löscheSchatten, orthographisch, reset, setzeAuge, setzeDiffusesLicht, setzeFüllToleranz, setzeLichtOrt, setzeNebelModus, setzeNebeldichte, setzeOrt, setzePunktXY, setzePunktgröße, setzeSchattenfarbe, setzeSpecularLicht, setzeStiftdicke, setzeTesselationRegeln, setzeTiefentestFunktion, setzeUmgebungslicht, speichereSchirm, wirfSchatten, zeichneBitmapSkaliertAuf

löscheBild perspektivisch


HC / Grafiken / Fenster-Kontrolle / perspektivisch

perspektivisch

HC [image] Grafiken [image] Fenster-Kontrolle [image] perspektivisch
löscheSchirm zweidimensional

perspektivisch

Kommando, das das aktive Grafik-Fenster für 3D-Befehle vorbereitet, und intern

    setzeAuge {400 400 600} {0 0 0} {0 1 0}
aufruft.

Beispiel:

perspektivisch
axes

Examples:

  • setzeTiefentestFunktion
  • setzeMaterialShininess
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSchattenfarbe
  • setzeSpecularLicht
  • Oberflächenspalte
  • Oberflächenstart
  • setzeNebeldichte
  • ZylinderlinienAn
  • EllipsoidenTeil
  • Oberflächenende
  • setzeNebelModus
  • setzeRollWinkel
  • setzeStiftdicke
  • zweidimensional
  • orthographisch
  • setzeLichtOrt
  • setzePunktXYZ
  • TiefentestAus
  • setzeNeigung
  • VieleckStart
  • wirfSchatten
  • rolleRechts
  • setzeOrtXYZ
  • VieleckEnde
  • Oberfläche
  • rolleLinks
  • SchattenAn
  • setzePunkt
  • Ellipsoid
  • setzeAuge
  • setzeXYZ
  • vorwärts
  • Zylinder
  • Vieleck
  • dreheX
  • dreheY
  • dreheZ
  • Grafik
  • OrtXYZ
  • runter
  • setzeZ
  • Kugel
  • zKoor
  • rauf

References:

    setzeXYZ(3), TiefentestAus(2), setzeNebelModus(2), BeleuchtungAn, Ellipsoid, EllipsoidenTeil, Grafik, Kugel, Oberfläche, Oberflächenende, Oberflächenspalte, Oberflächenstart, OrtXYZ, Release Notes für Version 4.64, SchattenAn, TiefentestAn, Vieleck, VieleckEnde, VieleckStart, Zylinder, ZylinderlinienAn, dreheX, dreheY, dreheZ, orthographisch, rauf, rolleLinks, rolleRechts, runter, setzeAuge, setzeDiffusesLicht, setzeLichtOrt, setzeMaterialShininess, setzeNebeldichte, setzeNeigung, setzeOrtXYZ, setzePunkt, setzePunktXYZ, setzeRollWinkel, setzeSchattenfarbe, setzeSpecularLicht, setzeStiftdicke, setzeTiefentestFunktion, setzeUmgebungslicht, setzeZ, vorwärts, wirfSchatten, zKoor, zweidimensional

löscheSchirm zweidimensional


HC / Grafiken / Fenster-Kontrolle / zweidimensional

zweidimensional

HC [image] Grafiken [image] Fenster-Kontrolle [image] zweidimensional
perspektivisch orthographisch

zweidimensional

Kommando, das das aktive Grafik-Fenster für 2D-Befehle vorbereitet, nach dem perspektivischen Modus.

Beispiel:

perspektivisch
axes
warte 1000
unperspecitve
axes

References:

    Release Notes für Version 4.64, reset

perspektivisch orthographisch


HC / Grafiken / Fenster-Kontrolle / orthographisch

orthographisch

HC [image] Grafiken [image] Fenster-Kontrolle [image] orthographisch
zweidimensional setzeAuge

orthographisch

Kommando, um den Projektionsmodus von Zentralperspektive nach Parallelperspektive zu ändern.

Parallelperspektive kann für Konstruktionspläne nötig sein.

Beispiel:

löscheSchirm
perspektivisch
achsen
setzeStiftFarbe "rot
orthographisch
für [x -1000 1000 200][
    für [y -1000 1000 200][
        für [z -1000 1000 200][
            StiftHoch setzeXYZ x y z StiftAb Kugel 50]]]

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

zweidimensional setzeAuge


HC / Grafiken / Fenster-Kontrolle / setzeAuge

setzeAuge

HC [image] Grafiken [image] Fenster-Kontrolle [image] setzeAuge
orthographisch Textmodus

setzeAuge Auge Zentrum Hochvektor

Kommando, das die 3D Projektionsparameter auf neue Werte setzt. Alle Parameter müssen 3D Reihen sein, wie {400 400 600}.

Auge: die Position des Beobachter-Augpunkts relativ zu {0 0 0}, Standart ist {400 400 600} im perspektivischen Modus.

Zentrum: die Position des Zentrums der Szene, Standart ist {0 0 0}.

Hochvektor: die Richtung, die nach oben auf dem Bildschirm ist, Standart ist {0 1 0}, so wird Y nach oben sein, im perspektivischen Modus.

Beispiel:

löscheSchirm
perspektivisch
axes
setzeAuge {100 400 600}{0 0 0}{0 1 0}
zeichneNochmal

References:

    Release Notes für Version 4.64, Release Notes für Version 4.65, perspektivisch, rotatescene

orthographisch Textmodus


HC / Grafiken / Fenster-Kontrolle / Textmodus

Textmodus

HC [image] Grafiken [image] Fenster-Kontrolle [image] Textmodus
setzeAuge GrafikGroß

Textmodus

ordnet die Fenster in Größe und Position so an, um den verfügbaren Platz im Text-Konsolen-Fenster zu maximieren (das für die Interaktion mit Logo benutzte Fenster). Siehe auch "geteilterBildschirm" und "GrafikGroß".

References:

    GrafikGroß, WortUnterCursor, geteilterBildschirm

setzeAuge GrafikGroß


HC / Grafiken / Fenster-Kontrolle / GrafikGroß

GrafikGroß

HC [image] Grafiken [image] Fenster-Kontrolle [image] GrafikGroß
Textmodus geteilterBildschirm

GrafikGroß

ordnet die Fenster in Größe und Position so an, um den verfügbaren Platz im Grafik-Fenster zu maximieren. Siehe auch "geteilterBildschirm" und "Textmodus".

Da es ein Text Fenster geben muss, das erlaubt zu schreiben, schaltet Logo automatisch von "GrafikGroß" auf "geteilterBildschirm" um, wann auch immer irgendetwas geschrieben wird.

References:

    FensterVollbild, Textmodus, geteilterBildschirm

Textmodus geteilterBildschirm


HC / Grafiken / Fenster-Kontrolle / geteilterBildschirm

geteilterBildschirm

HC [image] Grafiken [image] Fenster-Kontrolle [image] geteilterBildschirm
GrafikGroß setzeVariablenFensterteiler

geteilterBildschirm
(geteilterBildschirm Verhältnis)
(geteilterBildschirm Verhältnis)

ordnet die Fenster in Größe und Position so an, um etwas Raum für Text-Interaktion zu erlauben, wobei das Grafik-Fenster sichtbar bleibt. Das optionale Verhältnis muss eine Zahl im Bereich 0..1 sein. 0 bedeutet, das Grafik-Fenster wird minimalisiert, das Text-Fenster wird maximiert. 1 bedeutet das Gegenteil. 0.5 bedeutet, sie werden sich den verfügbaren Platz zu gleichen Teilen teilen. Siehe auch "Textmodus" und "GrafikGroß".

References:

    GrafikGroß(2), Release Notes für Version 4.672(2), Textmodus

GrafikGroß setzeVariablenFensterteiler


HC / Grafiken / Fenster-Kontrolle / setzeVariablenFensterteiler

setzeVariablenFensterteiler

HC [image] Grafiken [image] Fenster-Kontrolle [image] setzeVariablenFensterteiler
geteilterBildschirm setzeFensterteilerAufrufe

setzeVariablenFensterteiler Verhältnis

setzt den Fenster-Teiler zwischen der Text-Konsole und dem Vars und Aufrufe-Fenster zum Verhältnis. Das Verhältnis muss eine Zahl im Bereich 0..1 sein.

Beispiel:

setzeVariablenFensterteiler 0.6


HC / Grafiken / Fenster-Kontrolle / setzeFensterteilerAufrufe

setzeFensterteilerAufrufe

HC [image] Grafiken [image] Fenster-Kontrolle [image] setzeFensterteilerAufrufe
setzeVariablenFensterteiler Vollbildmodus

setzeFensterteilerAufrufe Verhältnis

setzt den Fenster-Teiler zwischen dem Vars-Fenster und dem Aufrufe-Fenster zum "Verhältnis". Das Verhältnis muss eine Zahl im Bereich 0..1 sein.

Beispiel:

setzeFensterteilerAufrufe 0.6


HC / Grafiken / Fenster-Kontrolle / Vollbildmodus

Vollbildmodus

HC [image] Grafiken [image] Fenster-Kontrolle [image] Vollbildmodus
setzeFensterteilerAufrufe keinVollbildmodus

Vollbildmodus

maximiert das Logo-Hauptfenster auf volle Bildschirmgröße. Um diesen Modus zu verlassen, führen Sie das Kommando "keinVollbildmodus" aus.

Reference:

    keinVollbildmodus(2)

setzeFensterteilerAufrufe keinVollbildmodus


HC / Grafiken / Fenster-Kontrolle / keinVollbildmodus

keinVollbildmodus

HC [image] Grafiken [image] Fenster-Kontrolle [image] keinVollbildmodus
Vollbildmodus setzeQuetschung

keinVollbildmodus

verläßt den Vollbildmodus, falls früher mit "Vollbildmodus" in ihn gewechselt wurde.

Reference:

    Vollbildmodus

Vollbildmodus setzeQuetschung


HC / Grafiken / Fenster-Kontrolle / setzeQuetschung

setzeQuetschung

HC [image] Grafiken [image] Fenster-Kontrolle [image] setzeQuetschung
keinVollbildmodus Einfachpuffer

setzeQuetschung xscale yscale

stellt den Abbildungsmaßstab und die Skalierung der Graphikenanzeige ein. Nachdem dieser Befehl benutzt worden ist, wird sämtliche Grafik in dem aktiven Fenster so skaliert, dass horizontale und vertikale Strecken um die zwei als Eingaben gegebenen Zahlen vervielfacht werden.

Zum Beispiel, nach der Anweisung

    setzeQuetschung 2 1
wird der Igel bei einem Kurs von 45 Grad zweimal so weit horizontal wie vertikal gehen. Wenn Ihre Quadrate nicht quadratisch aussehen, versuchen Sie diesen Befehl. (Alternativ können Sie die Quetschung beliebig fehlstellen, um Ellipsen statt Kreisen zu zeichnen.)

Reference:

    Quetschung(2)

keinVollbildmodus Einfachpuffer


HC / Grafiken / Fenster-Kontrolle / Einfachpuffer

Einfachpuffer

HC [image] Grafiken [image] Fenster-Kontrolle [image] Einfachpuffer
setzeQuetschung DoppelPufferung

setzt das aktive Grafik-Fenster in den Einfachpuffer-Modus.
Auf einigen Graphikenkarten benimmt sich die SwapBuffers()-C-Funktion seltsam, dies ist für jene schlechten Fälle.

Nachdem "Einfachpuffer" aufgerufen wurde, geht jedes Zeichnen direkt ins Grafikfenster.

Mehrere Demos können in diesem Modus allerdings flackern.

References:

    DoppelPufferung, Release Notes für Version 4.65, setzePlayOnSwap

setzeQuetschung DoppelPufferung


HC / Grafiken / Fenster-Kontrolle / DoppelPufferung

DoppelPufferung

HC [image] Grafiken [image] Fenster-Kontrolle [image] DoppelPufferung
Einfachpuffer zeichneNochmal

DoppelPufferung

setzt das aktive Grafik-Fenster in den Doppelpufferungs-Modus. Dies kann nötig sein, wenn Sie auf Einfachpuffer umgeschaltet hatten, und jetzt aber zurück zum Standart schalten wollen.

References:

    Release Notes für Version 4.65(2), reset

Einfachpuffer zeichneNochmal


HC / Grafiken / Fenster-Kontrolle / zeichneNochmal

zeichneNochmal

HC [image] Grafiken [image] Fenster-Kontrolle [image] zeichneNochmal
DoppelPufferung setzeGraphErneuern

zeichneNochmal

zeichnet die im Grafik-Fenster aufgezeichnete Grafik erneut.

Examples:

  • setzeLichtOrt
  • setzeAuge

References:

    Fenster-Stile(2), Release Notes für Version 4.69(2), SchattenAn, löscheSchatten, rotatescene, setzeAuge, setzeLichtOrt

DoppelPufferung setzeGraphErneuern


HC / Grafiken / Fenster-Kontrolle / setzeGraphErneuern

setzeGraphErneuern

HC [image] Grafiken [image] Fenster-Kontrolle [image] setzeGraphErneuern
zeichneNochmal erneuereGraph

setzeGraphErneuern wf

setzt die automatische Aktualisierung des Grafik-Fensters zu entweder wahr oder falsch. Wenn falsch, dann werden neue Zeichnungen nur auf den verborgenen Speicher-Schirm gezeichnet, und dieser wird nicht auf den wirklichen Grafik-Schirm kopiert, was gut für Animationen ist.

Beispiel:

zu rotateTree
  versteckeIgel
  setzeGraphAktualisieren falsch
  dauernd
  [ löscheBild
    rechts 1
    tree 6 100
    erneuereGraph
    wenn Taste? [Halt]
  ]
Ende


HC / Grafiken / Fenster-Kontrolle / erneuereGraph

erneuereGraph

HC [image] Grafiken [image] Fenster-Kontrolle [image] erneuereGraph
setzeGraphErneuern erneuereVariablenliste

erneuereGraph

aktualisiert sofort den Grafikbildschirm vom Speicher-Bildschirm. Dies ist gut für Animationen zusammen mit:

    setzeGraphAktualisieren falsch

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiLinksDoppeltGeklickterTextmaus
  • beiMitteDoppeltgeklickterTextmaus
  • beiRechtsGeklickterGraphMaus
  • beiTextMausRechtsLosgelassen
  • beiRechtsGeklickterTextmaus
  • beiTextMausLinksLosgelassen
  • beiTextMausMitteLosgelassen
  • beiÄnderungInReellerZahlbox
  • beiLinksGeklickterTextmaus
  • beiMitteGeklickterTextmaus
  • setzeReelleZahlboxBereich
  • beiGeklicktemSchaltknopf
  • beiGeklickterAnkreuzbox
  • beiRechtsGeklickterMaus
  • setzeSchaltknopfZustand
  • beiGanzzahlBoxÄnderung
  • setzeReelleZahlboxWert
  • beiGraphMausBewegung
  • GraphOnMouseLeftDown
  • beiTextMausbewegung
  • FloatControlDestroy
  • zerstöreSchaltknopf
  • SchaltknopfZustand
  • setzeGraphErneuern
  • ZerstöreAnkreuzbox
  • setzeFenstersizer
  • beiMausBewegung
  • setzeAnkreuzbox
  • AnkreuzboxWert
  • beiKnopfdruck
  • SchaltknopfAn
  • zerstöreKnopf
  • AnkreuzboxAn
  • Schaltknopf
  • ZahlboxWert
  • VideoFrame
  • VideoStart
  • VideoEnde
  • ZahlboxAn
  • Gestell
  • KnopfAn
  • Zahlbox

References:

    Gestell(4), Schaltknopf(2), beiGeklicktemSchaltknopf(2), beiGeklickterAnkreuzbox(2), beiKnopfdruck(2), setzeFenstersizer(2), AnkreuzboxAn, AnkreuzboxWert, FloatControlDestroy, GraphOnMouseLeftDown, KnopfAn, Release Notes für Version 4.64, SchaltknopfAn, SchaltknopfZustand, SchattenAn, VideoEnde, VideoFrame, VideoStart, Zahlbox, ZahlboxAn, ZahlboxWert, ZerstöreAnkreuzbox, beiGanzzahlBoxÄnderung, beiGraphMausBewegung, beiLinksDoppeltGeklickterTextmaus, beiLinksGeklickterTextmaus, beiMausBewegung, beiMitteDoppeltgeklickterTextmaus, beiMitteGeklickterTextmaus, beiRechtsDoppeltgeklickterTextmaus, beiRechtsGeklickterGraphMaus, beiRechtsGeklickterMaus, beiRechtsGeklickterTextmaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, beiTextMausbewegung, beiÄnderungInReellerZahlbox, setzeAnkreuzbox, setzeGraphErneuern, setzeReelleZahlboxBereich, setzeReelleZahlboxWert, setzeSchaltknopfZustand, zerstöreKnopf, zerstöreSchaltknopf

setzeGraphErneuern erneuereVariablenliste


HC / Grafiken / Fenster-Kontrolle / erneuereVariablenliste

erneuereVariablenliste

HC [image] Grafiken [image] Fenster-Kontrolle [image] erneuereVariablenliste
erneuereGraph erneuereVariablenlisteBeiSchritt

erneuereVariablenliste

Aktualisiert das Variablen-Fenster, das alle Variablen und ihre Werte zeigt. Dies ist gut zum Fehlersuchen.

Examples:

  • verteileMeldungen
  • TextMausOrt
  • TextMausX
  • TextMausY

References:

    Release Notes für Version 4.64, TextMausOrt, TextMausX, TextMausY, erneuereVariablenlisteBeiSchritt, verteileMeldungen

erneuereGraph erneuereVariablenlisteBeiSchritt


HC / Grafiken / Fenster-Kontrolle / erneuereVariablenlisteBeiSchritt

erneuereVariablenlisteBeiSchritt

HC [image] Grafiken [image] Fenster-Kontrolle [image] erneuereVariablenlisteBeiSchritt
erneuereVariablenliste Aufrufliste

erneuereVariablenlisteBeiSchritt yesno

setzt das Aufrufen von erneuereVariablenliste im Einzelschritt-Modus zu wahr oder falsch. Dies kann die Leistung sehr verbessern, wenn Sie viele Variablen haben und das Variablen-Fenster anzeigen lassen.

Beispiel:

erneuereVariablenlisteBeiSchritt falsch

Reference:

    Release Notes für Version 4.682

erneuereVariablenliste Aufrufliste


HC / Grafiken / Fenster-Kontrolle / Aufrufliste

Aufrufliste

HC [image] Grafiken [image] Fenster-Kontrolle [image] Aufrufliste
erneuereVariablenlisteBeiSchritt erneuereAufrufliste

Aufrufliste

Ausgabe ist eine Liste, die alle verschachtelten Benutzerprozedur-Aufrufe mit ihren Parametern enthält.


HC / Grafiken / Fenster-Kontrolle / erneuereAufrufliste

erneuereAufrufliste

HC [image] Grafiken [image] Fenster-Kontrolle [image] erneuereAufrufliste
Aufrufliste verteileMeldungen

erneuereAufrufliste

Aktualisiert das Aufrufe-Fenster, das alle geschachtelten Aufrufe und ihre Parameter zeigt. Es ist praktisch, die Aufrufe zu sehen, wenn man in einem großen Programm ist und man z.B. wissen will, wo ein Stapelüberlauf auftritt.

Reference:

    Release Notes für Version 4.64

Aufrufliste verteileMeldungen


HC / Grafiken / Fenster-Kontrolle / verteileMeldungen

verteileMeldungen

HC [image] Grafiken [image] Fenster-Kontrolle [image] verteileMeldungen
erneuereAufrufliste scrolle

verteileMeldungen

Verteilt alle noch ausstehenden Fenster-Meldungen, d. h. Mausbewegungen, Maus-Klicks, Tastendrücke etc. Dies ist notwendig für sofortige Reaktionen auf Benutzereingabe, besonders Mausaktionen. Siehe Beispiel bounce2.lg.

Beispiel:

dauernd [
    verteileMeldungen
    m=Mausort
    erneuereVariablenliste
    warte 1
]

Examples:

  • TextMausOrt
  • TextMausX
  • TextMausY

References:

    Release Notes für Version 4.64, TextMausOrt, TextMausX, TextMausY

erneuereAufrufliste scrolle


HC / Grafiken / Fenster-Kontrolle / scrolle

scrolle

HC [image] Grafiken [image] Fenster-Kontrolle [image] scrolle
verteileMeldungen kalibriereScrolling

scrolle Größenliste Versatzliste

Kommando, das das Grafik-Fenster von Größe "Größenliste" rechts unterhalb des Igels um "Versatzliste" Punke scrollt,

Beispiele: scrolltest.lg und scrolltest2.lg

Example:

  • kalibriereScrolling

References:

    kalibriereScrolling(3), Release Notes für Version 4.64

verteileMeldungen kalibriereScrolling


HC / Grafiken / Fenster-Kontrolle / kalibriereScrolling

kalibriereScrolling

HC [image] Grafiken [image] Fenster-Kontrolle [image] kalibriereScrolling
scrolle rotatescene

kalibriereScrolling VersatzListe

Ausgabe ist die Versetzung, um die "scrolle" scrollen wird um Versatz Punkten. Dies ist nötig, weil Logo-Koordinaten in Fenster-Koordinaten skaliert werden, und "scrolle" nur um ganze Punkte scrollen kann, die wahrscheinlich keine Ganzzahl in Logokoordinaten sein werden.

So wenn Sie den Bildschirm um zwei Punkte in X-Richtung scrollen wollen, werden Sie dann das Folgende ausführen müssen:

löscheSchirm rbox fülle
_setzeOrt [-400 299]
scc=scrollCal [2 0]
scrolle [800 600] scc

Reference:

    Release Notes für Version 4.64

scrolle rotatescene


HC / Grafiken / Fenster-Kontrolle / rotatescene

rotatescene

HC [image] Grafiken [image] Fenster-Kontrolle [image] rotatescene
kalibriereScrolling setzeSchirmbereich

rotatescene (Bibliotheksprozedur)

Kommando, das setzeAuge und zeichneNochmal in einer Schleife mit Benutzer-Interaktion aufruft, um eine gezeichnet 3D-Szene rotieren zu lassen. Das wird in vielen Beispielen gezeigt.

Examples:

  • setzeSchattenfarbe
  • Oberflächenspalte
  • Oberflächenstart
  • setzeNebeldichte
  • EllipsoidenTeil
  • Oberflächenende
  • setzePunktXYZ
  • VieleckStart
  • wirfSchatten
  • VieleckEnde
  • Oberfläche
  • Ellipsoid
  • setzeXYZ
  • Kugel

References:

    setzePunktXYZ(3), setzeXYZ(3), Ellipsoid, EllipsoidenTeil, Kugel, Oberfläche, Oberflächenende, Oberflächenspalte, Oberflächenstart, Release Notes für Version 4.65, Release Notes für Version 4.69, VieleckEnde, VieleckStart, setzeNebeldichte, setzeSchattenfarbe, wirfSchatten

kalibriereScrolling setzeSchirmbereich


HC / Grafiken / Fenster-Kontrolle / setzeSchirmbereich

setzeSchirmbereich

HC [image] Grafiken [image] Fenster-Kontrolle [image] setzeSchirmbereich
rotatescene betreteGrafik

setzeSchirmbereich

Wenn Sie Grafik-Fenster mit einer definierten Form benutzen, dann könnte setzeSchirmbereich nützlich sein, um den Standart [800 600] logischer Bildpunkte zu überschreiben.

Example:

  • Versions-Informationen für Version 4.7

References:

    Release Notes für Version 4.685, Versions-Informationen für Version 4.7

rotatescene betreteGrafik


HC / Grafiken / Fenster-Kontrolle / betreteGrafik

betreteGrafik

HC [image] Grafiken [image] Fenster-Kontrolle [image] betreteGrafik
setzeSchirmbereich verlasseGrafik

betreteGrafik

Kommando, um Logo zu sagen, dass der aktuelle Thread eine Grafik für sich beanspruchen wird. Das ist nützlich in einer multithreaded Anwendung, wenn ein Thread weiß, dass er viel zeichnen wird, um schneller zeichnen zu können. Die Anzahl der Aufrufe an "betreteGrafik" und "verlasseGrafik" sollte gleich sein, ehe das Program beendet wird. Sonst mag es passieren, dass eine Grafik auf Zeichenbefehle nicht reagiert.

Für ein Beispiel siehe testfiber.lg.

Reference:

    verlasseGrafik

setzeSchirmbereich verlasseGrafik


HC / Grafiken / Fenster-Kontrolle / verlasseGrafik

verlasseGrafik

HC [image] Grafiken [image] Fenster-Kontrolle [image] verlasseGrafik
betreteGrafik setzePlayOnSwap

verlasseGrafik

Kommando, um Logo zu sagen, dass der aktuelle Thread eine Grafik nicht mehr für sich beanspruchen wird. Das ist nützlich in einer multithreaded Anwendung, wenn ein Thread weiß, dass er nicht viel zeichnen wird, damit andere Threads schneller zeichnen können. Die Anzahl der Aufrufe an "betreteGrafik" und "verlasseGrafik" sollte gleich sein, ehe das Program beendet wird. Sonst mag es passieren, dass eine Grafik auf Zeichenbefehle nicht reagiert.

Für ein Beispiel siehe testfiber.lg.

Reference:

    betreteGrafik

betreteGrafik setzePlayOnSwap


HC / Grafiken / Fenster-Kontrolle / setzePlayOnSwap

setzePlayOnSwap

HC [image] Grafiken [image] Fenster-Kontrolle [image] setzePlayOnSwap
verlasseGrafik Igel- und Fenster-Fragen

setzePlayOnSwap wf

Kommando. Setzt die interne Zustandsvariable playOnSwap auf den boolschen Wert "wf". Wenn wahr, wird im Einfachpuffer-Modus der aktive Graph seine aufgezeichneten Grafikbefehle abspielen, wann immer die Puffer im Doppelpuffer-Modus ausgetauscht würden. Dies stellt sicher, dass nachdem ein Fenster teilweise von einem anderen überdeckt war, das Grafik-Fenster korrekt wieder gezeichnet wird.

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

verlasseGrafik Igel- und Fenster-Fragen


HC / Grafiken / Igel- und Fenster-Fragen

Igel- und Fenster-Fragen

HC [image] Grafiken [image] Igel- und Fenster-Fragen
setzePlayOnSwap sichtbarP

Igel- und Fenster-Fragen

...sind Fragen mit boolschen Antworten, die Sie den Igel und die Maus fragen können.

Igel- und Fenster-Fragen

  • sichtbarP
  • Mausort
  • TextMausOrt
  • TextMausX
  • TextMausY
  • Maustasten


HC / Grafiken / Igel- und Fenster-Fragen / sichtbarP

sichtbarP

HC [image] Grafiken [image] Igel- und Fenster-Fragen [image] sichtbarP
Igel- und Fenster-Fragen Mausort

sichtbarP
sichtbar?

Ausgabe ist wahr, wenn der Igel gezeigt wird (sichtbar ist), falsch, wenn der Igel versteckt wird. Siehe "zeigeIgel" und "versteckeIgel".


HC / Grafiken / Igel- und Fenster-Fragen / Mausort

Mausort

HC [image] Grafiken [image] Igel- und Fenster-Fragen [image] Mausort
sichtbarP TextMausOrt

Mausort

Ausgabe ist die Position der Maus im Grafik-Fenster als eine Liste dreier Gleitpunktzahlen.

Examples:

  • beiRechtsGeklickterGraphMaus
  • beiMitteGeklickterGraphMaus
  • beiRechtsGeklickterMaus
  • beiMitteGeklickterMaus
  • beiGraphMausBewegung
  • GraphOnMouseLeftDown
  • verteileMeldungen
  • beiMausBewegung

References:

    GraphOnMouseLeftDown, TextMausOrt, beiGraphMausBewegung, beiMausBewegung, beiMitteGeklickterGraphMaus, beiMitteGeklickterMaus, beiRechtsGeklickterGraphMaus, beiRechtsGeklickterMaus, verteileMeldungen

sichtbarP TextMausOrt


HC / Grafiken / Igel- und Fenster-Fragen / TextMausOrt

TextMausOrt

HC [image] Grafiken [image] Igel- und Fenster-Fragen [image] TextMausOrt
Mausort TextMausX

TextMausOrt

Ausgabe ist die Position der Maus im Konsole-Fenster als eine Liste zweier Ganzzahlen, die den X- und Y-MausOrt in Zeichen darstellen.

Beispiel:

dauernd [
    textpos=TextMausOrt
    verteileMeldungen
    erneuereVariablenliste
]
;schauen Sie das Vars Fenster an, während Sie die Maus in der Konsole bewegen!

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiLinksDoppeltGeklickterTextmaus
  • beiMitteDoppeltgeklickterTextmaus
  • beiTextMausRechtsLosgelassen
  • beiRechtsGeklickterTextmaus
  • beiTextMausLinksLosgelassen
  • beiTextMausMitteLosgelassen
  • beiTextMausbewegung

References:

    beiRechtsDoppeltgeklickterTextmaus(3), beiLinksDoppeltGeklickterTextmaus(2), beiMitteDoppeltgeklickterTextmaus(2), beiTextMausbewegung(2), beiRechtsGeklickterTextmaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen

Mausort TextMausX


HC / Grafiken / Igel- und Fenster-Fragen / TextMausX

TextMausX

HC [image] Grafiken [image] Igel- und Fenster-Fragen [image] TextMausX
TextMausOrt TextMausY

TextMausX

Ausgabe ist die Spaltenkoordinate der Maus im Konsole-Fenster, in Einheiten von Zeichen.

Beispiel:

dauernd [
    textxpos=TextMausX
    verteileMeldungen
    erneuereVariablenliste
]
;schauen Sie das Vars Fenster an, während Sie die Maus in der Konsole bewegen!


HC / Grafiken / Igel- und Fenster-Fragen / TextMausY

TextMausY

HC [image] Grafiken [image] Igel- und Fenster-Fragen [image] TextMausY
TextMausX Maustasten

TextMausY

Ausgabe ist die Zeilenkoordinate der Maus im Konsole-Fenster, in Einheiten von Zeichen.

Beispiel:

dauernd [
    textypos=TextMausY
    verteileMeldungen
    erneuereVariablenliste
]
;schauen Sie das Vars Fenster an, während Sie die Maus in der Konsole bewegen!

Reference:

    Release Notes für Version 4.672

TextMausX Maustasten


HC / Grafiken / Igel- und Fenster-Fragen / Maustasten

Maustasten

HC [image] Grafiken [image] Igel- und Fenster-Fragen [image] Maustasten
TextMausY Mehrere Igel

Maustasten

Ausgabe ist der Wert der Mausknöpfe. Bedeutung der Werte:

1=linker Knopf

2=rechter Knopf

3=linker & rechter Knopf

4=mittlerer Knopf

8=Umschalt-Taste

16=Strg-Taste

32=Alt-Taste

64=Meta-Taste

Example:

  • beiTextMausbewegung

Reference:

    beiTextMausbewegung

TextMausY Mehrere Igel


HC / Grafiken / Mehrere Igel

Mehrere Igel

HC [image] Grafiken [image] Mehrere Igel
Maustasten Igel

Mehrere Igel

...werden jetzt unterstützt. Aber anders als in MSW/FMSLogo, wo es eine interne Reihe von Igeln gibt, können Igel in dieser Version von Logo Variablen zugewiesen werden, was deren Identifikation (anstatt anhand von Zahlen) erleichtert.

Mehrere Igel

  • Igel
  • neuerIgel
  • setzeIgel


HC / Grafiken / Mehrere Igel / Igel

Igel

HC [image] Grafiken [image] Mehrere Igel [image] Igel
Mehrere Igel neuerIgel

Igel

Ausgabe ist der aktive Igel für Gebrauch mit einer Variablen-Zuweisung.

Beispiel:

oldt=igel
setzeIgel neuerIgel
vorwärts 100
setzeIgel oldt

Examples:

  • Versions-Informationen für Version 4.7
  • beiGeklicktemSchaltknopf
  • beiGeklickterAnkreuzbox
  • setzeSchaltknopfZustand
  • zerstöreSchaltknopf
  • SchaltknopfZustand
  • ZerstöreAnkreuzbox
  • setzeAnkreuzbox
  • AnkreuzboxWert
  • SchaltknopfAn
  • AnkreuzboxAn
  • Schaltknopf
  • Zaun
  • def

References:

    Ellipse(5), EllipsenBogen(5), Grafiken(5), Schreibstift- und Hintergrund-Kontolle(5), Bogen(4), FensterModus(4), Relative Igel-Bewegung(4), Absolute Igel-Bewegung(3), Randsprung(3), Versions-Informationen für Version 4.7(3), Zaun(3), vorwärts(3), zurück(3), _setzeOrt(2), arc2(2), def(2), fülle(2), fülleEllipse(2), fülleKuchen(2), setzeIgel(2), sichtbarP(2), Abstand, AbstandXYZ, AnkreuzboxAn, AnkreuzboxWert, BitmapKopieren, Direkte Grafik, Ellipsoid, EllipsoidenTeil, Igel Bewegungs-Abfragen, Igel- und Fenster-Fragen, Igel-Kontrolle, IgelFormen, Kreis, Kurs, Kurven-Zeichnen, Linie, Mehrere Igel, Mitte, Neigung, Oberfläche, Oberflächenstart, Punkt, Release Notes für Version 4.64, RollWinkel, Schaltknopf, SchaltknopfAn, SchaltknopfZustand, Stiftgröße, Tesselation, Vieleck, ZerstöreAnkreuzbox, Zylinder, ZylinderlinienAn, ZylinderlinienAus, _setzeOrtXYZ, beiGeklicktemSchaltknopf, beiGeklickterAnkreuzbox, dreheX, dreheY, dreheZ, fülleKreis, inRichtung, inRichtungXYZ, links, löscheSchirm, neuerIgel, rauf, rechts, rolleLinks, rolleRechts, runter, setzeAnkreuzbox, setzeIgelFormen, setzeIgelMatrix, setzeKurs, setzeNeigung, setzeOrientierung, setzeOrt, setzeOrtInKugelkoordinaten, setzeOrtXYZ, setzeQuetschung, setzeRollWinkel, setzeSchaltknopfZustand, setzeTextfarbe, setzeX, setzeXY, setzeXYZ, setzeY, setzeZ, setzeZylinderOrt, versteckeIgel, xKoor, yKoor, zKoor, zeichneBitmap, zeichneBitmapSchnell, zeichneGrafik, zeigeIgel, zerstöreSchaltknopf, zu

Mehrere Igel neuerIgel


HC / Grafiken / Mehrere Igel / neuerIgel

neuerIgel

HC [image] Grafiken [image] Mehrere Igel [image] neuerIgel
Igel setzeIgel

neuerIgel

Ausgabe ist ein neuer Igel, die mit "setzeIgel" benutzt werden kann, oder er kann in einer Variablen gespeichert werden.

Example:

  • Igel

References:

    Igel, Release Notes für Version 4.64, setzeIgel

Igel setzeIgel


HC / Grafiken / Mehrere Igel / setzeIgel

setzeIgel

HC [image] Grafiken [image] Mehrere Igel [image] setzeIgel
neuerIgel Schreibstift- und Hintergrund-Kontolle

setzeIgel einIgel

Kommando, das den aktiven Igel zu "einIgel" setzt. "einIgel" kann von "Igel" oder "neuerIgel" oder indirekt von einer Variablen erhalten werden. Siehe auch turtlestest.lg!

Example:

  • Igel

References:

    Igel(2), Release Notes für Version 4.64, neuerIgel

neuerIgel Schreibstift- und Hintergrund-Kontolle


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle

Schreibstift- und Hintergrund-Kontolle

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle
setzeIgel StiftAb

Schreibstift- und Hintergrund-Kontolle

Der Igel trägt einen Schreibstift, der zeichnen kann. Zu jeder Zeit kann der Schreibstift oben sein (in welchem Fall der Igel bei der Bewegung Nichts ändert, was auf dem Grafikbildschirm ist) oder unten (in welchem Fall der Igel eine Spur hinterlässt). Wenn der Schreibstift unten ist, kann er in einem von drei Modi laufen: "normalerStift" (so dass er Linien zieht, wenn sich der Igel bewegt), "radiere" (so dass er Linien ausradiert, die früher gezeichnet worden sind), oder "UmkehrStift" (so dass er den Zustand jedes Punkts entlang dem Igel-Pfad umkehrt).

Schreibstift- und Hintergrund-Kontolle

  • StiftAb
  • StiftHoch
  • normalerStift
  • radiere
  • UmkehrStift
  • setzeStiftfarbe
  • setzeFüllfarbe
  • setzeMaterialUmgebung
  • setzeMaterialDiffus
  • setzeMaterialSpecular
  • setzeMaterialEmission
  • setzeMaterialShininess
  • setzeHintergrundfarbe
  • setzeStiftdicke
  • setzeLinienmuster
  • setzestift
  • setzeTiefentestFunktion
  • setzeFüllToleranz
  • setzePunktgröße


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / StiftAb

StiftAb

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] StiftAb
Schreibstift- und Hintergrund-Kontolle StiftHoch

StiftAb

setzt die Stift-Position nach unten, ohne seinen Modus zu verändern.

Examples:

  • setzeOrtInKugelkoordinaten
  • zeichneBitmapSkaliertAuf
  • GraphOnMouseLeftDown
  • zeichneBitmapSchnell
  • beiTextMausbewegung
  • TesselationKontour
  • Oberflächenspalte
  • setzeFüllToleranz
  • Oberflächenstart
  • setzeZylinderOrt
  • zeichneBitmapAuf
  • Oberflächenende
  • setzeIgelMatrix
  • orthographisch
  • fülleBitmap
  • Schaltknopf
  • Oberfläche
  • setzeXYZ
  • setzeZ
  • zurück
  • fülle
  • RGB
  • TSH

References:

    setzeOrtInKugelkoordinaten(2), setzeXYZ(2), setzeZylinderOrt(2), zeichneBitmapAuf(2), zurück(2), Absolute Igel-Bewegung, GraphOnMouseLeftDown, Mitte, Oberfläche, Oberflächenende, Oberflächenspalte, Oberflächenstart, RGB, Relative Igel-Bewegung, Schaltknopf, StiftAbP, TSH, TesselationKontour, beiTextMausbewegung, fülle, fülleBitmap, orthographisch, reset, setzeFüllToleranz, setzeIgelMatrix, setzeZ, vorwärts, zeichneBitmapSchnell, zeichneBitmapSkaliertAuf

Schreibstift- und Hintergrund-Kontolle StiftHoch


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / StiftHoch

StiftHoch

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] StiftHoch
StiftAb normalerStift

StiftHoch

setzt die Stift-Position nach oben, ohne seinen Modus zu verändern.

Examples:

  • setzeOrtInKugelkoordinaten
  • zeichneBitmapSkaliertAuf
  • GraphOnMouseLeftDown
  • zeichneBitmapSchnell
  • beiTextMausbewegung
  • TesselationKontour
  • Oberflächenspalte
  • setzeFüllToleranz
  • Oberflächenstart
  • setzeZylinderOrt
  • zeichneBitmapAuf
  • Oberflächenende
  • setzeIgelMatrix
  • orthographisch
  • fülleBitmap
  • Schaltknopf
  • Oberfläche
  • setzeXYZ
  • setzeZ
  • zurück
  • fülle

References:

    setzeOrtInKugelkoordinaten(4), setzeZylinderOrt(4), fülle(2), setzeXYZ(2), zeichneBitmapAuf(2), GraphOnMouseLeftDown, Oberfläche, Oberflächenende, Oberflächenspalte, Oberflächenstart, Schaltknopf, TesselationKontour, beiTextMausbewegung, fülleBitmap, orthographisch, setzeFüllToleranz, setzeIgelMatrix, setzeZ, zeichneBitmapSchnell, zeichneBitmapSkaliertAuf, zurück

StiftAb normalerStift


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / normalerStift

normalerStift

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] normalerStift
StiftHoch radiere

normalerStift

setzt die Position des Stifts nach unten und seinen Modus zu "Zeichnen".

Examples:

  • beiGeklicktemRadioKnopf
  • zerstöreRadioknopf
  • setzeRadioknopf
  • RadioknopfWert
  • RadioknopfAn

References:

    beiGeklicktemRadioKnopf(2), zerstöreRadioknopf(2), RadioknopfAn, RadioknopfWert, Schreibstift- und Hintergrund-Kontolle, StiftModus, setzeRadioknopf

StiftHoch radiere


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / radiere

radiere

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] radiere
normalerStift UmkehrStift

radiere

setzt die Position des Stifts nach unten und seinen Modus zu "Radieren".

References:

    Schreibstift- und Hintergrund-Kontolle, StiftModus, speicherePostScript

normalerStift UmkehrStift


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / UmkehrStift

UmkehrStift

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] UmkehrStift
radiere setzeStiftfarbe

UmkehrStift

setzt die Position des Stifts nach unten und seinen Modus zu "Umkehren". (Dies kann in hardwareabhängiger Weise mit Verwendung von Farbe wechselwirken.)

References:

    Schreibstift- und Hintergrund-Kontolle, StiftModus, speicherePostScript

radiere setzeStiftfarbe


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeStiftfarbe

setzeStiftfarbe

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeStiftfarbe
UmkehrStift setzeFüllfarbe

setzeStiftfarbe Farbnummer
setzeStiftfarbe RGBListe
setzeStiftfarbe Farbname

setzt die Stift-Farbe auf die gegebene Zahl, die eine Ganzzahl sein muss, oder eine RGBListe (aus drei Elementen bestehend, Rot, Grün und Blau, die jeweils im Bereich 0..1 sein müssen), oder einer der Farbnamen in der wxWidgets Farbdatenbank. Farbe 0 ist immer Schwarz; Farbe 7 ist immer Weiß. Andere Farben können oder konsistent zwischen Maschinen sein oder nicht, aber namentlich gegebene Farben sollten plattformunabhängig sein - wie wxWidgets ist.

Beispiele:

LinienglättungAus		;is neccessary to setze independent color drawings
setzeStiftfarbe 1
box
setzeStiftfarbe 2
box
setzeStiftfarbe 3
box
setzeStiftfarbe 4
box
setzeStiftfarbe 7
box
setzeStiftfarbe rgb 1 0 0
box
setzeStiftfarbe rgb 0 1 0  box
setzeStiftfarbe rgb 0 0 1  box
setzeStiftfarbe rgba 0 0 0 .2 box
setzeStiftfarbe rgba 0 0 0 .2 box
setzeStiftfarbe rgba 0 0 0 .2 box
setzeStiftfarbe rgba 0 0 0 .2 box
setzeStiftfarbe rgba 0 0 0 .2 box
setzeStiftfarbe [0 0.5 0] box
setzeStiftfarbe "red box
setzeStiftfarbe "yellow box

Examples:

  • beiGeklicktemRadioKnopf
  • setzeTiefentestFunktion
  • setzeMaterialShininess
  • setzeTesselationRegeln
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSchattenfarbe
  • setzeSpecularLicht
  • zerstöreRadioknopf
  • Oberflächenspalte
  • Oberflächenstart
  • zeichneBitmapAuf
  • ZylinderlinienAn
  • Oberflächenende
  • setzeStiftdicke
  • orthographisch
  • TiefpaßFilter2
  • setzeLichtOrt
  • setzeTexturXY
  • TiefpaßFilter
  • VieleckStart
  • wirfSchatten
  • loadpalette
  • VieleckEnde
  • Oberfläche
  • SchattenAn
  • Stiftfarbe
  • Ellipsoid
  • vorwärts
  • Zylinder
  • setzeXY
  • Vieleck
  • Grafik
  • Textur
  • RGBA
  • TSHA
  • RGB
  • TSH

References:

    setzeSchattenfarbe(3), Stiftfarbe(2), TiefpaßFilter(2), TiefpaßFilter2(2), setzeXY(2), wirfSchatten(2), Ellipsoid, Grafik, Oberfläche, Oberflächenende, Oberflächenspalte, Oberflächenstart, RGB, RGBA, SchattenAn, TSH, TSHA, Textur, Vieleck, VieleckEnde, VieleckStart, Zylinder, ZylinderlinienAn, beiGeklicktemRadioKnopf, loadpalette, orthographisch, reset, setzeAuswahlboxFarbe, setzeAuswahlboxHintergrundfarbe, setzeBalkenFarbe, setzeBalkenHintergrundfarbe, setzeDiffusesLicht, setzeFüllfarbe, setzeHintergrundfarbe, setzeKombiBoxFarbe, setzeKombiBoxHintergrundfarbe, setzeLichtOrt, setzeListenControlFarbe, setzeListenControlHintergrundfarbe, setzeListenboxFarbe, setzeListenboxHintergrundfarbe, setzeMaterialDiffus, setzeMaterialEmission, setzeMaterialShininess, setzeMaterialSpecular, setzeMaterialUmgebung, setzeNebelfarbe, setzeSpecularLicht, setzeStiftdicke, setzeTesselationRegeln, setzeTextfarbe, setzeTexturXY, setzeTiefentestFunktion, setzeUmgebungslicht, vorwärts, zeichneBitmapAuf, zerstöreRadioknopf

UmkehrStift setzeFüllfarbe


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeFüllfarbe

setzeFüllfarbe

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeFüllfarbe
setzeStiftfarbe setzeMaterialUmgebung

setzeFüllfarbe Farbe

setzt die Füll-Farbe auf die gegebene Zahl, die eine Ganzzahl sein muss, oder eine RGBListe (aus drei Elementen bestehend, Rot, Grün und Blau, die jeweils im Bereich 0..1 sein müssen), oder einer der Farbnamen in der wxWidgets Farbdatenbank. Farbe 0 ist immer Schwarz; Farbe 7 ist immer Weiß. Andere Farben können oder konsistent zwischen Maschinen sein oder nicht, aber namentlich gegebene Farben sollten plattformunabhängig sein - wie wxWidgets ist. Siehe auch "setzeStiftfarbe".

Beispiel:

setzeFüllfarbe rgb 1 0 1
fbox

Examples:

  • fülleRechteck
  • fülleEllipse
  • fülleKreis
  • TexturenAn

References:

    Release Notes für Version 4.64(2), Release Notes für Version 4.67, TexturenAn, fülleEllipse, fülleKreis, fülleRechteck, reset

setzeStiftfarbe setzeMaterialUmgebung


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeMaterialUmgebung

setzeMaterialUmgebung

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeMaterialUmgebung
setzeFüllfarbe setzeMaterialDiffus

setzeMaterialUmgebung Farbe

setzt die Material-Umgebungsfarbe zu "Farbe". Für die erlaubten Dinge in "Farbe" siehe setzeStiftfarbe!


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeMaterialDiffus

setzeMaterialDiffus

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeMaterialDiffus
setzeMaterialUmgebung setzeMaterialSpecular

setzeMaterialDiffus Farbe

setzt die Material-Diffus-Farbe zu "Farbe". Für die erlaubten Dinge in "Farbe" siehe setzeStiftfarbe!


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeMaterialSpecular

setzeMaterialSpecular

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeMaterialSpecular
setzeMaterialDiffus setzeMaterialEmission

setzeMaterialSpecular Farbe

setzt die Material-Specular-Farbe zu "Farbe". Für die erlaubten Dinge in "Farbe" siehe setzeStiftfarbe!


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeMaterialEmission

setzeMaterialEmission

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeMaterialEmission
setzeMaterialSpecular setzeMaterialShininess

setzeMaterialEmission Farbe

setzt die Material-Emissionsfarbe zu "Farbe". Für die erlaubten Dinge in "Farbe" siehe setzeStiftfarbe!


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeMaterialShininess

setzeMaterialShininess

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeMaterialShininess
setzeMaterialEmission setzeHintergrundfarbe

setzeMaterialShininess shininess

setzt die Material-Shininess, eine Zahl zwischen 0 und ungefähr 100.

Beispiel:

perspektivisch
setzeStiftfarbe "red
setzeMaterialShininess 10
Kugel 200


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeHintergrundfarbe

setzeHintergrundfarbe

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeHintergrundfarbe
setzeMaterialShininess setzeStiftdicke

setzeHintergrundfarbe Farbe

setzt die Schirmhintergrundfarbe. Siehe auch "setzeStiftfarbe" und die Farbdatenbank.

Reference:

    reset

setzeMaterialShininess setzeStiftdicke


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeStiftdicke

setzeStiftdicke

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeStiftdicke
setzeHintergrundfarbe setzeLinienmuster

setzeStiftdicke Größenliste
setzeStiftdicke Größe

setzt die Stiftgröße zu der "Größe" oder der "Größenliste". "Größenliste" ist eine Liste zweier Zahlen, die zweite Zahl wird im Moment ignoriert, "Größe" ist eine Zahl.

Im perspektivischen Modus werden, wenn Zylinderlinien eingeschaltet sind, ist das erste Listenelement der Radius der Zylinder.

Beispiel:

setzeStiftdicke [3.5 4]
vorwärts 100
löscheSchirm
perspektivisch
setzeStiftfarbe 4
ZylinderlinienAn
setzeStiftdicke [50 50]
vorwärts 100

Examples:

  • rundeLinienendenAus
  • rundeLinienendenAn
  • ZylinderlinienAn
  • loadpalette
  • Grafik

References:

    Grafik, Release Notes für Version 4.65, ZylinderlinienAn, loadpalette, reset, rundeLinienendenAn, rundeLinienendenAus

setzeHintergrundfarbe setzeLinienmuster


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeLinienmuster

setzeLinienmuster

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeLinienmuster
setzeStiftdicke setzestift

setzeLinienmuster Muster

Funktioniert noch nicht.


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzestift

setzestift

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzestift
setzeLinienmuster setzeTiefentestFunktion

setzestift Liste (Bibliotheksprozedur)

setzt die Position des Stifts, seinen Modus, und hardwareabhängige Merkmale entsprechend der Information in der Eingabe-Liste, die von einem früheren Aufruf von "stift" genommen werden sollte.

Reference:

    Schreibstift

setzeLinienmuster setzeTiefentestFunktion


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeTiefentestFunktion

setzeTiefentestFunktion

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeTiefentestFunktion
setzestift setzeFüllToleranz

setzeTiefentestFunktion num

setzt die Tiefen-Vergleichsfunktion von OpenGL. Dies kann nützlich sein, wenn Sie gezeichnete Grafik überschreiben wollen, die näher am Auge sein kann. Sehen Sie bounce3.lg für ein Beispiel!

0=GL_NEVER besteht nie.

1=GL_LESS besteht, wenn der eingehende Z-Wert kleiner als der gespeicherte Z-Wert ist. Das ist der Standart.

2=GL_EQUAL besteht, wenn der eingehende Z-Wert gleich dem gespeicherten Z-Wert ist.

3=GL_LEQUAL besteht, wenn der eingehende Z-Wert kleiner oder gleich dem gespeicherten Z-Wert ist.

4=GL_GREATER besteht, wenn der eingehende Z-Wert größer als der gespeicherte Z-Wert ist.

5=GL_NOTEQUAL besteht, wenn der eingehende Z-Wert ungleich dem gespeicherten Z-Wert ist.

6=GL_GEQUAL besteht, wenn der eingehende Z-Wert größer oder gleich dem gespeicherten Z-Wert ist.

7=GL_ALWAYS besteht immer.

Die Werte 1, 3 und 7 sind am nützlichsten.

Beispiele:

perspektivisch
löscheSchirm
setzeStiftfarbe "red
setzeTiefentestFunktion 7
Kugel 100
setzeTiefentestFunktion 3
Kugel 100

Reference:

    Release

setzestift setzeFüllToleranz


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzeFüllToleranz

setzeFüllToleranz

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzeFüllToleranz
setzeTiefentestFunktion setzePunktgröße

setzeFüllToleranz Toleranz

Kommando. Setzt die interne Variable "Fülltoleranz" auf die Zahl "Toleranz".

Toleranz: Zahl in Bereich 0..1.

Beispiel:

löscheSchirm
LinienglättungEin
box
rechts 45
StiftHoch
vorwärts 10
setzeFüllToleranz 0.5
(fülle FILL_TOLERANT)
StiftAb

Examples:

  • Versions-Informationen für Version 4.7
  • fülle

References:

    fülle(2), Versions-Informationen für Version 4.7

setzeTiefentestFunktion setzePunktgröße


HC / Grafiken / Schreibstift- und Hintergrund-Kontolle / setzePunktgröße

setzePunktgröße

HC [image] Grafiken [image] Schreibstift- und Hintergrund-Kontolle [image] setzePunktgröße
setzeFüllToleranz Schalterfunktionen

setzePunktgröße Größe

Kommando. Setzt die interne Grafik-Variable "Punktgröße" zur Zahl "Größe".

Beispiel:

löscheSchirm
setzePunktgröße 10
PunktglättungAn
wiederhole 10000 [setzePunktXY (zufall 800)-400 (zufall 600)-399 zufall IntMax]


HC / Grafiken / Schalterfunktionen

Schalterfunktionen

HC [image] Grafiken [image] Schalterfunktionen
setzePunktgröße LinienglättungAn

Schalterfunktionen

zum An- und Ausschalten von Zuständen.

Schalterfunktionen

  • LinienglättungAn
  • LinienglättungAus
  • VieleckglättungAn
  • VieleckglättungAus
  • rundeLinienendenAn
  • rundeLinienendenAus
  • ZylinderlinienAn
  • ZylinderlinienAus
  • TiefentestAn
  • TiefentestAus
  • BeleuchtungAn
  • BeleuchtungAus
  • DitheringAn
  • DitheringAus
  • PunktglättungAn
  • PunktglättungAus
  • NebelAn
  • NebelAus
  • TexturschriftAn
  • TexturschriftAus


HC / Grafiken / Schalterfunktionen / LinienglättungAn

LinienglättungAn

HC [image] Grafiken [image] Schalterfunktionen [image] LinienglättungAn
Schalterfunktionen LinienglättungAus

LinienglättungAn

ermöglicht Antialiasing, d.h. Glättung, von Linien.

Beispiel:

LinienglättungAn
kreis 300

Example:

  • fülle

References:

    Release Notes für Version 4.65(2), fülle, reset

Schalterfunktionen LinienglättungAus


HC / Grafiken / Schalterfunktionen / LinienglättungAus

LinienglättungAus

HC [image] Grafiken [image] Schalterfunktionen [image] LinienglättungAus
LinienglättungAn VieleckglättungAn

LinienglättungAus

schaltet Antialiasing von Linien aus.

Beispiel:

LinienglättungAus
kreis 300

Examples:

  • setzeStiftfarbe
  • fülleBitmap
  • fülle

References:

    Release Notes für Version 4.65, fülle, fülleBitmap, setzeStiftfarbe

LinienglättungAn VieleckglättungAn


HC / Grafiken / Schalterfunktionen / VieleckglättungAn

VieleckglättungAn

HC [image] Grafiken [image] Schalterfunktionen [image] VieleckglättungAn
LinienglättungAus VieleckglättungAus

VieleckglättungAn

ermöglicht Antialiasing von Polygonen.

Aber passen Sie auf: Dies kann die Zeichnungsgeschwindigkeit sehr verringern!

Beispiel:

VieleckglättungAn
fülleKreis 300

Reference:

    Release Notes für Version 4.65

LinienglättungAus VieleckglättungAus


HC / Grafiken / Schalterfunktionen / VieleckglättungAus

VieleckglättungAus

HC [image] Grafiken [image] Schalterfunktionen [image] VieleckglättungAus
VieleckglättungAn rundeLinienendenAn

VieleckglättungAus

schaltet Antialiasing von Polygonen aus.

Beispiel:

VieleckglättungAus
fülleKreis 300

Reference:

    Release Notes für Version 4.65

VieleckglättungAn rundeLinienendenAn


HC / Grafiken / Schalterfunktionen / rundeLinienendenAn

rundeLinienendenAn

HC [image] Grafiken [image] Schalterfunktionen [image] rundeLinienendenAn
VieleckglättungAus rundeLinienendenAus

rundeLinienendenAn

ermöglicht Zeichnung von runden Enden an jedem Linienende.

Dies kann die Zeichnungsgeschwindigkeit senken, besonders in 3D, weil die Linien-Enden dann Kugeln sind. Aber es ist sehr schön.

Beispiel:

rundeLinienendenAn
setzeStiftdicke [50 50]
vorwärts 100

Reference:

    Release Notes für Version 4.65

VieleckglättungAus rundeLinienendenAus


HC / Grafiken / Schalterfunktionen / rundeLinienendenAus

rundeLinienendenAus

HC [image] Grafiken [image] Schalterfunktionen [image] rundeLinienendenAus
rundeLinienendenAn ZylinderlinienAn

rundeLinienendenAus

schaltet das Zeichnen von runden Enden an jedem Linieende aus.

Beispiel:

rundeLinienendenAus
setzeStiftdicke [50 50]
vorwärts 100

Reference:

    Release Notes für Version 4.65

rundeLinienendenAn ZylinderlinienAn


HC / Grafiken / Schalterfunktionen / ZylinderlinienAn

ZylinderlinienAn

HC [image] Grafiken [image] Schalterfunktionen [image] ZylinderlinienAn
rundeLinienendenAus ZylinderlinienAus

ZylinderlinienAn

ermöglicht das Zeichnen von automatischen Zylinder-Linien wenn mit dem Igel gezeichnet wird.

Dieser Kommando ist zur Ausführung im perspektivischen Modus vorgesehen.

Beispiel:

perspektivisch
ZylinderlinienAn
setzeStiftdicke [50 50]
setzeStiftfarbe 4
vorwärts 100
rechts 90
vorwärts 100

Examples:

  • setzeStiftdicke
  • vorwärts
  • Grafik

References:

    Grafik, setzeStiftdicke, vorwärts

rundeLinienendenAus ZylinderlinienAus


HC / Grafiken / Schalterfunktionen / ZylinderlinienAus

ZylinderlinienAus

HC [image] Grafiken [image] Schalterfunktionen [image] ZylinderlinienAus
ZylinderlinienAn TiefentestAn

ZylinderlinienAus

schaltet das Zeichnen von automatischen Zylinder-Linien aus, wenn mit dem Igel gezeichnet wird. Statt dessen werden flache Linien gezogen.

Reference:

    reset

ZylinderlinienAn TiefentestAn


HC / Grafiken / Schalterfunktionen / TiefentestAn

TiefentestAn

HC [image] Grafiken [image] Schalterfunktionen [image] TiefentestAn
ZylinderlinienAus TiefentestAus

TiefentestAn

ermöglicht den Tiefen-Test von OpenGL-Grafik. "perspektivisch" schaltet automatisch den Tiefentest an.


HC / Grafiken / Schalterfunktionen / TiefentestAus

TiefentestAus

HC [image] Grafiken [image] Schalterfunktionen [image] TiefentestAus
TiefentestAn BeleuchtungAn

TiefentestAus

schaltet den Tiefen-Test von OpenGL-Grafik aus. "perspektivisch" schaltet automatisch den Tiefen-Test an.

Beispiel:

perspektivisch
clockwork		;dies looks very unpretty
disDT
clockwork		;now you should see the differenz


HC / Grafiken / Schalterfunktionen / BeleuchtungAn

BeleuchtungAn

HC [image] Grafiken [image] Schalterfunktionen [image] BeleuchtungAn
TiefentestAus BeleuchtungAus

BeleuchtungAn

ermöglicht die OpenGL Beleuchtung. Es wird standardmäßig durch den Aufruf von "perspektivisch" angeschalten.


HC / Grafiken / Schalterfunktionen / BeleuchtungAus

BeleuchtungAus

HC [image] Grafiken [image] Schalterfunktionen [image] BeleuchtungAus
BeleuchtungAn DitheringAn

BeleuchtungAus

schaltet die OpenGL Beleuchtung aus. Dies kann manchmal mit Alpha-Blending besser funktionieren (Transparenz).


HC / Grafiken / Schalterfunktionen / DitheringAn

DitheringAn

HC [image] Grafiken [image] Schalterfunktionen [image] DitheringAn
BeleuchtungAus DitheringAus

DitheringAn

ermöglicht OpenGL's Dithering von Farben. Dies kann die Qualität von Grafik auf Anzeigen verbessern, die nur 8- oder 16-Bitfarben haben, aber verlangsamt wahrscheinlich das Rendering.


HC / Grafiken / Schalterfunktionen / DitheringAus

DitheringAus

HC [image] Grafiken [image] Schalterfunktionen [image] DitheringAus
DitheringAn PunktglättungAn

DitheringAus

schaltet das OpenGL-Dithering aus. Dies ist der Standart.


HC / Grafiken / Schalterfunktionen / PunktglättungAn

PunktglättungAn

HC [image] Grafiken [image] Schalterfunktionen [image] PunktglättungAn
DitheringAus PunktglättungAus

PunktglättungAn

schaltet die Punktglättung von OpenGL an. Dies ist schön, wenn Sie Antialiased Punkte haben wollen, die bei Bewegung weniger flackern.

Example:

  • setzePunktgröße

Reference:

    setzePunktgröße

DitheringAus PunktglättungAus


HC / Grafiken / Schalterfunktionen / PunktglättungAus

PunktglättungAus

HC [image] Grafiken [image] Schalterfunktionen [image] PunktglättungAus
PunktglättungAn NebelAn

PunktglättungAus

schaltet die Punktglättung von OpenGL aus. Dies ist der Standart.


HC / Grafiken / Schalterfunktionen / NebelAn

NebelAn

HC [image] Grafiken [image] Schalterfunktionen [image] NebelAn
PunktglättungAus NebelAus

NebelAn

schaltet den Nebel-Effekt von OpenGL an. Dies ist besonders nützlich, wenn Sie Mengen von Punkten zeichnen, weil diese nicht beleuchtet werden und dann Tiefe schwierig zu sehen sein kann. Mit Nebel kann dies überwunden werden, wie in IFS3D.lg benutzt.

Examples:

  • setzeNebeldichte
  • setzeNebelModus

References:

    setzeNebeldichte(2), Release Notes für Version 4.689, setzeNebelModus

PunktglättungAus NebelAus


HC / Grafiken / Schalterfunktionen / NebelAus

NebelAus

HC [image] Grafiken [image] Schalterfunktionen [image] NebelAus
NebelAn TexturschriftAn

NebelAus

schaltet den Nebel-Effekt von OpenGL aus. Dies ist der Standart.

Reference:

    Release Notes für Version 4.689

NebelAn TexturschriftAn


HC / Grafiken / Schalterfunktionen / TexturschriftAn

TexturschriftAn

HC [image] Grafiken [image] Schalterfunktionen [image] TexturschriftAn
NebelAus TexturschriftAus

TexturschriftAn

schaltet den Gebrauch von FTGLTextureFont an, was manchmal ein bisschen schöner sein kann. Aber beim Ausdrucken ist es wahrscheinlich nicht so scharf wie ohne.

Beispiel:

löscheSchirm
Mitte rechts 90
setzeSchriftgröße [50 50]
TexturschriftAn
IgelText [Hallo Welt!]
TexturschriftAus
IgelText [Hallo Welt!]


HC / Grafiken / Schalterfunktionen / TexturschriftAus

TexturschriftAus

HC [image] Grafiken [image] Schalterfunktionen [image] TexturschriftAus
TexturschriftAn Schreibstift-Abfragen

TexturschriftAus

Schaltet den Gebrauch von FTGLTextureFont aus. Das ist der Standart.

Example:

  • TexturschriftAn

Reference:

    TexturschriftAn

TexturschriftAn Schreibstift-Abfragen


HC / Grafiken / Schreibstift-Abfragen

Schreibstift-Abfragen

HC [image] Grafiken [image] Schreibstift-Abfragen
TexturschriftAus StiftAbP

Schreibstift-Abfragen

...fragen den Schreibstift nach seinen Eigenschaften.

Schreibstift-Abfragen

  • StiftAbP
  • StiftModus
  • Stiftfarbe
  • Füllfarbe
  • Stiftgröße
  • Schreibstift
  • SchirmFarbe


HC / Grafiken / Schreibstift-Abfragen / StiftAbP

StiftAbP

HC [image] Grafiken [image] Schreibstift-Abfragen [image] StiftAbP
Schreibstift-Abfragen StiftModus

StiftAbP
StiftAb?

Ausgabe ist wahr, wenn der Schreibstift unten ist, falsch wenn er oben ist.


HC / Grafiken / Schreibstift-Abfragen / StiftModus

StiftModus

HC [image] Grafiken [image] Schreibstift-Abfragen [image] StiftModus
StiftAbP Stiftfarbe

StiftModus

Ausgabe ist eines der Wörter "normalerStift", "radiere", oder "Umkehrstift", entsprechend dem gegenwärtigen Schreibstiftmodus.

Reference:

    löscheBild

StiftAbP Stiftfarbe


HC / Grafiken / Schreibstift-Abfragen / Stiftfarbe

Stiftfarbe

HC [image] Grafiken [image] Schreibstift-Abfragen [image] Stiftfarbe
StiftModus Füllfarbe

Stiftfarbe Stiftfarbe

Ausgabe ist eine Farbzahl, eine nichtnegative Ganzzahl, die mit einer Farbe verbunden ist durch die Hardware und das Betriebssystem.

Beispiele:

setzeStiftfarbe 0
Stiftfarbe		;-16777216  ;-)
hex Stiftfarbe		;FF000000  ;-)
listeRGBA Stiftfarbe		;[0 0 0 1] ;-)
setzeStiftfarbe 4
Stiftfarbe		;-16776961  ;-)
hex Stiftfarbe		;FF0000FF  ;-)
listeRGBA Stiftfarbe		;[1 0 0 1] ;-)

Examples:

  • ProzedurText
  • Volltext
  • hex
  • Ton

References:

    Ton(2), fülle(2), hex(2), Füllfarbe, ProzedurText, Release Notes für Version 4.686, Volltext, fülleBitmap

StiftModus Füllfarbe


HC / Grafiken / Schreibstift-Abfragen / Füllfarbe

Füllfarbe

HC [image] Grafiken [image] Schreibstift-Abfragen [image] Füllfarbe
Stiftfarbe Stiftgröße

Füllfarbe FC

Ausgabe ist die Füll-Farbe, eine nichtnegative Ganzzahl, die mit einer Farbe verbunden ist durch die Hardware und das Betriebssystem. Diese Farbe wird für gefüllte Formen benutzt.

Der Farbwert kann wie der von "Stiftfarbe" ausgegebene benutzt werden.

References:

    Release Notes für Version 4.64, fülleBitmap, fülleEllipse, fülleKreis

Stiftfarbe Stiftgröße


HC / Grafiken / Schreibstift-Abfragen / Stiftgröße

Stiftgröße

HC [image] Grafiken [image] Schreibstift-Abfragen [image] Stiftgröße
Füllfarbe Schreibstift

Stiftgröße

Ausgabe ist die Größe des Igel-Stifts.

Reference:

    setzeStiftdicke

Füllfarbe Schreibstift


HC / Grafiken / Schreibstift-Abfragen / Schreibstift

Schreibstift

HC [image] Grafiken [image] Schreibstift-Abfragen [image] Schreibstift
Stiftgröße SchirmFarbe

Schreibstift (Bibliotheksprozedur)

Ausgabe ist eine Liste, die Position des Schreibstifts, Modus, und hardwarespezifische Merkmale, für Verwendung mit "setzestift" enthaltend.

References:

    Schreibstift- und Hintergrund-Kontolle(3), Absolute Igel-Bewegung, Schreibstift-Abfragen, StiftAbP

Stiftgröße SchirmFarbe


HC / Grafiken / Schreibstift-Abfragen / SchirmFarbe

SchirmFarbe

HC [image] Grafiken [image] Schreibstift-Abfragen [image] SchirmFarbe
Schreibstift Kurven-Zeichnen

SchirmFarbe

Ausgabe ist die Grafikbildschirm-Hintergrundfarbe als eine Ganzzahl.

Examples:

  • zeichneBitmapSkaliertAuf
  • zeichneBitmapAuf

References:

    zeichneBitmapAuf(2), zeichneBitmapSkaliertAuf

Schreibstift Kurven-Zeichnen


HC / Grafiken / Kurven-Zeichnen

Kurven-Zeichnen

HC [image] Grafiken [image] Kurven-Zeichnen
SchirmFarbe Kreis

Kurven-Zeichnen

Hier sind einige Kommandos, um Kurven zu zeichnen. Der nützlichste ist natürlich "Kreis", obwohl Sie auch einen Kreis mit "Bogen" oder "Ellipse" zeichnen können.

Diese Kommandos bewegen den Igel nicht.

Kurven-Zeichnen

  • Kreis
  • EllipsenBogen
  • Ellipse
  • Bogen
  • arc2
  • cngon


HC / Grafiken / Kurven-Zeichnen / Kreis

Kreis

HC [image] Grafiken [image] Kurven-Zeichnen [image] Kreis
Kurven-Zeichnen EllipsenBogen

Kreis Radius

Zeichnet einen Kreis auf Grundlage der Igelposition und den gegebenen Argumenten.

Die Größe basiert auf dem Radius. Die gegenwärtige Igel-Position wird im Zentrum des Kreises sein. "Kreis" wird auch den Randsprung/Zaun/Fenstermodus-Zuständen folgen.

Beispiele:

Kreis 100
Kreis 50

Examples:

  • LinienglättungAus
  • LinienglättungAn
  • setzeIgelFormen
  • IgelFormen

References:

    Kurven-Zeichnen(2), Trigonometrische Funktionen(2), Bogen, IgelFormen, LinienglättungAn, LinienglättungAus, Zylinder, buglist für Version 4.65, fülleKreis, setzeIgelFormen

Kurven-Zeichnen EllipsenBogen


HC / Grafiken / Kurven-Zeichnen / EllipsenBogen

EllipsenBogen

HC [image] Grafiken [image] Kurven-Zeichnen [image] EllipsenBogen
Kreis Ellipse

EllipsenBogen Winkel xRadius yRadius StartWinkel

Kommando. Zeichnet eine Ellipse oder einen Teil von einer, basierend auf dem Igelkurs, seiner Position, und den gegebenen Argumenten.

Die Ellipse beginnt hinter dem Igel und schwingt um den Bertag des "Winkel"s, beginnend bei "StartWinkel".

Die Größe basiert auf den Werten von "xRadius" und "yRadius". Der momentane Igel-Ort wird im Zentrum der Ellipse sein. EllipsenBogen folgt auch dem Modus von Randsprung/Zaun/FensterModus.

xRadius: der Radius vom Igel rechts bis dem Bogen.

yRadius: der Radius in Richtung des Igel-Kurses, vom Igel zum Bogen.

Beispiele:

EllipsenBogen 360 100 200 0
löscheSchirm
EllipsenBogen 90 50 50 0
löscheSchirm
EllipsenBogen 90 50 50 90


HC / Grafiken / Kurven-Zeichnen / Ellipse

Ellipse

HC [image] Grafiken [image] Kurven-Zeichnen [image] Ellipse
EllipsenBogen Bogen

Ellipse xRadius yRadius

Kommando. Zeichnet eine Ellipse, die auf dem Igel-Kurs basiert, der Igel-Position und den gegebenen Argumenten.

Das Zentrum der Ellipse ist die aktuelle Igel-Position. xRadius ist der Ellipsenradius rechts vom Igel, yradius ist der Radius in Richtung des Igel-Kopfes.

Ellipse wird auch Randsprung /Zaun /Fenstermodi folgen.

Beispiele:

Ellipse 100 200
vorwärts 200
Ellipse 100 200
rechts 30
Ellipse 100 200

References:

    EllipsenBogen(3), Kurven-Zeichnen, Release Notes für Version 4.65, fülleEllipse, setzeSchreibBreitenGrenze, setzeSchreibTiefenGrenze

EllipsenBogen Bogen


HC / Grafiken / Kurven-Zeichnen / Bogen

Bogen

HC [image] Grafiken [image] Kurven-Zeichnen [image] Bogen
Ellipse arc2

Bogen Winkel Radius

Zeichnet einen Bogen eines Kreises, mit dem Igel im Zentrum, mit dem spezifizierten "Radius", der bei in Richtung des Igel-Kopfes anfängt und im Uhrzeigersinn um den angegebenen Winkel weitergeht. Der Igel bewegt sich dabei nicht.

Die Größe basiert auf dem "Radius". Die aktuelle Igel-Position wird im Zentrum des Bogens sein. "Bogen" folgt auch dem Zustand von Randsprung/Zaun/FensterModus.

    Bogen 360 Radius
zeichnet natürlich einen Kreis mit Radius "Radius".

Beispiel:

Bogen 360 100
Bogen 90 50

References:

    arc2(4), EllipsenBogen(2), buglist für Version 4.65(2), Kurven-Zeichnen, speicherePostScript

Ellipse arc2


HC / Grafiken / Kurven-Zeichnen / arc2

arc2

HC [image] Grafiken [image] Kurven-Zeichnen [image] arc2
Bogen cngon

arc2 Winkel Radius

wie "Bogen", zeichnet es einen Bogen eines Kreises, aber mit dem Igel als Startpunkt, und dem Zentrum rechts vom Igel. Wenn beide "Winkel" und "Radius" positiv sind, wird ein Bogen im Uhrzeigersinn gezeichnet. Wenn beide negativ sind, wird ein Bogen gegen den Uhrzeigersinn gezeichnet.

Beispiele:

arc2 30 100	;draws a rechts turn
arc2 -30 -100	;draws a links turn

Reference:

    Release Notes für Version 4.67

Bogen cngon


HC / Grafiken / Kurven-Zeichnen / cngon

cngon

HC [image] Grafiken [image] Kurven-Zeichnen [image] cngon
arc2 Text Zeichnen

cngon Seiten Radius (Bibliotheksprozedur)

Zeichnet ein reguläres Polygon innerhalb eines nicht gezeichneten Kreises.

Beispiele:

cngon 3 100
cngon 7 100


HC / Grafiken / Text Zeichnen

Text Zeichnen

HC [image] Grafiken [image] Text Zeichnen
cngon IgelText

Text Zeichnen

Hier sind einige Befehle zum Text-Zeichnen und zum Festlegen seiner Eigenschaften wie Ausrichtung, Größe, Schriftart, etc.

Text Zeichnen

  • IgelText
  • TextSchriftgröße
  • setzeSchriftgröße
  • TextSchriftart
  • setzeSchriftname
  • TextSchriftdicke
  • setzeSchriftdicke
  • TextAusrichtung
  • setzeSchriftausrichtung


HC / Grafiken / Text Zeichnen / IgelText

IgelText

HC [image] Grafiken [image] Text Zeichnen [image] IgelText
Text Zeichnen TextSchriftgröße

IgelText Text

nimmt ein Wort oder eine Liste als Eingabe, und schreibt die Eingabe ins Grafik-Fenster, beginnend bei der Position des Igels. Ein Wort wird immer kleinbuchstabig geschrieben, während die Groß-/Kleinscheibung einer Liste von Wörtern bewahrt wird.

Beispiel:

IgelText "Hallo		; wird "hallo" im Grafik-Fenster schreiben
IgelText [Hallo Welt!]	; wird "Hallo Welt!" schreiben

Examples:

  • beiTextMausRechtsLosgelassen
  • beiRechtsGeklickterTextmaus
  • beiTextMausLinksLosgelassen
  • beiTextMausMitteLosgelassen
  • beiLinksGeklickterTextmaus
  • beiMitteGeklickterTextmaus
  • setzeSchriftausrichtung
  • setzeSchriftdicke
  • setzeSchriftgröße
  • setzeSchriftname
  • TexturschriftAn

References:

    Radioknopf(3), TextSchriftgröße(3), setzeSchriftname(3), statischerText(3), ListControl(2), TexturschriftAn(2), fügeSpalteInListenControlEin(2), setzeSchriftausrichtung(2), setzeSchriftdicke(2), setzeSchriftgröße(2), setzeStatischenText(2), Auswahlbox, CheckBoxen, ChoiceBoxes, KombiBox, ListControls, Listenbox, Listenboxen, RadioButtons, Schiebe-Regler, Schieberegler, TextAusrichtung, TextControls, TextSchriftart, TextSchriftdicke, Zahlbox, Zahlboxen, beiGeklickterListencontrolSpalte, beiLinksGeklickterTextmaus, beiMitteGeklickterTextmaus, beiRechtsGeklickterTextmaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, setzeLogoSchriftenVerzeichnis

Text Zeichnen TextSchriftgröße


HC / Grafiken / Text Zeichnen / TextSchriftgröße

TextSchriftgröße

HC [image] Grafiken [image] Text Zeichnen [image] TextSchriftgröße
IgelText setzeSchriftgröße

Größe TextSchriftgröße Text
Schriftgröße (TextSchriftgröße)

Mit einem Argument wird dieser Befehl die Größe des bestimmten Textes "Text" ausgeben. Die Eingabe, die ein Wort oder eine Liste sein kann, wird genauso ausgewertet wie bei "IgelText". Sie können diese Information benutzen, um andere Formen von "IgelText" zu bauen. Andere Formen könnten ZentrierterText" oder "VertikalerText" sein. Sie können auch diese Information benutzen, um einen Ort für Text "vorzubereiten" (d. h. es einrahmen oder einen Hintergrund setzen).

size:(Liste) Liste von 2 Ganzzahlen [Breite Höhe] des Texts in der aktuellen Schrift.

Text:(Wert) Irgendein Wert, den Sie als Text wollen.

Beispiel:

zeige textschriftgröße "Hallo		;[44 24]

Ohne ein Argument, gibt TextSchriftgröße die aktuelle IgelText-Schriftgröße aus.

Beispiel:

zeige (TextSchriftgröße)		;[20 20]

References:

    Release Notes für Version 4.64, Release Notes für Version 4.686

IgelText setzeSchriftgröße


HC / Grafiken / Text Zeichnen / setzeSchriftgröße

setzeSchriftgröße

HC [image] Grafiken [image] Text Zeichnen [image] setzeSchriftgröße
TextSchriftgröße TextSchriftart

setzeSchriftgröße XYListe

setzt die Größe des nächsten von IgelText ausgegebenen Textes. "XYListe" ist ein Liste von Breite und Höhe eines einzelnen Zeichens.

Beispiel:

setzeSchriftgröße [10 20]	;set igeltext size to default size

Example:

  • TexturschriftAn

References:

    Release Notes für Version 4.64, TexturschriftAn

TextSchriftgröße TextSchriftart


HC / Grafiken / Text Zeichnen / TextSchriftart

TextSchriftart

HC [image] Grafiken [image] Text Zeichnen [image] TextSchriftart
setzeSchriftgröße setzeSchriftname

TextSchriftart

Ausgabe ist der aktuelle IgelText Schriftname.

Beispiel:

TextSchriftart		;Times  ;-)

Reference:

    Release Notes für Version 4.686

setzeSchriftgröße setzeSchriftname


HC / Grafiken / Text Zeichnen / setzeSchriftname

setzeSchriftname

HC [image] Grafiken [image] Text Zeichnen [image] setzeSchriftname
TextSchriftart TextSchriftdicke

setzeSchriftname Schriftname

setzt die Standart-Schrift für "IgelText" zu dem Wort Schriftname.

Beispiele:

setzeSchriftname "Times
IgelText [Hallo]
vorwärts 100
setzeSchriftname "Courier New
IgelText [Welt]

References:

    Release Notes für Version 4.64, reset

TextSchriftart TextSchriftdicke


HC / Grafiken / Text Zeichnen / TextSchriftdicke

TextSchriftdicke

HC [image] Grafiken [image] Text Zeichnen [image] TextSchriftdicke
setzeSchriftname setzeSchriftdicke

TextSchriftdicke

Ausgabe ist die aktuelle "IgelText"-Schriftdicke.

Beispiel:

TextSchriftdicke		;400  ;-)

Reference:

    Release Notes für Version 4.686

setzeSchriftname setzeSchriftdicke


HC / Grafiken / Text Zeichnen / setzeSchriftdicke

setzeSchriftdicke

HC [image] Grafiken [image] Text Zeichnen [image] setzeSchriftdicke
TextSchriftdicke TextAusrichtung

setzeSchriftdicke Gewicht

funktioniert noch nicht.

Kommando. Setzt die Dicke der "IgelText"-Schrift. Gewicht 400 ist normal, 1000 ist fett.

Beispiel:

setzeSchriftdicke 800
igeltext "hallo

Reference:

    Release Notes für Version 4.64

TextSchriftdicke TextAusrichtung


HC / Grafiken / Text Zeichnen / TextAusrichtung

TextAusrichtung

HC [image] Grafiken [image] Text Zeichnen [image] TextAusrichtung
setzeSchriftdicke setzeSchriftausrichtung

TextAusrichtung

Ausgabe ist die aktuell gesetzte Igeltext Ausrichtung als eine Liste zweier Ganzzahlen [xalign yalign].

Es gibt drei mögliche Werte für xalign und yalign: -1, 0, 1.

-1 steht für rechts oben, 0 zentriert den Text, 1 richtet nach links unten aus. 1 ist Standart.

Beispiel:

TextAusrichtung		;[0 0] ;-) x=center, y=center

Reference:

    Release Notes für Version 4.686

setzeSchriftdicke setzeSchriftausrichtung


HC / Grafiken / Text Zeichnen / setzeSchriftausrichtung

setzeSchriftausrichtung

HC [image] Grafiken [image] Text Zeichnen [image] setzeSchriftausrichtung
TextAusrichtung Zeichnung gefüllter Formen

setzeSchriftausrichtung xalign yalign

setzt die Ausrichtung der "IgelText" Schrift. Es gibt drei mögliche Werte für xalign und yalign: -1, 0, 1.

-1 steht für rechts oben, 0 zentriert den ProzedurText, 1 richtet nach links unten aus. 1 ist Standart.

Beispiel:

setzeSchriftausrichtung -1 1	;rechts-bottom
igeltext "hallo


HC / Grafiken / Zeichnung gefüllter Formen

Zeichnung gefüllter Formen

HC [image] Grafiken [image] Zeichnung gefüllter Formen
setzeSchriftausrichtung fülle

Zeichnung gefüllter Formen

...ist leicht mit diesen Befehlen.

Zeichnung gefüllter Formen

  • fülle
  • Vieleck
  • VieleckStart
  • VieleckEnde
  • Tesselation
  • TesselationStart
  • TesselationKontour
  • TesselationEnde
  • setzeTesselationRegeln
  • Oberfläche
  • Oberflächenstart
  • Oberflächenspalte
  • Oberflächenende
  • Grafik
  • GrafikAnfang
  • GrafikEnde
  • zeichneGrafik
  • VideoStart
  • VideoFrame
  • VideoEnde
  • fülleRechteck
  • fülleKreis
  • fülleEllipse
  • fülleKuchen
  • Kugel
  • Ellipsoid
  • EllipsoidenTeil
  • Zylinder


HC / Grafiken / Zeichnung gefüllter Formen / fülle

fülle

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] fülle
Zeichnung gefüllter Formen Vieleck

fülle
(fülle "wahr)
(fülle FüllTyp)

Füllt in einer Region des Grafik-Fensters, die den Igel enthält und von Linien, die früher gezogen wurden, begrenzt werden. Dies ist nicht portierbar; es funktioniert nicht für alle Maschinen, und kann nicht genau so auf unterschiedlichen Maschinen funktionieren.

Das Kommando (fülle "wahr) füllt das Gebiet um den Igel, durch die von "StiftFarbe" spezifizierten Farbe definiert. Das Füllen setzt sich nach außen in alle Richtungen fort, solange die Farbe gefunden wird. Dieser Stil ist nützlich dafür, Gebiete mit mehrfarbigen Grenzen zu füllen.

Die dritte Variante von "fülle" nimmt eine Ganzzahl als Eingabe, die die verwendete Füll-Methode angibt. Sie kann eine der folgenden Konstanten sein:

FILL_NORMAL FILL_SURFACE
FILL_TOLERANT FILL_SURFACE_TOLERANT
FILL_SMALL FILL_SMALL_SURFACE
FILL_SMALL_TOLERANT FILL_SMALL_SURFACE_TOLERANT

Die xxx_SURFACE Typen sind wie (fülle "true).

Wenn Sie die xxx_TOLERANT Fülltypen verwenden, so ist eine mehr oder weniger große Abweichung von der Begrenzungsfarbe erlaubt. So können Sie geglättete Linien als Grenzen haben, oder Bereiche füllen, die zur "StiftFarbe" ähnliche Farben enthalten. Die Füllfarben-Toleranz kann mit dem Kommando setzeFülltoleranz gesetzt werden.

Die SMALL Methoden sind ein bisschen schneller für kleine Bereiche, als die anderen Methoden.

In den meisten Fällen ist "fülle" nicht so schnell und exakt, wie ein tesseliertes Polygon unter Verwendung von Tesselation zu zeichnen.

Beispiele:

LinienglättungAus
box
rechts 45
StiftHoch vorwärts 10
fülle

löscheSchirm
LinienglättungAn
box
rechts 45
StiftHoch
vorwärts 10
setzeFülltoleranz 0.5
(fülle FILL_TOLERANT)
StiftAb

Examples:

  • Versions-Informationen für Version 4.7
  • beiRechtsGeklickterGraphMaus
  • beiRechtsGeklickterMaus
  • kalibriereScrolling
  • setzeFüllToleranz

References:

    Release Notes für Version 4.64, Versions-Informationen für Version 4.7, beiRechtsGeklickterGraphMaus, beiRechtsGeklickterMaus, fülleBitmap, kalibriereScrolling, setzeFüllToleranz, speicherePostScript, zumGestellDazu

Zeichnung gefüllter Formen Vieleck


HC / Grafiken / Zeichnung gefüllter Formen / Vieleck

Vieleck

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Vieleck
fülle VieleckStart

Vieleck Befehlsliste

Kommando, um ein Vieleck mit den Igel-Befehlen innerhalb der "Befehlsliste" zu zeichnen.

Das ist cool, um Formen zu zeichnen, besonders im Dreidimensionalen. Im perspektivischen Modus wird das Vieleck beleuchtet.

Aber Vorsicht: das Vieleck muss einfach und konvex sein. Für nicht-konvexe Vielecke und Vieleck mit Löchern verwenden Sie Tesselation!

Es wird empfohlen, das Grundwort "Vieleck" anstatt "VieleckStart..VieleckEnde" zu verwenden, weil Sie so nicht versehentlich "VieleckEnde" vergessen können, wenn z.B. eine Schleife mit "unterbrich" beendet wird, oder eine Prozedur mit "Ausgabe", "Halt" oder "wirf" verlassen wird.

Beispiel:

löscheSchrim
setzeStiftfarbe "rot
Vieleck [
    wiederhole 8 [vorwärts 100 rechts 45]
]

löscheSchirm
perspektivisch
Vieleck [
    wiederhole 6 [vorwärts 100 rechts 60]
]
rotatiereszene2

Examples:

  • Versions-Informationen für Version 4.7
  • setzeTexturXY

References:

    Tesselation(4), VieleckStart(3), Versions-Informationen für Version 4.7(2), VieleckEnde(2), setzeTexturXY(2), Schatten, TesselationEnde, TesselationStart, wirfSchatten

fülle VieleckStart


HC / Grafiken / Zeichnung gefüllter Formen / VieleckStart

VieleckStart

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] VieleckStart
Vieleck VieleckEnde

VieleckStart

Kommando, das Logo sagt, den Polygonmodus zu betreten.

Dies ist cool für Zeichnen von Formen, besonders in 3D. Im perspektivischen Modus wird das Vieleck beleuchtet.

Aber Vorsicht: das Vieleck muss einfach und konvex sein. Für nicht-konvexe Vielecke und Vieleck mit Löchern verwenden Sie Tesselation!

Beispiel:

setzeStiftfarbe 4
VieleckStart
box
VieleckEnde

perspektivisch
VieleckStart
box
VieleckEnde
rotatescene

Examples:

  • Versions-Informationen für Version 4.7
  • VieleckEnde

References:

    Release Notes für Version 4.672(2), VieleckEnde(2), Versions-Informationen für Version 4.7, Vieleck

Vieleck VieleckEnde


HC / Grafiken / Zeichnung gefüllter Formen / VieleckEnde

VieleckEnde

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] VieleckEnde
VieleckStart Tesselation

VieleckEnde

Kommando, das Logo sagt, den Vieleck-Modus zu beenden, und das gefüllte Polygon zu zeichnen.

Dies ist cool zum Zeichen von Formen, besonders in 3D. Im perspektivischen Modus wird das Vieleck beleuchtet.

Beispiel:

setzeStiftfarbe 4
VieleckStart
box
VieleckEnde

perspektivisch
VieleckStart
box
VieleckEnde
rotatescene

Example:

  • VieleckStart

References:

    Vieleck(2), VieleckStart(2)

VieleckStart Tesselation


HC / Grafiken / Zeichnung gefüllter Formen / Tesselation

Tesselation

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Tesselation
VieleckEnde TesselationStart

Tesselation Befehlsliste

Kommando, um ein kompliziertes Vieleck mit den Igel-Befehlen innerhalb der "Befehlsliste" zu zeichnen.

Das ist cool, um Formen zu zeichnen, besonders im Dreidimensionalen. Im perspektivischen Modus wird das Vieleck beleuchtet.

Das Vieleck kann konvex und mit Löchern sein. Für konvexe, einfache Vielecke können Sie auch das etwas schnellere "Vieleck"-Grundwort verwenden.

Es wird empfohlen, das Grundwort "Tesselation" anstatt "TessStart..TessEnde" zu verwenden, weil Sie so nicht versehentlich "TessEnde" vergessen können, wenn z.B. eine Schleife mit "unterbrich" beendet wird, oder eine Prozedur mit "Ausgabe", "Halt" oder "wirf" verlassen wird.

Beispiel:

Tesselation [
    fd 100 rt 90 fd 100 rt 90 fd 100
    rt 135 fd 100/sqrt 2 lt 90 fd 100/sqrt 2
]

Examples:

  • Versions-Informationen für Version 4.7
  • setzeTesselationRegeln

References:

    Versions-Informationen für Version 4.7(2), setzeTesselationRegeln(2), Schatten, Vieleck, VieleckStart, fülle, setzeTexturXY, wirfSchatten

VieleckEnde TesselationStart


HC / Grafiken / Zeichnung gefüllter Formen / TesselationStart

TesselationStart

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] TesselationStart
Tesselation TesselationKontour

TesselationStart

Kommando, das Logo sagt, den Tesselliermodus zu betreten.

Dies ist cool für Zeichnen von Formen, besonders in 3D. Im perspektivischen Modus wird das Vieleck beleuchtet.

Das Tesselated Polygonemerkmal wird dann benötigt, wenn das Sie nichtkonvexe Vielecke oder Vielecke mit Löchern zeichnen wollen.

Beispiel:

TesselationStart	;a non-convex polygon
vorwärts 100 rechts 90 vorwärts 100 rechts 90 vorwärts 100
rechts 135 vorwärts 100/quadratwurzel 2 links 90 vorwärts 100/quadratwurzel 2
TesselationEnde

Example:

  • TesselationKontour

References:

    Release Notes für Version 4.672, TesselationEnde, TesselationKontour

Tesselation TesselationKontour


HC / Grafiken / Zeichnung gefüllter Formen / TesselationKontour

TesselationKontour

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] TesselationKontour
TesselationStart TesselationEnde

TesselationKontour

Kommando zum Gebrauch im Tesselier-Modus, um einen neuen Umriss des Vielecks zu beginnen, z.B. ein Loch.

Beispiel:

TesselationStart	;a square with a triangular hole
wiederhole 4 [vorwärts 100 rechts 90]
TesselationKontour
StiftHoch rechts 45 vorwärts 20 links 15 StiftAb vorwärts 60 rechts 120 vorwärts 60 rechts 120 vorwärts 60 rechts 120
TesselationEnde

Reference:

    TesselationEnde

TesselationStart TesselationEnde


HC / Grafiken / Zeichnung gefüllter Formen / TesselationEnde

TesselationEnde

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] TesselationEnde
TesselationKontour setzeTesselationRegeln

TesselationEnde

Kommando, um den Vieleck-Tesselier-Modus zu verlassen. Siehe auch "TesselationStart", "TesselationKontour".

Examples:

  • TesselationKontour
  • TesselationStart

References:

    TesselationKontour, TesselationStart

TesselationKontour setzeTesselationRegeln


HC / Grafiken / Zeichnung gefüllter Formen / setzeTesselationRegeln

setzeTesselationRegeln

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] setzeTesselationRegeln
TesselationEnde Oberfläche

setzeTesselationRegeln Regel

Kommando, die Windregel für die nächsten Tesselation zur "Regel" zu setzen. Die "Regel" kann jeder der folgenden Werte sein:

0 GLU_TESS_WINDING_ODD
1 GLU_TESS_WINDING_NONZERO
2 GLU_TESS_WINDING_POSITIVE
3 GLU_TESS_WINDING_NEGATIVE
4 GLU_TESS_WINDING_ABS_GEQ_TWO

Beispiel:

zu tessstar
    löscheSchirm
    versteckeIgel
    image=ladeBild "bricks.png
    tex=Textur image
    TexturenAn
    fenstermodus
    setzeStiftfarbe "white
    zurück 300
    setzeTesselationRegeln 1
    Tesselation [
        setzeTexturXY 0.4 1    vorwärts 600  rechts 180-72/2
        setzeTexturXY 1   0.2  vorwärts 600  rechts 180-72/2
        setzeTexturXY 0   0.5  vorwärts 600  rechts 180-72/2
        setzeTexturXY 1   0.8  vorwärts 600  rechts 180-72/2
        setzeTexturXY 0.4 0    vorwärts 600  rechts 180-72/2
    ]
Ende

Reference:

    Release Notes für Version 4.683

TesselationEnde Oberfläche


HC / Grafiken / Zeichnung gefüllter Formen / Oberfläche

Oberfläche

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Oberfläche
setzeTesselationRegeln Oberflächenstart

Oberfläche Befehlsliste

Kommando, um eine Oberfläche mit den Igel-Befehlen innerhalb der "Befehlsliste" zu zeichnen. Es ist sehr einfach, mit diesem Kommando und mit "Oberflächenspalte" Oberflächen zu definieren.

Die Normalenvektoren der ersten Spalte von Punkten sind mit der letzten Spalte, wie in einem Torus, verbunden. So können Sie leicht geschlossene Oberflächen definieren.

Es wird empfohlen, das Grundwort "Oberfläche" anstatt "Oberflächenstart..Oberflächenende" zu verwenden, weil Sie so nicht versehentlich "Oberflächenende" vergessen können, wenn z.B. eine Schleife mit "unterbrich" beendet wird, oder eine Prozedur mit "Ausgabe", "Halt" oder "wirf" verlassen wird.

Sehen Sie auch pretzel2.lg und 3dsurfaces3.lg!

Beispiel:

zu surfacetest
    perspektivisch
    r=200
    setzeStiftfarbe rgb 1 0 0
    versteckeIgel
    Oberfläche [
        für [z -1 1 0.1]
        [	StiftHoch
            setzeOrtXYZ (liste -1 (kosinus 90*-1)*kosinus 90*z z)*r
            StiftAb
            für [x -1 1 0.1]
            [	setzeOrtXYZ (liste x (kosinus 90*x)*kosinus 90*z z)*r
            ]
            Oberflächenspalte
        ]
    ]
    rotateScene
Ende

Example:

  • Versions-Informationen für Version 4.7

References:

    Versions-Informationen für Version 4.7(3), wirfSchatten(2), Oberflächenstart, Schatten, Zylinder, setzeTexturXY

setzeTesselationRegeln Oberflächenstart


HC / Grafiken / Zeichnung gefüllter Formen / Oberflächenstart

Oberflächenstart

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Oberflächenstart
Oberfläche Oberflächenspalte

Oberflächenstart

Kommando, um Logo in den Oberflächen-Definitionsmodus zu bringen. Es ist sehr einfach, mit diesem Kommando und mit "Oberflächenspalte" Oberflächen zu definieren. Mit den Igel-Befehlen können Sie dann die Oberfläche zeichnen.

Die Normalenvektoren der ersten Spalte von Punkten sind mit der letzten Spalte, wie in einem Torus, verbunden. So können Sie leicht geschlossene Oberflächen definieren.

Siehe auch pretzel2.lg und 3dsurfaces3.lg!

Beispiel:

zu surfacetest
    perspektivisch
    r=200
    setzeStiftfarbe rgb 1 0 0
    versteckeIgel
    Oberflächenstart
    für [z -1 1 0.1]
    [	StiftHoch
        setzeOrtXYZ (liste -1 (kosinus 90*-1)*kosinus 90*z z)*r
        StiftAb
        für [x -1 1 0.1]
        [	setzeOrtXYZ (liste x (kosinus 90*x)*kosinus 90*z z)*r
        ]
        Oberflächenspalte
    ]
    Oberflächenende
    rotateScene
Ende

Examples:

  • Oberflächenspalte
  • Oberflächenende

References:

    Oberfläche, Oberflächenende, Oberflächenspalte

Oberfläche Oberflächenspalte


HC / Grafiken / Zeichnung gefüllter Formen / Oberflächenspalte

Oberflächenspalte

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Oberflächenspalte
Oberflächenstart Oberflächenende

Oberflächenspalte

Kommando, das Sie im Oberflächen-Definitionsmodus aufrufen können, um nach der Definition einer Spalte von Punkten eine weitere Spalte von Punkten zu definieren. Die Anzahl von Punkten sollte in jeder dieser Spalten gleich sein.

Beispiel:

to surfacetest
    perspektivisch
    r=200
    setzeStiftfarbe rgb 1 0 0
    versteckeIgel
    Oberflächenstart
    für [z -1 1 0.1]
    [	StiftHoch
        setzeOrtXYZ (liste -1 (kosinus 90*-1)*kosinus 90*z z)*r
        StiftAb
        für [x -1 1 0.1]
        [	setzeOrtXYZ (liste x (kosinus 90*x)*kosinus 90*z z)*r
        ]
        Oberflächenspalte
    ]
    Oberflächenende
    rotateScene
end

Examples:

  • Oberflächenstart
  • Oberflächenende
  • Oberfläche

References:

    Oberfläche(2), Oberflächenstart(2), Oberflächenende

Oberflächenstart Oberflächenende


HC / Grafiken / Zeichnung gefüllter Formen / Oberflächenende

Oberflächenende

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Oberflächenende
Oberflächenspalte Grafik

Oberflächenende

Kommando, um den Oberflächenmodus zu beenden.

Beispiel:

to surfacetest
    perspektivisch
    r=200
    setzeStiftfarbe rgb 1 0 0
    versteckeIgel
    Oberflächenstart
    für [z -1 1 0.1]
    [	StiftHoch
        setzeOrtXYZ (liste -1 (kosinus 90*-1)*kosinus 90*z z)*r
        StiftAb
        für [x -1 1 0.1]
        [	setzeOrtXYZ (liste x (kosinus 90*x)*kosinus 90*z z)*r
        ]
        Oberflächenspalte
    ]
    Oberflächenende
    rotateScene
end

Examples:

  • Oberflächenspalte
  • Oberflächenstart

References:

    Oberfläche(2), Oberflächenspalte, Oberflächenstart

Oberflächenspalte Grafik


HC / Grafiken / Zeichnung gefüllter Formen / Grafik

Grafik

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Grafik
Oberflächenende GrafikAnfang

Grafik Befehlsliste

Ausgabe ist eine neue Grafik, die einer Variablen zugewiesen werden kann, und später durch "zeichneGraphik" gezeichnet werden kann. Alle Grafikbefehle, die innerhalb der Befehlsliste zum aktiven Grafik-Fenster schreiben, werden aufgezeichnet.

Es wird empfohlen, das Grundwort Grafik" anstatt "GrafikStart..GrafikEnde" zu verwenden, weil Sie so nicht versehentlich "GrafikEnde" vergessen können, wenn z.B. eine Schleife mit "unterbrich" beendet wird, oder eine Prozedur mit "Ausgabe", "Halt" oder "wirf" verlassen wird.

Beispiel:

löscheSchirm
perspektivisch
ZylinderlinienAn
setzeStiftdicke 3
setzeStiftfarbe "blau
gr=Grafik [rbox]
wiederhole 50 [zeichneGrafik gr runter 90 vorwärts 20 rollerechts 2 rauf 90]
rotiereszene2

Examples:

  • Versions-Informationen für Version 4.7
  • setzeIgelFormen
  • IgelFormen
  • IgelText

References:

    Grafiken(4), FensterModus(3), ladeGraph(3), zeichneGrafik(3), IgelFormen(2), IgelText(2), Versions-Informationen für Version 4.7(2), betreteGrafik(2), geteilterBildschirm(2), setzeGraphErneuern(2), setzeIgelFormen(2), speichereGraph(2), verlasseGrafik(2), zeichneNochmal(2), Bilder, DitheringAn, DoppelPufferung, Einfachpuffer, GrafikAnfang, GrafikEnde, GrafikGroß, Kommandozeilen-Schalter -nogui, Mausort, Mitte, ModelviewMatrix, Randsprung, Relative Igel-Bewegung, Release, Release Notes für Version 4.65, SchattenAn, TiefentestAn, TiefentestAus, Zaun, aufzeichnenP, fülle, ladeGraphText, löscheBild, löscheSchirm, perspektivisch, runSecure, scrolle, setzePlayOnSwap, setzePunktXY, setzePunktXYZ, setzePunktgröße, setzeQuetschung, setzeSchirmbereich, setzeTextfarbe, setzeTiefentestFunktion, speichereGraphText, speichereSchirmVektoriell, zweidimensional

Oberflächenende GrafikAnfang


HC / Grafiken / Zeichnung gefüllter Formen / GrafikAnfang

GrafikAnfang

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] GrafikAnfang
Grafik GrafikEnde

GrafikAnfang

Kommando, um eine neue Grafik-Kommandoliste zu beginnen. Alle graphischen Kommandos, die auf den aktiven Graphen schreiben, bis "GrafikEnde", werden in ihr aufgezeichnet.

Beispiel:

zu testDrawGraphic
    GrafikAnfang
    box
    abox=GrafikEnde
    löscheSchirm
    rechts 30 vorwärts 100
    zeichneGraphik abox
    links 40 vorwärts 100
    (zeichneGraphik abox 0.5)
Ende


HC / Grafiken / Zeichnung gefüllter Formen / GrafikEnde

GrafikEnde

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] GrafikEnde
GrafikAnfang zeichneGrafik

GrafikEnde

Ausgabe ist die Grafik-Kommandoliste, die seit dem letzten "GraphicStart" aufgezeichnet wurde. Seine Ausgabe ist ein neuer Logo-Knotentyp, der bis jetzt noch nicht in Textform umgewandelt werden kann.

Für ein Beispiel siehe "GraphicStart".

Example:

  • GrafikAnfang

References:

    Grafik(2), GrafikAnfang(2)

GrafikAnfang zeichneGrafik


HC / Grafiken / Zeichnung gefüllter Formen / zeichneGrafik

zeichneGrafik

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] zeichneGrafik
GrafikEnde VideoStart

zeichneGrafik eineGrafik
(zeichneGrafik eineGrafik Skalierung)

Kommando, das die Grafik-Kommandoliste eineGrafik an der aktuellen Igel-Position und -Orientierung abspielt. Die Grafik wird mit einem Faktor "Skalierung" skaliert werden. Für ein Beispiel siehe "Grafik" oder drawasteroids.lg.

Example:

  • Grafik

Reference:

    Grafik

GrafikEnde VideoStart


HC / Grafiken / Zeichnung gefüllter Formen / VideoStart

VideoStart

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] VideoStart
zeichneGrafik VideoFrame

VideoStart Dateiname
(VideoStart Dateiname Framerate)

Kommando, um die Erstellung einer Video-für-Windows-Datei (.avi) mit Name Dateiname und Framerate (oder Framerate=30=Vorgabe) zu beginnen.

Beispiel:

VideoStart "test
für [i 0 90] [löscheSchirm rechts i  rbox  erneuereGraph VideoFrame]
VideoEnde

Examples:

  • VideoFrame
  • VideoEnde

References:

    VideoEnde(2), VideoFrame(2), Release Notes für Version 4.685

zeichneGrafik VideoFrame


HC / Grafiken / Zeichnung gefüllter Formen / VideoFrame

VideoFrame

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] VideoFrame
VideoStart VideoEnde

VideoFrame

Kommando, das einen Frame vom aktiven Graphen liest und in die mit VideoStart geöffnete Video-für-Windows-Datei (.avi) schreibt.

Beispiel:

VideoStart "prüfe
für [i 0 90] [löscheSchirm rechts i  rbox  erneuereGraph VideoFrame]
VideoEnde

Examples:

  • VideoStart
  • VideoEnde

References:

    Release Notes für Version 4.685, VideoEnde, VideoStart

VideoStart VideoEnde


HC / Grafiken / Zeichnung gefüllter Formen / VideoEnde

VideoEnde

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] VideoEnde
VideoFrame fülleRechteck

VideoEnde

Kommando zum Beenden eines Videos und Schließen der mit "VideoStart" geöffneten Video-für-Windows-Datei (.avi).

Beispiel:

VideoStart "prüfe
für [i 0 90] [löscheSchirm rechts i  rbox  erneuereGraph VideoFrame]
VideoEnde

Examples:

  • VideoFrame
  • VideoStart

References:

    VideoFrame, VideoStart

VideoFrame fülleRechteck


HC / Grafiken / Zeichnung gefüllter Formen / fülleRechteck

fülleRechteck

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] fülleRechteck
VideoEnde fülleKreis

fülleRechteck xy1 xy2

Zeichnet ein gefülltes Rechteck zwischen den Koordinaten xy1 und xy2 im floodColor.

Beispiel:

rechts 30
setzeFüllfarbe RGB 1 0 0
fülleRechteck [0 0][200 100]

Example:

  • TexturenAn

References:

    Release Notes für Version 4.64, TexturenAn

VideoEnde fülleKreis


HC / Grafiken / Zeichnung gefüllter Formen / fülleKreis

fülleKreis

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] fülleKreis
fülleRechteck fülleEllipse

fülleKreis Radius

Füllt einen Kreis beim Igel mit Radius "Radius" in der Farbe "Füllfarbe".

Beispiel:

setzeFüllfarbe RGB 1 0 0
fülleKreis 100

Examples:

  • VieleckglättungAus
  • VieleckglättungAn

References:

    VieleckglättungAn, VieleckglättungAus

fülleRechteck fülleEllipse


HC / Grafiken / Zeichnung gefüllter Formen / fülleEllipse

fülleEllipse

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] fülleEllipse
fülleKreis fülleKuchen

fülleEllipse radiusX radiusY

Zeichnet eine gefüllte Ellipse an dem Igel-Ort mit radiusX und radiusY in der Farbe "Füllfarbe". Die Radien sind relativ zur Igel Kurs.

Beispiel:

setzeFüllfarbe RGB 1 0 0
rechts 30
fülleEllipse 200 100

Reference:

    Release Notes für Version 4.64

fülleKreis fülleKuchen


HC / Grafiken / Zeichnung gefüllter Formen / fülleKuchen

fülleKuchen

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] fülleKuchen
fülleEllipse Kugel

fülleKuchen Winkelradius

Kommando zum Zeichnen eines gefüllten Kuchens an der Igel-Position vom Igel-Kurs in Uhrzeigerrichtung zeichnend.

Beispiel:

löscheSchirm
rechts 30
fülleKuchen 90 200


HC / Grafiken / Zeichnung gefüllter Formen / Kugel

Kugel

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Kugel
fülleKuchen Ellipsoid

Kugel Radius
(Kugel Radius Scheiben Stapel)
Kommando zum Zeichnen einer Kugel mit Radius "Radius" im
perspektivischen Modus.

Die optionalen Argumente Scheiben und Stapel sind ganze Zahlen, die feinere Kontrolle über die Zeichnung erlauben. Sie sollten nicht zu groß sein (um 500 maximal), weil sonst das Zeichnen Ewigkeiten dauert.

Beispiel:

perspektivisch
Kugel 100
rotatescene

Examples:

  • setzeTiefentestFunktion
  • setzeMaterialShininess
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSchattenfarbe
  • setzeSpecularLicht
  • orthographisch
  • setzeLichtOrt
  • wirfSchatten
  • SchattenAn

References:

    SchattenAn(2), setzeOrtInKugelkoordinaten(2), setzeTiefentestFunktion(2), wirfSchatten(2), Release Notes für Version 4.672, Release Notes für Version 4.685, Schatten, orthographisch, setzeDiffusesLicht, setzeLichtOrt, setzeMaterialShininess, setzeSchattenfarbe, setzeSpecularLicht, setzeUmgebungslicht

fülleKuchen Ellipsoid


HC / Grafiken / Zeichnung gefüllter Formen / Ellipsoid

Ellipsoid

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Ellipsoid
Kugel EllipsoidenTeil

Ellipsoid radiusx radiusy radiusz

Kommando zum Zeichnen eines Ellipsoiden an der Position des Igels, mit den drei Radien entlang des Igel-Dreibeins, das gebildet wird aus den Vektoren: (nach rechts), (vorne) und (nach oben).

Beispiel:

löscheSchirm
perspektivisch
setzeStiftfarbe 4
Ellipsoid 100 200 300
rotatescene


HC / Grafiken / Zeichnung gefüllter Formen / EllipsoidenTeil

EllipsoidenTeil

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] EllipsoidenTeil
Ellipsoid Zylinder

EllipsoidenTeil radiusx radiusy radiusz sls sle sl sts ste s_t

Kommando, einen Teil eines Ellipsoiden mit den drei Radien zu zeichnen, radiusx, radiusy und radiusz, relativ zur gegenwärtigen Igel Orientierung.

sls ist slicesStart (Winkel in Grad, 0..360),

sle ist slicesEnd (Winkel in Grad, 0..360),

sl ist Scheiben (Ganzzahl 1..100 vernünftig),

sts ist stacksStart (Winkel in Grad, 0..180),

ste ist stacksEnd (Winkel in Grad, 0..180),

s_t ist Stapel (Ganzzahl 1..100 vernünftig).

Beispiele:

perspektivisch
EllipsoidenTeil 100 200 300  0 180 10  0 90 10
EllipsoidenTeil 100 200 300  0 360 10  0 180 10
rotatescene

References:

    Release Notes für Version 4.69, Schatten, wirfSchatten

Ellipsoid Zylinder


HC / Grafiken / Zeichnung gefüllter Formen / Zylinder

Zylinder

HC [image] Grafiken [image] Zeichnung gefüllter Formen [image] Zylinder
EllipsoidenTeil Beleuchtung

Zylinder Länge BasisRadius
(Zylinder Länge BasisRadius TopRadius StartWinkel EndWinkel Quetschung Scheiben)

Kommando, um die Oberfläche eines Zylinders im Dreidimensionalen zu zeichnen. Die oberen und unteren Seiten werden nicht gezeichnet, bis jetzt. Die Argumente sollten alle Zahlen sein. Mit "BasisRadius"=0 oder "TopRadius"=0 wird es einen Kegle zeichnen. "StartWinkel" und "EndWinkel" werden in Grad angegeben, 360 stellt einen ganzen Kreis dar. Ein Teil-Zylinder kann gezeichnet werden, wenn Sie eine kleiner Differenz zwischen "EndWinkel" und "StartWinkel" als 360 Grad angeben. Wenn Sie diese Differenz zwischen den Winkeln viel höher wählen, können Sie seltsam aussehende, gefaltete Formen bekommen. "Quetschung" ist ein Faktor, gewöhnlich im Bereich 0..1..10, der zur Koordinate in Richtung des Igel-Kopfes multipliziert wird. "Scheiben" ist die Anzahl von Teilflächen, aus denen der Zylinder bestehen wird.

Beispiele:

löscheSchirm
perspektivisch
setzeStiftfarbe "rot
Zylinder 200 100
vorwärts 200
(Zylinder 200 100 0)
löscheSchirm
(Zylinder 300 200 100 0 90)
löscheSchirm
(Zylinder 300 200 100 0 360 2)
löscheSchirm
(Zylinder 300 200 100 0 360 1 5)

Example:

  • Versions-Informationen für Version 4.7

References:

    setzeZylinderOrt(2), Versions-Informationen für Version 4.7, ZylinderlinienAn, ZylinderlinienAus, setzeStiftdicke, vorwärts, zurück

EllipsoidenTeil Beleuchtung


HC / Grafiken / Beleuchtung

Beleuchtung

HC [image] Grafiken [image] Beleuchtung
Zylinder setzeLichtOrt

Beleuchtung

Hier sind Funktionen, um die Beleuchtungsparameter von OpenGL zu setzen.

Beleuchtung

  • setzeLichtOrt
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSpecularLicht

References:

    BeleuchtungAn, BeleuchtungAus

Zylinder setzeLichtOrt


HC / Grafiken / Beleuchtung / setzeLichtOrt

setzeLichtOrt

HC [image] Grafiken [image] Beleuchtung [image] setzeLichtOrt
Beleuchtung setzeUmgebungslicht

setzeLichtOrt 3dReihenOrt

Kommando zum Setzen der Position von light0 von OpenGL.

Das Argument ist ein Reihe, die drei Zahlen enthält (die Position).

Beispiel:

löscheSchirm
perspektivisch
setzeStiftfarbe 4
Kugel 300
setzeLichtOrt {0 0 100}
zeichneNochmal

Reference:

    Release Notes für Version 4.65

Beleuchtung setzeUmgebungslicht


HC / Grafiken / Beleuchtung / setzeUmgebungslicht

setzeUmgebungslicht

HC [image] Grafiken [image] Beleuchtung [image] setzeUmgebungslicht
setzeLichtOrt setzeDiffusesLicht

setzeUmgebungslicht Farbe

Kommando, um die Umgebungslichtfarbe zu setzen. "Farbe" ist ein Ganzzahl, die von RGB, RGBA, TSH, oder HSBA gebildet wurde.

Beispiel:

löscheSchirm
setzeStiftfarbe 7
perspektivisch
setzeUmgebungslicht RGB 1 0 0
Kugel 300

Reference:

    reset

setzeLichtOrt setzeDiffusesLicht


HC / Grafiken / Beleuchtung / setzeDiffusesLicht

setzeDiffusesLicht

HC [image] Grafiken [image] Beleuchtung [image] setzeDiffusesLicht
setzeUmgebungslicht setzeSpecularLicht

setzeDiffusesLicht Farbe

Kommando, um die diffuse Licht-Farbe zu setzen. Farbe ist eine Ganzzahl, die von RGB, RGBA, TSH, oder HSBA erzeugt wurde.

Beispiel:

löscheSchirm
setzeStiftfarbe 7
perspektivisch
setzeDiffusesLicht RGB 1 0 0
Kugel 300

Reference:

    reset

setzeUmgebungslicht setzeSpecularLicht


HC / Grafiken / Beleuchtung / setzeSpecularLicht

setzeSpecularLicht

HC [image] Grafiken [image] Beleuchtung [image] setzeSpecularLicht
setzeDiffusesLicht Nebel

setzeSpecularLicht Farbe

Kommando, um die Specular-Licht-Farbe zu setzen. Farbe ist eine Ganzzahl, die von RGB, RGBA, TSH, oder HSBA erzeugt wurde.

Beispiel:

löscheSchirm
setzeStiftfarbe 7
perspektivisch
setzeSpecularLicht RGB 1 0 0
Kugel 300

Reference:

    Release Notes für Version 4.65

setzeDiffusesLicht Nebel


HC / Grafiken / Nebel

Nebel

HC [image] Grafiken [image] Nebel
setzeSpecularLicht setzeNebeldichte

Nebel

Der schöne Nebel-Effekt von OpenGL ist nun auch in aUCBLogo (4.689) verfügbar.

Nebel

  • setzeNebeldichte
  • setzeNebelBereich
  • setzeNebelfarbe
  • setzeNebelModus

References:

    NebelAn(2), NebelAus, Release Notes für Version 4.689, setzeNebelModus

setzeSpecularLicht setzeNebeldichte


HC / Grafiken / Nebel / setzeNebeldichte

setzeNebeldichte

HC [image] Grafiken [image] Nebel [image] setzeNebeldichte
Nebel setzeNebelBereich

setzeNebeldichte Dichte

Kommando, um den Dichteparameter des OpenGL Nebels zu setzen. Es führt nicht "NebelAn" aus, Sie müssen das explizit aufrufen. Typische Werte für Dichte sind 0.001...0.5.

Beispiel:

löscheSchirm perspektivisch
setzeNebeldichte 0.3
setzeNebelfarbe "white
NebelAn
x=reelleZahlen random Ganzzahlen reelleZahlenFolge 800 800 1000000
y=reelleZahlen random Ganzzahlen reelleZahlenFolge 400 400 1000000
z=reelleZahlen random Ganzzahlen reelleZahlenFolge 800 800 1000000
setzePunktXYZ x-400 y-400 z-400 0
rotatescene

Example:

  • setzeNebelModus

References:

    Release Notes für Version 4.689, setzeNebelModus

Nebel setzeNebelBereich


HC / Grafiken / Nebel / setzeNebelBereich

setzeNebelBereich

HC [image] Grafiken [image] Nebel [image] setzeNebelBereich
setzeNebeldichte setzeNebelfarbe

setzeNebelBereich Anfang Ende

Kommando, um den Bereichparameter des OpenGL Nebels zu setzen. "Anfang" und "Ende" sind Zahlen im Bereich von sichtbaren Koordinaten, typischerweise ist "Anfang" 200..-400, "Ende" ist 0..1000.

Beispiel:

setzeNebelBereich 0 300

Reference:

    Release Notes für Version 4.689

setzeNebeldichte setzeNebelfarbe


HC / Grafiken / Nebel / setzeNebelfarbe

setzeNebelfarbe

HC [image] Grafiken [image] Nebel [image] setzeNebelfarbe
setzeNebelBereich setzeNebelModus

setzeNebelfarbe Farbe

Kommando, um die Nebelfarbe auf "Farbe" zu setzen, die eine gültige Farbe sein muss. Siehe auch setzeStiftfarbe.

Beispiel:

setzeNebelfarbe "weiß

Examples:

  • setzeNebeldichte
  • setzeNebelModus

References:

    Release Notes für Version 4.689, setzeNebelModus, setzeNebeldichte

setzeNebelBereich setzeNebelModus


HC / Grafiken / Nebel / setzeNebelModus

setzeNebelModus

HC [image] Grafiken [image] Nebel [image] setzeNebelModus
setzeNebelfarbe Bilder

setzeNebelModus Modus

Kommando, um den Nebelmodus zu setzen. Es wird empfohlen, in der OpenGL Dokumentation über die Nebelgleichungen zu lesen.

Die folgenden Konstanten können als Modus benutzt werden:

GL_LINEAR
GL_EXP
GL_EXP2

Linearer Nebel wird zur Zeit bei jedem Aufruf von "perspektivisch" ausgewählt.

Beispiel:

löscheSchirm perspektivisch
setzeNebeldichte 0.001
setzeNebelfarbe "white
setzeNebelModus GL_EXP
NebelAn
x=reelleZahlen random Ganzzahlen reelleZahlenFolge 800 800 1000000
y=reelleZahlen random Ganzzahlen reelleZahlenFolge 400 400 1000000
z=reelleZahlen random Ganzzahlen reelleZahlenFolge 800 800 1000000
setzePunktXYZ x-400 y-400 z-400 0

Reference:

    Release Notes für Version 4.689

setzeNebelfarbe Bilder


HC / Grafiken / Bilder

Bilder

HC [image] Grafiken [image] Bilder
setzeNebelModus speichereGraph

Bilder

Hier sind Kommandos zum Speichern und Laden von Grafik.

Bilder

  • speichereGraph
  • ladeGraph
  • speichereGraphText
  • ladeGraphText
  • speicherePostScript
  • speichereSchirm
  • speichereSchirmVektoriell
  • SpeicherungGröße
  • setzeSpeicherungsGröße

References:

    Einführung in die Logo-Programmierung, ladeBild

setzeNebelModus speichereGraph


HC / Grafiken / Bilder / speichereGraph

speichereGraph

HC [image] Grafiken [image] Bilder [image] speichereGraph
Bilder ladeGraph

speichereGraph Dateiname

Kommando. Schreibt eine Datei mit dem angegebenen Namen, die den Zustand vom Grafik-Fenster im internen Format des Logos enthalten wird. Dieses Bild kann dem "ladeGraph"-Befehl wieder auf den Schirm geholt werden. Das Format ist nicht portabel zwischen Plattformen, noch ist es leicht lesbar von anderen Programmen. Siehe "speicherePostScript" oder "speichereGraphText", um Logo-Grafik für andere Programme zu exportieren.

References:

    Release Notes für Version 4.64(2), Release Notes für Version 4.685, ladeGraph, speichereGraphText

Bilder ladeGraph


HC / Grafiken / Bilder / ladeGraph

ladeGraph

HC [image] Grafiken [image] Bilder [image] ladeGraph
speichereGraph speichereGraphText

ladeGraph Dateiname

Kommando. Liest die spezifizierte Datei, die von einem "speichereGraph" Befehl geschrieben worden sein muss, und stellt das Grafik-Fenster zu den in der Datei gespeicherten Werten wieder her. Jedwede Grafik vorher im aktuellek Graphen aufgezeichnete Grafik wird dabei gelöscht.

References:

    Release Notes für Version 4.64(2), Release Notes für Version 4.685, ladeGraphText, speichereGraph

speichereGraph speichereGraphText


HC / Grafiken / Bilder / speichereGraphText

speichereGraphText

HC [image] Grafiken [image] Bilder [image] speichereGraphText
ladeGraph ladeGraphText

speichereGraphText Dateibezeichnung

Kommando. Schreibt eine Datei mit dem angegebenen Namen, die den Zustand des Grafik-Fensters in Text Format enthält. Dieses Bild kann mit "ladeGraphText" wieder auf den Schirm geladen werden. Das Format ist portabel zwischen Plattformen, und von anderen Programmen leicht lesbar. Siehe "speichereGraph" für eine schnellere, aber nicht portable Methode.

References:

    Release Notes für Version 4.685, ladeGraphText, speichereGraph

ladeGraph ladeGraphText


HC / Grafiken / Bilder / ladeGraphText

ladeGraphText

HC [image] Grafiken [image] Bilder [image] ladeGraphText
speichereGraphText speicherePostScript

ladeGraphText Dateibezeichnung

Kommando. Liest die angegebene Datei, die von einem "speichereGraphText" Befehl oder einem kompatiblen Generator geschrieben worden sein muss, und stellt das Grafik-Fenster aus den in der Datei gespeicherten Werten wieder her. Jedwedes vorher im aktiven Graphen gezeichnete wird durch diesen Befehl gelöscht. Siehe "ladeGraph" für eine schnellere, aber nicht portable Methode.

References:

    Release Notes für Version 4.685, speichereGraphText

speichereGraphText speicherePostScript


HC / Grafiken / Bilder / speicherePostScript

speicherePostScript

HC [image] Grafiken [image] Bilder [image] speicherePostScript
ladeGraphText speichereSchirm

speicherePostScript Dateiname

funktioniert noch nicht gut!

Das neue Grundwort "speichereSchirmVektoriell" funktioniert besser.

Kommando. Schreibt eine Datei mit dem angegebenen Namen, die eine Darstellung des Graphikenfensterzustands im Encapsulated Postscript (EPS) enthält. Diese Datei kann in andere Programme importiert werden, die das EPS-Format verstehen. Einschränkungen: die Zeichnung kann "Bogen", "fülle", "radiere" oder "UmkehrStift" nicht benutzen; solche Anweisungen werden in der Übersetzung zur PostScript-Form ignoriert.

References:

    Release Notes für Version 4.64, speichereGraph

ladeGraphText speichereSchirm


HC / Grafiken / Bilder / speichereSchirm

speichereSchirm

HC [image] Grafiken [image] Bilder [image] speichereSchirm
speicherePostScript speichereSchirmVektoriell

speichereSchirm Dateiname

Kommando. Speichert den aktiven Grafikschirm in der Bilddatei namens "Dateiname". Die Größe des erzeugten Bildes hängt von der "SpeicherungsGröße" ab. Hochaufgelöstes Speichern wird bis jetzt nur unter Windows unterstützt.

Hier ist die Liste der zum Speichern verfügbaren Dateiformate:

    .bmp
    .png
    .jpeg
    .pcx
    .pnm
    .tiff
    .xpm
    .ico
    .cur
Beispiel:

setzeSpeicherungsGröße [400 300]
löscheSchirm
crbox
boundingbox
rechts 30
speichereSchirm "test.png

Example:

  • setzeSpeicherungsGröße

References:

    setzeSpeicherungsGröße(2), Release Notes für Version 4.685, SpeicherungGröße

speicherePostScript speichereSchirmVektoriell


HC / Grafiken / Bilder / speichereSchirmVektoriell

speichereSchirmVektoriell

HC [image] Grafiken [image] Bilder [image] speichereSchirmVektoriell
speichereSchirm SpeicherungGröße

speichereSchirmVektoriell Dateiname
(speichereSchirmVektoriell Dateiname Sortierung Optionen Farbanzahl)

TODO: Rest übersetzen (ab "Optionen")

Kommando, um das aktive Graph-Fenster einem Vektorgrafikformat zu speichern, das von der Dateierweiterung bestimmt wird.

Die benutzte Bibliothek GL2PS unterstützt bisher sechs Formate:

PS Der ausgegebene Strom ist im PostScript-Format.

EPS Der ausgegebene Strom ist im Encapsulated PostScript Format.

PDF Der ausgegebene Strom ist im Portable Document Format.

TEX Die Ausgabe wird eine LATEX Datei sein, die nur die Zeichenketten der Zeichnung (vergl. Abschnitt 2.2) enthält, ebenso wie einen \includegraphics-Befehl einschließlich einer Grafik-Datei des gleichen Basisnamens wie filename.1.

GL2PS_SVG (Experimentell) Der Ausgabestrom ist im Scalar Vector Graphics-Format.

GL2PS_PGF (Experimentell) Der Ausgabestrom ist im Portable LaTeX Graphics-Format.

"Sortierung" spezifiziert den Sortier-Algorithmus, aus folgender Auswahl:

GL2PS_NO_SORT Die Primitives werden nicht sortiert und werden in der Reihenfolge in den Strom ausgegeben, in der sie im Feedback-Puffer erscheinen. Das ist ausreichend für zweidimensionale Szenen.

GL2PS_SIMPLE_SORT Die Primitives werden nach ihrem Schwerpunkt sortiert. Das kann ausreichend sein für einfache dreidimensionale Szenen, und/oder wenn Korrektheit nicht unbedingt erforderlich ist.

GL2PS_BSP_SORT Die Primitives werden in einen Binären Raum-Teilungs-Baum (BSP) einsortiert. Dieser Baum wird dann von hinten nach vorne in einem Malerartigen Algorithmus durchgegangen. Dies sollte benutzt werden, wenn ein genaues Rendering einer dreidimensionalen Szene gefragt ist. Beachten Sie, dass dieser Algorithmus eine Menge mehr Rechenzeit (und Speicher) braucht als die einfache Schwerpunkts-Sortierung.

"Optionen" Sets global plot options, chosen among (multiple options can be combined with the bitwise inclusive or symbol ):

GL2PS_NONE No option.

GL2PS_DRAW_BACKGROUND The background frame is drawn in the plot.

GL2PS_SIMPLE_LINE_OFFSET A small offset is added in the z-buffer to all the lines in the plot. This is a simplified version of the GL2PS_POLYGON_OFFSET_FILL functionality (cf. section 2.4), putting all the lines of the rendered image slightly in front of their actual position. This thus performs a simple anti-aliasing solution, e.g. for finiteelement-like meshes.

GL2PS_SILENT All the messages written by GL2PS on the error stream are suppressed. GL2PS_BEST_ROOT The construction of the BSP tree is optimized by choosing the root primitives leading to the minimum number of splits.

GL2PS_NO_TEXT All the text strings are suppressed from the output stream. This is useful to produce the image part of a LATEX plot.

GL2PS_NO_PIXMAP All the pixmaps are suppressed from the output stream.

GL2PS_LANDSCAPE The plot is output in landscape orientation instead of portrait.

GL2PS_NO_PS3_SHADING (for PostScript output only) No use is made of the shfill PostScript level 3 operator. Using shfill enhances the plotting of smooth shaded primitives but can lead to problems when converting PostScript files into PDF files. See also options colornr below.

GL2PS_NO_BLENDING Blending (transparency) is disabled alltogether (regardless of the current GL_BLEND or GL2PS_BLEND status).

GL2PS_OCCLUSION_CULL All the hidden polygons are removed from the output, thus substantially reducing the size of the output file.

GL2PS_USE_CURRENT_VIEWPORT The current OpenGL viewport is used instead of viewport.

GL2PS_TIGHT_BOUNDING_BOX The viewport is ignored and the the plot is generated with a tight bounding box, i.e., a bounding box enclosing as tightly as possible all the OpenGL entities in the scene.

colornr (for PostScript output only) Controls the number of flat-shaded (sub-)triangles used to approximate a smooth-shaded triangle when the shfill operator is not supported by the system, or when the GL2PS_NO_PS3_SHADING option is set. The argument colornr specify the number of values used for interpolating the full range of red, green and blue color components; that is, a triangle is recursively subdivided until the color difference between two of its vertices is smaller that 1/nr for the red component, 1/ng for the green component and 1/nb for the blue component. If the arguments are set to zero, default values are used.

Examples:

spielbrett
saveScreenVector "test.ps
saveScreenVector "test.eps
(saveScreenVector "test.pdf GL2PS_NO_SORT
    GL2PS_SIMPLE_LINE_OFFSET+GL2PS_DRAW_BACKGROUND)

References:

    Release Notes für Version 4.685, speicherePostScript

speichereSchirm SpeicherungGröße


HC / Grafiken / Bilder / SpeicherungGröße

SpeicherungGröße

HC [image] Grafiken [image] Bilder [image] SpeicherungGröße
speichereSchirmVektoriell setzeSpeicherungsGröße

SpeicherungGröße

Ausgabe ist eine zweielementige Liste, die Breite und Höhe der virtuellen Grafikleinwand enthält, die bei "speichereSchirm" verwendet werden wird. Es ist standardmäßig [800 600].

Beispiel:

SpeicherungGröße		;[2000 1500]	 ;-)


HC / Grafiken / Bilder / setzeSpeicherungsGröße

setzeSpeicherungsGröße

HC [image] Grafiken [image] Bilder [image] setzeSpeicherungsGröße
SpeicherungGröße Bitmaps

setzeSpeicherungsGröße GrößenListe

Kommando, um Breite und Höhe der virtuellen Grafikleinwand zu setzen, die bei "speichereSchirm" verwendet werden wird.

Beispiel:

tree
setzeSpeicherungsGröße [4000 3000]
speichereSchirm "temp.bmp		;dann haben Sie einen hochaufgelösten Baum!

Example:

  • speichereSchirm

References:

    Release Notes für Version 4.65, speichereSchirm

SpeicherungGröße Bitmaps


HC / Grafiken / Bitmaps

Bitmaps

HC [image] Grafiken [image] Bitmaps
setzeSpeicherungsGröße BitmapKopieren

Bitmaps

Eine Bitmap ein interner Logo-Knotentyp, der eine RGBA Bitmap von spezifizierter Breite und Höhe beinhalten kann.

Bitmaps

  • BitmapKopieren
  • zeichneBitmap
  • zeichneBitmapSchnell
  • zeichneBitmapAuf
  • zeichneBitmapSkaliertAuf
  • ladeBild
  • speichereBild
  • macheBitmapDurchsichtig
  • BitmapSetzePunkt
  • BitmapPunkt
  • BitmapGrößeX
  • BitmapGrößeY
  • fülleBitmap


HC / Grafiken / Bitmaps / BitmapKopieren

BitmapKopieren

HC [image] Grafiken [image] Bitmaps [image] BitmapKopieren
Bitmaps zeichneBitmap

BitmapKopieren Breite Höhe

Ausgabe ist eine Bitmap, die einer Variablen zugewiesen und nochmals mit "zeichneBitmap" auf den Bildschirm geklebt werden kann.

In die Bitmap wird der Teil des Grafikbildschirms rechts oberhalb vom Igel mit Breite und Höhe kopiert. Siehe auch das bitmapTest.lg Beispiel!

Beispiel:

tree
b=BitmapKopieren 200 200
zurück 200
zeichneBitmap b

Examples:

  • zeichneBitmapSkaliertAuf
  • zeichneBitmapSchnell
  • zeichneBitmapAuf
  • zeichneBitmap
  • BitmapGrößeX
  • BitmapGrößeY
  • fülleBitmap

References:

    zeichneBitmapAuf(3), zeichneBitmapSkaliertAuf(2), BitmapGrößeX, BitmapGrößeY, Release Notes für Version 4.64, Release Notes für Version 4.685, fülleBitmap, zeichneBitmap, zeichneBitmapSchnell

Bitmaps zeichneBitmap


HC / Grafiken / Bitmaps / zeichneBitmap

zeichneBitmap

HC [image] Grafiken [image] Bitmaps [image] zeichneBitmap
BitmapKopieren zeichneBitmapSchnell

zeichneBitmap Bitmap

Kommando, das die Bitmap mit unterer linker Ecke beim Igel auf den Bildschirm klebt.

Beispiel:

tree
b=BitmapKopieren 200 200
zurück 200
zeichneBitmap b

Examples:

  • zeichneBitmapSkaliertAuf
  • macheBitmapDurchsichtig
  • zeichneBitmapAuf
  • BitmapKopieren
  • BitmapGrößeX
  • BitmapGrößeY
  • fülleBitmap
  • ladeBild

References:

    BitmapKopieren(2), macheBitmapDurchsichtig(2), zeichneBitmapAuf(2), BitmapGrößeX, BitmapGrößeY, Release Notes für Version 4.64, fülleBitmap, ladeBild, zeichneBitmapSchnell, zeichneBitmapSkaliertAuf

BitmapKopieren zeichneBitmapSchnell


HC / Grafiken / Bitmaps / zeichneBitmapSchnell

zeichneBitmapSchnell

HC [image] Grafiken [image] Bitmaps [image] zeichneBitmapSchnell
zeichneBitmap zeichneBitmapAuf

zeichneBitmapSchnell Bitmap

Kommando, das die Bitmap mit unterer linker Ecke beim Igel auf den Bildschirm klebt. Es verwendet direkt BitBlt auf das Fenster, daher ist es schneller als zeichneBitmap, aber mit dem Nachteil, dass jedes andere Zeichnen die Zeichnungen von zeichneBitmapSchnell auslöschen wird.

Beispiel:

zu bitpastefasttest
    setzeErneuereGraph falsch
    löscheSchirm
    box
    bmp=BitmapKopieren 100 100
    löscheSchirm
    StiftHoch
    solange [nicht Taste?]
    [	setzeXY 700*zufällig-400 500*zufällig-300
        zeichneBitmapSchnell bmp
    ]
    Mitte
    StiftAb
Ende


HC / Grafiken / Bitmaps / zeichneBitmapAuf

zeichneBitmapAuf

HC [image] Grafiken [image] Bitmaps [image] zeichneBitmapAuf
zeichneBitmapSchnell zeichneBitmapSkaliertAuf

zeichneBitmapAuf Ziel Quelle x y

Kommando, das die Bitmap "Quelle" mit unterer linker Ecke bei Punkt-Position (x,y) innerhalb der Bitmap "Ziel" zeichnet.

Beispiel:

zu bitpastetotest
    löscheSchirm
    box
    StiftHoch setzeXY -10 -10
    bmp=BitmapKopieren 200 200
    bmp2=BitmapKopieren 200 200
    macheBitmapDurchsichtig bmp2 SchirmFarbe
    zeichneBitmapAuf bmp bmp2 (BitmapGrößeX bmp)*0.4 (BitmapGrößeY bmp)*0.4
    Mitte
    setzeXY -10 -10
    zeichneBitmap bmp
    Mitte
    StiftAb
Ende

Ein interessanter Effekt wird erzeugt, wenn zeichneBitmapAuf mit Quelle gleich Ziel angewandt wird.

Beispiel:

zu bitpastetotest
    löscheSchirm
    setzeStiftFarbe RGBA 0 0 1 0.8
    box
    StiftHoch setzeXY -10 -10
    bmp=BitmapKopieren 200 200
    macheBitmapDurchsichtig bmp SchirmFarbe
    zeichneBitmapAuf bmp bmp (BitmapGrößeX bmp)*0.05 (BitmapGrößeY bmp)*0.03
    Mitte
    setzeXY -10 -10
    zeichneBitmap bmp
    Mitte
    StiftAb
Ende

Example:

  • zeichneBitmapSkaliertAuf

Reference:

    zeichneBitmapSkaliertAuf

zeichneBitmapSchnell zeichneBitmapSkaliertAuf


HC / Grafiken / Bitmaps / zeichneBitmapSkaliertAuf

zeichneBitmapSkaliertAuf

HC [image] Grafiken [image] Bitmaps [image] zeichneBitmapSkaliertAuf
zeichneBitmapAuf ladeBild

zeichneBitmapSkaliertAuf Ziel Quelle x y xSkalierung ySkalierung

Kommando, das die Bitmap "Quelle" mit unterer linker Ecke bei Punkt-Position (x,y) innerhalb der Bitmap "Ziel" zeichnet, aber skaliert um die Faktoren "xSkalierung" und "ySkalierung". "xSkalierung" und "ySkalierung" sollten gleich Eins sein, wenn keine Skalierung gewollt ist.

Beispiel:

zu bitpastetoscaledtest
    löscheSchirm
    box
    StiftHoch setzeXY -10 -10
    bmp=BitmapKopieren 200 200
    bmp2=BitmapKopieren 200 200
    macheBitmapDurchsichtig bmp2 SchirmFarbe
    zeichneBitmapAuf bmp bmp2 (BitmapGrößeX bmp)*0.1 (BitmapGrößeY bmp)*0.1 0.9 0.9
    Mitte
    setzeXY -10 -10
    zeichneBitmap bmp
    Mitte
    StiftAb
Ende


HC / Grafiken / Bitmaps / ladeBild

ladeBild

HC [image] Grafiken [image] Bitmaps [image] ladeBild
zeichneBitmapSkaliertAuf speichereBild

ladeBild Dateiname

Ausgabe ist eine von der Datei "Dateiname" geladene Bitmap. Gegenwärtig unterstützte Dateiformate sind:

wxBMPHandler  Für Laden und Speichern.
wxPNGHandler  Für Laden (einschließlich Alpha-Unterstützung) und Speichern.
wxJPEGHandler  Für Laden und Speichern.
wxGIFHandler  Für Laden (war wegen Patenten).
wxPCXHandler  Für Laden und Speichern.
wxPNMHandler  Für Laden und Speichern.
wxTIFFHandler  Für Laden und Speichern.
wxIFFHandler  Für Laden nur.
wxXPMHandler  Für Laden und Speichern.
wxICOHandler  Für Laden und Speichern.
wxCURHandler  Für Laden und Speichern.
wxANIHandler  Für Laden nur.

Laden von PNMs funktioniert nur für ASCII oder rohe RGB Bilder.

Beispiel:

b=ladeBild "iris.png
zeichneBitmap b

Examples:

  • macheBitmapDurchsichtig
  • setzeTesselationRegeln
  • setzeTexturXY
  • speichereBild
  • TexturenAn
  • Textur

References:

    Release Notes für Version 4.683(2), Textur, TexturenAn, macheBitmapDurchsichtig, setzeTesselationRegeln, setzeTexturXY, speichereBild

zeichneBitmapSkaliertAuf speichereBild


HC / Grafiken / Bitmaps / speichereBild

speichereBild

HC [image] Grafiken [image] Bitmaps [image] speichereBild
ladeBild macheBitmapDurchsichtig

speichereBild Bitmap Dateiname

Kommando zum Speichern der Bitmap in einer Datei. Gegenwärtig unterstützte Dateiformate sind:

wxBMPHandler  Für Laden und Speichern.
wxPNGHandler  Für Laden (einschließlich Alpha-Unterstützung) und Speichern.
wxJPEGHandler  Für Laden und Speichern.
wxGIFHandler  Für Laden (war wegen Patenten).
wxPCXHandler  Für Laden und Speichern.
wxPNMHandler  Für Laden und Speichern.
wxTIFFHandler  Für Laden und Speichern.
wxIFFHandler  Für Laden nur.
wxXPMHandler  Für Laden und Speichern.
wxICOHandler  Für Laden und Speichern.
wxCURHandler  Für Laden und Speichern.
wxANIHandler  Für Laden nur.

Beim Speichern im PCX-Format, wird der wxPCXHandler die Anzahl an verschiedenen Farben im Bild zählen; wenn es 256 oder weniger Farben gibt, wird es als 8 Bit-Bild gepseichert, sonst als 24 Bit-Bild.

Beim Speichern im PNM-Format, speichert der wxPNMHandler immer als raw RGB.

Beispiel:

b=ladeBild "iris.png
speichereBild b "temp.png

Reference:

    Release Notes für Version 4.683(2)

ladeBild macheBitmapDurchsichtig


HC / Grafiken / Bitmaps / macheBitmapDurchsichtig

macheBitmapDurchsichtig

HC [image] Grafiken [image] Bitmaps [image] macheBitmapDurchsichtig
speichereBild BitmapSetzePunkt

macheBitmapDurchsichtig Bitmap Farbe
macheBitmapDurchsichtig Bitmap Farbe

Kommando, das den alpha Wert der Farbe "Farbe" in der Bitmap zu 0 setzt, so dass diese "Farbe" transparent sein wird bei "zeichneBitmap".

Beispiel:

b=ladeBild "iris.png
macheBitmapDurchsichtig b rgb 1 1 1
vorwärts 100
zeichneBitmap b

Examples:

  • zeichneBitmapSkaliertAuf
  • zeichneBitmapAuf

References:

    Release Notes für Version 4.65(2), zeichneBitmapAuf(2), zeichneBitmapSkaliertAuf

speichereBild BitmapSetzePunkt


HC / Grafiken / Bitmaps / BitmapSetzePunkt

BitmapSetzePunkt

HC [image] Grafiken [image] Bitmaps [image] BitmapSetzePunkt
macheBitmapDurchsichtig BitmapPunkt

BitmapSetzePunkt Bitmap X Y Farbe

setzt den Punkt an Position (x y) der Bitmap zu "Farbe". Für ein Beispiel siehe throwcoin.lg.

References:

    BitmapGrößeX, BitmapGrößeY

macheBitmapDurchsichtig BitmapPunkt


HC / Grafiken / Bitmaps / BitmapPunkt

BitmapPunkt

HC [image] Grafiken [image] Bitmaps [image] BitmapPunkt
BitmapSetzePunkt BitmapGrößeX

BitmapPunkt Bitmap X Y

Ausgabe ist die Farbe von Punkt (x y) der Bitmap. Für ein Beispiel siehe throwcoin.lg.

References:

    BitmapGrößeX, BitmapGrößeY, Release Notes für Version 4.683

BitmapSetzePunkt BitmapGrößeX


HC / Grafiken / Bitmaps / BitmapGrößeX

BitmapGrößeX

HC [image] Grafiken [image] Bitmaps [image] BitmapGrößeX
BitmapPunkt BitmapGrößeY

BitmapGrößeX Bitmap

Ausgabe ist die maximale X-Koordinate der "Bitmap" für Gebrauch mit den "BitmapSetzePunkt" und "BitmapPunkt" Funktionen.

Beispiel:

b=BitmapKopieren 100 100
wiederhole BitmapGrößeY b [
    BitmapSetzPunkt b  BitmapGrößeX b  repcount  "red
]
zeichneBitmap b

Examples:

  • zeichneBitmapSkaliertAuf
  • zeichneBitmapAuf
  • BitmapGrößeY
  • fülleBitmap

References:

    zeichneBitmapAuf(2), BitmapGrößeY, Release Notes für Version 4.685, fülleBitmap, zeichneBitmapSkaliertAuf

BitmapPunkt BitmapGrößeY


HC / Grafiken / Bitmaps / BitmapGrößeY

BitmapGrößeY

HC [image] Grafiken [image] Bitmaps [image] BitmapGrößeY
BitmapGrößeX fülleBitmap

BitmapGrößeY Bitmap

Ausgabe ist die maximale Y-Koordinate der "Bitmap" für Gebrauch mit den "BitmapSetzePunkt" und "BitmapPunkt" Funktionen.

Beispiel:

b=BitmapKopieren 100 100
wiederhole BitmapGrößeX b [
    BitmapSetzPunkt b  repcount  BitmapGrößeY b  "red
]
zeichneBitmap b

Examples:

  • zeichneBitmapSkaliertAuf
  • zeichneBitmapAuf
  • BitmapGrößeX
  • fülleBitmap

References:

    zeichneBitmapAuf(2), BitmapGrößeX, Release Notes für Version 4.685, fülleBitmap, zeichneBitmapSkaliertAuf

BitmapGrößeX fülleBitmap


HC / Grafiken / Bitmaps / fülleBitmap

fülleBitmap

HC [image] Grafiken [image] Bitmaps [image] fülleBitmap
BitmapGrößeY Direkte Grafik

fülleBitmap Bitmap x y

Kommando zum Füllen eines Bereiches in einer Bitmap mit "Füllfarbe", unter Verwendung der momentanen Stiftfarbe als Randfarbe. Der Vorteil gegenüber fülle ist seine Geschwindigkeit, weil aUCBLogo OpenGL nutzt und noch niemand eine Möglichkeit gefunden hat, wie man einen Zeiger auf den Grafikkarten-Speicher mit dem aktuellen OpenGL-Bild bekommt. Wenn jemand weiß, wie das geht, bitte teilen Sie Ihr Wissen mit dem aUCBLogo-Entwickler.

Beispiel:

zu bitfilltest
    löscheSchirm
    LinienglättungAus
    box
    StiftHoch setzeXY -100 -100
    bmp=BitmapKopieren 200 200
    BitmapFüllen bmp (BitmapGrößeX bmp)*0.6 (BitmapGrößeY bmp)*0.6
    Mitte
    setzeXY -100 -100
    zeichneBitmap bmp
    Mitte
    StiftAb
Ende

Example:

  • Versions-Informationen für Version 4.7

Reference:

    Versions-Informationen für Version 4.7

BitmapGrößeY Direkte Grafik


HC / Grafiken / Direkte Grafik

Direkte Grafik

HC [image] Grafiken [image] Direkte Grafik
fülleBitmap setzePunkt

Direkte Grafik

Dies sind Grundwörter für direkte Grafik, ohne einen Igel zu benutzen, was manchmal für Simulationen praktischer ist, da es auch schneller ist.

Auch hier sind Operationen dafür, mit Farben zu arbeiten.

Direkte Grafik

  • setzePunkt
  • setzePunktXY
  • setzePunktXYZ
  • Linie
  • RGB
  • RGBA
  • listeRGB
  • listeRGBA
  • TSH
  • TSHA
  • listeTSH
  • listeTSHA
  • addiereFarben
  • addiereFarbenRest
  • liesFarbDatenbank


HC / Grafiken / Direkte Grafik / setzePunkt

setzePunkt

HC [image] Grafiken [image] Direkte Grafik [image] setzePunkt
Direkte Grafik setzePunktXY

setzePunkt Koordinate Farbe
setzePunkt Koordinaten Farben

setzt die Bildpunkte bei den "Koordinate(n)" zu den entsprechenden "Farbe(n)". setzePunkt kann jetzt auch 3D Koordinaten als Argumente nehmen. Es ist auch möglich, reelleZahlen von Länge 3 für die Koordinaten zu benutzen.

Beispiele:

setzePunkt [10 10] 0
setzePunkt [[10 10][20 10]] 0
setzePunkt [[10 10][20 10]] [12 14]
perspektivisch
setzePunkt {[10 10 10][20 10 0]} {12 14}
setzePunkt reelleZahlen {100 2 0} 0

Example:

  • Punkt

References:

    Punkt, Release Notes für Version 4.64, Release Notes für Version 4.685, Release Notes für Version 4.686

Direkte Grafik setzePunktXY


HC / Grafiken / Direkte Grafik / setzePunktXY

setzePunktXY

HC [image] Grafiken [image] Direkte Grafik [image] setzePunktXY
setzePunkt setzePunktXYZ

setzePunktXY XKoors YKoors Farbe(n)

Für einfacheres und schnelleres Zeichnen wurde das neue Kommando geschrieben: Es nimmt strukturierte X-Daten und ebenso strukturierte Y Daten als gesonderte Argumente an. Es ist nicht wirklich vollständig und hat einige Fehler, um diese zu kompensieren, sollten Sie Ihre Strukturen zu Ganzzahlen oder Gleitkommazahlen umwandeln, wie im Beispiel. Der Typ reelleZahlen wird für XKoors und YKoors, zusammen mit Ganzzahlen als Farben erlaubt, so ist es schnell. Die YKoors können auch eine einzige Zahl sein, solange sein Typ eine Reihe ist, so können Sie Ihre Grafik Zeilenweise zeichnen.

Beispiele:

setzePunktXY ganzzahl [0 1 2 3 4] ganzzahl [100 98 96 94 92] 0
x=reelleZahlenFolge -20 20 400
y=x*x
c=mod (Ganzzahlen GanzzahlFolge 1 zähle x) 16
setzePunktXY x*20 y c
löscheSchirm
x=Reihe ZahlenFolge -20 20 400
y=x*x
c=mod (Reihe GanzzahlFolge 1 zähle x) 16
wiederhole 300 ~
[	setzePunktXY x*20 y*#/300 c
    c=rotiere c 1
]

Example:

  • setzePunktgröße

References:

    Release Notes für Version 4.685, Release Notes für Version 4.686, setzePunktgröße

setzePunkt setzePunktXYZ


HC / Grafiken / Direkte Grafik / setzePunktXYZ

setzePunktXYZ

HC [image] Grafiken [image] Direkte Grafik [image] setzePunktXYZ
setzePunktXY Linie

setzePunktXYZ XKoors YKoors ZKoors Farbe(n)

Für einfacheres und schnelleres Zeichnen wurde das neue Kommando geschrieben: Es nimmt strukturierte X-Daten und ebenso strukturierte Y- und Z-Daten als gesonderte Argumente an. Es ist nicht wirklich vollständig und hat einige Fehler, um diese zu kompensieren, sollten Sie Ihre Strukturen zu Ganzzahlen oder Gleitkommazahlen umwandeln, wie im Beispiel. Der Typ reelleZahlen wird für XKoors und YKoors, zusammen mit Ganzzahlen als Farben erlaubt, so ist es schnell. Die YKoors können auch eine einzige Zahl sein, solange sein Typ eine Reihe ist, so können Sie Ihre Grafik Zeilenweise zeichnen.

Beispiele:

löscheSchirm perspektivisch
x=ganzzahl [0 1 2 3 4]
y=ganzzahl [100 98 96 94 92]
z=ganzzahl [10 20 30 40 50]
setzePunktXYZ x y z 0
rotatescene

löscheSchirm
z=reelleZahlenFolge -100 100 5000
x=kosinus z/10*360
y=sinus z/10*360
c=mod (Ganzzahlen GanzzahlFolge 1 zähle x) 16
setzePunktXYZ x*z y*z z*5 c
rotatescene

löscheSchirm
z=Reihe ZahlenFolge -100 100 5000
x=kosinus z/10*360
y=sinus z/10*360
c=mod (Reihe GanzzahlFolge 1 zähle x) 16
wiederhole 10 ~
[	setzePunktXYZ x*z y*z z*z*#/10 c
    c=rotiere c 1
]
rotatescene

Examples:

  • setzeNebeldichte
  • setzeNebelModus

References:

    Release Notes für Version 4.689, setzeNebelModus, setzeNebeldichte

setzePunktXY Linie


HC / Grafiken / Direkte Grafik / Linie

Linie

HC [image] Grafiken [image] Direkte Grafik [image] Linie
setzePunktXYZ RGB

Linie Koordinaten Farbe(n)

Zieht Linien zwischen den Koordinaten in der jeweiligen Farbe. Die erstes Farbe in einer Liste oder Reihe von Farben wird ignoriert. Es gibt einen Fehler, wenn viele Farben verwendet werden und der Igel sichtbar ist, daher "versteckeIgel" vor "Linie".

Beispiele:

Linie [[0 0][100 0][100 100]] 0
versteckeIgel Linie [[0 0][100 0][100 100]] (liste rgb 1 0 0  rgb 0 1 0  rgb 0 0 1) zeigIgel

Examples:

  • Einzelschritt
  • schreibe
  • weiter
  • RGB
  • TSH

References:

    Tokenisierung(14), Release Notes für Version 4.64(4), Release Notes für Version 4.682(2), weiter(2), Absolute Igel-Bewegung, Abstand, AbstandXYZ, Einzelschritt, Grafiken, Mitte, RGB, Relative Igel-Bewegung, Release Notes für Version 4.68, Starten und Verlassen von Logo, TSH, TextControls, Vorlagen-basierte Iteration, _Makro, buglist für Version 4.65, größerGleichP, größerP, holeAuswahl, holeAuswahlZahl, holeAuswahlmöglichkeiten, holePasswortVomBenutzer, holeTextVomBenutzer, kleinerGleichP, kleinerP, schreibe, vorwärts, zurück

setzePunktXYZ RGB


HC / Grafiken / Direkte Grafik / RGB

RGB

HC [image] Grafiken [image] Direkte Grafik [image] RGB
Linie RGBA

RGB Rot Grün Blau

Ausgabe ist eine Ganzzahl-Farbe der Form Rot:8 Grün:8 Blau:8 Bits aus den drei Parametern zwischen 0 und 1. 1 wird in 255 umgesetzt.

Beispiel:

setzeStiftfarbe RGB 1 0 0  StiftAb  vorwärts 100	;draws a red linie

See also:

  • Release Notes für Version 4.64
  • holeFarbeVomBenutzer
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSpecularLicht
  • Farb-Datenbank
  • speichereBild
  • ladeBild

Examples:

  • setzeStatischerTextHintergrundfarbe
  • setzeTextboxHintergrundfarbe
  • setzeFensterHintergundfarbe
  • macheBitmapDurchsichtig
  • holeFarbeVomBenutzer
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSpecularLicht
  • öffneZumLesenBinär
  • addiereFarbenRest
  • Oberflächenspalte
  • Oberflächenstart
  • Oberflächenende
  • setzeStiftfarbe
  • setzeFüllfarbe
  • addiereFarben
  • fülleRechteck
  • fülleEllipse
  • fülleKreis
  • hilfesuche
  • Oberfläche
  • listeRGB
  • Linie
  • Punkt

References:

    Linie(3), setzeStiftfarbe(3), addiereFarben(2), addiereFarbenRest(2), holeFarbeVomBenutzer(2), reset(2), setzeDiffusesLicht(2), setzeSpecularLicht(2), setzeUmgebungslicht(2), Farb-Datenbank, Oberfläche, Oberflächenende, Oberflächenspalte, Oberflächenstart, Punkt, Release Notes für Version 4.64, fülleEllipse, fülleKreis, fülleRechteck, hilfesuche, ladeBild, listeRGB, loadpalette, macheBitmapDurchsichtig, setzeFensterHintergundfarbe, setzeFüllfarbe, setzeStatischerTextHintergrundfarbe, setzeTextboxHintergrundfarbe, speichereBild, öffneZumLesenBinär

Linie RGBA


HC / Grafiken / Direkte Grafik / RGBA

RGBA

HC [image] Grafiken [image] Direkte Grafik [image] RGBA
RGB listeRGB

RGBA Rot Grün Blau Alpha

Ausgabe ist eine Ganzzahl-Farbe der Form Rot:8 Grün:8 Blau:8 Alpha:8 Bits aus den vier Parametern zwischen 0 und 1. 1 wird in 255 umgesetzt. Beim Alpha-Kanal steht 0 für transparent, 1 für opak.

Beispiele:

hex RGBA 0.5 0.25 0 1		;FF003F7F  ;-)
löscheSchirm
wiederhole 200 ~
[	setzeStiftfarbe RGBA 0 0 0 repCount/200
    box
    rechts 30 vorwärts 1 links 30
]

See also:

  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSpecularLicht
  • Bitmaps

Examples:

  • addiereFarbenRest
  • zeichneBitmapAuf
  • setzeStiftfarbe
  • addiereFarben
  • listeRGBA

References:

    setzeStiftfarbe(5), Bitmaps, addiereFarben, addiereFarbenRest, listeRGBA, setzeDiffusesLicht, setzeSpecularLicht, setzeUmgebungslicht, zeichneBitmapAuf

RGB listeRGB


HC / Grafiken / Direkte Grafik / listeRGB

listeRGB

HC [image] Grafiken [image] Direkte Grafik [image] listeRGB
RGBA listeRGBA

listeRGB Farbe

Ausgabe ist eine Liste der drei Zahlen für Rot, Grün und Blau der Farbe "Farbe".

Beispiel:

listeRGB RGB 1 0 0		;[1 0 0] ;-)

Examples:

  • holeFarbeVomBenutzer
  • addiereFarben

References:

    addiereFarben(2), holeFarbeVomBenutzer(2), Release Notes für Version 4.64

RGBA listeRGBA


HC / Grafiken / Direkte Grafik / listeRGBA

listeRGBA

HC [image] Grafiken [image] Direkte Grafik [image] listeRGBA
listeRGB TSH

listeRGBA Farbe

Ausgabe ist eine Liste der vier Zahlen für Rot, Grün, Blau und Alpha der Farbe "Farbe".

Beispiel:

listeRGBA RGBA 1 0.5 0.2 0.1		;[1 0.498039 0.2 0.0980392] ;-)

Examples:

  • addiereFarbenRest
  • addiereFarben
  • Stiftfarbe
  • Punkt

References:

    addiereFarbenRest(3), Stiftfarbe(2), Punkt, Release Notes für Version 4.65, addiereFarben

listeRGB TSH


HC / Grafiken / Direkte Grafik / TSH

TSH

HC [image] Grafiken [image] Direkte Grafik [image] TSH
listeRGBA TSHA

TSH Ton Sättigung Helligkeit

Ausgabe ist eine Ganzzahl-Farbe des Formats Rot:8 Grün:8 Blau:8 Bit, von "Ton" zwischen 0 und 360 ("Ton"=0 ist rot, "Ton"=120 ist grün, "Ton"=240 ist blau), und Sättigung und Helligkeit zwischen 0 und 1.

Beispiel:

setzeStiftfarbe TSH 120 1 1  StiftAb  vorwärts 100	;draws a green linie

See also:

  • Release Notes für Version 4.64
  • setzeUmgebungslicht
  • setzeDiffusesLicht
  • setzeSpecularLicht
  • listeTSHA
  • listeTSH

Example:

  • listeTSH

References:

    listeTSH(3), Release Notes für Version 4.64, Release Notes für Version 4.69, listeTSHA, setzeDiffusesLicht, setzeSpecularLicht, setzeUmgebungslicht

listeRGBA TSHA


HC / Grafiken / Direkte Grafik / TSHA

TSHA

HC [image] Grafiken [image] Direkte Grafik [image] TSHA
TSH listeTSH

TSHA Ton Sättigung Helligkeit Alpha

Ausgabe ist eine Ganzzahl-Farbe des Formats Rot:8 Grün:8 Blau:8 Alpha:8 Bit, von "Ton" zwischen 0 und 360 ("Ton"=0 ist rot, "Ton"=120 ist grün, "Ton"=240 ist blau), und Sättigung, Helligkeit und Alpha zwischen 0 und 1.

Alpha wird für Transparenz benutzt - 0 ist transparent, 1 opak.

Beispiel:

löscheSchirm
wiederhole 200 [
    setzeStiftfarbe TSHA 360*repcount/200 1 1 1-repCount/200
    box
    rechts 30 vorwärts 1 links 30
]

Example:

  • listeTSHA

Reference:

    listeTSHA

TSH listeTSH


HC / Grafiken / Direkte Grafik / listeTSH

listeTSH

HC [image] Grafiken [image] Direkte Grafik [image] listeTSH
TSHA listeTSHA

listeTSH Farbe

Ausgabe ist eine Liste dreier Zahlen, Ton, Sättigung und Helligkeit, welche die Farbe im TSH Farbraum repräsentiert.

Sie können jetzt leicht die Farbdatenbank unter Benützung von "liesFarbDatenbank" lesen, alle Farben in TSH umwandeln, nach Ton sortieren und eine schöne HTML-Farbtabelle wie in colordb2html.lg. schreiben.

listeTSH rundet die Farbwerte nicht, aber es kann nur mit ganzzahligen Farben arbeiten, die 8 Bit pro Kanal benutzen. Wenn Sie mehr Genauigkeit benötigen, benutzen Sie die in testrgb2hsb.lg definierten Logo-Funktionen.

Beispiel:

zeige listeTSH TSH 83 0.9 0.75
;[83.0233 0.900524 0.74902]

Reference:

    Release Notes für Version 4.69

TSHA listeTSHA


HC / Grafiken / Direkte Grafik / listeTSHA

listeTSHA

HC [image] Grafiken [image] Direkte Grafik [image] listeTSHA
listeTSH addiereFarben

listeTSHA Farbe

Ausgabe ist eine Liste von vier Zahlen, Ton, Sättigung, Helligkeit und Alpha, die die Farbe im TSH Farbraum einschließlich eines Alpha-Kanals repräsentieren.

Beispiel:

zeige listeTSHA TSHA 83 0.9 0.75 0.666
;[83.0233 0.900524 0.74902 0.662745]

Reference:

    Release Notes für Version 4.69

listeTSH addiereFarben


HC / Grafiken / Direkte Grafik / addiereFarben

addiereFarben

HC [image] Grafiken [image] Direkte Grafik [image] addiereFarben
listeTSHA addiereFarbenRest

addiereFarben c1 c2

Ausgabe ist die Ergebnisfarbe, die aus den zwei Farben color1 und color2 besteht.

Die Farben werden Kanalweise (R,G,B,A) mit Sättigung wie in folgender Logoprozedur addiert, nur schneller:

zu addColors_ ca cb
    lokal [ra rb r g b]
    ra=listeRGB ca
    rb=listeRGB cb
    r=ra.1+rb.1 wenn r>1 [r=1]
    g=ra.2+rb.2 wenn g>1 [g=1]
    b=ra.3+rb.3 wenn b>1 [b=1]
    a=ra.4+rb.4 wenn a>1 [a=1]
    Ausgabe RGBA r g b a
Ende

listeRGBA addiereFarben RGB .8 0 1 RGB .3 .4 .5
;[1 0.4 1 1]

Reference:

    Release Notes für Version 4.64

listeTSHA addiereFarbenRest


HC / Grafiken / Direkte Grafik / addiereFarbenRest

addiereFarbenRest

HC [image] Grafiken [image] Direkte Grafik [image] addiereFarbenRest
addiereFarben liesFarbDatenbank

addiereFarbenRest c1 c2

Ausgabe ist die Ergebnisfarbe, die aus den zwei Farben color1 und color2 besteht.

Die Farben werden Kanalweise (R,G,B,A) addiert, während die Kanäle im erlaubten Bereich bleiben unter Benützung von Modulo, wie im folgenden Logoprozedur, nur schneller:

zu addColors_ ca cb
    lokal [ra rb r g b]
    ra=listeRGBA ca
    rb=listeRGBA cb
    r=mod ra.1+rb.1 1
    g=mod ra.2+rb.2 1
    b=mod ra.3+rb.3 1
    a=mod ra.4+rb.4 1
    Ausgabe RGBA r g b a
Ende

Beispiel:

listeRGBA addiereFarbenRest RGB .8 .9 1 RGB .3 .4 .5
;[0.0941176 0.294118 0.494118 1]

Reference:

    Release Notes für Version 4.686

addiereFarben liesFarbDatenbank


HC / Grafiken / Direkte Grafik / liesFarbDatenbank

liesFarbDatenbank

HC [image] Grafiken [image] Direkte Grafik [image] liesFarbDatenbank
addiereFarbenRest Projektions-Matrix

liesFarbDatenbank

Ausgabe ist eine Liste von Listen aus Farbname, rotem, grünen und blauem Wert aller verfügbaren benannten Farben in der Farbdatenbank.

References:

    Farb-Datenbank, listeTSH

addiereFarbenRest Projektions-Matrix


HC / Grafiken / Projektions-Matrix

Projektions-Matrix

HC [image] Grafiken [image] Projektions-Matrix
liesFarbDatenbank ModelviewMatrix

Projektions-Matrix

Funktionen für Arbeit mit der graphischen Projektionsmatrix. So können Sie eine spezifische Graphik an unterschiedlichen Positionen und Drehungen benutzen. Für ein Beispiel siehe spelltest.lg!

Projektions-Matrix

  • ModelviewMatrix
  • setzeMatrix
  • IgelMatrix
  • setzeIgelMatrix
  • stapleMatrix
  • holeMatrixVomStapel
  • IdentitätsMatrix
  • setzeIdentitätsmatrix


HC / Grafiken / Projektions-Matrix / ModelviewMatrix

ModelviewMatrix

HC [image] Grafiken [image] Projektions-Matrix [image] ModelviewMatrix
Projektions-Matrix setzeMatrix

ModelviewMatrix

Operation, die die gegenwärtige Projektionsmatrix für die Grafik ausgibt: Dies ist

(liste (liste basex_x basex_y basex_z)
    (liste basey_x basey_y basey_z)
    (liste basez_x basez_y basez_z)
    (liste center_x center_y center_z))

(die Basis-Vektoren und Zentrum sind interne Variablen, die nicht direkt für den Benutzer zugreifbar sind).

Beispiels:

setidm
löscheSchirm
ModelviewMatrix		;[[1 0 0][0 1 0][0 0 1][0 0 0]] ;-)
vorwärts 100
rechts 30
setM IgelMatrix
löscheSchirm
rbox
ModelviewMatrix
;[[0.866025 -0.5 0][0.5 0.866025 0][0 0 1][0 100 0]] ;-)


HC / Grafiken / Projektions-Matrix / setzeMatrix

setzeMatrix

HC [image] Grafiken [image] Projektions-Matrix [image] setzeMatrix
ModelviewMatrix IgelMatrix

setzeMatrix eineMatrix

Kommando, der die gegenwärtige OpenGL Modelview Matrix zu "eineMatrix" setzt.

Beispiel:

tree
Matrix		;[[1 0 0][0 1 0][0 0 1][0 0 0]] ;-)
setMatrix Matrix*0.5
tree


HC / Grafiken / Projektions-Matrix / IgelMatrix

IgelMatrix

HC [image] Grafiken [image] Projektions-Matrix [image] IgelMatrix
setzeMatrix setzeIgelMatrix

IgelMatrix

Operation, die die Matrix des Igels ausgibt, einsatzfertig zum Gebrauch mit setMatrix.

Beispiel:

setMatrix IgelMatrix

Example:

  • ModelviewMatrix

References:

    Release Notes für Version 4.64(2), ModelviewMatrix

setzeMatrix setzeIgelMatrix


HC / Grafiken / Projektions-Matrix / setzeIgelMatrix

setzeIgelMatrix

HC [image] Grafiken [image] Projektions-Matrix [image] setzeIgelMatrix
IgelMatrix stapleMatrix

setzeIgelMatrix setzeIgelMatrix

Kommando, das die Igel Matrix als die neue Modelview-Matrix setzt.

Sehen Sie auch das spelltest.lg Beispiel!

Beispiel:

rechts 30
vorwärts 100
setzeIgelMatrix
StiftHoch Mitte StiftAb

Examples:

  • holeMatrixVomStapel
  • stapleMatrix

References:

    Release Notes für Version 4.64(2), holeMatrixVomStapel, stapleMatrix

IgelMatrix stapleMatrix


HC / Grafiken / Projektions-Matrix / stapleMatrix

stapleMatrix

HC [image] Grafiken [image] Projektions-Matrix [image] stapleMatrix
setzeIgelMatrix holeMatrixVomStapel

stapleMatrix

Kommando, das die gegenwärtige Modelview Matrix auf den Matrixstapel von OpenGL legt.

Beispiel:

rechts 30
vorwärts 100
staplematrix
setzeIgelMatrix
holematrixvomstapel

Example:

  • holeMatrixVomStapel

Reference:

    holeMatrixVomStapel

setzeIgelMatrix holeMatrixVomStapel


HC / Grafiken / Projektions-Matrix / holeMatrixVomStapel

holeMatrixVomStapel

HC [image] Grafiken [image] Projektions-Matrix [image] holeMatrixVomStapel
stapleMatrix IdentitätsMatrix

holeMatrixVomStapel

Kommando, das die letzte auf den Stapel gelegte Modelview Matrix vom OpenGL Matrixstapel holt.

Beispiel:

rechts 30
vorwärts 100
staplematrix
setzeIgelMatrix
holematrixvomstapel

Example:

  • stapleMatrix

Reference:

    stapleMatrix

stapleMatrix IdentitätsMatrix


HC / Grafiken / Projektions-Matrix / IdentitätsMatrix

IdentitätsMatrix

HC [image] Grafiken [image] Projektions-Matrix [image] IdentitätsMatrix
holeMatrixVomStapel setzeIdentitätsmatrix

IdentitätsMatrix IDM

Operation, die die Identitätsmatrix ausgibt.

Beispiel:

setMatrix IDM

Reference:

    Release Notes für Version 4.64

holeMatrixVomStapel setzeIdentitätsmatrix


HC / Grafiken / Projektions-Matrix / setzeIdentitätsmatrix

setzeIdentitätsmatrix

HC [image] Grafiken [image] Projektions-Matrix [image] setzeIdentitätsmatrix
IdentitätsMatrix Texturierung

setzeIdentitätsmatrix setIDM

Kommando, der die Projektionsmatrix zur Identität setzt.

Reference:

    Release Notes für Version 4.64

IdentitätsMatrix Texturierung


HC / Grafiken / Texturierung

Texturierung

HC [image] Grafiken [image] Texturierung
setzeIdentitätsmatrix Textur

Texturierung

...ist ein cooles Merkmal von OpenGL, um gefüllte Formen mit einer Bitmap zu dekorieren.

Texturierung

  • Textur
  • setzeTexturXY
  • setzeTexturort
  • TexturenAn
  • TexturenAus
  • löscheTexturen

References:

    TexturenAn, TexturenAus

setzeIdentitätsmatrix Textur


HC / Grafiken / Texturierung / Textur

Textur

HC [image] Grafiken [image] Texturierung [image] Textur
Texturierung setzeTexturXY

texhandle Textur Bitmap
Textur TexHandle
Textur []

Kommando oder Operation, je nach Argument.

setzt die momantane "Textur" zur "Bitmap", wenn das Argument eine Bitmap ist, und gibt eine TexHandle Ganzzahl aus, von durch die die Textur schneller ausgewählt werden kann.

Wenn ein TexHandle (eine ganzzahlige Ausgabe von einem früheren Aufruf von Textur), wird die jeweilige Textur ausgewählt.

Texturen werden nur angewandt, wenn TexturenAn einmal aufgerufen wird.

Beispiel:

b=ladeBild "iris.png
texhandle=Textur b
TexturenAn
setzeStiftfarbe 4
(tcube 400)
löscheSchirm
TexturenAn
Textur []
Textur texhandle
(tcube 400)

Examples:

  • setzeTesselationRegeln
  • setzeTexturXY
  • TexturenAn

References:

    setzeTexturXY(4), setzeTexturort(3), Release Notes für Version 4.685(2), TexturenAn(2), löscheTexturen(2), Release Notes für Version 4.65, Release Notes für Version 4.683, TexturenAus, setzeTesselationRegeln

Texturierung setzeTexturXY


HC / Grafiken / Texturierung / setzeTexturXY

setzeTexturXY

HC [image] Grafiken [image] Texturierung [image] setzeTexturXY
Textur setzeTexturort

setzeTexturXY x y

Kommando, das die OpenGL Textur-Koordinaten auf (x,y) setzt. x und y sollten im Bereich von 0..1 sein, wenn Sie keine Wiederholung der Textur zeigen wollen. Wenn die Werte größer sind, wird die Textur wiederholt.

Dieses Grundwort ist nützlich mit Vieleck, Tesselation und Oberfläche.

Beispiel:

TexturenAn
bricks=ladeBild "bricks.png
tex=textur bricks
setzeStiftfarbe "white
Vieleck [
    setzeTexturXY 0 1 vorwärts 100 rechts 90
    setzeTexturXY 1 1 vorwärts 100 rechts 90
    setzeTexturXY 1 0 vorwärts 100 rechts 90
    setzeTexturXY 0 0 vorwärts 100 rechts 90
]

Example:

  • setzeTesselationRegeln

Reference:

    setzeTesselationRegeln(5)

Textur setzeTexturort


HC / Grafiken / Texturierung / setzeTexturort

setzeTexturort

HC [image] Grafiken [image] Texturierung [image] setzeTexturort
setzeTexturXY TexturenAn

setzeTexturort xylist

setzt, zu denen das OpenGL textur koordiniert, [x y]. x und y sollten sein in der Bereich von 0..1 dafür, nur ein Vorkommen der Textur zu zeigen. Wenn die Werte großartiger sind, wird das textur wiederholt.

Dieses Primitiv ist nützlich mit PolyStart..PolyEnd und TessStart..TessEnd.

Beispiele:

setzeTexturort [0.2 0.9]
x=0.2 y=0.9
setzeTexturort liste x y


HC / Grafiken / Texturierung / TexturenAn

TexturenAn

HC [image] Grafiken [image] Texturierung [image] TexturenAn
setzeTexturort TexturenAus

TexturenAn TexturenAn

ermöglicht die Texturierung von mehreckigen Flächen.

Siehe auch: Textur.

Beispiel:

TexturenAn
bricks=ladeBild "bricks.png
tex=textur bricks
setzeFüllfarbe "white
fülleRechteck [-100 -100][100 100]

Examples:

  • setzeTesselationRegeln
  • setzeTexturXY
  • Textur

References:

    Textur(3), setzeTesselationRegeln, setzeTexturXY

setzeTexturort TexturenAus


HC / Grafiken / Texturierung / TexturenAus

TexturenAus

HC [image] Grafiken [image] Texturierung [image] TexturenAus
TexturenAn löscheTexturen

TexturenAus TexturenAus

schaltet die Texturierung von vieleckigen Flächen aus.

Siehe auch: Textur.


HC / Grafiken / Texturierung / löscheTexturen

löscheTexturen

HC [image] Grafiken [image] Texturierung [image] löscheTexturen
TexturenAus Schatten

löscheTexturen

Kommando, das zu einer möglichen Reinigung von Textur Speicher dient, so kann ein Textur-Speicherüberlauf verhindert werden, wenn Sie viele Texturen schaffen, die Sie vielleicht nur einmal oder ein paar Male benutzen, nach denen sie veraltet sind.

Ein gutes Beispiel für diesen Befehl ist candle.lg.

Reference:

    Release Notes für Version 4.685

TexturenAus Schatten


HC / Grafiken / Schatten

Schatten

HC [image] Grafiken [image] Schatten
löscheTexturen SchattenAn

Schatten

Schattenwurf ist ein schwierig zu bewerkstelligendes Feature, aber es ist jetzt verfügbar in aUCBLogo-4.69. Es hat noch einige Fehler, die Sie als graphisches Rauschen oder Artefakte sehen können. Ich weiß bis jetzt nicht, wie man dieses Rauschen vollkommen entfernen kann. Auch Zylinderlinien werfen noch keine Schatten. Aber Sie können Oberfläche, Vieleck, Tesselation, Kugel und EllipsoidenTeil benutzen, die Schatten werfen werden.

Schatten

  • SchattenAn
  • SchattenAus
  • wirfSchatten
  • löscheSchatten
  • setzeSchattenfarbe
  • Schattenfarbe

Example:

  • Versions-Informationen für Version 4.7

References:

    Release Notes für Version 4.69(3), SchattenAn(3), wirfSchatten(2), SchattenAus, Schattenfarbe, Versions-Informationen für Version 4.7, löscheSchatten, setzeSchattenfarbe

löscheTexturen SchattenAn


HC / Grafiken / Schatten / SchattenAn

SchattenAn

HC [image] Grafiken [image] Schatten [image] SchattenAn
Schatten SchattenAus

SchattenAn

Kommando, das den internen Zustand setzt, um Schatten-Erzeugung zu ermöglichen. Es muss gesetzt werden, bevor Sie Grafik zeichnen, wenn Sie irgendwelche Schatten sehen wollen.

Zusätzlich müssen Sie entweder das Grundwort wirfSchatten aufrufen, vielleicht von "erneuereGraph" gefolgt, oder "zeichneNochmal", um die Schatten zu erzeugen.

Beispiel:

löscheSchirm perspektivisch fenstermodus
SchattenAn
Kugel 100
setzeStiftfarbe "green
zurück 1000 kugel 800
wirfSchatten

Examples:

  • setzeSchattenfarbe
  • wirfSchatten

References:

    wirfSchatten(2), Release Notes für Version 4.69, setzeSchattenfarbe

Schatten SchattenAus


HC / Grafiken / Schatten / SchattenAus

SchattenAus

HC [image] Grafiken [image] Schatten [image] SchattenAus
SchattenAn wirfSchatten

SchattenAus

Kommando, das den internen Zustand zurücksetzt, um Schatten-Erzeugung auszuschalten.


HC / Grafiken / Schatten / wirfSchatten

wirfSchatten

HC [image] Grafiken [image] Schatten [image] wirfSchatten
SchattenAus löscheSchatten

wirfSchatten

Kommando, das die Schatten zeichnet, die von Oberfläche, Vieleck, Tesselation, Kugel und EllipsoidenTeil konstruiert worden sind, nach einem Aufruf von "SchattenAn".

Wenn Sie den Schatten einer spezifischen Oberfläche nicht sehen können, ist es wahrscheinlich, dass Sie sie mit dem entgegengesetzten Normalen-Vektor zeichnen müssen. Dies ist leicht durch umgekehrte Zeichnungs-Reihenfolge zu erfüllen, so wenn Sie rechts benutzt hatten, verwenden Sie links statt dessen, dann sollte es funktionieren.

Beispiel:

perspektivisch löscheSchirm löscheschatten
SchattenAn
setzeStiftfarbe "blue
pcube
zurück 1000
setzeStiftfarbe "green
kugel 900
wirfschatten
rotatescene

Examples:

  • setzeSchattenfarbe
  • SchattenAn

References:

    Release Notes für Version 4.69(2), SchattenAn(2), setzeSchattenfarbe

SchattenAus löscheSchatten


HC / Grafiken / Schatten / löscheSchatten

löscheSchatten

HC [image] Grafiken [image] Schatten [image] löscheSchatten
wirfSchatten setzeSchattenfarbe

löscheSchatten

Kommando, um den Schattenobjektepuffer zu löschen. Dies kann notwendig sein, wenn Sie etwas vollkommen anderes zeichnen wollen, in einer neuen Szene. In löscheSchirm werden die Schatten-Objekte nicht gelöscht, weil es nötig sein kann, mit "zeichneNochmal" die Szene noch eimal von einem unterschiedlichen Ansichtspunkt aus zeichnen zu können, und das ist viel schneller als die ganze Szene neu zu erstellen.

Examples:

  • setzeSchattenfarbe
  • wirfSchatten

References:

    Release Notes für Version 4.69, setzeSchattenfarbe, wirfSchatten

wirfSchatten setzeSchattenfarbe


HC / Grafiken / Schatten / setzeSchattenfarbe

setzeSchattenfarbe

HC [image] Grafiken [image] Schatten [image] setzeSchattenfarbe
löscheSchatten Schattenfarbe

setzeSchattenfarbe Farbe

Kommando, um die Farbe von künftigen Schatten zu "Farbe" zu setzen. Sie können alle Farbformate benutzen, die setzeStiftfarbe unterstützt.

Beispiel:

perspektivisch löscheSchirm löscheschatten
SchattenAn
setzeStiftfarbe "blue
pcube
zurück 1000
setzeStiftfarbe "green
kugel 900
setzeSchattenfarbe "red
wirfschatten
rotatescene

Reference:

    Release Notes für Version 4.69

löscheSchatten Schattenfarbe


HC / Grafiken / Schatten / Schattenfarbe

Schattenfarbe

HC [image] Grafiken [image] Schatten [image] Schattenfarbe
setzeSchattenfarbe GUI Programmierung

Schattenfarbe

Ausgabe ist die gegenwärtig ausgewählte Farbe für die nächsten Schatten, die Sie mit castShadows zeichnen.


HC / GUI Programmierung

GUI Programmierung

HC [image] GUI Programmierung
Schattenfarbe Standart-Ereignis-Behandler

GUI Programmierung

GUI bedeutet Graphische Anwenderschnittstelle, das ist etwas, welche Fenster, X11, oder GTK realisiert. Unter GUI Programmieren sind Gewohnheits-Ereignis-Führer, Standardmäßige Dialoge, Windows (=Frames), Diagramme (=Logo-Zeichnungsflächen), Sizers Und Controls.

Controls sind etwas Fenster, die etwas Inhalt, Zahl, wörtliche Oder Liste Werte zeigen, vielleicht editierbares oder readonly, oder clickable.

Wie startet man? Es ist am besten, an zu lesen. Die Registerseite jeden der Folgendenunterkapitel hilft Sie gestartet machend, und, auf das sie zumeist zu einem Demo-Logo-Programm, d. h. buttontest.lg oder frametest.lg. richten

GUI Programmierung

  • Standart-Ereignis-Behandler
  • Fenster-Stile
  • Rahmen
  • Diagramme
  • Rahmen-Fenster
  • Knöpfe
  • CheckBoxen
  • ChoiceBoxes
  • KombiBoxen
  • Zahlboxen
  • Balken-Anzeigen
  • GanzzahlBoxen
  • Listenboxen
  • ListControls
  • RadioButtons
  • Schiebe-Regler
  • StaticTexts
  • TextControls
  • ToggleButtons
  • Verschiedene GUI Elemente


HC / GUI Programmierung / Standart-Ereignis-Behandler

Standart-Ereignis-Behandler

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler
GUI Programmierung beiZeichen

Standart-Ereignis-Behandler

...sind "kurz" Logo-Routinen, die ausgeführt werden wenn ein spezifisches Ereignis erhöht wird, d. h. ein Tastendruck-Oder ein Mausklick.

"kurz" Mittel hier kurz in zur Anzahl von Ereignissen pro Sekunde relativem Ausführungs-Zeit. Wenn es viele Ereignisse in einer Sekunde gibt, es mit Mausereignissen sein kann, Ihr Gewohnheitsereignisführer dann nicht sperren sollte, und mindestens sollte es bei einigen zeit aufhören, sollte es aufhören.

Wenn es gibt erzeugten mehr Ereignisse als bearbeitet werden könnte, schließlich ein verhängnisvoller Stapelüberlauf wirst Occure Und Logo wird abstürzen.

Für die Konsole sind die folgenden Tastatur-Und Mausführer:

beiZeichen beiGedrückterTaste beiLosgelassenerTaste Tastenwert beiLinksGeklickterTextmaus beiRechtsGeklickterTextmaus beiMitteGeklickterTextmaus beiTextMausLinksLosgelassen beiTextMausRechtsLosgelassen beiTextMausMitteLosgelassen beiLinksDoppeltGeklickterTextmaus beiRechtsDoppeltgeklickterTextmaus beiMitteDoppeltgeklickterTextmaus beiTextMausbewegung

Für das Hauptdiagramm sind Fenster jene Mausführer:

beiLinksGeklickterMaus beiRechtsGeklickterMaus beiMitteGeklickterMaus beiLinksLosgelasserMaus beiRechtsLosgelasserMaus beiMitteLosgelasserMaus beiLinksDoppeltgeklickerMaus beiRechtsDoppeltgeklickerMaus beiMitteDoppeltgeklickerMaus beiMausBewegung

Die Ereignisroutine werden im Beispiel eventtest.lg. vorgestellt

Standart-Ereignis-Behandler

  • beiZeichen
  • beiGedrückterTaste
  • beiLosgelassenerTaste
  • Tastenwert
  • beiLinksGeklickterTextmaus
  • beiRechtsGeklickterTextmaus
  • beiMitteGeklickterTextmaus
  • beiTextMausLinksLosgelassen
  • beiTextMausRechtsLosgelassen
  • beiTextMausMitteLosgelassen
  • beiLinksDoppeltGeklickterTextmaus
  • beiRechtsDoppeltgeklickterTextmaus
  • beiMitteDoppeltgeklickterTextmaus
  • beiTextMausbewegung
  • beiRechtsGeklickterMaus
  • beiMitteGeklickterMaus
  • beiLinksLosgelasserMaus
  • beiRechtsLosgelasserMaus
  • beiMitteLosgelasserMaus
  • beiLinksDoppeltgeklickerMaus
  • beiRechtsDoppeltgeklickerMaus
  • beiMitteDoppeltgeklickerMaus
  • beiMausBewegung
  • VerzeichnisAuswahl
  • DateiAuswahl
  • holeFarbeVomBenutzer
  • holeSchriftVomBenutzer
  • holeAuswahlmöglichkeiten
  • holeZahlVomBenutzer
  • holePasswortVomBenutzer
  • holeTextVomBenutzer
  • holeAuswahl
  • holeAuswahlZahl
  • Meldungsbox


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiZeichen

beiZeichen

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiZeichen
Standart-Ereignis-Behandler beiGedrückterTaste

beiZeichen Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Zeichen Ereignis der Konsole. Ein Zeichen Ereignis wird erzeugt, wenn ein Taste gedrücktes länger runter gehaltenes oder ist.

Beispiel:

beiZeichen [schreibe Tastenwert]	;press Ctrl-Break to stop

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler, beiFensterZeichen, beiKombiBoxZeichen, beiListenboxZeichen, beiTextboxZeichen, beiZeichenInAuswahlbox, beiZeichenInListenControl

Standart-Ereignis-Behandler beiGedrückterTaste


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiGedrückterTaste

beiGedrückterTaste

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiGedrückterTaste
beiZeichen beiLosgelassenerTaste

beiGedrückterTaste Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Tasten-Runter Ereignis der Konsole. Ein Tasten-Runter Ereignis wird erzeugt, wenn ein Taste gedrücktes länger runter gehaltenes oder ist.

Beispiel:

beiGedrückterTaste [schreibe Tastenwert]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler, beiGedrückterTasteInAuswahlbox, beiGedrückterTasteInFenster, beiGedrückterTasteInKombiBox, beiGedrückterTasteInListenControl, beiGedrückterTasteInListenbox, beiGedrückterTasteInTextbox

beiZeichen beiLosgelassenerTaste


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiLosgelassenerTaste

beiLosgelassenerTaste

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiLosgelassenerTaste
beiGedrückterTaste Tastenwert

beiLosgelassenerTaste Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Tasten-Rauf Ereignis der Konsole. Ein Tasten-Rauf Ereignis wird erzeugt, wenn ein Taste aus dem gedrückten Zustand ausgelöst wird.

Beispiel:

beiLosgelassenerTaste [schreibe Tastenwert]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInFenster, beiLosgelassenerTasteInKombiBox, beiLosgelassenerTasteInListenControl, beiLosgelassenerTasteInListenbox, beiLosgelassenerTasteInTextbox, beiTextboxEingabe, beiTextboxÄnderung

beiGedrückterTaste Tastenwert


HC / GUI Programmierung / Standart-Ereignis-Behandler / Tastenwert

Tastenwert

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] Tastenwert
beiLosgelassenerTaste beiLinksGeklickterTextmaus

Tastenwert

Rückkehr die Schlüsselanzahl vom spätesten bearbeiteten Schlüsselereignis, dies ist ein Zeichen Ereignis, Tasten-Runter Ereignis-Oder Tasten-Rauf Ereignis, ganze gerade das Konsolfenster.

Die keycodes sind für normale Tasten ihre ASCII-Werte, und für besondere Tasten entsprechen sie den folgenden Konstanten:

WXK_BACK
WXK_TAB
WXK_RETURN
WXK_ESCAPE
WXK_SPACE
WXK_DELETE

WXK_START
WXK_LBUTTON
WXK_RBUTTON
WXK_CANCEL
WXK_MBUTTON
WXK_CLEAR
WXK_SHIFT
WXK_CONTROL
WXK_MENU
WXK_PAUSE
WXK_CAPITAL
WXK_PRIOR
WXK_NEXT
WXK_END
WXK_HOME
WXK_LEFT
WXK_UP
WXK_RIGHT
WXK_DOWN
WXK_SELECT
WXK_PRINT
WXK_EXECUTE
WXK_SNAPSHOT
WXK_INSERT
WXK_HELP
WXK_NUMPAD0
WXK_NUMPAD1
WXK_NUMPAD2
WXK_NUMPAD3
WXK_NUMPAD4
WXK_NUMPAD5
WXK_NUMPAD6
WXK_NUMPAD7
WXK_NUMPAD8
WXK_NUMPAD9
WXK_MULTIPLY
WXK_ADD
WXK_SEPARATOR
WXK_SUBTRACT
WXK_DECIMAL
WXK_DIVIDE
WXK_F1
WXK_F2
WXK_F3
WXK_F4
WXK_F5
WXK_F6
WXK_F7
WXK_F8
WXK_F9
WXK_F10
WXK_F11
WXK_F12
WXK_F13
WXK_F14
WXK_F15
WXK_F16
WXK_F17
WXK_F18
WXK_F19
WXK_F20
WXK_F21
WXK_F22
WXK_F23
WXK_F24
WXK_NUMLOCK
WXK_SCROLL
WXK_PAGEUP
WXK_PAGEDOWN

WXK_NUMPAD_SPACE
WXK_NUMPAD_TAB
WXK_NUMPAD_ENTER
WXK_NUMPAD_F1
WXK_NUMPAD_F2
WXK_NUMPAD_F3
WXK_NUMPAD_F4
WXK_NUMPAD_HOME
WXK_NUMPAD_LEFT
WXK_NUMPAD_UP
WXK_NUMPAD_RIGHT
WXK_NUMPAD_DOWN
WXK_NUMPAD_PRIOR
WXK_NUMPAD_PAGEUP
WXK_NUMPAD_NEXT
WXK_NUMPAD_PAGEDOWN
WXK_NUMPAD_END
WXK_NUMPAD_BEGIN
WXK_NUMPAD_INSERT
WXK_NUMPAD_DELETE
WXK_NUMPAD_EQUAL
WXK_NUMPAD_MULTIPLY
WXK_NUMPAD_ADD
WXK_NUMPAD_SEPARATOR
WXK_NUMPAD_SUBTRACT
WXK_NUMPAD_DECIMAL
WXK_NUMPAD_DIVIDE

The following key codes are only generated under Windows currently:

WXK_WINDOWS_LEFT
WXK_WINDOWS_RIGHT
WXK_WINDOWS_MENU
WXK_COMMAND

Examples:

  • beiLosgelassenerTasteInListenControl
  • beiGedrückterTasteInListenControl
  • beiLosgelassenerTasteInAuswahlbox
  • beiLosgelassenerTasteInListenbox
  • beiLosgelassenerTasteInKombiBox
  • beiGedrückterTasteInAuswahlbox
  • beiLosgelassenerTasteInFenster
  • beiLosgelassenerTasteInTextbox
  • beiGedrückterTasteInListenbox
  • beiGedrückterTasteInKombiBox
  • beiLosgelassenerTasteInGraph
  • beiGedrückterTasteInFenster
  • beiGedrückterTasteInTextbox
  • beiGedrückterTasteInGraph
  • beiZeichenInListenControl
  • beiZeichenInAuswahlbox
  • beiLosgelassenerTaste
  • beiListenboxZeichen
  • beiGedrückterTaste
  • beiKombiBoxZeichen
  • beiTextboxÄnderung
  • beiFensterZeichen
  • beiTextboxEingabe
  • beiTextboxZeichen
  • beiGraphZeichen
  • beiZeichen

References:

    Release Notes für Version 4.685(2), Standart-Ereignis-Behandler, beiFensterZeichen, beiGedrückterTaste, beiGedrückterTasteInAuswahlbox, beiGedrückterTasteInFenster, beiGedrückterTasteInGraph, beiGedrückterTasteInKombiBox, beiGedrückterTasteInListenControl, beiGedrückterTasteInListenbox, beiGedrückterTasteInTextbox, beiGraphZeichen, beiKombiBoxZeichen, beiListenboxZeichen, beiLosgelassenerTaste, beiLosgelassenerTasteInAuswahlbox, beiLosgelassenerTasteInFenster, beiLosgelassenerTasteInGraph, beiLosgelassenerTasteInKombiBox, beiLosgelassenerTasteInListenControl, beiLosgelassenerTasteInListenbox, beiLosgelassenerTasteInTextbox, beiTextboxEingabe, beiTextboxZeichen, beiTextboxÄnderung, beiZeichen, beiZeichenInAuswahlbox, beiZeichenInListenControl

beiLosgelassenerTaste beiLinksGeklickterTextmaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiLinksGeklickterTextmaus

beiLinksGeklickterTextmaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiLinksGeklickterTextmaus
Tastenwert beiRechtsGeklickterTextmaus

beiLinksGeklickterTextmaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Link-Knopf Runter Ereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiLinksGeklickterTextMaus [
    löscheSchirm versteckeIgel
    setzeKurs 90
    IgelText WortUnterCursor
    erneuereGraph]

Examples:

  • beiRechtsDoppeltgeklickterTextmaus
  • beiRechtsGeklickterTextmaus

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler, beiRechtsDoppeltgeklickterTextmaus, beiRechtsGeklickterTextmaus

Tastenwert beiRechtsGeklickterTextmaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiRechtsGeklickterTextmaus

beiRechtsGeklickterTextmaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiRechtsGeklickterTextmaus
beiLinksGeklickterTextmaus beiMitteGeklickterTextmaus

beiRechtsGeklickterTextmaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig Knopf Runter Ereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiRechtsGeklickterTextMaus [
    TextMausEreignisseAus	;neccessary to prevent popup menu
    löscheSchirm versteckeIgel
    setzeKurs 90
    IgelText WortUnterCursor
    erneuereGraph]
beiLinksGeklickterTextMaus [
    textmausereignissean
    setzeCursor TextMausOrt]

Example:

  • beiRechtsDoppeltgeklickterTextmaus

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler, beiRechtsDoppeltgeklickterTextmaus

beiLinksGeklickterTextmaus beiMitteGeklickterTextmaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiMitteGeklickterTextmaus

beiMitteGeklickterTextmaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiMitteGeklickterTextmaus
beiRechtsGeklickterTextmaus beiTextMausLinksLosgelassen

beiMitteGeklickterTextmaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Mittel-Knopf Runter Ereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiMitteGeklickterTextMaus [
    löscheSchirm versteckeIgel
    setzeKurs 90
    IgelText WortUnterCursor
    erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiRechtsGeklickterTextmaus beiTextMausLinksLosgelassen


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiTextMausLinksLosgelassen

beiTextMausLinksLosgelassen

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiTextMausLinksLosgelassen
beiMitteGeklickterTextmaus beiTextMausRechtsLosgelassen

beiTextMausLinksLosgelassen Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mauslink-Knopf Rauf (=release) Ereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiTextMausLinksLosgelassen [
    löscheSchirm versteckeIgel
    setzeKurs 90
    IgelText TextMausOrt
    erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiMitteGeklickterTextmaus beiTextMausRechtsLosgelassen


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiTextMausRechtsLosgelassen

beiTextMausRechtsLosgelassen

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiTextMausRechtsLosgelassen
beiTextMausLinksLosgelassen beiTextMausMitteLosgelassen

beiTextMausRechtsLosgelassen Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig knopf rauf (=release) Ereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiTextMausRechtsLosgelassen [
    löscheSchirm versteckeIgel
    setzeKurs 90
    IgelText TextMausOrt
    erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiTextMausLinksLosgelassen beiTextMausMitteLosgelassen


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiTextMausMitteLosgelassen

beiTextMausMitteLosgelassen

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiTextMausMitteLosgelassen
beiTextMausRechtsLosgelassen beiLinksDoppeltGeklickterTextmaus

beiTextMausMitteLosgelassen Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mausmittel-Knopf Rauf (=release) Ereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiTextMausMitteLosgelassen [
    löscheSchirm versteckeIgel
    setzeKurs 90
    IgelText TextMausOrt
    erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiTextMausRechtsLosgelassen beiLinksDoppeltGeklickterTextmaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiLinksDoppeltGeklickterTextmaus

beiLinksDoppeltGeklickterTextmaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiLinksDoppeltGeklickterTextmaus
beiTextMausMitteLosgelassen beiRechtsDoppeltgeklickterTextmaus

beiLinksDoppeltGeklickterTextmaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Link-Knopf Doppelt-Klick-Ereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiLinksDoppeltgeklickterTextMaus [
    setzeXY
        10*erstes TextMausOrt
        -20*erstes ohneErstes TextMausOrt
    erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiTextMausMitteLosgelassen beiRechtsDoppeltgeklickterTextmaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiRechtsDoppeltgeklickterTextmaus

beiRechtsDoppeltgeklickterTextmaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiRechtsDoppeltgeklickterTextmaus
beiLinksDoppeltGeklickterTextmaus beiMitteDoppeltgeklickterTextmaus

beiRechtsDoppeltgeklickterTextmaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig Knopf Doppeltklickereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiRechtsGeklickterTextMaus [
    TextMausEreignisseAus]	;neccessary to prevent popup menu
beiRechtsDoppeltgeklickterTextMaus [
    setzeXY
        10*erstes TextMausOrt
        -20*erstes ohneErstes TextMausOrt
    erneuereGraph]
beiLinksGeklickterTextMaus [
    textmausereignissean
    setzeCursor TextMausOrt]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiLinksDoppeltGeklickterTextmaus beiMitteDoppeltgeklickterTextmaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiMitteDoppeltgeklickterTextmaus

beiMitteDoppeltgeklickterTextmaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiMitteDoppeltgeklickterTextmaus
beiRechtsDoppeltgeklickterTextmaus beiTextMausbewegung

beiMitteDoppeltgeklickterTextmaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Mitten-Knopf Doppeltklickereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiMitteDoppeltgeklickterTextMaus [
    setzeXY
        10*erstes TextMausOrt
        -20*erstes ohneErstes TextMausOrt
    erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiRechtsDoppeltgeklickterTextmaus beiTextMausbewegung


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiTextMausbewegung

beiTextMausbewegung

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiTextMausbewegung
beiMitteDoppeltgeklickterTextmaus beiRechtsGeklickterMaus

beiTextMausbewegung Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mausbewegungsereignis der Konsole. Diese Weise ermöglicht es Gewohnheitsmausverhalten der Konsole.

Beispiel:

beiTextMausbewegung [
    wennsonst Maustasten != 0 [StiftAb][StiftHoch]
    setzeXY
        10*erstes TextMausOrt
        -20*erstes ohneErstes TextMausOrt
    erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiMitteDoppeltgeklickterTextmaus beiRechtsGeklickterMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiRechtsGeklickterMaus

beiRechtsGeklickterMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiRechtsGeklickterMaus
beiTextMausbewegung beiMitteGeklickterMaus

beiRechtsGeklickterMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig Knopf Runter Ereignis des Hauptdiagrammfensters.

Beispiel:

beiRechtsGeklickterMaus [setzeOrtXYZ Mausort  fülle  erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiTextMausbewegung beiMitteGeklickterMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiMitteGeklickterMaus

beiMitteGeklickterMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiMitteGeklickterMaus
beiRechtsGeklickterMaus beiLinksLosgelasserMaus

beiMitteGeklickterMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Mittel-Knopf Runter Ereignis des Hauptdiagrammfensters.

Beispiel:

beiMitteGeklickterMaus [schreibe Mausort]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiRechtsGeklickterMaus beiLinksLosgelasserMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiLinksLosgelasserMaus

beiLinksLosgelasserMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiLinksLosgelasserMaus
beiMitteGeklickterMaus beiRechtsLosgelasserMaus

beiLinksLosgelasserMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mauslink-Knopf Rauf (=release) Ereignis des Hauptdiagrammfensters.

Beispiel:

beiMausLinksLosgelassen [schreibe [rauf!]]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiMitteGeklickterMaus beiRechtsLosgelasserMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiRechtsLosgelasserMaus

beiRechtsLosgelasserMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiRechtsLosgelasserMaus
beiLinksLosgelasserMaus beiMitteLosgelasserMaus

beiRechtsLosgelasserMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig knopf rauf (=release) Ereignis des Hauptdiagrammfensters.

Beispiel:

beiMausRechtsLosgelassen [schreibe [rauf!]]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiLinksLosgelasserMaus beiMitteLosgelasserMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiMitteLosgelasserMaus

beiMitteLosgelasserMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiMitteLosgelasserMaus
beiRechtsLosgelasserMaus beiLinksDoppeltgeklickerMaus

beiMitteLosgelasserMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mausmittel-Knopf Rauf (=release) Ereignis des Hauptdiagrammfensters.

Beispiel:

beiMausMitteLosgelassen [schreibe [rauf!]]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiRechtsLosgelasserMaus beiLinksDoppeltgeklickerMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiLinksDoppeltgeklickerMaus

beiLinksDoppeltgeklickerMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiLinksDoppeltgeklickerMaus
beiMitteLosgelasserMaus beiRechtsDoppeltgeklickerMaus

beiLinksDoppeltgeklickerMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Link-Knopf Doppelt-Klick-Ereignis des Hauptdiagrammfensters.

Beispiel:

beiLinksDoppeltgeklickterMaus [schreibe [doubleclick!]]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiMitteLosgelasserMaus beiRechtsDoppeltgeklickerMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiRechtsDoppeltgeklickerMaus

beiRechtsDoppeltgeklickerMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiRechtsDoppeltgeklickerMaus
beiLinksDoppeltgeklickerMaus beiMitteDoppeltgeklickerMaus

beiRechtsDoppeltgeklickerMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig Knopf Doppeltklickereignis des Hauptdiagrammfensters.

Beispiel:

beiRechtsDoppeltGeklickterMaus [schreibe [doubleclick!]]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiLinksDoppeltgeklickerMaus beiMitteDoppeltgeklickerMaus


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiMitteDoppeltgeklickerMaus

beiMitteDoppeltgeklickerMaus

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiMitteDoppeltgeklickerMaus
beiRechtsDoppeltgeklickerMaus beiMausBewegung

beiMitteDoppeltgeklickerMaus Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Mitten-Knopf Doppeltklickereignis des Hauptdiagrammfensters.

Beispiel:

beiMitteDoppeltgeklickterMaus [schreibe [doubleclick!]]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiRechtsDoppeltgeklickerMaus beiMausBewegung


HC / GUI Programmierung / Standart-Ereignis-Behandler / beiMausBewegung

beiMausBewegung

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] beiMausBewegung
beiMitteDoppeltgeklickerMaus VerzeichnisAuswahl

beiMausBewegung Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mausbewegungsereignis des Hauptdiagrammfensters.

Beispiel:

beiMausbewegung [setzeOrtXYZ Mausort  erneuereGraph]

References:

    Release Notes für Version 4.685, Standart-Ereignis-Behandler

beiMitteDoppeltgeklickerMaus VerzeichnisAuswahl


HC / GUI Programmierung / Standart-Ereignis-Behandler / VerzeichnisAuswahl

VerzeichnisAuswahl

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] VerzeichnisAuswahl
beiMausBewegung DateiAuswahl

VerzeichnisAuswahl
(VerzeichnisAuswahl Nachricht defaultPath ort)

Operation zu zeige ein Verzeichniswählerdialog, der Benutzer ein Verzeichnis wählen kann.

Meldung ist das Eingabestichwort im Dialog.

defaultPath ist der standardmäßige Pfad, der Wähler startet.

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Ausgabe ist das Choosen Verzeichnis als ein Wort.

Beispiele:

schreibe VerzeichnisAuswahl
schreibe (VerzeichnisAuswahl [This is the input prompt][C:][100 200])

Reference:

    Release Notes für Version 4.685

beiMausBewegung DateiAuswahl


HC / GUI Programmierung / Standart-Ereignis-Behandler / DateiAuswahl

DateiAuswahl

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] DateiAuswahl
VerzeichnisAuswahl holeFarbeVomBenutzer

DateiAuswahl Nachricht
(DateiAuswahl Nachrichten-stdPath stdFilename stdExtension Jokerfahnen-Ort)

Operation zu zeige ein Dateiwählerdialog, der Benutzer eine Datei von einer Verzeichnisauflistung wählen kann.

Meldung ist das eingegebene prompte Text im Dialog.

stdPath ist der Vorgabepfad, der Wähler startet.

stdFilename ist die Vorgabedateibezeichnung.

stdExtension ist die Vorgabedateierweiterung.

Joker ist ein DOS-Oder Unix Joker für die Auswahl einer Teilmenge von zu zeigendem dateien.

Flags können eine Kombination von wxOPEN wxSAVE wxOVERWRITE_PROMPT wxFILE_MUST_EXIST wxMULTIPLE oder 0 sein

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Ausgabe ist die Choosen Dateibezeichnung als ein Wort.

Beispiele:

schreibe DateiAuswahl [Choose a file]
schreibe (DateiAuswahl [Choose a file] "  [dialogtest.lg][lg][*.lg]
    wxOPEN [400 100])

(holeFarbeVomBenutzer)

Reference:

    Release Notes für Version 4.685

VerzeichnisAuswahl holeFarbeVomBenutzer


HC / GUI Programmierung / Standart-Ereignis-Behandler / holeFarbeVomBenutzer

holeFarbeVomBenutzer

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holeFarbeVomBenutzer
DateiAuswahl holeSchriftVomBenutzer

holeFarbeVomBenutzer stdColor

Operation zu zeige ein Farbwählerdialog, der Benutzer eine Farbe mit RGB Zahlen, von einer Gruppe standardmäßiger Farben wählen kann, oder, indem man auf ein die Helligkeit wählendes Farbgradienten-Und klickt.

stdColor ist die ausgewählte Anfangsfarbe.

Ausgabe ist die Choosen Farbe als ein int.

Beispiele:

schreibe listeRGB (holeFarbeVomBenutzer)
schreibe listeRGB holeFarbeVomBenutzer RGB 1 0.5 0.25

References:

    DateiAuswahl, Release Notes für Version 4.685

DateiAuswahl holeSchriftVomBenutzer


HC / GUI Programmierung / Standart-Ereignis-Behandler / holeSchriftVomBenutzer

holeSchriftVomBenutzer

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holeSchriftVomBenutzer
holeFarbeVomBenutzer holeAuswahlmöglichkeiten

holeSchriftVomBenutzer

Operation zu zeige ein Schriftwählerdialog, der Benutzer eine Schrift auswählen kann.

Ausgabe ist ein Liste mit der folgenden Struktur:

[PointSize [PixelSizeX PixelSizeY] Familiy Stil-Gewicht FaceName]

Beispiel:

schreibe holeSchriftVomBenutzer

Reference:

    Release Notes für Version 4.685

holeFarbeVomBenutzer holeAuswahlmöglichkeiten


HC / GUI Programmierung / Standart-Ereignis-Behandler / holeAuswahlmöglichkeiten

holeAuswahlmöglichkeiten

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holeAuswahlmöglichkeiten
holeSchriftVomBenutzer holeZahlVomBenutzer

holeAuswahlmöglichkeiten Nachrichtenbildunterschrift optionen
(holeAuswahlmöglichkeiten Nachrichten Bildunterschrift Options-Ort Zentrumsgröße)

Operation zu zeige ein Dialog, um einige vielfacher Optionen zu wählen.

Meldung ist der Eingabe-Promt ProzedurText.

Bildunterschrift ist der Fenster Titeltext.

Optionen ist ein Liste von elemente, das Listen-Oder Wörter sein kann, auszuwählen.

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Wenn Zentrum wahr ist, wird das Nachrichten-Text (der neue Linie Charaktere einschließen kann) zentriert; wenn falsch, die
zeige (holeAuswahlmöglichkeiten [a Message][a Caption]
    [[Choice Nr. 1][Second Choice][Third Choice]])

zeige (holeAuswahlmöglichkeiten [a Message][a Caption]
    [[Choice Nr. 1][Second Choice][Third Choice]]
    [200 200] falsch [400 300])

Reference:

    Release Notes für Version 4.685

holeSchriftVomBenutzer holeZahlVomBenutzer


HC / GUI Programmierung / Standart-Ereignis-Behandler / holeZahlVomBenutzer

holeZahlVomBenutzer

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holeZahlVomBenutzer
holeAuswahlmöglichkeiten holePasswortVomBenutzer

holeZahlVomBenutzer Nachrichtenpromptbildunterschriftwert kleinstes größtes
(holeZahlVomBenutzer Nachrichtenstichwortbildunterschriftwert kleinstes größtes ort)

Operation zu zeige ein Dialog, um eine integre Zahl einzugeben.

Meldung ist der Dialogtext.

Stichwort ist der eingegebene prompte ProzedurText.

Bildunterschrift ist der Fenster Titeltext.

Wert ist die standardmäßige sich an der Öffnung zeigende Anzahl vom Dialog.

kleinstes ist der minimale Wert, der eingegeben werden kann.

größtes ist der maximale Wert.

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Ausgabe ist die eingegebene integre Zahl.

Beispiel:

zeige (holeZahlVomBenutzer [a Message][a Prompt
    maybe multiline][A caption] 1234 42 4321)

Reference:

    Release Notes für Version 4.685

holeAuswahlmöglichkeiten holePasswortVomBenutzer


HC / GUI Programmierung / Standart-Ereignis-Behandler / holePasswortVomBenutzer

holePasswortVomBenutzer

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holePasswortVomBenutzer
holeZahlVomBenutzer holeTextVomBenutzer

holePasswortVomBenutzer Nachrichtenbildunterschrift stdValue
(holePasswortVomBenutzer Nachrichten Bildunterschrift stdValue ort Zentrum)

Operation zu zeige ein Dialog, um ein Passwort einzugeben.

Meldung ist der Dialogtext.

Bildunterschrift ist der Fenster Titeltext.

stdValue ist das standardmäßige Passwort, das sich an der Öffnung des Dialogs zeigt.

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Wenn Zentrum wahr ist, wird das Nachrichten-Text (der neue Linie Charaktere einschließen kann) zentriert; wenn falsch, die Meldung ist linksbündig.

Ausgabe ist das eingegebene Passwort.

Beispiele:

zeige holePasswortVomBenutzer [A Message][A Caption][default_value]
zeige (holePasswortVomBenutzer [A Message][A Caption][default_value]
    [200 100])
zeige (holePasswortVomBenutzer [A Message][A Caption][default_value]
    [200 100] falsch)

Reference:

    Release Notes für Version 4.685

holeZahlVomBenutzer holeTextVomBenutzer


HC / GUI Programmierung / Standart-Ereignis-Behandler / holeTextVomBenutzer

holeTextVomBenutzer

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holeTextVomBenutzer
holePasswortVomBenutzer holeAuswahl

holeTextVomBenutzer Nachrichtenbildunterschrift stdValue
(holeTextVomBenutzer Nachrichten Bildunterschrift stdValue ort Zentrum)

Operation zu zeige ein Dialog, um ProzedurText einzugeben.

Meldung ist der Dialogtext.

Bildunterschrift ist der Fenster Titeltext.

stdValue ist das standardmäßige Passwort, das sich an der Öffnung des Dialogs zeigt.

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Wenn Zentrum wahr ist, wird das Nachrichten-Text (der neue Linie Charaktere einschließen kann) zentriert; wenn falsch, die Meldung ist linksbündig.

Ausgabe ist der eingegebene ProzedurText.

Beispiele:

zeige (holeTextVomBenutzer [A Message][A Caption][default_value]
    [200 100])
zeige (holeTextVomBenutzer [A Message][A Caption][default_value]
    [200 100] falsch)

Reference:

    Release Notes für Version 4.685

holePasswortVomBenutzer holeAuswahl


HC / GUI Programmierung / Standart-Ereignis-Behandler / holeAuswahl

holeAuswahl

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holeAuswahl
holeTextVomBenutzer holeAuswahlZahl

holeAuswahl Nachrichten bildunterschrift optionen
(holeAuswahl Nachrichten Bildunterschrift OptionsOrt Zentrumsgröße)

Operation zu zeige ein Dialog, um eine vielfacher Optionen zu wählen.

Meldung ist der Eingabe-Promt ProzedurText.

Bildunterschrift ist der Fenster Titeltext.

Optionen ist ein Liste von elemente, das Listen-Oder Wörter sein kann, auszuwählen.

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Wenn Zentrum wahr ist, wird das Nachrichten-Text (der neue Linie Charaktere einschließen kann) zentriert; wenn falsch, die
zeige (holeAuswahl [A Message][A Caption]
    [[Choice Nr. 1][Second Choice][Third Choice]])

Reference:

    Release Notes für Version 4.685

holeTextVomBenutzer holeAuswahlZahl


HC / GUI Programmierung / Standart-Ereignis-Behandler / holeAuswahlZahl

holeAuswahlZahl

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] holeAuswahlZahl
holeAuswahl Meldungsbox

holeAuswahlZahl Nachrichten bildunterschrift optionen
(holeAuswahlZahl Nachrichten Bildunterschrift Options Ort Zentrumsgröße)

Operation zu zeige ein Dialog, um eine vielfacher Optionen zu wählen.

Meldung ist der Eingabe-Promt ProzedurText.

Bildunterschrift ist der Fenster Titeltext.

Optionen ist ein Liste von elemente, das Listen-Oder Wörter sein kann, auszuwählen.

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Wenn Zentrum wahr ist, wird das Nachrichten-Text (der neue Linie Charaktere einschließen kann) zentriert; wenn falsch, die
zeige (holeAuswahlZahl [A Message][A Caption]
    [[Choice Nr. 1][Second Choice][Third Choice]])

Reference:

    Release Notes für Version 4.685

holeAuswahl Meldungsbox


HC / GUI Programmierung / Standart-Ereignis-Behandler / Meldungsbox

Meldungsbox

HC [image] GUI Programmierung [image] Standart-Ereignis-Behandler [image] Meldungsbox
holeAuswahlZahl Fenster-Stile

Meldungsbox Nachricht
(Meldungsbox Nachrichtenbildunterschriftstil Ort)

Operation zu zeige ein Dialog mit einem Kurznachrichten-Text Und eins oder mehr Knöpfe, je nach dem Stil.

Meldung ist der Meldungsbox ProzedurText.

Bildunterschrift ist der Fenster Titeltext.

Reference:

    Release Notes für Version 4.685

holeAuswahlZahl Fenster-Stile


HC / GUI Programmierung / Fenster-Stile

Fenster-Stile

HC [image] GUI Programmierung [image] Fenster-Stile
Meldungsbox Rahmen

Fenster-Stile

Die folgenden Stile können wendeAn zu allen Fenstern, obwohl sie werden nicht immer Setze Sinn für ein besonderes Fenster Klassen-Oder auf allen Plattformen.

wxSIMPLE_BORDER zeigt eine dünne Rand ums Fenster. wxBORDER ist der alte Name für diesen Stil.

wxDOUBLE_BORDER zeigt eine doppelte Rand. Windows-Und Mac nur.

wxSUNKEN_BORDER zeigt eine versunkene Rand.

wxRAISED_BORDER zeigt eine erhöhte Rand.

wxSTATIC_BORDER zeigt eine für eine statische Kontrolle geeignete Rand. Windows nur.

wxNO_BORDER zeigt nein grenzen, wenn man sich über den Vorgaberandstil für das Fenster hinwegsetzt.

wxTRANSPARENT_WINDOW Das Fenster ist transparent, das heißt, es wird nicht Lackereignisse bekommen. Windows nur.

wxTAB_TRAVERSAL Benutzen Sie dies, um Tabulator-Traversal für Nicht-Dialog-Fenster zu ermöglichen.

wxWANTS_CHARS Verwendung vergeht um zu zeigen dass das Fenster alle Zeichen/Key Ereignisse für alle Tasten bekommen will - sogar da Tasten wie TAB Oder EINDRINGEN die üblicherweise für Dialognavigations Und benutzt werden, das nicht ohne Würfelstil erzeugt werden würde. Wenn Sie Würfelstil benutzen müssen um das Pfeile-Oder etc. zu bekommen, aber stillen würden wie normale Tastaturnavigation stattfinden zu lassen, sollten Sie und schaffen ein wxNavigationKeyEvent als Antwort auf die Schlüsselereignisse für Tabulator-Und Umschaltungs Tabulator schicken.

wxNO_FULL_REPAINT_ON_RESIZE Sperrt das Fenster vollkommen wiedermalend wenn Größe verändert wird - Sie werden das neue Fenster Gebiet von Hand wenn neu zeichnen müssen, das Sie Würfelstil benutzen. Gegenwärtig nur hat eine Wirkung für Windows.

wxVSCROLLverwenden Sie dies Würfelstil, um ein vertikales scrollbar zu ermöglichen.

wxHSCROLLverwenden Sie dies Würfelstil, um ein horizontales scrollbar zu ermöglichen.

wxALWAYS_SHOW_SB Wenn ein Fenster scrollbars hat, sperren Sie sie, an Stelle, sie zu verstecken, wenn sie nicht sind, benötigt (d. h. wenn die Größe des Fenster groß ist, erfordert genug zu nicht, dass es die scrollbars navigieren). Dieser Stil wird nur gegenwärtig realisiert, da wxMSW und wxUniversal und nichts auf den anderen Plattformen ausführt.

wxCLIP_CHILDREN verwenden Sie dies Würfelstil, um Flimmern zu beseitigen, von dem Hintergrund verursacht, der wiederbemalt worden ist, dann Kinder über ihnen gemalt werdend. Windows nur.

wxFULL_REPAINT_ON_RESIZE verwenden Sie dies Würfelstil, um ein vollständiges zeichneNochmal des Fenster zu zwingen, wann auch immer es wiedergemessen wird, an Stelle, gerade den Teil des von Größenänderung ausgewirkten Fenster neuzuentwerfen. Anmerkung, die vergeht, war das Verhalten standardmäßig vor 2.5.1-Veröffentlichungs-Und, das es dies vielleicht wenn, das Sie zeichneNochmal Probleme bei dem Code erleben, der Sie früher normalerweise bearbeitete, versuchen will.

Meldungsbox Rahmen


HC / GUI Programmierung / Rahmen

Rahmen

HC [image] GUI Programmierung [image] Rahmen
Fenster-Stile Fenster

Rahmen

...sind Fenster typisch eine Rand darum habend und zumeist ein Titelleiste, vielleicht mit einem Systemmenü darauf. Sie können Controls-Oder Diagramme in einem Fenster setzen, specifing dem Fenster als Elternteil der Kontrolle.

Sie werden im Beispiel frametest.lg. präsentiert.

Rahmen

  • Fenster
  • zerstöreFenster
  • beiFensterZeichen
  • beiGedrückterTasteInFenster
  • beiLosgelassenerTasteInFenster
  • aktiviereFenster
  • FensterAn
  • FensterGroß
  • FensterKlein
  • FensterVollbild
  • setzeInnereFenstergröße
  • setzeFensterFarbe
  • setzeFensterHintergundfarbe
  • setzeFensterSchriftgröße
  • setzeFensterSchriftname
  • setzeFensterSchriftstil
  • setzeFensterSchriftdicke
  • settFensterform
  • setzeFenstersizer

References:

    Rahmen-Fenster(3), Release Notes für Version 4.685(2), Fenster, Versions-Informationen für Version 4.7, setzeInnereFenstergröße

Fenster-Stile Fenster


HC / GUI Programmierung / Rahmen / Fenster

Fenster

HC [image] GUI Programmierung [image] Rahmen [image] Fenster
Rahmen zerstöreFenster

Fenster Elternteil Titel Stil Ort Größe
(Fenster Elternteiltitelstil) (Fenster Elternteil Titel Stil Ort Größenname)

Operation, die einen neuen Fenster ausgibt (ein Fenster mit vielleicht einer Rand um). Dieses Fenster kann einer Variablen zugewiesen werden, und es wird gestrichen werden, wenn die Variable gestrichen wird. So können Sie mit Lokal Variablen Dialoge mit Rahmen-Bis nachahmen jene werden in aUCBLogo eingeschlossen werden.

Elternteil kann ein Fenster Oder ein Diagramm sein.

Titel ist der Fenster Titeltext.

Examples:

  • Versions-Informationen für Version 4.7
  • beiLosgelassenerTasteInFenster
  • beiGedrückterTasteInFenster
  • setzeFensterHintergundfarbe
  • setzeFensterSchriftdicke
  • setzeFensterSchriftgröße
  • setzeFensterSchriftname
  • setzeFensterSchriftstil
  • setzeInnereFenstergröße
  • beiFensterZeichen
  • setzeFensterFarbe
  • setzeFenstersizer
  • aktiviereFenster
  • FensterVollbild
  • settFensterform
  • zerstöreFenster
  • zerstöreGraph
  • FensterKlein
  • FensterGroß
  • TextMausOrt
  • FensterAn
  • TextMausX
  • TextMausY
  • Diagramm
  • IgelText
  • Gestell

References:

    Fenster-Stile(12), Release Notes für Version 4.685(9), Versions-Informationen für Version 4.7(8), Diagramm(5), TextControl(4), geteilterBildschirm(4), setzeInnereFenstergröße(4), zerstöreFenster(4), zumGestellDazu(4), FensterModus(3), FensterVollbild(3), GrafikGroß(3), Grafiken(3), Rahmen(3), Release Notes für Version 4.672(3), Textmodus(3), aktiviereFenster(3), setzeFensterteilerAufrufe(3), Auswahlbox(2), Balken(2), FensterAn(2), FensterGroß(2), FensterKlein(2), GUI Programmierung(2), GanzzahlBox(2), IgelText(2), Randsprung(2), Schaltknopf(2), Schieberegler(2), TextMausOrt(2), TextMausX(2), TextMausY(2), Zahlbox(2), beiFensterZeichen(2), beiGedrückterTasteInFenster(2), beiLosgelassenerTasteInFenster(2), settFensterform(2), setzeFensterFarbe(2), setzeFensterHintergundfarbe(2), setzeFensterSchriftdicke(2), setzeFensterSchriftgröße(2), setzeFensterSchriftname(2), setzeFensterSchriftstil(2), setzeFenstersizer(2), setzePlayOnSwap(2), setzeVariablenFensterteiler(2), statischerText(2), zerstöreGraph(2), Ankreuzbox, Balken-Anzeigen, CheckBoxen, ChoiceBoxes, Diagramme, DoppelPufferung, Einfachpuffer, Fehlersuche, Fenster-Kontrolle, GanzzahlBoxen, Gestell, Grafik, GraphOnMouseLeftDown, Knopf, Knöpfe, KombiBox, Kommandozeilen-Schalter -nogui, ListControl, ListControls, Listenbox, Listenboxen, Mausort, Meldungsbox, RadioButtons, Radioknopf, Rahmen-Fenster, Release Notes für Version 4.682, Release Notes für Version 4.689, Schiebe-Regler, Standart-Ereignis-Behandler, StaticTexts, TextControls, ToggleButtons, Zahlboxen, Zaun, beiGraphMausBewegung, beiGraphMausLinksDoppelKlick, beiGraphMausLinksLosgelassen, beiGraphMausMitteDoppelKlick, beiGraphMausMitteLosgelassen, beiGraphMausRechtsDoppelKlick, beiLinksGeklickterGraphMaus, beiMitteGeklickterGraphMaus, beiRechtsGeklickterGraphMaus, erneuereAufrufliste, erneuereVariablenliste, erneuereVariablenlisteBeiSchritt, holeAuswahl, holeAuswahlZahl, holeAuswahlmöglichkeiten, holePasswortVomBenutzer, holeTextVomBenutzer, holeZahlVomBenutzer, kalibriereScrolling, ladeGraph, ladeGraphText, löscheSchirm, perspektivisch, scrolle, setzeQuetschung, setzeSchirmbereich, setzeTextfarbe, speichereGraph, speichereSchirmVektoriell, versteckeLogoConsolew, verteileMeldungen, zeichneBitmapSchnell, zeichneNochmal, zeigeLogoConsolew, zweidimensional

Rahmen zerstöreFenster


HC / GUI Programmierung / Rahmen / zerstöreFenster

zerstöreFenster

HC [image] GUI Programmierung [image] Rahmen [image] zerstöreFenster
Fenster beiFensterZeichen

zerstöreFenster aframe

Kommando, das fenster aframe zu zerstören. Wenn eine Variable noch auf das fenster und hinweist das Sie dann ein anderes FrameXXX Primitiv mit jenem var nennen, tritt ein Fehler auf, weil das fenster dann zerstört worden ist und cannot benutzt werden nicht mehr.

Beispiel:

f=Fenster [][MyFrame][][400 200][200 100]
zerstöreFenster f

Reference:

    Release Notes für Version 4.685

Fenster beiFensterZeichen


HC / GUI Programmierung / Rahmen / beiFensterZeichen

beiFensterZeichen

HC [image] GUI Programmierung [image] Rahmen [image] beiFensterZeichen
zerstöreFenster beiGedrückterTasteInFenster

beiFensterZeichen aframe Befehle

Kommando, den Gewohnheitsereignisführer für das Zeichen Ereignis des fenster aframe zu zu setzen, befiehlt. Sehen Sie auch beiZeichen!

Beispiel:

f=Fenster [][MyFrame][][400 200][200 100]
beiFensterZeichen f [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

zerstöreFenster beiGedrückterTasteInFenster


HC / GUI Programmierung / Rahmen / beiGedrückterTasteInFenster

beiGedrückterTasteInFenster

HC [image] GUI Programmierung [image] Rahmen [image] beiGedrückterTasteInFenster
beiFensterZeichen beiLosgelassenerTasteInFenster

beiGedrückterTasteInFenster aframe Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Runter Ereignis des fenster aframe zu zu setzen, befiehlt. Sehen Sie auch beiGedrückterTaste!

Beispiel:

f=Fenster [][MyFrame][][400 200][200 100]
beiGedrückterTasteInFenster f [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiFensterZeichen beiLosgelassenerTasteInFenster


HC / GUI Programmierung / Rahmen / beiLosgelassenerTasteInFenster

beiLosgelassenerTasteInFenster

HC [image] GUI Programmierung [image] Rahmen [image] beiLosgelassenerTasteInFenster
beiGedrückterTasteInFenster aktiviereFenster

beiLosgelassenerTasteInFenster aframe Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Rauf zu setzen (=release), Ereignis des fenster aframe zu Kommandos. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

f=Fenster [][MyFrame][][400 200][200 100]
beiLosgelassenerTasteInFenster f [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiGedrückterTasteInFenster aktiviereFenster


HC / GUI Programmierung / Rahmen / aktiviereFenster

aktiviereFenster

HC [image] GUI Programmierung [image] Rahmen [image] aktiviereFenster
beiLosgelassenerTasteInFenster FensterAn

aktiviereFenster aframe

Befehlen Sie, dass die Tastatur-Und Maus, um festzuwerden, Fokus zu dem fenster aframe eingab.

Beispiel:

f=Fenster [][MyFrame][][100 200][200 100]
f2=Fenster [][MyFrame][][400 200][200 100]
aktiviereFenster f

Reference:

    Release Notes für Version 4.685

beiLosgelassenerTasteInFenster FensterAn


HC / GUI Programmierung / Rahmen / FensterAn

FensterAn

HC [image] GUI Programmierung [image] Rahmen [image] FensterAn
aktiviereFenster FensterGroß

FensterAn aframe Staat

Kommando, oder zu ermöglichen, das fenster aframe sperren.

Zustand ist ein boolesch. Wenn Zustand falsch ist, aframe und aller Kinder werden gesperrt werden, jenes Mittel, keine mehr Benutzereingabe wird akzeptiert.

Beispiele:

f=Fenster [][MyFrame] wxStay_on_top [100 200][200 100]
b=Knopf f [Close][ern "f  Müllsammeln]
FensterAn f falsch
;try to press the knopf - nothing happens!
FensterAn f wahr
;try to press the knopf again - vorwärts 100 executed!

Reference:

    Release Notes für Version 4.685

aktiviereFenster FensterGroß


HC / GUI Programmierung / Rahmen / FensterGroß

FensterGroß

HC [image] GUI Programmierung [image] Rahmen [image] FensterGroß
FensterAn FensterKlein

FensterGroß aframe Staat

befehlen Sie, dass Zustand, um das fenster aframe wenn zu maximieren, wahr ist. Sonst wird die normale Layout zurückgegeben werden.

Beispiel:

f=Fenster [][MyFrame] wxDefault_Frame_Style [100 200][200 100]
FensterGroß f wahr
FensterGroß f falsch

Reference:

    Release Notes für Version 4.689

FensterAn FensterKlein


HC / GUI Programmierung / Rahmen / FensterKlein

FensterKlein

HC [image] GUI Programmierung [image] Rahmen [image] FensterKlein
FensterGroß FensterVollbild

FensterKlein aframe Staat

befehlen Sie, dass Zustand, um das fenster aframe wenn zu iconize, wahr ist. Sonst wird die normale Layout zurückgegeben werden.

Beispiel:

f=Fenster [][MyFrame] wxDefault_Frame_Style [100 200][200 100]
FensterKlein f wahr
FensterKlein f falsch

Reference:

    Release Notes für Version 4.689

FensterGroß FensterVollbild


HC / GUI Programmierung / Rahmen / FensterVollbild

FensterVollbild

HC [image] GUI Programmierung [image] Rahmen [image] FensterVollbild
FensterKlein setzeInnereFenstergröße

FensterVollbild aframe Staatsstil

befehlen Sie, dass der Fenster Aframe Grafikgroß Wenn Staat zu zeige wahr ist. Sonst wird die normale Layout zurückgegeben werden.

Stil kann eine Mischung aus den folgenden Konstanten sein, die zeigen, welche Elemente des Fenster sie in VollBildschirmmodus verheimlichen sollten:

wxFULLSCREEN_NOMENUBAR
wxFULLSCREEN_NOTOOLBAR
wxFULLSCREEN_NOSTATUSBAR
wxFULLSCREEN_NOBORDER
wxFULLSCREEN_NOCAPTION
wxFULLSCREEN_ALL (all of the above)

Example:

f=Fenster [][MyFrame] wxDefault_Frame_Style [100 200][200 100]
FensterVollbild f wahr wxFULLSCREEN_ALL
FensterVollbild f falsch 0

Reference:

    Release Notes für Version 4.689

FensterKlein setzeInnereFenstergröße


HC / GUI Programmierung / Rahmen / setzeInnereFenstergröße

setzeInnereFenstergröße

HC [image] GUI Programmierung [image] Rahmen [image] setzeInnereFenstergröße
FensterVollbild setzeFensterFarbe

setzeInnereFenstergröße aframe Breitenhöhe

Kommando, die Kundengröße des Fenster Aframe zu setzen. Die Kundengröße ist das Innere von dem fenster, das ist, dem, was zumeist an Stelle der vollständigen Fenster Größe in Rahmen gehärtet werden muss.

Breiten-Und Höhe sind integre Zahlen.

Beispiel:

f=Fenster [][MyFrame] wxStay_on_top [100 200][200 100]
b=(Knopf f [Close][ern "f  Müllsammeln] 0 [-1 -1][100 40])
setzeInnereFenstergröße f 100 40

Examples:

  • settFensterform
  • zerstöreGraph
  • Diagramm

References:

    Diagramm, Release Notes für Version 4.685, settFensterform, zerstöreGraph

FensterVollbild setzeFensterFarbe


HC / GUI Programmierung / Rahmen / setzeFensterFarbe

setzeFensterFarbe

HC [image] GUI Programmierung [image] Rahmen [image] setzeFensterFarbe
setzeInnereFenstergröße setzeFensterHintergundfarbe

setzeFensterFarbe aframe acolor

Befehlen Sie acolor, das eine plausible Farbe sein muss (sehen Sie SetPenColor!), die Vordergrundfarbe des Fenster Aframe zu setzen.

Beispiel:

f=Fenster [][MyFrame] wxdefault_frame_style [100 200][200 100]
setzeFensterFarbe f "red
ic=GanzzahlBox f [number one] 0 1234 4321 []

Reference:

    Release Notes für Version 4.685

setzeInnereFenstergröße setzeFensterHintergundfarbe


HC / GUI Programmierung / Rahmen / setzeFensterHintergundfarbe

setzeFensterHintergundfarbe

HC [image] GUI Programmierung [image] Rahmen [image] setzeFensterHintergundfarbe
setzeFensterFarbe setzeFensterSchriftgröße

setzeFensterHintergundfarbe aframe acolor

Befehlen Sie acolor, das eine plausible Farbe sein muss (sehen Sie SetPenColor!), die Hintergrundfarbe des Fenster Aframe zu setzen.

Beispiel:

f=Fenster [][MyFrame] wxdefault_frame_style [100 200][200 100]
setzeFensterHintergundfarbe f rgb 1 0 0
b=(Knopf f [Close][ern "f  Müllsammeln] 0 [-1 -1][100 40])

Reference:

    Release Notes für Version 4.685

setzeFensterFarbe setzeFensterSchriftgröße


HC / GUI Programmierung / Rahmen / setzeFensterSchriftgröße

setzeFensterSchriftgröße

HC [image] GUI Programmierung [image] Rahmen [image] setzeFensterSchriftgröße
setzeFensterHintergundfarbe setzeFensterSchriftname

setzeFensterSchriftgröße aframe Größe

Kommando, die Schrifthöhe des zu messenden Fenster Aframe zu setzen, das eine integre Zahl sein muss.

Beispiel:

f=Fenster [][MyFrame] wxdefault_frame_style [100 200][200 100]
setzeFensterSchriftgröße f 50
b=(Knopf f [Close][ern "f  Müllsammeln] 0 [-1 -1][200 70])

Reference:

    Release Notes für Version 4.685

setzeFensterHintergundfarbe setzeFensterSchriftname


HC / GUI Programmierung / Rahmen / setzeFensterSchriftname

setzeFensterSchriftname

HC [image] GUI Programmierung [image] Rahmen [image] setzeFensterSchriftname
setzeFensterSchriftgröße setzeFensterSchriftstil

setzeFensterSchriftname aframe Größe

Kommando, den Schriftnamen des zu nennenden Fenster Aframe zu setzen, das ein plausibler Schriftname sein muss.

Beispiel:

f=Fenster [][MyFrame] wxdefault_frame_style [100 200][200 100]
setzeFensterSchriftname f [Courier]
b=(Knopf f [Close][ern "f  Müllsammeln] 0 [-1 -1][200 70])

Reference:

    Release Notes für Version 4.685

setzeFensterSchriftgröße setzeFensterSchriftstil


HC / GUI Programmierung / Rahmen / setzeFensterSchriftstil

setzeFensterSchriftstil

HC [image] GUI Programmierung [image] Rahmen [image] setzeFensterSchriftstil
setzeFensterSchriftname setzeFensterSchriftdicke

setzeFensterSchriftstil aframe Stil

Kommando, den Schriftstil des Fenster Aframe zu setzen.

Stil kann eine der Konstanten wxFONTSTYLE_NORMAL wxFONTSTYLE_SLANT wxFONTSTYLE_ITALIC sein.

Beispiel:

f=Fenster [][MyFrame] wxdefault_frame_style [100 200][200 100]
setzeFensterSchriftstil f wxFONTSTYLE_ITALIC
b=(Knopf f [Close][ern "f  Müllsammeln] 0 [-1 -1][200 70])

Reference:

    Release Notes für Version 4.685

setzeFensterSchriftname setzeFensterSchriftdicke


HC / GUI Programmierung / Rahmen / setzeFensterSchriftdicke

setzeFensterSchriftdicke

HC [image] GUI Programmierung [image] Rahmen [image] setzeFensterSchriftdicke
setzeFensterSchriftstil settFensterform

setzeFensterSchriftdicke aframe Gewicht

Kommando, das Schriftgewicht des Fenster Aframe zu setzen.

Gewicht kann eine der Konstanten wxFONTWEIGHT_NORMAL wxFONTWEIGHT_LIGHT wxFONTWEIGHT_BOLD sein

Beispiel:

f=Fenster [][MyFrame] wxdefault_frame_style [100 200][200 100]
setzeFensterSchriftdicke f wxFONTWEIGHT_BOLD
b=(Knopf f [Close][ern "f  Müllsammeln] 0 [-1 -1][200 70])

Reference:

    Release Notes für Version 4.685

setzeFensterSchriftstil settFensterform


HC / GUI Programmierung / Rahmen / settFensterform

settFensterform

HC [image] GUI Programmierung [image] Rahmen [image] settFensterform
setzeFensterSchriftdicke setzeFenstersizer

settFensterform aframe ashape

Befehlen Sie dem formatiereZahl-Ashape, die formatiereZahl des Fenster Aframe zu setzen.

ashape muss ein Liste von Positionen sein.

Eine Position in Würfelzusammenhang ist ein Liste zweier integrer x und y repräsentierender Zahlen. [0 0] ist an der oberen linken Position des Innenfläche.

Beispiel:

f=(Fenster [][MyFrame]
    wxdefault_frame_style+wxFRAME_SHAPED
    [100 200][200 100])
b=(Knopf f [Close][ern "f  Müllsammeln] 0 [-1 -1][200 100])
setzeInnereFenstergröße f 200 100
settFensterform f [[0 0][200 0][100 100]]

Reference:

    Release Notes für Version 4.685

setzeFensterSchriftdicke setzeFenstersizer


HC / GUI Programmierung / Rahmen / setzeFenstersizer

setzeFenstersizer

HC [image] GUI Programmierung [image] Rahmen [image] setzeFenstersizer
settFensterform Diagramme

setzeFenstersizer aframe asizer

Kommando, das sizer asizer für das Fenster Aframe zu setzen. Gegenwärtig wird nur Gestell als sizer gestützt.

Beispiel:

f=Fenster [][MyFrame] wxdefault_frame_style [100 200][100 200]
b1=Knopf f [Close][ern "f  Müllsammeln]
b2=Knopf f [vorwärts 100][vorwärts 100 erneuereGraph]
b3=Knopf f [zurück 100][zurück 100 erneuereGraph]
bs=Gestell wxVertical
zumBoxSizerDazu bs b1 100 wxExpand 0
zumBoxSizerDazu bs b2 200 wxExpand 10
zumBoxSizerDazu bs b3 200 wxExpand 20
setzeFenstersizer f bs

Example:

  • Gestell

References:

    Release Notes für Version 4.685(2), Gestell

settFensterform Diagramme


HC / GUI Programmierung / Diagramme

Diagramme

HC [image] GUI Programmierung [image] Diagramme
setzeFenstersizer Diagramm

Diagramme

Ein Diagramm ist ein Logo-Zeichnungsfläche, Sie irgendetwas verziehen können Logo können zeichnen im großen und ganzen Diagramm-Fenster. Ein Diagramm-Und benutzend Ereignisroutine, die Sie Ihrer eigenen Kontrolle in Logo schreiben können.

Diagramme

  • Diagramm
  • zerstöreGraph
  • GraphCurrent
  • aktiviereGraph
  • beiGraphZeichen
  • beiGedrückterTasteInGraph
  • beiLosgelassenerTasteInGraph
  • GraphOnMouseLeftDown
  • beiRechtsGeklickterGraphMaus
  • beiMitteGeklickterGraphMaus
  • beiGraphMausLinksLosgelassen
  • beiLinksGeklickterGraphMaus
  • beiGraphMausMitteLosgelassen
  • beiGraphMausLinksDoppelKlick
  • beiGraphMausRechtsDoppelKlick
  • beiGraphMausMitteDoppelKlick
  • beiGraphMausBewegung

References:

    GUI Programmierung, Rahmen

setzeFenstersizer Diagramm


HC / GUI Programmierung / Diagramme / Diagramm

Diagramm

HC [image] GUI Programmierung [image] Diagramme [image] Diagramm
Diagramme zerstöreGraph

Diagramm Elternteil
(Diagramm Elternteil Stil Ort Größenname)

Operation, die ein neues Diagramm ausgibt, ein Logo-Zeichnungsfläche.

Elternteil kann ein Fenster Oder ein Diagramm sein.

Stil kann eine Mischung aus den standardmäßigen Fenster Stilen sein, aber wird wahrscheinlich gerade wxFULL_REPAINT_ON_RESIZE sein, den ist wird dem Standardwert-Und Wenn Stil auch gesetzt werden ist das leere Liste [].

ort ist ein Liste zweier integrer X Und Y Position repräsentierender Zahlen.

Größe ist ein Liste zweier integrer Breiten-Und Höhe repräsentierender Zahlen.

Wie alle Fenster Oder Kontrollpositionen misst und den Wert -1 für ein koordinatives Mittel dass wxWidgets den Standardwert benutzen wird. Dies ist besonders nützlich, wenn Sie sizers benutzen, so müssen Sie zumeist die Koordinaten sich nicht für d. h. Knöpfe Oder Anderregler verstehen.

Name ist der interne Name des Fenster, es ist zumeist unbenutzt.

Ausgabe ist das geschaffene Diagramm.

Beispiel:

f=(Fenster [][MyFrame]
    wxResize_Border+wxCaption+wxSystem_Menu+wxClose_Box
    +wxFull_Repaint_on_Resize+wxStay_on_Top
    ;wxDefault_Frame_Style+wxStay_on_Top)
    [100 100][400 300])
setzeInnereFenstergröße f 400 300
g=(Graph f
    wxDefault_Frame_Style+wxFull_Repaint_on_Resize+wxStay_on_Top
    [0 0][400 300][Graph])

References:

    Release Notes für Version 4.685(4), zerstöreGraph(4), Diagramme(3), Auswahlbox(2), Balken(2), KombiBox(2), ListControl(2), Listenbox(2), Schieberegler(2), TextControl(2), Zahlbox(2), aktiviereGraph(2), statischerText(2), Ankreuzbox, Fenster, GanzzahlBox, GraphCurrent, GraphOnMouseLeftDown, Knopf, Radioknopf, Release, Schaltknopf, beiGedrückterTasteInGraph, beiGraphMausBewegung, beiGraphMausLinksDoppelKlick, beiGraphMausLinksLosgelassen, beiGraphMausMitteDoppelKlick, beiGraphMausMitteLosgelassen, beiGraphMausRechtsDoppelKlick, beiGraphZeichen, beiLinksGeklickterGraphMaus, beiLosgelassenerTasteInGraph, beiMitteGeklickterGraphMaus, beiRechtsGeklickterGraphMaus

Diagramme zerstöreGraph


HC / GUI Programmierung / Diagramme / zerstöreGraph

zerstöreGraph

HC [image] GUI Programmierung [image] Diagramme [image] zerstöreGraph
Diagramm GraphCurrent

zerstöreGraph agraph

Kommando, das Diagramm-Agraph zu zerstören. Wenn eine Variable noch auf das Diagramm-Und hinweist das Sie dann ein anderes GraphXXX Primitiv mit jenem var nennen, tritt ein Fehler auf, weil das Diagramm dann zerstört worden ist und cannot benutzt werden nicht mehr. Manchmal brauchen Sie zu vergrößere das Elternteil-Fenster ein bisschen zu löscheBild Mist vom Diagramm, weiß ich nicht warum außer ihm hilft.

Beispiel:

f=Fenster [][MyFrame][][100 100][400 300]
g=Graph f
setzeInnereFenstergröße f 400 300
boundingbox
rbox
zerstöreGraph g

Reference:

    Release Notes für Version 4.685

Diagramm GraphCurrent


HC / GUI Programmierung / Diagramme / GraphCurrent

GraphCurrent

HC [image] GUI Programmierung [image] Diagramme [image] GraphCurrent
zerstöreGraph aktiviereGraph

GraphCurrent

Ausgaben das gegenwärtig aktive Diagramm.

Beispiel:

g=(Graph GraphCurrent
    wxFull_Repaint_on_Resize
    [100 100][200 150])
boundingbox
rbox

Examples:

  • beiGraphMausRechtsDoppelKlick
  • beiGraphMausLinksDoppelKlick
  • beiGraphMausLinksLosgelassen
  • beiGraphMausMitteDoppelKlick
  • beiGraphMausMitteLosgelassen
  • beiLosgelassenerTasteInGraph
  • beiRechtsGeklickterGraphMaus
  • beiLinksGeklickterGraphMaus
  • beiMitteGeklickterGraphMaus
  • beiGedrückterTasteInGraph
  • beiGraphMausBewegung
  • GraphOnMouseLeftDown
  • beiGraphZeichen
  • aktiviereGraph

References:

    beiGedrückterTasteInGraph(2), beiGraphZeichen(2), beiLosgelassenerTasteInGraph(2), GraphOnMouseLeftDown, Release Notes für Version 4.685, aktiviereGraph, beiGraphMausBewegung, beiGraphMausLinksDoppelKlick, beiGraphMausLinksLosgelassen, beiGraphMausMitteDoppelKlick, beiGraphMausMitteLosgelassen, beiGraphMausRechtsDoppelKlick, beiLinksGeklickterGraphMaus, beiMitteGeklickterGraphMaus, beiRechtsGeklickterGraphMaus

zerstöreGraph aktiviereGraph


HC / GUI Programmierung / Diagramme / aktiviereGraph

aktiviereGraph

HC [image] GUI Programmierung [image] Diagramme [image] aktiviereGraph
GraphCurrent beiGraphZeichen

aktiviereGraph agraph

Kommando, das Diagramm-Agraph als gegenwärtiges Diagramm zu setzen.

Beispiele:

g=GraphCurrent
g1=(Graph g
    wxFull_Repaint_on_Resize
    [100 100][200 150])
g2=(Graph g
    wxFull_Repaint_on_Resize
    [400 100][200 150])
boundingbox
rbox
aktiviereGraph g1
tree
aktiviereGraph []
rboxes

Reference:

    Release Notes für Version 4.685

GraphCurrent beiGraphZeichen


HC / GUI Programmierung / Diagramme / beiGraphZeichen

beiGraphZeichen

HC [image] GUI Programmierung [image] Diagramme [image] beiGraphZeichen
aktiviereGraph beiGedrückterTasteInGraph

beiGraphZeichen agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Zeichen Ereignis des Diagramm-Agraph. Ein Zeichen Ereignis wird erzeugt, wenn ein Taste gedrücktes länger runter gehaltenes oder ist.

Beispiel:

beiGraphZeichen GraphCurrent [schreibe Tastenwert]
;activate the graph und tippe something!
beiGraphZeichen GraphCurrent []	;reset

Reference:

    Release Notes für Version 4.685

aktiviereGraph beiGedrückterTasteInGraph


HC / GUI Programmierung / Diagramme / beiGedrückterTasteInGraph

beiGedrückterTasteInGraph

HC [image] GUI Programmierung [image] Diagramme [image] beiGedrückterTasteInGraph
beiGraphZeichen beiLosgelassenerTasteInGraph

beiGedrückterTasteInGraph agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Tasten-Runter Ereignis des Diagramm-Agraph. Ein Tasten-Runter Ereignis wird erzeugt, wenn ein Taste gedrücktes länger runter gehaltenes oder ist.

Beispiel:

beiGedrückterTasteInGraph GraphCurrent [schreibe Tastenwert]
;activate the graph und tippe something!
beiGedrückterTasteInGraph GraphCurrent []	;reset

Reference:

    Release Notes für Version 4.685

beiGraphZeichen beiLosgelassenerTasteInGraph


HC / GUI Programmierung / Diagramme / beiLosgelassenerTasteInGraph

beiLosgelassenerTasteInGraph

HC [image] GUI Programmierung [image] Diagramme [image] beiLosgelassenerTasteInGraph
beiGedrückterTasteInGraph GraphOnMouseLeftDown

beiLosgelassenerTasteInGraph agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Tasten-Rauf Ereignis des Diagramm-Agraph. Ein Tasten-Rauf Ereignis wird erzeugt, wenn ein Taste aus dem gedrückten Zustand ausgelöst wird.

Beispiel:

beiLosgelassenerTasteInGraph GraphCurrent [schreibe Tastenwert]
;activate the graph und tippe something!
beiLosgelassenerTasteInGraph GraphCurrent []	;reset

Reference:

    Release Notes für Version 4.685

beiGedrückterTasteInGraph GraphOnMouseLeftDown


HC / GUI Programmierung / Diagramme / GraphOnMouseLeftDown

GraphOnMouseLeftDown

HC [image] GUI Programmierung [image] Diagramme [image] GraphOnMouseLeftDown
beiLosgelassenerTasteInGraph beiRechtsGeklickterGraphMaus

GraphOnMouseLeftDown agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Link-Knopf Runter Ereignis des Diagramm-Fenster Agraph.

Beispiel:

g=(Graph GraphCurrent
    wxFull_Repaint_on_Resize
    [100 100][200 150])
GraphOnMouseLeftDown g [StiftAb]
GraphOnMouseLeftUp g [StiftHoch]
GraphOnMouseMotion g [setzeOrtXYZ Mausort  erneuereGraph]

Reference:

    Release Notes für Version 4.685

beiLosgelassenerTasteInGraph beiRechtsGeklickterGraphMaus


HC / GUI Programmierung / Diagramme / beiRechtsGeklickterGraphMaus

beiRechtsGeklickterGraphMaus

HC [image] GUI Programmierung [image] Diagramme [image] beiRechtsGeklickterGraphMaus
GraphOnMouseLeftDown beiMitteGeklickterGraphMaus

beiRechtsGeklickterGraphMaus agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig Knopf Runter Ereignis des Diagramm-Fenster Agraph.

Beispiel:

(GraphOnMouseRightDown GraphCurrent
    [setzeOrtXYZ Mausort  fülle  erneuereGraph])

Reference:

    Release Notes für Version 4.685

GraphOnMouseLeftDown beiMitteGeklickterGraphMaus


HC / GUI Programmierung / Diagramme / beiMitteGeklickterGraphMaus

beiMitteGeklickterGraphMaus

HC [image] GUI Programmierung [image] Diagramme [image] beiMitteGeklickterGraphMaus
beiRechtsGeklickterGraphMaus beiGraphMausLinksLosgelassen

beiMitteGeklickterGraphMaus agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Mittel-Knopf Runter Ereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseMiddleDown GraphCurrent [schreibe Mausort]

Reference:

    Release Notes für Version 4.685

beiRechtsGeklickterGraphMaus beiGraphMausLinksLosgelassen


HC / GUI Programmierung / Diagramme / beiGraphMausLinksLosgelassen

beiGraphMausLinksLosgelassen

HC [image] GUI Programmierung [image] Diagramme [image] beiGraphMausLinksLosgelassen
beiMitteGeklickterGraphMaus beiLinksGeklickterGraphMaus

beiGraphMausLinksLosgelassen agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mauslink-Knopf Rauf (=release) Ereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseLeftUp GraphCurrent [schreibe [rauf!]]

Reference:

    Release Notes für Version 4.685

beiMitteGeklickterGraphMaus beiLinksGeklickterGraphMaus


HC / GUI Programmierung / Diagramme / beiLinksGeklickterGraphMaus

beiLinksGeklickterGraphMaus

HC [image] GUI Programmierung [image] Diagramme [image] beiLinksGeklickterGraphMaus
beiGraphMausLinksLosgelassen beiGraphMausMitteLosgelassen

beiLinksGeklickterGraphMaus agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig knopf rauf (=release) Ereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseRightUp GraphCurrent [schreibe [rauf!]]

Reference:

    Release Notes für Version 4.685

beiGraphMausLinksLosgelassen beiGraphMausMitteLosgelassen


HC / GUI Programmierung / Diagramme / beiGraphMausMitteLosgelassen

beiGraphMausMitteLosgelassen

HC [image] GUI Programmierung [image] Diagramme [image] beiGraphMausMitteLosgelassen
beiLinksGeklickterGraphMaus beiGraphMausLinksDoppelKlick

beiGraphMausMitteLosgelassen agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mausmittel-Knopf Rauf (=release) Ereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseMiddleUp GraphCurrent [schreibe [rauf!]]

Reference:

    Release Notes für Version 4.685

beiLinksGeklickterGraphMaus beiGraphMausLinksDoppelKlick


HC / GUI Programmierung / Diagramme / beiGraphMausLinksDoppelKlick

beiGraphMausLinksDoppelKlick

HC [image] GUI Programmierung [image] Diagramme [image] beiGraphMausLinksDoppelKlick
beiGraphMausMitteLosgelassen beiGraphMausRechtsDoppelKlick

beiGraphMausLinksDoppelKlick agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Link-Knopf Doppelt-Klick-Ereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseLeftDClick GraphCurrent [schreibe [doubleclick!]]

Reference:

    Release Notes für Version 4.685

beiGraphMausMitteLosgelassen beiGraphMausRechtsDoppelKlick


HC / GUI Programmierung / Diagramme / beiGraphMausRechtsDoppelKlick

beiGraphMausRechtsDoppelKlick

HC [image] GUI Programmierung [image] Diagramme [image] beiGraphMausRechtsDoppelKlick
beiGraphMausLinksDoppelKlick beiGraphMausMitteDoppelKlick

beiGraphMausRechtsDoppelKlick agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für eine Maus richtig Knopf Doppeltklickereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseRightDClick GraphCurrent [schreibe [doubleclick!]]

Reference:

    Release Notes für Version 4.685

beiGraphMausLinksDoppelKlick beiGraphMausMitteDoppelKlick


HC / GUI Programmierung / Diagramme / beiGraphMausMitteDoppelKlick

beiGraphMausMitteDoppelKlick

HC [image] GUI Programmierung [image] Diagramme [image] beiGraphMausMitteDoppelKlick
beiGraphMausRechtsDoppelKlick beiGraphMausBewegung

beiGraphMausMitteDoppelKlick agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Maus Mitten-Knopf Doppeltklickereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseMiddleDClick GraphCurrent [schreibe [doubleclick!]]

Reference:

    Release Notes für Version 4.685

beiGraphMausRechtsDoppelKlick beiGraphMausBewegung


HC / GUI Programmierung / Diagramme / beiGraphMausBewegung

beiGraphMausBewegung

HC [image] GUI Programmierung [image] Diagramme [image] beiGraphMausBewegung
beiGraphMausMitteDoppelKlick Rahmen-Fenster

beiGraphMausBewegung agraph Befehle

Dieser Kommando setzt den Logo-Ereignisroutine für ein Mausbewegungsereignis des Diagramm-Fenster Agraph.

Beispiel:

GraphOnMouseMotion GraphCurrent [setzeOrtXYZ Mausort  erneuereGraph]

Reference:

    Release Notes für Version 4.685

beiGraphMausMitteDoppelKlick Rahmen-Fenster


HC / GUI Programmierung / Rahmen-Fenster

Rahmen-Fenster

HC [image] GUI Programmierung [image] Rahmen-Fenster
beiGraphMausBewegung Gestell

Rahmen-Fenster

...sind Fenster, die normalerweise einen Rand außenherum haben, und meistens eine Titel-Leiste, möglicherweise mit einem System-Menü darauf. Sie können Anzeigen, Steuerelemente, oder Graphen in einen Rahmen platzieren, mit dem Rahmen als Elternteil des Elements.

Rahmen werden im Beispiel frametest.lg gezeigt.

Rahmen-Fenster

  • Gestell
  • zumGestellDazu
  • zerstöreGestell


HC / GUI Programmierung / Rahmen-Fenster / Gestell

Gestell

HC [image] GUI Programmierung [image] Rahmen-Fenster [image] Gestell
Rahmen-Fenster zumGestellDazu

Gestell ausrichten

Ausgaben ein neues Gestell mit dem orientierung ausrichten.

richten Sie aus können jedes wxHORIZONTAL oder wxVERTICAL sein.

Beispiele:

f=(Fenster [][MyFrame]
    wxFrame_Tool_Window+wxCaption+wxClose_Box
    +wxSystem_Menu+wxResize_Border+wxTab_traversal+wxStay_on_Top
    [200 200][-1 -1])
bfd=(Knopf f [&vorwärts]
[	vorwärts 100
    erneuereGraph
])
blt=(Knopf f [&links]
[	links 30
    erneuereGraph
])
brt=(Knopf f [&rechts]
[	rechts 30
    erneuereGraph
])
bbk=(Knopf f [&zurück]
[	zurück 100
    erneuereGraph
])
bs=Gestell wxVertical
zumBoxSizerDazu bs bfd 100 wxExpand 0
bsrl=Gestell wxHorizontal
zumBoxSizerDazu bsrl blt 100 wxExpand 0
zumBoxSizerDazu bsrl brt 100 wxExpand 0
zumBoxSizerDazu bs bsrl 100 wxExpand 0
zumBoxSizerDazu bs bbk 100 wxExpand 0
setzeFenstersizer f bs

Example:

  • setzeFenstersizer

References:

    zumGestellDazu(5), setzeFenstersizer(2), Release Notes für Version 4.685, zerstöreGestell

Rahmen-Fenster zumGestellDazu


HC / GUI Programmierung / Rahmen-Fenster / zumGestellDazu

zumGestellDazu

HC [image] GUI Programmierung [image] Rahmen-Fenster [image] zumGestellDazu
Gestell zerstöreGestell

zumGestellDazu aGestell acontrol Verhältnis flags Rand

Befehlt dem Gestell aGestell, das Kontroll acontrol hinzuzufügen.

Verhältnis zeigt an, wenn ein Kind eines sizer kann Größe im großen und ganzen orientierung des Gestell verändern - 0 steht für Nicht Veränderbar-Und wird ein Wert von mehr als null Verwandter im Wert von anderen Kindern des gleichen Gestell interpretiert. Zum Beispiel könnten Sie eine Horizontale Gestell mit drei Kindern haben, zwei von denen gemeint wird, dass man ihre Größe mit dem sizer verändert. Dann würden die zwei stretchable Fenster einen Wert von 1 jeweils zu setze bekommen sie und anpflanzen ebenso mit der horizontalen Abmessung des sizer schrumpfen. Als ein anderes Beispiel können Sie ein Gestell mit zwei Kindern davon haben, wen die erstes 150 % der Größe der Sekunde sein werden, Sie dann das erstes Kind mit einem Verhältnis hinzufügen würden, von 150, und das zweite Kind mit einem Verhältnis von 100.

Flag kann benutzt werden um eine Anzahl von Flags zu setzen, die bei der Benutzung der binären oder verbunden werden können, BitOder (oder + in den meisten Fällen). Zwei Hauptverhalten werden bei der Benutzung dieser Flags definiert. Eins ist die Rand um ein Fenster: der Grenzparameter bestimmt die Grenzbreite während die hier bestimmten Flags bestimmen welches side(s) des Elements, das die Rand hinzugefügt werden wird. Die anderen Flags bestimmen wie das Sizer Element sich benimmt wenn der dem sizer zugeteilte Platz sich ändert, und ist etwas abhängig von der Einzelheit, die irgendwie sizer benutzte.

wxTOP

wxBOTTOM

wxLEFT

wxRIGHT

wxALL Diese Flags werden benutzt zu spezifizieren welches side(s) des Sizer Elements die Grenzbreite wirst wendeAn zu.

wxEXPAND Das Element wird zu fülle expandiert werden, das der Platz dem Gegenstand zuwies.

wxSHAPED Das Element wird als viel so mögliches auch Abbildungsmaßstab aufrechterhaltend solange expandiert werden

wxFIXED_MINSIZE, das Normalerweise wxSizers GetAdjustedBestSize benutzen wird um zu entscheiden was die Minimalgröße von Fenster elemente sein sollte, und wird jene Größe benutzen um die Layout zu kalkulieren. Dies ermöglicht Layouts sich einzustellen, wenn ein Element und verändert das beste Größe wird, unterschiedlich. Wenn Sie lieber dann ein Fenster Element die Größe bleiben ließen, mit der es anfing, Verwendung wxFIXED_MINSIZE.

wxALIGN_CENTER

wxALIGN_LEFT

wxALIGN_RIGHT

wxALIGN_TOP

wxALIGN_BOTTOM

wxALIGN_CENTER_VERTICAL

wxALIGN_CENTER_HORIZONTAL, das Ihnen Die wxALIGN Flags erlauben die Ausrichtung des Elements innerhalb des dazu vom sizer zugeteilten Platzes zu spezifizieren, stellte sich für das Grenz-Wenn ein überhaupt.

Reference:

    Release Notes für Version 4.685

Gestell zerstöreGestell


HC / GUI Programmierung / Rahmen-Fenster / zerstöreGestell

zerstöreGestell

HC [image] GUI Programmierung [image] Rahmen-Fenster [image] zerstöreGestell
zumGestellDazu Knöpfe

zerstöreGestell aGestell

Kommando, das Gestell aGestell zu zerstören.

Reference:

    Release Notes für Version 4.685

zumGestellDazu Knöpfe


HC / GUI Programmierung / Knöpfe

Knöpfe

HC [image] GUI Programmierung [image] Knöpfe
zerstöreGestell Knopf

Knöpfe

...sind kleine Fenster die einen kurzen Text enthalten, und die eine Logo-Befehlsliste ausführen, wenn der Benutzer mit der Maus auf sie klickt. Ein guter Startpunkt, um die KnopfXXX-Grundwörter auszuprobieren, ist buttontest.lg.

Knöpfe

  • Knopf
  • zerstöreKnopf
  • beiKnopfdruck
  • KnopfAn

References:

    Diagramm, Meldungsbox

zerstöreGestell Knopf


HC / GUI Programmierung / Knöpfe / Knopf

Knopf

HC [image] GUI Programmierung [image] Knöpfe [image] Knopf
Knöpfe zerstöreKnopf

Knopf Elternteil Alabel Onclick
(Knopf Elternteil Alabel Onclick Stil Apos Größe)

Ausgaben ein neuer Knopf auf dem Elternteil (ein Fenster Oder ein Diagramm),

das Text alabel darauf haben,

und, das das onclick instructionlist laufen lässt, wenn der Benutzer mit der Maus darauf klickt.

Examples:

  • setzeFensterHintergundfarbe
  • setzeFensterSchriftdicke
  • setzeFensterSchriftgröße
  • setzeFensterSchriftname
  • setzeFensterSchriftstil
  • setzeInnereFenstergröße
  • setzeFenstersizer
  • settFensterform
  • beiKnopfdruck
  • zerstöreKnopf
  • FensterAn
  • Gestell
  • KnopfAn

References:

    KnopfAn(5), Gestell(4), Maustasten(4), FensterAn(3), beiKnopfdruck(3), setzeFenstersizer(3), Release Notes für Version 4.685(2), zerstöreKnopf(2), GanzzahlBoxen, GraphOnMouseLeftDown, RadioButtons, ToggleButtons, beiGraphMausLinksDoppelKlick, beiGraphMausLinksLosgelassen, beiGraphMausMitteDoppelKlick, beiGraphMausMitteLosgelassen, beiGraphMausRechtsDoppelKlick, beiLinksDoppeltGeklickterTextmaus, beiLinksDoppeltgeklickerMaus, beiLinksGeklickterGraphMaus, beiLinksGeklickterTextmaus, beiLinksLosgelasserMaus, beiMitteDoppeltgeklickerMaus, beiMitteDoppeltgeklickterTextmaus, beiMitteGeklickterGraphMaus, beiMitteGeklickterMaus, beiMitteGeklickterTextmaus, beiMitteLosgelasserMaus, beiRechtsDoppeltgeklickerMaus, beiRechtsDoppeltgeklickterTextmaus, beiRechtsGeklickterGraphMaus, beiRechtsGeklickterMaus, beiRechtsGeklickterTextmaus, beiRechtsLosgelasserMaus, beiTextMausLinksLosgelassen, beiTextMausMitteLosgelassen, beiTextMausRechtsLosgelassen, settFensterform, setzeFensterHintergundfarbe, setzeFensterSchriftdicke, setzeFensterSchriftgröße, setzeFensterSchriftname, setzeFensterSchriftstil, setzeInnereFenstergröße

Knöpfe zerstöreKnopf


HC / GUI Programmierung / Knöpfe / zerstöreKnopf

zerstöreKnopf

HC [image] GUI Programmierung [image] Knöpfe [image] zerstöreKnopf
Knopf beiKnopfdruck

zerstöreKnopf abutton

zerstört das Knopf Abutton.

Beispiel:

bfd=Knopf [][Go!][vorwärts 100 erneuereGraph]
zerstöreKnopf bfd


HC / GUI Programmierung / Knöpfe / beiKnopfdruck

beiKnopfdruck

HC [image] GUI Programmierung [image] Knöpfe [image] beiKnopfdruck
zerstöreKnopf KnopfAn

beiKnopfdruck abutton instructionlist

setzt der onClick Ereignisroutine des Knopf Abutton zu den Kommandos im Befehlsliste.

Beispiele:

bfd=Knopf [][Go!][vorwärts 100 erneuereGraph]
beiKnopfdruck bfd [vorwärts 10 erneuereGraph]	;slow motion!
beiKnopfdruck bfd []	;like disabling the Knopf


HC / GUI Programmierung / Knöpfe / KnopfAn

KnopfAn

HC [image] GUI Programmierung [image] Knöpfe [image] KnopfAn
beiKnopfdruck CheckBoxen

KnopfAn abutton Staat

Wenn Staat ist wahr dann ermöglicht es das Knopf Abutton, ist Wenn Staat falsch dann sperrt es den Knopf.

Beispiel:

bfd=Knopf [][Go!][vorwärts 100 erneuereGraph]
;Click on the Knopf - it goes
KnopfAn bfd falsch
;Click on the Knopf again --nothing happens
KnopfAn bfd wahr	;enabled again


HC / GUI Programmierung / CheckBoxen

CheckBoxen

HC [image] GUI Programmierung [image] CheckBoxen
KnopfAn Ankreuzbox

CheckBoxen

...sind kleine Fenster, die Überprüfungsboxen Und enthalten und ein ProzedurText-IgelText, den können führeAus ein Logo-Befehlsliste wenn der Benutzer mit der Maus auf sie klickt unüberprüft sie Und Überprüfungs-Oder. CheckBoxes werden in buttontest.lg. demonstriert

CheckBoxen

  • Ankreuzbox
  • ZerstöreAnkreuzbox
  • beiGeklickterAnkreuzbox
  • AnkreuzboxWert
  • setzeAnkreuzbox
  • AnkreuzboxAn


HC / GUI Programmierung / CheckBoxen / Ankreuzbox

Ankreuzbox

HC [image] GUI Programmierung [image] CheckBoxen [image] Ankreuzbox
CheckBoxen ZerstöreAnkreuzbox

Ankreuzbox Elternteil Alabel Onclick
(Ankreuzbox Elternteil Alabel Onclick Stil Apos Größe)

Ausgaben ein neuer Ankreuzbox auf dem Elternteil (ein Fenster Oder ein Diagramm),

das Text alabel darauf haben,

und, das das onclick instructionlist laufen lässt, wenn der Benutzer mit der Maus darauf klickt.

Examples:

  • beiGeklickterAnkreuzbox
  • ZerstöreAnkreuzbox
  • setzeAnkreuzbox
  • AnkreuzboxWert
  • AnkreuzboxAn

References:

    AnkreuzboxAn(3), beiGeklickterAnkreuzbox(3), AnkreuzboxWert(2), Release Notes für Version 4.685(2), ZerstöreAnkreuzbox(2), setzeAnkreuzbox(2)

CheckBoxen ZerstöreAnkreuzbox


HC / GUI Programmierung / CheckBoxen / ZerstöreAnkreuzbox

ZerstöreAnkreuzbox

HC [image] GUI Programmierung [image] CheckBoxen [image] ZerstöreAnkreuzbox
Ankreuzbox beiGeklickterAnkreuzbox

ZerstöreAnkreuzbox acheckbox

Kommando, der das Ankreuzbox Acheckbox zerstört.

Beispiel:

cbht=Ankreuzbox [][Hide Igel][
    wennsonst AnkreuzboxWert cbht [versteckeIgel][zeigIgel]
    erneuereGraph]
ZerstöreAnkreuzbox cbht

Reference:

    Release Notes für Version 4.685

Ankreuzbox beiGeklickterAnkreuzbox


HC / GUI Programmierung / CheckBoxen / beiGeklickterAnkreuzbox

beiGeklickterAnkreuzbox

HC [image] GUI Programmierung [image] CheckBoxen [image] beiGeklickterAnkreuzbox
ZerstöreAnkreuzbox AnkreuzboxWert

beiGeklickterAnkreuzbox acheckbox instructionlist

Kommando, der den onClick Ereignisroutine des Ankreuzbox Acheckbox zu den Kommandos im Befehlsliste setzt.

Beispiele:

cb=Ankreuzbox [][Hide Igel][
    wennsonst AnkreuzboxWert cb [versteckeIgel][zeigIgel]
    erneuereGraph]
beiGeklickterAnkreuzbox cb [
    wennsonst AnkreuzboxWert cb [schreibe [Yes, Sir!]][schreibe [No, Sir!]]
    erneuereGraph]
beiGeklickterAnkreuzbox cb []	;like disabling the Ankreuzbox

Reference:

    Release Notes für Version 4.685

ZerstöreAnkreuzbox AnkreuzboxWert


HC / GUI Programmierung / CheckBoxen / AnkreuzboxWert

AnkreuzboxWert

HC [image] GUI Programmierung [image] CheckBoxen [image] AnkreuzboxWert
beiGeklickterAnkreuzbox setzeAnkreuzbox

AnkreuzboxWert acheckbox

Ausgaben-Wahr Wenn der Ankreuzbox acheckbox wird überprüft, falsch sonst.

Beispiel:

cb=Ankreuzbox [][Hide Igel][
    wennsonst AnkreuzboxWert cb [versteckeIgel][zeigIgel]
    erneuereGraph]

Examples:

  • beiGeklickterAnkreuzbox
  • ZerstöreAnkreuzbox
  • setzeAnkreuzbox
  • AnkreuzboxAn

References:

    beiGeklickterAnkreuzbox(2), AnkreuzboxAn, Release Notes für Version 4.685, ZerstöreAnkreuzbox, setzeAnkreuzbox

beiGeklickterAnkreuzbox setzeAnkreuzbox


HC / GUI Programmierung / CheckBoxen / setzeAnkreuzbox

setzeAnkreuzbox

HC [image] GUI Programmierung [image] CheckBoxen [image] setzeAnkreuzbox
AnkreuzboxWert AnkreuzboxAn

setzeAnkreuzbox acheckbox Staat

Kommando, den setzt das Ankreuzbox Acheckbox zu überprüftem wenn angeben, ist wahr, zu ungehemmtem wenn nicht wahr.

Zustand muss ein boolesch sein.

Beispiel:

cb=Ankreuzbox [][Hide Igel][
    wennsonst AnkreuzboxWert cb [versteckeIgel][zeigIgel]
    erneuereGraph]
setzeAnkreuzbox bc sichtbar?

Reference:

    Release Notes für Version 4.685

AnkreuzboxWert AnkreuzboxAn


HC / GUI Programmierung / CheckBoxen / AnkreuzboxAn

AnkreuzboxAn

HC [image] GUI Programmierung [image] CheckBoxen [image] AnkreuzboxAn
setzeAnkreuzbox ChoiceBoxes

AnkreuzboxAn acheckbox Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das Ankreuzbox Acheckbox, ist Wenn Staat falsch dann sperrt es das CheckBox.

Zustand muss ein boolesch sein.

Beispiel:

cb=Ankreuzbox [][Hide Igel][
    wennsonst AnkreuzboxWert cb [versteckeIgel][zeigIgel]
    erneuereGraph]
AnkreuzboxAn bfd falsch
;Click on the Ankreuzbox again --nothing happens
AnkreuzboxAn bfd wahr	;enabled again

Reference:

    Release Notes für Version 4.685

setzeAnkreuzbox ChoiceBoxes


HC / GUI Programmierung / ChoiceBoxes

ChoiceBoxes

HC [image] GUI Programmierung [image] ChoiceBoxes
AnkreuzboxAn Auswahlbox

ChoiceBoxes

...sind Fenster die ein ProzedurText IgelText haben und enthaltend ein pulldown menulike liste von Text Optionen, den können führeAus ein Logo-Befehlsliste wenn der Benutzer mit der Maus auf sie klickt wählt und eine Wahl aus, und wenn ein Schlüsselereignis bekommen wird. Die entsprechende Demo ist choiceboxtest.lg.

ChoiceBoxes

  • Auswahlbox
  • zerstöreAuswahlbox
  • AuswahlboxAuswahl
  • setzeAuswahlboxAuswahl
  • setzeAuswahlboxMöglichkeiten
  • zurAuswahlboxDazu
  • setzeAuswahlboxElement
  • entferneAuswahlboxElement
  • zähleAuswahlbox
  • setzeAuswahlboxHintergrundfarbe
  • setzeAuswahlboxFarbe
  • setzeAuswahlboxSchriftgröße
  • setzeAuswahlboxSchriftname
  • setzeAuswahlboxSchriftstil
  • setzeAuswahlboxSchriftdicke
  • beiZeichenInAuswahlbox
  • beiGedrückterTasteInAuswahlbox
  • beiLosgelassenerTasteInAuswahlbox
  • beiAuswahlboxAuswahl
  • AuswahlboxAn


HC / GUI Programmierung / ChoiceBoxes / Auswahlbox

Auswahlbox

HC [image] GUI Programmierung [image] ChoiceBoxes [image] Auswahlbox
ChoiceBoxes zerstöreAuswahlbox

Auswahlbox Elternteil Optionen onSelect nennen
(Auswahlbox Elternteil Namens Options onSelect Stil Ort Größe)

Ausgaben ein neues Auswahlbox Und zeigt es auf dem Elternteil (ein Fenster Oder ein Diagramm, Haupt-Diagramm-Wenn []). Im Gegensatz zu einem listenbox ist nur die Auswahl sichtbares bis das Benutzerzüge-Runter die Menü von Optionen.

Name ist Igeltext ProzedurText.

Optionen ist ein Liste von elemente, aus dem der Benutzer einen auswählen kann.

onSelect ist ein Logo-Befehlsliste, das führeAus sein wird, wenn der Benutzer eine Wahl auswählt.

Stil ist der Fenster Stil, nichts besonderes hier, vernachlässigt es zu null.

ort ist die Position des Auswahlbox' (ein Liste zweier integrer Zahlen, x und y),

Größe ist die Größe des Auswahlbox' (ein Liste zweier integrer Zahlen, Breiten-Und Höhe).

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])

Examples:

  • beiLosgelassenerTasteInAuswahlbox
  • setzeAuswahlboxHintergrundfarbe
  • beiGedrückterTasteInAuswahlbox
  • setzeAuswahlboxMöglichkeiten
  • setzeAuswahlboxSchriftdicke
  • setzeAuswahlboxSchriftgröße
  • setzeAuswahlboxSchriftname
  • setzeAuswahlboxSchriftstil
  • entferneAuswahlboxElement
  • beiZeichenInAuswahlbox
  • setzeAuswahlboxAuswahl
  • setzeAuswahlboxElement
  • beiAuswahlboxAuswahl
  • setzeAuswahlboxFarbe
  • zerstöreAuswahlbox
  • AuswahlboxAuswahl
  • zurAuswahlboxDazu
  • zähleAuswahlbox
  • AuswahlboxAn

References:

    AuswahlboxAn(3), AuswahlboxAuswahl(3), Release Notes für Version 4.685(2), beiAuswahlboxAuswahl(2), beiGedrückterTasteInAuswahlbox(2), beiLosgelassenerTasteInAuswahlbox(2), beiZeichenInAuswahlbox(2), entferneAuswahlboxElement(2), setzeAuswahlboxAuswahl(2), setzeAuswahlboxElement(2), setzeAuswahlboxFarbe(2), setzeAuswahlboxHintergrundfarbe(2), setzeAuswahlboxMöglichkeiten(2), setzeAuswahlboxSchriftdicke(2), setzeAuswahlboxSchriftgröße(2), setzeAuswahlboxSchriftname(2), setzeAuswahlboxSchriftstil(2), zerstöreAuswahlbox(2), zurAuswahlboxDazu(2), zähleAuswahlbox(2)

ChoiceBoxes zerstöreAuswahlbox


HC / GUI Programmierung / ChoiceBoxes / zerstöreAuswahlbox

zerstöreAuswahlbox

HC [image] GUI Programmierung [image] ChoiceBoxes [image] zerstöreAuswahlbox
Auswahlbox AuswahlboxAuswahl

zerstöreAuswahlbox achoicebox

Kommando, der das Auswahlbox Achoicebox zerstört.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
zerstöreAuswahlbox cb

Reference:

    Release Notes für Version 4.685

Auswahlbox AuswahlboxAuswahl


HC / GUI Programmierung / ChoiceBoxes / AuswahlboxAuswahl

AuswahlboxAuswahl

HC [image] GUI Programmierung [image] ChoiceBoxes [image] AuswahlboxAuswahl
zerstöreAuswahlbox setzeAuswahlboxAuswahl

AuswahlboxAuswahl (AuswahlboxAuswahl achoicebox)

Ausgaben die Auswahl des Auswahlbox Achoicebox, ohne ein Argument angerufenen oder wenn, des Auswahlbox', das das letztes OnSelect Ereignis bearbeitete.

Der Ausgangswert ist eine null-basierte Ganzzahl, bei der Repräsentation der nten Wahl.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])

Examples:

  • beiLosgelassenerTasteInAuswahlbox
  • setzeAuswahlboxHintergrundfarbe
  • beiGedrückterTasteInAuswahlbox
  • setzeAuswahlboxMöglichkeiten
  • setzeAuswahlboxSchriftdicke
  • setzeAuswahlboxSchriftgröße
  • setzeAuswahlboxSchriftname
  • setzeAuswahlboxSchriftstil
  • entferneAuswahlboxElement
  • beiZeichenInAuswahlbox
  • setzeAuswahlboxAuswahl
  • setzeAuswahlboxElement
  • beiAuswahlboxAuswahl
  • setzeAuswahlboxFarbe
  • zerstöreAuswahlbox
  • zurAuswahlboxDazu
  • zähleAuswahlbox
  • AuswahlboxAn
  • Auswahlbox

References:

    beiAuswahlboxAuswahl(2), Auswahlbox, AuswahlboxAn, Release Notes für Version 4.685, beiGedrückterTasteInAuswahlbox, beiLosgelassenerTasteInAuswahlbox, beiZeichenInAuswahlbox, entferneAuswahlboxElement, setzeAuswahlboxAuswahl, setzeAuswahlboxElement, setzeAuswahlboxFarbe, setzeAuswahlboxHintergrundfarbe, setzeAuswahlboxMöglichkeiten, setzeAuswahlboxSchriftdicke, setzeAuswahlboxSchriftgröße, setzeAuswahlboxSchriftname, setzeAuswahlboxSchriftstil, zerstöreAuswahlbox, zurAuswahlboxDazu, zähleAuswahlbox

zerstöreAuswahlbox setzeAuswahlboxAuswahl


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxAuswahl

setzeAuswahlboxAuswahl

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxAuswahl
AuswahlboxAuswahl setzeAuswahlboxMöglichkeiten

setzeAuswahlboxAuswahl achoicebox Auswahl

Befehlen Sie der Wertauswahl, die Auswahl des Auswahlbox Achoicebox zu setzen.

Auswahl ist ein null-basiertes integres Register in die Optionen, die weniger sein müssen als die Anzahl von Optionen in der Kontrolle.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxAuswahl cb 2

Reference:

    Release Notes für Version 4.685

AuswahlboxAuswahl setzeAuswahlboxMöglichkeiten


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxMöglichkeiten

setzeAuswahlboxMöglichkeiten

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxMöglichkeiten
setzeAuswahlboxAuswahl zurAuswahlboxDazu

setzeAuswahlboxMöglichkeiten achoicebox Optionen

Kommando, das inhalt des Auswahlbox Achoicebox zu Optionen zu setzen.

Optionen müssen ein Liste von elemente sein, dessen Texte die Optionen im ChoiceBox sein werden.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox][]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxMöglichkeiten cb [
    [String 1]
    [und a second string]
    [und the letztes string]
]

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxAuswahl zurAuswahlboxDazu


HC / GUI Programmierung / ChoiceBoxes / zurAuswahlboxDazu

zurAuswahlboxDazu

HC [image] GUI Programmierung [image] ChoiceBoxes [image] zurAuswahlboxDazu
setzeAuswahlboxMöglichkeiten setzeAuswahlboxElement

zurAuswahlboxDazu achoicebox Wahl

Kommando, das Text der Wert Wahl an die Optionen von Auswahlbox Achoicebox anzuhängen.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
zurAuswahlboxDazu cb [und the letztes string]

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxMöglichkeiten setzeAuswahlboxElement


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxElement

setzeAuswahlboxElement

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxElement
zurAuswahlboxDazu entferneAuswahlboxElement

setzeAuswahlboxElement achoicebox Registerwahl

Befehlen Sie dem Text der Wert Wahl, das Element an Positionsregister des Auswahlbox Achoicebox zu verändern.

Register muss eine integre Zahlen Register->= 0 und-Register-<-Anzahl von Optionen im ChoiceBox sein.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxElement cb 1 [a changed element]

Reference:

    Release Notes für Version 4.685

zurAuswahlboxDazu entferneAuswahlboxElement


HC / GUI Programmierung / ChoiceBoxes / entferneAuswahlboxElement

entferneAuswahlboxElement

HC [image] GUI Programmierung [image] ChoiceBoxes [image] entferneAuswahlboxElement
setzeAuswahlboxElement zähleAuswahlbox

entferneAuswahlboxElement achoicebox Register

Befehlen Sie entferne das auserlesene Element an Positionsregister vom Auswahlbox Achoicebox.

Register muss eine integre Zahlen Register->= 0 und-Register-<-Anzahl von Optionen im ChoiceBox sein.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
entferneAuswahlboxElement cb 1

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxElement zähleAuswahlbox


HC / GUI Programmierung / ChoiceBoxes / zähleAuswahlbox

zähleAuswahlbox

HC [image] GUI Programmierung [image] ChoiceBoxes [image] zähleAuswahlbox
entferneAuswahlboxElement setzeAuswahlboxHintergrundfarbe

zähleAuswahlbox achoicebox

Ausgaben die Anzahl von Optionen im Auswahlbox Achoicebox.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
zeige zähleAuswahlbox cb

Reference:

    Release Notes für Version 4.685

entferneAuswahlboxElement setzeAuswahlboxHintergrundfarbe


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxHintergrundfarbe

setzeAuswahlboxHintergrundfarbe

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxHintergrundfarbe
zähleAuswahlbox setzeAuswahlboxFarbe

setzeAuswahlboxHintergrundfarbe achoicebox Farbe

Befehlen Sie der Farbfarbe, die Hintergrundfarbe des Auswahlbox Achoicebox zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxHintergrundfarbe cb "red

Reference:

    Release Notes für Version 4.685

zähleAuswahlbox setzeAuswahlboxFarbe


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxFarbe

setzeAuswahlboxFarbe

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxFarbe
setzeAuswahlboxHintergrundfarbe setzeAuswahlboxSchriftgröße

setzeAuswahlboxFarbe achoicebox Farbe

Befehlen Sie der Farbfarbe, die Vordergrundfarbe des Auswahlbox Achoicebox zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxFarbe cb "red

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxHintergrundfarbe setzeAuswahlboxSchriftgröße


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxSchriftgröße

setzeAuswahlboxSchriftgröße

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxSchriftgröße
setzeAuswahlboxFarbe setzeAuswahlboxSchriftname

setzeAuswahlboxSchriftgröße achoicebox Größe

Kommando, die Schrifthöhe des zu messenden Auswahlbox Achoicebox zu setzen, das eine integre Zahl sein muss.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxSchriftgröße cb 50

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxFarbe setzeAuswahlboxSchriftname


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxSchriftname

setzeAuswahlboxSchriftname

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxSchriftname
setzeAuswahlboxSchriftgröße setzeAuswahlboxSchriftstil

setzeAuswahlboxSchriftname achoicebox Name

Kommando, den Schriftnamen des zu nennenden Auswahlbox Achoicebox zu setzen, das ein plausibler Schriftname sein muss.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxSchriftname cb [Courier]

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxSchriftgröße setzeAuswahlboxSchriftstil


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxSchriftstil

setzeAuswahlboxSchriftstil

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxSchriftstil
setzeAuswahlboxSchriftname setzeAuswahlboxSchriftdicke

setzeAuswahlboxSchriftstil achoicebox Stil

Kommando, den Schriftstil des Auswahlbox Achoicebox zu setzen.

Stil kann eine der Konstanten wxFONTSTYLE_NORMAL wxFONTSTYLE_SLANT wxFONTSTYLE_ITALIC sein.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxSchriftstil cb wxFONTSTYLE_ITALIC

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxSchriftname setzeAuswahlboxSchriftdicke


HC / GUI Programmierung / ChoiceBoxes / setzeAuswahlboxSchriftdicke

setzeAuswahlboxSchriftdicke

HC [image] GUI Programmierung [image] ChoiceBoxes [image] setzeAuswahlboxSchriftdicke
setzeAuswahlboxSchriftstil beiZeichenInAuswahlbox

setzeAuswahlboxSchriftdicke achoicebox Gewicht

Kommando, das Schriftgewicht des Auswahlbox Achoicebox zu setzen.

Gewicht kann eine der Konstanten wxFONTWEIGHT_NORMAL wxFONTWEIGHT_LIGHT wxFONTWEIGHT_BOLD sein

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
setzeAuswahlboxSchriftdicke cb wxFONTWEIGHT_BOLD

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxSchriftstil beiZeichenInAuswahlbox


HC / GUI Programmierung / ChoiceBoxes / beiZeichenInAuswahlbox

beiZeichenInAuswahlbox

HC [image] GUI Programmierung [image] ChoiceBoxes [image] beiZeichenInAuswahlbox
setzeAuswahlboxSchriftdicke beiGedrückterTasteInAuswahlbox

beiZeichenInAuswahlbox achoicebox Befehle

Kommando, den Gewohnheitsereignisführer für das Zeichen Ereignis des Auswahlbox Achoicebox zu zu setzen, befiehlt. Sehen Sie auch beiZeichen!

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
beiZeichenInAuswahlbox cb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

setzeAuswahlboxSchriftdicke beiGedrückterTasteInAuswahlbox


HC / GUI Programmierung / ChoiceBoxes / beiGedrückterTasteInAuswahlbox

beiGedrückterTasteInAuswahlbox

HC [image] GUI Programmierung [image] ChoiceBoxes [image] beiGedrückterTasteInAuswahlbox
beiZeichenInAuswahlbox beiLosgelassenerTasteInAuswahlbox

beiGedrückterTasteInAuswahlbox achoicebox Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Runter Ereignis des Auswahlbox Achoicebox zu zu setzen, befiehlt. Sehen Sie auch beiGedrückterTaste!

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
beiGedrückterTasteInAuswahlbox cb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiZeichenInAuswahlbox beiLosgelassenerTasteInAuswahlbox


HC / GUI Programmierung / ChoiceBoxes / beiLosgelassenerTasteInAuswahlbox

beiLosgelassenerTasteInAuswahlbox

HC [image] GUI Programmierung [image] ChoiceBoxes [image] beiLosgelassenerTasteInAuswahlbox
beiGedrückterTasteInAuswahlbox beiAuswahlboxAuswahl

beiLosgelassenerTasteInAuswahlbox achoicebox Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Rauf zu setzen (=release), Ereignis des Auswahlbox Achoicebox zu Kommandos. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
beiLosgelassenerTasteInAuswahlbox cb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiGedrückterTasteInAuswahlbox beiAuswahlboxAuswahl


HC / GUI Programmierung / ChoiceBoxes / beiAuswahlboxAuswahl

beiAuswahlboxAuswahl

HC [image] GUI Programmierung [image] ChoiceBoxes [image] beiAuswahlboxAuswahl
beiLosgelassenerTasteInAuswahlbox AuswahlboxAn

beiAuswahlboxAuswahl achoicebox Befehle

Kommando, den Gewohnheitsereignisführer für das auserlesene Ereignis des Auswahlbox Achoicebox zu zu setzen, befiehlt. Das auserlesene Ereignis wird erzeugt wenn der Benutzer eine Wahl mit einem mouseclick oder auswählt ein Tastendruck.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
beiAuswahlboxAuswahl cb [schreibe AuswahlboxAuswahl]

Reference:

    Release Notes für Version 4.685

beiLosgelassenerTasteInAuswahlbox AuswahlboxAn


HC / GUI Programmierung / ChoiceBoxes / AuswahlboxAn

AuswahlboxAn

HC [image] GUI Programmierung [image] ChoiceBoxes [image] AuswahlboxAn
beiAuswahlboxAuswahl KombiBoxen

AuswahlboxAn achoicebox Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das Auswahlbox Achoicebox, ist Wenn Staat falsch dann sperrt es das ChoiceBox.

Zustand muss ein boolesch sein.

Beispiel:

cb=(Auswahlbox [][MyChoiceBox]
[	[String 1]
    [und a second string]
    [und the letztes string]
]
[	(zeige "MyChoiceBox AuswahlboxAuswahl)
])
AuswahlboxAn cb falsch
;Click on the Auswahlbox again --nothing happens
AuswahlboxAn cb wahr	;enabled again

Reference:

    Release Notes für Version 4.685

beiAuswahlboxAuswahl KombiBoxen


HC / GUI Programmierung / KombiBoxen

KombiBoxen

HC [image] GUI Programmierung [image] KombiBoxen
AuswahlboxAn KombiBox

KombiBoxen

Eine KombiBox ist wie eine Kombination von einem Bearbeite Kontroll-Und ein ListBox. Es kann als statisches Liste mit editierbarem Oder Schreibgeschützt-Text Gebiet gezeigt werden; oder ein Tropfen-Runter Liste mit Text Gebiet; oder ein Tropfen-Runter Liste ohne ein Text Gebiet.

Ein KombiBox erlaubt nur eine einzelne Auswahl. KombiBox elemente werden von null nummeriert.

Ein KombiBox können führeAus ein Logo-Befehlsliste wenn der Benutzer mit der Maus an klickt wählt ein Element-Und eine Wahl aus, wenn der Benutzer die Text Oder Pressen verändert [Treten Sie ein], und wenn ein Schlüsselereignis bekommen wird. Die entsprechende Demo ist comboboxtest.lg.

KombiBoxen

  • KombiBox
  • zerstöreKombiBox
  • KombiBoxAuswahl
  • setzeKombiBoxAuswahl
  • setzeKombiBoxMöglichkeiten
  • zurKombiBoxDazu
  • setzeKombiBoxElement
  • entferneKombiBoxElement
  • zähleKombiBox
  • KombiBoxWert
  • setzeKombiBoxWert
  • setzeKombiBoxHintergrundfarbe
  • setzeKombiBoxFarbe
  • setzeKombiBoxSchriftgröße
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • setzeKombiBoxSchriftdicke
  • beiKombiBoxZeichen
  • beiGedrückterTasteInKombiBox
  • beiLosgelassenerTasteInKombiBox
  • beiKombiBoxAuswahl
  • beiKombiBoxÄnderung
  • beiKombiBoxEingabe
  • KombiBoxAn


HC / GUI Programmierung / KombiBoxen / KombiBox

KombiBox

HC [image] GUI Programmierung [image] KombiBoxen [image] KombiBox
KombiBoxen zerstöreKombiBox

KombiBox Elternteil Text Optionen onSelect onChange onEnter
(KombiBox Elternteil Name Text Optionen name)
(KombiBox Elternteil Name Text Optionen onSelect onChange onEnter Stil Ort Größe)

Ausgaben, die es ein neues KombiBox und auf dem Elternteil zeigt (ein Fenster Oder ein Diagramm, Haupt-Diagramm-Wenn []).

Name ist Igeltext ProzedurText.

Text ist das standardmäßige Text, in der Bearbeite Kontrolle geführt, wenn das KombiBox geschaffen wird.

Optionen ist ein Liste von elemente, aus dem der Benutzer einen auswählen kann.

onSelect ist ein Logo-Befehlsliste, das führeAus sein wird, wenn der Benutzer eine Wahl auswählt.

onChange ist ein Logo-Befehlsliste, das führeAus sein wird, wenn der Benutzer das Text in der Bearbeite Kontrolle verändert.

onEnter ist ein Logo-Befehlsliste, das führeAus sein wird wenn der Benutzer drückt, der [Treten Sie ein] Taste.

Examples:

  • beiLosgelassenerTasteInKombiBox
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • setzeKombiBoxMöglichkeiten
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • entferneKombiBoxElement
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • beiKombiBoxÄnderung
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • setzeKombiBoxFarbe
  • setzeKombiBoxWert
  • zerstöreKombiBox
  • KombiBoxAuswahl
  • zurKombiBoxDazu
  • zähleKombiBox
  • KombiBoxWert
  • KombiBoxAn

References:

    KombiBoxAuswahl(4), KombiBoxen(4), KombiBoxAn(3), KombiBoxWert(3), Release Notes für Version 4.685(2), Zahlbox(2), beiGedrückterTasteInKombiBox(2), beiKombiBoxAuswahl(2), beiKombiBoxEingabe(2), beiKombiBoxZeichen(2), beiKombiBoxÄnderung(2), beiLosgelassenerTasteInKombiBox(2), entferneKombiBoxElement(2), setzeKombiBoxAuswahl(2), setzeKombiBoxElement(2), setzeKombiBoxFarbe(2), setzeKombiBoxHintergrundfarbe(2), setzeKombiBoxMöglichkeiten(2), setzeKombiBoxSchriftdicke(2), setzeKombiBoxSchriftgröße(2), setzeKombiBoxSchriftname(2), setzeKombiBoxSchriftstil(2), setzeKombiBoxWert(2), zerstöreKombiBox(2), zurKombiBoxDazu(2), zähleKombiBox(2)

KombiBoxen zerstöreKombiBox


HC / GUI Programmierung / KombiBoxen / zerstöreKombiBox

zerstöreKombiBox

HC [image] GUI Programmierung [image] KombiBoxen [image] zerstöreKombiBox
KombiBox KombiBoxAuswahl

zerstöreKombiBox acombobox

Kommando, der das KombiBox acombobox zerstört.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
zerstöreKombiBox cb

Reference:

    Release Notes für Version 4.685

KombiBox KombiBoxAuswahl


HC / GUI Programmierung / KombiBoxen / KombiBoxAuswahl

KombiBoxAuswahl

HC [image] GUI Programmierung [image] KombiBoxen [image] KombiBoxAuswahl
zerstöreKombiBox setzeKombiBoxAuswahl

KombiBoxAuswahl
(KombiBoxAuswahl acombobox)

Ausgaben die Auswahl des KombiBox acombobox, ohne ein Argument angerufenen oder wenn, des KombiBox, das das letztes KombiBox Ereignis bearbeitete.

Der Ausgangswert ist eine null-basierte Ganzzahl, bei der Repräsentation der nten Wahl.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])

Examples:

  • beiLosgelassenerTasteInKombiBox
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • setzeKombiBoxMöglichkeiten
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • entferneKombiBoxElement
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • beiKombiBoxÄnderung
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • setzeKombiBoxFarbe
  • setzeKombiBoxWert
  • zerstöreKombiBox
  • zurKombiBoxDazu
  • zähleKombiBox
  • KombiBoxWert
  • KombiBoxAn

References:

    beiKombiBoxAuswahl(2), KombiBoxAn, KombiBoxWert, Release Notes für Version 4.685, beiGedrückterTasteInKombiBox, beiKombiBoxEingabe, beiKombiBoxZeichen, beiKombiBoxÄnderung, beiLosgelassenerTasteInKombiBox, entferneKombiBoxElement, setzeKombiBoxAuswahl, setzeKombiBoxElement, setzeKombiBoxFarbe, setzeKombiBoxHintergrundfarbe, setzeKombiBoxMöglichkeiten, setzeKombiBoxSchriftdicke, setzeKombiBoxSchriftgröße, setzeKombiBoxSchriftname, setzeKombiBoxSchriftstil, setzeKombiBoxWert, zerstöreKombiBox, zurKombiBoxDazu, zähleKombiBox

zerstöreKombiBox setzeKombiBoxAuswahl


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxAuswahl

setzeKombiBoxAuswahl

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxAuswahl
KombiBoxAuswahl setzeKombiBoxMöglichkeiten

setzeKombiBoxAuswahl acombobox Auswahl

Befehlen Sie der Wertauswahl, die Auswahl des KombiBox acombobox zu setzen.

Auswahl ist ein null-basiertes integres Register in die Optionen, die weniger sein müssen als die Anzahl von Optionen in der Kontrolle.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxAuswahl cb 1

Reference:

    Release Notes für Version 4.685

KombiBoxAuswahl setzeKombiBoxMöglichkeiten


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxMöglichkeiten

setzeKombiBoxMöglichkeiten

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxMöglichkeiten
setzeKombiBoxAuswahl zurKombiBoxDazu

setzeKombiBoxMöglichkeiten acombobox Optionen

Befehlen Sie Optionen, das inhalt des KombiBox acombobox zu setzen.

Optionen müssen ein Liste von elemente sein, dessen Texte die Optionen im ComboBox sein werden.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string][]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxMöglichkeiten cb [
    [String 1]
    [und a second string]
    [und the letztes string]
]

Reference:

    Release Notes für Version 4.685

setzeKombiBoxAuswahl zurKombiBoxDazu


HC / GUI Programmierung / KombiBoxen / zurKombiBoxDazu

zurKombiBoxDazu

HC [image] GUI Programmierung [image] KombiBoxen [image] zurKombiBoxDazu
setzeKombiBoxMöglichkeiten setzeKombiBoxElement

zurKombiBoxDazu acombobox Wahl

Kommando, das Text der Wert Wahl an die Optionen von KombiBox acombobox anzuhängen.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])

Examples:

  • beiLosgelassenerTasteInKombiBox
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • setzeKombiBoxMöglichkeiten
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • entferneKombiBoxElement
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • beiKombiBoxÄnderung
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • setzeKombiBoxFarbe
  • setzeKombiBoxWert
  • zerstöreKombiBox
  • KombiBoxAuswahl
  • zähleKombiBox
  • KombiBoxWert
  • KombiBoxAn

References:

    KombiBoxAn, KombiBoxAuswahl, KombiBoxWert, Release Notes für Version 4.685, beiGedrückterTasteInKombiBox, beiKombiBoxAuswahl, beiKombiBoxEingabe, beiKombiBoxZeichen, beiKombiBoxÄnderung, beiLosgelassenerTasteInKombiBox, entferneKombiBoxElement, setzeKombiBoxAuswahl, setzeKombiBoxElement, setzeKombiBoxFarbe, setzeKombiBoxHintergrundfarbe, setzeKombiBoxMöglichkeiten, setzeKombiBoxSchriftdicke, setzeKombiBoxSchriftgröße, setzeKombiBoxSchriftname, setzeKombiBoxSchriftstil, setzeKombiBoxWert, zerstöreKombiBox, zähleKombiBox

setzeKombiBoxMöglichkeiten setzeKombiBoxElement


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxElement

setzeKombiBoxElement

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxElement
zurKombiBoxDazu entferneKombiBoxElement

setzeKombiBoxElement acombobox Registerwahl

Befehlen Sie dem Text der Wert Wahl, das Element an Positionsregister des KombiBox acombobox zu verändern.

Register muss ein integres Zahlen Register->= 0 und-Register < sein (Anzahl von Optionen im KombiBox).

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxElement cb 1 [Element 1 now]

Reference:

    Release Notes für Version 4.685

zurKombiBoxDazu entferneKombiBoxElement


HC / GUI Programmierung / KombiBoxen / entferneKombiBoxElement

entferneKombiBoxElement

HC [image] GUI Programmierung [image] KombiBoxen [image] entferneKombiBoxElement
setzeKombiBoxElement zähleKombiBox

entferneKombiBoxElement acombobox Register

Befehlen Sie entferne das auserlesene Element an Positionsregister vom KombiBox acombobox.

Register muss ein integres Zahlen Register->= 0 und-Register < sein (Anzahl von Optionen im KombiBox).

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
entferneKombiBoxElement cb 1

Reference:

    Release Notes für Version 4.685

setzeKombiBoxElement zähleKombiBox


HC / GUI Programmierung / KombiBoxen / zähleKombiBox

zähleKombiBox

HC [image] GUI Programmierung [image] KombiBoxen [image] zähleKombiBox
entferneKombiBoxElement KombiBoxWert

zähleKombiBox acombobox

Ausgaben die Anzahl von Optionen im KombiBox acombobox.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
zeige zähleKombiBox cb

Reference:

    Release Notes für Version 4.685

entferneKombiBoxElement KombiBoxWert


HC / GUI Programmierung / KombiBoxen / KombiBoxWert

KombiBoxWert

HC [image] GUI Programmierung [image] KombiBoxen [image] KombiBoxWert
zähleKombiBox setzeKombiBoxWert

KombiBoxWert
(KombiBoxWert acombobox)

Ausgaben das Text in der Bearbeite Kontrolle vom KombiBox acombobox oder wenn, ohne Argument des KombiBox angerufen, dessen Ereignis neuerdings bearbeitet wird.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])

Examples:

  • beiLosgelassenerTasteInKombiBox
  • setzeKombiBoxHintergrundfarbe
  • beiGedrückterTasteInKombiBox
  • setzeKombiBoxMöglichkeiten
  • setzeKombiBoxSchriftdicke
  • setzeKombiBoxSchriftgröße
  • setzeKombiBoxSchriftname
  • setzeKombiBoxSchriftstil
  • entferneKombiBoxElement
  • setzeKombiBoxAuswahl
  • setzeKombiBoxElement
  • beiKombiBoxÄnderung
  • beiKombiBoxAuswahl
  • beiKombiBoxEingabe
  • beiKombiBoxZeichen
  • setzeKombiBoxFarbe
  • setzeKombiBoxWert
  • zerstöreKombiBox
  • KombiBoxAuswahl
  • zurKombiBoxDazu
  • zähleKombiBox
  • KombiBoxAn

References:

    beiKombiBoxEingabe(3), beiKombiBoxÄnderung(3), KombiBoxAn(2), KombiBoxAuswahl(2), beiGedrückterTasteInKombiBox(2), beiKombiBoxAuswahl(2), beiKombiBoxZeichen(2), beiLosgelassenerTasteInKombiBox(2), entferneKombiBoxElement(2), setzeKombiBoxAuswahl(2), setzeKombiBoxElement(2), setzeKombiBoxFarbe(2), setzeKombiBoxHintergrundfarbe(2), setzeKombiBoxMöglichkeiten(2), setzeKombiBoxSchriftdicke(2), setzeKombiBoxSchriftgröße(2), setzeKombiBoxSchriftname(2), setzeKombiBoxSchriftstil(2), setzeKombiBoxWert(2), zerstöreKombiBox(2), zurKombiBoxDazu(2), zähleKombiBox(2), Release Notes für Version 4.685

zähleKombiBox setzeKombiBoxWert


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxWert

setzeKombiBoxWert

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxWert
KombiBoxWert setzeKombiBoxHintergrundfarbe

setzeKombiBoxWert acombobox Text

Befehlen Sie Text, das in ein wort zuerst umgewandelt werden wird, das Text in der Bearbeite Kontrolle vom KombiBox acombobox zu setzen.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxWert cb [Hallo World!]

Reference:

    Release Notes für Version 4.685

KombiBoxWert setzeKombiBoxHintergrundfarbe


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxHintergrundfarbe

setzeKombiBoxHintergrundfarbe

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxHintergrundfarbe
setzeKombiBoxWert setzeKombiBoxFarbe

setzeKombiBoxHintergrundfarbe acombobox Farbe

Befehlen Sie der Farbfarbe, die Hintergrundfarbe des KombiBox acombobox zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxHintergrundfarbe cb "red

Reference:

    Release Notes für Version 4.685

setzeKombiBoxWert setzeKombiBoxFarbe


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxFarbe

setzeKombiBoxFarbe

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxFarbe
setzeKombiBoxHintergrundfarbe setzeKombiBoxSchriftgröße

setzeKombiBoxFarbe acombobox Farbe

Befehlen Sie der Farbfarbe, die Vordergrundfarbe des KombiBox acombobox zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxFarbe cb "red

Reference:

    Release Notes für Version 4.685

setzeKombiBoxHintergrundfarbe setzeKombiBoxSchriftgröße


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxSchriftgröße

setzeKombiBoxSchriftgröße

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxSchriftgröße
setzeKombiBoxFarbe setzeKombiBoxSchriftname

setzeKombiBoxSchriftgröße acombobox Größe

Kommando, die Schrifthöhe des zu messenden KombiBox acombobox zu setzen, das eine integre Zahl sein muss.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxSchriftgröße cb 50

Reference:

    Release Notes für Version 4.685

setzeKombiBoxFarbe setzeKombiBoxSchriftname


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxSchriftname

setzeKombiBoxSchriftname

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxSchriftname
setzeKombiBoxSchriftgröße setzeKombiBoxSchriftstil

setzeKombiBoxSchriftname acombobox Name

Kommando, den Schriftnamen des zu nennenden KombiBox acombobox zu setzen, das ein plausibler Schriftname sein muss.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxSchriftname cb [Courier]

Reference:

    Release Notes für Version 4.685

setzeKombiBoxSchriftgröße setzeKombiBoxSchriftstil


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxSchriftstil

setzeKombiBoxSchriftstil

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxSchriftstil
setzeKombiBoxSchriftname setzeKombiBoxSchriftdicke

setzeKombiBoxSchriftstil acombobox Stil

Kommando, den Schriftstil des KombiBox acombobox zu setzen.

Stil kann eine der Konstanten wxFONTSTYLE_NORMAL wxFONTSTYLE_SLANT wxFONTSTYLE_ITALIC sein.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxSchriftstil cb wxFONTSTYLE_ITALIC

Reference:

    Release Notes für Version 4.685

setzeKombiBoxSchriftname setzeKombiBoxSchriftdicke


HC / GUI Programmierung / KombiBoxen / setzeKombiBoxSchriftdicke

setzeKombiBoxSchriftdicke

HC [image] GUI Programmierung [image] KombiBoxen [image] setzeKombiBoxSchriftdicke
setzeKombiBoxSchriftstil beiKombiBoxZeichen

setzeKombiBoxSchriftdicke acombobox Gewicht

Kommando, das Schriftgewicht des KombiBox acombobox zu setzen.

Gewicht kann eine der Konstanten wxFONTWEIGHT_NORMAL wxFONTWEIGHT_LIGHT wxFONTWEIGHT_BOLD sein

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
setzeKombiBoxSchriftdicke cb wxFONTWEIGHT_BOLD

Reference:

    Release Notes für Version 4.685

setzeKombiBoxSchriftstil beiKombiBoxZeichen


HC / GUI Programmierung / KombiBoxen / beiKombiBoxZeichen

beiKombiBoxZeichen

HC [image] GUI Programmierung [image] KombiBoxen [image] beiKombiBoxZeichen
setzeKombiBoxSchriftdicke beiGedrückterTasteInKombiBox

beiKombiBoxZeichen acombobox Befehle

Kommando, den Gewohnheitsereignisführer für das Zeichen Ereignis des KombiBox acombobox zu zu setzen, befiehlt. Sehen Sie auch beiZeichen!

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
beiKombiBoxZeichen cb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

setzeKombiBoxSchriftdicke beiGedrückterTasteInKombiBox


HC / GUI Programmierung / KombiBoxen / beiGedrückterTasteInKombiBox

beiGedrückterTasteInKombiBox

HC [image] GUI Programmierung [image] KombiBoxen [image] beiGedrückterTasteInKombiBox
beiKombiBoxZeichen beiLosgelassenerTasteInKombiBox

beiGedrückterTasteInKombiBox acombobox Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Runter Ereignis des KombiBox acombobox zu zu setzen, befiehlt. Sehen Sie auch beiGedrückterTaste!

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
beiGedrückterTasteInKombiBox cb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiKombiBoxZeichen beiLosgelassenerTasteInKombiBox


HC / GUI Programmierung / KombiBoxen / beiLosgelassenerTasteInKombiBox

beiLosgelassenerTasteInKombiBox

HC [image] GUI Programmierung [image] KombiBoxen [image] beiLosgelassenerTasteInKombiBox
beiGedrückterTasteInKombiBox beiKombiBoxAuswahl

beiLosgelassenerTasteInKombiBox acombobox Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Rauf zu setzen (=release), Ereignis des KombiBox acombobox zu Kommandos. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
beiLosgelassenerTasteInKombiBox cb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiGedrückterTasteInKombiBox beiKombiBoxAuswahl


HC / GUI Programmierung / KombiBoxen / beiKombiBoxAuswahl

beiKombiBoxAuswahl

HC [image] GUI Programmierung [image] KombiBoxen [image] beiKombiBoxAuswahl
beiLosgelassenerTasteInKombiBox beiKombiBoxÄnderung

beiKombiBoxAuswahl acombobox Befehle

Kommando, den Gewohnheitsereignisführer für das auserlesene Ereignis des KombiBox acombobox zu zu setzen, befiehlt. Das auserlesene Ereignis wird erzeugt wenn der Benutzer eine Wahl mit einem mouseclick oder auswählt ein Tastendruck.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
beiKombiBoxAuswahl cb [schreibe KombiBoxAuswahl]

Reference:

    Release Notes für Version 4.685

beiLosgelassenerTasteInKombiBox beiKombiBoxÄnderung


HC / GUI Programmierung / KombiBoxen / beiKombiBoxÄnderung

beiKombiBoxÄnderung

HC [image] GUI Programmierung [image] KombiBoxen [image] beiKombiBoxÄnderung
beiKombiBoxAuswahl beiKombiBoxEingabe

beiKombiBoxÄnderung acombobox Befehle

Kommando, den Gewohnheitsereignisführer für das Änderungs-Text Ereignis des KombiBox acombobox zu zu setzen, befiehlt. Das Änderungs-Text Ereignis wird erzeugt, wenn der Benutzer einige Text in die Bearbeite Kontrolle eingibt.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
beiKombiBoxÄnderung cb [schreibe KombiBoxWert]

Reference:

    Release Notes für Version 4.685

beiKombiBoxAuswahl beiKombiBoxEingabe


HC / GUI Programmierung / KombiBoxen / beiKombiBoxEingabe

beiKombiBoxEingabe

HC [image] GUI Programmierung [image] KombiBoxen [image] beiKombiBoxEingabe
beiKombiBoxÄnderung KombiBoxAn

beiKombiBoxEingabe acombobox Befehle

Kommando, den Gewohnheitsereignisführer für das Eingabetastenereignis des KombiBox acombobox zu zu setzen, befiehlt. Das ProzedurText-Ereignis "Eingabe" wird erzeugt wenn der Benutzer drückt der oder betreten die Eingabetaste.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
beiKombiBoxEingabe cb [schreibe KombiBoxWert]

Reference:

    Release Notes für Version 4.685

beiKombiBoxÄnderung KombiBoxAn


HC / GUI Programmierung / KombiBoxen / KombiBoxAn

KombiBoxAn

HC [image] GUI Programmierung [image] KombiBoxen [image] KombiBoxAn
beiKombiBoxEingabe Zahlboxen

KombiBoxAn acombobox Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das KombiBox acombobox, ist Wenn Staat falsch dann sperrt es das ComboBox.

Zustand muss ein boolesch sein.

Beispiel:

cb=(KombiBox [][MyComboBox][Initial string]
    [	[String 1]
        [und a second string]
        [und the letztes string]
    ]
    [	(zeige "MyComboBox KombiBoxAuswahl)
    ]
    [	(schreibe [change] KombiBoxWert)
    ]
    [	v=KombiBoxWert
        (schreibe [enter] v)
        zurKombiBoxDazu cb v
    ]
    wxCB_simple [-1 -1][300 200])
KombiBoxAn cb falsch
;Click on the KombiBox again --nothing happens
KombiBoxAn cb wahr	;enabled again

Reference:

    Release Notes für Version 4.685

beiKombiBoxEingabe Zahlboxen


HC / GUI Programmierung / Zahlboxen

Zahlboxen

HC [image] GUI Programmierung [image] Zahlboxen
KombiBoxAn Zahlbox

Zahlboxen

Eine Zahlbox ist ein wenig enthaltendes Fenster ein Text igeltext, eine Bearbeite Kontrolle für Verwendung mit Gleitpunktzahlen, und ein spinbutton. Es hält den Wert einer Gleitpunktzahl, die vom tippenden Benutzer von jedem, oder mit den Pfeiltasten verändert werden kann, oder, indem man auf das spinbuttton mit der Maus klickt.

Zahlbox wird in floatcontroltest.lg. demonstriert

Zahlboxen

  • Zahlbox
  • FloatControlDestroy
  • ZahlboxWert
  • setzeReelleZahlboxWert
  • setzeReelleZahlboxBereich
  • beiÄnderungInReellerZahlbox
  • ZahlboxAn


HC / GUI Programmierung / Zahlboxen / Zahlbox

Zahlbox

HC [image] GUI Programmierung [image] Zahlboxen [image] Zahlbox
Zahlboxen FloatControlDestroy

Zahlbox Elternteil Kleinstes Wert Größtes Inkrementsziffern onChange
(Zahlbox Elternteil Namens Kleinstes Wert Größtes Inkrement nennen)
(Zahlbox Elternteil Namens Kleinstes Wert Größtes Inkrements Stellig onChange Format Stil Ort Größe)

Ausgaben ein neuer Zahlbox auf dem Elternteil (ein Fenster Oder ein Diagramm, Haupt-Diagramm-Wenn []).

Name ist das igeltext Text und der Name der Kontrolle.

kleinstes ist das minimale erlaubte Wert, den die Kontrolle akzeptiert.

Wert ist die beim Start gezeigte Anzahl von der Kontrolle.

größtes ist das maximale erlaubte Wert, den die Kontrolle akzeptiert.

Inkrement ist die Menge, um die die Pfeiltasten Oder Verminderung anwachsen, der Wert.

kleinstes, Wert, Größtes Und Inkrement sind Logo-Zahlen, die in Schwimmer intern umgewandelt werden werden.

Ziffern sind die Ziffernanzahl der Zahl hinter dem Punkt. Es ist ein integres Zahlen-Und Vorgaben zu 3 geliefertes Wenn Nicht.

onChange ist ein Befehls-Liste, das führeAus wenn sein wird, das OnChange Ereignis der Kontrolle wird bearbeitet. Das ist, wann auch immer die Zahl in der Kontrolle sich ändert.

Format ist eine Ganzzahl zwischen 1 und 3, bei der Meinung von 1="%f (Gleitpunkt)," 2="%e (exponentiell)" und 3="%g" (Unterschriebener Wert druckte in F Oder E Format, gleich welches für die bestimmte Wert-Und Präzision kompakter ist. Das E Format wird benutzt nur wenn der Exponent des Wertes weniger als 4 ist oder, größer als vom Präzisionsargument gleiches oder. Beim Schleifen setzt auf Null werden gekürzt, und, das der Dezimalpunkt nur wenn eins scheint, oder, dem mehr Ziffern folgen, es.).

Stil ist das Fenster Stil-Und kann der besondere Wert wxSP_ARROW_KEYS, zu dem es vernachlässigt, sein.

ort ist die Position des KombiBox (ein Liste zweier integrer Zahlen, x und y),

Größe ist die Größe des KombiBox (ein Liste zweier integrer Zahlen, Breiten-Und Höhe).

Beispiel:

fcx=(Zahlbox [] [X] -400 0 400 1.01 5
    [	x=ZahlboxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ] 2 0 [10 20][-1 -1])

Examples:

  • beiÄnderungInReellerZahlbox
  • setzeReelleZahlboxBereich
  • setzeReelleZahlboxWert
  • FloatControlDestroy
  • ListenControlAn
  • GanzzahlBoxAn
  • ZahlboxWert
  • ZahlboxAn

References:

    ZahlboxAn(3), ZahlboxWert(3), FloatControlDestroy(2), Release Notes für Version 4.685(2), Zahlboxen(2), beiÄnderungInReellerZahlbox(2), setzeReelleZahlboxBereich(2), setzeReelleZahlboxWert(2), GanzzahlBoxAn, ListenControlAn

Zahlboxen FloatControlDestroy


HC / GUI Programmierung / Zahlboxen / FloatControlDestroy

FloatControlDestroy

HC [image] GUI Programmierung [image] Zahlboxen [image] FloatControlDestroy
Zahlbox ZahlboxWert

FloatControlDestroy afloatcontrol

Kommando, das Zahlbox Afloatcontrol zu zerstören.

Beispiel:

fcx=(Zahlbox [] [X] -400 0 400 1.01 5
    [	x=ZahlboxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ] 2 0 [10 20][-1 -1])
FloatControlDestroy fcx

Reference:

    Release Notes für Version 4.685

Zahlbox ZahlboxWert


HC / GUI Programmierung / Zahlboxen / ZahlboxWert

ZahlboxWert

HC [image] GUI Programmierung [image] Zahlboxen [image] ZahlboxWert
FloatControlDestroy setzeReelleZahlboxWert

ZahlboxWert (ZahlboxWert afloatcontrol)

Ausgaben der Wert des ohne Argumente angerufenen Zahlbox Afloatcontrol Oder Wenn, vom Zahlbox dessen Ereignis neuerdings bearbeitet wird.

Beispiel:

fcx=(Zahlbox [] [X] -400 0 400 1.01 5
    [	x=ZahlboxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ] 2 0 [10 20][-1 -1])

Examples:

  • beiÄnderungInReellerZahlbox
  • setzeReelleZahlboxBereich
  • setzeReelleZahlboxWert
  • FloatControlDestroy
  • ZahlboxAn
  • Zahlbox

References:

    FloatControlDestroy, Release Notes für Version 4.685, Zahlbox, ZahlboxAn, beiÄnderungInReellerZahlbox, setzeReelleZahlboxBereich, setzeReelleZahlboxWert

FloatControlDestroy setzeReelleZahlboxWert


HC / GUI Programmierung / Zahlboxen / setzeReelleZahlboxWert

setzeReelleZahlboxWert

HC [image] GUI Programmierung [image] Zahlboxen [image] setzeReelleZahlboxWert
ZahlboxWert setzeReelleZahlboxBereich

setzeReelleZahlboxWert afloatcontrol Wert

Befehlen Sie dem Zahlenwert, den Wert des Zahlbox Afloatcontrol zu setzen.

Beispiel:

fcx=(Zahlbox [] [X] -400 0 400 1.01 5
    [	x=ZahlboxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ] 2 0 [10 20][-1 -1])
setzeReelleZahlboxWert fcx 123.456

Reference:

    Release Notes für Version 4.685

ZahlboxWert setzeReelleZahlboxBereich


HC / GUI Programmierung / Zahlboxen / setzeReelleZahlboxBereich

setzeReelleZahlboxBereich

HC [image] GUI Programmierung [image] Zahlboxen [image] setzeReelleZahlboxBereich
setzeReelleZahlboxWert beiÄnderungInReellerZahlbox

setzeReelleZahlboxBereich afloatcontrol kleinstes größtes

Kommando, die Bereich von plausiblen Anzahlen vom Zahlbox Afloatcontrol zu setzen, zwischen den Zahlen-Kleinstes Und Größtes zu bleiben, inklusive.

Beispiel:

fcx=(Zahlbox [] [X] -400 0 400 1.01 5
    [	x=ZahlboxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ] 2 0 [10 20][-1 -1])
setzeReelleZahlboxBereich fcx -10.11 20.22

Reference:

    Release Notes für Version 4.685

setzeReelleZahlboxWert beiÄnderungInReellerZahlbox


HC / GUI Programmierung / Zahlboxen / beiÄnderungInReellerZahlbox

beiÄnderungInReellerZahlbox

HC [image] GUI Programmierung [image] Zahlboxen [image] beiÄnderungInReellerZahlbox
setzeReelleZahlboxBereich ZahlboxAn

beiÄnderungInReellerZahlbox afloatcontrol Befehle

Befehlen Sie, dass afloatcontrol, um den OnChange Ereignisroutine des Zahlbox' zu setzen, zu dem commandlist befiehlt.

Beispiel:

fcx=(Zahlbox [] [X] -400 0 400 1.01 5
    [] 2 0 [10 20][-1 -1])
beiÄnderungInReellerZahlbox fcx [
        x=ZahlboxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ]

Reference:

    Release Notes für Version 4.685

setzeReelleZahlboxBereich ZahlboxAn


HC / GUI Programmierung / Zahlboxen / ZahlboxAn

ZahlboxAn

HC [image] GUI Programmierung [image] Zahlboxen [image] ZahlboxAn
beiÄnderungInReellerZahlbox Balken-Anzeigen

ZahlboxAn afloatcontrol Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das Zahlbox Afloatcontrol, ist Wenn Staat falsch dann sperrt es das FloatControl.

Zustand muss ein boolesch sein.

Beispiel:

fcx=(Zahlbox [] [X] -400 0 400 1.01 5
    [	x=ZahlboxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ] 2 0 [10 20][-1 -1])
ZahlboxAn fcx falsch
;Click on the Zahlbox again --nothing happens
ZahlboxAn fcx wahr	;enabled again

ÿ

Reference:

    Release Notes für Version 4.685

beiÄnderungInReellerZahlbox Balken-Anzeigen


HC / GUI Programmierung / Balken-Anzeigen

Balken-Anzeigen

HC [image] GUI Programmierung [image] Balken-Anzeigen
ZahlboxAn Balken

Balken-Anzeigen

...enthalten einen Balken ein wenig enthaltendes Fenster ein farbiges Leiste ist, das nimmt rauf einige Prozentsätze der Breiten-Oder Höhe der Kontrolle. Es zeigt den Wert einer integren Zahl, von der Größe des Leiste repräsentiert. Balken ist schreibgeschützt.

Balken wird in gaugetest.lg. demonstriert

Balken-Anzeigen

  • Balken
  • zerstöreBalken
  • BalkenWert
  • setzeBalkenWert
  • setzeBalkenBereich
  • setzeBalkenFarbe
  • setzeBalkenHintergrundfarbe


HC / GUI Programmierung / Balken-Anzeigen / Balken

Balken

HC [image] GUI Programmierung [image] Balken-Anzeigen [image] Balken
Balken-Anzeigen zerstöreBalken

Balken Elternteil name bereich
(Balken Elternteil Name Reihen Wert Stil Ort Größe)

Ausgaben ein neuer Balken auf dem Elternteil (ein Fenster Oder ein Diagramm, Haupt-Diagramm-Wenn []).

Name ist der Name der Kontrolle.

Bereich ist der maximale erlaubte Wert, den die Kontrolle akzeptiert.

Wert ist die beim Start gezeigte Anzahl von der Kontrolle.

Reihen-Und Wert muss integre Zahlen sein.

Stil ist das Fenster Stil-Und kann eine Kombination sein von (wxGA_HORIZONTAL oder wxGA_VERTICAL) mit wxGA_SMOOTH.

wxGA_HORIZONTAL Schafft eine Horizontale
g=Balken [][Gauge1] 400
g2=(Balken [][Gauge1] 400 100 wxGA_horizontal+wxGA_smooth
    [0 200])

Examples:

  • setzeBalkenHintergrundfarbe
  • setzeBalkenBereich
  • setzeBalkenFarbe
  • setzeBalkenWert
  • zerstöreBalken
  • BalkenWert

References:

    Balken-Anzeigen(3), BalkenWert(2), Release Notes für Version 4.685(2), setzeBalkenBereich(2), setzeBalkenFarbe(2), setzeBalkenHintergrundfarbe(2), setzeBalkenWert(2), zerstöreBalken(2)

Balken-Anzeigen zerstöreBalken


HC / GUI Programmierung / Balken-Anzeigen / zerstöreBalken

zerstöreBalken

HC [image] GUI Programmierung [image] Balken-Anzeigen [image] zerstöreBalken
Balken BalkenWert

zerstöreBalken agauge

Kommando, das Balken Agauge zu zerstören.

Beispiel:

g=Balken [][Gauge1] 400
zerstöreBalken g

Reference:

    Release Notes für Version 4.685

Balken BalkenWert


HC / GUI Programmierung / Balken-Anzeigen / BalkenWert

BalkenWert

HC [image] GUI Programmierung [image] Balken-Anzeigen [image] BalkenWert
zerstöreBalken setzeBalkenWert

BalkenWert agauge

Ausgaben der Integer-Wert des Balken Agauge.

Beispiel:

g=(Balken [][Gauge1] 400 123 wxGA_smooth)
zeige BalkenWert g

Reference:

    Release Notes für Version 4.685

zerstöreBalken setzeBalkenWert


HC / GUI Programmierung / Balken-Anzeigen / setzeBalkenWert

setzeBalkenWert

HC [image] GUI Programmierung [image] Balken-Anzeigen [image] setzeBalkenWert
BalkenWert setzeBalkenBereich

setzeBalkenWert agauge Wert

Kommando, den Wert des Balken Agauge zum Integer-Wert zu setzen.

Beispiel:

g=(Balken [][Gauge1] 400 123 wxGA_smooth)
setzeBalkenWert g 321

Reference:

    Release Notes für Version 4.685

BalkenWert setzeBalkenBereich


HC / GUI Programmierung / Balken-Anzeigen / setzeBalkenBereich

setzeBalkenBereich

HC [image] GUI Programmierung [image] Balken-Anzeigen [image] setzeBalkenBereich
setzeBalkenWert setzeBalkenFarbe

setzeBalkenBereich agauge größtes

Kommando, die Bereich von plausiblen Anzahlen vom Balken Agauge zu setzen, um zwischen 0 und zu bleiben, das integre Zahlen-größtes.

Beispiel:

g=(Balken [][Gauge1] 400 123 wxGA_smooth)
setzeBalkenBereich g 333

Reference:

    Release Notes für Version 4.685

setzeBalkenWert setzeBalkenFarbe


HC / GUI Programmierung / Balken-Anzeigen / setzeBalkenFarbe

setzeBalkenFarbe

HC [image] GUI Programmierung [image] Balken-Anzeigen [image] setzeBalkenFarbe
setzeBalkenBereich setzeBalkenHintergrundfarbe

setzeBalkenFarbe agauge Farbe

Befehlen Sie der Farbfarbe, die Vordergrundfarbe des Balken Agauge zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

g=(Balken [][Gauge1] 400 123 wxGA_smooth)
setzeBalkenFarbe g "red

Reference:

    Release Notes für Version 4.685

setzeBalkenBereich setzeBalkenHintergrundfarbe


HC / GUI Programmierung / Balken-Anzeigen / setzeBalkenHintergrundfarbe

setzeBalkenHintergrundfarbe

HC [image] GUI Programmierung [image] Balken-Anzeigen [image] setzeBalkenHintergrundfarbe
setzeBalkenFarbe GanzzahlBoxen

setzeBalkenHintergrundfarbe agauge Farbe

Befehlen Sie der Farbfarbe, die Bakcground Farbe des Balken Agauge zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

g=(Balken [][Gauge1] 400 123 wxGA_smooth)
setzeBalkenHintergrundfarbe g "blue

Reference:

    Release Notes für Version 4.685

setzeBalkenFarbe GanzzahlBoxen


HC / GUI Programmierung / GanzzahlBoxen

GanzzahlBoxen

HC [image] GUI Programmierung [image] GanzzahlBoxen
setzeBalkenHintergrundfarbe GanzzahlBox

GanzzahlBoxen

Eine GanzzahlBox ist ein kleines Fenster, das einen Label-Text enthält, ein Text-Steuerelement für Verwendung mit Ganzzahlen, und einen Rauf- und RunterKnopf. Es hält den Wert einer Ganzzahl, die vom Benutzer entweder durch Tippen, oder mit den Pfeiltasten verändert werden kann, oder, indem man auf den Rauf- oder Runter-Knopf mit der Maus klickt.

GanzzahlBox wird in intcontroltest.lg. demonstriert

GanzzahlBoxen

  • GanzzahlBox
  • zerstöreGanzzahlBox
  • GanzzahlBoxWert
  • setzeGanzzahlBoxWert
  • setzeGanzzahlBoxBereich
  • beiGanzzahlBoxÄnderung
  • GanzzahlBoxAn


HC / GUI Programmierung / GanzzahlBoxen / GanzzahlBox

GanzzahlBox

HC [image] GUI Programmierung [image] GanzzahlBoxen [image] GanzzahlBox
GanzzahlBoxen zerstöreGanzzahlBox

GanzzahlBox Elternteil name Kleinstes Wert größtes beiÄndern
(GanzzahlBox Elternteil Name Kleinstes Wert größtes)
(GanzzahlBox Elternteil Name Kleinstes Wert größtes beiÄndern Stil Ort Größe)

Ausgabe ist eine neue GanzzahlBox auf dem Elternteil (ein Fenster oder ein Diagramm, Haupt-Graph wenn Elternteil [] ist).

Name ist der Label-Text und der Name des Steuerelements.

Kleinstes ist der minimale erlaubte Wert, den das Steuerelement akzeptiert.

Wert ist die beim Start gezeigte Zahl des Steuerelements.

größtes ist der maximale erlaubte Wert, den das Steuerelement akzeptiert.

kleinstes, Wert und größtes müssen Ganzzahlen sein.

beiÄndern ist eine Befehls-Liste, die ausgeführt wird, wenn das beiÄndern-Ereignis des Steuerelements eingetreten ist. Jenes tritt immer ein, wenn sich die Zahl im Steuerelement ändert.

Stil ist der Fenster Stil und kann der besondere Wert wxSP_ARROW_KEYS sein, der auch der sein Standardwert ist.

Ort ist die Position der GanzzahlBox (eine Liste zweier ganzer Zahlen, x und y),

Größe ist die Größe der GanzzahlBox (ein Liste zweier ganzer Zahlen, Breite und Höhe).

Beispiele:

ic=(GanzzahlBox [][X] -400 0 400
[	x=GanzzahlBoxWert
    (schreib "x= x)
])
ic2=(GanzzahlBox [][Y] -400 0 400
[	y=GanzzahlBoxWert
    (schreib "y= y)
] wxSP_Arrow_Keys [10 100] [80 -1])

Examples:

  • setzeGanzzahlBoxBereich
  • beiGanzzahlBoxÄnderung
  • setzeGanzzahlBoxWert
  • zerstöreGanzzahlBox
  • setzeFensterFarbe
  • GanzzahlBoxWert
  • GanzzahlBoxAn

References:

    GanzzahlBoxWert(3), GanzzahlBoxAn(2), GanzzahlBoxen(2), Release Notes für Version 4.685(2), beiGanzzahlBoxÄnderung(2), setzeGanzzahlBoxBereich(2), setzeGanzzahlBoxWert(2), zerstöreGanzzahlBox(2), setzeFensterFarbe

GanzzahlBoxen zerstöreGanzzahlBox


HC / GUI Programmierung / GanzzahlBoxen / zerstöreGanzzahlBox

zerstöreGanzzahlBox

HC [image] GUI Programmierung [image] GanzzahlBoxen [image] zerstöreGanzzahlBox
GanzzahlBox GanzzahlBoxWert

zerstöreGanzzahlBox aintcontrol

Kommando, das GanzzahlBox aintcontrol zu zerstören.

Beispiel:

ic=(GanzzahlBox [][X] -400 0 400 [x=GanzzahlBoxWert (schreibe "x= x)])
zerstöreGanzzahlBox ic

Reference:

    Release Notes für Version 4.685

GanzzahlBox GanzzahlBoxWert


HC / GUI Programmierung / GanzzahlBoxen / GanzzahlBoxWert

GanzzahlBoxWert

HC [image] GUI Programmierung [image] GanzzahlBoxen [image] GanzzahlBoxWert
zerstöreGanzzahlBox setzeGanzzahlBoxWert

GanzzahlBoxWert
(GanzzahlBoxWert aintcontrol)

Ausgaben, die der Integer-Wert des GanzzahlBox aintcontrol oder wenn ohne Argumente des GanzzahlBox aufrief, dessen Ereignis neuerdings bearbeitet wird.

Beispiel:

ic=(GanzzahlBox [][X] -400 0 400 [x=GanzzahlBoxWert (schreibe "x= x)])

Examples:

  • setzeGanzzahlBoxBereich
  • beiGanzzahlBoxÄnderung
  • setzeGanzzahlBoxWert
  • zerstöreGanzzahlBox
  • GanzzahlBoxAn
  • GanzzahlBox

References:

    GanzzahlBox(2), GanzzahlBoxAn, Release Notes für Version 4.685, beiGanzzahlBoxÄnderung, setzeGanzzahlBoxBereich, setzeGanzzahlBoxWert, zerstöreGanzzahlBox

zerstöreGanzzahlBox setzeGanzzahlBoxWert


HC / GUI Programmierung / GanzzahlBoxen / setzeGanzzahlBoxWert

setzeGanzzahlBoxWert

HC [image] GUI Programmierung [image] GanzzahlBoxen [image] setzeGanzzahlBoxWert
GanzzahlBoxWert setzeGanzzahlBoxBereich

setzeGanzzahlBoxWert aintcontrol Wert

Befehlen Sie dem integren Zahlenwert, den Wert des GanzzahlBox aintcontrol zu setzen.

Beispiel:

ic=(GanzzahlBox [][X] -400 0 400 [x=GanzzahlBoxWert (schreibe "x= x)])
setzeGanzzahlBoxWert ic 123.456

Reference:

    Release Notes für Version 4.685

GanzzahlBoxWert setzeGanzzahlBoxBereich


HC / GUI Programmierung / GanzzahlBoxen / setzeGanzzahlBoxBereich

setzeGanzzahlBoxBereich

HC [image] GUI Programmierung [image] GanzzahlBoxen [image] setzeGanzzahlBoxBereich
setzeGanzzahlBoxWert beiGanzzahlBoxÄnderung

setzeGanzzahlBoxBereich aintcontrol kleinstes größtes

Kommando, die Bereich von plausiblen Anzahlen vom GanzzahlBox aintcontrol zu setzen, zwischen den Zahlen-Kleinstes Und Größtes zu bleiben, inklusive.

Beispiel:

ic=(GanzzahlBox [][X] -400 0 400 [x=GanzzahlBoxWert (schreibe "x= x)])
setzeGanzzahlBoxBereich ic -10.11 20.22

Reference:

    Release Notes für Version 4.685

setzeGanzzahlBoxWert beiGanzzahlBoxÄnderung


HC / GUI Programmierung / GanzzahlBoxen / beiGanzzahlBoxÄnderung

beiGanzzahlBoxÄnderung

HC [image] GUI Programmierung [image] GanzzahlBoxen [image] beiGanzzahlBoxÄnderung
setzeGanzzahlBoxBereich GanzzahlBoxAn

beiGanzzahlBoxÄnderung aintcontrol Befehle

Befehlen Sie den Commandlist Befehlen, den OnChange Ereignisroutine des GanzzahlBox aintcontrol zu setzen.

Beispiel:

ic=GanzzahlBox [][X] -400 0 400 []
beiGanzzahlBoxÄnderung ic [
        x=GanzzahlBoxWert
        ;(schreibe "x= x)
        setzeX x
        erneuereGraph
    ]

Reference:

    Release Notes für Version 4.685

setzeGanzzahlBoxBereich GanzzahlBoxAn


HC / GUI Programmierung / GanzzahlBoxen / GanzzahlBoxAn

GanzzahlBoxAn

HC [image] GUI Programmierung [image] GanzzahlBoxen [image] GanzzahlBoxAn
beiGanzzahlBoxÄnderung Listenboxen

GanzzahlBoxAn aintcontrol Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das GanzzahlBox aintcontrol, ist Wenn Staat falsch dann sperrt es das IntControl.

Zustand muss ein boolesch sein.

Beispiel:

ic=(GanzzahlBox [][X] -400 0 400 [x=GanzzahlBoxWert (schreibe "x= x)])
GanzzahlBoxAn fcx falsch
;Click on the Zahlbox again --nothing happens
GanzzahlBoxAn fcx wahr	;enabled again

Reference:

    Release Notes für Version 4.685

beiGanzzahlBoxÄnderung Listenboxen


HC / GUI Programmierung / Listenboxen

Listenboxen

HC [image] GUI Programmierung [image] Listenboxen
GanzzahlBoxAn Listenbox

Listenboxen

...sind Fenster etwas ein Text igeltext und enthaltend ein Liste von Text Optionen, den können führeAus ein Logo-Befehlsliste wenn der Benutzer mit der Maus auf sie klickt wählt und eine Wahl aus, und wenn ein Schlüsselereignis bekommen wird.

Ein listenbox wird benutzt um ein oder mehr eines Liste von Linien auszuwählen. Die Linien werden in einem sich rollenden Box, mit dem ausgewählten in Dreheum Video markierten string(s), gezeigt. Ein listenbox kann einzelne Auswahl sein (wenn ein Element wird ausgewählt, die bisherige Auswahl wird beseitigt) Oder Mehrfachselektion (Klicken ein Element kippt das Element auf oder aus unabhängig von anderen Auswahlen).

Liste Kastenelemente werden von null nummeriert. Ihre Zahl wird in einigen Plattformen beschränkt (z. B. ca. 2000 auf GTK).

Die entsprechende Demo ist listboxtest.lg.

Listenboxen

  • Listenbox
  • zerstöreListenbox
  • ListenboxAuswahl
  • setzeListenboxAuswahl
  • setzeListenboxMöglichkeiten
  • hängeAnListenbox
  • setzeListenboxElement
  • entferneListenboxElement
  • zähleListenbox
  • setzeListenboxHintergrundfarbe
  • setzeListenboxFarbe
  • setzeListenboxSchriftgröße
  • setzeListenboxSchriftname
  • setzeListenboxSchriftstil
  • setzeListenboxSchriftdicke
  • beiListenboxZeichen
  • beiGedrückterTasteInListenbox
  • beiLosgelassenerTasteInListenbox
  • beiListenboxAuswahl
  • beiDoppeltgeklickterListenbox
  • ListenboxAn


HC / GUI Programmierung / Listenboxen / Listenbox

Listenbox

HC [image] GUI Programmierung [image] Listenboxen [image] Listenbox
Listenboxen zerstöreListenbox

Listenbox Elternteil Optionen onSelect onDClick
(Listenbox Elternteilnamensoptionen nennen)
(Listenbox Elternteil Namens Options onSelect onDClick Stil Ort Größe)

Ausgaben ein neues Listenbox Und zeigt es auf dem Elternteil (ein Fenster Oder ein Diagramm, Haupt-Diagramm-Wenn []).

Name ist Igeltext ProzedurText.

Optionen ist ein Liste von elemente, aus dem der Benutzer einen auswählen kann.

onSelect ist ein Logo-Befehlsliste, das führeAus sein wird, wenn der Benutzer eine Wahl auswählt.

onDCLick ist ein Logo-Befehlsliste, das führeAus sein wird, wann der Benutzer doppelt-klickt auf einer Wahl.

Examples:

  • beiLosgelassenerTasteInListenbox
  • setzeListenboxHintergrundfarbe
  • beiDoppeltgeklickterListenbox
  • beiGedrückterTasteInListenbox
  • setzeListenboxMöglichkeiten
  • setzeListenboxSchriftdicke
  • setzeListenboxSchriftgröße
  • setzeListenboxSchriftname
  • setzeListenboxSchriftstil
  • entferneListenboxElement
  • setzeListenboxAuswahl
  • setzeListenboxElement
  • beiListenboxAuswahl
  • beiListenboxZeichen
  • setzeListenboxFarbe
  • zerstöreListenbox
  • hängeAnListenbox
  • ListenboxAuswahl
  • zähleListenbox
  • ListenboxAn

References:

    ListenboxAn(3), ListenboxAuswahl(3), Listenboxen(2), Release Notes für Version 4.685(2), beiDoppeltgeklickterListenbox(2), beiGedrückterTasteInListenbox(2), beiListenboxAuswahl(2), beiListenboxZeichen(2), beiLosgelassenerTasteInListenbox(2), entferneListenboxElement(2), hängeAnListenbox(2), setzeListenboxAuswahl(2), setzeListenboxElement(2), setzeListenboxFarbe(2), setzeListenboxHintergrundfarbe(2), setzeListenboxMöglichkeiten(2), setzeListenboxSchriftdicke(2), setzeListenboxSchriftgröße(2), setzeListenboxSchriftname(2), setzeListenboxSchriftstil(2), zerstöreListenbox(2), zähleListenbox(2), Auswahlbox

Listenboxen zerstöreListenbox


HC / GUI Programmierung / Listenboxen / zerstöreListenbox

zerstöreListenbox

HC [image] GUI Programmierung [image] Listenboxen [image] zerstöreListenbox
Listenbox ListenboxAuswahl

zerstöreListenbox alistbox

Kommando, der das Listenbox Alistbox zerstört.

Beispiel:

lb=Listenbox [][LB] [[String 1][S2][S3]] [][]
zerstöreListenbox lb

Reference:

    Release Notes für Version 4.685

Listenbox ListenboxAuswahl


HC / GUI Programmierung / Listenboxen / ListenboxAuswahl

ListenboxAuswahl

HC [image] GUI Programmierung [image] Listenboxen [image] ListenboxAuswahl
zerstöreListenbox setzeListenboxAuswahl

ListenboxAuswahl
(ListenboxAuswahl alistbox)

Ausgaben die Auswahlen des Listenbox Alistbox, ohne ein Argument angerufenen oder wenn, des Listenbox', das das letzten Ereignis bearbeitete.

Der Ausgangswert ist ein Liste von null-basierten Ganzzahlen, bei der Repräsentation der nten Wahl.

Beispiel:

lb=(Listenbox [][LB] [[String 1][S2][S3]]
    [zeige ListenboxAuswahl][] wxLB_multiple)

Examples:

  • beiDoppeltgeklickterListenbox
  • beiListenboxAuswahl

References:

    Release Notes für Version 4.685, beiDoppeltgeklickterListenbox, beiListenboxAuswahl

zerstöreListenbox setzeListenboxAuswahl


HC / GUI Programmierung / Listenboxen / setzeListenboxAuswahl

setzeListenboxAuswahl

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxAuswahl
ListenboxAuswahl setzeListenboxMöglichkeiten

setzeListenboxAuswahl achoicebox Auswahlen

Befehlen Sie den Elementzahlen, die Auswahlen des Listenbox Alistbox zu setzen, in den Liste Auswahlen.

Auswahlen ist ein Liste von null-basierten integren Registern in die Optionen, die weniger sein müssen als die Anzahl von Optionen in der Kontrolle.

Beispiel:

lb=(Listenbox [][LB] [[String 1][S2][S3]] [][] wxLB_multiple)
setzeListenboxAuswahl lb [0 2]

Reference:

    Release Notes für Version 4.685

ListenboxAuswahl setzeListenboxMöglichkeiten


HC / GUI Programmierung / Listenboxen / setzeListenboxMöglichkeiten

setzeListenboxMöglichkeiten

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxMöglichkeiten
setzeListenboxAuswahl hängeAnListenbox

setzeListenboxMöglichkeiten alistbox Optionen

Kommando, das inhalt des Listenbox Alistbox zu Optionen zu setzen.

Optionen müssen ein Liste von elemente sein, dessen Texte die Optionen im ListBox sein werden.

Beispiel:

lb=Listenbox [][LB] [][][]
setzeListenboxMöglichkeiten lb [
    [First string]
    [und a second string]
    [und the letztes string]
]

Reference:

    Release Notes für Version 4.685

setzeListenboxAuswahl hängeAnListenbox


HC / GUI Programmierung / Listenboxen / hängeAnListenbox

hängeAnListenbox

HC [image] GUI Programmierung [image] Listenboxen [image] hängeAnListenbox
setzeListenboxMöglichkeiten setzeListenboxElement

hängeAnListenbox alistbox Wahl

Kommando, das Text der Wert Wahl an die Optionen von Listenbox Alistbox anzuhängen.

Beispiele:

lb=Listenbox [][LB] [][][]
hängeAnListenbox lb [First string]
hängeAnListenbox lb [und a second string]
hängeAnListenbox lb [und the letztes string]

Reference:

    Release Notes für Version 4.685

setzeListenboxMöglichkeiten setzeListenboxElement


HC / GUI Programmierung / Listenboxen / setzeListenboxElement

setzeListenboxElement

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxElement
hängeAnListenbox entferneListenboxElement

setzeListenboxElement alistbox Registerwahl

Befehlen Sie dem Text der Wert Wahl, das Element an Positionsregister des Listenbox Alistbox zu verändern.

Register muss ein integres Zahlen Register->= 0 und-Register < sein (Anzahl von Optionen im Listenbox).

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
setzeListenboxElement lb 1 [a changed element]

Reference:

    Release Notes für Version 4.685

hängeAnListenbox entferneListenboxElement


HC / GUI Programmierung / Listenboxen / entferneListenboxElement

entferneListenboxElement

HC [image] GUI Programmierung [image] Listenboxen [image] entferneListenboxElement
setzeListenboxElement zähleListenbox

entferneListenboxElement alistbox Register

Befehlen Sie entferne das auserlesene Element an Positionsregister vom Listenbox Alistbox.

Register muss eine integre Zahlen Register->= 0 und-Register-<-Anzahl von Optionen im ListBox sein.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][Last String]] [][]
entferneListenboxElement lb 1

Reference:

    Release Notes für Version 4.685

setzeListenboxElement zähleListenbox


HC / GUI Programmierung / Listenboxen / zähleListenbox

zähleListenbox

HC [image] GUI Programmierung [image] Listenboxen [image] zähleListenbox
entferneListenboxElement setzeListenboxHintergrundfarbe

zähleListenbox alistbox

Ausgaben die Anzahl von Optionen im Listenbox Alistbox.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
zeige zähleListenbox lb

Reference:

    Release Notes für Version 4.685

entferneListenboxElement setzeListenboxHintergrundfarbe


HC / GUI Programmierung / Listenboxen / setzeListenboxHintergrundfarbe

setzeListenboxHintergrundfarbe

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxHintergrundfarbe
zähleListenbox setzeListenboxFarbe

setzeListenboxHintergrundfarbe alistbox Farbe

Befehlen Sie der Farbfarbe, die Hintergrundfarbe des Listenbox Alistbox zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
setzeListenboxHintergrundfarbe lb "red

Reference:

    Release Notes für Version 4.685

zähleListenbox setzeListenboxFarbe


HC / GUI Programmierung / Listenboxen / setzeListenboxFarbe

setzeListenboxFarbe

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxFarbe
setzeListenboxHintergrundfarbe setzeListenboxSchriftgröße

setzeListenboxFarbe alistbox Farbe

Befehlen Sie der Farbfarbe, die Vordergrundfarbe des Listenbox Alistbox zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
setzeListenboxFarbe lb "red

Reference:

    Release Notes für Version 4.685

setzeListenboxHintergrundfarbe setzeListenboxSchriftgröße


HC / GUI Programmierung / Listenboxen / setzeListenboxSchriftgröße

setzeListenboxSchriftgröße

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxSchriftgröße
setzeListenboxFarbe setzeListenboxSchriftname

setzeListenboxSchriftgröße alistbox Größe

Kommando, die Schrifthöhe des zu messenden Listenbox Alistbox zu setzen, das eine integre Zahl sein muss.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
setzeListenboxSchriftgröße lb 50

Reference:

    Release Notes für Version 4.685

setzeListenboxFarbe setzeListenboxSchriftname


HC / GUI Programmierung / Listenboxen / setzeListenboxSchriftname

setzeListenboxSchriftname

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxSchriftname
setzeListenboxSchriftgröße setzeListenboxSchriftstil

setzeListenboxSchriftname alistbox Name

Kommando, den Schriftnamen des zu nennenden Listenbox Alistbox zu setzen, das ein plausibler Schriftname sein muss.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
setzeListenboxSchriftname lb [Courier]

Reference:

    Release Notes für Version 4.685

setzeListenboxSchriftgröße setzeListenboxSchriftstil


HC / GUI Programmierung / Listenboxen / setzeListenboxSchriftstil

setzeListenboxSchriftstil

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxSchriftstil
setzeListenboxSchriftname setzeListenboxSchriftdicke

setzeListenboxSchriftstil alistbox Stil

Kommando, den Schriftstil der Listenbox Alistbox zu setzen.

Stil kann eine der Konstanten wxFONTSTYLE_NORMAL wxFONTSTYLE_SLANT wxFONTSTYLE_ITALIC sein.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
setzeListenboxSchriftstil lb wxFONTSTYLE_ITALIC

Reference:

    Release Notes für Version 4.685

setzeListenboxSchriftname setzeListenboxSchriftdicke


HC / GUI Programmierung / Listenboxen / setzeListenboxSchriftdicke

setzeListenboxSchriftdicke

HC [image] GUI Programmierung [image] Listenboxen [image] setzeListenboxSchriftdicke
setzeListenboxSchriftstil beiListenboxZeichen

setzeListenboxSchriftdicke alistbox Gewicht

Kommando, das Schriftgewicht des Listenbox Alistbox zu setzen.

Gewicht kann eine der Konstanten wxFONTWEIGHT_NORMAL wxFONTWEIGHT_LIGHT wxFONTWEIGHT_BOLD sein

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
setzeListenboxSchriftdicke lb wxFONTWEIGHT_BOLD

Reference:

    Release Notes für Version 4.685

setzeListenboxSchriftstil beiListenboxZeichen


HC / GUI Programmierung / Listenboxen / beiListenboxZeichen

beiListenboxZeichen

HC [image] GUI Programmierung [image] Listenboxen [image] beiListenboxZeichen
setzeListenboxSchriftdicke beiGedrückterTasteInListenbox

beiListenboxZeichen alistbox Befehle

Kommando, den Gewohnheitsereignisführer für das Zeichen Ereignis des Listenbox Alistbox zu zu setzen, befiehlt. Sehen Sie auch beiZeichen!

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
beiListenboxZeichen lb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

setzeListenboxSchriftdicke beiGedrückterTasteInListenbox


HC / GUI Programmierung / Listenboxen / beiGedrückterTasteInListenbox

beiGedrückterTasteInListenbox

HC [image] GUI Programmierung [image] Listenboxen [image] beiGedrückterTasteInListenbox
beiListenboxZeichen beiLosgelassenerTasteInListenbox

beiGedrückterTasteInListenbox alistbox Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Runter Ereignis des Listenbox Alistbox zu zu setzen, befiehlt. Sehen Sie auch beiGedrückterTaste!

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
beiGedrückterTasteInListenbox lb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiListenboxZeichen beiLosgelassenerTasteInListenbox


HC / GUI Programmierung / Listenboxen / beiLosgelassenerTasteInListenbox

beiLosgelassenerTasteInListenbox

HC [image] GUI Programmierung [image] Listenboxen [image] beiLosgelassenerTasteInListenbox
beiGedrückterTasteInListenbox beiListenboxAuswahl

beiLosgelassenerTasteInListenbox alistbox Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Rauf zu setzen (=release), Ereignis des Listenbox Alistbox zu Kommandos. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
beiLosgelassenerTasteInListenbox lb [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiGedrückterTasteInListenbox beiListenboxAuswahl


HC / GUI Programmierung / Listenboxen / beiListenboxAuswahl

beiListenboxAuswahl

HC [image] GUI Programmierung [image] Listenboxen [image] beiListenboxAuswahl
beiLosgelassenerTasteInListenbox beiDoppeltgeklickterListenbox

beiListenboxAuswahl alistbox Befehle

Kommando, den Gewohnheitsereignisführer für das auserlesene Ereignis des Listenbox Alistbox zu zu setzen, befiehlt. Das auserlesene Ereignis wird erzeugt wenn der Benutzer eine Wahl mit einem mouseclick oder auswählt ein Tastendruck.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
beiListenboxAuswahl lb [schreibe ListenboxAuswahl]

Reference:

    Release Notes für Version 4.685

beiLosgelassenerTasteInListenbox beiDoppeltgeklickterListenbox


HC / GUI Programmierung / Listenboxen / beiDoppeltgeklickterListenbox

beiDoppeltgeklickterListenbox

HC [image] GUI Programmierung [image] Listenboxen [image] beiDoppeltgeklickterListenbox
beiListenboxAuswahl ListenboxAn

beiDoppeltgeklickterListenbox alistbox Befehle

Kommando, den Gewohnheitsereignisführer für das Mausdoppeltklickereignis des Listenbox Alistbox zu zu setzen, befiehlt.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
beiDoppeltGeklickterListenbox lb [schreibe ListenboxAuswahl]

Reference:

    Release Notes für Version 4.685

beiListenboxAuswahl ListenboxAn


HC / GUI Programmierung / Listenboxen / ListenboxAn

ListenboxAn

HC [image] GUI Programmierung [image] Listenboxen [image] ListenboxAn
beiDoppeltgeklickterListenbox ListControls

ListenboxAn alistbox Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das Listenbox Alistbox, ist Wenn Staat falsch dann sperrt es das ListBox.

Zustand muss ein boolesch sein.

Beispiel:

lb=Listenbox [][LB] [[The erstes String][S2][S3]] [][]
ListenboxAn lb falsch
;Click on the Listenbox again --nothing happens
ListenboxAn lb wahr	;enabled again

Reference:

    Release Notes für Version 4.685

beiDoppeltgeklickterListenbox ListControls


HC / GUI Programmierung / ListControls

ListControls

HC [image] GUI Programmierung [image] ListControls
ListenboxAn ListControl

ListControls

...sind Fenster mit einem ProzedurText-IgelText, die enthalten ein Liste von Listen von Text Optionen, den können führeAus ein Logo-Befehlsliste wenn der Benutzer mit der Maus auf sie klickt wählt und ein Element aus, und wenn ein Schlüsselereignis bekommen wird.

Eine Liste Kontrolle präsentiert Listen in einer Zahl von Formaten: Liste Aussicht, Berichtsansicht, Ikonen Ansichten-Und Kleinikonenansicht. In jedem Fall werden Elemente von null nummeriert. Für all diese Modi, das elemente werden gelagert in das Kontroll-Und muss dazu hinzugefügt werden, dass es InsertItem Methode verbraucht.

ListControls werden in listcontroltest.lg. demonstriert

ListControls

  • ListControl
  • zerstöreListenControl
  • fügeSpalteInListenControlEin
  • fügeElementInListenControlEin
  • setzeListenControlElement
  • holeListenControlElement
  • entferneListenControlElement
  • setzeListenControlZeile
  • setzeListenControlSpalte
  • setzeListenControl
  • holeListenControlZeile
  • holeListenControlSpalte
  • holeListenControlWert
  • zähleListenControlElemente
  • ListenControlSpaltenanzahl
  • ListenControlSpalte
  • ListenControlZeile
  • ListenControlText
  • sortiereListenControl
  • setzeListenControlHintergrundfarbe
  • setzeListenControlFarbe
  • setzeListenControlSchriftgröße
  • setzeListenControlSchriftname
  • setzeListenControlSchriftstil
  • setzeListenControlSchriftdicke
  • beiZeichenInListenControl
  • beiGedrückterTasteInListenControl
  • beiLosgelassenerTasteInListenControl
  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • beiGeklickterListencontrolSpalte
  • ListenControlAn


HC / GUI Programmierung / ListControls / ListControl

ListControl

HC [image] GUI Programmierung [image] ListControls [image] ListControl
ListControls zerstöreListenControl

ListControl Elternteil onItemSelected onItemActivated onColClick
(ListControl Elternteilname nennen)
(ListControl Elternteil Namens onItemSelected onItemActivated onColClick Stil Ort Größe)

Ausgaben, die es ein neues ListControl lc und auf dem Elternteil zeigt (ein Fenster Oder ein Diagramm, Haupt-Diagramm-Wenn []).

Name ist Igeltext ProzedurText.

onItemSelected ist ein Logo-Befehlsliste, das führeAus sein wird, wenn der Benutzer einen Liste Gegenstand auswählt.

onItemActivated ist ein Logo-Befehlsliste, das führeAus sein wird wenn der Benutzer ein Liste Element aktiviert, Benützung jeden der [Treten Sie ein] oder [Platz] Schlüsseldoppeltklicken mit der Maus.

onColClick ist ein Logo-Befehlsliste, das führeAus sein wird, wann der Benutzer links-klickt ein Spalten-Igeltext mit der Maus.

Examples:

  • beiLosgelassenerTasteInListenControl
  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • setzeListenControlHintergrundfarbe
  • beiGedrückterTasteInListenControl
  • beiGeklickterListencontrolSpalte
  • setzeListenControlSchriftdicke
  • setzeListenControlSchriftgröße
  • fügeElementInListenControlEin
  • setzeListenControlSchriftname
  • setzeListenControlSchriftstil
  • entferneListenControlElement
  • fügeSpalteInListenControlEin
  • ListenControlSpaltenanzahl
  • zähleListenControlElemente
  • beiZeichenInListenControl
  • setzeListenControlElement
  • holeListenControlElement
  • setzeListenControlSpalte
  • holeListenControlSpalte
  • setzeListenControlFarbe
  • setzeListenControlZeile
  • holeListenControlZeile
  • holeListenControlWert
  • sortiereListenControl
  • zerstöreListenControl
  • ListenControlSpalte
  • ListenControlZeile
  • setzeListenControl
  • ListenControlText
  • ListenControlAn

References:

    ListenControlAn(3), ListenControlSpalte(2), ListenControlSpaltenanzahl(2), ListenControlText(2), ListenControlZeile(2), Release Notes für Version 4.685(2), beiAktiviertemListenControlElement(2), beiAusgewähltemListenControlElement(2), beiGedrückterTasteInListenControl(2), beiGeklickterListencontrolSpalte(2), beiLosgelassenerTasteInListenControl(2), beiZeichenInListenControl(2), entferneListenControlElement(2), fügeElementInListenControlEin(2), fügeSpalteInListenControlEin(2), holeListenControlElement(2), holeListenControlSpalte(2), holeListenControlWert(2), holeListenControlZeile(2), setzeListenControl(2), setzeListenControlElement(2), setzeListenControlFarbe(2), setzeListenControlHintergrundfarbe(2), setzeListenControlSchriftdicke(2), setzeListenControlSchriftgröße(2), setzeListenControlSchriftname(2), setzeListenControlSchriftstil(2), setzeListenControlSpalte(2), setzeListenControlZeile(2), sortiereListenControl(2), zerstöreListenControl(2), zähleListenControlElemente(2)

ListControls zerstöreListenControl


HC / GUI Programmierung / ListControls / zerstöreListenControl

zerstöreListenControl

HC [image] GUI Programmierung [image] ListControls [image] zerstöreListenControl
ListControl fügeSpalteInListenControlEin

zerstöreListenControl alistcontrol

Kommando, der das ListControl alistcontrol zerstört.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_LIST [0 0][300 200])
fügeSpalteInListenControlEin lc 1 "Logo
data=[[UCBLogo][MSWLogo][Elica][Liogo][aUCBLogo]]
setzeListenControl lc data
zerstöreListenControl lc

Reference:

    Release Notes für Version 4.685

ListControl fügeSpalteInListenControlEin


HC / GUI Programmierung / ListControls / fügeSpalteInListenControlEin

fügeSpalteInListenControlEin

HC [image] GUI Programmierung [image] ListControls [image] fügeSpalteInListenControlEin
zerstöreListenControl fügeElementInListenControlEin

fügeSpalteInListenControlEin alistcontrol col labl
(fügeSpalteInListenControlEin alistcontrol col labl awidth Format)

Kommando, eine neue Spalte ins ListControl alistcontrol beim Spalten-Col mit dem Spalten-Igeltext Labl Und Spaltenbreiten-Awidth einzufügen.

col muss eine positive integre Zahl sein.

labl ist der Spalten-Igeltext ProzedurText.

awidth ist die Spaltenbreite.

Format kann wxLIST_FORMAT_LEFT, wxLIST_FORMAT_RIGHT oder wxLIST_FORMAT_CENTRE, sein.

Beispiele:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
(fügeSpalteInListenControlEin lc 1 [ID] 30)
(fügeSpalteInListenControlEin lc 2 [First Name]
    100 wxLIST_FORMAT_RIGHT)
fügeSpalteInListenControlEin lc 3 [Name]

Examples:

  • beiLosgelassenerTasteInListenControl
  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • setzeListenControlHintergrundfarbe
  • beiGedrückterTasteInListenControl
  • beiGeklickterListencontrolSpalte
  • setzeListenControlSchriftdicke
  • setzeListenControlSchriftgröße
  • fügeElementInListenControlEin
  • setzeListenControlSchriftname
  • setzeListenControlSchriftstil
  • entferneListenControlElement
  • ListenControlSpaltenanzahl
  • zähleListenControlElemente
  • beiZeichenInListenControl
  • setzeListenControlElement
  • holeListenControlElement
  • setzeListenControlSpalte
  • holeListenControlSpalte
  • setzeListenControlFarbe
  • setzeListenControlZeile
  • holeListenControlZeile
  • holeListenControlWert
  • sortiereListenControl
  • zerstöreListenControl
  • ListenControlSpalte
  • ListenControlZeile
  • setzeListenControl
  • ListenControlText
  • ListenControlAn

References:

    sortiereListenControl(3), ListenControlAn(2), ListenControlSpalte(2), ListenControlSpaltenanzahl(2), ListenControlText(2), ListenControlZeile(2), beiAktiviertemListenControlElement(2), beiAusgewähltemListenControlElement(2), beiGedrückterTasteInListenControl(2), beiGeklickterListencontrolSpalte(2), beiLosgelassenerTasteInListenControl(2), beiZeichenInListenControl(2), entferneListenControlElement(2), holeListenControlElement(2), holeListenControlSpalte(2), holeListenControlWert(2), holeListenControlZeile(2), setzeListenControl(2), setzeListenControlElement(2), setzeListenControlFarbe(2), setzeListenControlHintergrundfarbe(2), setzeListenControlSchriftdicke(2), setzeListenControlSchriftgröße(2), setzeListenControlSchriftname(2), setzeListenControlSchriftstil(2), setzeListenControlSpalte(2), setzeListenControlZeile(2), zähleListenControlElemente(2), Release Notes für Version 4.685, fügeElementInListenControlEin, zerstöreListenControl

zerstöreListenControl fügeElementInListenControlEin


HC / GUI Programmierung / ListControls / fügeElementInListenControlEin

fügeElementInListenControlEin

HC [image] GUI Programmierung [image] ListControls [image] fügeElementInListenControlEin
fügeSpalteInListenControlEin setzeListenControlElement

fügeElementInListenControlEin alistcontrol arow

Befehlen Sie, ein neues Element (eine Zeile in wxLC_REPORT-Modus) ins ListControl alistcontrol bei Reihen-Arow einfügend.

arow ist die Zeile vom neuen Element, einer null-basierten integren Zahl.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_LIST [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeElementInListenControlEin lc 0
setzeListenControlElement lc 0 0 [UCBLogo]

Example:

  • setzeListenControlElement

References:

    setzeListenControlElement(2), Release Notes für Version 4.685

fügeSpalteInListenControlEin setzeListenControlElement


HC / GUI Programmierung / ListControls / setzeListenControlElement

setzeListenControlElement

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlElement
fügeElementInListenControlEin holeListenControlElement

setzeListenControlElement alistcontrol arow col aitem

Kommando, das Element-Aitem an Position (Spalten-Col, Reihen-Arow) des ListControl alistcontrol zu setzen.

arow ist die Zeile (Y in wxLC_REPORT-Modus) von dem Element, das festgeworden ist. Es ist eine null-basierte Ganzzahl.

col ist die Spalte (X in wxLC_REPORT-Modus) vom Gegenstand. Es ist eine null-basierte Ganzzahl.

aitem ist das Element-Text, das festgeworden ist.

Beispiele:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
fügeElementInListenControlEin lc 0
fügeElementInListenControlEin lc 1
setzeListenControlElement lc 0 0 [UCBLogo]
setzeListenControlElement lc 0 1 [Brian Harvey]
setzeListenControlElement lc 1 0 [MSWLogo]
setzeListenControlElement lc 1 1 [George Mills]

Example:

  • fügeElementInListenControlEin

References:

    Release Notes für Version 4.685, fügeElementInListenControlEin

fügeElementInListenControlEin holeListenControlElement


HC / GUI Programmierung / ListControls / holeListenControlElement

holeListenControlElement

HC [image] GUI Programmierung [image] ListControls [image] holeListenControlElement
setzeListenControlElement entferneListenControlElement

holeListenControlElement alistcontrol arow col

Ausgaben das Text des Elements des Elements an Position (Spalten-Col, Reihen-Arow) des ListControl alistcontrol.

arow ist die Zeile (Y in wxLC_REPORT-Modus) von dem Element, das geholt wird. Es ist eine null-basierte Ganzzahl.

col ist die Spalte (X in wxLC_REPORT-Modus) vom Gegenstand. Es ist eine null-basierte Ganzzahl.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
zeige holeListenControlElement lc 0 1

Reference:

    Release Notes für Version 4.685

setzeListenControlElement entferneListenControlElement


HC / GUI Programmierung / ListControls / entferneListenControlElement

entferneListenControlElement

HC [image] GUI Programmierung [image] ListControls [image] entferneListenControlElement
holeListenControlElement setzeListenControlZeile

entferneListenControlElement alistcontrol arow

Kommando, das Reihen-Arow des ListControl alistcontrol zu streichen.

arow ist die Zeile (Y in wxLC_REPORT-Modus), die gestrichen wird. Es ist eine null-basierte Ganzzahl.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
entferneListenControlElement lc 0

Reference:

    Release Notes für Version 4.685

holeListenControlElement setzeListenControlZeile


HC / GUI Programmierung / ListControls / setzeListenControlZeile

setzeListenControlZeile

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlZeile
entferneListenControlElement setzeListenControlSpalte

setzeListenControlZeile alistcontrol arow Daten

Befehlen Sie dem Liste von elemente in Daten, die Zeile bei arow des ListControl alistcontrol zu setzen.

arow ist die Zeile (Y in wxLC_REPORT-Modus), die festgeworden ist. Es ist eine null-basierte Ganzzahl.

Daten sind ein Liste von elemente, den Spalten entsprechend.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlZeile lc 0 [Liogo [Lionel Laske]]

Reference:

    Release Notes für Version 4.685

entferneListenControlElement setzeListenControlSpalte


HC / GUI Programmierung / ListControls / setzeListenControlSpalte

setzeListenControlSpalte

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlSpalte
setzeListenControlZeile setzeListenControl

setzeListenControlSpalte alistcontrol col Daten

Befehlen Sie dem Liste von elemente in Daten, die Spalte bei col des ListControl alistcontrol zu setzen.

col ist die Spalte (X in wxLC_REPORT-Modus), die festgeworden ist. Es ist eine null-basierte Ganzzahl.

Daten sind ein Liste von elemente, den Zeilen entsprechend.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlSpalte lc 1 [Brian George]

Reference:

    Release Notes für Version 4.685

setzeListenControlZeile setzeListenControl


HC / GUI Programmierung / ListControls / setzeListenControl

setzeListenControl

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControl
setzeListenControlSpalte holeListenControlZeile

setzeListenControl alistcontrol Daten

Befehlen Sie dem Liste von Zeilen (die Listen von Spalten-Elemente sind) in Daten, das elemente des ListControl alistcontrol zu setzen.

Daten sind ein Liste von Zeilen. Ein Element von Zeilen ist ein Liste von elemente, den Spalten entsprechend.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]

Examples:

  • beiLosgelassenerTasteInListenControl
  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • setzeListenControlHintergrundfarbe
  • beiGedrückterTasteInListenControl
  • beiGeklickterListencontrolSpalte
  • setzeListenControlSchriftdicke
  • setzeListenControlSchriftgröße
  • setzeListenControlSchriftname
  • setzeListenControlSchriftstil
  • entferneListenControlElement
  • ListenControlSpaltenanzahl
  • zähleListenControlElemente
  • beiZeichenInListenControl
  • holeListenControlElement
  • setzeListenControlSpalte
  • holeListenControlSpalte
  • setzeListenControlFarbe
  • setzeListenControlZeile
  • holeListenControlZeile
  • holeListenControlWert
  • sortiereListenControl
  • zerstöreListenControl
  • ListenControlSpalte
  • ListenControlZeile
  • ListenControlText
  • ListenControlAn

References:

    ListenControlAn, ListenControlSpalte, ListenControlSpaltenanzahl, ListenControlText, ListenControlZeile, Release Notes für Version 4.685, beiAktiviertemListenControlElement, beiAusgewähltemListenControlElement, beiGedrückterTasteInListenControl, beiGeklickterListencontrolSpalte, beiLosgelassenerTasteInListenControl, beiZeichenInListenControl, entferneListenControlElement, holeListenControlElement, holeListenControlSpalte, holeListenControlWert, holeListenControlZeile, setzeListenControlFarbe, setzeListenControlHintergrundfarbe, setzeListenControlSchriftdicke, setzeListenControlSchriftgröße, setzeListenControlSchriftname, setzeListenControlSchriftstil, setzeListenControlSpalte, setzeListenControlZeile, sortiereListenControl, zerstöreListenControl, zähleListenControlElemente

setzeListenControlSpalte holeListenControlZeile


HC / GUI Programmierung / ListControls / holeListenControlZeile

holeListenControlZeile

HC [image] GUI Programmierung [image] ListControls [image] holeListenControlZeile
setzeListenControl holeListenControlSpalte

holeListenControlZeile alistcontrol arow

Ausgaben die Zeile bei arow vom ListControl alistcontrol.

arow ist die Zeile (Y in wxLC_REPORT-Modus), die geholt wird. Es ist eine null-basierte Ganzzahl.

Ausgabe ist ein Liste von elemente, den Spalten entsprechend, (Wörter).

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
zeige holeListenControlZeile lc 0
zeige erstes ohneErstes holeListenControlZeile lc 0	;It's a wort

Reference:

    Release Notes für Version 4.685

setzeListenControl holeListenControlSpalte


HC / GUI Programmierung / ListControls / holeListenControlSpalte

holeListenControlSpalte

HC [image] GUI Programmierung [image] ListControls [image] holeListenControlSpalte
holeListenControlZeile holeListenControlWert

holeListenControlSpalte alistcontrol col Daten

Ausgaben die Spalte bei col vom ListControl alistcontrol.

col ist die Spalte (X in wxLC_REPORT-Modus), die geholt wird. Es ist eine null-basierte Ganzzahl.

Ausgabe ist ein Liste von elemente, den Zeilen entsprechend, (Wörter).

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
zeige holeListenControlSpalte lc 1

Reference:

    Release Notes für Version 4.685

holeListenControlZeile holeListenControlWert


HC / GUI Programmierung / ListControls / holeListenControlWert

holeListenControlWert

HC [image] GUI Programmierung [image] ListControls [image] holeListenControlWert
holeListenControlSpalte zähleListenControlElemente

holeListenControlWert alistcontrol

Ausgaben das elemente des ListControl alistcontrol.

Ausgabe ist ein Liste von Zeilen. Ein Element von Zeilen ist ein Liste von elemente, den Spalten entsprechend, (Wörter).

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
zeige holeListenControlWert lc

Reference:

    Release Notes für Version 4.685

holeListenControlSpalte zähleListenControlElemente


HC / GUI Programmierung / ListControls / zähleListenControlElemente

zähleListenControlElemente

HC [image] GUI Programmierung [image] ListControls [image] zähleListenControlElemente
holeListenControlWert ListenControlSpaltenanzahl

zähleListenControlElemente alistcontrol

Ausgaben das Element-Zähle (die Anzahl von Zeilen in wxLC_REPORT-Modus) des ListControl alistcontrol.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
zeige zähleListenControlElemente lc

Reference:

    Release Notes für Version 4.685

holeListenControlWert ListenControlSpaltenanzahl


HC / GUI Programmierung / ListControls / ListenControlSpaltenanzahl

ListenControlSpaltenanzahl

HC [image] GUI Programmierung [image] ListControls [image] ListenControlSpaltenanzahl
zähleListenControlElemente ListenControlSpalte

ListenControlSpaltenanzahl alistcontrol

Ausgaben das Spalten-Zähle (die Anzahl von Spalten in wxLC_REPORT-Modus) des ListControl alistcontrol.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
zeige ListenControlSpaltenanzahl lc

Reference:

    Release Notes für Version 4.685

zähleListenControlElemente ListenControlSpalte


HC / GUI Programmierung / ListControls / ListenControlSpalte

ListenControlSpalte

HC [image] GUI Programmierung [image] ListControls [image] ListenControlSpalte
ListenControlSpaltenanzahl ListenControlZeile

ListenControlSpalte

Ausgaben die Spalte, das späteste Ereignis eines ListControl bearbeitet wurde.

Beispiele:

lc=(ListControl [][MyListControl]
    [	row=ListenControlZeile
        (schreibe wort [row=] row
            wort [column=] ListenControlSpalte
            ListenControlText
            [Selected])
    ]
    [	(schreibe wort [row=] ListenControlZeile
            wort [column=] ListenControlSpalte
            ListenControlText
            [Activated])
    ]
    [	c=ListenControlSpalte
        (schreibe wort [column=] c
            [Columnclick])
        sortiereListenControl lc c
    ] wxLC_REPORT [10 20][400 300])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]

Examples:

  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • beiGeklickterListencontrolSpalte
  • ListenControlZeile
  • ListenControlText

References:

    ListenControlText(3), ListenControlZeile(3), Release Notes für Version 4.685, beiAktiviertemListenControlElement, beiAusgewähltemListenControlElement, beiGeklickterListencontrolSpalte

ListenControlSpaltenanzahl ListenControlZeile


HC / GUI Programmierung / ListControls / ListenControlZeile

ListenControlZeile

HC [image] GUI Programmierung [image] ListControls [image] ListenControlZeile
ListenControlSpalte ListenControlText

ListenControlZeile

Ausgaben die Zeile, das späteste Ereignis eines ListControl bearbeitet wurde.

Beispiele:

lc=(ListControl [][MyListControl]
    [	row=ListenControlZeile
        (schreibe wort [row=] row
            wort [column=] ListenControlSpalte
            ListenControlText
            [Selected])
    ]
    [	(schreibe wort [row=] ListenControlZeile
            wort [column=] ListenControlSpalte
            ListenControlText
            [Activated])
    ]
    [	c=ListenControlSpalte
        (schreibe wort [column=] c
            [Columnclick])
        sortiereListenControl lc c
    ] wxLC_REPORT [10 20][400 300])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]

Examples:

  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • ListenControlSpalte
  • ListenControlText

References:

    ListenControlSpalte(2), ListenControlText(2), Release Notes für Version 4.685, beiAktiviertemListenControlElement, beiAusgewähltemListenControlElement

ListenControlSpalte ListenControlText


HC / GUI Programmierung / ListControls / ListenControlText

ListenControlText

HC [image] GUI Programmierung [image] ListControls [image] ListenControlText
ListenControlZeile sortiereListenControl

ListenControlText

Ausgaben das Element-Text der erstes Spalte in der Zeile, das späteste Ereignis eines ListControl bearbeitet wurde.

Beispiele:

lc=(ListControl [][MyListControl]
    [	row=ListenControlZeile
        (schreibe wort [row=] row
            wort [column=] ListenControlSpalte
            ListenControlText
            [Selected])
    ]
    [	(schreibe wort [row=] ListenControlZeile
            wort [column=] ListenControlSpalte
            ListenControlText
            [Activated])
    ]
    [	c=ListenControlSpalte
        (schreibe wort [column=] c
            [Columnclick])
        sortiereListenControl lc c
    ] wxLC_REPORT [10 20][400 300])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]

Examples:

  • beiAusgewähltemListenControlElement
  • beiAktiviertemListenControlElement
  • ListenControlSpalte
  • ListenControlZeile

References:

    ListenControlSpalte(2), ListenControlZeile(2), Release Notes für Version 4.685, beiAktiviertemListenControlElement, beiAusgewähltemListenControlElement

ListenControlZeile sortiereListenControl


HC / GUI Programmierung / ListControls / sortiereListenControl

sortiereListenControl

HC [image] GUI Programmierung [image] ListControls [image] sortiereListenControl
ListenControlText setzeListenControlHintergrundfarbe

sortiereListenControl alistcontrol col

Kommando, das ListControl alistcontrol von Spaltenanzahl-Col zu sortieren.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [col0]
fügeSpalteInListenControlEin lc 1 [col1]
fügeSpalteInListenControlEin lc 2 [col2]
setzeListenControl lc [
    [1  3 A]
    [2  1 B]
    [3 10 C]]
sortiereListenControl lc 1
sortiereListenControl lc 2

Examples:

  • beiGeklickterListencontrolSpalte
  • ListenControlSpalte
  • ListenControlZeile
  • ListenControlText

References:

    ListenControlSpalte, ListenControlText, ListenControlZeile, Release Notes für Version 4.685, beiGeklickterListencontrolSpalte

ListenControlText setzeListenControlHintergrundfarbe


HC / GUI Programmierung / ListControls / setzeListenControlHintergrundfarbe

setzeListenControlHintergrundfarbe

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlHintergrundfarbe
sortiereListenControl setzeListenControlFarbe

setzeListenControlHintergrundfarbe alistcontrol Farbe

Befehlen Sie der Farbfarbe, die Hintergrundfarbe des ListControl alistcontrol zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlHintergrundfarbe lc "red

Reference:

    Release Notes für Version 4.685

sortiereListenControl setzeListenControlFarbe


HC / GUI Programmierung / ListControls / setzeListenControlFarbe

setzeListenControlFarbe

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlFarbe
setzeListenControlHintergrundfarbe setzeListenControlSchriftgröße

setzeListenControlFarbe alistcontrol Farbe

Befehlen Sie der Farbfarbe, die Vordergrundfarbe des ListControl alistcontrol zu setzen.

Farbe muss eine plausible Farbe sein, auch setzeStiftfarbe sehen!

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlFarbe lc "red

Reference:

    Release Notes für Version 4.685

setzeListenControlHintergrundfarbe setzeListenControlSchriftgröße


HC / GUI Programmierung / ListControls / setzeListenControlSchriftgröße

setzeListenControlSchriftgröße

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlSchriftgröße
setzeListenControlFarbe setzeListenControlSchriftname

setzeListenControlSchriftgröße alistcontrol Größe

Kommando, die Schrifthöhe des zu messenden ListControl alistcontrol zu setzen, das eine integre Zahl sein muss.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlSchriftgröße lc 50

Reference:

    Release Notes für Version 4.685

setzeListenControlFarbe setzeListenControlSchriftname


HC / GUI Programmierung / ListControls / setzeListenControlSchriftname

setzeListenControlSchriftname

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlSchriftname
setzeListenControlSchriftgröße setzeListenControlSchriftstil

setzeListenControlSchriftname alistcontrol Name

Kommando, den Schriftnamen des zu nennenden ListControl alistcontrol zu setzen, das ein plausibler Schriftname sein muss.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlSchriftname lc [Courier]

Reference:

    Release Notes für Version 4.685

setzeListenControlSchriftgröße setzeListenControlSchriftstil


HC / GUI Programmierung / ListControls / setzeListenControlSchriftstil

setzeListenControlSchriftstil

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlSchriftstil
setzeListenControlSchriftname setzeListenControlSchriftdicke

setzeListenControlSchriftstil alistcontrol Stil

Kommando, den Schriftstil des ListControl alistcontrol zu setzen.

Stil kann eine der Konstanten wxFONTSTYLE_NORMAL wxFONTSTYLE_SLANT wxFONTSTYLE_ITALIC sein.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlSchriftstil lc wxFONTSTYLE_ITALIC

Reference:

    Release Notes für Version 4.685

setzeListenControlSchriftname setzeListenControlSchriftdicke


HC / GUI Programmierung / ListControls / setzeListenControlSchriftdicke

setzeListenControlSchriftdicke

HC [image] GUI Programmierung [image] ListControls [image] setzeListenControlSchriftdicke
setzeListenControlSchriftstil beiZeichenInListenControl

setzeListenControlSchriftdicke alistbox Gewicht

Kommando, das Schriftgewicht des ListControl alistcontrol zu setzen.

Gewicht kann eine der Konstanten wxFONTWEIGHT_NORMAL wxFONTWEIGHT_LIGHT wxFONTWEIGHT_BOLD sein

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
setzeListenControlSchriftdicke lc wxFONTWEIGHT_BOLD

Reference:

    Release Notes für Version 4.685

setzeListenControlSchriftstil beiZeichenInListenControl


HC / GUI Programmierung / ListControls / beiZeichenInListenControl

beiZeichenInListenControl

HC [image] GUI Programmierung [image] ListControls [image] beiZeichenInListenControl
setzeListenControlSchriftdicke beiGedrückterTasteInListenControl

beiZeichenInListenControl alistcontrol Befehle

Kommando, den Gewohnheitsereignisführer für das Zeichen Ereignis des ListControl alistcontrol zu zu setzen, befiehlt. Sehen Sie auch beiZeichen!

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
beiZeichenInListenControl lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

setzeListenControlSchriftdicke beiGedrückterTasteInListenControl


HC / GUI Programmierung / ListControls / beiGedrückterTasteInListenControl

beiGedrückterTasteInListenControl

HC [image] GUI Programmierung [image] ListControls [image] beiGedrückterTasteInListenControl
beiZeichenInListenControl beiLosgelassenerTasteInListenControl

beiGedrückterTasteInListenControl alistcontrol Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Runter Ereignis des ListControl alistcontrol zu zu setzen, befiehlt. Sehen Sie auch beiGedrückterTaste!

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
beiGedrückterTasteInListenControl lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiZeichenInListenControl beiLosgelassenerTasteInListenControl


HC / GUI Programmierung / ListControls / beiLosgelassenerTasteInListenControl

beiLosgelassenerTasteInListenControl

HC [image] GUI Programmierung [image] ListControls [image] beiLosgelassenerTasteInListenControl
beiGedrückterTasteInListenControl beiAusgewähltemListenControlElement

beiLosgelassenerTasteInListenControl alistcontrol Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Rauf zu setzen (=release), Ereignis des ListControl alistcontrol zu Kommandos. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]]
beiLosgelassenerTasteInListenControl lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiGedrückterTasteInListenControl beiAusgewähltemListenControlElement


HC / GUI Programmierung / ListControls / beiAusgewähltemListenControlElement

beiAusgewähltemListenControlElement

HC [image] GUI Programmierung [image] ListControls [image] beiAusgewähltemListenControlElement
beiLosgelassenerTasteInListenControl beiAktiviertemListenControlElement

beiAusgewähltemListenControlElement alistcontrol Befehle

Kommando, den Gewohnheitsereignisführer für das LIST_ITEM_SELECTED-Ereignis des ListControl alistcontrol zu zu setzen, befiehlt.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]
]
beiAusgewähltemListenControlElement lc [
        (schreibe wort [row=] ListenControlZeile
            wort [column=] ListenControlSpalte
            ListenControlText
            [Selected])
    ]

Reference:

    Release Notes für Version 4.685

beiLosgelassenerTasteInListenControl beiAktiviertemListenControlElement


HC / GUI Programmierung / ListControls / beiAktiviertemListenControlElement

beiAktiviertemListenControlElement

HC [image] GUI Programmierung [image] ListControls [image] beiAktiviertemListenControlElement
beiAusgewähltemListenControlElement beiGeklickterListencontrolSpalte

beiAktiviertemListenControlElement alistcontrol Befehle

Kommando, den Gewohnheitsereignisführer für das LIST_ITEM_ACTIVATED-Ereignis (GEBEN Sie Oder Doppeltklick EIN) des ListControl alistcontrol zu zu setzen, befiehlt.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]
]
beiAktiviertemListenControlElement lc [
        (schreibe wort [row=] ListenControlZeile
            wort [column=] ListenControlSpalte
            ListenControlText
            [Activated])
    ]

Reference:

    Release Notes für Version 4.685

beiAusgewähltemListenControlElement beiGeklickterListencontrolSpalte


HC / GUI Programmierung / ListControls / beiGeklickterListencontrolSpalte

beiGeklickterListencontrolSpalte

HC [image] GUI Programmierung [image] ListControls [image] beiGeklickterListencontrolSpalte
beiAktiviertemListenControlElement ListenControlAn

beiGeklickterListencontrolSpalte alistcontrol Befehle

Kommando, den Gewohnheitsereignisführer für das LIST_COL_CLICK-Ereignis (klicken Sie auf ein Spalten-Igeltext) des ListControl alistcontrol zu zu setzen, befiehlt.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]
]
beiGeklickterListenControlSpalte lc [
        c=ListenControlSpalte
        (schreibe wort [column=] c
            [Columnclick])
        sortiereListenControl lc c
    ]

Reference:

    Release Notes für Version 4.685

beiAktiviertemListenControlElement ListenControlAn


HC / GUI Programmierung / ListControls / ListenControlAn

ListenControlAn

HC [image] GUI Programmierung [image] ListControls [image] ListenControlAn
beiGeklickterListencontrolSpalte RadioButtons

ListenControlAn alistcontrol Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das ListControl alistcontrol, ist Wenn Staat falsch dann sperrt es das ListControl.

Zustand muss ein boolesch sein.

Beispiel:

lc=(ListControl [][MyListControl][][][]
    wxLC_REPORT [0 0][300 200])
fügeSpalteInListenControlEin lc 0 [Logo]
fügeSpalteInListenControlEin lc 1 [Main Author]
setzeListenControl lc [
    [UCBLogo [Brian Harvey]]
    [MSWLogo [George Mills]]
]
ListenControlAn lc falsch
;Click on the Zahlbox again --nothing happens
ListenControlAn lc wahr	;enabled again

Reference:

    Release Notes für Version 4.685

beiGeklickterListencontrolSpalte RadioButtons


HC / GUI Programmierung / RadioButtons

RadioButtons

HC [image] GUI Programmierung [image] RadioButtons
ListenControlAn Radioknopf

RadioButtons

...sind Fenster etwas ein Rundfunk-Knopf Und enthaltend ein Text igeltext, den können führeAus ein Logo-Befehlsliste wenn der Benutzer mit der Maus auf sie klickt überprüft sie und. CheckBoxes werden in buttontest.lg. demonstriert

RadioButtons

  • Radioknopf
  • zerstöreRadioknopf
  • beiGeklicktemRadioKnopf
  • RadioknopfWert
  • setzeRadioknopf
  • RadioknopfAn


HC / GUI Programmierung / RadioButtons / Radioknopf

Radioknopf

HC [image] GUI Programmierung [image] RadioButtons [image] Radioknopf
RadioButtons zerstöreRadioknopf

Radioknopf Elternteil Igeltext Onclick
(Radioknopf Elternteil Igeltext Onclick Stil Ort Größe)

Ausgaben ein neuer Radioknopf auf dem Elternteil (ein Fenster Oder ein Diagramm),

das Text igeltext darauf haben,

und, das das onclick instructionlist laufen lässt, wenn der Benutzer mit der Maus darauf klickt.

Examples:

  • beiGeklicktemRadioKnopf
  • zerstöreRadioknopf
  • setzeRadioknopf
  • RadioknopfWert
  • RadioknopfAn

References:

    RadioknopfAn(3), beiGeklicktemRadioKnopf(3), RadioknopfWert(2), Release Notes für Version 4.685(2), setzeRadioknopf(2), zerstöreRadioknopf(2)

RadioButtons zerstöreRadioknopf


HC / GUI Programmierung / RadioButtons / zerstöreRadioknopf

zerstöreRadioknopf

HC [image] GUI Programmierung [image] RadioButtons [image] zerstöreRadioknopf
Radioknopf beiGeklicktemRadioKnopf

zerstöreRadioknopf aradiobutton

Kommando, der das Radioknopf Aradiobutton zerstört.

Beispiel:

rb=(Radioknopf [][normalerStift]
[	wenn RadioknopfWert rb [normalerStift setzeStiftfarbe 0]
] wxRB_GROUP)
zerstöreRadioknopf rb

Reference:

    Release Notes für Version 4.685

Radioknopf beiGeklicktemRadioKnopf


HC / GUI Programmierung / RadioButtons / beiGeklicktemRadioKnopf

beiGeklicktemRadioKnopf

HC [image] GUI Programmierung [image] RadioButtons [image] beiGeklicktemRadioKnopf
zerstöreRadioknopf RadioknopfWert

beiGeklicktemRadioKnopf aradiobutton instructionlist

Kommando, der den onClick Ereignisroutine des Radioknopf Aradiobutton zu den Kommandos im Befehlsliste setzt.

Beispiele:

rb=(Radioknopf [][normalerStift][] wxRB_GROUP)
beiGeklicktemRadioknopf rb [
    wenn RadioknopfWert rb [normalerStift setzeStiftfarbe 0]
]
beiGeklicktemRadioknopf cb []	;like disabling the Radioknopf

Reference:

    Release Notes für Version 4.685

zerstöreRadioknopf RadioknopfWert


HC / GUI Programmierung / RadioButtons / RadioknopfWert

RadioknopfWert

HC [image] GUI Programmierung [image] RadioButtons [image] RadioknopfWert
beiGeklicktemRadioKnopf setzeRadioknopf

RadioknopfWert aradiobutton

Ausgaben-Wahr Wenn der Radioknopf aradiobutton wird überprüft, falsch sonst.

Beispiel:

rb=(Radioknopf [][normalerStift]
[	wenn RadioknopfWert rb [schreibe [checked]]
] wxRB_GROUP)

Examples:

  • beiGeklicktemRadioKnopf
  • zerstöreRadioknopf
  • setzeRadioknopf
  • RadioknopfAn

References:

    RadioknopfAn, Release Notes für Version 4.685, beiGeklicktemRadioKnopf, setzeRadioknopf, zerstöreRadioknopf

beiGeklicktemRadioKnopf setzeRadioknopf


HC / GUI Programmierung / RadioButtons / setzeRadioknopf

setzeRadioknopf

HC [image] GUI Programmierung [image] RadioButtons [image] setzeRadioknopf
RadioknopfWert RadioknopfAn

setzeRadioknopf acheckbox Staat

Kommando, den setzt das Radioknopf Aradiobutton zu überprüftem wenn angeben, ist wahr, zu ungehemmtem wenn nicht wahr.

Zustand muss ein boolesch sein.

Beispiel:

rb=(Radioknopf [][normalerStift]
[	wenn RadioknopfWert rb [schreibe [checked]]
] wxRB_GROUP)
setzeRadioknopf rb wahr
setzeRadioknopf rb falsch

Reference:

    Release Notes für Version 4.685

RadioknopfWert RadioknopfAn


HC / GUI Programmierung / RadioButtons / RadioknopfAn

RadioknopfAn

HC [image] GUI Programmierung [image] RadioButtons [image] RadioknopfAn
setzeRadioknopf Schiebe-Regler

RadioknopfAn aradiobutton Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das Radioknopf Aradiobutton, ist Wenn Staat falsch dann sperrt es das RadioButton.

Zustand muss ein boolesch sein.

Beispiel:

rb=(Radioknopf [][normalerStift]
[	wenn RadioknopfWert rb [schreibe [checked]]
] wxRB_GROUP)
RadioknopfAn rb falsch
;Click on the Radioknopf again --nothing happens
RadioknopfAn rb wahr	;enabled again

Reference:

    Release Notes für Version 4.685

setzeRadioknopf Schiebe-Regler


HC / GUI Programmierung / Schiebe-Regler

Schiebe-Regler

HC [image] GUI Programmierung [image] Schiebe-Regler
RadioknopfAn Schieberegler

Schiebe-Regler

Ein Schieberegler ist ein wenig enthaltendes Fenster mit einem ProzedurText-IgelText, und einem Schieberegler Control für Verwendung mit Ganzzahlen. Es hält den Wert einer integren Zahl, die vom Benutzer mit den Pfeiltasten verändert werden kann, oder von draging von oder, das auf das schieberegler mit der Maus klickt.

Schieberegler wird in slidertest.lg. demonstriert

Schiebe-Regler

  • Schieberegler
  • zerstöreSchieberegler
  • SchiebereglerWert
  • setzeSchiebereglerWert
  • setzeSchiebereglerBereich
  • beiSchiebereglerVerschiebung
  • SchiebereglerAn


HC / GUI Programmierung / Schiebe-Regler / Schieberegler

Schieberegler

HC [image] GUI Programmierung [image] Schiebe-Regler [image] Schieberegler
Schiebe-Regler zerstöreSchieberegler

Schieberegler Elternteilnamens Kleinstes schätzen größtes onScroll
(Schieberegler Elternteil Name Kleinstes Wert größtes)
(Schieberegler Elternteil Name Kleinstes Wert größtes onScroll Stil Ort Größe)

Ausgaben ein neuer Schieberegler auf dem Elternteil (ein Fenster Oder ein Diagramm, Haupt-Diagramm-Wenn []).

Name ist das igeltext Text und der Name der Kontrolle.

kleinstes ist das minimale erlaubte Wert, den die Kontrolle akzeptiert.

Wert ist die beim Start gezeigte Anzahl von der Kontrolle.

größtes ist das maximale erlaubte Wert, den die Kontrolle akzeptiert.

kleinstes, Wert und größtes muss integre Zahlen sein.

onChange ist ein Befehls-Liste, das führeAus wenn sein wird, das OnChange Ereignis der Kontrolle wird bearbeitet. Das ist, wann auch immer die Zahl in der Kontrolle sich ändert.

Stil ist das Fenster Stil-Und kann eine Mischung aus den folgenden Konstanten sein:

wxSL_HORIZONTAL Zeigt das schieberegler horizontal (dies ist die Vorgabe).

wxSL_VERTICAL zeigt das schieberegler vertikal.

wxSL_AUTOTICKS zeigt Häkchenzeichen.

wxSL_LABELS zeigt Minimum, maximale Und Wertlabel.

wxSL_LEFT Zeigt Häkchen links Und Kräfte das schieberegler, um vertikal zu sein.

wxSL_RIGHT Zeigt Häkchen rechts Und Kräfte das schieberegler, um vertikal zu sein.

wxSL_TOP zeigt Häkchen auf der Oberkante.

wxSL_BOTTOM zeigt Häkchen auf dem Unterkante (dies ist die Vorgabe).

wxSL_SELRANGE Erlaubt der Benutzer, um eine Windows nur. Bereich auf dem Schleifer auszuwählen.

wxSL_INVERSE Gegenteile die Mininum Und Maximalendpunkte auf dem Schleifer. Nicht kompatibel mit wxSL_SELRANGE.

Examples:

  • beiSchiebereglerVerschiebung
  • setzeSchiebereglerBereich
  • setzeSchiebereglerWert
  • zerstöreSchieberegler
  • SchiebereglerWert
  • SchiebereglerAn

References:

    Schiebe-Regler(4), SchiebereglerAn(3), SchiebereglerWert(3), Release Notes für Version 4.685(2), setzeSchiebereglerBereich(2), setzeSchiebereglerWert(2), zerstöreSchieberegler(2), beiSchiebereglerVerschiebung

Schiebe-Regler zerstöreSchieberegler


HC / GUI Programmierung / Schiebe-Regler / zerstöreSchieberegler

zerstöreSchieberegler

HC [image] GUI Programmierung [image] Schiebe-Regler [image] zerstöreSchieberegler
Schieberegler SchiebereglerWert

zerstöreSchieberegler aslider

Kommando, das Schieberegler Aslider zu zerstören.

Beispiel:

s=(Schieberegler [][X] -400 0 400 [x=SchiebereglerWert (schreibe "x= x)]
    wxSL_horizontal+wxSL_Labels+wxSL_Ticks
    [10 220][200 80])
zerstöreSchieberegler s

Reference:

    Release Notes für Version 4.685

Schieberegler SchiebereglerWert


HC / GUI Programmierung / Schiebe-Regler / SchiebereglerWert

SchiebereglerWert

HC [image] GUI Programmierung [image] Schiebe-Regler [image] SchiebereglerWert
zerstöreSchieberegler setzeSchiebereglerWert

SchiebereglerWert
(SchiebereglerWert aslider)

Ausgaben der Integer-Wert des ohne Argumente angerufenen Schieberegler Aslider Oder Wenn, vom Schieberegler dessen Ereignis neuerdings bearbeitet wird.

Beispiel:

s=(Schieberegler [][X] -400 0 400 [x=SchiebereglerWert (schreibe "x= x)]
    wxSL_horizontal+wxSL_Labels+wxSL_Ticks
    [10 220][200 80])

Examples:

  • beiSchiebereglerVerschiebung
  • setzeSchiebereglerBereich
  • setzeSchiebereglerWert
  • zerstöreSchieberegler
  • SchiebereglerAn

References:

    SchiebereglerAn, beiSchiebereglerVerschiebung, setzeSchiebereglerBereich, setzeSchiebereglerWert, zerstöreSchieberegler

zerstöreSchieberegler setzeSchiebereglerWert


HC / GUI Programmierung / Schiebe-Regler / setzeSchiebereglerWert

setzeSchiebereglerWert

HC [image] GUI Programmierung [image] Schiebe-Regler [image] setzeSchiebereglerWert
SchiebereglerWert setzeSchiebereglerBereich

setzeSchiebereglerWert aslider Wert

Befehlen Sie dem integren Zahlenwert, den Wert des Schieberegler Aslider zu setzen.

Beispiel:

s=(Schieberegler [][X] -400 0 400 [x=SchiebereglerWert (schreibe "x= x)]
    wxSL_horizontal+wxSL_Labels+wxSL_Ticks
    [10 220][200 80])
setzeSchiebereglerWert s 123


HC / GUI Programmierung / Schiebe-Regler / setzeSchiebereglerBereich

setzeSchiebereglerBereich

HC [image] GUI Programmierung [image] Schiebe-Regler [image] setzeSchiebereglerBereich
setzeSchiebereglerWert beiSchiebereglerVerschiebung

setzeSchiebereglerBereich aslider kleinstes größtes

Kommando, die Bereich von plausiblen Anzahlen vom Schieberegler Aslider zu setzen, zwischen den Zahlen-Kleinstes Und Größtes zu bleiben, inklusive.

Beispiel:

s=(Schieberegler [][X] -400 0 400 [x=SchiebereglerWert (schreibe "x= x)]
    wxSL_horizontal+wxSL_Labels+wxSL_Ticks
    [10 220][200 80])
setzeSchiebereglerBereich s -10 20


HC / GUI Programmierung / Schiebe-Regler / beiSchiebereglerVerschiebung

beiSchiebereglerVerschiebung

HC [image] GUI Programmierung [image] Schiebe-Regler [image] beiSchiebereglerVerschiebung
setzeSchiebereglerBereich SchiebereglerAn

beiSchiebereglerVerschiebung aslider Befehle

Befehlen Sie, dass aslider, um den OnScroll Ereignisroutine des Schiebereglers zu setzen, zu dem commandlist befiehlt.

Beispiel:

s=(Schieberegler [][X] -400 0 400 []
    wxSL_horizontal+wxSL_Labels+wxSL_Ticks
    [10 220][200 80])
beiSchiebereglerVerschiebung s [x=SchiebereglerWert (schreibe "x= x)]


HC / GUI Programmierung / Schiebe-Regler / SchiebereglerAn

SchiebereglerAn

HC [image] GUI Programmierung [image] Schiebe-Regler [image] SchiebereglerAn
beiSchiebereglerVerschiebung StaticTexts

SchiebereglerAn aslider Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das Schieberegler Aslider, ist Wenn Staat falsch dann sperrt es den Schleifer.

Zustand muss ein boolesch sein.

Beispiel:

s=(Schieberegler [][X] -400 0 400 [x=SchiebereglerWert (schreibe "x= x)]
    wxSL_horizontal+wxSL_Labels+wxSL_Ticks
    [10 220][200 80])
SchiebereglerAn s falsch
;Click on the Schieberegler again --nothing happens
SchiebereglerAn s wahr	;enabled again

Reference:

    Release Notes für Version 4.685

beiSchiebereglerVerschiebung StaticTexts


HC / GUI Programmierung / StaticTexts

StaticTexts

HC [image] GUI Programmierung [image] StaticTexts
SchiebereglerAn statischerText

StaticTexts

...sind Fenster ein oder enthaltend mehr Zeilen von festem ProzedurText.

Die entsprechende Demo ist statictexttest.lg.

StaticTexts

  • statischerText
  • zerstöreStatischenText
  • StatischerTextInhalt
  • setzeStatischenText
  • setzeStatischerTextFarbe
  • setzeStatischerTextHintergrundfarbe
  • setzeStatischerTextSchriftgröße
  • setzeStatischerTextSchriftname
  • setzeStatischerTextSchriftstil
  • setzeStatischerTextSchriftdicke


HC / GUI Programmierung / StaticTexts / statischerText

statischerText

HC [image] GUI Programmierung [image] StaticTexts [image] statischerText
StaticTexts zerstöreStatischenText

statischerText Elternteil Igeltext
(statischerText Elternteil Igeltext Stil Ort Größenname)

Ausgaben eine neue statischerText Kontrolle auf dem Elternteil (ein Fenster Oder ein Diagramm, oder wenn [] das Haupt-Diagramm).

igeltext kann irgendetwas sein, das in ein Wort umgewandelt werden kann. Jenes wort wird in der statischerText Kontrolle geführt.

Stil ist das Fenster Stil-Und kann eine Mischung aus den folgenden Konstanten sein:

wxALIGN_LEFT Richten Sie das Text
s=(statischerText [][This is
    a multiline
    static
    ProzedurText] wxAlign_centre [100 200][100 100][Text1])

Examples:

  • setzeStatischerTextHintergrundfarbe
  • setzeStatischerTextSchriftdicke
  • setzeStatischerTextSchriftgröße
  • setzeStatischerTextSchriftname
  • setzeStatischerTextSchriftstil
  • setzeStatischerTextFarbe
  • zerstöreStatischenText
  • StatischerTextInhalt
  • setzeStatischenText

References:

    Release Notes für Version 4.685(2), StatischerTextInhalt(2), setzeStatischenText(2), setzeStatischerTextFarbe(2), setzeStatischerTextHintergrundfarbe(2), setzeStatischerTextSchriftdicke(2), setzeStatischerTextSchriftgröße(2), setzeStatischerTextSchriftname(2), setzeStatischerTextSchriftstil(2), zerstöreStatischenText(2)

StaticTexts zerstöreStatischenText


HC / GUI Programmierung / StaticTexts / zerstöreStatischenText

zerstöreStatischenText

HC [image] GUI Programmierung [image] StaticTexts [image] zerstöreStatischenText
statischerText StatischerTextInhalt

zerstöreStatischenText astatictext

Kommando, der das statischerText astatictext zerstört.

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
zerstöreStatischenText s

Reference:

    Release Notes für Version 4.685

statischerText StatischerTextInhalt


HC / GUI Programmierung / StaticTexts / StatischerTextInhalt

StatischerTextInhalt

HC [image] GUI Programmierung [image] StaticTexts [image] StatischerTextInhalt
zerstöreStatischenText setzeStatischenText

StatischerTextInhalt astatictext

Ausgaben das Text inhalt der statischerText Kontrolle.

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
zeige StatischerTextInhalt s

Reference:

    Release Notes für Version 4.685

zerstöreStatischenText setzeStatischenText


HC / GUI Programmierung / StaticTexts / setzeStatischenText

setzeStatischenText

HC [image] GUI Programmierung [image] StaticTexts [image] setzeStatischenText
StatischerTextInhalt setzeStatischerTextFarbe

setzeStatischenText astatictext igeltext

Kommando, das enthaltene Text im statischerText Kontroll-Astatictext zu setzen.

igeltext ist irgendetwas druckfertiges. Es wird in ein Wort umgewandelt werden.

Beispiel:

s=(statischerText [] "
    wxAlign_centre [100 200][100 100][Text1])
setzeStatischenText s [This is a static ProzedurText]

Reference:

    Release Notes für Version 4.685

StatischerTextInhalt setzeStatischerTextFarbe


HC / GUI Programmierung / StaticTexts / setzeStatischerTextFarbe

setzeStatischerTextFarbe

HC [image] GUI Programmierung [image] StaticTexts [image] setzeStatischerTextFarbe
setzeStatischenText setzeStatischerTextHintergrundfarbe

setzeStatischerTextFarbe astatictext Farbe

Kommando, die Vordergrundfarbe des statischerText astatictext, anzumalen, zu setzen, das eine plausible Farbe sein muss (sehen Sie SetPenColor!).

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
setzeStatischerTextFarbe s "red

Reference:

    Release Notes für Version 4.685

setzeStatischenText setzeStatischerTextHintergrundfarbe


HC / GUI Programmierung / StaticTexts / setzeStatischerTextHintergrundfarbe

setzeStatischerTextHintergrundfarbe

HC [image] GUI Programmierung [image] StaticTexts [image] setzeStatischerTextHintergrundfarbe
setzeStatischerTextFarbe setzeStatischerTextSchriftgröße

setzeStatischerTextHintergrundfarbe astatictext Farbe

Kommando, die Hintergrundfarbe des statischerText astatictext, anzumalen, zu setzen, das eine plausible Farbe sein muss (sehen Sie SetPenColor!).

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
setzeStatischerTextHintergrundfarbe s rgb 1 0 0

Reference:

    Release Notes für Version 4.685

setzeStatischerTextFarbe setzeStatischerTextSchriftgröße


HC / GUI Programmierung / StaticTexts / setzeStatischerTextSchriftgröße

setzeStatischerTextSchriftgröße

HC [image] GUI Programmierung [image] StaticTexts [image] setzeStatischerTextSchriftgröße
setzeStatischerTextHintergrundfarbe setzeStatischerTextSchriftname

setzeStatischerTextSchriftgröße astatictext Größe

Kommando, die Schrifthöhe des zu messenden statischerText astatictext zu setzen, das eine integre Zahl sein muss.

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
setzeStatischerTextSchriftgröße s 50

Reference:

    Release Notes für Version 4.685

setzeStatischerTextHintergrundfarbe setzeStatischerTextSchriftname


HC / GUI Programmierung / StaticTexts / setzeStatischerTextSchriftname

setzeStatischerTextSchriftname

HC [image] GUI Programmierung [image] StaticTexts [image] setzeStatischerTextSchriftname
setzeStatischerTextSchriftgröße setzeStatischerTextSchriftstil

setzeStatischerTextSchriftname astatictext Größe

Kommando, den Schriftnamen des zu nennenden statischerText astatictext zu setzen, das ein plausibler Schriftname sein muss.

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
setzeStatischerTextSchriftname s [Courier]

Reference:

    Release Notes für Version 4.685

setzeStatischerTextSchriftgröße setzeStatischerTextSchriftstil


HC / GUI Programmierung / StaticTexts / setzeStatischerTextSchriftstil

setzeStatischerTextSchriftstil

HC [image] GUI Programmierung [image] StaticTexts [image] setzeStatischerTextSchriftstil
setzeStatischerTextSchriftname setzeStatischerTextSchriftdicke

setzeStatischerTextSchriftstil astatictext Stil

Kommando, den Schriftstil des statischerText astatictext zu setzen.

Stil kann eine der Konstanten wxFONTSTYLE_NORMAL wxFONTSTYLE_SLANT wxFONTSTYLE_ITALIC sein.

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
setzeStatischerTextSchriftstil s wxFONTSTYLE_ITALIC

Reference:

    Release Notes für Version 4.685

setzeStatischerTextSchriftname setzeStatischerTextSchriftdicke


HC / GUI Programmierung / StaticTexts / setzeStatischerTextSchriftdicke

setzeStatischerTextSchriftdicke

HC [image] GUI Programmierung [image] StaticTexts [image] setzeStatischerTextSchriftdicke
setzeStatischerTextSchriftstil TextControls

setzeStatischerTextSchriftdicke astatictext Gewicht

Kommando, das Schriftgewicht des statischerText astatictext zu setzen.

Gewicht kann eine der Konstanten wxFONTWEIGHT_NORMAL wxFONTWEIGHT_LIGHT wxFONTWEIGHT_BOLD sein

Beispiel:

s=(statischerText [][This is a static ProzedurText]
    wxAlign_centre [100 200][100 100][Text1])
setzeStatischerTextSchriftdicke f wxFONTWEIGHT_BOLD

Reference:

    Release Notes für Version 4.685

setzeStatischerTextSchriftstil TextControls


HC / GUI Programmierung / TextControls

TextControls

HC [image] GUI Programmierung [image] TextControls
setzeStatischerTextSchriftdicke TextControl

TextControls

...ist ein Fenster mit einem Text igeltext und eine Bearbeite Kontrolle, die multilineal sein könnte, vielleicht formatiertes und.

Eine Text Kontrolle erlaubt Text gezeigt zu werden und editiert. Es kann einzelnes linie oder mehrzeilig sein.

Die entsprechende Demo ist textcontroltest.lg.

TextControls

  • TextControl
  • zerstöreTextbox
  • Textbox
  • setzeTextboxInhalt
  • schreibeInTextbox
  • zuTextboxDazu
  • setzeTextboxEinfügepunktAnsEnde
  • TextboxCursor
  • setzeTextboxCursor
  • TextboxEinfügemodus
  • TextboxÜberschreibmodus
  • setzeTextboxFarbe
  • setzeTextboxHintergrundfarbe
  • setzeTextboxSchriftgröße
  • setzeTextboxSchriftname
  • setzeTextboxSchriftstil
  • setzeTextboxSchriftdicke
  • beiTextboxZeichen
  • beiGedrückterTasteInTextbox
  • beiLosgelassenerTasteInTextbox
  • beiTextboxÄnderung
  • beiTextboxEingabe
  • TextboxAn


HC / GUI Programmierung / TextControls / TextControl

TextControl

HC [image] GUI Programmierung [image] TextControls [image] TextControl
TextControls zerstöreTextbox

TextControl Elternteil name wert
(TextControl Elternteil name)
(TextControl Elternteil Name Wert onChange onEnter Stil Ort Größe)

Ausgaben ein neues TextControl auf dem Elternteil (ein Fenster Oder ein Diagramm, oder wenn [] das Haupt-Diagramm).

Wert kann irgendetwas sein, das in ein Wort umgewandelt werden kann. Jenes wort wird am Anfang im TextControl geführt.

Stil ist das Fenster Stil-Und kann eine Mischung aus den folgenden Konstanten sein:

wxTE_PROCESS_ENTER Die Kontrolle wird das Ereignis wxEVT_COMMAND_TEXT_ENTER erzeugen (sonst dringende Eingabetaste ist auch intern von dem für Navigation zwischen Dialogreglern benutzten Kontroll-Oder bearbeitet).

wxTE_PROCESS_TAB, das Die Kontrolle wxEVT_CHAR-Ereignisse für TAB bekommen wird, drückte - normalerweise, wird TABULATOR dafür benutzt, zur nächsten Kontrolle in einem Dialog statt dessen vorbeizukommen. Da die Kontrolle mit Würfelstil schuf, können Sie stillen Ctrl-Enter benutzen um zur nächsten Kontrolle von der Tastatur vorbeizukommen.

wxTE_MULTILINE Die Text Kontrolle erlaubt vielfache Zeilen.

wxTE_PASSWORD Das Text wird als Sternzeichen wiedergegeben werden.

wxTE_READONLY Das Text wird nicht benutzereditierbar sein.

wxTE_RICH-Verwendung reiche Text Kontrolle unter Win32, dies erlaubt mehr zu haben als 64KB von Text in der Kontrolle sogar unter Win9x. Dieser Stil wird unter anderen Plattformen ignoriert.

wxTE_RICH2-Verwendung reiche Text Kontrollversion 2.0 oder 3.0 unter Win32, Würfelstil wird unter anderen Plattformen ignoriert

wxTE_AUTO_URL-Glanzlicht das URLs und das wxTextUrlEvents erzeugen wenn Mausereignisse über ihnen auftreten. Dieser Stil wird nur für wxTE_RICH Win32 und-Multilinie wxgtk2 ProzedurText-Controls gestützt.

wxTE_NOHIDESEL Standardmäßig, die Fenster-Text Kontrolle tut nicht zeige die Auswahl wenn es Fokus nicht hat - benutzen Sie immer es zu zwingenden Würfelstil zeige es. Es führt nichts unter anderen Plattformen aus.

wxHSCROLL A Horizontalen-Scrollbar wird und, benutzt, so dass Text nicht eingepackt werden wird, geschaffen werden. Keine Wirkung unter wxGTK1.

wxTE_LEFT Das Text in der Kontrolle wird (Vorgabe).linksbündig sein

wxTE_CENTRE Das Text in der Kontrolle wird sich konzentriert werden (gegenwärtig wxMSW und wxGTK2 nur).

wxTE_RIGHT Das Text in der Kontrolle wird rechtsbündig sein (gegenwärtig wxMSW und wxGTK2 nur).

wxTE_DONTWRAP Gleich als tun nicht überhaupt wxHSCROLL Stil: Randsprung, Zeige Horizontalen-Scrollbar statt dessen.

wxTE_CHARWRAP-Hülle, die die Zeilen sich auch danach sehnen, dass man sich gänzlich an jeder Position zeigt (wxUniv und wxGTK2 nur).

wxTE_WORDWRAP-Hülle, die die Zeilen sich auch danach sehnen, dass man sich gänzlich an Wort Grenzen zeigt (wxUniv und wxGTK2 nur).

wxTE_BESTWRAP die Zeilen bei Wort Grenz-Oder an jedem anderen Charakter Einpacken, den wenn, das es gibt, länger ausdrückt als die Fenster Breite (dies ist die Vorgabe).

wxTE_CAPITALIZE Auf PocketPC und Smartphone, verursacht den zu kapitalisierenden erstes Buchstaben.

Examples:

  • setzeTextboxEinfügepunktAnsEnde
  • beiLosgelassenerTasteInTextbox
  • setzeTextboxHintergrundfarbe
  • beiGedrückterTasteInTextbox
  • setzeTextboxSchriftdicke
  • setzeTextboxSchriftgröße
  • setzeTextboxSchriftname
  • setzeTextboxSchriftstil
  • TextboxÜberschreibmodus
  • TextboxEinfügemodus
  • beiTextboxÄnderung
  • setzeTextboxCursor
  • setzeTextboxInhalt
  • beiTextboxEingabe
  • beiTextboxZeichen
  • schreibeInTextbox
  • setzeTextboxFarbe
  • zerstöreTextbox
  • TextboxCursor
  • zuTextboxDazu
  • TextboxAn
  • Textbox

References:

    TextboxAn(4), Textbox(3), Release Notes für Version 4.685(2), TextboxCursor(2), TextboxEinfügemodus(2), TextboxÜberschreibmodus(2), beiGedrückterTasteInTextbox(2), beiLosgelassenerTasteInTextbox(2), beiTextboxEingabe(2), beiTextboxZeichen(2), beiTextboxÄnderung(2), schreibeInTextbox(2), setzeTextboxCursor(2), setzeTextboxEinfügepunktAnsEnde(2), setzeTextboxFarbe(2), setzeTextboxHintergrundfarbe(2), setzeTextboxInhalt(2), setzeTextboxSchriftdicke(2), setzeTextboxSchriftgröße(2), setzeTextboxSchriftname(2), setzeTextboxSchriftstil(2), zerstöreTextbox(2), zuTextboxDazu(2)

TextControls zerstöreTextbox


HC / GUI Programmierung / TextControls / zerstöreTextbox

zerstöreTextbox

HC [image] GUI Programmierung [image] TextControls [image] zerstöreTextbox
TextControl Textbox

zerstöreTextbox atextcontrol

Kommando, das TextControl atextcontrol zu zerstören.

Beispiel:

t=(TextControl [][TextControl1][This is some prozedurtext][][]
    wxTE_CENTRE [0 0][300 200])
zerstöreTextbox t

Reference:

    Release Notes für Version 4.685

TextControl Textbox


HC / GUI Programmierung / TextControls / Textbox

Textbox

HC [image] GUI Programmierung [image] TextControls [image] Textbox
zerstöreTextbox setzeTextboxInhalt

Textbox Inhalt
(Textbox Inhalt atextcontrol)

Ausgaben, die der Wort Wert des TextControl atextcontrol oder wenn ohne Argumente des TextControl aufrief, dessen Ereignis neuerdings bearbeitet wird.

Beispiele:

t=(TextControl [][TextControl1][This is some prozedurtext]
    [	(schreibe [onChange] TextboxInhalt)
    ][	(schreibe [onEnter] TextboxInhalt)
    ]
    wxTE_MULTILINE+wxTE_RICH2 [0 0][300 200])


HC / GUI Programmierung / TextControls / setzeTextboxInhalt

setzeTextboxInhalt

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxInhalt
Textbox schreibeInTextbox

setzeTextboxInhalt atextcontrol Wert

Kommando, den Text Wert des zu schätzenden TextControl atextcontrol zu setzen.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial prozedurtext][][]
    wxTE_CENTRE [0 0][300 200])
setzeTextboxInhalt t [That's the new prozedurtext!]

Reference:

    Release Notes für Version 4.685

Textbox schreibeInTextbox


HC / GUI Programmierung / TextControls / schreibeInTextbox

schreibeInTextbox

HC [image] GUI Programmierung [image] TextControls [image] schreibeInTextbox
setzeTextboxInhalt zuTextboxDazu

schreibeInTextbox atextcontrol Wert

Kommando, das Text von Wert an der gegenwärtigen Einfügemarke Position ins TextControl atextcontrol zu schreiben.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_CENTRE [0 0][300 200])
setzeTextboxCursor t [10 0]
schreibeInTextbox t [!That's the new prozedurtext!]

Examples:

  • setzeTextboxEinfügepunktAnsEnde
  • setzeTextboxCursor
  • TextboxCursor

References:

    Release Notes für Version 4.685, TextboxCursor, setzeTextboxCursor, setzeTextboxEinfügepunktAnsEnde

setzeTextboxInhalt zuTextboxDazu


HC / GUI Programmierung / TextControls / zuTextboxDazu

zuTextboxDazu

HC [image] GUI Programmierung [image] TextControls [image] zuTextboxDazu
schreibeInTextbox setzeTextboxEinfügepunktAnsEnde

zuTextboxDazu atextcontrol Wert

Befehlen Sie dem TextControl atextcontrol, das Text von Wert anzuhängen.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_CENTRE [0 0][300 200])
zuTextboxDazu t [!That's the new prozedurtext!]

Reference:

    Release Notes für Version 4.685

schreibeInTextbox setzeTextboxEinfügepunktAnsEnde


HC / GUI Programmierung / TextControls / setzeTextboxEinfügepunktAnsEnde

setzeTextboxEinfügepunktAnsEnde

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxEinfügepunktAnsEnde
zuTextboxDazu TextboxCursor

setzeTextboxEinfügepunktAnsEnde atextcontrol

Befehlen Sie dem Ende des Text des TextControl atextcontrol, die Einfügestelle zu setzen (das einfügemarke).

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_CENTRE [0 0][300 200])
setzeTextboxEinfügepunktAnsEnde t	;like with append
schreibeInTextbox t [!That's the new prozedurtext!]

Reference:

    Release Notes für Version 4.685

zuTextboxDazu TextboxCursor


HC / GUI Programmierung / TextControls / TextboxCursor

TextboxCursor

HC [image] GUI Programmierung [image] TextControls [image] TextboxCursor
setzeTextboxEinfügepunktAnsEnde setzeTextboxCursor

TextboxCursor atextcontrol

Ausgaben die Einfügemarke Position des TextControl atextcontrol als ein Liste zweier null-basierter Ganzzahlen, [Spalten Zeile].

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxCursor t [10 2]
schreibeInTextbox t [!That's the new prozedurtext!]
zeige TextboxCursor t

Reference:

    Release Notes für Version 4.685

setzeTextboxEinfügepunktAnsEnde setzeTextboxCursor


HC / GUI Programmierung / TextControls / setzeTextboxCursor

setzeTextboxCursor

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxCursor
TextboxCursor TextboxEinfügemodus

setzeTextboxCursor atextcontrol ort

Kommando, die Einfügestelle, das einfügemarke, des TextControl atextcontrol zu dem ort liste zu setzen, den besteht von [Spalten Zeile].

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxCursor t [10 2]
schreibeInTextbox t [!That's the new prozedurtext!]

Examples:

  • schreibeInTextbox
  • TextboxCursor

References:

    Release Notes für Version 4.685, TextboxCursor, schreibeInTextbox

TextboxCursor TextboxEinfügemodus


HC / GUI Programmierung / TextControls / TextboxEinfügemodus

TextboxEinfügemodus

HC [image] GUI Programmierung [image] TextControls [image] TextboxEinfügemodus
setzeTextboxCursor TextboxÜberschreibmodus

TextboxEinfügemodus atextcontrol

Kommando festzuwerden der Modus vom einzufügenden TextControl atextcontrol schreiben.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
TextboxÜberschreibmodus t	;tippe something
TextboxEinfügemodus t	;tippe something more

Example:

  • TextboxÜberschreibmodus

References:

    Release Notes für Version 4.685, TextboxÜberschreibmodus

setzeTextboxCursor TextboxÜberschreibmodus


HC / GUI Programmierung / TextControls / TextboxÜberschreibmodus

TextboxÜberschreibmodus

HC [image] GUI Programmierung [image] TextControls [image] TextboxÜberschreibmodus
TextboxEinfügemodus setzeTextboxFarbe

TextboxÜberschreibmodus atextcontrol

Funktioniert dennoch nicht!

Kommando festzuwerden der Modus vom zu überschreibenden TextControl atextcontrol schreiben.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE+wxTE_RICH2 [0 0][300 200])
TextboxÜberschreibmodus t	;tippe something
TextboxEinfügemodus t	;tippe something more

Example:

  • TextboxEinfügemodus

References:

    Release Notes für Version 4.685, TextboxEinfügemodus

TextboxEinfügemodus setzeTextboxFarbe


HC / GUI Programmierung / TextControls / setzeTextboxFarbe

setzeTextboxFarbe

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxFarbe
TextboxÜberschreibmodus setzeTextboxHintergrundfarbe

setzeTextboxFarbe aTextControl Farbe

Kommando, die Vordergrundfarbe des TextControl aTextControl, anzumalen, zu setzen, das eine plausible Farbe sein muss (sehen Sie SetPenColor!).

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxFarbe t "red

Reference:

    Release Notes für Version 4.685

TextboxÜberschreibmodus setzeTextboxHintergrundfarbe


HC / GUI Programmierung / TextControls / setzeTextboxHintergrundfarbe

setzeTextboxHintergrundfarbe

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxHintergrundfarbe
setzeTextboxFarbe setzeTextboxSchriftgröße

setzeTextboxHintergrundfarbe aTextControl Farbe

Kommando, die Hintergrundfarbe des TextControl aTextControl, anzumalen, zu setzen, das eine plausible Farbe sein muss (sehen Sie SetPenColor!).

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxHintergrundfarbe t rgb 1 0 0

Reference:

    Release Notes für Version 4.685

setzeTextboxFarbe setzeTextboxSchriftgröße


HC / GUI Programmierung / TextControls / setzeTextboxSchriftgröße

setzeTextboxSchriftgröße

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxSchriftgröße
setzeTextboxHintergrundfarbe setzeTextboxSchriftname

setzeTextboxSchriftgröße aTextControl Größe

Kommando, die Schrifthöhe des zu messenden TextControl aTextControl zu setzen, das eine integre Zahl sein muss.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxSchriftgröße t 50

Reference:

    Release Notes für Version 4.685

setzeTextboxHintergrundfarbe setzeTextboxSchriftname


HC / GUI Programmierung / TextControls / setzeTextboxSchriftname

setzeTextboxSchriftname

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxSchriftname
setzeTextboxSchriftgröße setzeTextboxSchriftstil

setzeTextboxSchriftname aTextControl Größe

Kommando, den Schriftnamen des zu nennenden TextControl aTextControl zu setzen, das ein plausibler Schriftname sein muss.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxSchriftname t [Courier]

Reference:

    Release Notes für Version 4.685

setzeTextboxSchriftgröße setzeTextboxSchriftstil


HC / GUI Programmierung / TextControls / setzeTextboxSchriftstil

setzeTextboxSchriftstil

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxSchriftstil
setzeTextboxSchriftname setzeTextboxSchriftdicke

setzeTextboxSchriftstil aTextControl Stil

Kommando, den Schriftstil des TextControl aTextControl zu setzen.

Stil kann eine der Konstanten wxFONTSTYLE_NORMAL wxFONTSTYLE_SLANT wxFONTSTYLE_ITALIC sein.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxSchriftstil t wxFONTSTYLE_ITALIC

Reference:

    Release Notes für Version 4.685

setzeTextboxSchriftname setzeTextboxSchriftdicke


HC / GUI Programmierung / TextControls / setzeTextboxSchriftdicke

setzeTextboxSchriftdicke

HC [image] GUI Programmierung [image] TextControls [image] setzeTextboxSchriftdicke
setzeTextboxSchriftstil beiTextboxZeichen

setzeTextboxSchriftdicke aTextControl Gewicht

Kommando, das Schriftgewicht des TextControl aTextControl zu setzen.

Gewicht kann eine der Konstanten wxFONTWEIGHT_NORMAL wxFONTWEIGHT_LIGHT wxFONTWEIGHT_BOLD sein

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
setzeTextboxSchriftdicke t wxFONTWEIGHT_BOLD

Reference:

    Release Notes für Version 4.685

setzeTextboxSchriftstil beiTextboxZeichen


HC / GUI Programmierung / TextControls / beiTextboxZeichen

beiTextboxZeichen

HC [image] GUI Programmierung [image] TextControls [image] beiTextboxZeichen
setzeTextboxSchriftdicke beiGedrückterTasteInTextbox

beiTextboxZeichen aTextControl Befehle

Kommando, den Gewohnheitsereignisführer für das Zeichen Ereignis des TextControl aTextControl zu zu setzen, befiehlt. Sehen Sie auch beiZeichen!

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
beiTextboxZeichen lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

setzeTextboxSchriftdicke beiGedrückterTasteInTextbox


HC / GUI Programmierung / TextControls / beiGedrückterTasteInTextbox

beiGedrückterTasteInTextbox

HC [image] GUI Programmierung [image] TextControls [image] beiGedrückterTasteInTextbox
beiTextboxZeichen beiLosgelassenerTasteInTextbox

beiGedrückterTasteInTextbox aTextControl Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Runter Ereignis des TextControl aTextControl zu zu setzen, befiehlt. Sehen Sie auch beiGedrückterTaste!

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
beiGedrückterTasteInTextbox lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiTextboxZeichen beiLosgelassenerTasteInTextbox


HC / GUI Programmierung / TextControls / beiLosgelassenerTasteInTextbox

beiLosgelassenerTasteInTextbox

HC [image] GUI Programmierung [image] TextControls [image] beiLosgelassenerTasteInTextbox
beiGedrückterTasteInTextbox beiTextboxÄnderung

beiLosgelassenerTasteInTextbox aTextControl Befehle

Kommando, den Gewohnheitsereignisführer für das Tasten-Rauf zu setzen (=release), Ereignis des TextControl aTextControl zu Kommandos. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
beiLosgelassenerTasteInTextbox lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiGedrückterTasteInTextbox beiTextboxÄnderung


HC / GUI Programmierung / TextControls / beiTextboxÄnderung

beiTextboxÄnderung

HC [image] GUI Programmierung [image] TextControls [image] beiTextboxÄnderung
beiLosgelassenerTasteInTextbox beiTextboxEingabe

beiTextboxÄnderung aTextControl Befehle

Kommando, den Gewohnheitsereignisführer für das Text Änderungsereignis des TextControl aTextControl zu zu setzen, befiehlt. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
beiTextboxÄnderung lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiLosgelassenerTasteInTextbox beiTextboxEingabe


HC / GUI Programmierung / TextControls / beiTextboxEingabe

beiTextboxEingabe

HC [image] GUI Programmierung [image] TextControls [image] beiTextboxEingabe
beiTextboxÄnderung TextboxAn

beiTextboxEingabe aTextControl Befehle

Kommando, den Gewohnheitsereignisführer für das Text zu setzen, Ereignis "Eingabe" (wann [Treten Sie ein] war gedrückt) vom TextControl aTextControl zu Kommandos. Sehen Sie auch beiLosgelassenerTaste!

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
beiTextboxEingabe lc [schreibe Tastenwert]

Reference:

    Release Notes für Version 4.685

beiTextboxÄnderung TextboxAn


HC / GUI Programmierung / TextControls / TextboxAn

TextboxAn

HC [image] GUI Programmierung [image] TextControls [image] TextboxAn
beiTextboxEingabe ToggleButtons

TextboxAn atextcontrol Staat

Kommando. Wenn Zustand dann wahr ist ermöglicht es das TextControl aTextControl, ist Wenn Staat falsch dann sperrt es das TextControl.

Zustand muss ein boolesch sein.

Beispiel:

t=(TextControl [][TextControl1]
    [This is the initial text.][][]
    wxTE_MULTILINE [0 0][300 200])
TextboxAn t falsch
;Click on the TextControl again --nothing happens
TextboxAn t wahr	;enabled again

Reference:

    Release Notes für Version 4.685

beiTextboxEingabe ToggleButtons


HC / GUI Programmierung / ToggleButtons

ToggleButtons

HC [image] GUI Programmierung [image] ToggleButtons
TextboxAn Schaltknopf

ToggleButtons

...sind Fenster etwas ein knopf mit zwei Zuständen enthaltend, den können führeAus ein Logo-Befehlsliste wenn der Benutzer mit der Maus auf sie klickt kippt sie und auf und aus. ToggleButtons werden in buttontest.lg. demonstriert

ToggleButtons

  • Schaltknopf
  • zerstöreSchaltknopf
  • beiGeklicktemSchaltknopf
  • SchaltknopfZustand
  • setzeSchaltknopfZustand
  • SchaltknopfAn


HC / GUI Programmierung / ToggleButtons / Schaltknopf

Schaltknopf

HC [image] GUI Programmierung [image] ToggleButtons [image] Schaltknopf
ToggleButtons zerstöreSchaltknopf

Schaltknopf Elternteil Alabel Onclick
(Schaltknopf Elternteil Alabel Onclick Stil Apos Größe)

Ausgaben ein neuer Schaltknopf auf dem Elternteil (ein Fenster Oder ein Diagramm),

das Text alabel darauf haben,

und, das das onclick instructionlist laufen lässt, wenn der Benutzer mit der Maus darauf klickt.

Stil ist der Fenster Stil, Vorgaben zu 0.

apos ist die Position des Knopfs (ein Liste zweier integrer Zahlen, x und y),

Größe ist die Größe des Knopfs (nochmals ein Liste zweier integrer Zahlen, Breiten-Und Höhe).

Beispiele:

tbpd=Schaltknopf [][Pen Down][
    wennsonst SchaltknopfZustand tbpd [StiftAb][StiftHoch]
    erneuereGraph]
tbht=(Schaltknopf [][Hide Igel][
    wennsonst SchaltknopfZustand tbht [versteckeIgel][zeigIgel]
    erneuereGraph]
    wxBU_LEFT+wxBU_TOP [0 100][200 100])

Examples:

  • beiGeklicktemSchaltknopf
  • setzeSchaltknopfZustand
  • zerstöreSchaltknopf
  • SchaltknopfZustand
  • SchaltknopfAn

References:

    SchaltknopfAn(3), Release Notes für Version 4.685(2), SchaltknopfZustand(2), beiGeklicktemSchaltknopf(2), setzeSchaltknopfZustand(2), zerstöreSchaltknopf(2)

ToggleButtons zerstöreSchaltknopf


HC / GUI Programmierung / ToggleButtons / zerstöreSchaltknopf

zerstöreSchaltknopf

HC [image] GUI Programmierung [image] ToggleButtons [image] zerstöreSchaltknopf
Schaltknopf beiGeklicktemSchaltknopf

zerstöreSchaltknopf aToggleButton

Kommando, der den Schaltknopf zerstört, aToggleButton.

Beispiel:

tbht=Schaltknopf [][Hide Igel][
    wennsonst SchaltknopfZustand tbht [versteckeIgel][zeigIgel]
    erneuereGraph]
zerstöreSchaltknopf tbht

Reference:

    Release Notes für Version 4.685

Schaltknopf beiGeklicktemSchaltknopf


HC / GUI Programmierung / ToggleButtons / beiGeklicktemSchaltknopf

beiGeklicktemSchaltknopf

HC [image] GUI Programmierung [image] ToggleButtons [image] beiGeklicktemSchaltknopf
zerstöreSchaltknopf SchaltknopfZustand

beiGeklicktemSchaltknopf aToggleButton instructionlist

Kommando, der den onClick Ereignisroutine des Schaltknopfs setzt, aToggleButton zu den Kommandos im Befehlsliste.

Beispiele:

tb=Schaltknopf [][Hide Igel][
    wennsonst SchaltknopfZustand tb [versteckeIgel][zeigIgel]
    erneuereGraph]
beiGeklicktemSchaltknopf tb [
    wennsonst SchaltknopfZustand tb [schreibe [Yes, Sir!]][schreibe [No, Sir!]]
    erneuereGraph]
beiGeklicktemSchaltknopf tb []	;like disabling the Schaltknopf

Reference:

    Release Notes für Version 4.685

zerstöreSchaltknopf SchaltknopfZustand


HC / GUI Programmierung / ToggleButtons / SchaltknopfZustand

SchaltknopfZustand

HC [image] GUI Programmierung [image] ToggleButtons [image] SchaltknopfZustand
beiGeklicktemSchaltknopf setzeSchaltknopfZustand

SchaltknopfZustand aToggleButton

Ausgaben-Wahr Wenn der Schaltknopf aToggleButton wird überprüft, falsch sonst.

Beispiel:

tb=Schaltknopf [][Hide Igel][
    wennsonst SchaltknopfZustand tb [versteckeIgel][zeigIgel]
    erneuereGraph]

Examples:

  • beiGeklicktemSchaltknopf
  • setzeSchaltknopfZustand
  • zerstöreSchaltknopf
  • SchaltknopfAn
  • Schaltknopf

References:

    Schaltknopf(2), beiGeklicktemSchaltknopf(2), Release Notes für Version 4.685, SchaltknopfAn, setzeSchaltknopfZustand, zerstöreSchaltknopf

beiGeklicktemSchaltknopf setzeSchaltknopfZustand


HC / GUI Programmierung / ToggleButtons / setzeSchaltknopfZustand

setzeSchaltknopfZustand

HC [image] GUI Programmierung [image] ToggleButtons [image] setzeSchaltknopfZustand
SchaltknopfZustand SchaltknopfAn

setzeSchaltknopfZustand aToggleButton Staat

Kommando, der dem Schaltknopf aToggleButton zu überprüftem Wenn Staat stellt, ist wahr, zu ungehemmtem wenn nicht wahr.

Zustand muss ein boolesch sein.

Beispiel:

tb=Schaltknopf [][Hide Igel][
    wennsonst SchaltknopfZustand tb [versteckeIgel][zeigIgel]
    erneuereGraph]
setzeSchaltknopfZustand tb sichtbar?

Reference:

    Release Notes für Version 4.685

SchaltknopfZustand SchaltknopfAn


HC / GUI Programmierung / ToggleButtons / SchaltknopfAn

SchaltknopfAn

HC [image] GUI Programmierung [image] ToggleButtons [image] SchaltknopfAn
setzeSchaltknopfZustand Verschiedene GUI Elemente

SchaltknopfAn aToggleButton Staat

Kommando. Wenn Zustand dann wahr ist befähigt es den Schaltknopf aToggleButton, ist Wenn Staat falsch dann sperrt es das ToggleButton.

Zustand muss ein boolesch sein.

Beispiel:

tb=Schaltknopf [][Hide Igel][
    wennsonst SchaltknopfZustand tb [versteckeIgel][zeigIgel]
    erneuereGraph]
SchaltknopfAn tb falsch
;Click on the Schaltknopf again --nothing happens
SchaltknopfAn tb wahr	;enabled again

Reference:

    Release Notes für Version 4.685

setzeSchaltknopfZustand Verschiedene GUI Elemente


HC / GUI Programmierung / Verschiedene GUI Elemente

Verschiedene GUI Elemente

HC [image] GUI Programmierung [image] Verschiedene GUI Elemente
SchaltknopfAn beginneBeschäftigt

Verschiedene GUI Elemente

Verschiedene GUI Elemente

  • beginneBeschäftigt
  • beendeBeschäftigt
  • beschäftigtP
  • aktiviereKonsole


HC / GUI Programmierung / Verschiedene GUI Elemente / beginneBeschäftigt

beginneBeschäftigt

HC [image] GUI Programmierung [image] Verschiedene GUI Elemente [image] beginneBeschäftigt
Verschiedene GUI Elemente beendeBeschäftigt

beginneBeschäftigt

Befehlen Sie zeige ein beschäftigtes Maus-Einfügemarke (Sanduhr).

References:

    Release Notes für Version 4.685, beschäftigtP

Verschiedene GUI Elemente beendeBeschäftigt


HC / GUI Programmierung / Verschiedene GUI Elemente / beendeBeschäftigt

beendeBeschäftigt

HC [image] GUI Programmierung [image] Verschiedene GUI Elemente [image] beendeBeschäftigt
beginneBeschäftigt beschäftigtP

beendeBeschäftigt

Befehlen Sie zeige der standardmäßige Mauscursors.

References:

    Release Notes für Version 4.685, beschäftigtP

beginneBeschäftigt beschäftigtP


HC / GUI Programmierung / Verschiedene GUI Elemente / beschäftigtP

beschäftigtP

HC [image] GUI Programmierung [image] Verschiedene GUI Elemente [image] beschäftigtP
beendeBeschäftigt aktiviereKonsole

beschäftigtP
beschäftigt?

Ausgaben wahr wenn beginneBeschäftigt wurde gerufen neuerdings, und falsch wenn beendeBeschäftigt wurde neuerdings gerufen.


HC / GUI Programmierung / Verschiedene GUI Elemente / aktiviereKonsole

aktiviereKonsole

HC [image] GUI Programmierung [image] Verschiedene GUI Elemente [image] aktiviereKonsole
beschäftigtP Geräusche

aktiviereKonsole

setzt die Tastatur zur Konsole fokussieren, den gewollt werden können Wenn Benutzereingabe wird gebraucht.

Reference:

    Release Notes für Version 4.686

beschäftigtP Geräusche


HC / Geräusche

Geräusche

HC [image] Geräusche
aktiviereKonsole PC-Lautsprecher

Geräusche

Hier sind einige Kommandos, um den PC-Lautsprecher zu kontrollieren, um Wave-Sound abzuspielen auf dem analogen Sound-Karten-Ausgang, und für Midi-Musik.

Geräusche

  • PC-Lautsprecher
  • Wave Sound
  • Midi
  • Midi Tabelle
  • Midi Kontroll-Tabelle
  • Midi Glossary
  • Midi Instruments

Reference:

    Wave Sound

aktiviereKonsole PC-Lautsprecher


HC / Geräusche / PC-Lautsprecher

PC-Lautsprecher

HC [image] Geräusche [image] PC-Lautsprecher
Geräusche Ton

PC-Lautsprecher

Hier können Sie Sinus-Töne auf dem PC-Lautsprecher ausgeben. Es gibt sogar Abspielbefehle, die parallel zum Hauptprogramm arbeiten.

PC-Lautsprecher

  • Ton
  • Töne
  • stoppeTöne
  • beendeteTöne
  • Sound
  • Sounds
  • SoundsStop
  • SoundsFinished

References:

    Geräusche, Sound, Ton, spieleWave

Geräusche Ton


HC / Geräusche / PC-Lautsprecher / Ton

Ton

HC [image] Geräusche [image] PC-Lautsprecher [image] Ton
PC-Lautsprecher Töne

Ton Höhe Dauer

läßt den PC-Lautsprecher einen "Dauer" Sekunden andauernden Ton der Tonhöhe "Höhe" ausgegeben. Die "Höhe" ist eine Zahl, normalerweise eine Ganzzahl, eine Musik-Note repräsentierend. 0 heißt Kammmerton A (440 Hz). Seine Frequenz wird durch 440*2^(Höhe/12) berechnet.

Beispiele:

ton 3 1000	;outputs a C on the Stiftfarbe speaker
ton -12 1000	;outputs a A (220Hz) on the Stiftfarbe speaker

References:

    TSH(5), TSHA(5), listeTSH(2), Release Notes für Version 4.64, Release Notes für Version 4.686, Sound, listeTSHA

PC-Lautsprecher Töne


HC / Geräusche / PC-Lautsprecher / Töne

Töne

HC [image] Geräusche [image] PC-Lautsprecher [image] Töne
Ton stoppeTöne

Töne HöheLängeListe
(Töne Höhen Längen)

Kommando, das einen neuen parallelen Thread startet, der die Noten spielt, entweder von der HöheLängeListe [Höhe1 Länge1 Höhe2 Länge2...] oder von den zwei Listen Höhen und Längen. Länge kann auch eine einzelne Zahl sein.

Beispiele:

Töne [0 1000 2 1000 4 1000]
(Töne [0 2 4 5 7 9 11 12] [400 350 300 250 200 150 100 50])
(Töne [0 2 4 5 7 9 11 12] 400)

Example:

  • beendeteTöne

References:

    beendeteTöne(4), stoppeTöne(2), MidiAusgabestrom, PC-Lautsprecher, Release Notes für Version 4.686

Ton stoppeTöne


HC / Geräusche / PC-Lautsprecher / stoppeTöne

stoppeTöne

HC [image] Geräusche [image] PC-Lautsprecher [image] stoppeTöne
Töne beendeteTöne

stoppeTöne

Beendet einen von "Töne" geschaffenen Thread. Wenn Sie mehr als einen parallelausführenden "Töne"-Thread aufgerufen haben, können Sie genauso viele Male "stoppeTöne" aufrufen.

Reference:

    Release Notes für Version 4.686

Töne beendeteTöne


HC / Geräusche / PC-Lautsprecher / beendeteTöne

beendeteTöne

HC [image] Geräusche [image] PC-Lautsprecher [image] beendeteTöne
stoppeTöne Sound

beendeteTöne

Ausgabe ist eine Ganzzahl, die die Anzahl von "Töne"-Threads repräsentiert, die beendet wurden.

Beispiel:

zu testtones
    töne [0 1000 2 1000 4 1000 5 1000] warteMilliSekunden 300
    töne [4 1000 5 1000 7 1000] warteMilliSekunden 300
    töne [7 1000 9 1000]
    tf=beendeteTöne
    otf=tf
    schreibe tf
    tf=tf+3
    Überschreibmodus
    y=Cursor.2-1
    solange [beendeteTöne < tf]
    [	wenn beendeteTöne != otf
        [	otf=beendeteTöne
            setzeCursor liste 0 y
            tippe otf
        ]
    ]
    EinfügeModus
    schreibe []
Ende

Reference:

    Release Notes für Version 4.686

stoppeTöne Sound


HC / Geräusche / PC-Lautsprecher / Sound

Sound

HC [image] Geräusche [image] PC-Lautsprecher [image] Sound
beendeteTöne Sounds

Sound Frequenz Dauer

läßt den PC-Lautsprecher einen Ton der Frequenz "Frequenz" ausgeben, der "Dauer" Sekunden anhält. Die Frequenz muss eine positive Zahl sein. Wenn die Dauer -1 ist, hört der Sound niemals auf.

Beispiel:

Sound 440 1000

References:

    Release Notes für Version 4.686(3), Geräusche(2), spieleWave

beendeteTöne Sounds


HC / Geräusche / PC-Lautsprecher / Sounds

Sounds

HC [image] Geräusche [image] PC-Lautsprecher [image] Sounds
Sound SoundsStop

Sounds FrequenzenLängenListe
(Sounds Frequenzen Längen)

Kommando, das einen neuen Thread startet, der die Frequenzen spielt, die entweder in der FrequenzyLängenListe [Frequenz1 Länge1 Frequenz2 Länge2...] oder in den zwei Listen Frequenzen und Längen stehen. Die "Längen" können auch eine einzlne Zahl sein.

Beispiele:

Sounds [440 400 880 300 1760 200]
(Sounds [440 880 1760] [400 300 200])
(Sounds [440 880 1760] 400)
(Sounds (Satz
    ZahlenFolge 20 10000 100
    ZahlenFolge 10000 20 100) 10)
(Sounds (sinus ZahlenFolge 0 15*360 200)*4000+4000  10)
warteMilliSekunden 2000
(Sounds (sinus ZahlenFolge 0 3*360 200)*1000+1000  10)

References:

    SoundsStop(2), MidiAlleGeräuscheAus, Release Notes für Version 4.686, SoundsFinished

Sound SoundsStop


HC / Geräusche / PC-Lautsprecher / SoundsStop

SoundsStop

HC [image] Geräusche [image] PC-Lautsprecher [image] SoundsStop
Sounds SoundsFinished

SoundsStop

Hält einen von Sounds geschaffenen Thread an. Wenn Sie mehr als einen "Sounds" Thread aufgerufen haben, können Sie "SoundsStop" genauso viele Male aufrufen, um alle Threads zu stoppen.

Reference:

    Release Notes für Version 4.686

Sounds SoundsFinished


HC / Geräusche / PC-Lautsprecher / SoundsFinished

SoundsFinished

HC [image] Geräusche [image] PC-Lautsprecher [image] SoundsFinished
SoundsStop Wave Sound

SoundsFinished

Ausgabe ist eine Ganzzahl, die Anzahl von "Sounds"-Threads repräsentierend, die beendet wurden. Siehe auch "TonesFinished".

Reference:

    Release Notes für Version 4.686

SoundsStop Wave Sound


HC / Geräusche / Wave Sound

Wave Sound

HC [image] Geräusche [image] Wave Sound
SoundsFinished spieleWave

Wave Sound

...sind Reihen digitaler Werte, die in analoge elektrische Spannungswerte umgesetzt werden können, meist von einer Soundkarte. Diese Analog-Signale könne durch Lautsprecher in Geräusche umgewandelt werden. Dieses Unterkapitel befasst sich mit dem Abspielen solcher Waveforms.

Wave Sound

  • spieleWave
  • spieleWaveSchnell


HC / Geräusche / Wave Sound / spieleWave

spieleWave

HC [image] Geräusche [image] Wave Sound [image] spieleWave
Wave Sound spieleWaveSchnell

spieleWave waveDatei Schalter
spieleWave waveDaten Schalter

Die waveDatei muss eine Dateibezeichnung einer .WAV Datei sein. Die waveDaten können Ganzzahlen oder 16BitZahlen sein, geladen mit dem Inhalt einer Wave-Datei, einschließlich dem Dateikopf.

Die Schalter beschreiben, wie der Sound gespielt werden soll.

Aber man braucht nicht unbedingt eine echte Soundkarte, um die Ausgabe dieses Befehls zu genießen.

Es gibt einen öffentlich verfügbaren SPEAKER(.EXE, .DRV genannten Treiber von Microsoft .ZIP?) der die Wavedateimöglichkeiten auf dem PC-Lautsprecher emuliert.

Example:

  • setzeSchreiber

References:

    setzeSchreiber(2), Release Notes für Version 4.64, Release Notes für Version 4.67, Release Notes für Version 4.686

Wave Sound spieleWaveSchnell


HC / Geräusche / Wave Sound / spieleWaveSchnell

spieleWaveSchnell

HC [image] Geräusche [image] Wave Sound [image] spieleWaveSchnell
spieleWave Midi

spieleWaveSchnell waveDaten

Die waveDaten können Ganzzahlen oder 16BitZahlen sein, die mit dem Inhalt einer richtigen Wavedatei einschließlich des Datei-Kopfes geladen wurden.

Bis zu 32 Wellen können gleichzeitig gespielt werden, und die Start-Zeit ist sehr kurz, so ist es ideal für Spiele und Musik-Programme.

Beispiel:

to loadwav f
    lokal [size wav]
    öffneZumLesenBinär f
    setReader f
    size=DateiGröße f
    wav=lies16BitZahlenBinär size/2
    setReader []
    schließe f
;	(schreibe f "loaded)
    output wav
end
to resizeWav wav factor
    lokal "w
    w=16BitZahlen 44+round ((zähle wav)-44)*factor
    setzeElemente 1 w Elemente 1 44 wav
    setzeElemente 45 w vergrößere
        (Elemente 45 zähle wav wav) (zähle w)-44
    output w
end
clickWav=loadwav "start.wav
cmajor=[0 2 4 5 7 9 11 12]
stoneWav=Reihe 8
wiederhole 8 [
    i=repcount
    stoneWav.i=resizeWav clickWav 2^((12-cmajor.i)/12)
]
wiederhole 100 [spieleWave2 stonewav.(1+random 8) wartemillisekunden 10]


HC / Geräusche / Midi

Midi

HC [image] Geräusche [image] Midi
spieleWaveSchnell MidiGeräteInfo

Midi

Midi

  • MidiGeräteInfo
  • öffneMidi
  • schließeMidi
  • MidiMeldung
  • wechsleMidiProgramm
  • MidiNoteAn
  • MidiNoteAus
  • MidiAlleGeräuscheAus
  • MidiAusgabestrom
  • starteMidiAusgabestrom
  • stoppeMidiAusgabestrom
  • beendeteMidiAusgabeströme

See also:

  • Midi Glossary

Examples:

  • MidiGeräteInfo
  • Midi Tabelle

References:

    öffneMidi(4), MidiGeräteInfo(2), Geräusche, Midi Glossary, Midi Tabelle, MidiAlleGeräuscheAus, MidiAusgabestrom, Release Notes für Version 4.686, beendeteMidiAusgabeströme, schließeMidi, wechsleMidiProgramm

spieleWaveSchnell MidiGeräteInfo


HC / Geräusche / Midi / MidiGeräteInfo

MidiGeräteInfo

HC [image] Geräusche [image] Midi [image] MidiGeräteInfo
Midi öffneMidi

MidiGeräteInfo devnr devInfo MidiGeräteInfo devnr

Ausgaben hardwarespezifische Geräteinformation über das Midi Gerätezahlen-Devnr.

Das erstes Element der Ausgabe ist jedes "Eingabe"-Oder "Ausgabe", welches Mittel den Gerät ist jeden ein Eingabe-Oder Ausgabegerät.

Beispiel:

wiederhole zähleMidiGeräte [schreibe MidiGeräteInfo repcount-1]
;output Microsoft MIDI-Mapper MMSystem
;input MPU-401 MMSystem
;output Microsoft GS Wavetable SW Synth MMSystem
;output MPU-401 MMSystem

Reference:

    Release Notes für Version 4.686

Midi öffneMidi


HC / Geräusche / Midi / öffneMidi

öffneMidi

HC [image] Geräusche [image] Midi [image] öffneMidi
MidiGeräteInfo schließeMidi

öffneMidi öffneMidi outputDeviceNr

Dieser Kommando öffnet die Midi Geräte Zahlen-outputDeviceNr und Zugänge es durch einen Midi Gerätetreiber.

Der gewählte Gerätetreiber ist von mehreren Dingen abhängig.

Es lässt Sie jeden verfügbaren verfügbaren Midi Fahrer auf Ihrem System wählen.

Das id startet um 0 rauf zu 1 weniger als Anzahl von verfügbaren Midi Fahrern.

Zu bestimmen welches id zu vermisst welcher Treiber mehrere öffneMidi Befehle damit versuchen, id anzuwachsen.

öffneMidi wird den Namen des Treibers ausgeben, der benutzt wird.

See also:

  • schließeMidi

Examples:

  • starteMidiAusgabestrom
  • MidiAlleGeräuscheAus
  • wechsleMidiProgramm
  • MidiAusgabestrom
  • schließeMidi
  • MidiNoteAus
  • MidiNoteAn

References:

    schließeMidi(2), MidiAlleGeräuscheAus, MidiAusgabestrom, MidiMeldung, MidiNoteAn, MidiNoteAus, Release Notes für Version 4.686, starteMidiAusgabestrom, wechsleMidiProgramm

MidiGeräteInfo schließeMidi


HC / Geräusche / Midi / schließeMidi

schließeMidi

HC [image] Geräusche [image] Midi [image] schließeMidi
öffneMidi MidiMeldung

schließeMidi

Dieser Kommando schließt das Midi Gerät. Es gibt keine Eingaben-Oder Ausgaben.

Sehen Sie, dass auch das öffneMidi befiehlt.

Beispiel:

öffneMidi 0
MidiNoteAn 0 60 127
schließeMidi

Examples:

  • starteMidiAusgabestrom
  • MidiAlleGeräuscheAus
  • wechsleMidiProgramm
  • MidiAusgabestrom
  • MidiNoteAus
  • MidiNoteAn

References:

    MidiAlleGeräuscheAus, MidiAusgabestrom, MidiNoteAn, MidiNoteAus, Release Notes für Version 4.686, starteMidiAusgabestrom, wechsleMidiProgramm

öffneMidi MidiMeldung


HC / Geräusche / Midi / MidiMeldung

MidiMeldung

HC [image] Geräusche [image] Midi [image] MidiMeldung
schließeMidi wechsleMidiProgramm

MidiMeldung Nachricht

Die Eingabe muss eine Liste sein. Sie muss schon von herausgegeben ein öffneMidi Befehl, diesbefehl zu benutzen.

Reference:

    Release Notes für Version 4.686

schließeMidi wechsleMidiProgramm


HC / Geräusche / Midi / wechsleMidiProgramm

wechsleMidiProgramm

HC [image] Geräusche [image] Midi [image] wechsleMidiProgramm
MidiMeldung MidiNoteAn

wechsleMidiProgramm Kanalprogramm

Kommando, das Programm (das Timbre) des Midi Kanalkanals zu Programm zu verändern.

Kanal muss eine Ganzzahl in der Bereich sein 0..15.

Programm muss eine Ganzzahl in der Bereich sein 0..127.

Beispiel:

öffneMidi 0
wechsleMidiProgramm 0 127
MidiNoteAn 0 58 127
schließeMidi

Example:

  • MidiAlleGeräuscheAus

References:

    MidiAlleGeräuscheAus, Release Notes für Version 4.686

MidiMeldung MidiNoteAn


HC / Geräusche / Midi / MidiNoteAn

MidiNoteAn

HC [image] Geräusche [image] Midi [image] MidiNoteAn
wechsleMidiProgramm MidiNoteAus

MidiNoteAn Kanal Neigung Geschwindigkeit

Kommando, die Anmerkung mit Neigung des Kanals einzuschalten. Die Geschwindigkeit ist die Geschwindigkeit, mit der ein Taste ist, gedrücktes und vermisst direkt zum Volumen des Soundes.

Kanal muss eine Ganzzahl in der Bereich sein 0..15.

Neigung muss eine Zahl in der Bereich sein 0..127.

Geschwindigkeit muss eine Ganzzahl in der Bereich sein 0..127.

Beispiel:

öffneMidi 0
MidiNoteAn 0 58 127
schließeMidi

Examples:

  • MidiAlleGeräuscheAus
  • wechsleMidiProgramm
  • schließeMidi
  • MidiNoteAus

References:

    MidiAlleGeräuscheAus(3), MidiNoteAus, Release Notes für Version 4.686, schließeMidi, wechsleMidiProgramm

wechsleMidiProgramm MidiNoteAus


HC / Geräusche / Midi / MidiNoteAus

MidiNoteAus

HC [image] Geräusche [image] Midi [image] MidiNoteAus
MidiNoteAn MidiAlleGeräuscheAus

MidiNoteAus Kanal Neigung Geschwindigkeit

Kommando, die Anmerkung mit Neigung des Kanals auszuschalten. Die Geschwindigkeit ist die Geschwindigkeit, mit der ein Taste ausgelöst wird.

Kanal muss eine Ganzzahl in der Bereich sein 0..15.

Neigung muss eine Zahl in der Bereich sein 0..127.

Geschwindigkeit muss eine Ganzzahl in der Bereich sein 0..127.

Beispiel:

öffneMidi 0
MidiNoteAn 0 58 127
MidiNoteAus 0 58 127
schließeMidi

Reference:

    Release Notes für Version 4.686

MidiNoteAn MidiAlleGeräuscheAus


HC / Geräusche / Midi / MidiAlleGeräuscheAus

MidiAlleGeräuscheAus

HC [image] Geräusche [image] Midi [image] MidiAlleGeräuscheAus
MidiNoteAus MidiAusgabestrom

MidiAlleGeräuscheAus

Kommando, sich außerhalb aller laufenden Midi Sounds des ausgewählten Geräts zu drehen.

Beispiel:

öffneMidi 0
wechsleMidiProgramm 0 16
MidiNoteAn 0 58 127
MidiNoteAn 0 58+5 127
MidiNoteAn 0 58+9 127
MidiAlleGeräuscheAus
schließeMidi

Reference:

    Release Notes für Version 4.686

MidiNoteAus MidiAusgabestrom


HC / Geräusche / Midi / MidiAusgabestrom

MidiAusgabestrom

HC [image] Geräusche [image] Midi [image] MidiAusgabestrom
MidiAlleGeräuscheAus starteMidiAusgabestrom

MidiAusgabestrom MidiAusgabestrom Kanal Tonelist
(MidiAusgabestrom Kanal Pitchs Durations Geschwindigkeiten)

Kommando, ein neues parallelausführen in Gang zu setzen, das das Midi Töne in tonelist oder in den Listen pitchs spielen wird, Durations Und Geschwindigkeiten.

Die geschaffenen Gewinde müssen bei der Benutzung des Kommandos MidiOutStreamsStart aktiviert werden.

tonelist ist ein Liste von Tripeln von Zahlen: [pitch1 Dauer1 velocity1 pitch2 Dauer2 velocity2...]

Kanal muss eine Ganzzahl in der Bereich sein 0..15.

Neigung muss eine Zahl in der Bereich sein 0..127.

Geschwindigkeit muss eine Ganzzahl in der Bereich sein 0..127.

Dauer muss sein ein Zahlen-Und wird in Millisekunden gemessen.

Beispiel:

öffneMidi 0
MidiAusgabestrom 0 [60 1000 127  62 1000 127  64 1000 127  65 1000 127]
MidiAusgabestrom 1 [64 1000 127  65 1000 127  67 1000 127]
MidiAusgabestrom 2 [67 1000 127  69 1000 127]
starteMidiAusgabestrom
schließeMidi

Example:

  • starteMidiAusgabestrom

References:

    starteMidiAusgabestrom(3), Release Notes für Version 4.686, beendeteMidiAusgabeströme, stoppeMidiAusgabestrom

MidiAlleGeräuscheAus starteMidiAusgabestrom


HC / Geräusche / Midi / starteMidiAusgabestrom

starteMidiAusgabestrom

HC [image] Geräusche [image] Midi [image] starteMidiAusgabestrom
MidiAusgabestrom stoppeMidiAusgabestrom

starteMidiAusgabestrom

Kommando, die Wartgewinde zu aktivieren, die mit MidiOutStream geschaffen wurden.

Beispiel:

öffneMidi 0
MidiAusgabestrom 0 [60 1000 127  62 1000 127  64 1000 127  65 1000 127]
MidiAusgabestrom 1 [64 1000 127  65 1000 127  67 1000 127]
MidiAusgabestrom 2 [67 1000 127  69 1000 127]
starteMidiAusgabestrom
schließeMidi

Example:

  • MidiAusgabestrom

References:

    MidiAusgabestrom, Release Notes für Version 4.686

MidiAusgabestrom stoppeMidiAusgabestrom


HC / Geräusche / Midi / stoppeMidiAusgabestrom

stoppeMidiAusgabestrom

HC [image] Geräusche [image] Midi [image] stoppeMidiAusgabestrom
starteMidiAusgabestrom beendeteMidiAusgabeströme

stoppeMidiAusgabestrom

Kommando, die Gewinde zu stoppen, von vielleicht von MidiOutStreamsStart aktiviertem MidiAusgabestrom und geschaffen.

Reference:

    Release Notes für Version 4.686

starteMidiAusgabestrom beendeteMidiAusgabeströme


HC / Geräusche / Midi / beendeteMidiAusgabeströme

beendeteMidiAusgabeströme

HC [image] Geräusche [image] Midi [image] beendeteMidiAusgabeströme
stoppeMidiAusgabestrom Midi Tabelle

beendeteMidiAusgabeströme

Ausgaben die Anzahl von fertigen MidiAusgabestrom Gewinden. Dies ist nützlich für das Bestimmen des Endes eines Midi Soundes.

Reference:

    Release Notes für Version 4.686

stoppeMidiAusgabestrom Midi Tabelle


HC / Geräusche / Midi Tabelle

Midi Tabelle

HC [image] Geräusche [image] Midi Tabelle
beendeteMidiAusgabeströme Midi Kontroll-Tabelle

Midi Tabelle

Command Name	Command Code	Data Byte 1	Data Byte 2

Note Off		128 + Channel	0-127 Pitch		0-127 Velocity
Note On		144 + Channel	0-127 Pitch		0-127 Velocity
Poly Pressure	160 + Channel	0-127 Pitch		0-127 Pressure
Control Change	176 + Channel	0-127 Midi Control	0-127 MSB
Program Change	192 + Channel	0-127 Program	Not used
Channel Pressure	208 + Channel	0-127 Pressure	Not used
Pitch Wheel	224 + Channel	0-127 LSB		0-127 MSB
System Exclusive	240		0-127 Id Code	Any number of bytes
Undefined		241		Not used		Not used
Song Position	242		0-127 LSB		0-127 MSB
Song Select	243		0-127 Song		Not used
Undefined		244		Not used		Not used
Undefined		245		Not used		Not used
Tune Request	246		Not used		Not used
End of Exclusive	247		Not used		Not used
Timing Clock	248		Not used		Not used
Undefined		249		Not used		Not used
Start		250		Not used		Not used
Continue		251		Not used		Not used
Stop		252		Not used		Not used
Undefined		253		Not used		Not used
Active Sensing	254		Not used		Not used
System Reset	255		Not used		Not used

See also the Midi Glossary.


HC / Geräusche / Midi Kontroll-Tabelle

Midi Kontroll-Tabelle

HC [image] Geräusche [image] Midi Kontroll-Tabelle
Midi Tabelle Midi Glossary

Midi Kontroll-Tabelle

Command Name	Command Code	Data Byte 1	Data Byte 2

Control Change	176 + Channel	0 Undefined	0-127 MSB
Control Change	176 + Channel	1 Modulation Wheel	0-127 MSB
Control Change	176 + Channel	2 Breath Controller	0-127 MSB
Control Change	176 + Channel	3 After Touch	0-127 MSB
Control Change	176 + Channel	4 Foot Controller	0-127 MSB
Control Change	176 + Channel	5 Portamento Zeit	0-127 MSB
Control Change	176 + Channel	6 Data Entry	0-127 MSB
Control Change	176 + Channel	7 Main Volume	0-127 MSB
Control Change	176 + Channel	8-31 Undefined	0-127 MSB
Control Change	176 + Channel	32-63 LSB of 0-31	0-127 LSB
Control Change	176 + Channel	64 Damper Pedal	0:Off 127:On
Control Change	176 + Channel	65 Portamento	0:Off 127:On
Control Change	176 + Channel	66 Sostenuto	0:Off 127:On
Control Change	176 + Channel	67 Soft Pedal	0:Off 127:On
Control Change	176 + Channel	68-92 Undefined	0:Off 127:On
Control Change	176 + Channel	93 Chorus		0:Off 127:On
Control Change	176 + Channel	94 Celeste		0:Off 127:On
Control Change	176 + Channel	95 Phaser		0:Off 127:On
Control Change	176 + Channel	96 Data Entry + 1	0:Off 127:On
Control Change	176 + Channel	97 Data Entry - 1	0:Off 127:On
Control Change	176 + Channel	98-121 Undefined	0:Off 127:On
Control Change	176 + Channel	122 Local Control	0-127
Control Change	176 + Channel	123 All Notes Off	0
Control Change	176 + Channel	124 Omni Mode off	0-15
Control Change	176 + Channel	125 Omni Mode on	0
Control Change	176 + Channel	126 Mono on/Poly off	0
Control Change	176 + Channel	127 Poly on/Mono off	0

See also the Midi Glossary.


HC / Geräusche / Midi Glossary

Midi Glossary

HC [image] Geräusche [image] Midi Glossary
Midi Kontroll-Tabelle Midi Instruments

Midi Glossary

Kanal: Ein Kanal ist eine Zahl von 0-15, das Kanälen 1-16 entspricht.

Neigung: Ein Neigung ist eine Zahl von 0-127 entspricht und zu einer Anmerkung auf dem Instrument.

Geschwindigkeit: Eine Geschwindigkeit ist eine Zahl von 0-127 entspricht und dazu, wie fast der Taste (Oder Schnur) in Not ist, ausgelöstes oder (die meisten Terminologie ist in Bezug auf Tastaturen). 0 Mittel wird freigegeben.

Druck: Ein Druck ist eine Zahl von 0-127 und entspricht zu den Merkmalen davon, wie der Taste getroffen wird.

Programm: Ein Programm ist eine Zahl von 0-127 entspricht und zum zu benutzenden Instrument. Sehen Sie den Midi INSTRUMENTE-Tisch.

MSB:Die Meisten Bedeutenden Bits.

LSB:Niedrigstwertige Bits.

Id Code: Fertigungen Id Code. Benutzt um einzudringen System-Ausschließlich-Modus, der spezifisch zum Hersteller des Geräts ist.

Lied: Ein Lied ist eine Rhythmusmaschine.

See also:

  • Midi Kontroll-Tabelle
  • Midi Tabelle

References:

    Midi Kontroll-Tabelle, Midi Tabelle

Midi Kontroll-Tabelle Midi Instruments


HC / Geräusche / Midi Instruments

Midi Instruments

HC [image] Geräusche [image] Midi Instruments
Midi Glossary Klaviere

Midi Instruments

Midi Instruments

  • Klaviere
  • Chromatisches
  • Organe
  • Gitarren
  • Bässe
  • Linien
  • Ensembles
  • Messing
  • Schilf
  • Pfeifen
  • Synth-Lead
  • Synth-Pad
  • Synth-Effects
  • Ethnisch
  • Schlag
  • Soundeffects


HC / Geräusche / Midi Instruments / Klaviere

Klaviere

HC [image] Geräusche [image] Midi Instruments [image] Klaviere
Midi Instruments Chromatisches

Klaviere

0 -	Acoustic Grand Piano
1 -	Bright Acoustic Piano
2 -	Electric Grand Piano
3 -	Honky-tonk Piano
4 -	Rhodes Piano
5 -	Chorused Piano
6 -	Harpsichord
7 -	Clavinet


HC / Geräusche / Midi Instruments / Chromatisches

Chromatisches

HC [image] Geräusche [image] Midi Instruments [image] Chromatisches
Klaviere Organe

Chromatisches Schlagzeug

8 -	Celesta
9 -	Glockenspiel
10 -	Music box
11 -	Vibraphone
12 -	Marimba
13 -	Xylophone
14 -	Tubular Bells
15 -	Dulcimer


HC / Geräusche / Midi Instruments / Organe

Organe

HC [image] Geräusche [image] Midi Instruments [image] Organe
Chromatisches Gitarren

Organe

16 -	Hammond Organ
17 -	Percussive Organ
18 -	Rock Organ
19 -	Church Organ
20 -	Reed Organ
21 -	Accordian
22 -	Harmonica
23 -	Tango Accordian


HC / Geräusche / Midi Instruments / Gitarren

Gitarren

HC [image] Geräusche [image] Midi Instruments [image] Gitarren
Organe Bässe

Gitarren

24 -	Acoustic Guitar (nylon)
25 -	Acoustic Guitar (steel)
26 -	Electric Guitar (jazz)
27 -	Electric Guitar (löscheBild)
28 -	Electric Guitar (muted)
29 -	Overdriven Guitar
30 -	Distortion Guitar
31 -	Guitar Harmonics


HC / Geräusche / Midi Instruments / Bässe

Bässe

HC [image] Geräusche [image] Midi Instruments [image] Bässe
Gitarren Linien

Bässe

32 -	Acoustic Bass
33 -	Electric Bass (finger)
34 -	Electric Bass (wähleZufällig)
35 -	Fretless Bass
36 -	Slap Bass 1
37 -	Slap Bass 2
38 -	Synth Bass 1
39 -	Synth Bass 2


HC / Geräusche / Midi Instruments / Linien

Linien

HC [image] Geräusche [image] Midi Instruments [image] Linien
Bässe Ensembles

Linien

40 -	Violin
41 -	Viola
42 -	Cello
43 -	Contrabass
44 -	Tremolo Strings
45 -	Pizzicato Strings
46 -	Orchestral Harp
47 -	Timpani

References:

    Listenboxen(2), Schreibstift- und Hintergrund-Kontolle(2), ZylinderlinienAus(2), fülle(2), Linie, LinienglättungAn, LinienglättungAus, ZylinderlinienAn, größerGleichP, größerP, kleinerGleichP, kleinerP, rundeLinienendenAn, vorwärts, zurück

Bässe Ensembles


HC / Geräusche / Midi Instruments / Ensembles

Ensembles

HC [image] Geräusche [image] Midi Instruments [image] Ensembles
Linien Messing

Ensembles

48 -	String Ensemble 1
49 -	String Ensemble 2
50 -	Synth Strings 1
51 -	Synth Strings 2
52 -	Choir Aahs
53 -	Voice Oohs
54 -	Synth Voice
55 -	Orchestra Hit


HC / Geräusche / Midi Instruments / Messing

Messing

HC [image] Geräusche [image] Midi Instruments [image] Messing
Ensembles Schilf

Messing

56 -	Trumpet
57 -	Trombone
58 -	Tuba
59 -	Muted Trumpet
60 -	French Horn
61 -	Brass Section
62 -	Synth Brass 1
63 -	Synth Brass 2


HC / Geräusche / Midi Instruments / Schilf

Schilf

HC [image] Geräusche [image] Midi Instruments [image] Schilf
Messing Pfeifen

Schilf

64 -	Soprano Sax
65 -	Alto Sax
66 -	Tenor Sax
67 -	Baritone Sax
68 -	Oboe
69 -	English Horn
70 -	Bassoon
71 -	Clarinet


HC / Geräusche / Midi Instruments / Pfeifen

Pfeifen

HC [image] Geräusche [image] Midi Instruments [image] Pfeifen
Schilf Synth-Lead

Pfeifen

72 -	Piccolo
73 -	Flute
74 -	Recorder
75 -	Pan Flute
76 -	Bottle Blow
77 -	Shakuhachi
78 -	Whistle
79 -	Ocarina


HC / Geräusche / Midi Instruments / Synth-Lead

Synth-Lead

HC [image] Geräusche [image] Midi Instruments [image] Synth-Lead
Pfeifen Synth-Pad

Synth-Lead

80 -	Lead 1 (square)
81 -	Lead 2 (sawtooth)
82 -	Lead 3 (caliope lead)
83 -	Lead 4 (chiff lead)
84 -	Lead 5 (charang)
85 -	Lead 6 (voice)
86 -	Lead 7 (fifths)
87 -	Lead 8 (brass + lead)


HC / Geräusche / Midi Instruments / Synth-Pad

Synth-Pad

HC [image] Geräusche [image] Midi Instruments [image] Synth-Pad
Synth-Lead Synth-Effects

Synth-Pad

88 -	Pad 1 (new age)
89 -	Pad 2 (warm)
90 -	Pad 3 (polysynth)
91 -	Pad 4 (choir)
92 -	Pad 5 (bowed)
93 -	Pad 6 (metallic)
94 -	Pad 7 (halo)
95 -	Pad 8 (sweep)


HC / Geräusche / Midi Instruments / Synth-Effects

Synth-Effects

HC [image] Geräusche [image] Midi Instruments [image] Synth-Effects
Synth-Pad Ethnisch

Synth-Effects

96 -	FX 1 (rain)
97 -	FX 2 (soundtrack)
98 -	FX 3 (crystal)
99 -	FX 4 (atmosphere)
100 - FX 5 (brightness)
101 - FX 6 (goblins)
102 - FX 7 (echoes)
103 - FX 8 (sci-fi)


HC / Geräusche / Midi Instruments / Ethnisch

Ethnisch

HC [image] Geräusche [image] Midi Instruments [image] Ethnisch
Synth-Effects Schlag

Ethnisch

104 - Sitar
105 - Banjo
106 - Shamisen
107 - Koto
108 - Kalimba
109 - Bagpipe
110 - Fiddle
111 - Shanai


HC / Geräusche / Midi Instruments / Schlag

Schlag

HC [image] Geräusche [image] Midi Instruments [image] Schlag
Ethnisch Soundeffects

Schlag

112 - Tinkle Bell
113 - Agogo
114 - Steel Drums
115 - Woodblock
116 - Taiko Drum
117 - Melodic Tom
118 - Synth Drum
119 - Reverse Cymbal


HC / Geräusche / Midi Instruments / Soundeffects

Soundeffects

HC [image] Geräusche [image] Midi Instruments [image] Soundeffects
Schlag

Soundeffects

120 - Guitar Fret Noise
121 - Breath Noise
122 - Seashore
123 - Bird Tweet
124 - Telephone Ring
125 - Helicopter
126 - Applause
127 -Schuss

Schlag